Anda di halaman 1dari 38

Simulacin con el Software Arena

Resumen de los captulos 1 al 4


Documento que resume la informacin contenida en los captulos 1 al 4 del libro Simulacin con Software Arena (4ta edicin) de Kelton, Sadowski y Sturrock Ing. Claudio Gmez 6/26/2012

Simulacin con el Software Arena

NDICE Pg. Introduccin 1. QU ES LA SIMULACIN? 1.1. Tipos de modelos 1.1.1. Modelos fsicos 1.1.2. Modelos lgicos o matemticos 1.2. Anlisis de la simulacin por computadora 1.2.1. Ventajas 1.2.2. Desventajas 1.3. Tipos de simulaciones 1.3.1. Esttico contra dinmico 1.3.2. Continuo contra discreto 1.3.3. Determinista contra estocstico 2. CONCEPTOS PRINCIPALES DE LA SIMULACIN 2.1. 2.2. Medidas de desempeo Opciones de anlisis de resultados 4 5 5 5 5 5 5 5 5 6 6 6 7 8 8 9 9 9 9 9 9 9 10 10 10 10 10 10

2.2.1. Conjetura educada 2.2.2. Teora de colas 2.2.3. Simulacin mecnica 2.3. Piezas de un modelo de simulacin 2.3.1. Entidades 2.3.2. Atributos 2.3.3. Variables 2.3.4. Recursos 2.3.5. Colas 2.3.6. Acumuladores estadsticos 2.3.7. Eventos 2.3.8. Reloj de simulacin 2.3.9. Empezar y parar 2.4. Visin general de un estudio de simulacin

3. RECORRIDO A TRAVS DE ARENA 3.1. 3.2. 3.3. 3.4. 3.5. 3.6. Qu es Arena? Cmo instalar Arena en su computadora? Exploracin de la ventana de Arena Vista del diagrama de flujo Mdulos Crear un modelo

11 11 12 14 15 16 16 25 36

4. MODELACIN DE OPERACIONES Y ENTRADAS BSICAS Bibliografa

Introduccin
El presente documento es un resumen de los captulos del 1 al 4 del libro de Simulacin con Software Arena de los autores Kelton, D., Sadowski, R. y Sturrock, D. Adicional a la informacin del libro, el autor del resumen agrega ciertas impresiones de pantalla, pasos adicionales y modificaciones a los ejercicios, con la finalidad de facilitar el aprendizaje para el lector. El objetivo de este documento es el de ensear los conceptos bsicos de simulacin y entrenar al lector como analista de simulacin para que ste sea capaz de desarrollar sus propios modelos cuando lo requiera.

4 1. QU ES LA SIMULACIN? Esta seccin tiene como finalidad darle al lector una nocin general acerca de la simulacin, dnde encaja y las cosas que puede hacer. Se refiere a un gran conjunto de mtodos y aplicaciones que buscan imitar el comportamiento de sistemas reales, generalmente en una computadora con un software apropiado. Simular consiste en utilizar herramientas que permitan reproducir un sistema real. El objetivo es que la simulacin sea lo ms parecido al sistema real, en relacin a: Elementos incluidos. Nivel de detalle. Restricciones. Elementos de entrada y salida del modelo.

Algunos de los sistemas reales que pueden ser simulados son los siguientes: Planta de manufactura con maquinas, personas, mtodos de trasporte, bandas transportadoras y espacio de almacenamiento. Un banco con diferentes tipos de clientes, servidores e instalaciones (ventanillas de cajeros, cajeros automticos, entre otros) Un aeropuerto con pasajeros que facturan, pasan por seguridad y luego a la puerta de embarque; vuelos de salida que requieren de remolcadores de empuje y de retorno; asignacin de pistas de aterrizaje y despegue. Las instalaciones de urgencias de un hospital (personal, habitaciones, equipos, suministros y transporte de pacientes). Un sistema de autopistas de segmentos de carreteras, cruces, controles y trfico. Un restaurante de comida rpida. Un supermercado con control de inventarios, cajas y servicio al cliente. Un parque de atracciones.

Las personas a menudo estudian un sistema para medir su desempeo o mejorar su operacin, o disearlo si es que no existe. A los gerentes o controladores de un sistema tambin les gustara tener ayuda disponible para las operaciones cotidianas, como decidir qu hacer en una fbrica si una mquina importante se avera. Tambin existen gerentes que solicitan la construccin de simulaciones, aunque en realidad no les importan los resultados finales; su objetivo principal fue enfocarse en entender cmo funcionaba su sistema. Es importante mencionar que en algunos casos es posible experimentar con el sistema fsico actual, esta situacin tiene la ventaja de que se estar analizando lo correcto y Realizado por: Ing. Claudio Gmez

5 no habr que preocuparse por una aproximacin realizada por un modelo de simulacin a computadora. Sin embargo, a veces no se puede (o no se debe) experimentar con el sistema (bien sea por razones de costos, manejo de personal, entre otras); es en estos casos que se debe construir un modelo que permita estudiar las variaciones que se aplicaran al sistema.

1.1.

Tipos de modelos

1.1.1. Modelos fsicos: Tambin llamados modelos icnicos, se refieren a rplicas a escala del sistema. Un ejemplo comn son las rplicas o versiones miniaturas de algunas instalaciones o procesos (trenes elctricos). 1.1.2. Modelos lgicos o matemticos: Estos se refieren al conjunto de aproximaciones y suposiciones acerca de la forma en la que funciona o funcionar el sistema estudiado. Estos modelos realizados en computadora son, por lo general, ms fciles, baratos y rpidos al momento de obtener respuestas en comparacin a los fsicos.

1.2.

Anlisis de la simulacin por computadora

1.2.1. Ventajas Capacidad para tratar con modelos muy complicados de sistemas. Altamente rentable (elevada proporcin de desempeo/precio del hardware). Herramienta flexible y de fcil uso. 1.2.2. Desventajas Cuando la simulacin se ve afectada por entradas aleatorias e incontrolables, los resultados o salidas sern aleatorios. Ejecutar una simulacin estocstica una vez es como realizar un experimento al azar una vez (se requiere de un tiempo para lograr una estabilizacin).

1.3.

Tipos de simulaciones

1.3.1. Esttico contra dinmico: Los estticos son aquellos donde el tiempo no desempea un papel natural en los modelos (lanzar una moneda, el problema de la aguja de Buffon). En el caso de los dinmicos, si se desempea un papel natural (procesos de manufactura). Realizado por: Ing. Claudio Gmez

6 1.3.2. Continuo contra discreto: Los modelos discretos son aquellos que presentan variaciones en momentos especficos del tiempo, mientras que los continuos, los sufren continuamente en el tiempo. Es importante sealar que tambin existen modelos combinados (continuo-discreto). 1.3.3. Determinista contra estocstico: Los primeros son aquellos cuyas variables de entrada no son aleatorias; a diferencia de los estocsticos, los cuales operan con al menos una entrada aleatoria.

2. CONCEPTOS PRINCIPALES DE SIMULACIN Esta seccin permitir entender la lgica, la estructura, los componentes y la administracin fundamentales de un proyecto de modelacin de simulacin. A continuacin se describir un ejemplo de un sistema y de la informacin requerida para entender su comportamiento y ejecucin. El ejemplo consiste en un centro de perforacin, al cual llegan piezas azules a una mquina perforadora, son trabajadas, y luego salen del sistema (ver fig. 1). Es importante sealar que, cuando la perforadora se encuentra ocupada, las piezas debern esperar en una cola hasta ser procesadas.

Cola

Perforadora

Fig. 1: Sistema de procesamiento sencillo Fuente: Kelton y otros, 2008

Tambin deben ser especificados algunos aspectos numricos, por ejemplo cmo ser el comienzo y fin de la simulacin y las unidades base con las que se medir el tiempo. El primer aspecto se refiere a cmo ser el inicio de la simulacin, ella se orienta a suposiciones en relacin a cantidad partes en el sistema, equipos inactivos, entre otras (es importante establecer esta suposicin en funcin al proceso que se estudia). Con respecto a la finalizacin, se refiere al tiempo exacto en el cual se detendr la simulacin, y si este depender de factores como por ejemplo: elementos en el sistema.

Realizado por: Ing. Claudio Gmez

7 En relacin a las unidades base, se sugiere elegir las mas apropiadas, familiar y convenientes. Por ejemplo, si un proceso lleva segundos en realizarse, no seria conveniente elegir como unidad base das. Para el ejemplo del sistema de procesamiento sencillo con la perforadora, el proceso inicia a los 0 minutos, sin elementos en el sistema, y finaliza en un tiempo de 20 minutos, por tanto, la unidad base elegida fue de minutos. Los tiempos de llegadas, entre llegadas y de servicio (en minutos), se encuentran en la tabla 1.

Tabla 1. Tiempos de llegadas, entre llegadas y de servicios de las partes (en minutos) Fuente: Kelton y otros (2008)

Numero de parte 1 2 3 4 5 6 7 8 9 10 11 . .

Tiempo de llegada 0.00 1.73 3.08 3.79 4.41 18.69 19.39 34.91 38.06 39.82 40.82 . .

Tiempo entre llegadas 1.73 1.35 0.71 0.62 14.28 0.70 15.52 3.15 1.76 1.00 . . .

Tiempo de servicio 2.90 1.76 3.39 4.52 4.46 4.36 2.07 3.36 2.37 5.38 . . .

Al clasificar este modelo dentro de los tipos mencionados, este sera un modelo lgico o matemtico, dinmico, continuo y estocstico (con la suposicin de que los tiempos entre llegadas son valores aleatorios). 2.1. Medidas de desempeo

Uno de los pasos de mayor importancia, es la eleccin de las medidas de desempeo que se desea recopilar una vez ejecutada la simulacin; por lo general, estas son: La produccin total: Se refiere a la cantidad de elementos que salen del sistema. En el caso del ejemplo del sistema de procesamiento sencillo, son la cantidad de partes que completan su servicio en la perforadora. El tiempo promedio de espera en la cola: Es el registro de tiempo que va desde que un elemento inicia la espera para ser atendido en un

Realizado por: Ing. Claudio Gmez

8 mdulo, hasta que se inicie dicha atencin. Manualmente se calcula con la siguiente frmula: Donde: WQi = Tiempo de espera en la cola para pieza i-sima N = Cantidad de elementos procesados El tiempo de espera mximo en una cola: Es la medida del peor de los casos, este valor brinda garantas de servicio a los clientes. El promedio del tiempo que las partes esperan en cola: Se refiere al promedio ponderado de las longitudes posibles de la cola ponderadas por la proporcin de tiempo durante la ejecucin que la cola tena en esa longitud. Este parmetro sirve de inters al momento de estimar espacio para elementos en espera. El numero mximo de partes que estuvieron esperando en la cola: Otra medida del peor de los casos; tambin sirve de inters al momento de estimar espacio para elementos en espera. El tiempo total promedio y mximo en el sistema: Tambin llamado tiempo del ciclo; es el registro del tiempo desde que entra una entidad al sistema, hasta su partido, englobando tiempos en cola y en proceso. El uso de los recursos: Se define como la proporcin de tempo en que esta ocupado un elemento durante la simulacin.

2.2.

Opciones de anlisis de resultados

2.2.1. Conjetura educada: Esta opcin consiste en realizar operaciones aritmticas sencillas que en ocasiones pueden llevar a al menos una perspectiva cualitativa del problema (en ocasiones no). Es importante sealar que esto depende tanto de la situacin y de las habilidades para realizar las suposiciones. Con respecto al ejemplo y la informacin que se provee (tabla 1), una conjetura es estimar el promedio del tiempo entre llegadas (4,34 minutos) y del tiempo de servicio (3,46 minutos). Los valores resultantes indican que el tiempo de servicio es menor que el correspondiente a las llegadas (resultado alentador). Sin embargo, observando de manera detallada la tabla, nos damos cuenta de que la mayora de los tiempos entre llegadas son menores que los de servicio, lo cual indica que la conclusin llegada mediante la conjetura es incorrecto. Queda claro que conjeturar tiene sus lmites.

Realizado por: Ing. Claudio Gmez

9 2.2.2. Teora de colas: Se refiere a la utilizacin de las formulas de teora de colas para generar una idea de donde estn las colas y brindar valores estimados de tiempos de espera. Con respecto a este mtodo de anlisis se debe sealar que para la obtencin de resultados de alta confiabilidad, requiere de conocimientos amplios en esa rea y en estadstica. 2.2.3. Simulacin mecnica: Por mecnica se entiende que las operaciones individuales ocurrirn como lo haran en la realidad. La simulacin proporciona una forma concreta de tratar directamente con el modelo (el sistema). 2.3. Piezas de un modelo de simulacin

2.3.1. Entidades: Son objetos dinmicos que, por lo general, son creados, se mueven alrededor del sistema durante un tiempo y finalmente son desechados (es importante mencionar que no todas las entidades son desechadas, algunas se mantienen circulando en el proceso). La mayora de las entidades representan cosas reales en una simulacin, es por ello que en un sistema pueden existir varios tipos de entidades (por ejemplo: variedad de piezas), que tengan diferentes procesamientos, rutas y prioridades. 2.3.2. Atributos: Para individualizar las entidades, se requiere la asignacin de atributos. Estos son caractersticas comunes de todas las entidades, pero que poseen valores especficos que permiten diferenciarlas entre ellas. Por ejemplo, si se tienen dos piezas (entidades) y el atributo color asignado, se podrn diferenciar las piezas al establecer que una es azul y la otra verde. Lo ms importante con respecto a los atributos es que estos se encuentran unidos a entidades especficos. 2.3.3. Variables: Informacin que refleja alguna caracterstica del sistema (no se ve afectada por la cantidad o tipo de entidades). Existen dos tipos de variables: las incorporadas en Arena (numero en la cola, numero de servidores ocupadas, tiempo en el reloj de la simulacin actual, entre otros) y las definidas por el usuario (Tiempo de servicio, tiempo de traslado, turno actual, entre otros). Las variables pueden ser usadas para muchos propsitos y tambin pueden ser vectores o matrices. 2.3.4. Recursos: Con frecuencia las entidades compiten entre ellas por el servicio de los recursos que representan cosas, como personal, equipo o espacio en el rea de almacenaje de tamao limitado. Una entidad se aprovecha de

Realizado por: Ing. Claudio Gmez

10 una cantidad de unidades de un recurso cuando esta disponible y lo liberar una vez que finalice. 2.3.5. Colas: Cuando una entidad no puede seguir adelante (quiz porque requiere de un recurso inmovilizado por otra entidad), se requiere de un lugar para esperar, esto se define como cola. En Arena, las colas tienen nombres y pueden tener tambin capacidades de representacin. 2.3.6. Acumuladores estadsticos: Son las variables que permiten obtener las mediciones de desempeo de resultados. Se puede obtener una vez finalizada la simulacin o conforme progresa la misma. 2.3.7. Eventos: Se define como algo que sucede en un instante de tiempo que tiene el poder de cambiar atributos, variables o acumuladores estadsticos. En Arena, el registro y almacenamiento de eventos se realiza en el calendario de eventos, el cual permite establecer instantes en el que ocurrirn cambios en el modelo. 2.3.8. Reloj de simulacin: Se refiere a la variable que almacena el valor actual del tiempo en la simulacin. Este permite detectar cundo se aproxima la ocurrencia de algn evento o la finalizacin de la simulacin. 2.3.9. Empezar y parar: Esto se dirige a que el analista debe determinar las condiciones de inicio apropiadas, cuanto debe durar una ejecucin y si se debe detener en un tiempo determinado o cuando ocurra algn evento. Es importante pensar en esto y hacer suposiciones consistentes con lo que se est modelando; las decisiones pueden tener un gran efecto en los resultados.

2.4.

Visin general de un estudio de simulacin

Si bien es cierto ningn estudio de simulacin sigue una frmula prestablecida al momento de decidir como modelar un sistema, los autores sugieren que se consideren los siguientes aspectos: Entender el sistema: El analista debe tener un sentimiento intuitivo y realista de lo que sucede; en caso de no tenerlo, debe realizar visitas al lugar y entrevistas a las personas que lo trabajen diariamente. Ser claro en los objetivos: Hay que entender lo que se puede aprender del estudio y no esperar ms. Es esencial especificar acerca de lo que se observa,

Realizado por: Ing. Claudio Gmez

11 manipula, cambia y, finalmente, entrega. La atencin debe mantenerse enfocada en lo que es importante y en los objetivos planteados. Formular la representacin del modelo: Se refiere a la cantidad de detalles requeridos, de la necesidad de modelar algunas partes del sistema de forma cuidadosa y otras de manera primitiva. En este aspecto es importante convencer a la administracin y a los encargados de tomar decisiones para las suposiciones del modelado. Traducir a un software de modelacin: Una vez que las suposiciones del modelo se acepten, hay que representarlas fielmente en el software de simulacin. Lo clave de este aspecto es plasmarlas de forma abierta y honesta, as como involucrar a los que conocen el proceso. Verificar que la representacin en la computadora caracterice fielmente el modelo conceptual: Consiste en verificar que el modelo siga la lgica establecida en la etapa conceptual. Validar el modelo: Referido a ver si las distribuciones de entrada corresponden con lo que se observ en el campo; si las mediciones del desempeo resultantes corresponden a las de la realidad. En esta etapa se valora mucho una buena dosis de sentido comn. Disear los experimentos: Se debe planear qu se desea saber y cmo los experimentos de simulacin lo conducirn a obtener las respuestas de una manera precisa y eficaz. Ejecutar los experimentos: Consiste en iniciar las simulaciones, esta fase es muy sencilla, pero depende de qu tan bien se disearon los experimentos y de la validacin del modelo. Analizar los resultados: Llevar a cabo las formas correctas de anlisis estadsticos para ser capaz de hacer declaraciones acertadas y precisas. Tener entendimiento: Esto es mas fcil decirlo que hacerlo. Qu significan los resultados? Todos tienen sentidos? Cules son las consecuencias? Se esta observando el conjunto adecuado de mediciones de desempeo? Documentar lo que se hace: La documentacin tambin es esencial para convencer a la administracin e implementar las recomendaciones en las que trabaj tan duro para ser capaz de lograrlas con precisin y confianza.

3. Recorrido a travs de Arena 3.1. Qu es Arena?

Arena es una aplicacin (creada por Rockwell Software) del sistema operativo Windows de Microsoft (totalmente compatible con otros software de Windows) que permite la realizacin de modelos de simulacin con un elevado nivel de detalle, tanto conceptualmente como con el uso de animaciones.

Realizado por: Ing. Claudio Gmez

12 3.2. Cmo instalar Arena en su computadora?

En caso de poseer Windows XP o versiones anteriores de sistema operativo en su computadora, la instalacin solamente consiste en insertar el CD y seleccionar la opcin Install Arena 10.00.00 (CPR 7). Sin embargo, si su versin de Windows es Vista o 7, los pasos son los siguientes: 1. Insertar el CD 2. Clic derecho en el icono del CD y seleccionar la opcin Explorar (Open).

3. Una vez dentro de los archivos del CD, se debe presionar clic derecho en el archivo de aplicacin Setup, y luego seleccionar propiedades.

Realizado por: Ing. Claudio Gmez

13 4. Al seleccionar propiedades del archivo Setup, se debi abrir una ventana con dicho nombre, la cual posee 3 pestaas; a continuacin se debe seleccionar la segunda pestaa (Compatibilidad).

5. En la pestaa Compatibilidad de la ventana Propiedades de Setup, se debe ir al Modo de compatibilidad y activar la opcin Ejecutar este programa en modo de compatibilidad para:, una vez activada, se puede seleccionar una lista ubicada inmediatamente debajo de la opcin activada, en ella se debe elegir Windows XP (Service Pack 2).

Realizado por: Ing. Claudio Gmez

14 6. Una vez seleccionado esto, presionar Aceptar, y luego doble clic en el archivo de aplicacin Setup (el que acaba de ser modificado). 7. Finalmente se deben de seguir las instrucciones del instalador para completar el proceso de manera correcta (para informacin mas detallada, ver el apndice E del libro)

3.3.

Exploracin de la ventana de Arena

A continuacin se aprecia la ventana principal de Arena y sus elementos.


Vista del diagrama de flujo de la ventana del modelo

Barra de herramientas

Barra de proyectos

Barra de estado

Vista de la hoja de clculo de la ventana del modelo

A la derecha, ocupando la mayor parte de la pantalla, se halla la ventana del modelo, que de hecho est dentro de la ventana de Arena. En caso de tener varios modelos abiertos al mismo tiempo, se tendr una ventana para cada uno (para circular rpidamente entre ellos, use Ctrl + Tab). Las operaciones familiares de cortar, copiar y pegar funcionan en Arena igual que otras aplicaciones comunes de Windows. Es importante mencionar que desde Excel se pueden copiar directamente celdas e insertarlas en el campo deseado de la vista de la hoja de clculo.

Realizado por: Ing. Claudio Gmez

15 La ventana del modelo, se divide en dos regiones o vistas: vista del diagrama de flujo y vista de la hoja de clculo. La primera vista, siempre permanece activa, y ella contiene las grficas del modelo, incluyendo el diagrama de flujo del proceso, animacin y otros elementos de dibujo; la segunda, se puede activar o desactivar al hacer clic en el icono que se ubica en la barra de herramientas estndar, y ella despliega datos del modelo, tales como tiempos y otros parmetros, permitiendo introducirlos o editarlos, ella brinda acceso a muchos parmetros a la vez, los cual resulta muy conveniente. La barra de proyectos contiene los paneles con los objetos con los que se trabajar, estos paneles son: proceso bsico, el cual contiene los mdulos que se usaran para representar el proceso; los reportes; que despliegan un panel que contiene un mapa para orientarse hacia los resultados de una simulacin despus de que se ejecuto; y, la navegacin, que permite desplegar diferentes vistas de un modelo. Para finalizar con la barra de proyectos, se hablara de las plantillas. Dependiendo de la complejidad del modelo o de o que se desee simular, Arena provee al usuario con una variedad de plantillas; para adjuntar una plantilla, se debe hacer clic derecho dentro del panel de proceso bsico, seleccionar la opcin Template Panel y luego Attach (de la misma manera, se puede realizar a travs de la barra de herramientas, en el men de File, y luego la opcin Template Panel). Cabe destacar que las plantillas se encuentran en la carpeta Template, dentro de la carpeta de Arena 10.0. Si se desea que Arena adjunte ciertas plantillas cada vez que se cree un nuevo modelo, se presionar Tools > Options > Settings y escribir los nombres de los archivos dentro del cuadro Auto Attach Panels (en la parte inferior de la ventana Options).

3.4.

Vista del diagrama de flujo

La forma ms prctica de movilizarse a travs del ambiente grafico de Arena, es con el uso del mouse, el movimiento hacia delante de la rueda permite acercar, mientras que hacia atrs, aleja. Si usted desea tener vistas especficas del modelo, Arena provee una herramienta llamada Named View (Vista con nombre), la cual permite acceder a vistas con el uso de comandos. Para agregar una Named View, se debe presionar View > Named Views > Add y se agregara la vista actual del modelo (para nombrar las vistas, Arena es capaz de distinguir entre maysculas y minsculas). Estas vistas pueden ser accedidas en cualquier momento, incluso mientras se esta ejecutando la simulacin. Otra herramienta til, es la cuadrcula (Grid), la cual aplica una rejilla de fondo de pequeos puntos que facilita mantener un arreglo entre los mdulos del proceso. Para

Realizado por: Ing. Claudio Gmez

16 editarla se debe presionar View > Grid & Snap Settings, aqu se personaliza el espaciado de los puntos que componen la rejilla.

3.5.

Mdulos

Los elementos bsicos para los modelos de Arena se llaman mdulos. Estos son el diagrama de flujo y los objetos de datos que definen el proceso que se va a simular y se eligen de las plantillas de la barra de proyectos. Vienen en dos formas bsicas: diagrama de flujo y datos. Los mdulos de diagrama de flujo describen procesos dinmicos del modelo. Se pueden interpretar como nodos o lugares a travs de los cuales fluyen las entidades o en donde se originan o dejan el modelo. Para el panel de proceso bsico, los mdulos de diagrama de flujo disponibles son Create, Dispose, Process, Decide, Batch, Separate, Assign y Record. Los mdulos de datos definen caractersticas de varios elementos del proceso, como entidades, recursos y colas. Tambin pueden configurar variables y otros tipos de valores y expresiones numricos que pertenecen al modelo en su conjunto. Los iconos para los mdulos de datos en la barra de proyecto parecen pequeas hojas de clculo. Para el panel de proceso bsico, los mdulos de datos disponibles son Entity, Queue, Resource, Variable, Schedule y Set.

3.6.

Crear un modelo

Lo primero que se requiere, es describir el proceso, la descripcin es la siguiente: Cada 5 minutos llega una pieza al sistema (el tiempo entre llegada esta regido por una distribucin exponencial), luego, pasa al centro de perforacin, donde, usando el recurso Perforadora y, siguiendo una distribucin triangular, se procesa con los parmetros: mnimo = 1; valor = 3; mximo = 6; Finalmente, la pieza sale del sistema. El segundo paso, es determinar la cantidad y tipo de mdulo a utilizar. Con la informacin del prrafo anterior, se aprecia la necesidad de 3 mdulos: 1 de Create (llegada de piezas al sistema), 1 de Process (centro de perforacin) y 1 de Dispose (salida de piezas). Una vez aclarado esto, se procede a crearlos en Arena; para hacerlo, se deben arrastrar de la barra de proyectos, y de la plantilla proceso bsico, cada uno de los mdulos requeridos (uno a la vez).

Realizado por: Ing. Claudio Gmez

17 Si usted sigui los pasos correctamente, la pantalla se deber ver como la imagen mostrada a continuacin.

Es importante sealar que, al seguir este procedimiento, se generaron las conexiones de manera automtica, esto es debido a que se tiene la opcin de Auto-Connect activada (para acceder a ella se debe presionar Object > Auto-Connect). Cabe destacar que para realizar las conexiones automticas, se debe tener seleccionado el mdulo que ser origen de la conexin y luego insertar el mdulo destino desde la plantilla de procesos bsicos. La forma manual de crear conexiones es presionando el icono ubicado en la barra de herramientas estndar, luego hacer clic en el mdulo origen y luego en el mdulo destino. El siguiente paso es introducir los datos dentro de cada mdulo; hay 3 formas de hacerlo, la primera es presionando dos veces clic izquierdo en el mdulo que se desea modificar, la segunda es presionando clic derecho y luego elegir la opcin Edit via Dialog, y la tercera es ingresar la informacin directamente en la vista de la hoja de clculo de la ventana del modelo. La manera ms cmoda (para el escritor de este resumen), es la primera o la segunda, ya que permite ver ms claramente qu variables insertar por mdulo, as como facilita la focalizacin de la atencin en el proceso de ingresar los datos. Una vez abierto el cuadro de dilogo del mdulo Create, se procede a introducir los siguientes datos: Name (nombre): Llegada de partes al sistema Entity Type (tipo de entidad): Parte

Realizado por: Ing. Claudio Gmez

18 Time Between Arrivals area (rea de tiempos entre llegadas): o Type (tipo): Random (Expo); Aleatorio (exponencial) o Value (valor): 5 o Units (unidades): Minutes; minutos o Entities per Arrival (Entidades por llegada): 1 o Max Arrival (mximas llegadas): Infinite (infinitas) o First Creation (primera creacin): 0.0

El cuadro de dilogo de su mdulo Create se debera ver as:

Con respecto a la accin que se acaba de ejecutar, hay que resaltar que al escribir Parte en el campo Entity Type, se defini una entidad para el sistema. Para ver detalles acerca de la entidad Parte, se debe ir al mdulo de datos llamado Entity (ubicado en la plantilla procesos bsicos en la barra de proyectos). Si desea realizar algunos cambios de animacin al modelo, puede seleccionar el mdulo de datos Entity, y la informacin correspondiente aparecer en la vista de la hoja de clculo de la ventana del modelo. Ah puede modificar la segunda columna Initial Picture y elegir la opcin Blue ball para que se observe una pelota azul pasando a travs de los mdulos de su modelo. A continuacin modificaremos el mdulo de diagrama de flujo Process; luego de abrir su cuadro de dilogo, se proceder a introducir los siguientes datos: Name (nombre): Centro de perforacin Action (accin): Seize Delay Release; Tomar Demorar Liberar Resources (recursos) (dialogo secundario a travs del botn Add [agregar]): o Type (tipo): Resource; Recurso o Resource Name (nombre del recurso): Drill press; perforadora o Quantity (cantidad): 1 Delay Type (tipo de retraso): Triangular

Realizado por: Ing. Claudio Gmez

19 Units (unidades): Minutes; minutos Minimum (mnimo): 1 Value (valor): 3 Maximum (mximo): 6

Al seguir las instrucciones, su cuadro de dialogo se debera ver como se muestra a continuacin:

Finalmente, el mdulo Dispose del diagrama de flujo, es el mas sencillo, solo requiere que se cambie su nombre a Partes que salen del sistema, y en caso de no estar activa, accionar la opcin de Record Entity Statistics (Guardar estadsticas de la entidad), con la finalidad de tener informacin acerca de la entidad del sistema. Su cuadro de dialogo del mdulo Dispose debe de verse as:

Ahora que los tres mdulos de su proceso estn claramente definidos, se puede realizar un ordenamiento para que queden alineados, esto se ejecuta seleccionando todos los mdulos y luego presionando Arrange > Flowchart Alignment, si tambin desea que tengan un espaciado uniforme, entonces debe seleccionar todos los mdulos y luego presionar Arrange > Distribute > Horizontal.

Realizado por: Ing. Claudio Gmez

20 Su modelo debera verse parecido a la siguiente imagen:

A continuacin, se deben establecer las condiciones de ejecucin, usando el comando Run > Setup, se aprecian una cantidad de pestaas que permiten establecer ciertos criterios para su modelo. Las ms relevantes son: la primera pestaa (Project Parameters; parmetros de proyectos) permite establecer el titulo del proyecto (Project Title), nombre del analista (Analyst Name), descripcin del proyecto (Project Description) y qu estadsticas se desean recopilar; y, la segunda pestaa (Replications Parameters), en la que se permite establecer el nmero de replicaciones (Number of Replications), fecha y hora de inicio (Start Date and Time), periodo de calentamiento (Warm-up Period) con sus unidades de tiempo (Time units), duracin de la replicacin (Replication Length) con sus unidades de tiempo, horas por da (Hours per day), las unidades de tiempo base (Base Time Units), y, finalmente, alguna condicin terminante (Terminating Condition).

Realizado por: Ing. Claudio Gmez

21 El ejemplo que esta realizando, ejecutar 1 replicacin con una duracin de 20 minutos, y sus unidades tiempo base son minutos. Bajo estas premisas, su cuadro de configuracin de la corrida (Run Setup) se debera ver as:

Ahora que todo est listo, se sugiere siempre presionar la tecla F4, cuya funcin es realizar una revisin de posibles errores o advertencias dentro del modelo (falta de conexiones, unidades errneas, entre otros); si sigui correctamente todos los pasos, se activ el siguiente cuadro, el cual indica que no hay errores o advertencias en el modelo:

Finalmente, para iniciar la corrida del modelo, tiene 3 opciones: presionar el cono ubicado en la barra de herramientas estndar, presionar Run > Go, o presionar la tecla F5. Es importante recalcar que la barra ubicada en la barra de herramientas estndar, permite controlar la velocidad de la simulacin, a medida que

Realizado por: Ing. Claudio Gmez

22 se acerque ms al lado izquierdo, su velocidad se disminuir, caso contrario si se moviliza al lado derecho. Al concluir la simulacin, aparecer la siguiente ventana:

Ella indica si usted desea ver los resultados del modelo, al presionar Yes (S), se iniciar el proceso de creacin del informe de resultados, mientras que si presiona No, volver a la ventana del modelo (presione la primera opcin). En la ventana de Category Overview (Resumen de categoras), se observa la cantidad de unidades que salieron del sistema (que deberan ser 5). Si usted desea ver informacin detallada, puede presionar el cono que est a la izquierda de Unnamed Project (o el nombre que usted le coloc al proyecto) en el panel Preview a la izquierda del informe. Esta accin debi desplegar 3 opciones ms: Entity, Queue y Resource. Cada una de ellas tiene informacin sobre las entidades, las colas y los recursos respectivamente. En estos momentos su pantalla se debera ver as:

Realizado por: Ing. Claudio Gmez

23 En este punto es importante recordar cules eran las medidas de desempeo que usted eligi para su proyecto, para este ejemplo, se tomarn de medidas de desempeo: unidades que salieron del sistema, tiempo promedio en cola, tiempo mximo en cola, cantidad mxima de unidades en el sistema, uso del recurso, tiempo total mximo y promedio de la entidad, y el tiempo promedio operativo o de valor agregado por entidad. La primera medida (unidades que salieron del sistema), la observamos en la pantalla inicial del informe creado, el resultado es 5, es decir, si cada 20 minutos se despachan 5 unidades, se pude establecer (con el uso de la conjetura educada), que cada 4 minutos unidad sale del sistema. La segunda medida (tiempo promedio en cola), se accede a travs de la opcin entidad ubicada a la izquierda:

Al seleccionar Entity (entidad), su pantalla de resumen de categoras se debera ver as:

En esta pantalla, podemos tomar algunas medidas de desempeo (tiempo promedio en cola, tiempo mximo en cola, tiempo total mximo y promedio de la entidad, y el tiempo promedio operativo o de valor agregado por entidad). El tiempo promedio en cola es el Average dentro del Wait Time (marcado en azul en la siguiente imagen), el tiempo mximo en cola es el Maximum Value dentro del Wait Time (marcado en verde en la siguiente imagen), el tiempo total mximo y promedio se ubica en el grupo de

Realizado por: Ing. Claudio Gmez

24 Total Time, y las columnas de Average y Maximum Value (resaltado en rojo para la siguiente imagen), y el tiempo promedio operativo o de valor agregado por entidad se ubica en el grupo VA Time (Value Added Time) y en la columna Average (resaltado en amarillo en la siguiente imagen).

Finalmente, para obtener la medida de desempeo cantidad mxima de unidades en el sistema, se debe presionar + Entity > + Other > WIP. Su mapa del resumen de categoras debera verse as:

Realizado por: Ing. Claudio Gmez

25 Y su pantalla, as:

La columna con las siglas WIP (Work In Process) corresponden a las unidades en sistema, y el nmero que se esta buscando se ubica en la columna Maximum Value, cuyo resultado es 4. Con este paso se finaliza el ejemplo, ya usted cre un modelo, lo simul, y obtuvo las medidas de desempeo que requera; a partir de este momento, puede realizar modelos de procesos sencillos.

4. Modelacin de operaciones y entradas bsicas En esta seccin, el lector debera ser capaz de construir algunos modelos razonablemente elaborados, as como de especificar distribuciones apropiadas y realistas como entradas para sus modelos. A continuacin se describir un proceso de manera detallada con el objetivo de imitarlo con el uso del software Arena y aplicar una serie de herramientas y mdulos de elevada utilidad. De manera introductoria, se dice que el sistema a simular representa las operaciones finales de la produccin de dos diferentes unidades electrnicas selladas; las partes que llegan son cajas de metal moldeado que ya han sido mecanizadas y trabajadas para aceptar las partes electrnicas. Las primeras unidades, llamadas Parte A, se producen en un departamento contiguo, fuera de los lmites de este modelo, con tiempos entre llegadas que estn exponencialmente distribuidas con una media de 5 (todos los tiempos estn en minutos). A la llegada, se transfieren (de forma instantnea) al rea de preparacin de

Realizado por: Ing. Claudio Gmez

26 la Parte A, en donde las superficies de unin de las cajas se mecanizan y se trabajan para asegurar un buen sellado y despus a la parte se le quita la rebaba, se desbarba y limpia; el tiempo de proceso para esta operacin combinada en el area de preparacin de la Parte A sigue una distribucin triangular (1, 4, 8). Despus se transfiere la parte (de forma instantnea) al sellador. Las segundas unidades, llamadas Parte B, se producen en un edificio diferente, tambin fuera de los lmites de este modelo, en donde se les retiene hasta que est listo un lote de cuatro unidades; el lote se enva al rea de produccin final que estamos modelando. El tiempo entre las llegadas de los lotes sucesivos de la Parte B a nuestro modelo es exponencial con una media de 30 minutos. A la llegada al rea de preparacin de la Parte B, el conjunto se separa en las cuatro unidades individuales, que se procesan una a una desde este punto y las partes individuales proceden (de forma instantnea) al rea de preparacin. El proceso en el rea de preparacin de la Parte B, tiene los mismo tres pasos que el de la Parte A, excepto que el tiempo del proceso sigue una distribucin triangular (3, 5, 10). Luego la parte se enva (de forma instantnea) al sellador. En la operacin del sellador se insertan los componentes electrnicos, la caja se ensambla y se sella y se prueba la unidad sellada. El tiempo total del proceso para estas operaciones depende del tipo de parte: distribucin triangular (1, 3, 4) para la Parte A y distribucin Weibull (2.5, 5.3) para la Parte B (2.5 es el parmetro escala y 5.3 es el parmetro forma). Noventa y uno por ciento de las partes pasan la inspeccin y se transfieren inmediatamente al dpto. de envo; si una parte pasa es independiente de si cualquier otra parte lo hace. Las partes restantes se transfieren de forma instantnea al rea de retrabajo en donde se les desensambla, repara, limpia, se ensamblan de nuevo y se les pone a prueba otra vez. Ochenta por ciento de las partes que se procesan en el rea de retrabajo se recuperan y transfieren de forma inmediata al dpto. de envo como partes reprocesadas y el resto se dirigen de forma instantnea al rea de descarte. El tiempo para reprocesar una parte sigue un distribucin exponencial con media de 45 y es independiente del tipo de parte y de la disposicin ltima. Se desea recopilar estadsticas en cuanto a uso del recurso, nmero en cola, tiempo en cola y tiempo del ciclo (o tiempo total en el sistema) en cada rea por separado para las partes enviadas, recuperadas o descartadas; todos estos resultados para cuatro turnos de 8 horas o 1920 minutos. El primer paso para resolver este ejercicio es determinar qu mdulos se van a usar y su cantidad. Para este casos se requieren: 2 mdulos Create (llegada de dos tipos de partes distintas)

Realizado por: Ing. Claudio Gmez

27 2 mdulos Assign (con la finalidad de hacerle seguimiento y procesos especficos a cada tipo de parte) 4 mdulos Process (2 para la preparacin de las partes, 1 para el sellado y 1 para el reprocesamiento) 2 mdulos Decide (1 para la primera inspeccin y 1 para la inspeccin de las partes reprocesadas) 3 mdulos Record (1 para cada tipo de parte: enviadas, recuperadas y descartadas) 3 mdulos Dispose (1 para cada tipo de parte: enviadas, recuperadas y descartadas)

En caso de requerirse ms mdulos, habra que evaluar de nuevo el proceso para verificar la necesidad de una posible adicin. Ahora se requiere que se inserten los mdulos siguiendo la lgica del sistema. Lo sugerido es seguir el flujo del proceso, de la siguiente manera: 1. Agregar los dos mdulos de creacin, uno para cada parte. 2. Agregar los dos mdulos de asignar (Assign) (estos se requieren tanto para poder dar resultados de la disposicin final de las partes y para determinar los tiempos de sellado). Estos dos mdulos se conectan a cada uno de los mdulos Create. 3. Agregar dos mdulos de procesos, para representar los procesos de preparacin para cada tipo de pieza (restan 2 mdulos ms de procesos que sern agregados ms adelante). Estos dos mdulos se conecta a cada uno de los mdulos Assign. 4. Agregar un mdulo de proceso, para representar el sellador (resta 1 mdulo de procesos). Este mdulo recibe las dos partes preparadas, es decir, el proceso pasa de tener dos flujos a uno, con este mdulo como punto de convergencia. 5. Agregar un mdulo de Decide (decisin), este representar la inspeccin inicial (resta 1 mdulo de decisin). Este mdulo se conecta al de proceso del sellador. A partir de esta decisin, se originan dos nuevos flujos, uno se referir a las piezas enviadas y otro a las rechazadas (nicamente de la inspeccin inicial). 6. Agregar un mdulo de Record (guardar), el cual permitir (con la ayuda del mdulo Assign) obtener resultados de la duracin por tipo de parte (faltan 2 mdulos de guardar). Este se conecta con la decisin False del mdulo anterior de decisin (es importante sealar que no necesariamente se debe conectar a esta decisin, se puede elegir conectarlo a la decisin True, pero con la finalidad de seguir el ejemplo segn la bibliografa usada, se sigui este esquema).

Realizado por: Ing. Claudio Gmez

28 7. Agregar un mdulo de Dispose (descartar), el cual se encargar de retirar del sistema las partes que fueron enviadas. Este se conecta con el mdulo Record. En este punto se termin el recorrido que siguen las partes enviadas (faltan 2 mdulos de Dispose). 8. Agregar un mdulo de procesos, el cual se conectara a la decisin True colocada en el paso 5. Este mdulo de procesos representara el reprocesamiento para las piezas rechazadas (con este mdulo, ya se agregaron al modelo todos los mdulos de procesos). 9. Agregar un mdulo de Decide (decisin), para representar la segunda inspeccin, el cual se conectara con el modulo de procesos del reprocesamiento (ya fueron agregados al modelo todos los mdulos de decisin). 10. Agregar dos mdulos de Record (grabar), que saldrn de cada una de los opciones del mdulo Decide, para registrar las partes que fueron recuperadas y las que fueron descartadas (ya se agregaron todos los mdulos de Record). 11. Agregar dos mdulos de Dispose (descartar), el cual se encargara de retirar del sistema las partes tanto recuperadas como descartadas. Este se conecta a cada mdulo de Record (ya se agregaron todos los mdulos al proceso). Si se siguieron las instrucciones correctamente, su vista del diagrama de flujo en la ventana del modelo se debera ver as (o al menos poseer la lgica del diagrama y la misma correspondencia en cantidad de mdulos de diagrama de flujo):

El siguiente paso, es introducir los datos a cada uno de los mdulos; a continuacin se presentan las impresiones de pantalla que debe poseer cada mdulo, para mayor informacin acerca de los datos introducidos, recomendamos leer de nuevo la descripcin del sistema.

Realizado por: Ing. Claudio Gmez

29 Mdulo Crear para la Parte A:

Mdulo Crear para la Parte B: Con respecto a este mdulo, hay que recordar que llega un lote con 4 piezas cada 30 minutos.

Mdulo Asignar para la Parte A: Este mdulo permite asignar variables o atributos especficos a las entidades que pasen a travs de l. En el caso de este modelo, se requiere asignarle a la Parte A un tiempo de sellado especfico y, para hacerle seguimiento con respecto a su disposicin final se le asignar un atributo de tiempo de llegada. Con respecto al tiempo de sellado especfico, se debe presionar Add, y luego seleccionar Type: Attribute (tipo: atributo), Attribute Name: Tiempo de sellado (nombre del atributo), New value: TNOW (valor nuevo; es importante sealar que TNOW significa que guardar el tiempo actual de la simulacin, si se desea buscar ms opciones, se puede hacer clic derecho en este campo y seleccionar la opcin Build Expression)

Realizado por: Ing. Claudio Gmez

30

Mdulo Asignar para la Parte B: La diferencia con respecto a la asignacin de la Parte A radica en que el tiempo del sellador sigue una distribucin Weibull, con el parmetro de escala igual a 2.5 y el de forma a 5.3.

Mdulo Procesar para la Parte A:

Realizado por: Ing. Claudio Gmez

31 Mdulo Procesar para la parte B:

Mdulo Procesar para el sellado de ambas partes: Se debe resaltar que al elegir el tipo de demora (Delay Type), se debe seleccionar Expression (recuerde que ambas partes convergen en este mdulo pero tienen tiempos de sellado distintos) y en el campo ubicado debajo, escribir Tiempo del sellador (recuerde que en los mdulos de Asignar, ya le atribuy valores a esta expresin)

Realizado por: Ing. Claudio Gmez

32 Mdulo Decisin para la inspeccin inicial: Para este ejercicio se estableci que 91% de las partes no son rechazadas, por tanto 9% se dirigen al rea de reprocesamiento. El tipo de decisin a elegir es 2-way by Chance (dos caminos por porcentajes) debido a que solo se tienen dos casos: parte rechazada (TRUE) y parte aceptada (FALSE).

Mdulo de Proceso para el retrabajo o reprocesamiento:

Realizado por: Ing. Claudio Gmez

33 Mdulo de Decisin para la segunda inspeccin:

Mdulo de Grabar para las 3 partes que salen del sistema (descartadas, recuperadas, enviadas): El tipo de grabar requerido es Time Interval (intervalo de tiempo) debido a que permitir obtener el tiempo que pasan en el sistema cada una de las 3 tipos de partes que fluyen en el sistema (en las siguientes imgenes se observan 2/3 de los mdulos grabar)

Realizado por: Ing. Claudio Gmez

34 Mdulo de Descartar para la salida de las 3 partes (en las siguientes imgenes se aprecian 2/3 de los mdulos descartar.

Acaba de finalizar el ingreso de datos a todos los mdulos de su modelo de simulacin.

Realizado por: Ing. Claudio Gmez

35 Su modelo se debiera ver de la siguiente manera (al menos los nombres de los mdulos):

El siguiente paso es determinar las condiciones de la ejecucin, las cuales son: Cantidad de replicaciones: 1 Duracin de la replicacin: 32 horas Unidades base: minutos

Y, con la finalidad de ver la diferencia entre las partes, se sugiere cambiar, a travs del mdulo de datos Entity, las imgenes que representan estas entidades a una bola azul para la parte A y una bola roja para la parte B. Antes de ejecutar el modelo, recuerde presionar la tecla F4 para chequear si existe algn error (en caso de existir, saldr una pantalla explicando el error y para ir directamente al mdulo que genera el error, debe presionar la opcin Find). Finalmente, ejecute el modelo para observar el flujo de las partes a travs del sistema.

Realizado por: Ing. Claudio Gmez

BIBLIOGRAFIA Kelton, W., Sadowski, R. y Sturrock, D. (2008). Simulacin con Software Arena (4ta edicin). Mxico D.F. McGraw Hill interamericana. Rockwell Software (2005). Arena Basic Users Guide. Estados Unidos. Rockwell Automation.