Anda di halaman 1dari 12

Topologi MikroTik router

Dalam bab ini akan di bahas tentang bagaimana cara membuat MikroTik router pada sebuah komputer standar yang dilengkapi dengan 2 buah ethernet card. Topologi jaringan MikroTik router yang akan dibahas seperti gambar berikut:

Server 10.0.1.3 Public Network 10.0.1.0/24

Internet Gateway 10.0.1.1 Interface Public Address : 10.0.1.200/24

Local Network 192.168.0.0/24

Interface Local Address :192.168.0.1/24

Workstation Address :192.168.0.2 /24

Laptop Address :192.168.0.3/24

Gambar 37: Topologi MikroTik router.

Identitas ethernet. Untuk merubah nama ethernet yang terpasang pada mesin MikroTik, ketikkan : [admin@proxy]>/interface [admin@proxy]interface>ethernet set ether1 name=public

Untuk melihat hasil konfigurasi ketikan : [admin@proxy]interface>pr Flags: X - disabled, D - dynamic, R - running # NAME TYPE RX -RATE TX-RATE MTU

Modul MikroTik RouterOS by Kustanto

R public

ether

1500

Kemudian lakukan yang sama pada ethernet yang kedua : [admin@proxy]>/interface [admin@proxy]interface> ethernet set ether2 name=lan

Untuk melihat hasil konfigurasi nya ketikan : [admin@proxy]interface>pr Flags: X - disabled, D - dynamic, R - running # NAME 0 R public 1 R lan IP address. Untuk melakukan setting IP address pada masing -masing ethernet, dengan perintah sebagai berikut : TYPE ether ether RX -RATE 0 0 TX-RATE 0 0 MTU 1500 1500

[admin@proxy]>/ip address [admin@proxy]ip address> add interface=public address=10.0.1.200/24 [admin@proxy]ip address>pr Flags: X - disabled, I - invalid, D - dynamic # ADDRESS 0 10.0.1.200/24 NETWORK 10.0.1.0 BROADCAST 10.0.1.255 INTERFACE public

Kemudian konfigurasikan IP address beserta netm ask, untuk ethernet yang ke-2 yaitu ethernet lan, caranya sama dengan diatas yaitu :

[admin@proxy]>/ip address [admin@proxy]ip address> add interface=lan address=192.168.0.1/24 Sehingga untuk mengetahui hasil konfigurasi kedua ethernet tersebut, ketikkan:

Modul MikroTik RouterOS by Kustanto

[admin@proxy]ip address>pr Flags: X - disabled, I - invalid, D - dynamic


# ADDRESS 0 10.0.1.200/24 NETWORK 10.0.1.0 BROADCAST 10.0.1.255 NTERFACE public

1 192.168.0.1/24 192.168.0.0

192.168.0.255 lan

IP Gateway. Untuk mengkonfigurasi gateway pada router internet ini, ketikan : [admin@proxy]>/ip route [admin@proxy]ip route>add gateway=10.0.1.1

Untuk melihat hasil konfigurasi ketikan : [admin@Proxy] ip route>pr


Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf # DST-ADDRESS PREF-SRC G GATEWAY DISTANCE INTERFACE lan public public

0 ADC 192.168.0.0/24 192.168.0.1 1 ADC 10.0.1.0/24 2 A S 0.0.0.0/0 10.0.1.200 r 10.0.1.1

DNS (Domain Name Server). Dalam mengisikan IP DNS, sesuaikan dengan rekomendasi dari ISP anda. misalkan : DNS1 : 202.134.1.10 DNS2 : 202.134.0.155

Maka untuk konfigurasinya, ketikan : [admin@proxy]>/ip dns [admin@proxy]ip dns> set primary-dns=202.134.1.10 [admin@proxy]ip dns> set secondary-dns=202.134.0.155

Untuk melihat hasil konfigurasinya, ketikan : [admin@Proxy] ip dns>pr primary-dns: 202.134.1.10

Modul MikroTik RouterOS by Kustanto

secondary -dns: 202.134.0.155 allow-remote-requests: no cache-size: 2048KiB cache-max-ttl: 1w cache -used: 65KiB

Agar semua komputer client dalam LAN bisa lebih cepat dalam melakukan browsing internet, maka MikroTik router perlu diset agar bisa melakukan penyimpanan cache DNS. Sehingga setiap kali komputer client browsing tidak perlu mengambil informasi dari server ISP, namun langsung mengambil informasi yang ada dalam server DNS MikroTik router anda. Adapun yang perlu di set untuk kebutuhan ini adalah sebagai berikut: admin@Proxy] ip dns> set allow-remote-request=yes

Kemudian kolom Preferred DNS server pada komputer client, isikan dengan IP addressnya ethernet MikroTik router yang menghubung ke LAN . Sedangkan untuk kolom Alternate DNS server biarkan saja kosong atau samakan dengan DNS MikroTik router. Jika kita salah dalam mengetikkan perintah diatas, maka akan muncul peringatan "no such argument".

Gambar : Internet Protocol (TCP/IP) Propertiess

Modul MikroTik RouterOS by Kustanto

IP firewall nat. Agar komputer client bisa akses internet, maka IP address ethernet lan harus ditranslate ke Ip ethernet public dengan perintah: [admin@proxy]>/ip firewall nat [admin@proxy]ip firewall nat> add chain=srcnat out -interface=public

src-address=192.168.0.0/24 action=masquerade

Untuk melihat hasil konfigurasi tersebut, ketikan :

[admin@proxy]ip firewall nat>pr Flags: X - disabled, I - invalid, D - dynamic 0 chain=srcnat out-interface=public src address=192.168.0.0/24 action=masquerade

Komputer Client. Agar komputer client bisa akses internet melalui mesin Mik roTik routerOS tersebut, maka perlu dilakukan konfigurasi sebagai berikut:

a. Konfigurasi komputer workstation: IP address Subnet mask Default gateway Preferred DNS server
Alternate DNS server

: 192.168.0.2 : 255.255.255.0 : 192.168.0.1 : 192.168.0.1


: 202.134.0.155 { sama seperti pada IP DNS mikrotik OS atau dikosongkan juga nggak masalah}.

Konfigurasi pada Windows XP Profesional :

Modul MikroTik RouterOS by Kustanto

Klik Start>Control Panel> Network Connections> Local Area Connection> Properties> Internet Protocol(TCP/IP), OK.

Gambar 54: Setting IP address pada workstation

b. Konfigurasi komputer laptop: IP address Subnet mask Default gateway Preferred DNS server Alternate DNS server : 192.168.0.3 : 255.255.255.0 : 192.168.0.1 : 192.168.0.1 :

Modul MikroTik RouterOS by Kustanto

Klik Start>Control Panel> Network Connections> Local Area Connection> Properties> Internet Protocol (TCP/IP), OK.

Gambar 55: Setting IP address pada laptop Kemudian untuk mengetahui apakah komputer client bisa akses internet atau tidak, dengan cara kita coba ping ke IP gateway dengan perintah : ping 192.168.0.1 (menguji apakah komputer client bisa terkoneksi dengan mesin MikroTik router ) dan ping google.com (menguji alamat DNS server ). Langkah ini dilakukan baik dari komputer workstation maupun komputer laptop pada menu Command Promt. Hasil uji coba tersebut seperti gambar berikut:

Modul MikroTik RouterOS by Kustanto

Gambar : Command Promt Windows XP Profesional

Modul MikroTik RouterOS by Kustanto

Gambar : Uji coba akses ke internet melalui IE IP web-proxy Agar mesin MikroTik routerOS menjadi proxy server, maka buatkan konfigurasi berikut : [admin@proxy]>/ip web -proxy [admin@proxy]ip web-proxy> set enabled=yes >> to make ip web proxy enable

[admin@proxy]ip web-proxy> set src-address=0.0.0.0 proxy will allow >> to make source address to access web

[admin@proxy]ip web-proxy> set port=8080 >> to make port for web proxy

Modul MikroTik RouterOS by Kustanto

[admin@proxy]ip web-proxy> set hostname=proxy.lab.ac.id web proxy >> setting for visble hostname

[admin@proxy]ip web-proxy> set transparent-proxy=yes >> make transparant proxy enable

[admin@proxy]ip web-proxy> set parent-proxy=0.0.0.0:0 >> if we used parent proxy x

[admin@proxy]ip web-proxy> set cache-administrator=webmaster >> make set administrators e-mail displayed on proxy error page

[admin@proxy]ip web-proxy> set max-object-size=4096KiB >> maximal object can cacth with the proxy server

[admin@proxy]ip web-proxy> set cache-drive=system >> where drive position that cache wil be saved

[admin@proxy]ip web-proxy> set max-cache-size=unlimited cache set max-ram-cache-size=unlimited >> maximal ram we used for cache. >> maximal harddrive we used for

[admin@proxy]ip web-proxy> set reserved-for-cache=4733952KiB

[admin@proxy]ip web-proxy> set reserved-for-ram-cache=2048KiB

Modul MikroTik RouterOS by Kustanto 10

[admin@proxy]ip web-proxy> set status=running Untuk melihat hasil konfigurasi proxy server diatas ketikan : [admin@proxy]ip web-proxy>pr Proxy transparant Setelah melakukan konfigurasi diatas, kemudian kita harus mentransparankan IP Local (lan) agar IP address dibawahnya di redire ct melalui mesin proxy. Perintah untuk mentransparankan proxy tersebut adalah sebagai berikut :

[admin@proxy]>/ip firewall nat [admin@proxy]ip firewall nat> add chain=dstnat in-interface=lan protocol=tcp dst port=80 src-address-list=iplan dst-address-

list=192.168.0.0/24 action=redirect to -ports=8080 >> setting can redirect port 80 to 8080 for proxy server [admin@proxy]ip firewall nat> add chain=dstnat in-interface=lan protocol=tcp dst port=3128 src-address-list=iplan dst-address-

list=192.168.0.0/24 act ion=redirect to-ports=8080 >> setting can redirect port 3128 to 8080 for proxy server

[admin@proxy]ip firewall nat> add chain=dstnat in-interface=lan protocol=tcp dst port=8080 src-address-list=iplan dst-address-

list=192.168.0.0/24 action=redirect to -ports=8080 >> setting can redirect port 8080 to 8080 for proxy server

[admin@proxy]ip firewall nat> add chain=dstnat protocol=tcp dst -port=80 action=accept >> setting can redirect port 80 to 8080 for proxy server

[admin@proxy]ip firewall nat>

Modul MikroTik RouterOS by Kustanto 11

add chain=dstnat protocol=tcp dst -port=3128 action=accept >> setting can redirect port 3128 to 8080 for proxy server

[admin@proxy]ip firewall nat> [admin@proxy]ip firewall nat> add chain=dstnat protocol=tcp dst -port=8080 action=accept >> setting can redirect port 8080 to 8080 for proxy server

Setelah konfigurasi diatas, maka mesin anda sudah menjadi mesin Proxy Transparant.

Untuk melihat hasil konfigurasi dengan perintah : [admin@proxy]ip firewall nat>pr

Modul MikroTik RouterOS by Kustanto 12