Anda di halaman 1dari 9

TUTORIAL MEMBUAT PROGRAM BELANJA SEDERHANA A.

Cara Memulai VB 6
1. Langkah pertama, memulai dengan mengklik dua kali shortcut yang ada di wallpaper windows. Sebagai contoh shortcut VB 6 seperti berikut.

Anda juga dapat memulai VB 6 dengan memilih menu start > All Programs > Microsoft Visual Basic 6.0 > Microsoft Visual Basic 6.0

Tutorial Visual Basic 6.0 | WULAN DARI

B. Tampilan Utama (IDE) VB 6


1. Setelah Anda memulai VB 6 akan muncul jendela New Project.

2. Klik tombol Open pada pilihan Standard EXE pada tab New Project, Anda akan melihat tampilan area kerja atau IDE VB 6. Kenali beberapa bagian utama di dalam IDE VB 6 berikut ini 1 2

3 6

Keterangan: 1) MenuBar 2) ToolBar 3) ToolBox

Tutorial Visual Basic 6.0 | WULAN DARI

Berisi tools yang digunakan untuk mendesain form. Untuk menampilkan Toolbox, klik tombol Toolbox pada baris Toolbar atau klik menu View > Toolbox 4) Form Designer/ Form Window Pada Form Window, pemrogram bebas untuk mendesain bentuk tampilan form. Untuk menampilkan Form Window, klik tombol View Object pada Project Explorer atau klik menu View > Object 5) Project Explorer Project Explorer berisi form, module, class module, report, atau file lain yang terdapat dalam suatu Project. Project Explorer memudahkan kita untuk melihat dan memodifikasi form/module/class module/report yang telah kita buat. Untuk menampilkan Project Explorer, klik tombol Project Explorer pada baris Toolbar atau klik menu View > Project Explorer. 6) Properties Window Properties Window berisi atribut-atribut yang terdapat dalam suatu control yang dapat diubah-ubah sesuai dengan kebutuhan. Untuk menampilkan Properties Window, klik tombol Properties Window () pada baris Toolbar atau klik menu View > Properties Window.

C. Membuat Program VB 6
Membuat User Interface (UI) Pada saat VB 6 sudah aktif, Jendela Form buatlah UI seperti:

Tutorial Visual Basic 6.0 | WULAN DARI

Langkah-Langkah Membuat Program VB 6 1. Kita mulai membuat user interface (UI) dengan mengklik komponen Label ( ) di dalam toolbox kemudian gambar object Label1di damam Form dengan cara drag-drop.

Lakukan langkah yang sama untuk object Label2 dan Label3

Tutorial Visual Basic 6.0 | WULAN DARI

3. Selanjutnya gambar object Text1, Text2, dan Text3 dengan menggunakan komponen TextBox ( ) , sedangkan object Command1 dan Command2 menggunakan komponen Command Button ( )

4. Setelah menggambar object, selanjutnya adalah mengatur properti object melalui jendela Properties. Atur setiap property object sebagai berikut: Object Properties Value Form1 Caption Belanja Label1 Caption Harga Satuan Label2 Caption Jumlah Barang Label3 Caption Bayar (Name) txtHargaBarang Text1 Caption (Name) txtJumlah Text2 Caption (Name) txtBayar Text3 Caption Command1 Caption Hasil Command2 Caption Keluar

Tutorial Visual Basic 6.0 | WULAN DARI

Sehingga UI-nya menjadi seperti ini:

Langkah terakhir yaitu menulis kode program. Program yang berbasis Windows bersifat event-driven, artinya program bekerja berdasarkan event yang terjadi pada object di dalam program tersebut. Misalnya, jika seorang user meng-klik sebuah tombol maka program akan memberikan "reaksi" terhadap event klik tersebut. Program akan memberikan "reaksi" sesuai dengan kode-kode program yang dibuat untuk suatu event pada object tertentu. 5. Pilih object Command1 pada bagian Object Selector. Secara otomatis pada bagian Code Editor akan muncul blok kode program berikut:

Tutorial Visual Basic 6.0 | WULAN DARI

Event Click merupakan event default (standar) dari object Command1, Anda bisa melihat event lainnya pada bagian Event Selector. Pada bagian Code Editor ketikkan kode programnya sebagai berikut: txtBayar.Text = Val(txtHargaSatuan.Text) * Val(txtJumlah.Text)

6. Selanjutnya pilih object Command2 pada bagian Object Selector. Setelah muncul bagian Code Editor ketikkan kode programnya sebagai berikut: Unload Me

Tutorial Visual Basic 6.0 | WULAN DARI

D. Menyimpan Program VB 6
Pilih menu File > Save Project As Simpan Form1 (nama file : Latl.frm) dan Project1 (nama file : Latihan1.vbp). VB 6 akan menyimpan program yang Anda buat ke dalam beberapa file yang saling terkait, antara lain : file project (*.vbp), file form (*.frm) dan file module (*.bas).

E. Menjalankan Program
1. Coba jalankan Project1 dengan menekan tombol F5 pada keyboard maka akan tampil hasil sebagai berikut:

2. Masukkan angka berapa saja dalam TextBox harga satuan dan jumlah barang. Misalnya memasukkan angka 2300 pada TextBox harga satuan dan angka 3 pada TextBox jumlah barang seperti pada gambar.

Tutorial Visual Basic 6.0 | WULAN DARI

3. Klik tombol Hasil untuk melihat hasil pada TextBox bayar

4. Bila ingin keluar, klik tombol Keluar

F. Menutup Program VB 6
Untuk Menutup Sistem VB 6, dengan memilih File > Exit.

Tutorial Visual Basic 6.0 | WULAN DARI