Anda di halaman 1dari 5

BENEMRITA UNIVERSIDAD AUTNOMA DE PUEBLA

Esc. Preparatoria 2 de Octubre de 1968

Informtica III

Actividad: ALGORITMOS 3

Mtra. Minerva Gmez Marcos

Marcos Yael Pedraza Chamorro

Noviembre 2013

Pedraza Chamorro Marcos Yael 3DM INFO Proceso IMC Escribir "dar el peso en kilogramos"; Leer peso; Escribir "dar la estatura en metros"; Leer estatura; IMC<-peso/(estatura*estatura); Escribir "Tu Indice de Masa Corporal es:", IMC; SI IMC<16 Entonces Escribir "Tienes Desnutricion nivel III" FinSi SI IMC>=16 Y imc <=16.9 Entonces Escribir "Tienes Desnutricion nivel II, DEBES COMER MAS" FinSi SI IMC >=17 Y IMC <=18.4 Entonces Escribir "Tienes Desnutricion tipo I, SOLO COME UN POCO MAS" FinSi SI IMC <18.5 entonces Escribir "La persona esta BAJA DE PESO" FinSi Si IMC >=18.5 Y IMC<=24.5 Entonces Escribir "Estas normal" FinSi Si IMC >=25 Y IMC<=29.9 Entonces Escribir "Tienes sobrepeso" FinSi Si IMC>=30 Y IMC<=34.9 Entonces Escribir "Tienes Obesidad nivel I" FinSi

Pedraza Chamorro Marcos Yael 3DM INFO Si IMC>=35 Y IMC<=39.9 Entonces Escribir "Tienes Obesidad nivel II" FinSi si IMC>=40 Entonces Escribir "Tienes Obesidad nivel III" FinSi FinProceso

Proceso beca

Escribir "Dame calificacion de Matematicas" Leer mat Escribir "Dame calificacion de Informatica" Leer info Prom<-(mat+info)/2 Escribir "Su promedio es:",Prom Si Prom>=7 Entonces Escribir "Te has ganado una beca de 5000 pesos mensuales" Sino Escribir "Lo siento tendras que pagar un curso de regularizacion" Finsi Finproceso

Pedraza Chamorro Marcos Yael 3DM INFO Proceso Votar

Escribir "Dame tu edad" Leer edad Escribir "Dame el ano actual" Leer anio Si edad>=18 Entonces Escribir "Ya puedes votar" tiempo<- edad-18 Escribir "Has votado desde hace ", tiempo, " anos" Sino Escribir "Eres menor de edad" tiempo<-18-edad Escribir "Te faltan " ,tiempo, " anos para poder votar" FinSi

Finproceso

Proceso Playeras Escribir "Dame el numero de playeras compradas" Leer play Si play>=5 Entonces Escribir "Pagas $170 c/u" Precio<-play*170 Escribir "El total a pagar es:", Precio Sino Escribir "Pagas $230 c/u"

Pedraza Chamorro Marcos Yael 3DM INFO Precio1<-play*230 Escribir "El total a pagar es:", Precio1 Finsi FinProceso