Anda di halaman 1dari 7

Spesifikasi:

Ukuran: 14x21 cm Tebal: 130 hlm Harga: Rp 32.800 Terbit pertama: Maret 2005 Sinopsis singkat: Perancangan Berorientasi Objek merupakan metode perancangan perangkat lunak visual atau objek. Perancangan Objek sangat mudah dipelajari karena hanya mempunyai satu metodologi yang terdiri dari tiga model, yaitu Model Objek, Model Dinamis, dan Model Fungsional. Model Objek berhubungan dengan desain database (normalisasi atau ERD), Model Dinamis berguna untuk menentukan State (Properties) dan Event (Kejadian), sedangkan Model Fungsional berisi DFD dan Flowchart atau Pseudocode. Buku ini akan memandu Anda dalam desain objek melalui Visual Foxpro 8.0 yang merupakan perangkat lunak yang mudah dan andal. Kemampuan database, report, form, menu, dan lain-lain yang terintegrasi di dalamnya akan memudahkan Anda untuk mempelajari Perancangan Berorientasi Objek. Dalam buku ini, penulis memfokuskan pada pelajaran desain objek dan hubungannya dengan Visual Foxpro 8.0.

Bab 8
Persiapan Pembuatan Program
Pokok Bahasan:

G G G

Membuat Folder Penyimpanan Proyek Mengatur Folder Proyek Menjadi Aktif

Mengatur Bentuk Mata Uang Menjadi Rupiah

Mengatur Tampilan Form

8.1 Pendahuluan
Untuk memudahkan pembuatan program maka sebelumnya kita harus mempersiapkan pembuatan program sebaik-baiknya. Pembuatan program Sistem Pembayaran Tunggakan Siswa ini, terdiri dari beberapa persiapan, yaitu: 1. Pembuatan folder/direktori penyimpanan proyek. 2. Pengaturan (setting) folder proyek menjadi folder aktif. 3. Mengatur bentuk mata uang ke bentuk mata uang rupiah. 4. Mengatur tampilan form.

8.2 Membuat Folder Penyimpanan Proyek


Folder yang kita buat sebaiknya mempunyai nama sesuai dengan proyek yang kita kerjakan sehingga memudahkan kita dalam hal pencarian folder untuk proyek tertentu. Untuk membuat folder, terdapat beberapa cara, yaitu: 41

1. Melalui menu utama Windows: a. Klik Start > Programs > Windows Explorer (Windows Explorer akan terbuka). b. Klik folder/direktori C. c. Pilih menu File > New > Folder. d. Ketik nama folder, contohnya sisfodiksma dan tekan ENTER. atau: a. Klik kanan Start > Explore, lalu klik folder C. b. Pilih menu File > New > Folder. c. Ketik sisfodiksma dan tekan ENTER. 2. Melalui command window Visual Foxpro: a. Dengan keadaan sistem Microsoft Visual Foxpro terbuka, ketik set default to c: di command window dan tekan ENTER. b. Ketik md sisfodiksma di command window dan tekan ENTER.

8.3 Mengatur Folder Proyek Menjadi Aktif


Pengaturan (setting) folder aktif untuk proyek bertujuan untuk mengatur arah baca proyek sehingga ketika Anda pertama kali membuka Microsoft Visual Foxpro, sistem secara otomatis membaca folder proyek kita sehingga kita tidak perlu lagi mengarahkan folder ke proyek kita. Cara pengaturan folder menjadi aktif adalah sebagai berikut: 1. Dengan Microsoft Visual Foxpro aktif/terbuka, pilih Tools > Options sehingga kotak Options akan tampil (lihat Gambar 8.1). 2. Pilih tab File Locations.

42

3. Klik Default Directory > Modify (akan tampil window seperti Gambar 8.2). 4. Ketik c:\sisfodiksma. 5. Klik OK. 6. Klik Set As Default.

Gambar 8.1 Kotak Options

Gambar 8.2 Kotak Change File Location

43

8.4 Mengatur Bentuk Mata Uang Menjadi Rupiah


Pengaturan ini berguna untuk menampilkan bentuk mata uang Rupiah (Rp.) pada segala data yang berhubungan dengan tipe data currency. Cara mengaturnya adalah sebagai berikut: 1. Dalam keadaan Microsoft Visual Foxpro aktif/terbuka, pilih Tools > Options. 2. Pilih tab Regional (akan tampil window seperti Gambar 8.3).

Gambar 8.3 Kotak Options Tab Regional

3. Ketik Rp. di Currency Symbol:. 4. Ketik , (tanda koma) di Decimal Separator:. 5. Ketik . (tanda titik) di 1000 Separator:. 6. Ketik , (tanda koma) di Decimal Digits:. 7. Klik OK.

44

8.5 Mengatur Tampilan Form


Pengaturan form ini meliputi menghilangkan garis grid, konfirmasi penyimpanan ketika akan menjalankan form, dan daerah desain maksimum pada form, serta menampilkan posisi objek dan posisi spasi, baik mendatar maupun tegak. Cara mengaturnya adalah sebagai berikut: 1. Dengan Microsoft Visual Foxpro aktif/terbuka, pilih Tools > Options. 2. Pilih tab Form (akan tampil window seperti Gambar 8.4).

Gambar 8.4 Kotak Options Tab Form

3. Hilangkan tanda centang pada Grid lines. 4. Beri tanda centang pada Show position. 5. Ketik 4 pada objek spinner untuk Horizontal spacing (pixels). 6. Ketik 4 pada objek spinner pada Vertical spacing (pixels). 7. Pilih ukuran 1600x1200 dari daftar pada Maximum design area. 8. Beri tanda centang pada Prompt to save changes before running form. 45

9. Klik objek button Set As Default > OK. Setelah pengaturan di atas selesai dilakukan, Anda siap untuk membuat program.

46