Anda di halaman 1dari 78

PENGENALAN SPSS

Modify oleh : Ambar Roestam Untan 2006 Bahan diambil : Prof. Bastaman Basuki Dr. Muchtaruddin Mansyur

Topik diskusi
Membuat dan import data, transform variabel, pengendalian data, dan menjalankan statistik deskriptif. Penjelasan beberapa statistik infrensia

Penampilan output berupa grafik

Pendahuluan
SPSS adalah perangkat lunak:
Menjalankan analisis statistik Pengolahan data (recoding, computing variabel baru, merging, dan agregating data) Membuat tabel dan grafik dari data

Analisis statistik berkisar dari : *) statistik deskriptif dasar (seperti; nilai rata rata dan frekuensi) sampai *) statistik infrensial (seperti model regressi, analisis varians, dan analisis faktor).

Pendahuluan
SPSS for Windows terdiri dari 5 jendela (windows)

Data Editor
Jendela yang terbuka saat start-up U/ memasukkan & menyimpan data dlm format spreadsheet

Output Viewer
Terbuka otomatis saat menjalankan analisis/membuat grafik Berisikan hasil analisis statistik dan grafik

Syntax Editor
Text editor menyusun SPSS commands dan menempatkan ke SPSS processor Terdiri dari metoda untuk input, pendefinisian, dan pengorganisasian data

Data editor
Menampilkan format spreadsheet yang terdiri dari variabel di kolom dan kasus di lajur. Terdiri dari data view dan variable view. Bukan file *.save -> import dari open menu.
Jika tidak dikenal translate dulu ke file yang dikenal SPSS (contoh, tab-delimited data).

Data editor

Syntax editor
Menampilkan prosedur/proses data Memungkinkan kita mengikuti proses data dari output yang ada sesuai instruksi Memungkinkan pengulangan analisis data bila diperlukan Dapat dilakukan dengan menekan paste pada box analisis data.

Syntax editor
Dengan mengklik Paste atau (Alt + P) akan dihasilkan berikut: DESCRIPTIVES VARIABLES=educ /STATISTICS=MEAN STDDEV MIN MAX . Syntax dapat disimpan dan kemudian dijalankan kemudian selama menggunakan data dan variabel yang sama. Penyimpanan syntax berguna untuk mengulang kembali analisis;
Setelah penambahan data Data lain dengan variabel yang sama

Output Viewer
Seluruh output analisis statistik ditampilkan pada Output Viewer . Informasi lain;
command syntax, Judul Error messages

Output viewer

Tampilan Output
Pengaturan tampilan output dapat dilakukan dengan menggunakan menu Options atau (Alt+E+N) pada menu Edit: Edit Options...

Importing data
Data (spreadsheet) dalam bentuk bukan SPSS dapat di impor ke SPSS Umumnya bentuk Microsoft Excel Membuka Excel file:
Pilih pilihan menu pada data editor atau (Alt+F+O+A):

File Open... Pilih lokasi file yang ingin dibuka menggunakan pilihan Look in. Pilih Excel dari menu Files of type. File yang tersimpan tampak pada bkotak dialog Open File. Selanjutnya dapat dibuka dengan double-clicking.

Membuat &mendefinisikan variabel


Variabel dan value. Variabel : ukuran atau klasifikasi yang mempunyai beberapa value (nilai).

Value : angka /klasifikasi kategori yang menggambarkan variabel yang diukur. Contoh; pekerjaan sbg variabel diklasifikasikan sebagai staff (nilai 1), administratif (nilai 2), dan manajer (nilai 3).
Manfaat pendefinisian:
Membantu dalam menginterpretasi output Value yang tampil berupa label pada output Memberikan informasi mengenai skala data yang digunakan

You can define information about your variables by clicking the Variable Information tab. Doing so will bring the Variable Information sheet to the foreground. You can also access this sheet by double-clicking one of the gray boxes at the top of the columns in the Data Editor. The advantage of the second method is that it takes you to the row for the variable whose column head you clicked. Finally, you can also use the keystroke Ctrl+T to toggle between the windows. Regardless of the method you use, you will see a spreadsheet organized as the one below:

Hidden dialog box


Sel pada spreadsheet terdapat hidden dialog boxes yang dapat diaktivasi dengan mengklik sel ybs. Contoh; klik pada kotak sel untuk kolom Type pada variabel jobcat, membentuk kotak dialog disamping ini;

Penambahan dan penghapusan kasus dan variabel


Data Insert Variable Insert Case atau (Alt+D+V utk Variabel dan Alt+D+I untuk kasus)

Menghitung variabel baru


Digunakan untuk memodifikasi nilai suatu variabel:
Misal umur dalam bulan diganti dengan umur dalam tahun Perhitungan dapat dilakukan pada variabel yang berskala numerik. Gunaka Compute dari menu pada Data Editor atau (Alt+T+C):

Transform Compute...

Recoding variabel
Nilai suatu variabel dapat diubah dengan melakukan Recoding Misal yang semula jenis pekerjaan tdd 3 kategori, ingin diubah menjadi 5 kategori Recode option atau (Alt+T+R) is available from the menu in the Data Editor: Transform Recode Recoding pada variabel yang sama (Alt+T+R+S) atau pada variabel baru maka (Alt+T+R+D) harus digunakan.

Pemilihan kasus
Digunakan saat akan menganalisa subset data yang spesifik Dilakukan dengan menggunakan option Select Cases Dapat menghapus kasus secara permanen atau sementara. Lakukan (Alt+D+C) Data Select Cases...

Statistik deskriptif
Tahap awal dalam analisis data adalah meringkas informasi variabel yang ada seperti nilai rerata, varians dan lain lain yang merupakan statistik deskriptif. Beberapa statistik deskriptif dimaksud terdapat pada option Descriptives yang terdapat pada menu Analyze dan Descriptive Statistics: Analyze Descriptive Statistics Descriptives...

Pilih variabel yang akan dianalisis dengan; Klik pada nama variabel Klik tanda panah utk memindahkan variabel ke kotak variable(s)

Output deskriptif
Klik pilihan statistik yang diinginkan Klik tanda Continue di Options kotak dialog, Lalu klik OK pada kotak dialog Descriptives dialog. Contoh; dihasilkan perhitungan berikut;

Frekuensi
Untuk data kategorikal digunakan perhitungan frekuensi. Prosedur perhitungan frekuensi sebagai berikut Analyze Descriptives Statistics Frequencies...

Output frekuensi

Pembuatan Grafik
Mengklik Statistics menghasilkan kotak dialog dengan berbagai pilihan statistik deskriptif tambahan. Mengklik Charts menghasilkan kotak disamping untuk membuat grafik

Kurve normal
Dengan kurve normal memungkinkan kita menilai apakah data terdistribusi normal atau tidak untuk menentukan statistik infrensial yang digunakan. Penilaian distribusi normal ini jjuga dapat dengan prosedur Explore di menu Descriptives

Tabel silang
Prosedur Crosstabs berguna untuk menjelaskan hubungan antara 2 variabel. Prosedur: Analyze Descriptive Statistics Crosstabs

Klik pada Statistics memungkinkan kita untuk memilih uji statistik yang sesuai Klik pada Cells memungkinkan untuk menampilkan beberapa informasi masing masing sel dalam tabel silang.

Output tabel silang

Statistik inferensial
Chi-Square Test Uji Chi-square test terdapat pada kotak dialog Crosstabs dengan mengklik Statistics

Uji T
Uji T digunakan untuk membandingkan 2 nilai rerata. Terdapat 3 jenis uji T dengan pilihan pada menu Analyze: Analyze Compare Means One-Sample T test... Independent-Samples T test... Paired-Samples T test...

Contoh hasil uji T

Korelasi
Korelasi adalah pengukuran hubungan linier antara 2 variabel. Koefisien korelasi berkisar antara -1 s/d 1. Prosedur penghitungan korelasi; Mulai dengan menu Analyze Pilih Correlate dan terdapat 3 pilihan (1) Bivariate, (2) Partial, and (3) Distances. Korelasi bivariat dipakai hanya untuk 2 variabel Korelasi partial untuk pengukuran hubungan 2 variabel tetapi memperhitungkan satu atau lebih faktor lain. Analyze Correlate Bivariate...

Contoh hasil korelasi bivariat

Penyajian data
Tabel Ekspor tabel di SPSS Grafik Bar Scatterplots Modifikasi dan ekspor grafik Chart interactif

Contoh scatterplot
Scatterplots suatu tool visualisasi hubungan antara 2 atau lebih variabel seperti ppada uji korelasi dan regressi Prosedur Graphs Scatter...

Simple Scatterplot

Simple scatterplot

PRAKTIKUM

Latihan SPPS 10.05


1. 2. 3. 4. Pembuatan formulir entri data Entri data Verifikasi data Regruping data
4.1 Buat variabel baru (isi sama dengan variabel lama) 4.2 Recoding variabel baru 4.3 Langkah recoding

5. Tabel deskriptif dengan Custom Tables 6. Penggabungan files

Cuplikan formulir kunjungan rumah PBL I 2003

Contoh satu tabel akhir untuk laporan atau presentasi

Dibuat dengan CUSTOM TABLE dan dimodifikasi dengan program WORD

Data set yang diperlukan

1. Pembuatan data set


1) Pembuatan variabel pada variable view 2) Entri data pada data view

1) Membuat variabel pada variable view

2) Entri data pada data view

2. Pembuatan formulir data entri


1) Pilih variable view 2) Buat variabel-variabel 3) Pilih jenis variabel 4) Buat VALUE variabel (jika perlu)

1) Pilih variable view

2) Ketik SEMUA variabel pada VARIABLE VIEW

Type variabel

3) Ketik ISI (value) variabel yang diperlukan pada variabel, misalnya nama DESA

4) Ketik ISI yang diperlukan pada SEMUA variabel Misalnya, STATUS PERAWINAN, PENDIDKAN RESPONDEN dan BOJO, dst.

2. Entri data

Mengerjakan Data Entri

Entri data harus cermat dan seksama

1) Pilih Data View

2) Lakukan Data Entry Save secara teratur

3. Verifikasi data
1) Sorting 2) Tabel deskiptif 3) Tabel frekuensi

Sorting dapat dilakukan ascending atau descending

Verifikasi data dengan analisis Descriptive


1) 2)

Descriptiv e Statistics N Desa Jenis kelamin Umur Status perkawinan Jenis rumah Lanta lumah Valid N (listwise) 539 539 539 539 537 536 536 Minimum 1 1 18 1 0 0 Maximum 13 2 90 5 99 99 Mean 5,98 1,72 43,93 1,45 2,95 2,51 Std. Deviation 4,39 ,45 16,86 ,99 4,19 4,22

Hasil deskriptif ternyata terdapat kesalahan atau keganjilan data??

Verifikasi data dengan analisis FREKUENSI

Jenis kelamin Cumulative Percent 28,4 100,0

Valid

Laki-laki Perempuan Total

Frequency 153 386 539

Percent Valid Percent 28,4 28,4 71,6 71,6 100,0 100,0

Hasil gender OK!

Jenis rumah Cumulative Percent ,9 3,7 18,6 99,8 100,0

Valid

Missing Total

0 Darurat Semi permanen Permanen 99 Total System

Frequency 5 15 80 436 1 537 2 539

Percent Valid Percent ,9 ,9 2,8 2,8 14,8 14,9 80,9 81,2 ,2 ,2 99,6 100,0 ,4 100,0

Hasil frekuensi ternyata terdapat kesalahan atau keganjilan data

4. Regrouping data

4. Regrouping data
Misalnya,

Tekanan darah sistolik, TDS, (data kontinu) ingin diubah menjadi 4 grup berdasarkan kriteria JNC 7 TDS aktual (data kontinu) TDS 4 grup (menurut JNC 7) (data ordinal) 0= 1= 2= 3= 120 120 139 140 159 160 (Normal) (Prehipertensi) (Stage 1) (Stage 2)

75 sampai 260

Langkah utama regrouping data


1) Buat variabel baru (isi sama dengan variabel lama)!! 2) Recoding variabel baru 3) Buat isi (value) variabel baru

Variabel yang asli jangan diregrouping!!!

Langkah REGRUPING data


1) Pilih transform, compute
4)

2) Compute newvar = oldvar sistgnc7 = n1_sisto

5)

2)

6) 3)

Hasil computasi dan recoding


Tampilan TANPA Value label

Tampilan dengan value label

5. Pembuatan Tabel Deskriptif dengan CUSTOM TABLES

Langkah Pembuatan CUSTOM TABLES 1) Output dapat di-copy dan diedit dengan WORD
Tahun survei 2002,00 Count Col % 72 13,4% 78 14,5% 86 16,0% 75 13,9% 75 13,9% 78 14,5% 75 13,9% 153 28,4% 386 71,6% 430 79,8% 38 7,1% 13 2,4% 54 10,0% 4 ,7%

Desa

2)

Jenis kelamin Status perkawinan

3)

Ciburuy Cisalada Pasir Jaya Cibalung Cipelang Warung Menteng Cijeruk Laki-laki Perempuan Kawin Belum Cerai Janda Duda

Buat interpretasi dan uraian tekstular!!!

6. Pengggabungan files
File 3

Desa Pasir Jaya

File gabungan
File 2 Desa Cisalada File 1 Desa Ciburuy

3 Desa

Cara Merge Files:


Pilih data Merge File, Add Cases - Pilih file yang akan ditambahkan - Jika semua variabel tidak ada yang Unpaired - Tekan OK

Pada waktu melakukan Merge Files (Add Cases), uratan dan semua nama variabel serta valuenya harus sama

Nah mari kita


latihan bersamo

Latihan SPPS 10.05


1. 2. 3. 4. Pembuatan formulir entri data Entri data Verifikasi data Regruping data
4.1 Buat variabel baru (isi sama dengan variabel lama) 4.2 Recoding variabel baru 4.3 Langkah recoding

5. Tabel deskriptif dengan Custom Tables 6. Penggabungan files

Latihan 1. Lakukan wawancara imajinatif pada suatu keluarga dengan mempergunakan formulir PBL I 2003 seperti di atas s/d butir C6. 2. Buat formulir lengkap entri data dengan SPSS 10 3. Lakukan entri data s/d butir C6 4. Lakukan verifikasi data 5. Lakukan regruping data untuk variabel pendidikan responden 6. Buat tabel deskriptif beberapa variabel demografi responden

Anda mungkin juga menyukai