Anda di halaman 1dari 97

LAPORAN PRAKTIKUM I TEKNIK INFORMATIKA PENGENALAN DATABASE, DATABASE RELATIONSHIP, QUERY, FORM, DAN REPORT

Disusun Oleh : Luthfi Yusuf 211 341 015 1AEA

TEKNIK OTOMASI MANUFAKTUR DAN MEKATRONIKA POLITEKNIK MANUFAKTUR NEGERI BANDUNG APRIL 2012

KATA PENGANTAR Puji dan syukur penulis panjatkan kepada Allah SWT yang telah melimpahkan rahmat dan karunia-Nya, sehingga penulis dapat menyelesaikan Laporan Praktikum 1 Teknik Informatika ini. Laporan ini merupakan realisasi dari hasil kegiatan perkuliahan berupa praktikum Teknik Informatika yang penulis lakukan untuk melaksanakan kewajiban sebagai mahasiswa kepada dosen/instruktur mata kuliah praktikum teknik informatika. Kami menyadari bahwa laporan ini jauh dari sempurna. Dalam penulisan laporan ini, penulis masih banyak memiliki kekurangan dan kesalahan dalam penulisan ataupun penyusunan laporan. Untuk itu, penulis mengharapkan saran dan kritik untuk lebih menyempurnakan laporan ini dan menjadi bahan pertimbangan penulisan dan penyusunan laporan yang selanjutnya. Bandung, 16 April 2012

Penulis

PENDAHULUAN
Database (Basis Data ) adalah himpunan kelompok data (arsip) yang saling berhubungan yang diorganisai sedemikian rupa agar kelak dapat dimanfaatkan kemabali denagan mudah. Tujuan dari Database adalah : Kecepatan dan kemudahan (speed), Efesiensi ruang penyimpanan (spaace), Keakuratan (acccuracy), Ketersediaan (availability), Kelengkapan (Completeness), Keamanan (Scurity) dan Kebersamaan pemakaiaan (sharability). Database memiliki dua bahasa yaitu DDL (Data Definition Language) dan DML (Data Manipulation Language). a. DDL Skema basis data dispesifikasikan oleh sekumpulan definisi dengan sebuah bahasa khusus yang disebut Data Definition Language ( DDL ).Hasil kompilasi DDL berupa tabeltabel yang disimpan dalam sebuah file,disebut Data Dictionary ( Kamus Data ) atau Data Directory. b. DML Adalah bahasa untuk memanipulasi data yaitu : - Pengambilan Informasi yang disimpan dalam Basis Data - Penyisipan Informasi baru ke Basis Data - Penghapusan Informasi dari Basis Data - Modifikasi Informasi yang disimpan dalam Basis Data.

Pratikum I
Pengertian Microsoft Access 2007

Microsoft Access adalah suatu program aplikasi basis data komputer


relasional yang digunakan untuk merancang, membuat, dan mengolah berbagai jenis data dengan kapasitas yang benar.

Database adalah kumpulan tabel-tabel yang saling berelasi. Antar tabel yang
satu dan yang lain saling berelasi sehingga sering disebut basis data relasional. Relasi antar tabel dihubungkan oleh suatu key, yaitu primary key dan foreign key. Tampilan Microsoft Access

Tampilan awal Microsoft access

Status bar Microsoft access Komponen Utama Microsoft Access Table adalah objek utama dalam database yang digunakan untuk menyimpan sekumpulan data sejenis dalam sebuah objek. Table terdiri atas : a. Field Name : atribut dari sebuah table yang menempati bagian kolom. b. Record : Isi dari field atau atribut yang saling berhubungan yang menempati bagian baris. 2. Query ( SQL / Structured Query Language ) Query adalah bahasa untuk melakukan untuk manipulasi terhadap database. Digunakan menampilkan,

1. Table

mengubah, dan menganalisa sekumpulan data. Query dibedakan menjadi 2, yaitu : DDL ( Data Definition Language ) digunakan untuk membuat atau mendefinisikan objek-objek atau skema database seperti membuat tabel, relasi antar tabel dan sebagainya. Contoh : CREATE, ALTER, MODIFY.

DML ( Data Manipulation Language ) digunakan untuk data serta mengambil informasi yang

manipulasi database, seperti : menambah, mengubah atau menghapus DELETE. 3. Form Form digunakan untuk mengontrol proses masukan data (input), menampilkan data (output), memeriksa dan memperbaharui data. 4. Report Objek database yang digunakan untuk menampilkan laporan hasil analisa data. Laporan di buat dapat dikelompokan, dihitung total dan subtotalnya berdasarkan kriteria tertentu. Laporan dapat berisi grafik atau label data. diperlukan dari database. Contoh : INSERT, UPDATE,

Tipe Data Field - field dalam sebuah tabel harus ditentukan tipe datanya. Ada beberapa tipe data dalam Access, yaitu : 1. Text

Text digunakan untuk field alfanumeric (misal : nama, alamat, kode pos, telp), sekitar 255 karakter tiap fieldnya. 2. Memo

Memo dapat menampung 64000 karakter untuk tiap fieldnya, tapi tidak bisa diurutkan/diindeks. 3. Number

Number digunakan untuk menyimpan data numeric yang akan digunakan untuk proses perhitungan matematis. 4. Date/Time

Data berupa tanggal atau waktu.Merupakan Niali data tunggal dan waktu untuk tahun 100 sampai 9999. 5. Currency

Data nilai uang atau angka yang dapat dipergunakan dalam perhitungan matematik Termasuk data 1 sampai 4 angkadi belakang tanda desimal. 6. Auto Number

Data angka yang berurutan dan unik (Tidak ada yang sama) yang secara otomatis diberi access jika record data baru ditambahkan kedalam table. Data jenis ini tidak dapat diubah. 7. Yes/No

Data yang memiliki hanya dua Kemungkinan nilai, sepaerti Ya/Tidak, benar/salah, atau on/off. 8. OLE Object

OLE Object digunakan untuk eksternal objek, seperti bitmap atau file suara.

9. Hyperlink Data yang berisi sambungan (link) ke objek lain pada jaringan internet, dengan menglink dataini dalam tabledapat membuka dan menampilkan objek tersebut. 10.Lookup Wizard

Jika menggunakan tipe data ini untuk sebuah field, maka bisa memilih sebuah nilai dari tabel lain atau dari sebuah daftar nilai yang ditampilkan dalam combo box. Membuka Microsoft Access Dan Database Langkah langkah untuk membuka Microsoft Access dan membuat database : 1. 2007 2. 3. Kemudian akan tampil jendela Microsoft Access seperti gambar di bawah ini, lalu klik Blank Database untuk membuat database. Membuat database (Nama File).accdb kemudian click tombol create. Click Start All Program Microsoft Office Microsoft Access

Membuat Tabel Langkah langkah untuk membuat tabel : 1. Click tab Create pada jendela 2. Click Table Design pada ribbon Tables

Properti Field Field size

Fungsinya Menentukan lebar maksimum data yang dapat dimasukan ke dalam field. Properi ini ada pada tipe data teks, number, dan autonumber.

Format

Mengatur tampilan data angka, tanggal, waktu, dan teks pada layar monitor maupun printer. Pilihan format yang telah didefinisikan dapat dipilih salah satu atau embuat format sendiri mengunakan simbol-simbol format

Input Mask

Menentukan tampilan data setelah dimasukan ke dakam field. Properti ini dapat digunakan unuk mengendalikan nilai data yang dapat dimasukan ke dalam field.

Decimal Places Caption Default Rule Validation Rule Validation Text

Menentukan jumlah angka desimal dibelakang data angka. Menampilkan informasi untuk pengguna seperti judul kolom, from, atau laporan. Menentukan data yang otomatis dimasukan kedalam field ketika record data baru dimasukan kedalam tabel Membatasi data yang dimasukan kedalam field Menampilan Teks keterangan atau pesan jika data yang dimasukan ke dalam field diluar batasan yang telah ditentukan pada field.

Required

Menentuka apakah nilai kosong atau Zero length string ( )adalah data yang sah. Pilihan yes jika data sah, pilihan no jika dianggap data tidak sah. Properti ini berlaku untuk tipe data teks, memo, dan hyperlink.

Indexed

Membuat indeks pada field

Latihan Praktikum I
1. Buat tabet dan atur format beserta propertinya berdasarkan masing-masing tipe data yang dipakai. Untuk membuat table ada beberapa langkah yang harus kita lakukan : Tampilan pertama akan muncul gambar seperti di bawah ini

I.

Klik kanan kemudian pilih design view

II.

Setelah memilih design view,akan keluar kotak seperti ini :

Masukkan nama table pada kotak tersebut,kemudian klik Ok.

Setelah itu akan keluar tampilan seperti gambar dibawah ini :

Isi sesuai dengan type data yang digunakan Isi Field name

Menunjukkan ukuran dari dan jenis dari field name.

a. Tabel Nasabah

b. Tabel Cabang

c. Tabel tabungan

d. Tabel pinjaman

e. Petugas

Analisa Pada latihan praktikum I ini yang harus diperhatikan adalah menentukan Field size untuk tipe data Text pada field properties karna ini menunjukan jumlah data maksimum yang dapat disikan pada field tersebut. Selain itu juga kita harus menetukan primary key dengan tepat dan benar.

Pratikum II
Membuat Hubungan Antar Tabel I. Relationship Tabel Table relationship adalah relasi atau hubungan antara beberapa tabel dalam database yang kita miliki. Relasi antar tabel dihubungkan oleh primary key dan foreign key. Untuk membuat relationship maka masingmasing tabel harus memiliki primary key dan foreign key Primary Key Tabel memiliki primary key, yaitu suatu atribut yang tidak hanya mengidentifikasi secara unik suatu kejadian tetapi juga mewakili setiap kejadian dari suatu entitas. Contoh Kasus : NIM dalam tabel Mahasiswa merupakan nilai unik yang tidak mungkin bersifat ganda. Karena setiap mahasiswa memiliki NIM yang berbeda antara mahasiswa yang satu dengan mahasiswa yang lain. Foreign Key

Foreign key adalah atribut yang melengkapi relationship dan menunjukkan hubungan antara
tabel induk dengan tabel anak . Foreign key ditempatkan pada tabel anak untuk dapat menghubungkan antara tabel induk dengan tabel anak. Ada beberapa macam Relationship, yaitu: A. Hubungan satu ke satu Setiap record data pada tabel pertama hanya bersesuaian dengan satu record data pada tabel kedua dan seballiknya. B. Hubungan satu ke banyak Suatu record data pada tabel pertama bersesuaian dengan banyak record data pada tabel kedua. Tetapi satu record data pada tabel kedua bersesuaian dengan hanya satu record data pada tabel pertama.

C. Hubungan banyak ke banyak Satu record pada tabel pertama bersesuaian dengan banyak record data pada tabel kedua. Satu record data pada tabel kedua bersesuaian dengan banyak record pada tabel pertama.

II.

Membuat Hubungan Tabel Langkah langkah untuk membuat database relationship: 1. Clik tab database Tools pada jendela 2. Clik Relationship pada ribbon show/hide

3. Kemudian akan muncul tab relationship pada object tab dan kotak dialog 4. Show table, kemudian pilih tab tables

5. Click tabel yang yang akan dibuat hubungan relationship dan click button Add, kemudian hubungkan kedua tabel tersebut

6. Kemudian akan muncul kotak dialog relationship . click checkbox Enforce Referential Integrity, lalu click button Create. III. Membuat hubungan Satu ke Satu antara dua tabel Jika mempunyai dua tabel yang mempunyai field kunci primer dapat membuat hubungan satu ke satu antara kedua tabel, caranya adalah sebagai berikut: 1. Tunjuk field kunci primer pada tabel pertama dalam jendela hubungan tabel 2. Kemudian seret field kunci primer ke field kunci primer pada tabel lain 3. Setelah tepat, lepaskan penekanan tombol mouse. Pada layar monitor terlihat kotak dialog edit relatioship untuk membuat hubungan tabel, ditunjukan gambar dibawah ini

4. Pada bagian bawah kotak dialog terlihat tipe hubungan satu ke satu (one to one).klik tombol crate pada kotak dialog dan membuat hubungan satu ke satu antara dua tabel. Tabel yang dihubungkan ditandai dengan garis yang menghubungkan antara kedua field terlihat seperti gambar dibawah

IV.

Membuat Hubungan Satu kebanyak antara dua tabel Cara membuat hubungan satu ke banyak adalah dengan: 1. Buka jendela hubungan tabel 2. Masukan tabel yang akan dihubungkan 3. Seret field kunci primer pada tabel pertama ke field lain pada tabel kedua 4. Lepaskan penekanan tombol mouse setelah tepat, maka pada layar monitor terlihat kotak dialog edit relationship seperti gambar dibawah ini

5. Pada bagian kotak dialog terlihat tipe hubungan satu ke banyak(One to many). Kemudiak klik crate pada kotak dialog untuk menutup kotak dialog dan membuat hubungan satu ke banyak antaradua tabel seperti ditunjukan gambar dibawah ini.

V.

Membuat hubungan Satu ke banyak antara dua tabel Hubungan Satu kebanyak yang melibatakan tiga tabel terlihat seperti gambar dibawah ini.

VI.

Mengubah Hubungan Tabel Hubungan antara dua tabel yang telah ditentukan dapat diedit melalui langkah: 1. Buka jendela hubungan tabel dari database 2. Klik ganda hubungan antara dua tabelyang akan diedit untuk menampilkan kotak dialog edit relationships. 3. Pada tabel/query pilih tabel pertama yang ingin dihubungkan dan dibawahnya pilih field yang digunakan untuk menghubungkan tabel. Pada rlated table/query

pilih tabel kedua yang ingin dihubungkan ke tabel pertama dan dibawahnya field yang digunakan untuk menghubungkan tabel ke tabel pertama . 4. Klik kotak cek enforce Referential Integrity untuk memberi tanda pada cek pada pilihan ini jika ingin mengunakan aturan Referential Integrity pada hubungan tabel. 5. Klik kotak cek pilihan Cascade Update Related Fields untuk memberi tanda cek pada pilihan ini jika ingin perubahan data field kunci primer pada tabel pertama secara otomatis mengubah data pada record-record yang bersesuaian dalam tabel kedua. 6. Klik kotak cek pilihan Cascade Delete Related Records untuk memberi tanda cek pada pilihan ini jika ingin penghapusan record pada tabel pertama secara otomatis. Menghapus record-record yang bersesuaian dalam tabel kedua, sehinggga kotak dialog Edit Relationships terlihat seperti gambar dibawah ini.

7. Klik tombol join untuk menampilkan kotak dialog Join Properties ditunjukan gamabr dibawah ini

8. Klik tombol 1 ,jika hanya ingin menampilkan record-record yang bersesuaian dari kedua tabel yang berhubungan. Klik tombol pihan 2 jika ingin menampilkan semua record dalam tabel yang dihubungkan dan hanya record-record yang bersesuaian pada tabel pertama. Klik tombol pilihan 3 jikaingin menampilkan

semua record dalam tabel pertama dan hanya tabel-tabel yang bersesuaian pada tabel kedua. 9. Setelah mengubah tipe penggabungan tabel, klik tombol ok untuk menutup kotak dialog Join Properties. 10. Klik tombol Create New untuk menampilkan kotak dialog create New, terlihat pada gambar dibawah ini.

11. Pada Left Table Name pilih tabel pertama yang ingin dihubungkan dan pada kotak Left Column Name dibawahnya pilih field yang digunakan untuk menghubungkan tabel . pada Right Table Name pilih tabel kedua yang ingin dihubungkan ke table pertama dan pada kotak Right Column Name dibawahnya pilih field yang digunakan untuk menghubungkan tabel ke tabel pertama. 12. Klik tombol Ok pada kotak create new untuk menutupnya dan kembali ke kotak dialog edit relatioships danmembuat hubungan baru. 13. Klik tombol OK untuk menutup kotak dialog Edit Relationships dan menggunkan pilihan yang ditentukan pada hubungan tabel.

Latihan Praktikum II
1. Buat Relationship studi kasus BANK dengan lengkap sesuain dengan entity relationship diagram yang telah dirancang.

Hasil Praktikum

Setelah membuat relationship,barulah kita dapat mengisi table yang telah kita buat dengan data. Gambar Tabel Nasabah :

Gambar Tabel Cabang :

Gambar Tabel Tabungan

Gambar Tabel pinjaman

Gambar Tabel Petugas

Gambar table melayani

Analisa : Yang harus diperhatikan pada praktikum kedua adalah ketepatan menarik garis relasi antar tabel karna jika salah maka data tidak dapat dimasukan kedalam sel serta harus memperhatikan Primary key dan Foreign Key.

Praktikum III Mengunakan Form Untuk Menampilkan Data


Form adalah komponen utama yang terintegrasi secara khusus dan berfungsi sebagai: a. Input data b. Mengedit dan menampilkan data c. Mengontrol application flow. d. Mencetak informasi 3.1 Membuat Form Dalam tampilan Desain Membuat Form dalam tampilan desain dapat mengikut langkah-langkah berikut: 1. Buka file database tempat akan dibuatkan form. 2. Klik Forms pada bar objek database untuk membuat Form. 3. Klik ganda pilihan Create form in design view untuk menampilkan jendela desain form pertama dan bar tombol toolbox. 4. Seret bar tombol toolbox dan letakan di bawah bar tombol lainya supaya tidak mengganggu kegiatan pembuatan form. 5. Seret tepi kiri area grid ke kanan atau tepi bawah ke baawah untuk menyediakan area grid yang sesuai dengan ukuran form yang akan dibuat terlihat seperti gambar 1

Gambar 1 Jendela Desain form dengan bar tombol toolbox 6. Pastikan objek form dipilih pada kotak object bar tombol formating (Form/Report) 7. Klik Toolbar Add Existing Fields. 8. Seret letakan field pada form untuk membuat form yang dibutuhkan. Setelah selesai form yang dibuat terlihat pada gambar 2.

Gambar 2. Form yang dibuat dalam tampilan desain 3.2. Menyimpan Form Setelah Form di buat dapat disimpan dengan mengikuti langkah berikut: 1. Klik menu File dan klik perintah Save As untuk menampilkan kotak dialog Save As. 2. Pada Kotak save Form Name Isikan nama Form yang dinginkan terlihat seperti gambar 3

Gambar 3 Kotak Dialog Save As 3. Kemudian klik tombol OK untuk menutup kotak dialog Save As

3.3. Membuat Form Menggunakan Wizard Form dengan menggunakan wizard dapat dilakukan dengan langkah berikut : 1. Click tab Create pada jendela 2. Click More Form pada ribbon Forms,kemudian pilih Form wizard. Sehingga akan muncul kotak dialog wizard ditunjukan gambar 4.

Gambar 4 kotak dialog Form Wizard dengan pilihan field 3. Memilih tabel yang atribut-atributnya akan digunakan. 4. Click tombol atau untuk memilih atribut atribut yang akan ditampilkan

dalam form, ditunjukan gambar 5.

Gambar 5 Pemilihan Atribut

Gambar 6 Kotak dialog Wizard dengan pilihan layout Form

Gambar 7 Kotak dialog Wizard dengan pilihan style form

Gambar 8 Kotak dialog Wizard ddengan nama form 5. Pada kotak dialog What title do you want for your form? , ketikan nama form. Klik tombol pilihan Open the form to view or enter information jika ingin membuka form untuk menampilkan atau memasukan informasi atau klik tombol pilihan Modify the

forms design untuk memodifikasi desain form. Sehingga terlihat seperti gambar 8.
6. Klik tombol Finish untuk menutup kotak dialog dan membuat form sesuai dengan informasi yang dimasukan pada kotak dialog form Wizard,terlihat seperti gambar 9.

Gambar 9. Tampilan Form dengan Wizard

3.4.

Tombol Toolbox Form yang telah dibuat belum lengkap, sehingga dapat menggunakan kontrol

pada bar tombol toolbox untuk melengkapi form yang telah dibuat. Tombol , nama tombol dan fungsi tombol pada tabel 1. Tabel 1 Tombol, nama tombol dan fungsi tombol toolbox Tombol Nama Tombol Select Object Control Wizards Label Text Box Option Group Tonggle Button Option Button Check box Combo box List box Command Button Image Unbound Object Frame Bound Object Frame Page Break Tab Control Subform/ Subreport Line Rectangle Fungsi Memilih objek pada Form Mengaktifkan mode wizard untuk menjalakan wizard Memasukan label kedalam form Memasukan kotak teks kedalam form Memasukan kotak kelompok tombol pilihan ke dalam form Memasukan tombol tonggle kedalam form Memasukan tombol pilihan kedalam form Memasukan kotak cek kedalam form Memasukan kotak combo ke dalam form Memasukan kotak daftar pilihan kedalam form Memasukan tombol perintah kedalam form Memasukan gambar kedalam form Memasukan frame objek tidak terkait kedalam form Memasukan frame objek terikat kedalam form Memasukan kontrol perpindahan halaman ke halaman form Memasukan kontrol tab ke dalam form Memasukan subform atau sub report kedalam form Menggambar garis pada form Menggambar persegi panjang pada form

More Controls

Memasukan kontrol-kontrol lainnya ke dalam form.

3.5.

Aksi pada Tombol Perintah (

Tombol perintah berisi aksi yang dapat melengkapi sebuah form. Kategori dan aksi pada tombol perintah dijelaskan pada tabel 2. Tabel 2. Kategori, Aksi dan Fungsi tombol perintah Kategori Find Next Find Record Record Navigation Go To First Record Go To Last Record Go To Next Record Go To Previous Record Add New Record Record Operation Delete Record Duplicate Record Print Record Aksi dicari Menemukan record data yang dibutuhkan Pindah ke record pertama Pindah ke record data terakhir Pindah ke record data selanjutnya Pindah ke record data sebelumnya Menambah record data Menghapus record data Menduplikasi record data Mencetak record data Fungsi Menemukan record selanjutnya yang

Save Record Undo Record Apply Form Filter Close Form Edit Form Filter Form Operations Open Form Open Page Print a Form Print Current Form Refresh From Data Mail Report Report Operations Preview Report Send Report To File Print Report Quit Aplication Run Apication Aplication Run MS Excel Run MS Word Run Notepad Miscellaneous Auto Dialer Print Table Run Macro Run Query 3.6.

Menyimpan record data Membatalkan penambahan record data Mengaplikasikan filter form Menutup form Mengedit filter form Membuka form Membuka halaman akses data Mencetak form Mencetak form yang ditampilkan Memperbaharui data form Mengirim laporan dengan e-mail Menampilkan bentuk cetak laporan Menyimpan laporan dalam file Menyimpan laporan dalam file Keluar dari aplikasi Menjalankan aplikasi Menjalankan Excel Menjalankan Word Menjalankan Notepad Memutar nomor telepon Mencetak Table Menjalankan Macro Menjalankan Query

Memasukan Tombol Perintah pada Form

Form yang telah dibuat dapat dilengkapi dengan tombol perintah dengan langkah sebagai berikut: 1. Buka form yang akan diberi tombol perintah 2. Pastikan tombol kontrol wizard aktif pada tombol ini 3. Klik tombol Command Button pada bar tombol toolbox, maka petunjuk mouse berubah bentuk menjadi tanda plus (+) dan tombol perintah. dan terlihat border

4. Tunjuk pada form di tempat tombol perintah akan diletakan. Seret ke bawah dan ke kanan untuk menggambarkan tombol perintah yang akan dibuat sesuai dengan ukuran yang dibutuhkan form. Kemudian lepaskan penekanan tombol mouse , pada layar monitor terlihat kotak dialog Command Button Wizard dengan kategori dan aksi tombol perintah. 5. Klik kategori (record navigation ) dan aksi (Go to NextRecord) yang akan digunakan pada tombol, sehingga kotak dialog command Button Wizard terlihat seperti gambar 10.

Gambar 10 Kotak Dialog Button Wizard 6. Klik tombol Next untuk melanjutkan wizard. Pada kotak dialog terlihat pilihan teks atau gambar yang akan dibuat pada tombol. Pilih tampilan dari tombol teks atau gambar sesuai petunjuk pada tombol perintah, sehingga kotak dialog Command Button Wizard seperti gambar 11 .

Gambar 11. Kotak Dialog Button Wizard dengan pilihan teks 7. Lanjutkan wizard dengan mengklik tombol next, pada kotak dialog terlihat informasi nama untuk tombol perintah. 8. Pada kotak A meaningful name will help you to refer to the button later ketikan nama tommbol perintah ,terlihat seperti gambar 12. 9. Klik tombol finish untuk menutup kotak dialog Command Button Wizard,tombol perintah dibuat pada form dengan teks petunjuk sesuai dengan pilihan yang diamasukan pada kotak dialog seperti terlihat pada gambar 12.

Gambar 12. Kotak Dialog Button Wizard dengan nama tommbol perintah

Gambar 13. Form dengan tombol perintah yang dibuat 10. Lakukan langkah 3 sampai 9 untuk memasukan tombol-tombol perintah lain sehingga terlihat seperti gambar 13. 11. Simpan perubahan form dan tampilkan dalam tampilan form. 12. Melakukan masukan, dan edit record data dengan tombol perintah yang telah dibuat pada form dan melengkapi dengan tommbol navigasi.

Gambar 14. Form dengan tombol perintah Go to Next Record, previous record, first record,last record, print form dan close record

Tampilan-tampilan form yang telah dibuat : Form Melayani

Form nasabah

Form Cabang

Form petugas

Form Pinjaman

Form Tabungan

Praktikum IV Membuat Query


Query adalah permintaan yang diberikan oleh user untuk mengambil informasi yang tersimpan dalam database. Fungsi dari Query adalah untuk menyaring dan menampilkan data dari berbagai criteria dan urutan yang kita kehendaki.

I.

Jenis Query
Ada beberapa jenis query yang mempunyai kegunaan, dijelaskan dalam tabel 1 berikut. Tabel 1 Jenis-jenis Query

Jenis Query Query Pemilihan (Select Query)

Keterangan Query ini merupakan query yang paing umum, digunakan untuk menyaring dan menampilkan data tertentu dari satu atau lebih tabel. Query pemilihan dapat digunakan untuk mengelompokan record data dan menghitung jumlah total, jumlah data, dan ata-ratanya.

Query Parameter (Parameter Query)

Query yang dijalankan menampilkan kotak dialog untuk meminta informasi yang digunakan sebagai kriteria untuk menyaring data atau nilai yang ingin dimasukan ke dalam field

Query Crosstab (Crosstab Query)

Query yang digunakan untuk menganalisa data dengan menampilkan data-data yang telah diolah (jumlah total, jumlah data, dan rata-rata) dari suatu field dan mengelompokan data pada bagian kiri lembar data.

Query Aksi (Action Query)

Query aksi digunakan untuk membuat perubahan satu atau beberapa record data sekaligus. Query aksi ada 4 jenis, yaitu query menghapus record data pad satu atau lebih tabel, query mengubah (update query) untuk membuat perubahan record data pada satuatau lebih tabel, query menambah (appnend query) untuk menambahkan record data dari satu atau lebih tabel kedalam satu atau lebih tabel,dan query membuat tabel (make-table query) untuk membuat tabel baru dari seluruh atau sebagian data dalam satu atau lebih tabel

Query SQL (SQL Query)

Query SQL dibuat dengan pernyataan SQL. Query ini

terdapat tiga jenis,yaitu query penggabungan (union query) untuk menggabungkan field (kolom) dari satu atau lebih tabel atau query kedalam satu field (kolom) query yang dibuat, query langsung (pass-through query) untuk mengirimkan perintah secara langsung ke ODBC database, query definisi data (data definition query) untuk membuat objek database.

II.

Membuat Query dalam Tampilan Desain


Langkah membuat query dalam tampilan desain: 1. Buka file database yang akan membuat query 2. Klik queries pada bar objek, pada bagian kanan jendela database terlihat dua pilihan untuk membuat query. 3. Klik ganda pilihan create query in design view, pada layar monitor terlihat jendela query pemilihan pertama untuk mendesain query dan kotak dialog Show Table untuk memasukan tabel sumber data query yang akan dibuat. 4. Pilih dan masukan tabel sumber data query yang akan dibuat menggunakan kotak dialog Show Table. Kemudian tutup kotak dialog Show Table. 5. Klik sel Table pada kolom pertama, kemudian pilih table yang akan digunakan sebagai sumber data Query yang akan di buat. 6. Klik sel field pada kolom pertama, kemudian pilih field pada tabel yang akan ditampilkan pada kolom pertama query. 7. Klik sel Sort pada kolom pertama dan pilih cara pengurutan data pada query. 8. Klik kotak cek pada sel Show untuk memberi tanda cek() jika ingin menampilkan data field pada query atau klik kotak cek kembali untuk menghilangkan tanda cek jika tidak ingin menampilkan data field pada query. 9. Klik sel Criteria pada kolom pertama dan ketikan kriteria yang menyaring data. 10. Lakukan pemilihan tabel , field yang ingin diatampilkan pada query, cara pengurutan, ditampilkan atau tidak, dan kriteria penyaringan data untu field-field lai query yang aka di buat, sehingga jendela desain query terlihat seperti gambar 1

Gambar 1. Query Design 11. Kemudian klik menu query, dan klik perintah Run pada jendela query

untuk penyaringan dan menampilkan data berdasarkan ketentuan yang dibuat pada query. Data field tabel yang dipilih pada query yang dibuat, ditampilkan pada gambar 2.

Gambar 2. Data hasil Query

III.

Membuat Field Perhitungan dalam query


Query dapat digunakan untuk melakukan perhitungan dalam tabel, dengan langkah: 1. Buka file database tempat query perhitungan akan dibuat 2. Buka query baru dalam tampilan desain 3. Masukan tabel-tabel sumber data yang akan dilakukan perhitungan 4. Pilih field-field yang ingin diatampilakan pada query dan sumber data untuk melakukan perhitungan. 5. Klik sel field pada kolom tampat akan melakukan perhitungan.

6. Kemudian ketikan nama field baru untuk menyimpan hasil perhitungan diikuti dengan tanda titik dua(:) dan operasi perhitungan dari field-field sumber data. Nama field yang terdiri dari lebih dari satu kata diapit tanda {}. Seperti gambar 6

Gambar 6. Desain query untuk melakukan perhitungan. 7. Kemudian jalankan query, seperti gambar 7

Gambar 7. Hasil Query

IV.

Query Dengan SQL View


1. Perintah dasar SQL SELECT Perintah SQL untuk menampilkan data memiliki cara penulisan sebagai berikut : SELECT * | [ kolom1,kolom2,...] FROM <nama table> [ WHERE <kondisi>]; o SELECT artinya memilih kolom atau field mana yang akan ditampilkan Dapat berupa list kolom, suatu persamaan (operasi aritmatika), fungsi, obyek tertentu Dapat diketikkan * yang artinya menampilkan semua field yang dimiliki oleh table

tersebut o o FROM menunjukkan nama Tabel yang akan ditampilkan WHERE untuk meletakkan definisi kondisi penyaringan Operator perbandingan yang dapat digunakan adalah : o o o = (sama dengan), (tidak sama dengan) LIKE (khusus untuk data char/varchar yang mencari data berdasarkan pola. Karakter khusus yang dapat dimasukkan dalam operator LIKE antara lain % untuk sembarang lebih dari satu karakter, _ atau garis bawah untuk mewakili sembarang satu karakter), o BETWEEN nilai_awal AND nilai_akhir (untuk menguji apakah suatu nilai berada di antara nilai_awal dan nilai_akhir), o >, >=, <, <= (lebih besar, lebih besar atau sama dengan, lebih kecil, lebih kecil atau sama dengan), IS NULL atau IS NOT NULL (digunakan untuk menguji apakah nilai suatu kolom kosong atau tidak) 3. Operator Logika Selain itu, jika kita memiliki dua atau lebih ekspreis perbandingan, anda harus menggunakan salah satu dari operator logika berikut: o AND, anda akan menghasilkan nilai true jika dan hanya jika kedua nilai yang dibangingkan bernilai true, o OR, akan menghasilkan nilai true jika dan hanya jija salah satu dari dua nilai yang dibandingkan bernilai True

2. Operator Perbandingan

4. Bentuk Umum SQL

SELECT DaftarField FROM namaTabel WHERE syarat catatan: SELECT, FROM dan WHERE disebut Klausa/perintah (ditulis apa adanya)
Menampilkan Seluruh field suatu tabel

Menampilkan seluruh field pada tabel TNasabah

SELECT * FROM TNasabah SELECT * FROM TCabang;

Menampilkan seluruh field pada tabel Tcabang Tampilkan seluruh field pada tabel TDeposito

SELECT * FROM TDeposito

Menampilkan beberapa Field

Tampilkan Nama dan Alamat pada Tabel TNasabah.

SELECT Nama_Nasabah, Alamat FROM TNasabah SELECT Nama_Cabang FROM TPinjaman


Filter data

Tampilkan Nama_Cabang saja pada tabel TPinjaman

Tampilkan semua isi field table Tnasabah yang tinggal di bandung

SELECT * FROM M TNasabah WHERE Kota_Tinggal = Bandung

Menampilkan data dari beberapa tabel Tampilkan Nama nasabah dan Nama cabang yang berasall dari tabel nasabah dan Deposito

SELECT Nama_Nasabah, Nama_Cabang FROM TNasabah, TDeposito WHERE Tnasabah.Nama_Nasabah = TDeposito.Nama_Nasabah

Menggunakan Nama field yang sama

Tampilkan NPM, NamaMahsiswa, KodeFakultas, NamaFakultas, KodeProdi, dan NamaProdi dari rabel Fakultas, Mahasiswa dan Prodi

SELECT NPM, NamaMahasiswa,Fakultas.KodeFakultas, NamaFakultas, Prodi.KodeProdi, NamaProdi, FROM Prodi, Mahasiswa, Fakultas WHERE (Fakultas.KodeFakultas = Prodi.KodeFakultas) AND (Prodi.KodeProdi = Mahasiswa.KodeProdi)
Operator Logika

Tampilkan NamaMahasiswa dengan Kodeprodi = 11 dan alamat = Bandung

SELECT NamaMahasiswa FROM Mahasiswa WHERE (KodeProdi = 11) AND (Alamat = Bandung) SELECT NIM, NamaMahasiswa FROM Mahasiswa WHERE Alamat = Bandung OR Alamat = maluku

Tampilkan NIM, NamaMahasiswa dengan Alamat=Bandung atau Alamat=maluku

Tampilkan NamaProdi dan NamaMahasiswa yang tinggal di Bandung

SELECT NamaProdi, NamaMahasiswa FROM Prodi, Mahasiswa WHERE Alamat=Bandung AND Prodi.KodeProdi = Mahasiswa.KodeProdi
Tampilkan NamaFakultas, NamaProdi, NIM, NamaMahasiswa yang tinggal di Bandung atau maluku

SELECT NamaFakultas, NamaProdi, NIM, NamaMahasiswa FROM Fakultas, Prodi, Mahasiswa WHERE (Fakultas.KodeFakultas = Prodi.KodeFakultas) AND (Prodi.KodeProdi = Mahasiswa.Kodeprodi) AND ((Alamat = Bandung) OR (Alamat=maluku))
Operator NOT

Tampilkan seluruh field tabel Mahasiswa yang tidak berlamat Bandung.

SELECT * FROM Mahasiswa WHERE ALAMAT <> Bandung

atau dengan menggunakan Klausa NOT dapat ditulis:

SELECT * FROM Mahasiswa WHERE NOT (ALAMAT = Bandung)


WILD CHAR

* (Asterisk) > artinya semua/bebas ? > Menggantikan satu huruf Tampilkan Nama Mahasiswa yang huruf depannya A

SELECT NamaMahasiswa

FROM Mahasiswa WHERE NamaMahasiswa LIKE A*

Tampilkan NamaMahasiswa yang huruf belangkangnya A

SELECT NamaMahasiswa FROM Mahasiswa WHERE NamaMahasiswa LIKE *A

Tampilkan NamaMahasiswa yang mengandung huruf a

SELECT NamaMahasiswa FROM Mahasiswa WHERE NamaMahasiswa LIKE *a* SELECT * NamaMahasiswa FROM Mahasiswa WHERE NamaMahasiswa LIKE ?A*
Pengurutan (ORDER BY)

Tampilkan NamaMahasiswa yang huruf keduanya a

Tampilkan NamaMahasiswa, Alamat dari Tabel Mahasiswa urut Alamat

SELECT NamaMahasiswa, Alamat FROM Mahasiswa ORDER BY Alamat;

Tampilkan Nama, Alamat dari tabel Mahasiswa urut Nama dengan urut menurun (Descending)

SELECT NamaMahasiswa, Alamat FROM Mahasiswa ORDER BY NamaMahasiswa DESC;

Tampilkan Alamat, Nama dari Tabel Mahasiswa urut Alamat, NamaMahasiswa

SELECT Alamat, NamaMahasiswa FROM Mahasiswa ORDER BY Alamat, NamaMahasiswa;


Fungsi Left (string,n)

Mengambil n karakter dari kiri suatu string.

Tampilkan 3 huruf nama mahasiswa

SELECT Left(NamaMahasiswa, 3) FROM Mahasiswa;

Tampilkan nama Mahasiswa yang huruf pertamnya

SELECT NamaMahasiswa From Mahasiswa WHERE LEFT(NamaMahasiswa,1) =A


Fungsi MID (string,i,n)

Digunakan untuk mengambil n karakter dari string mulai posisi ke i. Tampilkan 3 karakter mulai dari karakter kedua dari NamaMahasiswa;

SELECT MID(namamahasiswa, 2, 3) FROM Mahasiswa;

Jika terdapat nama inan maka akan tampil nan

Fungsi Right(string,n)

Mengambil n karakter dari Kanan suatu string.

Tampilkan 3 huruf terakhir nama mahasiswa

SELECT RIGHT(NamaMahasiswa, 3) FROM Mahasiswa;

Tampilkan nama Mahasiswa yang huruf terakhirnya A SELECT NamaMahasiswa FROM Mahasiswa WHERE RIGHT(NamaMahasiswa,1) =A Fungsi Ucase(string) Digunakan untuk mengubah string menjadi huruf kapital.

Tampilkan nama mahasiswa dalam huruf kapital.

SELECT UCASE (NamaMahasiswa) As NamaKapital FROM Mahasiswa


Fungsi LCASE(string) Digunakan untuk mengubah string menjadi huruf kecil.

Tampilkan nama mahasiswa dalam huruf kecil.

SELECT LCASE (NamaMahasiswa) As NamaKecil FROM Mahasiswa


Menggabungkan String

Tampilkan nama Mahasiswa dan alamat dalam satu kolom.

SELECT NamaMahasiswa + + Alamat AS NamaAlamat FROM Mahasiswa


Fungsi Year(tanggal) Menampilkn tahun dari sebuah tanggal.

Tampilkan tahun lahir dari Mahasiswa.

SELECT YEAR (TanggalLahir) As TahunLahir FROM Mahasiswa;


Tampilkan nama, umur dari mahasiswa Cara lain:

SELECT NamaMahasiswa, YEAR(DATE())YEAR(TGLLAHIR) AS Umur FROM Mahasiswa; SELECT NamaMahasiswa, (DATE()-TGLLAHIR)/365 AS Umur FROM Mahasiswa;

Fungsi MONTH(tanggal) Digunakan untuk mengambil bulan dari tanggal

Tampilkan nama, tgllahir, dan bulan lahir dari mahasiswa dalam kolom yang berbeda

SELECT NamaMahasiswa, TanggallLahir, MONTH(TanggalLahir) AS BulanLahir FROM Mahasiswa;


Fungsi DAY(tanggal) Digunakan untuk mengambil hari (1 31) dari data tanggal Tampilkan nama, tgllahir, dan hari lahir (1 31) dari mahasiswa;

SELECT NamaMahasiswa, TanggallLahir, DAY(TanggalLahir) AS HariLahir FROM Mahasiswa;

5. SQL View Masuk ke tab create Klik query design Kilik kanan kemudian pilih SQL View

Gambar 8. Tampilan SQL View

Ketikan perintah querynya

Gambar 9 contoh intruksi SQL menampilkan data nasabah

Setelah selesai klik tombol

untuk mengeksekusi perintah S

QL.

Data hasil di run :

Latihan Praktikum IV
1. Tampilkan Nama_Nasabah,Alamat, Kota_Nasabah. SQL SELECT * FROM TNasabah ; atau

Hasil

Analisis : Sql yang digunakan ada dua cara karna masalah yang diminta adalah menampilkan tabel nasabah sehingga dapat menggunakan (*) yang menunjukan bahwa kita memilih semua isi tabel. 2. Tampilkan semua Nama_nasabah,No_Rekening dan Saldo yang dimiliki SQL

Hasil

Analisis : Sql yang digunakan adalah hanya menampilkan beberapa field sehingga
pada perintah SELECT harus dilist Field yang akan ditampilkan satu persatu SELECT DaftarField FROM namaTabel 3. Cari petugas yang melayani nasabah yang bernama smith SQL

Hasil

Analisis : Pada masalah ini kita harus menggunakan Kriteria/syarat dimana perintah
ini ditulis apa adanya , sehingga struktur sqlnya menjadi SELECT DaftarField FROM namaTabel WHERE syarat

4. Tampilkan Nama Cabang, No_Pinjaman, Nama_nasabah, Jmh_pinjaman Dengan jumlh pinjaman lebih besar dari 500.000 SQL

Hasil

Analisa: Pada masalah ini kita menggunakan Kriteria namun Kriteria disini bisa
berupa operator perbandingan SQL Tanda > untuk lebih besar dari Tanda < untuk lebih kecil dari Tanda >= untuk lebih besar dari atau sama dengan Tanda <= untuk lebih kecil dari atau sama dengan Tanda = untuk sama dengan

5. Cari nasabah yang mempunyai deposito dibawah 1 juta

Hasil

Analisis : pada masalah ini sama seperti no 4 yang kriterianya berupa


perbandingan.

6. Cari nasabah yang mempunyai pinjaman di cabang Leimena SQL

Hasil

Analisis : Pada masalah ini menggunakan sql yang berfungsi untuk menyaring data
yang pada intinya adalah mengunakan kriteria sesuai inputan yang diberikan user seperti pada soal ini hanya mencari nasabah yang mempunyai pinjaman di leimena. 7. Tampilkan nasabah yang memiliki pinjaman dan tabungan di kota cabang yang sama SQL

Hasil

Analisis : Pada soal ini kita menggunakan menggunakan operator logika AND yang
akan menghasilkan nilai benar jika kedua nilai yang dibandingkan bernilai true 8. Buat total Saldo deposito di tiap cabang SQL

Hasil

Analisis: pada soal ini sql menggunakan AS yang berfungsi untuk mengganti nama
field sehingga SumofSaldo adalah pengganti nama dari Sum(Tdeposito.Saldo) , dan GROUP BY berguna untuk mengelompokan record data secara kolom pada query. 9. Carilah total nasabah dari morotai SQL

Hasil

Analisis: pada soal ini mengunakan = yang artinya isi dari field pada tabel
Tnasabah (nama nasabah) sama dengan isi field(nama nasabah) tabel Tdeposito adalah sama sehingga dapat digabungkan. 10. Tampilkan semua petugas bank yang melayani nasabah peminjaman SQL

Hasil

Analisis: pada soal ini kita hanya mengambil data dari table melayani, dan
memasukkan nama nasabah dengan nama petugas.

Praktikum V Menggunakan Report Untuk Membuat Laporan


5.1. Membuat Laporan dalam Tampian Desain

Laporan dapat dibuat sesuai dengan kreasi pengguna, langkah membuat laporan dengan tampilan desain adalah sebagai berikut. 1. Buka file database tempat akan dibuat laporan dan klik report pada bar objek database untuk membuat laporan. 2. Klik ganda create report in design view untuk menampilkan jendela desain laporan pertama 3. Klik menu view dan klik perintah properties unntuk menampilkan jendela property laporan. 4. Jendela laporan terdiri dari tiga bagian, yaitu Page Header, detail, dan Page Footer Page header berisi teks yang akan dicetak pada bagian atas setiap halaman Detail berisi perincian data yang akan dicetak Page Footerberisi teks yang akan dicetak pada bagian bawah setiap halaman 5. Masukan tombol label pada page header sebanyak field yang akan dibuat dan ketikan nama fieldnya. 6. Pindahkan field dari jendela daftar field dan letakan pada bagian detail sesuai dengan nama field yang akan dimasukan pada bagian detail. 7. Klik printah Date and Time untuk menampilkan kota dialog Date and Time. 8. Pilihlah kotak cek pilihan include untuk memasukan data tanggal dan pilih bentuk tampilan yang diinginkan seperti gambar 1.

Gambar 1 kotak dialog Date and Time dengan pilihan tanggal dan waktu. 9. Klik tombol Ok untuk menutup kotak dialog. 10. Klik perintah page Numbers untuk memasukan nomor halaman dan jumlah halaman pada laporan seperti gambar 2 . Button page(footer) nomor halaman pada bagian dasar. Top of page nomor halaman pada bagian atas Page Nmemilih nomor halaman saja Page N of Mmemilih menampilkan nomor halaman dan jumlah halaman Aligmentpilih peralatan nomor halaman

Gambar 2 Kotak Dialog Page Numbers 11. Klik tombol Ok untuk menutup kotak dialog page number. Setelah selesai desain laporan seperti pada gambar 3.

Gambar 3 Jendela laporan dengan desain laporan

5.2.

Mengubah Tampilan Laporan

Laporan dapat diubah sesuai kebutuhan dengan langkah: 1. Kik menu View 2. Klik print preview untuk menampilkan laporan seperti gambar 4

3. Klik menu view klik design View kembali untuk menamilkan laporan dalam tampilan design kembali. 5.3. Menyimpan Laporan 1. Klik menu file, dan klik perintah save 2. Pada kotak dialog Save As , tuliskan nama report sehuinggadilog terlihat seperti gambar 5

Laporan dapat disimpan dengan langkah:

Gambar 5 Kotak dialog Save As 3. Klik Ok untuk menutup Kotak Dialog dan menyimpan Laporan.

5.4.

Membuat Laporan Menggunakan Wizard a) Klik tolbar create pada menu bar b) Klik Report wizard seperti gambar 6

Laporan akan lebih mudah dengan mengunkan wizard, mengikuti langkah:

c) Muncul kotak dialog seperti gambar 7 dan tentukan Field yang akan di laporkan dengan mengklik tombol >> atau >

d) Tambahkan informasi yang diperlukan dan pilih field yang akan digunakan sebagai pengelompokan.

e) Klik tombol next dan Pilih field kunci pengurutan perincian record data, seperti gambar 9 .

Gambar 9 kotak dialaog report Wizard

f) Pilih bentuk keluaran tampilan report dan orientasi laporan , seperti gambar 10

Gambar 10 pilihan layout report wizard g) Pilih style yang diinginkan seperti gambar 11.

Gambar 11 memilih style laporan h) Klik tombol next dan ketikan nama report yang diinginkan sebaiknya diawali dengan huruf R agar lebih mudah mengenalinya seperti gambar 12.

Gambar 11. Kotak dialog untuk Judul Report yang diinginkan i) Klik preview report untuk menampilkan laporandan klik Modify the report design untuk mendesain laporan . klik finish untuk menutup kotak dialog report wizard dan akan tampil seperti gambar 12.

Gambar 12 tampilan laporan report wizard.

Tampilan-tampilan report yang telah dibuat : Report melayani

Report nasabah

Report Cabang

Report Petugas

Report Pinjaman

Report Tabungan

Praktikum VI Membuat Menu (Switchboard)


Swichboard merupakan suatu fasilitas yang disediakan oleh ms access yang dapat digunakan untuk navigasi. 6.1. Pembuatan Switchboard a) Klik database tools, klik switchboard

b) Kemudian akan muncul konfirmasi swichboard manager seperti gambar 2, klik tombol yes untuk menytujui pembuatan switchboard manager. c) Lalu muncul swichboard manager lalu klik menu edit untuk mengganti nama main Switchbard(default) menjadi Menu Utama dengan mengklik tombol edit seperti gambar 3

Gambar 3 menu utama

d) Kemudian klik tombol new untuk membuat halaman swichboard yang baru . isikan pada kotak isian switchboard page name dengan menu data, klik ok e) Selanjutnya untuk mendesain sub menu dat klik tombol edit ,klik tombol edit lalu isikan item yang diinginkan dan klik tombol close untuk menyetujui dan keluar dari kotak dialog Switchboard manager. 6.2. Menjalankan Switchboard

Aktifkan database object form Pilih dan klik Switchboard, klik tombol open maka akan muncul tampilan Switcboard yang telah dibuat.

Apabila kita memilih menu data, maka akan keluar tampilan sebagai berikut :

i. ii. iii. iv. v. vi.

Data cabang akan menampilkan form cabang. Data nasabah akan menampilkan form nasabah. Data petugas akan menampilkan form petugas. Data tabungan akan menampilakan form tabungan. Data pinjaman akan menampilkan form pinjaman Kembali ke menu utama berarti kita kembali ke menu utama

BAB VII Studi Kasus Database Perkuliahan

Entinity Relationship Diagram


Jns_kelamin Tmp_lahir Gol_darah Tgl_lahir JURUSAN Kuliah_di MAHASISWA

Nama_belakang Nama_depan

Kode_jur

Nama_jur Nim Program Pengajar Alamat

Alamat NIP

Nama_belakang Nama_depan

Kode_MK

Nama_MK SKS

Alamat DOSEN Ngajar MATA_KULIAH Ambil take

Tgl_lahir Jns_kelamin Tmp_lahir Gol_darah Kode_pengambilan

dIadakan_di

Prasyarat

No_kelas Kapasitas Tahun

Hari

Kelas

Waktu

Note :

Kode_pengambilan : berisi ganjil atau genap Semester : pada semester berapa mata kuliah tersebut diambil

ER Perkulihaan pada Perguruan Tinggi

Diagram Relasi
Mahasiswa ________________ Nim char(9) <PK> Nama_depan varchar(10) Nama_belakang varchar(10) Jns_kelamin char(1) tgl_lahir date Tmpt_lahir varchar(15) Gol_darah varchar(2) Alamat varchar(30) kode_jur char(2) <FK>

Jurusan _________________ Kode_jur char(2) PK Nama_jur varchar(10)

Kode_jur=kode_jur

Nim

Kode_jur=kode_jur

Ko d

im =N

e_

jur

=k o

de

_ju

Dosen ____________________ NIP varchar(20) <PK> Nama_depan varchar(10) Nama_belakang varchar(10) Alamat varchar(30) jns_kelamin char(1) gol_darah varchar(2) tgl_lahir date tmpt_lahir varchar(15) kode_jur char(2) <FK>

Ni

p= nip

d Ko

e_

ko k=

de

_m

Mata Kuliah ___________________ Kode_MK char(6) <PK> kode_jur char(2) <FK> Nama_MK varchar(30) SKS number(1) Kode_pengambilan varchar(6)

d Ko
d Ko

e_

od =K MK

e_

MK

Ambil ___________________ Nim char(9) <PK> <FK> Kode_MK char(6) <PK> <FK> take number(1) <pk> Nilai char(1)

e_ M s K_ kr ng K K M M e_ e_ od od =K =K m elu eb M s K_

d Ko

e_

Ngajar ___________________ nip varchar(20)<fk> kode_mk char(6)<pk><fk>

Prasyarat _________________ Kode_MK_skrng char(6) <PK> <FK> Kode_MK_sebelum char(6) <PK>< FK>

Kelas
__________________ no_kelas char(5) <PK> kode_MK char(6) <PK> <FK> Kapasitas number(2) Waktu char(5) hari varchar(6) tahun number(4)

Diagram Relasi

Diagram Relationship pada Ms Access

kode_mk=kode_mk

Modul I
1. Tabel Jurusan Design View

Setelah data diinput

2. Tabel Mata Kuliah Design View

Setelah data diinput

3. Tabel Dosen Design View

Setelah data diinput

4. Tabel Mahasiswa Design View

Setelah data diinput

5. Tabel Ngajar Design View

Setelah data diinput

6. Tabel Prasyarat Design View

Setelah data diinput

7. Tabel Ambil Design View

Setelah data diinput

8. Tabel Kelas Design View

Setelah data diinput

Analisa: sebelum menginputkan data ke dalam table, hendaklah kita terlebih dahulu
menentukan primary key dan foreign key pada desain view. Dan kita juga harus terlebih dahulu membuat relationship antar tabel sebelum kita menginputkan dengan data-data.

Modul II
1. Buatlah query yang menampilkan nama mahasiswa satu angkatan berdasarkan inputan dari user. SQL

Hasil Run

Report

Analisis: Pada soal ini diperintahkan untuk menampilkan mahasiswa se angkatan dimana
diambil dari nilai tengah nim sehingga menggunakan mid sebagai parameter dan serta menggabungkan nama depan dengan nama belakang menjadi nama mahasiswa.

2. SQL

Hasil Run

Report

3. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk membuat parameter agar hanya menampilkan
kode pengambilan genap dan mengubah nama sks menjadi SKSS serta mengurutkan data dengan descending.

4. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan nama, 3 digit akhir NIM, dan nama jurusan. Untuk membuat 3 digit akhir NIM bias menggunakan fungsi mid(nama field,angka ke-,jumlah angkayang diambil ). Mahasiswa yang tampil adalah mahasiswa angkatan 98 sehingga mengunakan like 98 5. SQL

Hasil run

Report

Analisis: pada soal ini dituntut untuk

menampilkan Nama dosen yang berumur 57

sampai 62 tahun. Untuk menghitung umur bisa menggunakan operator matematika dengan variabel tahun sekarang dan tahun lahir, dimana [tahun sekarang] [tahun lahir] dan parameter menggunakan between untuk mengambil nilai tengahnya. 6. a. SQL

Hasil run

Report

Analisis :

pada soal ini diperintahkan untuk menampilkan tabel TMahasiswa,

dimana data yang muncul adalah hanya mahasiswa yang mempunyai NIM dengan awalan

113. menggunakan symbol * untuk memilih sesuru Tabel. Dan mengukanan Like untuk mengambil seluruh nilai yang mengandung nilai yang dibandingkan , 113* tanda (*) diakhir menandakan masih ada karakter dibelakang angka 113. b. SQL

Hasil run

Report

Analisis: pada soal ini diprintahkan menampilkan NIM, nama_depan, jns_kelamin, dan
golongan darah dari tabel TMahasiswa dengan NIM sebagai parameter (input masukan yang ditentukan). Tanda [ ] berfungsi untuk filter data . 7. a. SQL

Hasil run

Report

Analisis : pada soal ini diperintahkan menampilkan nama_depan, nama_belakang, dan


kode_Jur dari tabel TDosen dengan NIP sebagai input masukan(parameter) yang dinginkan user. b. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan tabel kelas dengan parameter
Kode_mk sebagai filder data. c. SQL

Hasil run

Report

Analisis : Pada soal ini mengunakan penambahaan field yaitu field jurusan dengan
struktur (nama field yang akan diisikan AS nama field) dan mengunakan As(alias untuk mengubah Nama field . 8. a. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan kode_mk, nama_mk, dan sks dari
tabel TMataKuliah dengan input masukan (parameter) kode_mk. b. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan NIM , Kode _mk, dan Nilai dari tabel
Tambil dengan input masukan (parameter) kode_mk. c. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan NIM, nama_depan , dan Kode_Jur
dari tabel TMataKuliah dengan input masukan (parameter) NIM. D. SQL

Hasil run

Report

Anaisis :pada soal ini dituntut untuk menampilkan NIM, KODE _mk, dan NILAI dari tabel Tambil dengan input masukan (parameter) NIM. 9. a. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan Ruang, kode_mk ,kapasitas ., dan
hari dari tabel Tkelas dengan input masukan (parameter) Nama Haridan menggunakan ucase untuk merubah huruf besar ke kecil . 10. a. SQL

Hasil run

Report

b. SQL

Hasil run

Report

Analisa : pada soal ini dituntut untuk menampilkan ruang,hari , dan waktu dari tabel
Tkelas dengan menambahkan sebuah field dengan menggunakan AS(alias)

11. a. SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan NIP dan nama dari tabel TDosen
dengan input masukan (parameter) jurusani IF dan Gol_dar B

b.SQL

Hasil run

Report

Analisis : pada soal ini dituntut untuk menampilkan NIP dan nama dari tabel TDosen
dengan input masukan (parameter) jurusani IF dan Gol_dar B serta yany lahir dibulan maret dengan menggunakan Like

12. a. SQL

Hasil run

Report

Analisis: pada soal ini banyak menggunakan as untuk mengganti nama dan
menggabungkan dengan karakter karakter.yang diinginkan.

b. SQL

Hasil run

Report

Analisis: pada soal ini banyak menggunakan as untuk mengganti nama dan
menggabungkan dengan karakter karakter.yang diinginkan dan menggunakan Len untuk menghitung jumlah teks . 13. SQL

Hasil run

Report

Analisis : pada soal ini intinya menggunakan struktur Lcase untuk merubah huruf
kapital ke huruf kecil dan menggunaka parameter If untuk menyaring data Kode_MK_sekarang dan Mata_kuliah. 14. SQL

Hasil run

Report

Analisis : pada soal ini intinya adalah mengambil data Nim dengan menggunakan mid
dan right untuk mengambil nilai tengah dan kanan teks.

PENUTUP
Kesimpulan Microsoft Access adalah program basis data yang berfungsi untuk merancang, membuat, dan mengolah berbagai jenis data dengan kapasitas yang besar. Selain itu juga ms access dilengkapi dengan Query yang menggunakan SQL untuk memudahkan dalam memfilter data sesuai dengan yang diinginkan ditambah lagi dengan mengunakan Switchboard untuk menampilkan data secara keseluruhan hingga membentuk sebuah database yang memiliki Kecepatan dan kemudahan (speed),Efesiensi ruang penyimpanan (spaace),Keakuratan (acccuracy),Ketersediaan (availability),Kelengkapan (Completeness),Keamanan (Scurity) dan Kebersamaan pemakaiaan (sharability) yang diinginkan. Microsoft Acces sangat cocok bagi programmer pemula untuk membuat suatu basisdata (database) bahkan bisa juga membuat aplikasi sederhana atau desain web karena dalam aplikasi Microsoft ACCESS terdapat beberapa fitur yang memudahkan kita, diantaranya menu pembuatan Table, Form, Query, Report, dll. SARAN Sebelum menginputkan data pada tabel, hendaklah kita terlebih dahulu menentukan primary key yang tepat dan membuat relationship antar tabel yang benar, karena apabila terjadi kesalahan pada penginputan data pada tabel atau relationship tabel yang salah, maka kita akan susah untuk melanjutkan ke tahap selanjutnya (pembuatan Query, Form dan Report) Pembuatan query dengan SQL menjadi sorotan utama dan diberikan perhatian lebih agar bisa melanjutkan dengan mudah ke praktikum informatika II (VISUAL BASIC) , dan computer atau laptop yang ada dilab sebaiknya dipasang anti virus yang lebih baik karna sering kali data rusak dan menghambat proses praktikum dan sering menyebabkan hang .