Anda di halaman 1dari 26

Dosen : Marlina, S.

Kom








Disusun oleh :
KELOMPOK V
ERWIN PATULLAH 212 280 205
MUH. MUSBIR 212 280 227
ARMA ELIZA ARIS 212 280 259
AYU ASHARY 212 280 265
SULAWATI SULTAN 1213 280 022
FEBRIANSYAH Y.M 206 280 028


FAKULTAS TEKNIK JURUSAN TEKNIK INFORMATIKA
UNIVERSITAS MUHAMMADIYAH PAREPARE
T. A. 2013/2014
1. a. Langkah langkah membuat data base
Buka aplikasi Microsoft Visual basic 6.0










Pada menu, klik Add-Ins > Visual Data Manager





Setelah itu akan muncul tampilan seperti gambar berikut ini, Kemudian pilih file
> new > Microsoft Acces > Version 7.0








Setelah itu save database yang anda buat , seperti gambar berikut ini :






Setelah itu klik kanan Properties>New Table, seperti gambar berikut :






Setelah itu Beri nama table database , setelah diberi nama pilih Add Field> Isi
nama untuk tiap table , type dan sizenya > Ok > close . KemudianKlik Build
thr table > close .







Setelah itu Double Klik Nama Tabel yang sudah anda buat
Kemudian pada layer pengeditan, pilih Add> Isi data yang anda inginkan, seperti
gambar berikut:






Setelah itu pilih update untuk meyimpan data anda, begitupun seterusnya jika anda
ingin menambahkan beberapa data , seperti gambar berikut ini :






Setelah itu , maka anda sudah berhasil membuat suatu database.






b. Langkah-langkah membuka DataBase.
Buka aplikasi Microsoft Visual basic 6.0










Pada menu, klik Add-Ins > Visual Data Manager





Kemudian klik File> Open DataBase > Microsoft acces .







Setelah itu cari dimana anda menyimpan Database yang anda buat sebelumnya >
Open.





















2. Tuliskan dan jelaskan dengan gambar langkah-langkah membuat ODBC Drive!
Hal pertama yang harus kita lakukan adalah membuat folder baru pada drive anda
dengan cara klik kanan pada mouse atau touchpad anda => New => Folder dan beri
nama foldernya. Contoh db_ayuashary.








Setelah itu Klik Start => Control Panel















Pilih System and Security








Pilih Administrative Tools








Pilih Data Source (ODBC)








Pada kotak dialog ODBC Data Source Administrator Pilih Add...













Pada kotak dialog Create New Data Source pilih Drive do Microsoft Access (*.mdb)
kemudian pilih Finish












Pada kotak dialog ODBC Microsoft Access Setup, Isi Data Source Name, kemudian
pilih Create












Pada kotak dialog New Database Isi database Name, kmudian cari folder yang telah
kita buat tadi. Kemudian stelah dapat foldernya klik OK.












Kemudian akan muncul kotak dialog ODBC Microsoft Access Setup Pilih OK













Setelah Data Source Name dan Database sudah ada pada ODBC Microsoft Access
Setup pilih OK












Setelah Database kita sudah jadi Pilih Apply => OK

























3. Menghubungkan Database Ke Form
Langkah pertama kita tambahkan dulu komponen pada toolbox nya dengan
mngetikkan Ctrl+T atau klik menu projeck lalu pilih Componen.,
kemudian cari dan centang komponen Microsoft Ado Data Control 6 (OLEDB) dan
Data Grid Control 6 (OLEDB)
Setelah itu centang lalu tekan tombol OK, kemudian masukkan kedua komponen
tersebut ke dalam form., komponen tool data grid berfungsi untuk menampilkan isi
dari database yang kita inputkan.
Setelah itu , klik kanan pada tool adodc1, lalu pilih ADODC Properties.
Kemudian akan muncul Properties Page, Klik tabulasi general, kemudian pada frame
source of connection pilih option Use Connection String lalu klik tombol Build.
Setelah itu akan muncul form Data Link Properties pada tab Provider pilih Microsoft
Jet 4 OLE DB Provider, kemudian Klik Next.
Pada tab Connection pilih tombol cari (....) pada Select or Enter a Database Name
untuk mencari database yang sudah kita buat sebelumnya.
Setelah database dimasukkan kemudian klik tombol Test Connection, jika berhasil
maka akan muncul pesan Test Connection Succeeded, kemudian Klik Tombol OK.
Kemudian kembali ke form Property Pages, klik tab Record Source kemudian pada
Command Type Pilih adCmdTable dan pada Table or Stored Procedure Name pilih
tabel dari database yang kita buat lalu klik OK.








4. Langkah langkah menambahkan komponen SSTab, ADODC, Data Grid dan
Timer pada toolBox :
Buka aplikasi Microsoft Visual basic 6.0
Pada menu , Klik project kemudian pilih components atau bisa langsung crt+T
Setelah muncul kotak dialog component , centang :
Microsoft Tabbed Dialog control 6.0 (SP4) untuk SSTab
Microsoft ADO Data Control 6.0 (OLEDB) untuk ADODC
Microsoft Data Grid Control 6.0 (OLEDB) untuk Data Grid
Kemudian Klik OK.

5. Tuliskan dan jelaskan langkah-langkah membuat laporan pada Visual Basic!
Ada dua langkah untuk membuat data laporan. Pertama, kita perlu membuat Data
Environtment. Disini kita akan merancang dengan Visual Basic yang digunakan oleh data
report untuk menampilkan data dari file database. Langkah kedua, kita membuat Data
Report itu sendiri. Ini juga dapat dikerjkan dalam Visual Basic. Data Environtment dan data
Report adalah bagian dari pengembangan project dalam Visual Basic sebagai database
management system.
Membuat Data Envirotment
Langkah-langkah untuk membuat Data Environtment antara lain sebagai berikut :

Mulailah membuka Project Standar EXE yang baru.







Pada menu Project, klik Add Data Environtment.







Dalam jendela Data Environtment, pilih Connection1 kemudian klik kanan dan
pilih properties. Dalam kotak dialog box Data Link Properties, pilih Microsoft Jet
4.0 OLE DB Provider. Klik next untuk berpindah ke tab Connection. Klik tombol
Elipsis. Cari database buku anda (.mdb) klik OK untuk menutup dialog box.

















Sekarang kita akan mengenal Data Environtment dengan database. Klik kanan
tab Connection1 dan klik Rename untuk mengubah data koneksinya. Ubahlah
nama tersebut dengan nama buku. Klik kanan nama tab yang baru dan klik Add
Command untuk membuat tab Command1. Klik kanan tab tersebut dan pillih
Properties. Isilah propertinya dengan nilai berikut :
Command Name = DaftarBuku
Connection = Data_Buku
Database Object = Table
Object Name = Daftar_Buku



















Klik OK. Semua yang dibutuhkan untuk keneksi ke database kita sudah selesai.
Tampilan jendela properties dan berikan nama untuk data environtment dengan
nama denBuku. Klik file dan save denBuku As. Simpan environtment ini pada
folder yang tepat.


Membuat data report
Setelah data enviroontment kita sudah dibuat, kita akan membuat data report. Drag file
database yang berada dalam data environtment ke dalam form yang dibuat untuk Data
Report. Pastikan bahwa jendela data environtment tetap tersedia.
Adapun langkah-langkah untuk membuat data Report antara lain sebagai berikut :
Pada menu project, klik Add Data Report dan satu data report akan ditambahkan ke
dalam project anda.







Isilah properties pada report seperti berikut :
Name = rptBuku
Caption = Daftar Buku
DataSource = denBuku
(data environtment Buku dipilih, janagn diketik)
Daftar member = DaftarBuku
\(name table dipilih, jangan diketik)










Daftar file report terdapat lima bagian, antara lain : Report, Header, Page Header,
detail Section, Page Footer,dan Report Footer. Header, Detail Section, Page Footer,
dan Report Footer. Header dan footer berisi informasi yang ingin ditampilkan pada
setiap halaman. Untuk meletakkan informasi dalam satu bagian ini, klik kanan bagian
yang dipilih, klik Insert Control, kemudian pilih kontrol yang diinginkan untuk
digunakan.
Bagian detail digunakan untuk membuat layout informasi yang ingin anda cetakdari
setiap record pada file database anda. Klik tab pada Kode_Buku dalam jendela Data
Environtment dan drag file tersebut ubutuk diletakkan pada bagian detail pada data
report. Dua item akan ditampilkan : sebuah text box Kode_Buku dan sebuah text box
Kode_Buku. Text box yang pertama adalah informasi header. Pindahkan text box ke
dalam bagian page header. Text box yang kedua adalah nilai dari field yang
sebenarnya dari filetable Daftar_Buku. Letakkan text box tersebut dibawah header
Kode_Buku. Sekarang, drag field Judul_Buku dari Data Environtment ke data report.
Lakukan seperti anda melakukan untuk field Kode_Buku. Ulangi langkah tersebut
sampai pada field Tahun_Terbit.
Klik File dan Save rptBuku As. Simpan environtment pada folder yang tepat.
Sebagai contoh, kita akan mendesain laporan data dosen yang telah dibuat data
basenya. Tambahkan komponen-komponen data report kedalam desain laporan
dengan pengaturan properti sebagai berikut:









Sehingga akan didapatkan hasil seperti pada gambar berikut :








Kemudian jalankan program sehingga didapat hasil seperti pada gambar berikut :

























6. Tuliskan dan jelaskan langkah-langkah membuat menu pada Visual Basic!

Langkah-langkah untuk membuat Menu Utama adalah Sbb :
Buat sebuah project baru.
Pada kotak dialog form kita ganti captionnya menjadi Menu Utama dan ubah StartUp
position jadi 2 CenterScreen






















Pada Menu Bar pilih Tools => Menu Editor atau tekan CTRL + E







Setelah Form Menu Editor terbuka, ikuti langkah dibawah ini :

Caption : Entry (Diisi)
Name : ent (Diisi)
Klik tombol Next => Klik tombol panah kanan (Lihat gambar dibawah ini)













Dengan sobat menekan tombol panah kanan, artinya sobat akan membuat Sub Menu
dari Menu Entry yang telah kita buat dengan cara diatas tadi.


Kemudian ikuti langkah selanjutnya berikut ini :
Caption : Entry Data Mahasiswa (Diisi)
Name : edm (Diisi)
Klik tombol Next (Lihat gambar dibawah ini)











Sekarang kita akan membuat Sub Menu Entry berikutnya yaitu Entry Mata Kuliah.
Ikuti langkah-langkah berikut ini :

Caption : Entry Mata Kuliah (Diisi)
Name : emk (Diisi)
Klik tombol Next (Lihat gambar dibawah ini)











Selanjutnya kita akan membuat Sub Menu Entry berikutnya yaitu Entry Nilai
Mahasiswa. Ikuti langka-lagkah berikut ini :

Caption : Entry Nilai Mahasiswa (Diisi)
Name : enm (Diisi)
Klik Tombol Next -> Klik tombol panah kiri (Lihat gambar dibawah ini)











Dengan kita menekan tombol panah kiri, maka kita mengembalikan posisi kursor ke
Menu (Bukan Sub Menu). Karena selanjutnya kita akan membuat Menu Laporan.
Selanjutnya ikuti langkah-langkah berikut ini :

Caption : Laporan (Diisi)
Name : lap (Diisi)
Klik tombol Next -> Klik tombol panah kanan (Lihat gambar dibawah ini)










Setelah menekan tombol panah kanan, kita akan membuat Sub Menu Laporan yang
pertama. Ikuti langkah-langkah berikut ini :

Caption : Laporan Data Mahasiswa (Diisi)
Name : ldm (Diisi)
Klik tombol Next (Lihat gambar dibawah ini)











Sub Menu laporan yang terakhir kita akan membuat Sub Menu Laporan Nilai Siswa.
Silakan sobat ikuti langkah-langkah berikut ini :

Caption : Laporan Nilai Mahasiswa (Diisi)
Name : lnm (Diisi)
Klik Tombol Next -> Klik tombol panah kiri (Lihat gambar dibawah ini)










Yang terakhir, kita akan membuat Menu Exit/Keluar. Silakan sobat ikuti langkah-
langkahnya berikut ini :

Caption : Exit (Diisi)
Name : ext (Diisi)
Klik Tombol OK (Lihat gambar dibawah ini)




















Jika pada saat menekan tombol OK dan mendapat pesan Error seperti dibawah ini :










Periksa kembali penggunaan Name pada tiap-tiap Menu maupun Sub Menu yang sobat
buat, kemungkinan terjadi kesamaan dalam penggunaan Name. Untuk penggunaan Name
sendiri bersifat bebas, disini saya menggunakan inisial dari Caption sebagai Name agar
mudah dipahami.





Langkah-langkah diatas baru sebatas design saja dan belum bisa berfungsi. Agar program
menu ini bisa berjalan, kita harus memasukkan sedikit script didalamnya.

Disini saya memisalkan sebagai berikut :
Entry Data Mahasiswa = Form2
Entry Mata Kuliah = Form3
Entry Nilai Mahasiswa = Form4
Laporan Data Mahasiwa = Form5
Laporan Nilai Mahasiswa = Form6
Jika mengikuti seluruh langkah-langkah diatas sama persis, langkah selanjutnya sobat cukup
Copy Paste saja script berikut ke dalam program yang bikin :

Private Sub eds_Click()
Form2.Show
End Sub

Private Sub emp_Click()
Form3.Show
End Sub

Private Sub en_Click()
Form4.Show
End Sub

Private Sub lds_Click()
Form5.Show
End Sub

Private Sub lns_Click()
Form6.Show
End Sub

Private Sub xxx_Click()
Dim a
a = MsgBox("Tutup Aplikasi...??", vbQuestion + vbYesNo, "Info")
If a = vbYes Then
End
Else
Cancel = 1
End If
End Sub