Anda di halaman 1dari 153

Kustanto Daniel T Saputro

Membangun Server Internet

dengan

MIKROTIK OS

Kustanto Daniel T Saputro ■ Membangun Server Internet dengan MIKROTIK OS

IX

DAFTAR ISI

Kata Pengantar

Daftar lsi

BAB I

PEMAHAMAN JARINGAN KOMPUTER

1.1

n Jaringan Komputer

1.2

ksi Antar Node/Komputer

1.3

vii

ix

1

Pengertia

2

Interkone

4

Jangkaua

n

Area Jaringan

5

a. Local Area Network (LAN)

5

b. Metropolitan Area Network (MAN)

7

c. Wide Area Network (WAN)

8

1.4 Topologi Jaringan Komputer

9

 

a. Topologi Point to Point

9

b. Topologi Bus

10

c. Topologi Star

12

d. Topologi Tree

13

e. Topologi Ring

14

f. Topologi Mesh

16

1.5 Tipe Jaringan

17

BAB II

KOMPONEN JARINGAN KOMPU

2.1 Media Transmisi

TER.

19

20

2.

M

X

 

edia Transmisi Tanpa Kabel/WiFi (Wireless Fidelity)

25

3.

Media

 

Transmisi dengan Satelit

26

 

2.2

Hardware untuk membangun infrastruktur jaringan komputer dan koneksi ke internet

27

 

A.

Infrastruktur jaringan LAN dengan media transmisi Kabel

27

 

1.

Ethernet Card (NIC)

27

2

Kabel UTP Cat 5

28

3. Hub / Concentrator atau Switch

32

4. Router

33

5. Komputer standar

34

6. Modem

35

 

B.

Infrastruktur Jaringan LAN dengan Media Transmisi Tanpa Kabel/WIFI

36

 

2.3

Software untuk Membangun Infrastruktur Jaringan Komputer

37

2.4

Protokol

 

37

BAB III

PEMAHAMAN IP ADDRESS

41

3.1 IP Address

42

32 Kelas IP Address

42

a.

Kelas A

43

b.

Kelas B

43

c.

Kelas C

44

d.

Kelas D

45

e.

Kelas E

45

3.3

Alamat

Khusus

46

3.4

IP

Private

47

3.5

Subnet

Mask

47

3.6

Subneti

ing

49

b.

Protek situs internet dengan protocol & port

91

6.4 Log Manajemen

95

b. Subnetting Kelas B

51

 

.

c. Subnetting Kelas C

53

BAB IV

INSTALASIMIKROTIK

……….

55

4.1 Sekilas MikroTik

56

4.2 Instalasi MikroTik

56

4.3 Perintah dasar MikroTik OS

62

BAB V

MIKROTIK ROUTER

69

5.1

Topologi

MikroTik router

70

5.2

Mengakt

ifkan ethernet

71

5.3

Identitas

Ethernet

72

5.4

IP

Address

74

5.5

IP

Gateway

75

5.6

DNS

(Domain Name Server)

76

5.7

IP

Firewall Nat

79

80

BAB VI

Komputer Client

WEB-PROXY

85

6.1 IP web-proxy

86

6.2 Proxy transparant

88

6.3 IP Firewall Filter

90

XI

XII

BAB VII

MANAJEMEN BANDWIDTH…………………….

97

7.1

Manajemen bandwidth jenis queue tree

98

a. IP firewall mangle

99

b. Konfigurasi Queue Tree

104

7.2

Manajemen bandwidth jenis queue simple

110

BAB VIII

HTTP PROXY

117

8.1

Mengaktifk

an http proxy

118

8.2

Konfigu

rasi proxy transparant

119

8.3

Kontrol

Bandwidth

121

BAB IX

MIKROTIKMRTG

125

9.1

Definisi

126

9.2

Menga

ktifkan fungsi graphing-------------------------------------------

126

a.

Resource graphing

-----------------

126

b.

Traffic interface

---------------

127

c.

Traffic simple queue

129

BAB X

DHCP SERVER--------------------------------------

135

10.1 Instalasi Interface------------------------------------------

137

10.2 Setting IP Address

139

10.3 Konfigurasi IP Gateway----------------------------------

140

10.4 Konfigurasi IP dns

141

10.5 Setting address pool

142

10.6 Menentukan interface Ian dhcp dan mengaktifkan dhcp server.------------------------------

144

d.

IP Gateway

165

10.7 Setting IP firewall nat

10.8 Setting Komputer klien

BAB XI

PEMAHAMAN JARINGAN H0TSP0T MODEM ADSL520T

145

146

147

11.1 Hot Spot gateway dengan MikroTik

148

11.2 Hotspot dengan modem ADSL

149

a. Persiapan dan pemasangan modem ADSL

150

b. Persiapan koneksi line telepon

151

c. Modem ADSL dan indikator lampu

152

d. Persiapan sebelum melakukan setup modem

153

e. Setting manual modem adsl

155

11.3 MikroTik proxy

161

a. Mengaktifkan Ethernet

161

b. Identitas ethemet

162

c. IP address

164

e.

DNS (Domain Name Server)

165

e.

IP firewall nat

166

f.

IP web-proxy

166

g.

Proxy transparant

168

11.4 Bandwidth limiter

169

a.

IP firewall mangle

169

b.

Konfigurasi Queue Tree

174

d.

Mengaktifkan fungsi graphing

179

11.5 Konfigurasi Access Point (AP) Wireless

182

Daftar Pustaka

188

Tentang Penulis

189

XIII

BAB I

PEMAHAMAN

JARINGAN

KOMPUTER

Tujuan :

Memahami konsep jaringan komputer dan topologinya

Komunikasi antar komputer pada saat ini sudah tidak mengenal batas-batas geografi, artinya dengan komputer yang kita miliki, kita dapat mengakses dan mencari data di seluruh dunia. Kita tidak perlu lagi meninggalkan meja kerja kita untuk mencari suatu informasi dari benua lain. Kita cukup menyalakan komputer kemudian mengkoneksikan ke internet dan semua informasi yang kita inginkan sudah tersaji di layar monitor. Bagaimana hal ini dapat terjadi? Semua ini dapat terjadi dikarenakan adanya teknologi jaringan komputer. Jaringan komputer merupakan sebuah teknologi komputer yang sudah cukup lama dan senantiasa berkembang sehingga dengan jaringan komputer jarak dan batas territorial suatu negara, benua seakan-akan tidak ada.

Pada bab ini, kita akan mempelajari mengenai dasar-dasar

jaringan komputer, hardware dan software jaringan komputer,

dll.

1.1 Pengertian Jaringan Komputer

Jaringan Komputer adalah kumpulan dua atau lebih

komputer yang saling berhubungan satu sama lain untuk

melakukan komunikasi data dengan menggunakan protokol

komunikasi melalui media komunikasi (kabel atau nirkabel),

sehingga komputer-komputer tersebut dapat saling berbagi

informasi, data, program-program, dan penggunaan perangkat

keras secara bersama. Dalam hal ini komunikasi data yang bisa

dilakukan melalui jaringan komputer dapat berupa data teks,

gambar, video dan suara. Berikut adalah contoh jaringan

komputer yang paling sederhana:

2

adalah contoh jaringan komputer yang paling sederhana: 2 Gambar 1-1: Jaringan komputer sederhana Beberapa manfaat dan

Gambar 1-1: Jaringan komputer sederhana

Beberapa manfaat dan tujuan dibangunnya jaringan komputer adalah:

Sharing Resource Resource sharing bertujuan agar seluruh program, peralatan, dan khususnya data dapat digunakan oleh setiap orang yang ada pada jaringan komputer tanpa terpengaruh oleh lokasi resource dan pemakai. Contohnya adalah pemakaian printer secara bersama-sama (printer sharing).

• Media komunikasi Jaringan komputer memungkinkan terjadinya komunikasi antar pengguna yang jaraknya saling berjauhan. Komunikasi ini dapat mengirimkan informasi dalam bentuk gambar, suara, text yang sering disebut dengan teleconference atau suara saja (VOIP)

Integrasi data Dengan jaringan komputer proses pengolahan data tidak hams dilakukan pada satu komputer saja, tetapi dapat dilakukan di komputer-komputer yang lain. Oleh karena itu akan dapat terbentuk data yang terintegrasi sehingga memudahkan pemakai untuk memperoleh dan mengolah informasi setiap saat. Contohnya adalah program database yang bersifat client-server.

Hiburan

Jaringan komputer dapat memberikan sarana hiburan bagi manusia. Contohnya adalah chatting, game online.dll.

3

• Efisien (hemat) waktu, tenaga dan Informasi yang terkini. Jaringan komputer yang dapat mengintegrasikan data, komunikasi pengguna jarak jauh, berbagi data, tentunya akan dapat menghemat waktu dalam pencarian data dan data yang dihasilkan adalah data terkini. Dalam membangun sebuah jaringan komputer ada beberapa hal yang hams diperhatikan dan dipertimbangkan antara lain meliputi: struktur bangunan, jangkauan area jaringan, kecepatan akses, biaya operasional, pemeliharaan, hardware dan software yang digunakan dan sebagainya.

1.2 Interkoneksi Antar Node/Komputer

Interkoneksi antar node/Komputer adalah sistem koneksi/ hubungan

antar komputer satu dengan komputer lainnya. Model Interkoneksi antar

node/komputer di bedakan menjadi dua bagian yaitu:

Interkoneksi point to point Interkoneksi komputer yang dilakukan secara langsung antara dua komputer (node), seperti hatnya pada gambar 1-

1.

Interkoneksi multipoint Interkoneksi yang dilakukan dengan banyak komputer dengan

pemakaian secara bersamaan (teknik share).

4

komputer dengan pemakaian secara bersamaan (teknik share). 4 Gambar 1-2: Interkoneksi multi point. 1.3 Jangkauan Area

Gambar 1-2: Interkoneksi multi point.

1.3 Jangkauan Area Jaringan

Berdasarkan luas areanya atau letak geografisnya, jaringan area komputer dibedakan menjadi:

a. Local Area Network (LAN).

b. Metropolitan Area Network (MAN).

c. Wide Area Network (WAN).

a. Local Area Network (LAN)

LAN adalah sebuah jaringan komputer dengan jangkauan area yang terbatas dan hubungan fisik antar komputer saling

berdekatan.

Misalnya jaringan komputer di sebuah kantor, jaringan komputer di sebuah ruangan kerja (Laboratorium).

5

Gambar 1-3: Local Area Network

Keuntungan LAN yaitu:

• Pertukaran file, data antar komputer dapat dilakukan dengan mudah

(file sharing).

• Penggunaan printer dapat dilakukan oleh semua user (printer sharing).

• Pertukaran data antar komputer dapat dikendalikan sehingga

keamanan data dapat terjaga.

• Proses back up data menjadi lebih mudah dan cepat.

• Komunikasi antar user dapat dilakukan dengan email atau chat.

• Instalasi jaringan mudah dan cukup murah.

Kerugian LAN yaitu:

• Area jaringan hanya sebatas satu gedung atau ruangan.

• IP address komputer LAN tidak bisa di akses dari jaringan WAN

6

b. Metropolitan Area Network (MAN)

MAN biasanya meliputi area yang lebih besar dari LAN, area yang digunakan adalah dalam sebuah negara. Dalam hal ini jaringan komputer menghubungkan beberapa buah jaringan-jaringan LAN ke dalam lingkungan area yang lebih besar, sebagai contoh yaitu: jaringan pada Bank (sistem Online Perbankan). Setiap bank tentunya memiliki kantor pusat dan kantor cabang. Di setiap kantor baik kantor cabang maupun kantor pusat tentunya memiliki LAN, penggabungan LAN - LAN di setiap kantor ini akan membentuk sebuah MAN. MAN biasanya mampu menunjang data teks dan suara, bahkan dapat berhubungan dengan jaringan televisi kabel atau gelombang radio.

dengan jaringan televisi kabel atau gelombang radio. Gambar 1 -4: Metropolitan Area Network Keuntungan MAN: •

Gambar 1 -4: Metropolitan Area Network

Keuntungan MAN:

• Server kantor pusat dapat berfungsi sebagai pusat data dari kantor cabang.

7

• Transaksi yang Real-Time (data di server pusat diupdate saat itu juga, contoh ATM Bank unluk wilayah nasional)

• Komunikasi antar kantor bisa menggunakan e-mail, chatting

dan Video Conference (ViCon).

Kerugian MAN:

• Biaya operasional mahal.

• Instalasi infrastrukturnya tidak mudah.

• Rumit jika terjadi trouble jaringan (network trouble shooting).

c. Wide Area Network (WAN)

WAN adalah jaringan komputer dengan jangkauan area geografi yang paling luas, antar negara, antar benua bahkan keluar

angkasa (sebagai contoh jaringan internet yang menggunakan

sistem koneksi satelit).

Gambar 1-5: Wide Area Network

8

Keuntungan WAN:

• Penggunaan kartu kredit di seluruh dunia

• Pengambilan uang dengan jaringan internasional (ATM Internasional)

• Komunikasi antar kantor bisa menggunakan e-mail, chatting dan Video Conference (ViCon).

• Pooling data dan up date data antar kantor dapat dilakukan setiap hari pada waktu yang ditentukan.

• Data dapat dikirim melalui e-mail.

Kerugian WAN:

• Biaya operasional mahal.

• Susah dalam instalasi infrastrukturnya.

• Rumit jika terjadi trouble jaringan (network trouble shooting).

1.4 Topologi Jaringan Komputer

Topologi jaringan komputer adalah infrastruktur fisik jaringan komputer yang digunakan untuk mengimplementasikan LAN. Topologi jaringan dapat dibedakan menjadi:

a. Topologi point to point.

b. Topologi Bus.

c. Topologi Star.

d. Topologi Tree.

e. Topologi Ring

f. Topologi Mesh.

a. Topologi point to point

Merupakan topologi yang menggambarkan bagaimana cara kita menghubungkan infrastruktur jaringan antar node (komputer) secara langsung. Berikut merupakan gambar topologi point to point:

9

Gambar 1 -6: Topologi Point to point

Keuntungan topologi point to point:

• Tanpa menggunakan concentrator (hub atau switch).

• Biaya murah.

• Pemeliharaan mudah.

• Transfer pertukaran data dengan teknik sharing folder.

• Instalasi jaringan sangat sederhana.

• Peralatan

jaringan sederhana. Kerugian topologi point to point:

• Jumlah terminal terbatas (hanya 2

komputer).

• Jika salah satu node (komputer) ada yang rusak maka jaringan tidak dapat difungsikan.

• Jika terjadi pengiriman paket data bersamaan,

maka akan terjadi collesion (tabrakan data).

b. Topologi Bus

Topologi bus adalah topologi jaringan komputer yang menggunakan sebuah kabel utama (backbone) sebagai tulang punggung jaringan. Topologi ini menggunakan T- connector sebagai penghubung antar node dan Terminator sebagai penutup di ujung- ujung kabel utama.

10

Terminator sebagai penutup di ujung- ujung kabel utama. 10 Gambar 1 -7: Topologi Bus Keuntungan topologi

Gambar 1 -7: Topologi Bus

Keuntungan topologi bus:

• Transfer pertukaran file, data dengan menggunakan teknik sharing folder.

• Tanpa menggunakan hub atau

concentrator.

• Cocok digunakan untuk area yang tidak luas (laboratorium, kantor)

• Dapat dipakai untuk tipe jaringan komputer work group (peer to peer) atau client - server.

Kerugian topologi bus:

• Penambahan terminal node, akan menyebabkan gangguan aktifitas jaringan yang sedang berlangsung.

• Sulit dalam perawatan jaringan.

11

Jika salah satu konektor pada node ada yang rusak, maka aktifitas jaringan tidak dapat digunakan.

Jika lalu lintas data terlalu tinggi dapat terjadi kemacetan (congestion).

Diperlukan repeater untuk menguatkan sinyal pada pemasangan

jarak jauh.

Transfer pertukaran file, data dengan menggunakan teknik folder.

sharing

• Memungkinkan untuk penambahan node pada saat jaringan aktif jadi untuk penambahan node jaringan tidak perlu dimatikan.

• Jika salah satu node ada yang rusak, sistem jaringan tetap dapat beraktifitas.

c.

Topologi Star adalah topologi jaringan komputer yang menggunakan

concentrator (hub atau switch) sebagai pengatur paket data.

Topologi Star.

• Mudah di hubungkan dengan jaringan lain.

• Mudah dalam perawatan jaringan.

dengan jaringan lain. • Mudah dalam perawatan jaringan. Gambar 1-8: Topologi Star. Kerugian topologi star: •

Gambar 1-8: Topologi Star.

Kerugian topologi star:

• Biaya agak mahal, karena menggunakan hub atau switch.

• Hub atau switch merupakan kunci dari aktifitas jaringan, jika hub atau swicth rusak maka aktivitas jaringan akan berhenti (jaringan rusak).

• Bila menggunakan hub (concentrator) dan lalu lintas data padat dapat menyebabkan terjadi collision (tabrakan data).

d. Topologi Tree

Topologi Tree merupakan kombinasi dari topologi bus dengan topologi star (star - bus). Dalam topologi ini tidak semua node (komputer) mempunyai kedudukan yang sama. Node dengan kedudukan yang tinggi menguasai node di bawahnya, sehingga node yang terbawah sangat tergantung pada node di atasnya. Penerapan topologi ini biasa digunakan pada infrastruktur jaringan LAN antar dua gedung. Adapun gambar dari topologi ini adalah sebagai berikut:

Keuntungan topologi star:

• Dapat digunakan untuk sistem jaringan workgroup (peer to peer) atau

client-server.

13

12

Gambar 1-9: Topologi Tree e. Topologi Ring Topologi jaringan yang berupa lingkaran tertutup yang berisi

Gambar 1-9: Topologi Tree

e. Topologi Ring Topologi jaringan yang berupa lingkaran tertutup yang berisi node-node. Signal mengalir dalam dua arah sehingga dapat menghindari terjadinya collision sehingga memungkinkan terjadinya pergerakan data yang cepat. Semua komputer yang saling tersambung membentuk

lingkaran (seperti bus tetapi ujung-ujungnya disambung). Data yang dikirim diberi address tujuan sehingga dapat menuju komputer yang dituju. Tiap komputer dapat diberi repeater (transceiver) yang mempunyai berfungsi:

Listen state: selama penerimaan bit, repeater juga melakukan modifikasi pada bit yang diterima dan diteruskan kembali (dibutuhkan 1 bit delay).

Transmit state: jika station hendak mengirim, maka repeater akan mengirimkannya melalui outgoing link.

14

Bypass state, bit dikuatkan dan langsung diteruskan ke repeater berikutnya.

Keuntungan topologi ring:

• Pemeliharaannya mudah

• Dapat menggunakan kabel fiber optik

• Jarak jangkauan lebih jauh daripada bus

• Laju data (transfer rate) tinggi

• Dapat melayani lalu lintas data yang padat

• Tidak diperlukan pengendali pusat (hub/switch),maka relatif lebih murah

• Komunikasi antar terminal mudah

Kerugian topologi ring:

• Jika ada satu repeater mati, jaringan mati.

• Penambahan atau pengurangan terminal sangat

sulit.

• Kerusakan pada media pengirim dapat menghentikan kerja seluruh jaringan.

• Kerusakan pada salah satu terminal dapat mengakibatkan kelumpuhan jaringan.

• Tidak kondusif untuk pengiriman suara, gambar dan data.

15

Gambar 1-10: Topologi Ring f. Topologi Mesh Pada topologi ini semua komputer saling terkoneksi satu

Gambar 1-10: Topologi Ring

f. Topologi Mesh

Pada topologi ini semua komputer saling terkoneksi satu sama lain

dan penerapannya pada jaringan WAN (Wide Area Network).

Sebagai contoh jaringan internet dan gambar dari topologi ini

adalah sebagai berikut:

dan gambar dari topologi ini adalah sebagai berikut: Gambar 1 -11: Topologi Mesh 16 1.5 Tipe

Gambar 1 -11: Topologi Mesh

16

1.5 Tipe Jaringan

Dilihat dari tingkatan hak akses dan kedudukan komputer dalam jaringan, tipe jaringan komputer dibagi menjadi:

Peer to peer

Pada jaringan tipe ini semua komputer yang tergabung dalam sistem mempunyai kedudukan yang sama.

yang tergabung dalam sistem mempunyai kedudukan yang sama. Gambar 1-12: Jaringan peer to peer. • Client

Gambar 1-12: Jaringan peer to peer.

Client Server.

Pada jaringan ini masing-masing komputer yang terhubung dalam sistem mempunyai kedudukan dan hak akses yang berbeda. Contoh komputer server, tentu akan mempunyai hak akses yang berbeda dengan komputer client.

Gambar 1-13: Jaringan clint server

17

Server adalah komputer yang menyediakan fasilitas (resource) komputer- komputer lain di dalam jaringan dan client adalah komputer-komputer yang menerima atau menggunakan fasilitas (resource) yang disediakan oleh server. Server dijaringan tipe client-server disebut dengan Dedicated Server karena murni berperan sebagai server yang menyediakan fasilitas kepada workstation dan server tersebut tidak dapat berperan sebagai workstation.

18

BAB II

KOMPONEN

JARINGAN

KOMPUTER

Tujuan:

Memahami komponen jaringan komputer dan implementasinya.

20

Pada bagian ini akan dibahas mengenai hardware/ peralatan- peralatan dan software yang digunakan dalam membangun jaringan komputer. Pemilihan hardware yang kurang tepat akan menyebabkan terganggunya komunikasi di dalam jaringan computer. Pastikan bahwa hardware yang dipilih mempunyai kualitas yang bagus. Sebagai contoh adalah pemilihan kabel UTP sebagai media transmisi. Ada beberapa merk kabel UTP yang dijual, tetapi pilihlah kabel UTP dengan merk Belden Cat 5 sebagai media tranmisinya (penulis tidak mempromosikan merk dagang tertentu, tetapi demi kelancaran dalam membangun jaringan komputer anda, pilihlah hadware yang berkualitas bagus). Dalam pemilihan sofware yang dipakai dalam jaringan komputer, ditekankan kepada kemampuan penguasaan pengguna terhadap suatu software tertentu dan lisensi software tersebut. Begitu banyak sofware yang dipakai dalam jaringan komputer seperti Microsoft (Microsoft server, xp.dll), mikrotik, linux, dll. Kuasailah terlebih dahulu software yang akan digunakan sebelum diaplikasikan ke jaringan komputer anda.

2.1 Media Transmisi

Merupakan suatu media yang berfungsi untuk menghubungkan

antar komputer secara fisik sebagai sarana komunikasi data.

Media transmisi dalam jaringan komputer dibedakan menjadi

tiga macam yaitu:

1. Media transmisi dengan kabel

2. Media transmisi tanpa kabel/Wi-Fi

3. Media transmisi dengan satelit (VSAT)

1. Media transmisi dengan kabel

Dalam jaringan komputer dikenal dengan 3 macam kabel

sebagai sarana komunikasi data, antara lain:

Komponen Jaringan Komputer

a. Kabel coaxial.

Kabel ini biasa digunakan untuk topologi bus. Secara fisik, kabel coaxial seperti kabel antena televisi. Mirip sekali antara kabel coaxial dengan kabel antena, tetapi yang membedakan adalah struktur dalam dari kabel. Bentuk fisik kabel coaxial adalah sebagai berikut:

Gambar 2-1: Kabel coaxial dan konektor BNC.

Kabel coaxial yang dipakai di jaringan komputer ada 2 macam yaitu thick coaxial dan thin coaxial.

Thick coaxial (RG-6) Kabel jenis ini dispesifikasikan berdasarkan standar IEEE 802.3 10BASE5 dan disebut sebagai standar thick ethernet

(ThickNet). Ciri fisik kabel ini adalah mempunyai diameter rata- rata 12 mm dan berwarna kuning. Aturan penggunaan kabel pada sebuah jaringan adalah:

• Jarak maksimum panjang kabel tiap adalah 500 m

• Jumlah perangkat keras maksimum tiap segmen/bagian adalah 100 perangkat keras. Yang termasuk perangkat keras adalah komputer, hub, switch maupun repeater.

• Jarak maksimum tiap segmen adalah 150 m

• Jumlah segmen maksimum adalah 3

• Setiap ujung kabel hams diberi terminator 50 ohm.

• Setiap segmen harus diberi ground

21

Membangun Server Internet dengan MikroTik OS

* Setiap kartu jaringan mempunyai pemancar tambahan

(external/ transceiver).

• Jarak maksimum antara percabangan dengan device (printer, scanner) adalah 5 m dan jarak minimumnya adalah 2,5 m.

Thin coaxial (RG-58)

standar IEEE 802.3

-10BASE2 dan disebut sebagai standar thin ethernet (ThinNet). Ciri fisik kabel ini adalah mempunyai diameter rata-rata 5 mm. Aturan

Kabel

jenis

ini

dispesifikasikan

berdasarkan

penggunaan kabel pada sebuah jaringan adalah:

• Jarak maksimum panjang kabel tiap adalah 185 m

• Jumlah perangkat keras maksimum tiap segmen/bagian adalah 30 perangkat keras. Yang dimaksud perangkat keras adalah komputer, hub, switch maupun repeater.

• Jarak maksimum tiap segmen adalah 55 m

• Jumlah segmen maksimum adalah 3

• Setiap ujung kabel harus diberi terminator 50 ohm.

• Setiap segmen harus diberi ground

• Setiap kartu jaringan mempunyai pemancar tambahan (external

transceiver).

• Jarak maksimum antara percabangan dengan device(printer, scanner) adalah 5 m dan jarak minimumnya adalah 2,5 m.

b. Kabel Twisted Pair

Twisted Pair terdiri dari 2 jenis:

1. Unshielded Twisted Pair (UTP)

2. Shielded Twisted Pair (STP)

Perbedaan antara UTP dan STP adalah ada tidaknya lapisan pelindung interferensi. Hal lain yang mempengaruhi besar kecilnya derau ataupun interferensi adalah jumlah anyaman (twisting) dari kabel tersebut. Tentunya kabel STP memiliki

22

Komponen Jaringan Komputer

lapisan pelindung interferensi, tetapi kabel STP jarang digunakan karena mahal. Kabel Twisted Pair (UTP) paling banyak digunakan dalam jaringan LAN adalah kabel UTP Cat5 (dibaca kategori 5), seperti gambar berikut:

UTP Cat5 (dibaca kategori 5), seperti gambar berikut: Gambar2-2:KabelUTPCat5 Untuk mencari kabel UTP yang

Gambar2-2:KabelUTPCat5

Untuk mencari kabel UTP yang berkualitas baik adalah dengan cara menggesek-gesekkan inti kabel dengan bantuan si let/cutter atau amplas, jika inti kabel tidak berubah warnanya (tetap warna tembaga) berarti kabel tersebut baik, tetapi jika inti kabel berubah menjadi silver maka kabel tersebut kurang baik. Beberapa macam kategori kabel UTP dapat dilihat pada tabel2-

1.

Tabel 2-1 :Tipe kabel UTP

Tipe kabel

UTP

Kategori 1

UTP

Kategori 2

Keterangan

Analog. Biasanya digunakan di perangkat telepon pada jalur ISDN (Integrated Service Digital Network), juga untuk menghubungkan modem dengan line telepon

perangkat telepon pada jalur ISDN (Integrated Service Digital Network), juga untuk menghubungkan modem dengan line telepon

Bisa mencapai 1 Mbits (sering digunakan pada topologi Ring)

r

23

Tlpe kabel

Keterangan

UTP/STP

16 Mbits data transfer (sering digunakan pada topologi

Catagori 3

Ring atau 10 BaseT).

UTP/STP

20 Mbits data transfer (sering digunakan pada topologi

Catagori 4

Ring).

UTP/STP

Bisa mencapai 100 Mbits (sering digunakan pada topologi

Catagori 5

Star atau tree).

UTP/STP

1 Gigabit Ethernet, jarak 100m, terdiri dari 4 pasang kabel tembaga yang tiap pasangnya di-plintir (sering digunakan pada topologi token ring 16 Mbps, Ethernet 10/100 Mbps).

Catagori 5

Enhanced

UTP/STP

2,5 Gigabit Ethernet, dengan kec frekuensi 155 Mhz atau

Catagori 6

250 Mhz.

UTP/STP

Gigabit Ethernet, dengan kec frekuensi 200 Mhz atau 700

Catagori 7

Mhz.

c. Kabel fiber optik

baik

dibandingkan dengan jenis kabel lainnya, tetapi kendalanya adalah masalah harga yang mahal. Berikut adalah gambar bentuk fisik kabel

fiber optik:

Kabel

ini

merupakan

jenis

media

transmisi

yang

sangat

optik: Kabel ini merupakan jenis media transmisi yang sangat Gambar 2-3: Bentuk fisik kabel fiber optik.

Gambar 2-3: Bentuk fisik kabel fiber optik.

Kabel Serat Optik memiliki jangkauan lebih panjang, frekuensi lebih tinggi, lebih ringan, berukuran kecil, tidak ada radiasi elektrik, kebal terhadap derau, dan isolasi ground yang baik. Kabel serat optik mempunyai diameter sangat tipis, antara 2-125/ym. Berbagai bahan kaca dan plastik dapat digunakan untuk membuat serat optik yang baik dan memiliki loss terkecil adalah menggunakan serat ultra pure fussed silica. Bahan ini sangat

24

Sulit untuk diproduksi karena itu digantikan oleh bahan lain yang memiliki loss yang lebih besar tetapi masih dapat di toleransi yaitu bahan plastik dan campuran kaca. Serat optik berbentuk silindris terdiri dari tiga bagian, core, cladding, jacket. Core adalah bagian terdalam dan terdiri dari 1 serat atau lebih. Tiap serat tersebut dikelilingi oleh cladding dan kemudian ditutupi oleh coating. Bagian terluar adalah jacket yang bertugas melindungi serat optik dari kelembaban, abrasi dan kerusakan.

2. Media transmisi tanpa kabel /Wi-Fi (Wireless Fidelity)

Media ini biasa disebut wireless atau jaringan nirkabel, yang menggunakan gelombang radio sebagai sarana penyampaian informasi paket data. Wireless merupakan perangkat jaringan yang fleksibel, baik dari perawatan, kerapian dan instalasi infrastrukturnya. Berikut adalah macam-macam contoh komponen wireless dalam jaringan LAN :

kerapian dan instalasi infrastrukturnya. Berikut adalah macam-macam contoh komponen wireless dalam jaringan LAN :
Gambar 2-4: Macam-macam komWpoi-Fne.i n 3. Media Transmisi dengan Satelit Satelit biasa digunakan untuk komunikasi

Gambar 2-4: Macam-macam komWpoi-Fne.i n

3. Media Transmisi dengan Satelit

Satelit biasa digunakan untuk komunikasi data jarak jauh, misalnya antar propinsi, antar negara atau antar benua. Antena

yang biasa digunakan pemakai adalah antena parabola. Berikut contoh instalasi infrastruktur antena parabola

2.2 Hardware untuk membangun infrastruktur jaringan komputer dan koneksi ke internet.

Hardware dan software untuk membangun infrastruktur jaringan komputer dibedakan menjadi 2 yaitu dengan media kabel atau nirkabel (wireless)

A. Infrastruktur jaringan LAN dengan media transmisi Kabel

Ada beberapa komponen yang hams disediakan jika hendak membangun jaringan LAN dengan media kabel, antara lain:

1. Ethernet Card (NIC)

Gambar 2-6: Ethernet Card

27

Merupakan interface komunikasi data dalam sistem jaringan komputer, interface ini mempunyai kecepatan rate data 10/10 Mbps atau 10/100 Mbps dan model terbaru 100/1000 Mbps. Media transmisi data antar komputer bisa menggunakan kabel UTP cat 5, Coaxial RG 8, fiber optic. Berikut contoh bentuk fisik ethernet card:

2.

KabelUTPCat5

Kabel ini penggunaan dalam sistem jaringan dengan panjang max

100 meter, jika lebih harus dipasang repeater (penguat signal data)

bam bisa disambung kabel UTP lagi. Contoh: Kabel UTP merk

Belden.

disambung kabel UTP lagi. Contoh: Kabel UTP merk Belden. Gambar 2-7: UTP dengan konektor RJ 45

Gambar 2-7: UTP dengan konektor RJ 45

Pengurutan kabel UTP dapat dibedakan menjadi 2 macam yaitu berdasarkan hubungan crossover dan hubungan straight.

Hubungan Crossover adalah hubungan Pc - Pc, Hub -Hub,

Switch - Switch, Router - Router, 'pengurutan dapat dilihat pada tabel

2-2.

Tabel 2-2: Hubungan dan Urutan Kabel Crossover Standar Microsoft

28

PCJL

PC,

B

Hubungan Straight adalah Pc - Hub, Pc - Switch, Switch - Router, Pc - Access Point. Pengurutan dapat dilihat pada tabel 2-3.

Tabel2-3:HubungandanUrutanKabelStraightStandarMicrosoft

 

Wmiu

Pin Rj-

r.isunyan warna

Pin Rj-

Wnniii

 

45

45

P.

Orange

1

 

1

P.Orange

 
 

Orange

2

2

Orange

P.

Hijau

3

--------------------

3

P. Hijau

Biru

4

4

P

Biru

S

 

s

Hijau

 
 

Hijau

6

 

6

Hijau

1'

Coklat

---------------------

P.Coklat

Coklat

7 8

7 8

Coklat

Dari tabel 2-2 dan 2-3 yang menjelaskan hubungan tiap node dan pengurutan kabel UTP, maka langkah berikutnya adalah dilakukan

instalasi kabel UTP. Langkah-langkah instalasi adalah sebagai berikut:

1. Pengurutan kabel I 2.

Menguatkan (clipping) agar kabel tidak lepas dari konektor 4 Melakukan test dengan alat tester RJ 45

Memasukkan kabel ke konektor RJ 45 3.

29

Gambar 2-8: Langkah instalasi UTP dengan konektor RJ 45 1. Pengurutan Kabel Pengurutan kabel telah

Gambar 2-8: Langkah instalasi UTP dengan konektor RJ 45

1. Pengurutan Kabel Pengurutan kabel telah dijelaskan pada tabel 2 dan 3. Yang hams diperhatikan adalah hubungan tiap node dan pengurutan kabel untuk setiap pinnya.

2. Memasukkan kabel ke konektor RJ 45

Setelah urutan kabel sesuai dengan nomor pin, maka kabel

dapat dimasukkan ke dalam RJ 45

30

3. Menguatkan (clipping) agar kabel tidak lepas dari konektor Clipping dilakukan agar kabel yang telah dimasukkan ke RJ 45 tersebut tidak lepas lagi. Yang harus diperhatikan adalah harus dilakukan dengan kuat agar kabel dapat menyatu dengan pin-pin RJ 45 sehingga terjadi tegangan antara kabel dan pin RJ 45. Dengan adanya tegangan ini, maka kabel dapat dipakai sebagai media transmisi.

4. Melakukan Test dengan tester RJ 45

Langkah ini merupakan langkah terakhir yang harus dilakukan, dan pada langkah ini akan diketahui apakah kabel yang telah dimasukkan ke RJ 45 dapat digunakan sebagai media transmisi. Ujung-ujung kabel yang telah dimasukkan ke konektor, dimasukkan ke dalam lubang konektor yang ada di tester Rj 45 kemudian tester RJ 45 akan memberikan signal berupa lampu hijau. Di sebelah lampu hijau ini terdapat angka 1 sampai dengan 8 yang memberi arti bahwa bila lampu hijau nyala berarti hubungan kabel dengan pin RJ 45 tidak bermasalah. Sebagai contoh adalah, bila lampu hijau no 2 menyala berarti

urutan kabel no 2 tidak bermasalah. Demikian seterusnya dengan kabel 1,3,4,5,6,7,8. Terkadang ada lampu hijau yang tidak menyala, hal ini dikarenakan karena proses Clipping yang tidak kuat. Pada tabel 2-4, penulis memberikan pin-pin yang dianggap penting sebagai pengirim data. Lampu pin-pin ini harus hidup/ menyala pada saat dilakukan pengetesan.

31

32

Tabel 2-4: Fungsi Pin pada konektor Rj 45

Pin

 

Pin

Rj-45

Rj-45

 

1 Rx(+)

1

2 Rx(+)

 

2

3 Rx(-)

3

4 Rx(-)

 

4

5 Tx(+)

5

6 Tx(+)

 

6

7 NC

NC

7

8 NC

NC

8

Tx(-)

 

Tx(-)

NC

NC

NC

NC

Pada tabel 2-4 ini terlihat bahwa pada pin no 1 dan 2 berfungsi sebagai penerima (recieving(RX)), pin 3 dan 6 berfungsi sebagai pengirim (transferring(TX)), pin no 4,5,7,8 tidak memiliki fungsi/ground (NC artinya Not Connecting). Jadi setelah mengetahui fungsi tiap pin pada RJ 45 maka lampu hijau pada tester RJ 45 untuk no pin 1,2,3,6 hams menyala. Sedangkan no pin no 4,5,7,8 lampu hijau diperbolehkan tidak menyala, tetapi sebaiknya seluruh no pin pada tester RJ 45 menyala semua.

3. Hub/Concentrator atau Switch.

H ub/Concentrator Merupakan sebuah repeater dengan banyak port (multi port) yang mendukung kabel twisted pair dalam sebuah topologi star. Setiap node yang berkomunikasi dengan hub atau consentrator,

kemudian sinyal akan diperkuat dan ditransmisikan keluar dari setiap port. Hub bekerja pada level listrik

keluar dari setiap port. Hub bekerja pada level listrik Gambar2-9:Hub Switch. Merupakan gabungan dari hub dan

Gambar2-9:Hub

Switch. Merupakan gabungan dari hub dan bridge yang berfungsi untuk meneruskan paket data dalam sistem komunikasi data, prinsip kerja:

• Menggunakan alamat network yang sama pada semua port.

• Membuat tabel berdasarkan alamat MAC.

• Memfilter lalu lintas network berdasarkan informasi MAC.

• Memforward lalu lintas berdasarkan frame.

• Memforward lalu lintas broadcast.

berdasarkan frame. • Memforward lalu lintas broadcast. Gambar 2-10: Switch 4. Router Merupakan hardware yang

Gambar 2-10: Switch

4. Router

Merupakan hardware yang berfungsi untuk menghubungkan dua i M twork atau lebih yang berbeda network id atau arsitekturnya.

33

Prinsip kerja:

6.

Modem

Menggunakan alamat network yang befbeda pada semua port

• Membuat tabel berdasarkan alamat layer

network.

• memfilter lalu lintas network berdasarkan intormasi

network.

• Memblokir lalu lintas ke alamat yang tidak diketahui

• Memblokir lalu lintas ke alamat yang tidak diketahui 5. Gambar2-11:Router Komputer standar Merupakan hardware

5.

Gambar2-11:Router

Komputer standar

Merupakan hardware yang berfungsi untuk menjalan software sistem operasi (Windows, linux, free BSD, open BSD dll) dalam

sistem jaringan komputer.

Merupakan perangkat modulator de modulator yaitu untuk mengubah informasi data digital ke analog atau sebaliknya. Pada Modem standar, saat ini telah tersedia Modem dengan kecepatan 56 Kbps bahkan lebih. Modem juga dilengkapi dengan kompresi data (data compression) dan error correction yang cukup bagus sehingga semakin meningkatkan kinerjanya yang pada akhimya meningkatkan kinerja komputer pada saat berkomunikasi. Menurut bentuknya dan pemasangannya, perangkat Modem ini dibedakan menjadi 2, yaitu :

1. Internal Modem (modem internal). Modem internal, dipasang pada Slotekspansi PCI atau ISA pada sebuah mainboard komputer (tergantung teknologi card modemnya).

2. External Modem (modem ekstemal). Jenis Modem ini di pasang diluar komputer dan terhubung pada salah satu port serial (COM port) baik port serial DB_9 atau DB_25 dan port USB. Bahkan sekarang telah keluar teknologi modem dengan kecepatan tinggi bisa menembus rate data 384 Kbps yaitu modem adsl. Pada modem ekstemal membutuhkan catu daya tersendiri sedangkan modem internal tidak memerlukan catu daya sendiri.

adsl. Pada modem ekstemal membutuhkan catu daya tersendiri sedangkan modem internal tidak memerlukan catu daya sendiri.

Gambar2-13:Modem

34

35

B. Infrastruktur Jaringan LAN dengan Media Tranmisi Tanpa Kabel/WIFI

Berikut merupakan hardware yang harus dipersiapkan jika hendak membanguh infrastruktur jaringan LAN tanpa kabel (wireless):

membanguh infrastruktur jaringan LAN tanpa kabel (wireless): Gambar 2-14: Hardware wireless 36 2.3 Sofware untuk

Gambar 2-14: Hardware wireless

36

2.3 Sofware untuk Membangun Infrastruktur Jaringan Komputer

Disamping harware yang diperlukan, software pun juga harus dipersiapkan jika hendak membangun jaringan komputer. Software sistem operasi untuk network ada yang harus beli lisensi maupun non lisensi.

Software lisensi Salah satu contoh software untuk network yang harus beli lisensinya seperti:

• Microsoft windows (Windows 97, Windows '98, Windows 'ME, Windows XP, Wndows 2000 P, Windows 2000 Server, Windows 2003 Server, Windows Vista, Wmdos NT).

• Novell Netware

Software non lisensi Yang dimaksud software non lisensi adalah suatu perangkat lunak yang sifatnya free dari segi untuk memperoleh software master maupun implementasi pada hardware komputer (tidak harus membeli lisensi dari pihak vendor), bahkan untuk mendapatkan software masternya kita dapat download dari internet seperti:

• Linux, seperti: Slackware, Ubuntu, Suse, Vedora, RedHat, Vector dsb.

• Free BSD dan Open BSD .

2.4 Protokol

Merupakan sebuah aturan yang mendefinisikan beberapa fungsi yang ada dalam sebuah jaringan komputer, misalnya mengirim pesan, data, informasi dan fungsi lain yang harus ditaati atau

37

dipenuhi oleh sisi penerima (receiver) maupun sisi pengirim

(transmitter) agar komunikasi antar komputer dapat berlangsung

dengan benar.

jaringan komputer yaitu NetBEUI, IPX /SPX dan TCP /IP.

• NetBEUI (NetBios Extended User Interface). Protokol ini dipakai pada jaringan LAN kecil yang sederhana dengan menggunakan sistem operasi microsoft. NetBEUI didasarkan pada protokol NetBIOS yang dikembangkan oleh IBM untuk workgroup. Jaringan NetBEUI tidak bisa di route, karena protokolnya tidak dapat di route. Sehingga jaringan dengan NetBEUI bersifat lokal, atau tidak bisa menghubungkan 2 jaringan NetBEUI.

IPX /SPX (Internet Package Exchange / Sequenced Packed Exchange), merupakan pengembangan dari NetBEUI dengan penambahan kemampuan routing dan remote console. Protokol ini diperuntukkan untu jaringan NetWare sebelum versi 5.0. IPX /SPX memberikan kinerja lebih cepat dari pada TCP/IP.

TCP /IP. Merupakan protokol yang paling populer dan paling banyak digunakan saat ini, dengan alasan:

• TCP /IP menggunakan pengalamat yang fleksibel dan untuk jaringan besar.

• Hampir semua sistem operasi dari platform dapat menggunakan TCP /IP.

• Merupakan protokol untuk internet global

Dalam jaringan LAN terdapat tiga protokol

Protokol yang terpasang pada komputer anda dapat dilihat pada windows yaitu pada Lical Area Connection Properties, seperti terlihat pada gambar berikut:

38

Gambar 2-15. Protokol TCP/IP

BAB III

PEMAHAMAN IP ADDRESS

Tujuan:

Memahami konsep IP address dan Subnet mask

3.1 IP Address

IP atau Internet Protocol adalah sederetan angka biner 32 bit yang terbagi menjadi 4 kelompok, masing-masing kelompok terdiri atas biner 8 bit yang dipisahkan dengan tanda titik (dot). IP beroperasi pada lapisan network OSI (Open System Interconnection). Untuk mempermudah dalam pemahaman, biner 32 bit ini dinotasikan dalam bentuk bilangan desimal dengan anggota 0 sampai 9 di semua sistem operasi network baik Windows, Linux, Novell netwere maupun free BSD atau Open BSD. Format IP biasa di disimbolkan dengan huruf "x", dimana x bisa bernilai biner 1 atau 0. Contoh:

xxxxxxxx . xxxxxxxx. xxxxxxxx . xxxxxxxx (label hu ruf X)

11000000.10101000.00000000.00000001 (jika x bernilai 1 atau 0)

192.168.0.1 (konversi biner

ke desimal)

desimal

diberbagai sistem operasi network (network operating system), untuk komunikasi protokol TCP/IP tetap menggunakan angka biner (karena komputer dalam berkomunikasi atau berinteraksi

antar komponen menggunakan sinyal digital).

Walaupun

IP

address

dinotasikan

dalam

angka

i. Kelas A

Kolas A mempunyai 8 bil yang dialokasikan untuk Network ID

(bit untuk nomor unit jaringan) dan 24 bit yang dialokasikan untuk

alamat Host ID (bit untuk nomor unik kompuloi atau ethernet). Bit

yang merupakan urutan nilai tertinggi (most signification bit) berada di

paling kiri dengan nilai selalu 0. Adapun format penulisan berikut:

0

Network ID

Host ID

Tabel 3-1:Kelas A

Snhingga untuk alamat minimumnya semua bit di isikan dengan ungka 0.

00000000.00000000.00000000.00000000

(nilai biner)

0.0.0.0

(nilai desimal)

Sedangkan untuk mendapatkan alamat maksimumnya semua bit di

isikan dengan biner 1 (kecuali bit pertama paling kiri).

 

01111111.11111111.11111111.11111111

(nilai biner)

3.2 Kelas IP Address

127.255.255.255

(nilai desimal)

Dalam pengelolaannya IP address di bagi menjadi 5 kelas, yang

mana masing-masing kelas akan mempunyai fungsi bit yang

berbeda-beda. Berikut merupakan pembagian ke 5 kelas dari IP address tersebut:

42

Karena dalam kelas A bit yang dialokasikan untuk alamat host (komputer) sebanyak 24 bit (2 24 ), sehingga alamat ini dipakai untuk jaringan besar (big network).

b. Kelas B

Kelas B mempunyai 16 bit untuk alokasi alamat Network ID dan 16 bit untuk alokasi alamat Host ID (nomor unik ethernet komputer). Bit yang mempunyai nilai tertinggi berada di paling kiri dengan nilai selalu 10.

43

Tabel3-2:KelasB

1

0

Network ID

Host ID

Pada kelas B, untuk mendapat alamat minimumnya dengan cara mengisikan biner 0 semua ke 30 bit dalam tabel di atas.

10000000.00000000.00000000.00000000 (nilai biner)

128.0 .0.0

(nilai desimal)

dan untuk mendapatkan alamat maksimum ke 30 bit tersebut di

isikan dengan biner 1 semua.

10111111.11111111.11111111.11111111

(nilai biner)

191.255.255.255

(nilai desimal)

di alokasikan untuk Host ID

sebanyak 16 bit (2 16 ), sehingga alamat ini biasa dipakai untuk jaringan sedang (medium network).

Karena dalam kelas B bit yang

c. Kelas C

Dalam kela C bit yang di alokasikan untuk Network ID sebanyak 24 bit

dan bit yang dialokasikan untuk Host ID sebanyak 8 bit. Bit paling

kiri merupakan bit yang nilainya paling tinggi dan selalu bernilai 110.

Tabel 3-3: Kelas C

1

1

0

Network ID

Host ID

Pada kelas C untuk mendapatkan alamat minimum dengan cara mengisikan ke 29 bit pada tabel di atas dengan biner 0 semua.

11000000.00000000.00000000.00000000 (nilai biner)

192.0.0.0 (nilai desimal)

dan untuk mendapatkan alamat maksimum dari kelas C ini, ke 29 bit tersebut di isikan dengan biner 1 semua.

11011111.11011111.11011111.11011111

(nilai biner)

223.255.255.255

(nilai desimal)

Karena dalam kelas C bit yang di alokasikan untuk alamat Host ID sebanyak 8 bit (2 8 ), maka alamat ini biasa di pakai untuk jaringan kecil (small network).

d. Kelas D

Dalam jaringan kelas D semua bit digunakan untuk keperluan multicasting. Bit yang bernilai paling tinggi berada pada bit yang paling kiri dan selalu bernilai 1110.

Tabel 3-4: Kelas D

1

1

1

0

Kelompok Multicast

Untuk mendapat nilai alamat minimumnya dengan cara memasukkan biner 0 semua ke 28 bit tersebut

11100000.00000000. 00000000. 00000000

(nilai biner)

224.0.0.0

(nilai desimal)

Sedangkan untuk mendapat alamat maksimumnya, dengan cara memasukkan biner 1 semua ke 28 bit pada kelas D.

11101111.11111111.11111111.11111111

(nilai biner)

2 39 .2 5 5 .2 55 .2 5 5

(nilai desimal)

e. Kelas E

Dalam kelas E bit yang nilainya paling tinggi berada pada bit paling kiri dan selalu bernilai 11110.

Tabel 3-5: Kelas E

1

1

1

1

0

Di cadangkan

45

44

Nilai minimum untuk kelas E adalah

11110000.00000000.00000000.00000000

(nilai biner)

240.0.0.0

(nilai desimal)

Sedangkan untuk nilai maksimumnya adalah

11110111.11111111.11111111.11111111 (nilai biner)

247.255.255.255 (nilai desimal)

Alamat ini digunakan untuk keperluan IP address di masa yang

akandatang.

3.3 Alamat Khusus

Dalam alamat khusus ini perlu diperhatikan sekali jika anda ingin memberikan alamat pada protocol TCP /IP di komputer anda.

• Alamat 0.0.0.0 tidak boleh digunakan untuk alamat yang menunjukkan host atau komputer.

• Alamat 255.255.255.255 tidak boleh digunakan untuk alamat host, karena alamat ini menunjukkan alamat broadcast.

• Nilai bit dalam format IP address yang menunjukkan alamat host, tidak boleh di isi dengan biner 0 semua atau 1 semua. Karena jika bit yang menunjukkan alamat host di isi biner 0 semua, secara otomatis akan digunakan oleh sistem sebagai alamat jaringan (Network-ID). Sedangkan jika bit untuk host tersebut di isi dengan biner 1 semua, secara otomatis akah menjadi alamat broadcast.

• Alamat 127.0.0.1 adalah alamat khusus yang digunakan untuk local host (loopback), sehingga tidak boleh di gunakan untuk Host ID.

• Alamat 224.0.0.0 - 239.255.255.255 digunakan untuk teknologi multicasting.

• Alamat 240.0.0.0 - 247.255.255.255 digunakan untuk keperluan IP address di masa yang akan datang.

46

3.4 IP Private

Dalam penggunaan IP address untuk mempermudah pengelolaan dalam jaringan baik jaringan WAN atau LAN, maka IP Address dibedakan menjadi 2 kelompok yaitu IP address yang ter-regritasi di internet dan IP address yang tidak di regestrasi dalam internet (IP Private). Kelompok IP address Private adalah alamat yang dipakai oleh LAN (Local Area Network) dan tidak dapat di akses oleh internet range IP private seperti pada tabel berikut:

Tabel 3-6 : IP private.

Kelas

KelompokPrivateAddress

A

10.0.0.1-10.255.255.254

B

172.16.0.1-172.31.255.254

C

192.168.0.1 -192.168.255.254

3.5 Subnet Mask

Nilai subnet mask berfungsi untuk memanajemen jumlah host. Dengan subnet mask router dapat menentukan bagian mana yang menunjukkan alamat jaringan (Network ID) dan bagian mana yang menunjukkan alamat host (Host ID). Format subnet mask terdiri dari 32 bit yang setiap 8 bitnya di pisahkan dengan tanda titik (dot). Pada subnet mask default, bit yang menunjukkan alamat jaringan di isi dengan biner 1 semua sedang bit yang menunjukkan alamat host di isi dengan biner 0 semua. Berikut merupakan tabel dari subnet mask default.

Tabel 3-7: Subnet mask

Kelas

SubnetMaskdalambiner

SubnetMask

dalam desimal

A

11111111.00000000.00000000.00000000

255.0.0.0

B

11111111.11111111.00000000.00000000

255.255.0.0

C

11111111.11111111.11111111.00000000

255.255.255.0

47

Contoh:

Kelas A

IP address

: 10.0.0.1

Subnet mask

: 255.0.0.0

Network ID

: 10.0.0.0

Broadcast ID

: 10.255.255.255

Kelas B

IP address

: 172.16.0.1

Subnet mask

: 255.255.0.0

Network ID

:

172.16.0.0

Broadcast ID

: 172.16.255.255

Kelas C

IPaddress

: 192.168.1.1

Subnet mask

: 255.255.255.0

Network ID

:192.168.1.0

Broadcast ID

: 192.168.1.255

Dalam sistem operasi Linux penulisan subnet mask ditulis dengan tanda “/”. Contoh:

• address 192.168.0.1/24 {kelas C} /24 diambil dari banyaknya jumlah angka 1 dari subnet.

Subnet kelas C adalah 255.255.255 jika dituliskan secara desimal adalah 11111111.11111111.11111111.00000000. Jika dihitung, maka jumlah angka 1 adalah sebanyak 24.

• address 172.16.0.1/16

{kelas B}

 

address 10.0.0.1/8.

{kelas A}

Contoh kasus:

Dalam sebuah lab. Jaringan komputer tersedia 14 komputer, antar komputer di buat LAN dengan topologi star. Jika dalam

48

LAN tersebut di kehendaki dengan alamat jaringan kelas C (misalkan 192.168.0.0). Tentukan:

• Subnet mask dan range IP address komputer dalam LAN tersebut!

Jawab:

Subnet mask kelas C

= 11111111.11111111.11111111.11110000

= 255.255.255.240

Jumlah host

=2 N -2 = 2 4 -2 =14

Sehingga range IP address LAN antara 192.168.0.1 -192.168.0.14, sedangkan alamat jaringan (Network ID):

192.168.0.0 dan alamat broadcastnya adalah 192.168.0.15

3.6 Subnetting

Subnetting adalah suatu metode untuk memperbanyak network ID dari suatu network ID yang telahanda miliki. Contoh kasus diperiukannya subnetting: Sebuah perusahaan memperoleh IP address network kelas C 192.168.0.0. Dengan IP network tersebut maka akan didapatkan sebanyak 254 (2 8 -2) alamat IP address yang dapat kita pasang pada komputer yang terkoneksi ke jaringan. Yang menjadi masalah adalah bagaimana mengelola jaringan dengan jumlah komputer lebih dari 254 tersebut. Tentu tidak mungkin jika anda harus menempatkan komputer sebanyak itu dalam satu lokasi. Jika anda hanya menggunakan 30 komputer dalam satu kantor, maka ada 224 IP address yang tidak akan terpakai. Untuk mensiasati jumlah IP address yang tidak terpakai tersebut dengan jalan membagi IP network menjadi beberapa network yang lebih kecil yang disebut subnet.

49

Rumus untuk menghitung jumlah subnet adalah: 2 n -2

n adalah jumlah bit yang diselubungi

Rumus untuk menghitung jumlah host per subnet = 2 N - 2 N adalah jumlah bit yang masih tersisa untuk host ID

a. Subnetting Kelas A

PEMAHAMAN IP ADDRESS

50

Jika suatu perusahaan telah mendapatkan IP jaringan 10.0.0.0, sehingga bisa dibangun suatu jaringan dengan jumlah host yang sangat besar yaitu 2 24 -2 atau 16777214 host Sedangkan jumlah komputer yang ada hanya 100 unit. Agar IP network tersebut bisa bermanfaat, maka diperlukan pembagian subnet. Dari IP jaringan tersebut bisa kita bagi subnetnya dengan cara:

Jumlah komputer yang tersedia sebanyak 100 unit, sehingga biner subnet masknya adalah 11111111.11111111.11111111.10000000 atau 255.255.255.128. sehingga jumlah subnetnya adalah 2 17 - 2 = 131070 dan jumlah host persubnetnya adalah 126. Sehingga masih memungkinkan untuk menambah komputer sebanyak 26 unit Dari rumus diatas sehingga bisa dibuat tabel subnetting kelas A seperti berikut

Tabel 3-8: Subnetting kelas A

Jumlah Subnet

Subnet Mask

Jumlah Host/ Subnet

2

255.192.0.0

4194302

6

255.224.0.0

2097150

14

255.240.0.0

1048574

30

255.248.0.0

524286

62

255.252.0.0

262142

126

255.254.0.0

131070

254

255.255.0.0

65534

510

255.255.128.0

32766

1022

255.255.192.0

16382

Jumlah Subnet

Subnet Mask

Jumlah Host/ Subnet

2046

255.255.224.0

8190

4094

255.255.2400

4094

8190

255.255.248.0

2046

16382

255.255.252.0

1022

32766

255.255.254.0

510

65534

255.255.255.0

254

131070

255.255.255.128

126

262142

255.255.255.192

62

524286

255.255.255.224

30

1048574

255.255.255.240

14

2097150

255.255.255.248

6

4194302

255.255.255.252

2

b. Subnetting Kelas B

Untuk kelas B dengan 3 bit diselubungi, Subnet Masknya adalah 11111111.11111111.11100000.00000000 atau 255.255.224.0 dan IP Network yang di miliki: 180.124.0.0. Dengan rumus jumlah subnet

adalah : 2 n - 2 dan jumlah host per subnet = 2 N - 2, sehingga dapat di hitung:

• jumlah subnet = 2 3 - 2 = 6

Jumlah bit yang masih tersisa untuk host ID adalah N = 16 -3 = 13

• jumlah host persubnet = 2 13 - 2 = 8190

Dengan menerapkan rumus (256-angka oktetyang diselubungi) = (256 - 224) = 32, sehingga kelompok subnet yang dapat digunakan adalah kelipatan 32 yaitu: 32,64,96,128,160,192.

Maka subnet (Network ID) yang tersedia adalah:

• 180.124.32.0

• 180.124.64.0

• 180.124.96.0

.

51

• 180.124.128.0

• 180.124.160.0

• 180.124.192.0

Dengan kelompok Ip Address yang dapat digunakan untuk host adalah:

• 180.124.32.1 sampai 180.124.63.254

• 180.124.64.1 sampai 180.124.95.254

• 180.124.96.1 sampai 180.124.127.254

• 180.124.128.1 sampai 180.124.159.254

• 180.124.160.1 sampai 180.124.191.254

• 180.124.192.1 sampai 180.124.223.254

Sedangkan kelompok broadcast yang dapat digunakan adalah:

180.124.63.255

 

180.124.95.255

180.124.127.255

180.124.159.255

180.124.191.255

180.124.223.255

Dengan menggunakan rumus di atas, sehingga bisa terbentuk tabel

subnetting kelas B seperti berikut:

Tabel 3-9: Subnetting kelas B

Jumlah Subnet

Subnet Mask

Jumlah Host /subnet

2

255.255.192.0

16382

6

255.255.224.0

8190

14

255.255.240.0

4094

30

255.255.248.0

2046

62

255.255.252.0

1022

126

255.255.254.0

510

254

255.255.255.0

254

52

Jumlah Subnet

Subnet Mask

Jumlah Host /subnet

510

255.255.255.128

126

1022

255.255.255.192

62

2046

255.255.255.224

30

4094

255.255.255.240

14

8190

255.255.255.248

6

16382

255.255.255.252

2

c. Subnetting Kelas C

Misalkan kita memiliki IP network 192.200.73.0 dengan subnet mask 11111111.11111111.11111111.11111100 atau 255.255.255.252 dimaha bit oktet ke empat yang terselubung adalah 252. Dengan menggunakan rumus di atas bisa di hitung:

• jumlah subnet = 2 6 - 2 = 62

• jumlah host persubnet = 2 2 - 2 = 2

Dengan menggunakan rumus (256-252)=4, sehingga kelompok

248.

Dengan demikian kelompok IP address yang dapat digunakan untuk host adalah:

subnet yang dapat dipakai adalah keiipatan 4 yaitu: 4,8,12,

192.200.73.5 sampaidengan 192.200.73.6

192.200.73.9 sampai dengan 192.200.73.10

 

.

 

.

 

.

192.200.73.249 sampai dengan 192.200.73.250

Sedangkan kelompok subnet (Network ID) yang dapat digunakan adalah :

• 192.200.73.4

• 192.200.73.8

53

192.200.73.248

Sedangkan kelompok broadcast yang dapat digunakan adalah:

192.200.73.7

192.200.73.11

 

.

 

.

 

.

192.200.73.251

Kasus soal Misalkan kita mendapatkan IP network 192.100.73.0 dengan subnet mask 11111111.11111111.11111111.11000000 atau 255.255.255.192,

dimana oktet bit ke empat yang terselubung adalah 192 (2 bit dari kiri). Seperti rumus diatas, sehingga bisa di hitung:

• jumlah subnet =2 2 - 2 = 2

• Jumlah host persubnet=2 6 - 2 = 62

Dengan menggunakan rumus (256-192)=64, sehingga kelompok subnet yang dapat digunakan adalah kelipatan 64 yaitu :64 dan 128.

Dengan demikian kelompok IP address yang dapat digunakan untuk host adalah:

• 192.100.73.65 sampai dengan 192.100.73.126

• 192.100.73.129 sampai dengan 192.100.73.190

54

BAB IV

INSTALASI

MIKROTIK

Tujuan:

Memahami Konsep Install Mikrotik dan Perintah dasar

4.1 Sekilas MikroTik

MikroTik merupakan sistem operasi jaringan (operating system network) yang banyak digunakan oleh Internet Service Provider untuk keperiuan firewall atau router network. MikroTik menjadikan router network yang handal yang dilengkapi dengan berbagai fitur dan tool, baik untuk jaringan kabel maupun wireless. Dalam tutorial kali ini penulis menyajikan pembahasan dan petunjuk sederhana dan simple dalam mengkonfigurasi MikroTik untuk keperluan-keperluan tertentu yang biasa dibutuhkan untuk server /router warnet maupun jaringan lainya. Konfirugasi tersebut meliputi: web-proxy, transparent proxy, firewall, BW manajemen dan MRTG. Versi MikroTik yang penulis gunakan untuk tutorial ini adalah MikroTik 2.9.27

4.2 Instalasi MikroTik

Sebelum melakukan instalasi, pastikan komputer yang akan diinstall MikroTik mempunyai spesifikasi hardware minimal: 2 NIC, RAM 128 MB, HDD 4 GB, Processor Pentuim III 800 MHz (semakin tinggi spesifikasi komputer yang digunakan akan semakin baik pula unjuk kerja server yang akan krta buat). Namun jika anda hanya membutuh kan sebagai router dan Bandwith Limiter (BW manajemen) dapat anda lakukan di komputer Pentium II atau bahkan Pentium I dengan spesifikasi RAM di bawah 128M dan HDD dibawah 4 GB. Untuk mendapatkan software master MikroTik dan software utilitasnya dapat anda download di http://mikrotik.com Untuk melakukan install MikroTikOS dengan Compaq Disk (CD), anda dapat mendownload file mikrotik.iso dari www.mikrotik.com. Setelah anda mendownload file iso tersebut lakukan Burn CD dengan software aplikasi Ahead Nero. Pada aplikasi ahead nero tersebut pilih Burn Image dari recorder menu, kemudian open file mikrotik.iso tersebut yang telah di

56

Instalasi Mikrotik

download dari www.mikrotik.com. Centang Write pada menu Action dan pilih Write speed sesuai yang anda kehendaki (misal 24x), kemudian klik buttom Burn sehingga proses Bum CD akan beriangsung dan klik finish.

Adapun langkah dalam menginstalasi sistem operasi MikroTik

adalah sebagai berikut: 1.

Set BIOS untuk booting melalui CD-ROM

Gambar 4-1: Boot kernel isolinux MikroTik

2. Setelah proses booting akan muncul menu pilihan software yang mau di instalasi, pilih sesuai kebutuhan yang akan direncanakan, jika anda menginginkan semua menu di instalasi tekan huruf "a".

Gambar 4-2: Paket software MikroTik

57

Sedangkan kalau untuk kebutuhan router, web-proxy, bandwidth manajemen, sebaiknya anda pilih:

System

DHCP

Advanced Tote

Routing

Routing Test

Security

Synchronous

Web-Proxy

Web Proxy- Test

Ket:

• System:

Packet yang wajib diinstail karena merupakan inti dari system mikrotik.

• PPP:

Untuk membuat Point to Point Protocol Server

• dhcp:

Packet yang dibutuhkan apabila ingin membuat dhcp server atau untuk mendapatkan dynamic ip address.

• Advanced-tools:

Tools tambahan seperti ip-scan, bandwidth test dan lainnya.

• arlan:

Packet untuk konfigurasi chipset wireless aironet arlan.

Packet untuk support GPS Device

• hotspot:

Packet untuk membuat hotspot gateway, seperti authentication, traffic quota dan SSL.

• hotspot-fix:

Tambahan packet hotspot

58

isdn:

Packet untuk isdn server dan isdn client mernbuluhkan packet PPP.

lcd:

Packet untuk customize port led

3.

Ketik " i " setelah setesai memilih option software, lalu

akan muncul menu pilihan seperti berikut:

Do yon want to keep old configuration [y/n] ketik y

Setelah anda ketik y akan muncul proses pembuatan partisi

dan format disk, seperti gambar berikut:

Continue ? [y/n]

ketik y

Gambar 4-3: Proses create partition dan format disk

Setelah proses pembuatan partisi dan format disk selesai akan dilanjutkan proses instalasi Mikrotik seperti gambar berikut:

59

Gambar 4-5: Proses install paket software MikroTik

4. Setelah proses instalasi paket software selesai, maka kita akan di minta untuk merestart system, tekan enter untuk merestart system (lihat gambar diatas).

60

5. Setelah komputer booting kembali ke system MikroTik, akan ada pilihan untuk melakukan check system disk, tekan

Gambar 4-6: Deteksi sistem error disk.

6. Setelah itu akan muncul menu login.

MikroTik Login=admin

password=(kosong saja), selanjutnya tekan Enter

Gambar 4-7: Halaman login MikroTik. 7.

61

Untuk Software Lisensi tekan "y", seperti gambar berikut:

Gambar 4-8: Halaman license agreement.

8. Setelah itu tekan Enter beberapa kali sampai muncul promt untuk command line. Berikut halaman promt command line:

Gambar 4-9: Promt command line.

Selesailah proses instalasi sistem operasi MikroTik

(MikroTikOS).

4.3 Perintah dasar MikroTik OS.

1. Untuk shutdown dan restart komputer, ketikkan:

[admin@MikroTik]> system shutdown [admin@MikroTik]> system reboot (untuk restart komputer) [admin@MikroTik]>

system reset (untuk mereset konfigurasi yang sudah kita buat sebelumnya). Perintah-perintah diatas harus dilakukan pada direktori admin.

62

2. Untuk merubah nama mesin MikroTik ini, ketik :

[admin@MikroTik]>/system identity [admin@MikroTik]system identity> set name=proxy

Untuk melihat hasil konfigurasi, ketikan "print" atau "pr" seperti perintah berikut:

[admin@proxy]system identity>pr name: "proxy"

Lalu konsole berubah menjadi

[admin@proxy]>

3. Merubah password mesin MikroTik, ketikkan :

[admin@proxy]>/password [admin@proxy]password>old password (ketikkan kosong, jika sebelumnya anda belum mengeset password) [admin@proxy]password>

new password :

<ketikkan

password yg baru>

[admin@proxy]password>retype new password :

<masukkan sekali lagi passwordnya>

Contoh:

Jika password lama di kosongkan dan password yang baru 123456, maka perintahnya adalah sebagai berikut:

[admin@proxy]>/password [admin@proxy]password>old password [admin@proxy]password>new password 123456 [admin@proxy]password>retype new password 123456

4. Melihat paket software MikroTik OS :

[admin@proxy] >/system package [admin@proxy] system package> <ketikan print atau pr>

ntoh:

Co

[admin@proxy] system package>print atau [admin@proxy] system package>pr

63

4

name="advanced-tools" version="2.9.27" build- time=jul/03/2006 10:56:41 scheduled=""

dengan perintah tersebut, maka akan tampil paket software yang ada dalam MikroTik OS. Contoh :

Gambar 4-10: Tampilan paket software MikroTik.

untuk melihat lebih detailnya, ketikan: [admin@proxy]

system package> pr detail Flags: X - disabled

0 X name="routing-test" version="2.9.27" build-time=jul/03/2006 10:57:35 scheduled-""

1 name="system" version="2.9.27" build- time=jul/03/2006 10:56:37 scheduled'""

2 name-"security" version="2.9.27" build- time=jul/03/2006 10:56:44 scheduled=""

3 name="web-proxy" version="2.9.27" build- time=jul/03/2006 10:58:03 scheduled=""

64

5 name="dhcp" version="2.9.27" build-time=jul/03/2006 10:56:45 scheduled=""

6 name="hotspot" version="2.9.27" build-time=jul/03/2006 10:56:58 scheduled=""

7 X name="webproxy-test" version="2.9.27" build- time=jul/03/2006 10:57:52 scheduled=""

8 name="routerboard" version="2.9.27" build- time=jul/03/2006 10:57:17 — [Q quit | D dump |up | down]

5. Mengupgrade paket software router:

[admin@MikroTik] system upgrade > To upgrade chosen packages:

[admin@MikroTik] system upgrade > download

0,1,2,5,6,7,8,9,10,13,14

6. Mengaktifkan paket software yang ada dalam MikroTik OS:

[admin@proxy] system package> enable <ketikan paket yang dikehendaki>

Contoh:

[admin@proxy] system package>enable dhcp

7. Mengaktif interface ethernet yang terpasang pada mesin MikroTik OS:

[admin@proxy]>/interface [admineproxy]interface> ethernet enable <ketikan ethernet yang terpasang>

65

Contoh:

[admin@proxy]>/interface [admin@proxy]interface> ethernet enable etherl

atau

[admin@proxy] interface> enable<ketikan number ethernet yang terpasang>

Contoh :

[admin@proxy]interface>enable 0 [admin@proxy]interf ace >enable 1

8. Merubah nama ethernet pada mesin MikroTik OS:

[adraineproxy]>/interface [admin@proxy] interf ace > ethernet set etherl

<ketikan nama ethernet sesuai yang dikehendaki>

Contoh:

Jika nama ethernet yang terpasang diberi nama "public", maka perintahnya adalah:

[admin@proxy]>/interface [admin@proxy] interface>ethernet set etherl name=public

atau

[admin@proxy] interface> set <ketikan number ethernet yang terpasang> name=<nama ethernet yang baru>

Contoh:

[admin@proxy]interface>set 0 name=public [admin@proxy]interface>set 1 name=lan

atau

[admin@proxy]interface>

set 0 name=public;

set 1 name=lan

66

9. Setting IP address pada mesin MikroTik OS :

[admin@proxy]>/ip address [admin@proxy]ip address> add interface=<nama interface> address= <ketikan IP address/ subnet mask interface>

Contoh:

Jika nama interfacenya "Ian" dan IP address yang dikehendaki: 192.168.0.1 dan subnet mask: 255.255.255.0, maka perintahnya sebagai berikut:

[admin@proxy]>/ip address [admin@proxy]ip address> add interface=lan address=192.168.0.1/24

10. Setting IP DNS Primary dan Secondary:

[admin@proxy]>/ip dns [admin@proxy] ip dns> set <nama-dns>=<IP dns dari ISP>

Contoh:

Jika IP DNS primary dari ISP :202.134.1.10 dan secondary:

202.134.0.155, maka perintahnya adalah sebagai berikut:

[admin@proxy]>/ip dns [admin@proxy]ip dns> set primary-dns=202.134.1.10 [admin@proxy] ip dns> set secondary-dns=202.134.0.155

11. Setting IP Gateway pada mesin MikroTik OS :

[admin@proxy]>/ip route [admin@proxy]ip route>add gateway=<IP gateway>

Contoh:

IP gateway dari ISP: 202.134.1.1, maka perintahnya:

[admin@proxy]>/ip route [admin@proxy]ip route> add gateway=202.134.1.1

67

12. Setting Network Address Translate (NAT) pada mesin MikroTik OS:

[admin@proxy] >/ip firewall nat [admin@proxy] ip firewall nat > add chain=srcnat out-interface=<ethernet yang terhubung dengan jaringan WAN> src-address= <network-id interface yang terhubung LAN/ subnet mask interface LAN> action=masquerade

Contoh:

Jika network-id interface LAN : "192.168.0.0" dan subnet mask: "255.255.255.0". Untuk interface mesin MikroTik OS yang terhubung ke jaringan WAN : "public", maka perintahnya sebagai berikut:

[admin@proxy]>/ip firewall nat [admin@proxy]ip firewall nat> add chain=srcnat out-interface=public src- address=192.168.0.0/24 action=masquerade

68

BABV

MIKROTIK

ROUTER

Tujuan :

Memahami konsep MikroTik router dan penerapannya

5.1 Topologi MikroTik router

Dalam bab ini akan di bahas tentang bagaimana cara membuat MikroTik router pada sebuah komputer standar yang dilengkapi dengan 2 buah ethernet card. Topologi jaringan MikroTik router yang akan dibahas seperti gambar berikut:

Gambar5-1:TopologiMikroTikrouter.

Sebelum melakukan konfigurasi ethernet, perlu anda ketahui

bahwa MikroTik OS bisa diakses:

• Via console

Mikrotik router board ataupun PC dapat diakses langsung

via console/ shell maupun remote akses menggunakan putty

• Via winbox Mikrotik bisa juga diakses/remote menggunakan software

tool winbox

70

• Via web

MikroTik juga dapat diakses via web/port 80 dengan menggunakan browser. Dalam konfigurasi ini, mikrotik diakses via konsole dan tool Win Box.

5.2 Mengaktifkan ethernet

Untuk mengaktifkan kedua ethernet yang terpasang pada mesin MikroTik router OS, dengan perintah:

[admin@proxy]>/interface

[admin@proxy]interface>ethernet enable etherl

Jika muncul tanda kesalahan, ada dua alasan: pertama : Ada kemungkinan ethernet card yang terpasang, rusak kedua : Driver dari ethernet card belum disupport oleh MikroTik OS.

Kemudian lakukan yang sama juga pada ethernet yang kedua :

[admin@proxy]>/interface [admin@proxy]interface>ethernet enable ether2

Untuk Melihat kedua ethernet Card yang terpasang (apakah sudah komplit dua), ketikkan print atau pr:

[admin@proxy] interface>print

Flags: X - disabled, D - dynamic, R - running

# NAME

TYPE

RX-RATE

TX-RATE

MTU

1

R etherl

ether

0

0

1500

2

R ether2

ether

0

0

1500

3

71

Konfigurasi dengan menggunakan Winbox

Gambar5-2:TampilanInterfaceList

5.3 Identitas Ethernet

Untuk merubah nama ethernet yang terpasang pada mesin

MikroTik, ketikkan:

[admin@proxy]>/interface [admin@proxy]interface>ethernet set ether1 name=public

Untuk melihat hasil konfigurasi ketikan:

[admin@proxy]interface>pr

Flags: X - disabled, D - dynamic, R - running

#

NAME

TYPE

RX-RATE

TX-RATE

MTU

0

R public

ether

0

0

1500

Kemudian lakukan yang sama pada ethernet yang kedua:

[admin@proxy]>/interface [admin@proxy]interface> ethernet set ether2 name=lan

72

Mlkrotik Router

Untuk melihat hasil konfigurasinya ketikan :

[admin@proxy]interface>pr

Flags: X - disabled, D - dynamic, R - running #

NAME

1

ether

2

ether

TYPE

0

0

RX-RATE

TX-RATE

MTU

R public

0

R Ian

0

1500

1500

Konfigurasi dengan menggunakan Winbox:

Klik menu lnterfaces> tanda + warna merah, kemudian isikan kolom Name dan MTU seperti berikut:

Gambar 5-3: Tampilan Interface List

Catatan: Kalau sudah anda rubah nama ethernetnya, maka setiap anda akan melibat nama ether I atau ether! harus anda ganti namanya yaitu public untuk ether I dan Ian untuk ether! (jika tidak anda sesuaikan akan mengalami trouble pada mesin MikroTik router anda).

Berdasar tampilan monitor ethernet pertama bernama "ether1" dimana etherl ini nantinya terkoneksi ke IP Public/ Internet sedang ethernet kedua bernama "ether2" ini terkoneksi ke IP jaringan local (LAN).

73

5.4 IP Address

Untuk melakukan setting IP address pada masing-masing ethemet, dengan perintah sebagai berikut:

[admin@proxy]>/ip address [admin@proxy] ip address> add interface-public address=10.0.1.200/24 [admin@proxy] ip address>pr

Flags: X - disabled, I - invalid, D - dynamic

# ADDRESS

0 10.0.1.200/24 10.0.1.0 10.0.1.255 public

NETWORK

BROADCAST

INTERFACE

Kemudian konfigurasikan IP address beserta netmask,

untuk ethemet yang ke-2 yaitu ethernet Ian, caranya sama

dengan diatas yaitu:

[admin@proxy]>/ip address [admin@proxy]ip address> add interface=lan

address=192.168.0.1/24

Sehingga untuk mengetahui hasil konfigurasi kedua ethernet

tersebut, ketikkan:

[adminSproxy] ip address>pr

Flags: X - disabled, I - invalid, D - dynamic

# ADDRESS

1 10.0.1.200/24 10.0.1.0

public

NETWORK

BROADCAST

INTERFACE

10.0.1.255

2 192.168.0.1/24 192.168.0.0 192.168.0.255 Ian

Lihat hasilnya pada konfigurasi diatas. Untuk naik ke

direktori yang lebih tinggi ketikkan titik dua "

direktori admin, yang merupakan direktori tertinggi dalam

MikroTik router OS.

atau " / u ke

",

Konfigurasi dengan menggunakan Winbox:

Klik menu IP> Address, kemudian isikan kolom Address, Network, broadcast dan Interface seperti gambar berikut:

74

Network, broadcast dan Interface seperti gambar berikut: 74 Gambar 54: Tampilan Address List 5.5 IP Gateway

Gambar 54: Tampilan Address List

5.5 IP Gateway

Untuk mengkonfigurasi gateway pada router internet ini, ketikan:

[admin@proxy] >/ip route [admin@proxy] ip route>add gateway=10.0.1.1

Untuk melihat basil konfigurasi ketikan :

[admin@proxy] ip route>pr Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf

# DST-ADDRESS

PREF-SRC 6 GATEWAY DISTANCE

INTERFACE 0 ADC 192.168.0.0/24 192.168.0.1

lan

1 ADC 10.0.1.0/24

10.0.1.200

public

2 A S 0.0.0.0/0

r 10.0.1.1

public

75

Konfigurasi dengan WinBox:

Klik menu IP> Routes, kemudian isikan kolom Gateway, Apply,

OK.

IP> Routes, kemudian isikan kolom Gateway, Apply, OK. Gambar 5-5: Route List Gateway 5.6 DNS (Domain

Gambar 5-5: Route List Gateway

5.6 DNS (Domain Name Server)

Dalam mengisikan IP DNS, sesuaikan dengan rekomendasi dan ISP anda. misalkan : DNS1: 202.134.1.10 DNS2: 202.134.0.155

Maka untuk konfigurasinya, ketikan:

[admin@proxy]>/ip dns [admin@proxy] ip dns> set prixnary-dns=202.134.1.10 [admin@proxy] ip dns> set secondary-dns=202.134.0.155

76

Untuk melihat hasil konfigurasinya, ketikan:

[admin@proxy] ip dns> pr primary-dns: 202.134.1.10 secondary-dns: 202.134.0.155 allow- remote-requests: no cache-size: 2048KiB cache-max- ttl: 1w cache-used: 65KiB

Agar semua komputer client dalam LAN bisa lebih cepat dalam melakukan browsing internet, maka MikroTik router periu diset agar bisa melakukan penyimpanan cache DNS. Sehingga setiap kali komputer client browsing tidak perlu mengambil informasi dari server ISP, namun langsung mengambil informasi yang ada dalam server DNS MikroTik router anda. Adapun yang perlu di set untuk kebutuhan ini adalah sebagai berikut:

[admin@proxy] ip dns> set allow-remote-request=yes

Kemudian kolom Preferred DNS server pada komputer client isikan dengan IP addressnya ethernet MikroTik router yang menghubung ke LAN. Sedangkan untuk kolom Alternate DNS server biarkan saja kosong atau samakan dengan DNS MikroTik router. Jika kita salah dalam mengetikkan perintah diatas, maka akan muncul peringatan "no such argument".

77

Gambar 5-6: Internet Protocol (TCP/IP) Propertiess Konfigurasi dengan WinBox: Klik menu IP> DNS> Static Settings,

Gambar 5-6: Internet Protocol (TCP/IP) Propertiess

Konfigurasi dengan WinBox:

Klik menu IP> DNS> Static Settings, kemudian isikan kolom Primary DNS, Secondary DNS dan aktifkan Allow Remote Requests, Apply, OK.

Gambar 5-7: DNS Settings 78
Gambar 5-7: DNS Settings 78

Gambar 5-7: DNS Settings

78

5.7 IP Firewall Nat

Agar komputer client bisa akses internet, maka IP address ethernet Ian hams ditranslate ke Ip ethernet public dengan perintah:

[admin@proxy]>/ip firewall nat [admin@proxy] ip firewall nat> add chain=srcnat out-interface=public src-address=192.168.0.0/24 action=masquerade

Untuk melihat hasil konfigurasi tersebut, ketikan :

[admin@proxy] ip firewall nat>pr flags: X - disabled, I - invalid, D – dynamic 0 chain=srcnat out-interface=public src- address=192.168.0.0/24 action=masquerade

Untuk naik ke direktori yang lebih tinggi ketikkan titik dua atau "/" ke direktori admin, yang merupakan direktori tertinggi MikroTik OS.

Konfigurasi dengan WinBox:

Klik menu IP> Firewall>NAT >tanda + merah, kemudian isikan kolom Chain, Src Address. Out Interface, Apply, OK.

79

Gambar 5-8: Firewall NAT Rule

5.8 Komputer Client

Agar komputer client bisa akses internet melalui mesin MikroTik routerOS tersebut, maka perlu dilakukan konfigurasi sebagai

berikut:

a. Konfigurasi komputer workstation:

IP address

: 192.168.0.2

Subnet mask

: 255.255.255.0

Default gateway

: 192.168.0.1

Preferred DNS server: 192.168.0.1 Alternate DNS server: 202.134.0.155 (sama seperti pada IP DNS mikrotik OS atau dikosongkan juga nggak masalah).

80

Konfigurasi pada Windows XP Profesional:

Klik Start>Control Panel> Network Connections> Local Area Connection> Properties> Internet Protocol (TCP/IP), OK. Gambar 5-9: Setting IP address pada workstation

b. Konfigurasi komputer laptop:

IP address

: 192.168.0.3

Subnet mask : 255.255.255.0 Default gateway : 192.168.0.1 Preferred DNS server: 192.168.0.1 Alternate DNS server:

Klik Start>Control Panel> Network Connections> Local Area Connection> Properties> Internet Protocol (TCP/IP), OK.

81

Gambar 5-10: Setting IP address pada laptop Kemudian untuk mengetahui apakah komputer client bisa akses

Gambar 5-10: Setting IP address pada laptop

Kemudian untuk mengetahui apakah komputer client bisa akses internet atau tidak, dengan cara kita coba ping ke IP gateway dengan perintah : ping 192.168.0.1 (rnenguji apakah komputer client bisa terkoneksi dengan mesin MikroTik router) dan ping google.com (rnenguji alamat DNS server). Langkah ini dilakukan baik dari komputer workstation maupun komputer laptop pada menu Command Promt. Hasil uji coba tersebut seperti gambar berikut:

82

Promt. Hasil uji coba tersebut seperti gambar berikut: 82 Gambar 5-11: Command Promt Windows XP Profesional
Promt. Hasil uji coba tersebut seperti gambar berikut: 82 Gambar 5-11: Command Promt Windows XP Profesional
Promt. Hasil uji coba tersebut seperti gambar berikut: 82 Gambar 5-11: Command Promt Windows XP Profesional
Promt. Hasil uji coba tersebut seperti gambar berikut: 82 Gambar 5-11: Command Promt Windows XP Profesional

Gambar 5-11: Command Promt Windows XP Profesional

Gambar 5-12: Uji coba

akses ke internet melalui IE

83

Dengan melihat hasil gambar di atas, menunjukkan bahwa mesin MikroTik routerOS kita sudah berhasil dengan baik. Selamat Mencoba!

84

BAB VI

.

.

WEB-PROXY

Tujuan:

Memahami konsep Web-Proxy MikroTik dan penerapannya

Bab inl merupakan kelanjutan dari bab sebelumnya, yang akan membahas tentang bagaimana cara mengimplementasikan MikroTik routerOS sebagai proxy server yang merupakan tempat penyimpanan file-file sementara saat kita hendak melakukan browsing internet.

6.1 IP web-proxy

Agar mesin MikroTik routerOS menjadi proxy server, maka

buatkan konfigurasi berikut:

[admin@proxy] >/ip wob-proxy [admin@proxy] ip web-proxy> set enabled=yes ->> to maka ip wab proxy enable

[admin@proxy] ip wab-proxy> sat arc-address=0.0.0.0 ->> to maka source address to access web proxy will allow

[admin@proxy] ip web-proxy> set port=8080 ->> to make port for web proxy

[admin@proxy] ip web-proxy> set hostname="proxy.lab.ac.id" -» setting for visble hostname web proxy

[admin@proxy] ip web-proxy> set transparent-proxy=yes ->> make transparant proxy enable

[admin@proxy] ip web-proxy> set parent-proxy=0.0.0.0:0 ->> if we used parent proxy x

[admin@proxy] ip web-proxy> set cache-administrator="webmaster" -» make set administrator's e-mail displayed on proxy error page

86

[admin@proxy] ip web-proxy> set max-object-size=4096KiB ->> maximal object can cactb with the proxy server

[admin@proxy] ip web-proxy> set cache-drive=system ->> where drive position that cache wil be saved

[admin@proxy] ip web-proxy> set max-cache-size=unlimited ->> maximal harddrive we used for cache set max-ram-cache-size=unlimited ->> maximal ram we used for cache.

[admin@proxy] ip web-proxy> set reserved-for-cache=4733952K1B

[admin@proxy] ip web-proxy> set reserved-for-ram-cache=2048KiB

[admin@proxy] ip web-proxy> set status=running

Untuk melihat hasil konfigurasi proxy server diatas ketikan :

[admin@proxy] ip web-proxy>pr enabled: yes src-address: 0.0.0.0 port: 8080 hostname: “proxy.lab.acid" transparent-proxy: yes parent-proxy: 0.0.0.0:0 cache-administrator: "webmaster" max-object-size: 4096K1B cache-drive: system max-cache-size: unlimited max-ram- cache-size: unlimited status: running reserved-for-cache: 4733952KiB reserved-for-ram-cache: 2048KiB

87

6.2 Proxy transparent

Setelah melakukan konfigurasi diatas, kemudian kita harus mentransparankan IP Local (Ian) agar IP address dibawahnya di redirect melalui mesln proxy. Perintah untuk mentransparankan proxy tersebut adalah sebagai berikut:

[admin@proxy]>/ip tirewall nat [admin@proxy]ip firewall nat> add chain=dstnat in-interface=lan protocol=tcp dst- port=80 arc-address-list=iplan dst-address- list=192.168.0.0/24 action=redirect to-ports=8080 ->> setting can redirect port 80 to 8080 for proxy server

[admin@proxy]ip firewall nat> add chain=dstnat in-interface=lan protocol=tcp dst- port=3128 arc-address-list=iplan dst-address- list=192.168.0.0/24 action=redirect to-ports=8080 ->> setting can redirect port 3128 to 8080 for proxy server

[admin@proxy]ip firewall nat> add chain=dstnat in-interface=lan protocol=tcp dst- port=8080 arc-address-list=iplan dst-address- list=192.168.0.0/24 action=redirect to-ports=8080 ->> setting can redirect port 8080 to 8080 for proxy server

[admin@proxy] ip firewall nat > add chain=dstnat protocol=tcp dst-port=80 action=accept ->> setting can redirect port 80 to 8080 for proxy server

[admin@proxy] ip firewall nat> add chain=dstnat protocol=tcp dst-port=3128 action=accept ->> setting can redirect port 3128 to 8080 for proxy server

[admin@proxy] ip firewall nat>

88

add chain=dstnat protocol=tcp dst-port=8080 action=accept ->> setting can redirect port 8080 to 8080 for proxy server

Setelah konfigurasi diatas, maka mesin anda sudah menjadi mesin Proxy Transparant.

Untuk melihat hasil konfigurasi dengan perintah:

[admin@proxy]ip firewall nat>pr Flags: X - disabled, I - invalid, D - dynamic

1

chain=srcnat out-interface=public src- address=192.168.0.0/24 action=masquerade

2

chain=dstnat in-interface=lan protocol=tcp dst-

port=80

src-address-list=iplan dst-address- list=192.168.0.0/24 action=redirect to-

porta=8080

2

chain=dstnat in-interface=lan protocol=tcp

dat-port=3128

arc-address-list=iplan dst-address- list=192.168.0.0/24 action=redirect to-

porta=8080

3

chain=dstnat in-interface=lan protocol=tcp

dst-port=8080

src-address-list=iplan dst-address- list=192.168.0.0/24 action=redirect to-

ports=8080

4

chain=dstnat protocol=tcp dst-port=80 action=accept

5

chain=dstnat protocol=tcp dst-port=3128 action=accept

6

chain=dstnat protocol=tcp dst-port=8080 action=accept

89

6.3 IP Firewall Filter

a. Protek situs Internet dengan IP address

[admin@proxy]>/ip firewall filter [admin@proxy]ip firewall filter> add chain=forward src- address=82.0.0.0/8 action=drop [admin@proxy]ip firewall filter> add chain=forward dst-address=82.0.0.0/8 action=drop

[admin@proxy]ip firewall filter> add chain=forward src-ddress=82.98.86.0/8 action=drop [admin@proxy]ip firewall filter> add chain=forward dst-address=82.98.86.0/8 action=drop

[admin@proxy]ip firawall filter> add chain=forward src-ddress=64.0.0.0/8 action=drop [admin@proxy] ip firewall filter> add chain=forward dst-address=64.0.0.0/8 action=drop

[admin@proxy]ip firewall filter> add chain=forward src-adress=202.159.57.178 action=drop [admin@proxy] ip firewall fliter> add chain=forward dst-address=202.159.57.178 action=drop

Untuk melihat hasil konfigurasinya dengan perintah :

[admin@proxy]ip firewall filter>pr Flags: X-disabled, I - invalid, D - dynamic

1 chain=forward dst-address=202.159.57.178 action=drop

2 chain=forward src-address=202.159.57.178 action=drop

90

2

chain=forward dst-address=64.0.0.0/8 action=drop

3

chain=forward src-address=64.0.0.0/8 action=drop

4

chain=forward src-address=82.0.0.0/8 action=drop

5

chain=forward dst-address=82.0.0.0/8 action=drop

6

chain=forward dst-address=82.0.0.0/8 action=drop

7

chain=forward src-address=82.0.0.0/8 action=drop

b.

Protek situs internet dengan protocol & port

[admin@proxy]>/ip firewall filter [admin@proxy] ip firewall filter>

Protek protokol tcp:

[admin@proxy]ip firewall filter> add chain=tcp protocol=tcp dst-port=69 action=drop comment="deny TFTP"

[admin@proxy]ip firewall filter> add chain=tcp protocol=tcp dst-port=111 action=drop comment="deny RPC portmapper"

[admin@proxy] ip firewall filter> add chain=tcp protocol=tcp dst-port=137-139 action=drop comment="deny NBT”

[admin@proxy]ip firewall filter> add chain=input protocol=tcp dst-port=23 action=drop (protek router via telnet)

[admin@proxy]ip firewall filter> add chain=forward protocol=tcp tcp-flags=syn connection- limit=6,32 action=drop (protek klien lebih dari 5 user)

91

Untuk melihat hasil konfigurasinya dengan perintah :

[admin@proxy]ip firewall filter>pr Flags:X disabled, I invalid. D-dynamlc

1 chain=forward dst-address=202.159.57.178 action=drop

2 chain=forward src-address=202.159.57.178 action=drop

3 chain=forward dst-address=64.0.0.0/8 action=drop

4 chain=forward src-address=64.0.0.0/8 action=drop

5 chain=forward src-address=82 .0.0.0/8 action=drop

6 chain=forward dst-address=82. 0.0.0/8 action=drop

7 chain=forward dst-address=82. 0.0.0/8 action=drop

8 chain=forward src-address=82.0.0.0/8 action=drop

9 ;;; deny TFTP chain=tcp protocol=tcp dst-port=69 action=drop

10 ;;; deny RPC portmapper chain=tcp protocol=tcp dst-port=111 action=drop

11 ;;; deny NBT chain=tcp protocol=tcp dst-port=137-139 action=drop

12 chain=input protocol=tcp dst-port=23 action=drop

13 chain=forward protocol=tcp tcp-flags=syn connection-limit=6,32 action=drop

Protek situs internet dengan protokol udp:

[admin@proxy]ip firewall fliter> add chain=udp protocol=udp dst-port-69 action=drop comment-"deny TFTP"

[admin@proxy]ip firewall filter > add chain=udp protocol=udp dst-port=111 action=drop comment="deny PRC portmapper"

92

[admin@proxy]ip firewall filter> add chain=udp protocol=udp dst-port=137-139 action=drop comment="deny NBT"

Untuk melihat hasil konfigurasinya dengan perintah :

[admin@proxy] ip firewall filter>pr

I-invalid, D-

Flags: X-disabled, dynamic

0 ;;; deny TFTP

chain=udp protocol=udp dst-port=69 action=drop

1 ;;; deny RPC portmapper chain=udp protocol=udp dst-port=111 action=drop

2

chain=udp protocol=udp dst-port=137-139

action=drop

;;;

deny NBT

Proteksi protokol iemp:

[admin@proxy]ip firewall filter> add chain=icmp protocol=icmp icmp-options=0:0 action=accept comment="drop invalid connections"

[admin@proxy] ip firewall filter> add chain=icmp protocol=icmp icmp-options=3:0 action-accept comment="allow established connections"

[admin@proxy] ip firewall filter> add chain=icmp protocol=icmp icmp-options=3:l action=accept comment="allow already establised connections"

[admin@proxy] ip firewall filter> add chain=icmp protocol=icmp icmp-options=4:0 action=accept comment="allow source quench"

[admin@proxy] ip firewall filter> add chain=icmp protocol=icmp icmp-options=8:0 action=accept comment="allow echo request"

93