Anda di halaman 1dari 4

MODUL VISUAL FOXPRO MERCUSUAR

TABLE
Table merupakan kerangka utama dalam database. Karena semua elemen database dari paling kecil ke
paling besar bermula dari table.
Cara membuat Table :
Masukkan perintah berikut pada Command Window :
CREATE <nama table>
Maka akan muncul pengisi struktur table seperti dibawah ini :



Masukkan field-field pada : Nama field pada Field, Tab, pilih type data pada Type, Tab, ketik lebar
field pada Width, Tab, ketik desimal (jika tipe Numeric), Tab, pilih index (Ascending, Descending,
None), Tab, Tab, masukkan field yang lain.
Akhiri dengan tekan OK, muncul pertanyaan Input record data now, Jawab Yes (bila langsung
mengisi record) atau No (jika tidak akan mengisi record).

Memodifikasi Table
Masukkan perintah ini pada Command Window
MODIFY STRUCTURE
Cara pengoperasiannya sama dengan pengoperasian langkah-langkah membuat table.

FORM
Form adalah tool dalam pemrograman visual untuk merancang tampilan masukan (input).
Langkah-Langkah membuat Form :
Dengan Wizard
Klik menu File, Pilih New, muncul

MODUL VISUAL FOXPRO MERCUSUAR





Pengoperasian Form :
Add untuk menambah record. Top ke record no.1
Save untuk menyimpan record Prev ke record sebelum
Print mencetak record Next ke record sesudah
Edit untuk meng-edit record Bottom ke record terakhir
Delete untuk menghapus record Exit menutup form
Find untuk mencari record

Membuat Form secara manual
Masukkan perintah berikut pada Command Window
CREATE FORM <nama form>
Atau Klik Menu File, Pilih New, Pilih Form, pilih New File
Muncul Form kosong, Klik menu View, Pilih Data Environment, Pilih Table, OK, Klik Close, Klik
tahan fields, arahkan pointer mouse ke form yang kosong, lepaskan. Atur posisi field. Tutup window
Data Environment.
Membuat Tombol Pengoperasian Form.
Klik Command Button pada Toolbox Form (bila tidak muncul pilih View, Pilih Form Control
Toolbar). Klik View pilih Properties, pilih Caption, ganti teksnya dengan nama tombol yang
diinginkan.
Memberi Rutin agar tombol dapat difungsikan.
Klik dua kali (Double Klik) pada tombol yang akan diberi rutin. Ketik rutinnya. Klik Close.
Berikut rutin untuk tombol-tombol tertentu.
Klik Form, klik Wizard, pilih Form Wizard, OK, Pilih Table
yang ada (kalau tidak ada Klik tombol ...., pilih Table, OK).
Klik tombol >> untuk memilih semua field dari table yang
akan dibuat form. Klik Next.
Pilih Style Form (Standard, Chiseled, Shadowed, Boxed,
Embosed, Fancy, Stone, Flex, Colorful), pilih jenis tombol
(Text Button, Picture Button, No Button, Custom), Klik
Next.
Pilih field yang dijadikan kunci urutan, Klik Add, Klik
Ascending (urut kecil besar) atau Descending (urut besar
kecil), Klik Next.
Ketik judul form, Klik Finisih. Ketik nama file form, Klik Save.
Menjalankan Form :
DO FORM <nama form>
Hasil dari form muncul seperti contoh berikut :
MODUL VISUAL FOXPRO MERCUSUAR

Tambah data Ke Record Pertama (Top) Ke Record Akhir (Bottom)
Append Blank Go Top Go Bottom
ThisForm.Refresh ThisForm.Refresh ThisForm.Refresh


Ke record Sebelum (Prev) Ke record Sesudah (Next) Menghapus
If BOF() If EOF() Delete
Go Top Go Bottom ThisForm.Refresh
Else Else Keluar
Skip -1 Skip ThisForm.Release
Endif Endif
ThisForm.Refresh ThisForm.Refresh

REPORT
Report adalah tool dalam pemrograman visual yang digunakan untuk merancang laporan.
Langkah-langkah membuat report
Dengan Wizard
Klik Menu File, Pilih New, Pilih Report, Klik Wizard, Pilih Report Wizard, OK.
Pilih nama table (bila belum ada, klik tombol ..., pilih table, OK), Pilih field-fieldnya dan Klik tombol >>,
Klik Next
Pilih field yang dijadikan kunci pengelompokan, Klik Next
Pilih Style Form (Executive, Ledger, Presentation, Banded, Casual), Klik Next
Pilih Field Layout (Columns, Row) dan Pilih Orientation (Portrait, Landscape), Klik Next
Pilih field yang dijadikan kunci urutan, Klik Add, Klik Ascending (urut kecil besar) atau Descending
(urut besar kecil), Klik Next.
Ketik judul Report, Klik Finisih. Ketik nama file Report, Klik Save.

Membuka File Report
Masukkan perintah berikut pada Command Window
REPORT FORM <nama report>

Membuat Form secara manual
Masukkan perintah berikut pada Command Window
CREATE REPORT <nama form>
Atau Klik Menu File, Pilih New, Pilih Report, pilih New File
Muncul report dalam keadaan kosong.
Klik Menu Report, pilih Quick Report, OK, maka field akan masuk kedalam report. Atur posisi.
Untuk menambah Judul, Klik menu Report, pilih Titles/Summary,






Klik Check Box pada Title Band, Klik OK
Ketik Judul Laporan pada tempat sudah
disediakan.
Untuk melihat hasil report, Klik icon Preview.
Untuk melihat hasil report ke printer klik Icon !
atau dari menu Report pilih Run Record.
Untuk menyimpan, klik menu tombol Close [X]
jawab Yes.

MODUL VISUAL FOXPRO MERCUSUAR

QUERY
QUERY adalah tool dalam pemrograman visual yang digunakan untuk menghubungkan beberapa table
menjadi satu relasi atau join.
Langkah membuat Query
Masukkan perintah ini dalam Command Windows
CREATE QUERY <nama query>
Pilih table pertama, OK, Klik Other, pilih table kedua (dan seterusnya), OK, Klik OK,
Akhiri dengan tekan tombol Close. Maka menjadi seperti contoh berikut :





Pilih field pada bagian Available fields dan tekan tombol Add> maka field pindah ke bagian Selected
fields.
Klik Icon ! untuk melihat hasil Query.
Untuk menyaring data klik bagian Filter, Pilih Field Name, Pilih Criteria, masukkan kriteria
penyaringan. Jalankan hasil query.
Akhiri dengan menyimpan file Query.