Anda di halaman 1dari 7

STARCOM TRAINING CENTER PRINGSEWU

SOAL / TUGAS
Buatlah rancang bangun sebuah Server yang berfungsi sebagai Server Router, pengatur bandwith,
block website dan hotspot jaringan dengan berbasis text, konfigurasi sebagai berikut :
Konfigurasi Modem/WAN= 10.10.10.x
1. IP Internet
= Sesuai dengan Network yang diberikan ISP
2. IP LAN
= 192.168.50.1/27
3. Blocking Site
= www.youtube.com , www.facebook.com
4. Gateway
= 10.10.10.1
Konfigurasi Router
1.
Sistem Operasi
= OS Linux Mikrotik
2.
NAT
= Yes
3.
Limit Bandwidth
1
= 256 KBps
4.
Limit Bandwidth
2
= 512 KBps
5.
6.
IP Hotspot
= 192.168.50.xxx/27
7.
Hotspot
= 25 users
Konfigurasi Client
5. IP Wifi

= DHCP Server Mikrotik

Topologi Jaringan

starcompringsewu.com

Page 1

STARCOM TRAINING CENTER PRINGSEWU

MIKTORIK 5.18
INSTALASI
Cara instalasi sangat mudah tinggal setting agar komputer bisa boot
dari CDROM. Kemudian masukan CD MIKROTIK. Ketika komputer di booting
CD akan mulai bekerja booting awal system MIKROTIK, bisa dilihat di
gambar di bawah :

Apabila

proses

booting

awal

berjalan

dengan

baik

kemudian

akan

ditampilkan menu instalasi MIKROTIK sepert berikut :

Pada menu instalasi di tampilkan service apa saja yang ingin kita
install.
disediakan

Untuk

lebih

dengan

mudahnya

menekan

tombol

kita
a.

pilih
maka

semua
semua

service

yang

service

akan

terpilih setelah itu tekan tombol i untuk instalasi..

starcompringsewu.com

Page 2

STARCOM TRAINING CENTER PRINGSEWU

Pada Do you publict to keep old configurasi pilih N, pada pilihan


format pilih Y
Langkah berikutnya akan disiapkan ruang harddisk yang akan dipakai
oleh

MIKROTIK

dengan

memformatnya

dan

mengkopikan

file-file

yang

dibutuhkan

Setelah

proses

pengkopian

file

selesai

kemudian

proses

instalasi

membutuhkan reboot ulang. Keluarkan CD ISO MIKROTIK lalu Tekan enter


pada pilihan enter to reboot.
Tampilan awal MIKROTIK
MIKROTIK 5.18
MIKROTIK Login : _
Secara default user yang dipakai adalah user admin dengan password
yang masih kosong.

starcompringsewu.com

Page 3

STARCOM TRAINING CENTER PRINGSEWU


KONFIGURASI MIKROTIK
Mengganti nama interface:
[admin@STARCOM] > /interface print
Flags: X - disabled, D - dynamic, R - running
#
NAME
TYPE
RX-RATE
0 R ether1
ether
0
1 R ether2
ether
0

TX-RATE
0
0

MTU
1500
1500

[admin@STARCOM] > /interface set name=public

ether1

(lalu Enter)

[admin@STARCOM] > /interface set name=lan

ether2

(lalu Enter)

Melihat perubahan nama interface


[admin@STARCOM] > /interface print
(lalu Enter)
Flags: X - disabled, D - dynamic, R - running
#
NAME
TYPE
RX-RATE
TX-RATE
MTU
0 R public
ether
0
0
1500
1 R lan
ether
0
0
1500

Seting IP Address :
[admin@STARCOM]>/ip address add address=200.3.3.15/24 interface=public (lalu Enter)
[admin@STARCOM]>/ip address add address=192.168.10.1/24 interface=lan

(lalu Enter)

Cek IP Address :
[admin@STARCOM] > /ip address print
(lalu Enter)
Flags: X - disabled, I - invalid, D - dynamic
#
ADDRESS
NETWORK
INTERFACE
0
200.3.3.15/24
200.10.28.0
public
1
192.168.10.1/24
192.168.10.0
lan

Setting IP Gateway
[admin@STARCOM] > /ip route add gateway=200.3.3.1 (lalu Enter)

Cek IP Gateway
[admin@STARCOM] > /ip route print

(lalu Enter)

Flags: X - disabled, A - active, D dynamic,


C connect, S static, r rip, b bgp, o ospf, m mme,
B blackhole, U unreachable, P prohib
#
0
1
2

A S
ADC
ADC

DST-ADDRESS
0.0.0.0/0
192.168.10.0/24
200.10.28.0/24

PREF-SRC

GATEWAY
200.10.28.1
192.168.10.1
lan
200.3.3.15
public

DISTANCE
1

Setting DNS
[admin@STARCOM] > /ip dns set servers=8.8.8.8
(lalu Enter)

allow-remote-requests=yes

Cek ip DNS
[admin@STARCOM] > /ip dns print

(lalu Enter)

servers : 8.8.8.8
dynamic-servers :
allow-remote-requests : yes

starcompringsewu.com

Page 4

STARCOM TRAINING CENTER PRINGSEWU


Konfigurasi Hotspot Mikrotik
[admin@STARCOM] > / ip hotspot setup

[tekan enter]

Select interface to run HotSpot on


hotspot interface: lan

[tekan enter]

Set HotSpot address for interface


local address of network: 192.168.10.1/24
masquerade network: yes
Set pool for HotSpot addresses

[tekan enter]
[tekan enter]

address pool of network: 192.168.10.2-192.168.10.30


Select hotspot SSL certificate

[tekan enter]

select certificate: none


[hapus tulisan: import-other-certificate, ganti menjadi: none, lalu tekan enter]

Select SMTP server


ip address of smtp server: 0.0.0.0
Setup DNS configuration

[tekan enter]

dns servers: 200.3.3.15,8.8.8.8


DNS name of local hotspot server

[tekan enter]

dns name:nama_sekolah.sch.id
Create local hotspot user

[tekan enter]

name of local hotspot user: admin


password for the user: 1234

[tekan enter]
[tuliskan 1234, lalu enter]

Konfigurasi Limit Bandwidth


[admin@STARCOM] > ip hotspot user profile add name=limit_user rate-limit=64k/64k
transparent-proxy=yes [tekan enter]
Menambahkan Limit User Hotspot
[admin@STARCOM] > ip hotspot user add profile=limit_user password=1234 name=user1
[tekan enter]

Untuk memudahkan Konfigurasi User tekan tanda panah atas pada keyboard, maka akan muncul
perintah sebelumnya, ganti nilai akhir secara berurutan, nilai 1 menjadi 2, lalu 2 nya diganti ke 3
hingga angkanya 10, perintahnya sebagai berikut:
[admin@STARCOM] > ip hotspot user add profile=limit_user password=1234 name=user1
[ganti 1 seperti berikut]
[admin@STARCOM] > ip hotspot user add profile=limit_user password=1234 name=user2
[tekan enter]
[admin@STARCOM] > ip hotspot user add profile=limit_user password=1234 name=user3
[tekan enter]

starcompringsewu.com

Page 5

STARCOM TRAINING CENTER PRINGSEWU

Konfigurasi Proxy
Mengaktifkan fitur web proxy di mikrotik:
[admin@STARCOM] > /ip proxy set enabled=yes port=8080 cache-administrator=
admin@starcompringsewu.com max-cache-size=unlimited cache-on-disk=yes (lalu Enter)

Membuat rule untuk transparent proxy pada firewall NAT, yang berfungsi untuk membelokkan
Traffic data Web ke Port 3128 (Port default Proxy).:
[admin@STARCOM] > /ip firewall nat add chain=dstnat protocol=tcp dstport=80,3128,8000 action=redirect to-ports=8080
(lalu Enter)
Membuat Daftar Situs yang tidak boleh di akses
[admin@STARCOM]</ip proxy access add dst-host=*.youtube* action=deny (lalu Enter)
[admin@STARCOM]</ip proxy access add dst-host=*.facebook* action=deny (lalu Enter)

SETTING IP CLIENT MIKTORIK


1. Setelah itu setting IP DHCP Komputer Client OK

Jika Semua Konfigurasi benar, harusnya browsing Anda akan diarahkan ke halaman login Mikrotik
dengan tampilan seperti berikut:

starcompringsewu.com

Page 6

STARCOM TRAINING CENTER PRINGSEWU

HASIL BLOK SITUS

Hasil Limit Bandwith User

starcompringsewu.com

Page 7