Anda di halaman 1dari 3

Masking/Cropping Citra Menggunakan ENVI 4.

x
Oleh :
Yan Andika 1101564_2011

Dalam pengolahan citra sering kali data yang kita inginkan terlalu besar cakupan
wilayahnya, sehingga dalam proses pengolahan sering kali berjalan lambat
dikarenakan cakupan wilayah yang diinterpretasi terlalu besar, maka dari itu
alangkah baik nya sebelum melakukan pengolahan citra kita lakukan pemotongan
citra berdasarkan daerah yang kita inginkan saja, sehingga proses pengolahan
menjadi lebih mudah dan cepat. Dalam software pengolahan citra seperti ENVI
ada cara untuk melakukan proses pemotongan tersebut atau biasa disebut
masking, adapun langkah-langkah untuk melakukan pemotongan citra tersebut di
software ENVI 4.5 adalah sebagai berikut :
1. Pertama buka software ENVI 4.5
2. Kemudian pilih File dan klik Open Image File, dan kemudian pilih file citra
yang akan di crop/masking, setelah itu tampilkan citra tersebut.
3. Selanjutnya kita tampilkan data vector (shp) daerah yang akan kita ambil pada
citra, karena kita memotong citra tersebut berdasarkan data vector (shp)
tersebut. Pilih File > Open Vector File, setelah itu pilih data vector yang ingin
kita gunakan sebagai pemotong, ubah format file sesuai dengan format data
vector yang dimiliki, dalam laporan ini formatnya shapefile (shp)

Ubah format sesuai data yang dimiliki


4. Setelah itu maka akan tampil jendela Import Vctor File Parameters, pada
jendela tersebut sesuaikan system koortdinat vector dengan citra yang akan
dipotong, dan klik OK, dan akan muncul jendela Available Vectors List, pilh
file vector tadi dan klik Load Selected, kemudian pilih pada display berapa
akan ditampilkan file tersebut, klik OK, maka file vector akan muncul.

Yan Andika(1101564/2011)_Geografi

Jendela Import Vector File Parameters

Jendela Available Vector List

5. Setelah itu kita akan membuat mask/pemotongnya, berdasarkan data vektor


tadi, dengan cara pilih Basic Tools > Masking > Build Mask, pilih display
input yang diinginkan, pada laporan ini yaitu display 1 kemudian klik OK,
maka jendela Mask Definition akan muncul.

6. Pilih file yang kan kita gunakan sebagai pemotong dengan pilih Options >
Import EVFs, kemudian pilih file vektor tadi, kemudian pilih dimana file
pemotong akan disimpan, kemudian klik Apply
7. Setelah file file pemotong siap, maka kita lakukan pemotongan dengaan cara
pilih Basic Tools > Masking > Apply Mask, maka jendela Apply Mask
Input File akan muncul, pilih file citra yang akan kita potong, kemudian pilih

Yan Andika(1101564/2011)_Geografi

area yang akan kita potong pada Spatial Subset > Image, setelah itu pilih band
yang ingin kita pilih pada Spectral Subset, dan terakhir pilih file pemotong
yang kita buat tadi pada Select Mask Band, setelah itu klik OK.

8. Pada jendela Apply Mask Parameters, jika menginginkan background hasil


hitam isi Mask Value 0, tapi jika ingin backgroundnya putih isi Mask Value
dengan nilai pixel tertinggi pada citra tersebut, kemudian pilih dimana citra
hasil pemotongan akan disimpan, dan klik OK.

9. Setelah proses pemotong selesai, dikarenakan file masih berupa file internal
dari software ENVI, maka file harus di simpan dalam format yang bisa dibuka
oleh software lain. Adapun langkah-langkah nya ialah pilih File > Save File As
> Tiff/Geotiff.

Yan Andika(1101564/2011)_Geografi