Anda di halaman 1dari 14

Manajemen Proyek

Tugas Kelompok
Anggota

: 1. Gilang Sardika F.

L200120048

2. Aryani Ristyabudi

L200120049

3. Yusuf Fakhruddin

L200120050

Tools dan Template Manajemen Proyek


Proyek merupakan sebuah rangkaian aktivitas unik yang saling terkait untuk mencapai
suatu hasil tertentu dan dilakukan dalam periode waktu tertentu pula. Manajemen
proyek merupakan aplikasi pengetahuan (knowledges), keterampilan (skills), alat (tools)
dan teknik (technique) dalam aktivitas-aktivitas proyek untuk memenuhi kebutuhankebutuhan proyek .
Ada banyak tools yang dapat membantu seorang manajer proyek dalam memanajemen
proyek, di antaranya: GanttProject, Microsoft Project, dan Open Proj.
GanttProject
GanttProject adalah desktop tools dan merupakan open source lintas platform untuk
manajemen proyek. Program ini bisa berjalan di windows, Linux, dan Mac OS.
GanttProject merupakan aplikasi Java murni yang berguna untuk membuat perencanaan
proyek menggunakan Gantt Chart (grafik). GanttProject dapat memecah proyek menjadi
tugas-tugas (task-task), menunjukkan dependensi (ketergantungan), dan mengelola
sumber daya.
GanttProject dapat digunakan untuk beberapa pengelolaan, seperti:

Gant Chart: Membuat struktur susunan kerja, menggambarkan keterkaitannya,


dan menentukan patokannya.
Sumber Daya (Resources): Menunjuk sumber daya manusia untuk mengerjakan
tugas dan melihat alokasi mereka di resource load chart.
Pert Chart: Menghasilkan Pert Chart dari Gantt Chart. Pert Chart merupakan suatu
tools manajemen proyek yang digunakan untuk melakukan penjadwalan,
mengatur dan mengkoordinasi bagian-bagian pekerjaan yang ada di dalam suatu
proyek.
Export: Menyimpan chart dalam bentuk gambar JPG/PNG dan menghasilkan
laporan-laporan dalam bentuk PDF dan HTML.
Saling Beroperasi: Bisa meng-import dan meng-export file proyek ke dalam format
Microsoft Project. Mengekspor ke spreadsheet dengn CVS.
Kolaborasi: Membagi dan mendiskusikan proyek dengan kolega-kolega dengan
menggunakan WebDAV.

GanttProject menyimpan semua informasi yang kita masukkan ke dalam field-field, di


mana setiap field dipisahkan berdasarkan tipe spesifikasi informasinya, seperti nama

task dan durasinya. Di GanttProject field biasanya dimunculkan dalam sebuah kolom.
Setelah membuat list tugas/task dan membuat information schedule, maka plan dibangun.
Dengan GanttProject, kita bisa melihat model dari proyek secara lengkap. Termasuk
kapan proyek akan selesai dan kapan dimulai untuk setiap task.
Keuntungan menggunakan GanttProject:
1.
2.
3.
4.
5.
6.
7.
8.

Mengerti dan menyetujui tujuan dari proyek.


Dapat mengntrol saat proyek dimulai, sedang dikerjakan dan saat proyek selesai.
Komunikasi yang jelas di antara orang-orang yang terlibat dalam proyek.
Proyek dapat selesai tepat waktu, bahkan penggunaan biaya, ruang lingkup dan
kualitasnya dapat sesuai dengan yang direncanakan.
Realistis dan tujuan dapat tercapai.
Keputusan jelas.
Kualitas kontrol dapat ditingkatkan.
Manajemen perubahan dan resiko.

Contoh perencanaan proyek dengan menggunakan GanttProject:

Gambar 1. Proyek Sederhana


A. Gantt Chart
Membuat Task Baru
Pertama dengan mengklik ikon New Task atau dengan memilih menu Tasks New
Task. Tasks muncul pada tree di sebelah kiri, kita dapat langsung mengubah nama
task di sini. Selanjutnya, kita dapat mengatur task-task dengan membentuk
kelompok-kelompok atau kategori. Jadi kita bisa memiliki hirarki seperti ini:

Gambar 2. Penyusunan Task-task Secara Hirarki


Task juga dapat diorganisir dengan menggunakan fungsi up dan down. Fungsi-fungsi
ini memindahkan task yang dipilih ke atas atau ke bawah dalam hirarki itu.
Relationship
Ganttproject memungkinkan kita untuk menentukan hubungan antara dua task. Kita
dapat mengaturnya dengan men-drag langsung pada tabel. Klik dan tahan pada task
pertama dan pindahkan kursor ke task kedua. Panah akan muncul mengikuti gerak
kursor. Tarik panah untuk task kedua dan lepaskan mouse. Task kedua akan
tergantung pada yang pertama. Contohnya seperti gambar di bawah ini:

Gambar 3. Relasi Antar Task


PERT Charts
Cara menampilkan Pert Chart dengan memilih menu View PERT Chart. Contoh
dari Pert Chart:

Gambar 4. PERT Chart

Sumber Daya (Resources)


Membuat Resources
Sebuah proyek terdiri dari task dan orang-orang (atau sumber daya) yang ditugaskan
untuk setiap task. Kita dapat menciptakan sumber daya pada panel Resources
dengan menentukan nama, tugas dan informasi kontak (email atau telepon).
Resources Chart
Merupakan sebuah chart khusus yang tersedia untuk semua sumber daya pada panel.
Resources chart menunjukkan alokasi waktu sumber daya dan mirip dengan Gantt
Chart. Contohnya seperti berikut:

Gambar 5. Resources Chart


B. Manajemen File (File Management)
Format XML
GanttProject menggunakan format file XML. Jadi sederhana untuk mengedit dengan
text editor favorit kita seperti yang kita inginkan. File XML menyimpan daftar task,
daftar sumber daya (resources), dan hubungan (relationship) antara task dan sumber
daya. File ekstensinya dapat berupa .xml atau .gan.
Export JPG/PNG
GanttProject dapat mengekspor Gantt Chart berupa gambar PNG/JPG. Caranya
dengan memilih menu Project Export As dan pilih salah satu dari gambar
PNG/JPG setelah menentukan ekstensi file png/jpg.
Export PDF/HTML
GanttProject juga dapat mengekspor proyek sebagai halaman web HTML. Halamanhalaman web berisi semua informasi tentang proyek seperti:
Informasi Proyek
Chart (Gantt dan sumber daya)
Daftar task dengan informasi yang berbeda seperti tanggal mulai/akhir, jangka
waktu, catatan, dll.
Daftar sumber daya
Untuk mengekspor GanttProject ke HTML menggunakan transformasi XSL.
GanttProject menggunakan XSL standar termasuk dalam file jar. Tapi kita dapat
menentukan sendiri xsl lain dengan memilih direktori pada pengaturan. Bahkan kita
dapat membuat file xsl sendiri untuk menyesuaikan halaman web html kita.

Untuk mengekspor PDF menggunakan aplikasi FOP, library BATIK untuk


mengekspor dalam format pdf. Hal ini juga menggunakan teknologi transformasi xsl.
Jadi, kita dapat menggunakan tema PDF, dengan tema default file GanttProject jar.
Microsoft Project
Salah satu aplikasi yang digunakan dalam penyusunan sebuah proyek atau management
proyek adalah Microsoft office project. Microsoft Office Project dibagi menjadi 3, yaitu :
Microsoft Office Project Standart, Microsoft Office Project Professional, dan Microsoft
Office Project Server.
Microsoft Office Project Professional merupakan software administrasi proyek yang
digunakan untuk melakukan perencanaan, pengelolaan, pengawasan dan pelaporan data
dari suatu proyek. Kemudahan penggunaan dan keleluasaan lembar kerja serta cakupan
unsur-unsur proyek menjadikan software ini sangat mendukung proses administrasi
sebuah proyek.
Microsoft Office Project memberikan unsur-unsur manajeman proyek yang sempurna
dengan memadukan kemudahan penggunaan, kemampuan, dan fleksibilitas sehingga
penggunanya dapat mengatur proyek secara lebih efisien dan efektif. Kita akan
mendapatkan informasi, mengendalikan pekerjaan proyek, jadwal, laporan keuangan,
serta mengendalikan kekompakan tim proyek. Kita juga akan lebih produktif dengan
mengintegrasikan program-program Microsoft Office yang familiar, membuat pelaporan
yang kuat, perencanaan yang terkendali dan sarana yang fleksibel.
Pengelolaan proyek konstruksi membutuhkan waktu yang panjang dan ketelitian yang
tinggi. Microsoft Office Project dapat menunjang dan membantu tugas pengelolaan
sebuah proyek konstruksi sehingga menghasilkan suatu data yang akurat. Keunggulan
Microsoft Office Project adalah kemampuannya menangani perencanaan suatu kegiatan,
pengorganisasian dan pengendalian waktu serta biaya yang mengubah input data
menjadi sebuah output data sesuai tujuannya. Pengelolaan Proyek Konstruksi Bangunan
Gedung dengan Microsoft Office Project secara khusus ditujukan bagi para perencana dan
praktisi yang ingin menerapkan Microsoft Office praktis, cepat dan aplikatif untuk
mengelola proyek konstruksi bangunan gedung.
Microsoft Office Project merupakan software yang dapat digunakan untuk membuat
rancangan proyek serta melakukan manajemen dalam proyek tersebut. Kelengkapan
fasilitas dan kemampuannya yang luar biasa dalam pengolah data-data proyek
menjadikan software ini paling banyak dipakai oleh operator komputer. Ini karena
keberadaannya benar-benar mampu membantu dan memudahkan pemakai dalam
menyelesaikan pekerjaan, terutama pekerjaan yang berhubungan dengan olah data
proyek.
Berikut ini beberapa keuntungan yang dapat diperoleh dengan menggunakan Microsoft
Project:
1.

Dapat melakukan penjadwalan produksi secara efektif dan efisien, karena


ditunjang dengan alokasi waktu yang dibutuhkan untuk tiap proses, serta
kebutuhan sumber daya untuk setiap proses sepanjang waktu.

2.
3.
4.

Dapat diperoleh secara langsung informasi aliran biaya selama periode.


Mudah dilakukan modifikasi, jika ingin dilakukan rescheduling.
Penyusunan jadwal produksi yang tepat akan lebih mudah dihasilkan dalam
waktu yang cepat.

Dalam hal perencanaan suatu proyek yang didesain menggunakan Microsoft Office
Project akan sangat baik dan komplit apabila dibuat report yang canggih. Keistimewaan
Microsoft Office Project dalam menghasilkan suatu perencanaan yang akurat, cepat dan
tepat juga ditunjang dengan keluaran yang juga canggih. Dalam report yang dihasilkan
banyak pilihan yang bisa diambil oleh para perencana ataupun oleh para penentu
kebijakan. Jenis dan report mana saja yang paling pas dan sesuai. Namun kadang-kadang
para perencana menginginkan suatu laporan yang sangat lengkap. Jika demikian tidak
ada jalan lain semua jenis report yang disediakan Microsoft Office Project bisa digunakan.

View
View adalah suatu tampilan ruang kerja yang digunakan untuk mengelola berbagai
hal di dalam project mulai dari task, resource, calendar, dan lain-lain. Setiap view
ditampilkan pada panel yang dinamakan Project Plan Window.

Terdapat banyak jenis view di dalam aplikasi Microsoft Project 2007. Masing-masing
dengan tampilan, isian data yang berbeda dan spesifik untuk mengelola item tertentu.
Jenis format tampilan dasar yang membentuk berbagai view tersebut adalah :

Gantt Chart:

Network Diagram:

Graph:

Sheet:

Usage:

Form:

Catatan : kita hanya dapat bekerja dengan 1 atau maksimal 2 view pada suatu saat.

Semua view disusun dalam tiga kategori, yaitu task views, resource views, dan
assignment views. Berikut adalah daftar rincian view dari tiap kategori tersebut.
1.

Task Views
Format Gantt Chart:
Gantt Chart: merupakan view default dengan dua panel, dengan satu panel berbentuk
tabular (sheet) yang menampilkan task dan informasi lainnya. Pada panel lainnya
menampilkan grafik batang yang diplot dengan skala waktu (timescale).
Bar Rollup: digunakan untuk menampilkan subtask dalam bentuk jejeran / rangkaian
bar pada level group (summary) task. Hal ini mempermudah kita untuk melihat
rincian tugas yang ada walaupun pada level summary.
Milestone Date Rollup: hampir sama seperti item no. 2 di atas, namun pada level
summary indikator milestone yang ditampilkan dan bukannya bar. Pada indikator
milestone ditampilkan juga label task dan tanggal awal task (start date).
Milestone Rollup: hampir sama seperti item no. 2 di atas, namun pada level summary
indikator milestone yang ditampilkan dan bukannya bar. Pada indikator milestone
tersebut ditampilkan juga label dari task terkait.
Detail Gantt: digunakan untuk melihat slack (toleransi durasi waktu sebelum project
memasuki masa kritis, yang dapat menyebabkan keterlambatan project) dan
slippage (perbedaan antara biaya dan anggaran).
Leveling Gantt: proses levelling pada suatu project adalah melakukan reschedule
karena kita mengalokasikan task yang berlebihan kepada resource kita
(overallocation). View ini digunakan untuk melihat efek dari sebelum dan sesudah
proses levelling dilakukan.
Multiple Baselines Gantt:
PA_Expected Gantt: adalah tampilan yang dapat digunakan setelah menjalankan
PERT (Program, Evaluation, and Review Technique) analysis tool. View ini
digunakan untuk mengevaluasi ekspektasi dari durasi, tanggal mulai dan tanggal
berakhirnya project.
PA_Optimistic Gantt: View ini digunakan bersama dengan PERT analysis tool untuk
mengevaluasi skenario terbaik (best-case) dari durasi, tanggal mulai dan tanggal
berakhirnya project.
PA_Pessimistic Gantt: View ini digunakan bersama dengan PERT analysis tool untuk
mengevaluasi skenario terburuk (worst-case) dari durasi, tanggal mulai dan tanggal
berakhirnya project.
Tracking Gantt: Variasi dari Gantt Chart dengan tampilan 2 bar, yaitu durasi waktu
pengerjaan dari task yang sedang / sudah dilaksakan (scheduled / actual) versus
perencanaan (baseline).

Format Network Diagram:

Network Diagram: merupakan representasi task dalam bentuk kotak (box) dan relasi
dependensi antar task berupa garis penghubung antar box. Kita dapat
menambahkan, mengedit rincian dan melakukan review dari tiap task maupun
dependensi dari diagram ini.
Descriptive Network Diagram: view ini sama dengan Network Diagram, hanya saja
ukuran box lebih besar dan deskripsinya lebih rinci.
Relationship Diagram: adalah network diagram yang tidak menampilkan task secara
keseluruhan, tapi task saat ini beserta task pendahulu (predecessor) dan dependen
terhadapnya (successor).

Format Graph:

Calendar: tampilan kalender yang dapat digunakan untuk menambah, merubah dan
melakukan review terhadap task.

Format Sheet:

Task Sheet: tampilan informasi task dalam bentuk sheet / tabular.


PA_PERT Entry Sheet: adalah sheet yang digunakan untuk membantu menganalisa
dan menguji skenario ekspektasi, optimistik (best-case) dan pesimistic (worst-case)
dalam menentukan durasi proyek.

Format Form:

Task Details Form: berisi formulir perubahan data dan jadwal untuk satu task, dalam
bentuk grid.
Task Form: berisi formulir perubahan data untuk satu task, dalam bentuk grid.
Task Name Form: versi sederhana dari Task Form.
2.

Resources Views
Format Graph:
Resource Graph: berisi informasi alokasi resource, biaya dan pekerjaan yang over
time dalam bentuk grafik bar.

Format Sheet:

Resourche Sheet: merupakan tampilan untuk memasukkan, merubah dan melakukan


review terhadap data resource.

Format Form:

Resource Form: merupakan tampilan untuk memasukkan, merubah dan melakukan


review terhadap data satu resource dalam satu waktu.
Resource Name Form: merupakan versi sederhana dari Resource Form.

3.

Assignment Views
Format Usage:
Task Usage: menampilkan 2 sheet pada panel yang berbeda. Satu panel berisi daftar
task, sedangkan panel lainnya berisi data durasi waktu task yang sudah digunakan
pada sheet timescale.
Resource Usage: menampilkan 2 sheet pada panel yang berbeda. Satu panel berisi
daftar resource, sedangkan panel lainnya berisi data durasi waktu penggunaan
resource tersebut pada sheet timescale.

OpenProj
OpenProj merupakan salah satu alternatif pengganti MsProject dengan beberapa alasan
sebagai berikut:

Mendukung program Kementrian Kominfo Indonesia Goes to Open Source (IGOS)


untuk mewujudkan kemandirian bangsa
Mendukung kampanye penggunaan aplikasi legal
Mendorong efektifitas dan efisiensi biaya, lisensi OpenProj adalah free
Kesamaan fitur dan tampilan dengan MsProject 2003
Memiliki kompatibiltas dengan MsProject, dapat membuka file MsProject, dapat
mengexport file save as ke MsProject.

Cara penggunaan OpenProj hampir sama dengan MsProject, setidaknya sampai dengan
MsProject versi 2003. Namun demikian, ini sudah lebih dari cukup untuk pengelolaan
berbagai proyek tipikal dengan berbagai macam ukuran. Bahkan artikel ini dibuat
dengan menggunakan referensi-referensi dari Microsoft Project sebagai bukti bagi para
pemakai MsProject untuk dapat langsung migrasi tanpa memerlukan adaptasi terlalu
lama.
1. Membuat Proyek Baru
Sesaat setelah menjalankan OpenProj pertama kali akan muncul jendela selamat
datang ke OpenProj. Kita akan diminta memilih antara membuat proyek baru
atau membuka file proyek yang sudah ada. Pilihlah opsi membuat proyek baru dan
masukkan nama proyek, manajer proyek, tanggal mulai proyek, serta biarkan opsi
forward scheduled tetap aktif (artinya, file proyek yang akan kita buat adalah
proyek yang baru, dan bukan untuk mengevaluasi proyek yang sudah berjalan di
mana tanggal-tanggal di dalam file proyek kita nantinya bisa diset mundur).
2. Membuat outline proyek
Membuat outline proyek merupakan langkah memasukkan daftar-daftar
pekerjaan (tasks) sebagai implementasi dari work-breakdown-structure (WBS)
dari proyek kita, memasukkan waktu dan durasi proyek (timing), serta mengatur
urutan pengerjakan tasks tersebut (dengan kata lain: mengatur
dependencies/ketergantungan antar task).

Memasukkan tasks ke dalam OpenProj sama langkahnya dengan MsProject. kita


dapat create new task, insert, delete, indent, outdent, dsb-nya. Gambar 2
menunjukkan tasks 1 s/d 10 dalam proyek yang tengah dibuat.
Editing/pengaturan waktu dan durasi (timing) dari setiap task serta
dependencies antar-task dapat dilakukan dengan klik ganda pada task yang akan
diedit. Pada jendela yang sama, kita dapat menggunakan tab predecessors
maupun Successors untuk menentukan alur/path dari proyek kita.
Melalui jendela Gantt Chart (lihat gambar ), kita dapat mengatur tanggal awal
proyek, tanggal selesai, predecessors. Kita juga dapat menggunakan fasilitas click
& drag pada Gantt Chart untuk mengatur dependencies antar task
3. Mengalokasikan Resource
OpenProj, sebagaimana MsProject, mengenal resources yang dapat dialokasikan
ke setiap task. Untuk dapat melakukan alokasi, resource harus sudah didaftarkan
lebih dulu. Untuk mendaftarkan resource gunakan menu View Resources untuk
menampilkan jendela Resource (kita juga dapat mengaktifkan jendela ini
menggunakan icon yang sesuai). Pada jendela Resources, masukkan nama
resource, tipe, initials, standard rate, overtime rate, dan cost per usage.
Selanjutnya, kita dapat mengalokasikan resources ini ke tasks proyek. Pilih menu
View Gantt Chart, dan klik setiap task yang akan kita alokasikan resources-nya.
Pada saat mengalokasikan resources ke dalam tasks proyek, perlu diingat agar
tidak terjadi over-allocated. Over-allocated terjadi misalnya bila seseorang
mendapatkan beban kerja 16 jam dalam sehari, padahal jam kerja dia adalah 8 jam
(lihat gambar 8). Walaupun ada overtime cost pada saat mendaftarkan resources,
namun pelaksanaan over-allocated perlu dipertimbangkan masak-masak. Untuk
mengatasi over-allocated, kita dapat mengalokasikan sumber daya lain atau
mengatur ulang durasi pekerjaan/task.
4. Membuat baseline
Setelah kita selesai dengan membuat outline proyek dan mengalokasikan
resources ke proyek tersebut, hal selanjutnya yang dapat dilakukan adalah
membuat baseline. Baseline merupakan istilah yang umum di dalam manajemen
proyek yang digunakan sebagai titik referensi yang dapat memberikan gambaran
status proyek pada saat tertentu (biasanya sebelum pekerjaan realisasi
dilakukan). Dengan membuat baseline, maka kita dapat melakukan
tracking/penelusuran pelaksanaan proyek, yaitu merekam realisasi proyek dan
membandingkannya dengan status awal yang ditandai dengan Baseline tersebut.
Untuk membuat baseline, pilih menu Tools Tracking Save Baseline. Setelah
membuat baseline, kita akan melihat persegi panjang berwarna abu-abu di bawah
persegi panjang biru/merah. Warna abu-abu adalah baseline kita, sedangkan
warna merah/biru memberikan status real.

5. Tracking Gantt
Setelah membuat baseline, kita sudah bisa mulai perekaman realisasi proyek.
Gunakan menu View Tracking Gantt. Dan masukkan actual start, prosentasi
realisasi pekerjaan, dan bila selesai: actual finish. Di sinilah pekerjaan
sesungguhnya dari pengelolaan proyek, yaitu merekam aktualisasi/realisasi,
membandingkannya dengan baseline, analisa, bila perlu membuat baseline
berikutnya, merekam realisasi lagi, dan seterusnya siklus ini berlangsung sampai
proyek dinyatakan selesai.
6. Reporting
Pelaporan di dalam OpenProj pada dasarnya dapat dilakukan dengan dua
pilihan, yaitu:
a. Mencetak view yang diinginkan apa adanya (misal view Gantt Chart, Network
Chart, dsb).
b. Menggunakan view Report (menu View Reports).
Pada menu View Reports, Anda bias memilih untuk mencetak:
a.
b.
c.
d.

Project details
Resource Information
Task Information
Who Does What

Masing-masing pilihan memiliki filter. Gambar memperlihatkan contoh View


Report Who Does What dengan filter Basic Report.
7. Kompatibilitas dengan Microsoft Project
OpenProj memiliki kompatibilitas dengan MsProject, yaitu OpenProj dapat
membuka file-file proyek yang dibuat oleh MsProjectdan sebaliknya,
OpenProj dapat juga mengekspor file menjadi format MsProject sehingga bisa
dibaca oleh MsProject.
Untuk meng-export file OpenProj ke format MsProject, gunakan menu File
Save As, dan pilih format Microsoft Project XML.

Perbandingan

GanttProject
Gratis
User friendly
Tampilan kurang menarik
Pengembangan lambat

Ukuran kecil
Ringan dan dapat
dijalankan di semua PC

Microsoft Project
Berbayar
User friendly
Tampilan menarik
Pengembangan cukup
cepat dan berkala
Ukuran besar
Berat dan memerlukan
PC dengan spesifikasi
tertentu

OpenProj

Gratis
User friendly
Tampilan kurang menarik
Pengembangan lambat

Ukuran kecil
Ringan dan kompatibel
dengan banyak PC

Kesimpulan
Dari uraian di atas, dapat disimpulkan bahwa Microsoft Project merupakan tools
manajemen proyek yang mempunyai fasilitas paling lengkap dibanding tools yang lain.
Namun bukan berarti tools yang lain tidak memiliki kelebihan, semua kembali kepafa
pengguna. Penggunaan tools dalam manajemen proyek sebaiknya disesuaikan dengan
skala dan kebutuhan proyek.