Anda di halaman 1dari 46

BAB I

PENDAHULUAN
1.1

Latar Belakang
Perkembangan ilmu pengetahuan dan kemajuan teknologi dewasa ini, sangat
membawa dampak positif di berbagai bidang, termasuk pula kemajuan iptek
khususnya di bidang komputer dan komunikasi. Hampir semua aspek kegiatan
memanfaatkan kemajuan teknologi, karena kemajuan teknologi komputer dan
komunikasi ini telah melahirkan suatu sistem berbasis komputer yang mampu
mengontrol jalannya atau perkembangan suatu kegiatan atau usaha secara lebih
mudah dan efektif.
Perkembangan ini membawa perubahan pada perkembangan sistem basis
data. Dimana, sistem basis data ini merupakan kumpulan dari item data yang saling
berhubungan satu dengan lainnya yang diorganisasikan berdasar sebuah skema atau
struktur tertentu, tersimpan di hardware komputer dan dengan software digunakan
untuk melakukan manipulasi data untuk tujuan tertentu. Jika dilihat dari berbagai
sudut pandang, basis data dapat didefinisikan sebagai berikut :

Himpunan kelompok data (arsip) yang saling berhubungan dan diorganisir


sedemikian rupa agar dapat dimanfaatkan kembali dengan cepat dan mudah.

Kumpulan data yang saling berhubungan dan disimpan secara bersamaan


sedemikian rupa tanpa adanya pengulangan (redundant) yang tidak perlu untuk
memenuhi berbagai kebutuhan.

Kumpulan file/tabel/arsip yang saling berhubunga yang disimpan dalam media


penyimpanan elektronis.
Basis data memiliki prinsip utama yaitu pengaturan data/arsip. Dan tujuan

utamanya adalah mencapai kemudahan dan kecepatan dalam pengambilan kembali


data/arsip dengan memakai media penyimpanan elektronis seperti disk (disket atau
harddisk).
Dalam suatu basis data bagian yang ditonjolkan adalah pengaturan /
pemilihan / pegelompokkan / pengorganisasian data yang akan disimpan sesuai
fungsi dan jenisnya. Pengaturan/pemilihan/pegelompokkan/pengorganisasian dapat
berbentuk sejumlah file atau tabel terpisah atau dalam bentuk pendefinisian
kolom/field data dalam setiap file atau tabel.
Dengan adanya sistem basis data, suatu pekerjaan yag memanfaatkan
kemajuan teknologi ini dapat terselesaikan dengan efektif dan efisien, karena data1

data diatur/diorganisir secara tepat. Sehingga dapat dengan cepat memperoleh


informasi dari susunan data tersebut.
1.2. Rumusan Masalah
Pada laporan praktikum ini akan dirumuskan masalah mengenai
Bagaimana membuat suatu sistem basis data Mahasiswa.
1.3. Tujuan Pembuatan Basis Data
Tujuan dibuatnya basis data secara umum adalah :
a.Agar mahasiswa dapat mengenal perangkat lunak Microsoft Access yang
merupakan salah satu program pendukung dalam mensplit data atau memisahkan
data agar tidak terjadi adanya data yang redundant.
b. Mahasiswa juga diharapkan mampu membuat sebuah model basis data yang baik.
Sedangkan tujuan utama dari pembuatan basis data adalah :
a.Agar data-data dapat diatur/dipilih/dikelompokkan/diorganisir sesuai dengan fungsi
dan jenisnya.
b. Agar dapat memperoleh informasi dari sejumlah data yang telah diorganisir dan
disimpan dalam media penyimpanan elektronis dengan mudah dan cepat.
c.Agar dapat meningkatkan kecepatan operasional dalam suatu fungsi Pengelolaan
Sistem Informasi.
1.4. Manfaat Basis Data
Pemanfaatan perangkat komputer dalam sebuah organisasi/perusahaan hampir
selalu berhubungan dengan basis data, dan biasanya digunakan untuk menjalankan
fungsi pengelolaan sistem informasi. Dengan adanya basis data sebagai salah satu
komponen utama dalam setiap sistem informasi, maka diharapkan dapat
meningkatkan

efisiensi,

daya

saing,

keakuratan,

kecepatan

operasional

organisasi/perusahaan terhadap sejumlah data yang telah diatur/diorganisir tersebut.


Jadi

secara

umum,

basis

data

ini

dapat

dimanfaatkan

untuk

membuat/menjalankan suatu sistem informasi


1.5. Volume Perkerjaan
Pada pelaksanaan praktikum Sistem Basis Data dengan menggunakan
Microsoft Access, yang dilakukan adalah mengilustrasikan model dan relational
secara lebih nyata, sebagai contoh basis data yang berkaitan dengan data fasilitas
(umum) daerah kota Malang. Basis data ini terdiri atas 5 buah tabel yaitu Data
2

Mahasiswa, Dosen, Jurusan, Nilai, Mata Kuliah. Yang kita ketahui, data tersebut
sudah tersedia dalam bentuk hardcopy atau cetakan dan siap kita implementasikan.
Sebelum kita menerapkan basis data, terlebih dahulu yang harus kita ketahui adalah
contoh data yang akan kita pergunakan. Contoh data ini harus di analisis untuk
mengetahui karakteristik masing-masing tabel data. Khusus untuk praktikum Sistem
Basis Data yang telah dilakukan di Laboratorium Sistem Informasi Geografi, Institut
Teknologi Nasional Malang adalah sebagai berikut :
1. Pengenalan Microsoft Access
2. Pembuatan dan modifikasi Tabel
3. Pembuatan relasi antar tabel (Relationship)
4. Pembuatan dan penggunaan Query
5. Pembuatan, penggunaan dan modifikasi Form
6. Pembuatan Report
7. Pembuatan Switchboard
1.6. Metode Penulisan
Dalam menyusun laporan Sistem Basis Data ini digunakan metode sebagai berikut :
1.6.1. Studi Literatur
Penyusunan laporan ini diawali dengan melakukan studi literatur yang
dimaksudkan guna mendapatkan dasar teori, informasi dan pengetahuan dari
berbagai sumber bacaan yang kemudian digunakan sebagai bahan acuan
penyusunan laporan. Literatur yang digunakan antara lain :
a.

Konsep Sistem Basis Data .

b.

Buku Microsoft Access.

I.6.2. Praktek Laboratorium


Praktek Laboratorium yang dilaksanakan adalah berupa praktek dan
pengambilan serta pemrosesan data sebagai bahan penunjang penyusunan
laporan, yang dilakukan pada tanggal 18 Mei 2009 bertempat di Laboratorium
SIG, Jurusan Teknik Geodesi, Institut Teknologi Nasional Malang.

BAB II
DASAR TEORI

2.1. Pengenalan Basis Data


Sistem Basis Data adalah suatu sistem menyusun dan mengelola necord-record
menggunakan computer untuk menyimpan atau merekam serta memelihara data
operasional lengkap sebuah organisasi/perusahaan sehingga mampu menyediakan
informasi yang optimal yang diperlukan pemakai untuk proses mengambil keputusan.
Salah satu cara menyajikan data untuk mempermudah modifikasi adalah dengan cara
pemodelan data. Model yang akan dipergunakan pada pelatihan ini adalah Entity
Relationship Model.
Model Entity Relationship adalah representasi logika dari data pada suatu
organisasi atau area bisnis tertentu dengan menggunakan Entity dan Relationship.
2.1.1. Entity/Entitas

Adalah obyek di dunia nyata yang dapat dibedakan dari obyek lain.

Entity Set / Kumpulan Entity adalah kumpulan dari entitas sejenis/dalam tipe sama.

Entity set dapat berupa:

Obyek fisik : rumah, kendaraan, pegawai

Obyek abstrak : konsep politik, pekerjaan, rencana, dll.

Simbol yang digunakan untuk entity adalah persegi panjang.

Tipe entitas :
o Entitas Kuat yaitu entitas mandiri yang keberadaannya tidak bergantung pada
keberadaan entitas lain
o Entitas Lemah / Weak Entity yaitu entitas yang keberadaannya bergantung
pada keberadaan entitas lain.
o Entitas Assosiatif adalah entitas yang terbentuk dari suatu relasi, bisa terjadi
jika :
-

Relasi yang merekatkan dua entitas bersifat banyak ke banyak

Biasanya berasal dari suatu relasi dimana relasi itu memiliki makna
mandiri bagi pengguna

2.1.2. Relationship
4

Adalah hubungan antara suatu himpunan entitas dengan himpunan entitas lainnya.
Simbol yang digunakan adalah bentuk belah ketupat, diamod atau rectangle.
Contoh :

Derajat Relationship
o Menjelaskan jumlah entity yang terlibat dalam suatu relationship
-

Unary Degree (Derajat satu) -> hanya satu entity yang terlibat

Binary Degree (Derajat dua) ->menghubungkan dua entity

Ternary Degree (Derajat tiga) menghubungkan tiga entity

Cardinality Ratio Constraint


o Menjelaskan batasan jumlah relasi suatu entity dengan entity lainnya
o Jenis rasio kardinalitas :
-

One to one (1:1)

One to many/many to one (1: M / M:1)

Many to many (M : N)

o Batasan kardinalitas
-

Kardinalitas Minimum
Adalah jumlah minimum instansiasi relasi B yang berasosiasi dengan
setiap instansiasi entitas A

Kardinalitas Maksimum
Adalah jumlah maksimum instansiasi relasi B yang berasosiasi dengan
setiap instansiasi entitas A

Participation Constraint
o Menjelaskan apakah keberadaan suatu entity tergantung pada hubungannya
dengan entity lain
-

Total participation, yaitu keberadaan suatu entity tergantung pada


hubungannya dengan entity lain. Di dalam diagram ER digambarkan
dengan dua garis penghubung antara entity dengan relationship.

Partial participations, yaitu keberadaan suatu entity tidak tergantung pada


hubungan dengan entity lain. Di dalam diagram ER digambarkan dengan
satu garis penghubung antara entity dengan relationship.

2.1.3. Atribut
Adalah property deskriptif yang dimiliki oleh setiap himpunan entitas
Jenis-jenis atribut :
o Atribut key : digunakan untuk mengidentifikasi suatu entity secara unik
o Atribut tunggal : memiliki nilai tunggal
o Atribut multivalue : memiliki sekelompok nilai untuk setiap instant entity
o Atribut composite : dapat didekomposisi menjadi beberapa atribut lain
o Atribut derivative : dihasilkan dari atribut yang lain
2.1.4. Key
Adalah sejumlah atribut yang mengidentifikasi record/baris dalam sebuah relation
secara unique.
6

Beberapa jenis key:


o Super Key

satu atribut atau kumpulan atribut yang secara unik

mengidentifikasi sebuah record di dalam relasi atau himpunan dari satu atau
lebih entitas yang dapat digunakan untuk mengidentifikasi secara unik sebuah
entitas dalam entitas set.
o Candidate Key : atribut-atribut yang menjadi determinan yang dapat dijadikan
identitas record pada sebuah relation bisa terdapat satu atau lebih candidate
key
o Primary key : candidate key yang menjadi identitas record karena dapat
mengidentifikasi record secara unik
o Altenate key : candidate key yang tidak dijadikan primary key
o Composite key : key yang terdiri dari 2 atribut atau lebih. Atribut-atribut
tersebut bila berdiri sendiri tidak menjadi identitas record, tetapi bila
dirangkaikan menjadi satu kesatuan akan dapat mengidentifikasi secara unik.
o Foreign key : non key atribut pada sebuah relation yang juga menjadi key
(primary) atribut di relation lainnya. Foreign key biasanya digunakan sebagai
penghubung antara record-record dan kedua relation tersebut.
o Contoh :

Super Key : S#, SName, Kode


Candidate Key : S#, SName
Primary Key : S#
Alternative Key : SName
Foreign Key : Kode
2.2. Membuat dan Memodifikasi Tabel (Table)
Tabel adalah kumpulan data yang berhubungan dengan topik tertentu, misalnya
daftar produk atau daftar pemasok. Dengan menggunakan tabel-tabel yang terpisah
untuk tiap topik, artinya anda menyimpan data hanya sekali untuk setiap data, yang
mengakibatkan database anda lebih efisien dan mengurangi kesalahan pemasukan
7

data. Tabel mengorganisasikan data ke dalam kolom-kolom (field) dan baris-baris


(record).
2.2.1. Jenis Data
Beberapa jenis data yang ditempatkan dalam setiap field yaitu antara lain :

Text, dapat menerima huruf, angka, spasi dan tanda baca. Sebuah field berisi
jenis data teks dapat menampung hingga 255 karakter, atau sebanyak lebar yang
anda tentukan dalam properti FieldSize.

Memo, dapat menerima teks apa saja sebagai catatan atau keterangan dengan
panjang maksimal 65535 karakter.

Number, berisi data bilangan yang digunakan untuk perhitungan matematis.


Ukurannya tergantung dari properti FieldSize.

Date/Time, hanya dapat menerima tanggal/waktu. Berisi nilai data tanggal dan
waktu untuk tahun 100 sampai dengan 9999. Ukuran tipe data ini adalah 8 byte.

Currency, berisi nilai uang dan data bilangan yang digunakan dalam perhitungan
matematis termasuk data dengan 1 sampai 4 angka dibelakang tanda desimal.
Tipe data ini memiliki ketelitian sampai 15 digit disebelah kiri tanda desimal dan
4 digit disebelah kanan tanda desimal. Ukuran tipe data ini adalah 8 byte.

AutoNumber, berisi bilangan yang berurutan atau bilangan acak yang unik
secara otomatis diberikan oleh Access 2007 jika record baru ditambahkan
kedalam tabel. Tipe data ini tidak dapat diubah-ubah nilainya oleh user. Properti
FieldSize dari tipe data ini dapat berupa Long Integer atau Replication ID.
Ukuran tipe data ini adalah 4 byte untuk bilangan (number) dan 16 byte untuk
Replication ID.

Yes/No, berisi nilai Yes atau No, atau field yang hanya memiliki 2 kemungkinan
nilai (Yes/NO, True/False, atau On/Off). Ukuran tipe data ini adalah 1 byte.

OLE Object, berisi obyek yang dikaitkan (linked) ke atau disisipkan (embedded)
ke dalam tabel Access 2007. Obyek disini contohnya antara lain lembar kerja
Excel, dokumen Word, gambar, foto, grafik, suara, atau data biner lainnya.
Ukuran tipe data ini adalah sampai 1 gigabyte atau dibatasi dengan ukuran media
penyimpanan yang tersedia.

Hyperlink, dapat diisi dengan alamat hyperlink (URL) agar bisa terkait dengan
objek atau data yang tersimpan dilokasi tertentu. Dengan menggunakan hyperlink
anda dapat melompat ke sebuah obyek dalam database Microsoft Access, ke
dokumen Microsoft Word, ke lembar kerja Microsoft Excel, ke slide presentasi
Microsoft PowerPoint, ke halaman Web di Internet atau Intranet.
8

Lookup Wizardmemungkinkan anda untuk memilih nilai dari tabel lain atau
dari daftar nilai yang didefinisikan sendiri dengan menggunakan list box atau
combo box. Ukuran tipe data ini adalah sama dengan primary key yang digunakan
untuk menampilkan lookup, biasanya 4 byte.

2.3. Membuat Dan Menggunakan Query


Anda dapat menggunakan query untuk melihat, mengubah, dan menganalisa
data dalam berbagai cara. Anda juga dapat menggunakan query sebagai sumber untuk
record-record yang digunakan pada form dan report.
Ada beberapa macam query yang terdapat dalam Access 2007, yaitu :

Select Query, merupakan jenis query yang paling umum. Select query
mengambil data dari satu tabel atau lebih menggunakan suatu kriteria tertentu,
kemudian menampilkannya. Anda dapat juga menggunakan select query untuk
mengelompokkan sejumlah record dan menghitung jumlah total, jumlah, serta
rata-rata.

Parameter Query, adalah query yang jika dijalankan menampilkan kotak dialog
yang menanyakan informasi yang akan digunakan sebagai kriteria untuk
mengambil data atau suatu nilai yang ingin disisipkan dalam suatu field. Anda
dapat merancang query untuk menanyakan lebih dari satu informasi sebagai
kriteria, misalnya anda dapat merancang untuk menanyakan dua buah tanggal,
kemudian Access 2007 mengambil semua record yang ada diantara kedua tanggal
tersebut.
Parameter query juga berguna sebagai basis data bagi form dan report.
Contohnya, untuk membuat laporan pendapatan bulanan berdasarkan parameter
query. Ketika anda mencetak laporan (report), Access 2007 menampilkan kotak
dialog menanyakan bulan yang anda inginkan. Anda mengisikan bulan yang anda
inginkan dan Access 2007 mencetak laporan pendapatan bulan tersebut.

Crosstab Query, menampilkan nilai-nilai yang telah diolah (jumlah total, jumlah
nilai, dan rata-rata) dari suatu field dalam tabel dan mengelompokkannya
kedalam suatu kelompok fakta yang didaftarkan pada bagian kiri dari datasheet
dan kelompok fakta lain pada bagian atas dari datasheet.
Anda juga bisa menampilkan data crosstab tanpa membuat query yang terpisah
dalam database dengan menggunakan PivotTable Wizard. Dengan PivotTable
anda dapat mengubah judul baris dan kolom untuk menganalisa data dalam
berbagai cara.
9

Action Query, adalah query yang membuat perubahan terhadap satu atau
beberapa report sekaligus. Ada 4 macam action query yaitu : delete query, update
query, append query, make-table query.

Delete Query, digunakan untuk menghapus sekumpulan record dalam satu tabel
atau lebih. Misalnya, anda dapat menggunakan delete query untuk menghapus
produk-produk yang sudah tidak aktif dijual dan dibeli lagi. Dengan delete query,
anda selalu menghapus keseluruhan record, bukan hanya beberapa field dalam
satu record.

Update Query, digunakan untuk membuat perubahan umum/global terhadap


sekumpulan record dalam satu tabel atau lebih. Sebagai contoh, anda dapat
menaikkan harga produk sebesar 10 %, atau anda dapat menaikkan upah sebesar
5 %.

Append Query, digunakan untuk menambahkan sekelompok record dari satu


atau lebih tabel kedalam satu atau lebih tabel.

Make-Table Query, digunakan untuk membuat tabel baru dari seluruh atau
sebagian data dalam satu atau lebih tabel. Make-Table Query juga berguna untuk
membuat tabel untuk ditransfer pada database Access 2007 yang lain, membuat
report yang menampilkan data mulai posisi tertentu, membuat backup atau
salinan dari suatu tabel, membuat tabel history yang berisi record-record yang
sudah lama.

SQL Query, adalah query yang dibuat menggunakan pernyataan SQL. SQL
query terdiri dari union query, pass-through query, data definition query.

Union, jenis query ini menggabungkan field (kolom) dari satu atau lebih tabel
atau query kedalam satu field atau kolom dalam query hasilnya. Misalnya, jika
anda memiliki enam pemasok yang mengirimkan daftar persediaan barang tiap
bulan, anda dapat menggabungkan daftar tersebut ke dalam sebuah query
menggunakan union query, kemudian anda dapat membuat tabel make-table
query berdasarkan union query tersebut untuk membuat sebuah tabel yang baru.

Pass-Through, jenis query ini mengirimkan perintah secara langsung ke database


ODBC, seperti Microsoft SQL Server, menggunakan perintah yang dapat
diterima oleh server. Contohnya, anda dapat menggunakan pass-through query
untuk mengambil record atau mengubah data.

Data-Definition, jenis query ini membuat obyek database, seperti tabel Microsoft
Acccess atau tabel Microsoft SQL Server.

10

2.4. Mengenal Form (Formulir)


Form digunakan untuk mempermudah memasukkan data pada tabel,
menampilkan, mencari, memperbaiki dan mencetak data. Anda dapat membuat form
dengan fasilitas Create form in Design View (relatif lebih fleksibel) atau dengan
Create form by using Wizard. Apabila kita menggunakan create form fasilitas create
report by using wizard, kita dapat memilih layout form,bentuk form,dan lain-lain
sesuai dengan kenginan kita.
2.5. MENGENAL ACCESS 2007
Microsoft Access adalah suatu aplikasi yang dapat membantu kita membuat
sebuah aplikasi database dalam waktu yang relatif singkat. Biasanya digunakan untuk
pembuatan aplikasi-aplikasi yang kecil. Misalnya Program untuk Kasir di koperasi,
penjualan untuk toko. Sebelum mulai belajar jangan lupa berdoa dulu kemudian
Tanamkan pada diri anda bahwa Microsoft Access itu gampang dan mudah dipelajari.
Kuatkan keyakinan pada diri anda bahwa anda dapat menguasainya.
Bagian bagian Microsoft Access yaitu terdiri dari :
a.Table digunakan untuk menyimpan data
b. Query digunakan untuk memanipulasi data
c.Form digunakan untuk frontend aplikasi. Biasanya untuk menampilkan data,
menambah data dll.
d. Report digunakan untuk membuat laporan
e.Macro digunakan untuk melakukan satu atau beberapa fungsi.
f. Switchboard digun
2.5.1. Memulai Microsoft Access 2007
Ada beberapa cara yang dapat anda gunakan untuk menjalankan Access 2007.
Yang pertama adalah dengan menggunakan tombol Start di Taskbar, kedua dengan
menggunakan Microsoft Office Shortcut Bar dan yang ketiga yaitu dengan memilih
Menu New Office Document. Pada buku bab ini akan dijelaskan urutan langkah
bagaimana menjalankan Access 2007 dengan menggunakan Tombol Start di Taskbar,
dengan langkah sebagai berikut :
1. Klik tombol Start yang ada di Taskbar.
2. Pilih menu Programs. Lalu pilih Microsoft Office dan klik program Microsoft
Office Access 2007 (gambar 2.1.). Kemudian tunggu sampai jendela program
aplikasi Access 2007 ditampilkan dan kotak dialog Startup Access ditampilkan.
(gambar 2.1.).
11

Gambar 2.1. Cara Memulai Access 2007 Melalui Tombol Start


2.5.2. Membuat Database Baru yang Masih Kosong
Untuk membuat database baru yang masih kosong, berikut langkahnya :
1. Jalankan atau aktifkan program aplikasi Access 2007. Setelah terbuka klik Blank
Database, pada jendela file new database isikan nama file yang diinginkan.

Gambar 2.2. Kotak Dialog Microsoft Access Startup


2. Pada kotak dialog tersebut pilh atau klik tombol, pilihan berikut ini:
a.New Blank Database, untuk membuat sebuah database baru yang masih
kosong.
12

b. Pada Fetured Online Templates dapat dipilh beberapa jenis Database yang
bias didapatkan dari Microsoft secara online.
2.5.3. Mengenal Elemen Dasar Access 2007
Elemen dasar Access 2007 yang perlu diketahui diantaranya :
a. Jendela Home berisi menu-menu untuk menampilkan tabel, design tabel
b. Baris Judul (Title Bar), berisi nama file dan nama program aplikasi yang
sedang aktif. Baris judul ini dapat juga digunakan untuk memindahkan
jendela ke posisi lain.
c. Baris Menu (Menu Bar), berisi barisan perintah berupa menu, seperti
menu File, Edit, View, Insert, Format, Records, Tools, Windows dan
Help.
d. Baris Toolbar (Toolbars), berisi tombol-tombol yang digunakan untuk
menjalankan suatu perintah dengan cepat dan mudah, terutama untuk
perintah-perintah yang sering anda gunakan.
e. Jendela Database, menampilkan file database yang sedang aktif, lengkap
dengan seluruh obyek databasenya.
f. Microsoft Access Help, memberikan informasi dan penjelasan singkat
untuk setiap masalah yang ditemui ketika bekerja dengan Access 2007.
2.5.4. Menggunakan Menu Help
Menu Help akan memberikan informasi dan penjelasan singkat untuk setiap
masalah yang ditemui ketika bekerja dengan Access 2007. Penggunaan menu
Microsoft Access Help ini akan dipandu oleh Office Assistant yang ditampilkan
dengan gambar animasi yang menarik dan interaktif. Untuk menggunakan fasilitas
Microsoft Help ini, pilih dan klik menu Help, Microsoft Access Help (F1) atau klik
tombol toolbar Microsoft Access Help.
Langkah penggunaannya adalah sebagai berikut :
1. Pilih dan klik menu Help, Microsoft Access Help (F1) atau klik tombol toolbar
Microsoft Access Help. Kotak percakapan Office Assistant akan ditampilkan.
(gambar2.4.).

13

Gambar 2.4. Tampilan Office Assistant


2. Pada kotak isian yang telah disediakan, ketikkan topik permasalahan yang ingin
anda ketahui. Kemudian klik tombol perintah Search. Misalnya anda ingin
mengetahui berbagai hal yang berhubungan dengan relation, untuk itu ketikkan
Relationship sebagai topik yang ingin anda ketahui.
3. Kotak percakapan Office Assistant yang baru akan ditampilkan, yang berisi butirbutir informasi yang mendekati topik permasalahan yang anda tanyakan. Pilih
salah satu butir informasi yang anda inginkan. Misalnya anda pilih dan klik butir
Add labels to relationship. Jendela Microsoft Access Help akan ditampilkan.
(gambar 2.5)

Gambar 2.5. Jendela Microsoft Access Help

14

2.5.5. Mengakhiri Penggunaan Access 2007


Setelah anda selesai bekerja dengan Access 2007, anda dapat mengakhirinya
dengan menggunakan langkah sebagai berikut :
1. Simpan database yang telah dibuat atau yang telah disunting (edit).
2. Kemudian pilih salah satu langkah untuk mengakhiri penggunaan Access 2007
berikut ini :

Pilih dan klik menu File, Exit (Alt+F4).

Klik tombol Close (X) yang berada di pojok kanan atas jendela.

Klik dua kali Icon Kontrol Menu yang berada dipojok kiri atas jendela kerja
Access 2007.

3. Tunggu sampai jendela kerja Access 2007 ditutup.

15

BAB III
PEMBUATAN MODEL BASIS DATA

3.1. Alat Yang Digunakan Untuk Membuat Basis Data


Basis data merupakan sistem yang berbasis komputer yang terdiri dari item
data yang saling berhubungan satu dengan lainnya yang diorganisasikan berdasar
struktur tertentu dan tersimpan di hardware komputer dengan software yang
digunakan untuk melakukan manipulasi data untuk tujuan tertentu
Maka komponen utama dalam proses ini adalah komputer beserta software
pedukungnya. Secara spesifik komponen / alat yang digunakan untuk membuat basis
data adalah sebagai berikut :

Perangkat Keras ( Hardware )


Untuk pembuatan basis data, perangkat keras yang dibutuhkan meliputi :

CPU
Bagian dari unit komputer yang berfungsi untuk memproses data yang telah
kita peroleh. Jadi apabila kita ingin melihat kembali informasi yang kita
simpan, kita tidak akan mengalami kesulitan dalan pencariannya.

Monitor
Berfungsi untuk menampilkan data yang telah kita simpan untuk kemudian
kita proses.

Keyboard
Berfungsi untuk memasukkan data kedalam CPU dalam bentuk tulisan atau
simbol.

Hard disc
Berfungsi untuk menyimpan file tempat kita memasukkan data yang telah kita
peroleh.

Mouse
Untuk membantu memberikan perintah yang sudah ada pada komputer.

Perangkat Lunak ( Software )


Perangkat lunak (software) yang diperlukan untuk dapat melakukan pengolahan
data-data agar dapat membuat basis datanya, antara lain program aplikasi
Microsoft Office Access 2007 dan Microsoft Office Word 2007.

Microsoft Office Access 2007

16

Microsoft Office Access 2007 adalah perangkat lunak pengolahan


database yang cocok untuk mengolah informasi dalam jumlah banyak. Office
Access 2007 merupakan software manajemen database atau sistem
manajemen database, yang sering disingkat DBMS. Office Access 2007
menyediakan banyak cara peragaan informasi yang dibuat dengan query,
form, report. Masing-masing mempunyai fungsi tersendiri misalnya :
o Query, untuk menampilkan dengan spesifikasi tertentu.
o Form, untuk menampilkan seluruh data satu record.
o Report, untuk menampilkan data dengan format tertentu.
Beberapa istilah database yang akan sering dipakai dalam Office Access
2007 diterangkan sebagai berikut :
o Database adalah kelompok informasi yang diatur berhubungan dengan
pengolahan data, penyediaan informasi dan penggunaan referensi.
o Field adalah tempat dimana informasi ditampung.
o Record adalah kumpulan informasi yang berhubungan dengan informasi
di field.
3.2. Diagram Alir Perancangan Sistem Basis Data

17

Diagram di atas menunjukkan alur atau urutan dalam proses pembuatan basis data
yang terangkum sebagai suatu bentuk rumusan permasalahan, yaitu meliputi beberapa
hal antara lain :

Persiapan
Tahap persiapan meliputi dua hal yaitu kesiapan dari segi teknis dan kesiapan datadata yang akan digunakan. Kesiapan teknis berkaitan dengan alat yang akan dipakai
untuk mengolah data ( membuat basis data ) baik berupa perangkat keras maupun
perangkat lunaknya. Sedangkan kesiapan data-data berkaitan dengan suatu
permasalahan/topik

pada

bidang

tertentu

yang

akan

diangkat

untuk

diatur/diorganisir membentuk suatu sistem basis data.


Dalam lapoan ini permasalahan/topik yang dibahas adalah mengenai pembuatan
basis data untuk keperluan reservasi bus.

Persiapan dan Analisa Permasalahan ( tentang basis data )


Basis data merupakan kumpulan data yang berhubungan dengan suatu objek, topik
atau tujuan khusus tertentu. Permasalahan / topik yang akan diangkat harus
dianalisa untuk keperluan penyusunan basis datanya. Dalam laporan ini, topik
tentang reservasi bus dianalisa terlebih dahulu dan ditentukan materi atau data-data
apa saja yang diperlukan untuk penyusunan basis datanya. Berdasarkan hasil
analisa permasalahan tersebut, maka didapat sejumlah data yang dikelompokkan
dalam beberapa buah tabel antara lain : tabel nama awak bus, tabel daftar bus, tabel
jenis bus, tabel kelas bus, tabel jurusan, tabel jadwal keberangkatan, tabel
operasional dan tabel tarif bus.

Pengumpulan Data Software


Data-data yang akan diorganisir dengan suatu sistem basis data, dapat diperoleh
dari berbagai sumber yakni dapat diperoleh secara langsung dari perusahaan yang
bersangkutan ataupun dari sumber-sumber lain. Data yang diperoleh kemudian
dikelompokkan dalam bentuk format tabel-tabel dengan entitas tertentu, yang mana
untuk pembuatan basis datanya harus menggunakan suatu sistem pengolahan data
(perangkat lunak / software) sehingga dapat mempermudah dan mempercepat
pemrosesan data.

Hubungan antar Tabel/ Entitas (Relationship)


Adalah hubungan antara suatu himpunan entitas dengan himpunan entitas lainnya
18

Analisa Data (Query)


Data-data yang telah dibuat basis datanya, harus dianalisa kebenaran dalam
penyusunannya atau dalam hubungan antar tabel-tabelnya (relationships). Dalam
hal ini dapat dilakukan dengan membuat query. Atau dengan kata lain query dapat
digunakan untuk mencari dan menampilkan data yang memenuhi syarat tertentu
dari sebuah tabel atau lebih.

Form
Untuk mempermudah memasukkan data pada tabel menampilkan, mencari,
memperbaiki dan mencetak data. Anda dapat membuat form dengan fasilitas yang
telah tersedia.

Report
Basis data yang telah dibuat dapat ditampilkan sebagai suatu bentuk laporan hasil
analisa data dengan membuat report yang dapat disajikan dalam bentuk yang
beragam.

3.3. Langkah Pembuatan Basis Data


3.3.1. Pembuatan Tabel

Membuat Tabel Baru Dengan Fasilitas Create Table in Design View


Ada 3 cara yang dapat digunakan untuk membuat table baru, yaitu pertama
menggunakan fasilitas Create Table in Design View, kedua dengan fasilitas
Create Table by Entering Data. Namun dalam praktikum ini akan dipelajari
membuat table dengan menggunkan fasilitas Create Table in Design View karena
sifatnya yang relatif fleksibel daripada menggunakan kedua fasilitas yang lain.
Adapun langkah kerjanya adalah sebagai berikut :
. Buka file database yang anda inginkan, kemudian pada jendela kerja database,
klik Tables dalam kolom Objects dan klik menu View, Database Objects,
Tables.

Gambar 3.1 Jendela Object Table

19

b. Pada jendela kerja database dengan pilihan obyek table tersebut, klik dua kali
Create Table in Design View. Jendela table design akan ditampilkan

Gambar 3.2 Table Design

. Pada kotak dialog tersebut, lakukan endefinisian struktur tabel dengan cara
mengisi nama field (field name) dengan panjang maksimum 64 karakter, jenis
data (data type) dan keterangan (description) bila ada. Catatan : ketika anda
mengisi filed name, anda perlu menentukan field name mana yang akan
dijadikan Primary Key, pilih dan klik menu Edit, Primary Key atau tombol
toolbar Primary Key.
d. Setelah selesai melakukan pendefinisian struktur tabel, simpan hasil
pendefinisian tersebut dengan cara memilih dan mengklik menu File, Save
(Ctrl+S) atau klik tombol toolbar Save.

Gambar 3.3 Save As Table

e. Pada kotak isian Table Name, ketikkan nama untuk tabel tersebut. Kemudian
klik OK.
f. Bila tidak dibutuhkan lagi, tutup jendela pendefinisian tabel tersebut dengan
cara memilih dan mengklik File, Close atau klik tombol Close (X).
3.3.2. Pembuatan Relationships
Relasi antar tabel bekerja dengan mencocokkan data dalam data field kunci,
biasanya berupa field yang memiliki nama yang sama pada kedua tabel yang
20

memiliki relasi. Pada umumnya, field-field yang bersesuaian ini adalah primary
key pada tabel yang satu, yang memberikan identitas unik bagi tiap record dalam
tabel tersebut dan foreign key pada tabel yang lain.

Jenis-Jenis Relasi antar Tabel


o One to one relationship ( relasi satu ke satu )
Dalam relasi satu ke satu, setiap record dalam tabel a hanya dapat
memiliki satu record yang bersesuaian dalam tabel B, dan sebaliknya.
Jenis relasi ini tidak umum, karena sebenarnya tabel A dan tabel b dapat
digabungkan menjadi satu tabel. Anda dapat menggunakan relasi satu ke
satu untuk membagi tabel yang memiliki field yang banyak, untuk
mengisolasi sebagian dengan alasan keamanan data.
o One to many relationship (relasi satu ke banyak)
Dalam relasi satu ke banyak, sebuah record dalam tabel A berhubungan
dengan banyak record yang bersesuaian dalam tabel B. Tetapi sebuah
record dalam tabel B hanya memiliki sebuah record yang berhubungan
dalam tabel A.
o Many to many relationship (relasi banyak ke banyak)
Dalam relasi banyak ke banyak, sebuah reciord dalam tabel A dapat
memiliki banyak record yang bersesuaian dalam tabel B, dan sebuah
record dalam tabel b dapat memiliki banyak record yang bersesuaian
dalam tabel A. Jenis relasi ini hanya memungkinkan jika kita
mendefinisikan tabel baru sebagai perantara. Relasi banyak ke banyak
sebenarnya merupakan dua buah relasi satu ke banyak terhadap tabel
perantara.
Sebagai contoh database 5 buah tabel yaitu :

Kabupaten

Kecamatan

Pasar

Jalan

Hotel

21

Berikut ini adalah beberapa contoh tabel tersebut :

Gambar 3.4 Tabel Data Kabupaten

Gambar 3.5 Tabel Kecamatan

Gambar 3.6 Tabel Pasar

22

Gambar 3.7 Tabel Jalan

Gambar 3.8 Tabel Hotel

Untuk membuat hubungan antar tabel dari tabel-tabel tersebut, ikuti langkah
berikut ini :
a. Buka file database yang anda inginkan. Untuk contoh di atas buka file Mahasiswa.
b. Pilih dan klik menu Tools, Relationships atau klik tombol toolbar Relationships.
c. Pilih dan klik nama tabel yang ingin anda hubungkan, kemudian klik tombol
perintah Add atau klik dua kali pada nama tabel yang anda inginkan.
d. Untuk kotak dialog Show Table, pilih dan klik tombol perintah Close.
e. Untuk membuat hubungan antar tabel, geserlah (drag) nama field yang ingin anda
gunakan sebagai penghubung ke posisi nama field pada tabel lain. Dengan catatan
kedua field da;am masing-masing tabel tersebut harus sama.
f. Langkah yang sama dilakukan juga untuk tabel yang lain yang akan dihubungkan.
g. Untuk menyimpan hasil rancangan hubungan antar tabel tersebut, pilih dan klik
menu File, Save (CTRL+S) atau klik tombol toolbar Save.
h. Untuk menutup jendela kerja Relationships, pilih dan klik menu File, Close atau
klik tombol Close(X).

23

Gambar 3.9 Hubungan Antar Tabel

3.3.3. Pembuatan Query


Query dapat digunakan untuk melihat, mengubah dan menganalisa data dalam
berbagai cara. Selain itu juga dapat digunakan sebagai sumber untuk record-record
yang dipakai pada pembuatan form dan report.

Jenis-Jenis Query
Beberapa macam query yang terdapat dalam Access 2007 antara lain :
Select Query , merupakan jenis query yang paling umum. Select query
mengambil data dari satu tabel atau lebih menggunakan suatu kriteria tertentu,
kemudian menampilkannya. Selain itu select query juga dapat digunakan
untuk mengelompokkan sejumlah record dan menghitung jumlah total,
jumlah, serta rata-rata.
Parameter Query, adalah query yang jika dijalankan akan menampilkan kotak
dialog yang menanyakan informasi yang akan digunakan sebagai kriteria
untuk mengambil data atau suatu nilai yang ingin disisipkan ke dalam suatu
field. Agar dapat merancang query untuk menanyakan lebih dari satu
informasi sebagai kriteria, misalnya merancang untuk menanyakan dua buah
tanggal, kemudian Office Access 2007 mengambil semua record yang ada di
antara kedua tanggal tersebut.
Parameter query juga berguna sebagai basis data bagi form dan report.
Crosstab Query , menampilkan nilai-nilai yang telah diolah (jumlah total,
jumlah

nilai,

dan

rata-rata)

dari

satu

field

dalam

tabel

dan

mengelompokkannya ke dalam suatu kelompok fakta yang didaftarkan pada


bagian kiri dari datasheet dan kelompok fakta lain pada bagian atas dari
datasheet.
24

Data csosstab juga dapat ditampilkan tanpa membuat query yang terpisah
dalam database denngan menggunakan Pivot Table Wizard. Dengan Pivot
Table judul baris dan kolom dapat dirubah untuk menganalisa data dalam
berbagai cara.
Action Query , adalah query yang dapat membuat perubahan terhadap satu
atau beberapa reportsekaligus. Ada 4 macam query yaitu : delete query,
update query, append query, make-table query.
- Delete Query : digunakan untuk menghapus sekumpulan record dalam satu
tabel atau lebih.
- Update Query : digunakan untuk membuat perubahan umum atau global
terhadap sekumpulan record dalam satu tabel atau lebih.
- Append Query : digunakan untuk menambahkan sekelompok record dari
satu atau lebih tabel ke dalam satu atau lebih tabel.
- Make-table Query : digunakan untuk membuat tabel baru dari seluruh atau
sebagian data dalam satu tabel atau lebih.Make-table query juga dapat
digunakan untuk membuat tabel untuk ditransfer pada database Office
Access 2007 yang lain, membuat report yang menampilkan data mulai
posisi tertentu, membuat backup atau salinan dari suatu tabel, membuat
tabel history yang berisi record-record yang sudah lama.
SQL Query , adalah query yang dibuat menggunakan pernyataan SQL. SQL
query terdiri dari union query, pass-through query, data definition query.
- Union, jenis query ini menggabungkan field (kolom) dari satu atau lebih
tabel atau query ke dalam satu field atau kolom dalam query hasilnya.
- Pass-Through, jenis query ini mengirimkan perintah secara langsung ke
database ODBC, seperti Microsoft SQL Server, menggunakan perintah
yang dapat diterima oleh server.
- Data-Definition, jenis query ini membuat objek database, seperti tabel
Microfost Access atau microsoft SQL Server.

Membuat Query dengan Fasilitas Create Query by Using Wizard.


Untuk membuat query baru dengan fasilitas ini ikutilah langkah berikut :
a.Buka file Database yang anda inginkan, kemudian pada jendela kerja database,
klik Queries yang ada di bawah Objects atau pilih dan klik menu View,
Database Object, Queries.

25

b. Pada jendela kerja database dengan pilihan obyek queries tersebut, klik dua
kali Create Query by Using Wizard. Kotak dialog simple Query Wizard
yang pertama akan ditampilkan.

Gambar 3.10 Kotak Dialog Simple Query Wizard

c. Pada kotak dialog tersebut, lakukan pemilihan sebagai berikut :


Pada tombol daftar pilihan Table/Queries, pilih dan klik tabel yang diinginkan.
-

Pada kotak daftar pilihan Available Fields, pilih dan klik nama field yang
akan diambil. Kemudian klik tombol >, untuk memindahkan pada kotak
Selected Fields. Lakukan langkah yang sama untuk memilih field yang lain
yang ingin ditampilkan dalam query. Untuk membatalkan perintah gunakan
tombol <.

Bila perlu anda dapat memilih tabel lain, yang fieldnya ingin ditampilkan
pada query yang sama.
Catatan : bila memilih lebih dari satu tabel, tabel-tabel yang anda

pilih harus sudah memiliki hubungan satu sama lain (relationship)


Klik tombol perintah Next, untuk melanjutkan ke kotak dialog Simple Query
Wizard yang kedua yang akan ditemapilakan pada gambar di bawah ini :

26

Gambar 3.11 Kotak Dialog Simple Query Wizard

d. Pada kotak yang kedua ini, anda diminta untuk mengisi nama query dan
memilih opsi pembuatan query. Setelah itu tekan Finish.

Gambar 3.12 Kotak Dialog Simple Query Wizard

e.

Tampilan hasil Query Nilai

Gambar 3.13 Kotak Dialog Query

f. Pada kotak dialog yang terakhir, ini ketikkan nama atau judul yang akan anda
query tersebut. Kemudian klik atau beri tanda tombol pilihan Open the query
27

to view information, untuk menampilkan hasil query yang terbentuk. Untuk


mengakhiri penggunaan Simple Query Wizard, klik tombol perintah Finish.

Membuat Query dengan Fasilitas Create Query in Design View

Untuk membuat query baru dengan menggunkan fasilitas ini, ikutilah langkah berikut :
a. Buka file database anda, kemudian pada jendela kerja database, klik Create
kemudian pilih Queries Design. Pada jendela kerja database dengan pilihan
obyek queries tersebut, klik 2 kali Create Query in Design View. Jendela kerja
Select Query dengan kotak dialog Show Table akan ditampilkan seperti pada
gambar 3.14.

Gambar 3.14 Kotak Dialog Show Table Select Query

a. Buka file database anda, kemudian pada jendela kerja database, klik Create
kemudian pilih Queries Design. Pada jendela kerja database dengan pilihan
obyek queries tersebut, klik 2 kali Create Query in Design View. Jendela kerja
Select Query dengan kotak dialog Show Table akan ditampilkan seperti pada
gambar 3.15.
b. Pada kotak dialog Show Table, pilih dan klik tabel atau query lain yang akan
dilibatkan. Kemudian pilih dan klik tombol perintah Add. Catatan : untuk
memilih beberapa tabel secara sekaligus, lakukan pemilihan sambil menekan
tombol Ctrl.
c. Untuk menutup kotak dialog Show Table, pilih dan klik tombol perintah Close.
Dengan langkah ini jendela kerja Select Query yang siap digunakan akan
ditampilkan (Gambar 3.15).
Catatan : apabila ingin menampilkan kembali kotak dialog Show Table pilih
dan klik View, Show Table atau klik tombol toolbar Show Table.

28

Gambar 3.15 Kotak Dialog Query Nilai

d. Pada jendela kerja Select Query tersebut, tempatkan field-field yang anda
inginkan pada kolom yang disediakan. Untuk itu gunkan salah satu cara
berikut :
-

Mulai dengan kolom pertama, dengan menggunakan tombol daftar pilihan


yang ada pada baris Table pilih dan klik tabel yang anda inginkan,
kemudian dengan menggunakan tombol daftar yang ada pada baris Field
pilih dan klik field yang akan ditampilkan. Dengan menggunakan langkah
yang sama, lanjutkan untuk pengisian kolom-kolom berikutnya.

Pada kotak daftar pilihan field yang ada di bagian atas jendela kerja Select
Query, pilih dan klik nama field yang ingin ditampilkan kemudian geser
(drag) ke posisi kolom yang anda inginkan.

Pada kotak daftar pilihan yang ada dibagian atas jendela kerja Select Query,
pilih dan klik dua kali nama field yang ingin ditampilkan. Dengan langkah
ini secara otomatis field yang anda pilih akan ditempatkan pada posisi
kolom berikutnya yang masih kosong.

e. Untuk melihat hasil query yang baru anda bentuk, pilih dan klik menu Query,
Run atau klik tombol toolbar Run.
Menggunakan Tombol Toolbar :
Toolbar
!

Perintah
Run

Keterangan
Digunakan untuk menampilkan Query yang anda rancang

29

Gambar 3.16. Jendela Kerja Hasil Query

Mengakhiri dan Menyimpan Query


Untuk mengakhiri dan menyimpan query yang anda buat, ikutilah langkah berikut :
a. Pilih dan klik menu File, Close atau tombol Close ( X ). Kotak dialog yang
mengkonfirmasi penyimpanan akan ditampilkan.
b. Untuk menyimpan rancangan query yang telah anda buat, klik tombol perintah
Yes. Kemudian ketikkan nama query yang anda inginkan.
c. Klik OK.

Membuka dan Menjalankan Query

Untuk membuka dan menjalankan query yang telah anda simpan, ikutilah langkah
berikut ini:
a. Buka file database yang anda inginkan, kemudian pada jendela kerja database,
klik Queries yang ada dibawah All Tables .
b. Pilih dan klik nama queri yang anda inginkan, kemudian klik tombol perintah
Open atau klik dua klik pada nama query yang ingin anda buka.
c.

Dengan langkah ini query akan dibuka tampilan Datasheet View.


Pada tampilan tersebut, anda dapat melakukan pengolahan data seperti halnya
anda mengolah data pada tabel.

Memodifikasi Rancangan Query


Untuk menyesuaikan kebutuhan anda, rancangan query yang telah dibuat dapat
dimodifikasi lebih lanjut dengan berbagai cara berikut:

Menghapus Sebuah Field

30

Untuk menghapus sebuah field tertentu yang tidak dibutuhkan lagi dari query,
ikutilah langkah berikut ini:
a. Buka file database yang anda inginkan, kemudian pada jendela kerja
database, klik Queries yang ada dibawah All Tables. Pilih dan klik Query
yang ingin anda modifikasi rancangannya, kemudian klik tombol toolbar
Design. Jendela perancangan query akan ditampilkan.
b. Pilih dan klik field yang akan anda hapus, kemudian pilih dan klik menu
Edit, Delete Colums.
Catatan :
-

Untuk melihat hasil perubahan atau modifikasi yang telah anda lakukan
pilih dan klik menu Query, Run atau klik tombol toolbar Run. Dengan
langkah ini query akan dijalankan dalam tampilan Datasheet View.

Untuk kembali ke jendela kerja perancangan (design view), pilih dan klik
menu View, Design View atau klik tombol toolbar Design View.

Setelah anda melakukan

modifikasi rancangan query, jangan lupa

menyimpannya dengan cara memilih menu File, Save (Ctrl + S) atau klik
tombol toolbar Save.

Menyisipkan Kolom Baru yang Masih Kosong

Untuk menyisipkan kolom baru yang masih kosong pada query, ikutilah
langkah berikut :
a. Pilih dan klik query yang anda ingin modifikasi rancangannya,
kemudian klik tombol toolbar Design. Jendela kerja perancangan query
akan di tampilkan.
b. Pilih dan klik field yang akan anda sisipkan kolom field baru, kemudian
pilih dan klik menu Insert, Colums. Dengan langkah ini kolom baru
yang masih kosong akan di tampilkan.

Menyembunyikan Field Tertentu


Untuk menyembunyikan field tertentu agar tidak tampil pada saat query
dijalankan, ikutilah langkah berikut :
a. Pilih dan pilih query yang anda ingin modifikasi rancangannya
kemudian klik tombol toolbar Design. Jendela kerja perancangan query
akan ditampilkan.
b. Klik atau hilangkan tanda pemilihan pada kotak cek Show yang ada
pada field tersebut.
31

3.3.4.Pembuatan Form
Form digunakan untuk merepresentasikan ke user atau menerima inputan dari user
data-data dalam tabel/query dalam bentuk interface grid, tombol, dan lain-lain kontrol
windows. form dalam office access bisa dimasukkan ke dalam form lain sebagai control
sub form, biasanya jika bekerja dalam transaksi master-detail. Form juga digunakan untuk
mempermudah memasukkan data pada tabel menampilkan, mencari, memperbaiki dan
mencetak data. Anda dapat membuat form dengan fasilitas create form in design view
(relatif lebih fleksibel) atau dengan create form by using wizard.

Membuat Form dengan Fasilitas Create in Design View

Untuk membuat sebuah form dengan fasilitas ini, maka ikutilah langkah berikut:
a. Pilih dan klik data table yang ingin di sajikan dalam bentuk Form. Klik Create pilih
Form.
b. Pada jendela kerja database dengan pilihan objects forms tersebut, klik dua kali
Create Form in Design View.

Gambar 3.17 Create Form in Design View

32

c. Bila ingin merancang form untuk pemasukan data pada suatu tabel anda harus
menentukan data Sourcenya lebih dulu. Untuk itu pada toolbar Object, pilih
dan klik Form. Kemudian pilih dan klik menu View, Properties atau klik
tombol toolbar Properties. Pada kotak dialog propertis tersebut, klik tab
Data, kemudian pada tombol daftar pilihan record Source, pilih dan klik tabel
yang anda inginkan.
d. Selanjutnya pada jendela perancangan form (form design) tersebut, lakukan
perancangan form dengan memanfaatkan field list dan toolbox yang ada.

Menutup dan Menyimpan Form


Untuk menutup dan menyimpan form yang telah anda buat, ikuti langkah berikut:
a. Pada jendela kerja form yang sedang aktif pilih dan klik File, Close atau klik
tombol Close (X). Apabila belum menyimpan form itu sebelumnya, kotak
dialog yang mengkonfirmasi pentimpanan akan ditampilkan.
b. Untuk mentimpan form yang telah dibuat, klik tombol perintah Yes. Kotak
dialog Save As akan ditampilkan.
c. Pada kotak dialog tersebut, ketikkan nama form yang anda inginkan.
Kemudian klik OK.

3.3.5.Pembuatan Report
Banyak cara yang digunakan untuk membuat sebuah report (laporan).
Diantaranya dengan menggunakan fasilitas create report by using wizard atau ditata
secara manual dengan fasilitas design view.
33

Membuat report dengan Fasilitas Create Report Design View


Untuk sebuah report dengan fasilitas ini ikutilah langkah berikut:
a. Klik Reports yang ada dibawah Objects atau pilih dan klik menu View,
Database Objects Reports
b. Create Report in Design View. Jendela perancangan report (design view).

Gambar 3.18 Create Form in Design View

c. Sebelum merancang report harus ditentukan dahulu data source. Untuk itu
pada toolbar Object, pilih dan klik Report. Kemudian pilih dan klik menu
View, Properties atau klik tombol toolbar Properties. Pada kotak dialog
report tersebut, klik tab Data, kemudian pada tombol daftar pilihan record
source, pilih dan klik tabel yang anda inginkan.
d. Pada jendela rancangan report (design view) tersebut, lakukan perancangan
report dengan memanfaatkan field list (daftar field) dan toolbox kotak piranti
yang ada titik.

Menutup dan Menyimpan Report


Untuk menyimpan report yang telah dibuat, ikuti langkah berikut:
a. Pilih dan klik File, Close atau klik tombol Close (X). kotak dialog yang
mengkonfirmasi akan ditampilkan.
b. Untuk menyimpan report yang telah dibuat, klik tombol perintah Yes. Kotak
dialog Save As akan ditampilkan.
c. Pada kotak dialog tersebut, ketikkan nama report yang anda inginkan
kemudian klik OK.

34

BAB IV
HASIL DAN PEMBAHASAN
Dalam praktikum sistem basis data, topik atau permasalahan yang dibahas adalah
tentang pembuatan basis data untuk informasi data Mahasiswa Institut Teknologi Nasional
Malang. Berikut ini adalah hasil pembuatan basis data tentang informasi data fasilitas
35

umum yang disusun dengan menggunakan cara pembuatan tabel, relationships, query, form
dan report.
Tabel-tabel yang dibuat, meliputi 12 tabel.
Tabel terdiri dari :
Kabupaten
Kecamatan
Pasar
Jalan
Hotel
Plaza
Terminal
Rumah Sakit
Bandara
Restoran
Obyek Wisata
Universitas

Tabel

Kabupaten

terdiri

dari

beberapa

atribut

antara

lain

ID_Kabupaten,Nama Kabupaten, Nama Buapti,Jumlah Kecamatan,Luas


Kabupaten.
Atribut yang menjadi primary key adalah ID_Kabupaten.

Gambar 4.1. Tabel Kabupaten

Tabel Kecamatan terdiri dari beberapa atribut antara lain : ID_Kecamatan,Nama


Kecamatan, Jumlah Desa, Luas Kecamatan, Nama Camat, ID_Kabupaten.
Atribut yang menjadi primary key adalah ID_Kecamatan.

36

Gambar 4.2. Tabel Kecamatan

Tabel Pasar terdiri dari beberapa atribut antara lain : ID_Pasar,Nama


Pasar,Nama Kepala Pasar,Jumlah Pengunjung,Luas Pasar,ID_Kecamatan.
Atribut yang menjadi primary key adalah ID_Pasar.

Gambar 4.3. Tabel Pasar

Tabel Jalan terdiri dari beberapa atribut antara lain : ID_Jalan,Nama Jalan,Lebar
Jalan,Jenis Jalan,ID_Kabupaten.
Atribut yang menjadi primary key adalah ID_Jalan.

37

Gambar 4.4. Tabel Jalan

Tabel Hotel terdiri dari beberapa atribut antara lain : ID_Hotel,Nama


Hotel,Jenis Hotel,Alamat,Harga sewa,No.Telpon,dan ID_Kabupaten. Atribut
yang menjadi primar key adalah ID_Hotel.

Gambar 4.5. Tabel Hotel

Tabel Plaza terdiri dari beberapa atribut antara lain : ID_Plaza,Nama


PlazaAlamat,Waktu Operasi, Jumlah Pengunjung,ID_Kabupaten.. Atribut yang
menjadi primar key adalah ID_Plaza.

Gambar 4.6 Tabel Plaza

Tabel Terminal terdiri dari beberapa atribut antara lain : ID_terminal,Nama


Terminal, Alamat, Rute, Jumlah Penumpang, Armada, ID_Kecamatan.Atribut
yang menjadi primar key adalah ID_Terminal.

38

Gambar 4.7 Tabel Terminal

Tabel Rumah Sakit terdiri dari beberapa atribut antara lain : ID_Rumah
Sakit,Nama Rumah Sakit, Alamat, Nama Kepala Rumah Sakit, Jumlah
pegawai, ID_Kabupaten. Atribut yang menjadi primar key adalah ID_Rumah
Sakit.

Gambar 4.8 Tabel Rumah Sakit

Tabel Bandara terdiri dari beberapa atribut antara lain : ID_Bandara,Nama


Bandara, Jumlah Maskapai,Nama Maskapai, Jumlah Penumpang, Rute,
ID_Kabupaten. Atribut yang menjadi primar key adalah ID_Bandara.

39

Gambar 4.9 Tabel Bandara

Tabel Restoran terdiri dari beberapa atribut antara lain : ID_Restoran, Nama
Restoran, Alamat, Jenis Restoran, Daftar Makanan, ID_Kabupaten. Atribut
yang menjadi primar key adalah ID_ Restoran.

Gambar 4.10 Tabel Restoran

Tabel Obyek Wisata terdiri dari beberapa atribut antara lain : ID_Obyek Wisata,
Nama Obyek Wisata, Lokasi, Wahana, Harga Tiket, ID_Kabupaten. Atribut
yang menjadi primar key adalah ID_ Obyek Wisata.

Gambar 4.11 Tabel Obyek Wisata

Tabel Universitas terdiri dari beberapa atribut antara lain : ID_Universitas,


Nama Universitas, Daftar jurusan, Jumlah mahasiswa, Jenis universitas,
Jumlah Kelas, ID_Kabupaten. Atribut yang menjadi primar key adalah ID_
Universitas.

40

Gambar 4.12 Tabel Universitas

Dari Keduabelas tabel yang telah dibuat tersebut, maka dapat disusun hubungan
antar tabel yaitu dengan membuat relationships, dengan hasil seperti yang ditunjukkan
pada Gambar IV.6. Relationships ini dapat dibuat dengan menghubungkan atribut-atribut
yang sama antara tabel yang satu dengan tabel yang lainnya.

Gambar 4.13. Hubungan Antar Tabel (Relationships)

Untuk menganalisa data-data yang telah dibuat pada tabel-tabel tersebut, maka
dapat dilakukan dengan membuat query dari data-data tabel.
Berikut ini adalah beberapa contoh query yang telah dibuat berkaitan dengan masalah
kemahasiswaan antara lain :

Query Bandara + Hotel + Jalan + Kabupaten

Query Kabupaten + Universitas + Hotel + Rumah Sakit + Hotel

Query Bandara +Hotel +Kabupaten

Query Kecamatan +Pasar +Plaza +Obyek Wisata

Query Bandara + Hotel + Jalan + Kabupaten terdiri dari beberapa atribut antara lain
: Nama Bandara,Nama Hotel,Nama Jalan,Nama Kabupaten.
41

Gambar 4.14. Query Bandara + Hotel + Jalan + Kabupaten

Query Kabupaten + Universitas + Hotel + Rumah Sakit + Hotel terdiri dari


beberapa atribut antara lain : Nama Kabupaten,Nama Universitas,Nama Rumah
Sakit,Nama Hotel.

Gambar 4.15. Query Kabupaten + Universitas + Hotel + Rumah Sakit + Hotel

Query Bandara +Hotel +Kabupaten terdiri dari beberapa atribut antara lain : Nama
Bandara,Nama Hotel,Nama Kabupaten.

42

Gambar 4.16. Query Bandara +Hotel +Kabupaten

Query Kecamatan +Pasar +Plaza +Obyek Wisata terdiri dari beberapa atribut antara
lain : Nama Kecamatan, Nama Pasar, Nama Plaza, Nama Obyek Wisata.

Gambar 4.17 Query Kecamatan +Pasar +Plaza +Obyek Wisata

BAB V
PENUTUP

5.1. Kesimpulan
Berdasarkan dari materi-materi yang telah dibahas pada praktikum sistem basis
data ini, maka dapat ditarik kesimpulan sebagai berikut :
43

Untuk menjalankan fungsi pengelolahan setiap informasi, semua data pada suatu
aspek tertentu dapat diatur/diorganisir untuk dibuat basis datanya dengan
memanfaatkan perangkat komputer dan program, aplikasinya seperti Microsoft
Office Access 2007.
Sistem data merupakan suatu sistem berbasis komputer dimana suatu proses dan
penyimpananya dilakukan dalam bentuk digital dan harus memenuhi persyaratan
logika komputer.
Data base (basis data) merupakan kumpulan data yang berhubungan dengan suatu
objek/topik atau tujuan tertentu.

Prinsip utama pengaturan data/arsip dengan sistem komputerisasi dapat


memberikan nilai lebih dalam proses pencarian informasi sehingga dapat
diperoleh kemudahan, kecepatan operasional, dan efisiensi dalam suatu
organisasi/perusahaan.

Perangkat lunak yang digunakan dalam pengolahan data untuk pembuatan basis
data adalah Microsoft Office Access 2007 yang menyediakan banyak cara
peragaan informasi yang dibuat dengan tabel, query, form, dan report.
Bidang-bidang atau aspek-aspek yang memanfaatkan sistem basis data ini sangat
beragam, salah satunya yang dibahas dalam laporan ini adalah mengenai
pengolahan data fasilitas umum kota malang. Untuk keperluan ini dibuat
beberapa tabel yang sesuai sebagai dasar penyusunan data-data, antara lain :
Kabupaten
Kecamatan
Pasar
Jalan
Hotel
Plaza
Terminal
Rumah Sakit
Bandara
Restoran
Obyek Wisata
Universitas

Dari tabel-tabel tersebut dapat dihubungkan dengan menggunakan suatu format


relationships hingga dapat membentuk beberapa buah query. Dan untuk menyajikan
data-data yang telah tersusun sebagai suatu basis data, maka dapat dilakukan
dengan membuat form dan report.
44

5.2. Saran - Saran

Untuk dapat membuat suatu sistem basis data diperlukan pemahaman materi dan
cara pengoperasian program aplikasi Microsoft Office Access 2007.

Hendaknya antara pengajar dengan praktikan terjalin kerja sama yang baik
sehingga praktikum dapat berjalan dengan lancar.

DAFTAR PUSTAKA
1. Penerbit PT Elex Media Komputindo. 36 jam belajar Komputer Microsoft Acces
2007. Jakarta.
2.

Diktat Praktikum Sistem Basis Data, ITN Malang

3.

Buku Catatan Kuliah Sistem Basis Data


45

46