Anda di halaman 1dari 2

.

Remote Ubuntu server kita Dengan PuTTY dari PC admin


Jika belum punya silahkan downloada di sini Aplikasi Untuk Mikrotik & Proxy
3. Login ke root cek Ping ke public utuk internetnya jika sudah jalan mari kita
lanjutkan,..
4. Update & upgrade repositor Ubuntu
Copas kode dibawah ini dan pastekan di terminal PuTTY ( klik kanan lalu Enter )
apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y && apt-get insta
ll squid -y && apt-get install squid squidclient squid-cgi -y && apt-get install
gcc -y && apt-get install build-essential -y && apt-get install sharutils -y &&
apt-get install ccze -y && apt-get install libzip-dev -y && apt-get install aut
omake1.9 -y && wget http://proxy-ku.googlecode.com/files/LUSCA_FMI.tar.gz && tar
xzvf LUSCA_FMI.tar.gz && cd LUSCA_FMI/ && make distclean
Tunggu sampai selesai, lama waktu update tergantung koneksi internet kita!!
5. Lakukan perintah compile Untuk Lusca FMI
Copas Kodennya:
./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/s
bin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spo
ol/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --wi
th-aufs-threads=24 --with-pthreads --enable-storeio=aufs --enable-linux-netfilte
r --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --wi
th-dl --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests -disable-unlinkd --enable-large-cache-files --with-large-files --enable-err-langu
ages=English --enable-default-err-language=English --with-maxfd=65536 && make &&
make install
6. Setelah proses selesai lanjutkan pada proses berikut
Copy file-file berikut dengan Program WinSCP
============================================
- File "squid.conf" yang telah disesuaikan ke folder: /etc/squid/
- File "storeurl.pl" ke folder: /etc/squid/
- File "squid" ke folder: /etc/init.d/
Jika belum punya squid.conf dll nya silahkan download disini Perlengkapan Squid
Proxy Lusca FMI. (edit dan sesuaikan )
Setelah seleseai di copy mari kita lanjutkan langkah berikutnya :
============================================
7. Memberikan izin akses kepada user squid
Copas Kodennya:
chmod +x /etc/init.d/squid && /etc/init.d/squid stop
8. Memberikan permission pada folder cache
Copas Kodennya:
chown proxy:proxy /cache && chmod 777 /cache chown proxy:proxy /etc/squid/storeu
rl.pl && chmod 777 /etc/squid/storeurl.pl && chmod +x /etc/init.d/squid
9. Membuat folder swap/cache di dalam folder cache
============================================
/etc/init.d/squid stop
squid -f /etc/squid/squid.conf -z && /etc/init.d/squid restart
10. Agar proses shutdown dapat langsung dijalankan dengan menekan tombol Power g
unakan perintah berikut:
Copas Kodennya:
apt-get install acpid
------- reboot ------11. Setting Redirect Proxy Ubuntu Eksternal di mikrotik.
buka di winbox kemudian pastekan di terminal mikrotik script di bawah :
/ip firewall address-list add address=192.168.2.0/24 comment="SQUID PROXY EXTERN
AL" disabled=no list="ProxyNet"
/ip firewall nat add action=dst-nat \
chain=dstnat comment="TRANSPARENT DNS UDP LOCAL" \
disabled=no dst-port=53 in-interface=local \

protocol=udp to-ports=53
/ip firewall nat add action=dst-nat \
chain=dstnat disabled=no dst-port=53 in-interface=proxy \
protocol=udp to-ports=53 comment="TRANSPARENT DNS UDP PROXY"
/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.2.2 to-ports=3128 \
protocol=tcp src-address=192.168.11.0/24 src-address-list=!ProxyNet \