Anda di halaman 1dari 6

PERTEMUA V

ALGORITHM

I. TUJUA
1. Mahasiswa mengenal tampilan tool algorithm pada Ermapper
2. Mahasiswa mampu menampilkan citra menggunakan berbagai macam color mode
3. Mahasiswa mampu membuat tampilan multispektral
4. Mahasiswa mengenal fasilitas template processing pada Ermapper

II. ALAT DA BAHA


1. Seperangkat komputer yang terinstal software Ermapper
2. Citra satelit
3. Alat tulis

III. PELAKSAAA
3.1. Mengenal algorithm
Algorithm merupakan salah satu keutamaan dari ERMapper dalam menyimpan prosesproses yang telah kita lakukan dalam pengolahan citra dan dapat menjadi template bagi data yang
lain untuk proses yang sama.
Untuk memulai dapat dengan memilih tombol VIEW > Algorithm atau menekan tombol
dan akan menampilkan kotak dialog algorithm seperti berikut:

untuk mengetahui masing-masing fungsi dari tools yang ada pada algorithm, dapat dengan cara

mengarahkan kursor pada tombol yang dimaksud dan akan muncul nama dari tools tersebut, seperti
pada gambar diatas.
Pada tab pages terdapat pilihan antara surface, layer dan coordinate system. Untuk surface terdapat
dua pilihan yaitu, color mode dan color table. Color mode dalam ERMapper ada 3 yaitu :
pseudocolor, RGB (Red Green Blue) dan HSI (Hue-Saturation-Intensity). Gambar dibawah ini
menunjukkan pilhan color table pada color mode pseudocolor.

Color table hanya aktif pada pilihan color mode pseudocolor. Terdapat banyak pilihan warna semu
pada color table seperti ampphase, azimuth, blue, dan sebagainya.
Terdapat juga 10 pilihan raster layer yang terdapat dalam ERMapper yang dimunculkan
dengan cara klik kanan pada layer. 10 raster layer tersebut seperti pada gambar dibawah ini.

Intensity layer dapat aktif pada color mode Pseudocolor, RGB dan HSI. Intensity layer dapat
digunakan untuk image fusion dengan resolusi yang lebih tinggi. Class Display digunakan untuk
klassifikasi, sedangkan Classification untuk thematic layer. View mode 3D dapat aktif bila salah
satu layernya adalah layer intensity atau height DEM.

3.2. Menampilkan citra


Ada beberapa cara yang dapat dipakai untuk melihat tampilan citra, yaitu pseudocolor,

RGB (Red Green Blue) dan HSI (Hue-Saturation-Intensity), yang terdapat dalam color mode.
Terdapat 2 cara membuka citra yaitu:
1. Dari menu utama, pilih File > Open atau klik ikon
a. Kemudian akan muncul suatu jendela citra kosong ditampilkan pada sudut kiri atas, pada
bagian atas jendela terdapat tulisan Algorithm not yet saved *.

b. Seperti pada gambar di atas, kita dapat membuka file algorithm dengan memilih file yang
berekstensi

*.alg.

Misalnya

buka

algorithm

filenya

di

//ERMapper/examples/Data_Types/Landsat_TM/RGB_542.alg. Kemudian pada jendela


citra akan terdapat tulisan ***RGB_542.alg***
c. Untuk membuka image/ Dataset pilihlah file yang berekstensi *.ers, seperti buka dataset
file-nya

di

//ERMapper/examples/Shared_data/Landsat_TM_years_1985.ers.

Kemudian pada jendela citra tetpa akan muncul tulisan ***Algorithm not yet saved***. Hal
ini berarti bahwa dataset-nya belum disimpan sebagai Algorithm.
2. Dari menu utama pilih File > ew, akan tampil jendela citra kosong dengan tulisan ***Algorithm
not yet saved***. kemudian dari menu View > Algorithm kemudian akan muncul kotak dialog
algoritm. Dari kotak dialog tersebut, klik Load Dataset

, bukalah data raster

Landsat_TM_years_1985.ers tadi.
Lakukan cara menampilkan citra yang telah dijelaskan sebelumnya menggunakan data citra
yang lain terdapat pada //ERMapper/examples.

3.3. Membuat Tampilan Multispektral


Dalam membuat tampilan multi spectral perlu diperhatikan karakteristik spectral dari sensor
satelit yang digunakan. Sebagai contoh, karakteristik spectral dari sensor citra Landsat akan berbeda

dengan citra SPOT. Hal ini telah dijelaskan dengan rinci pada materi perkuliahan.
Tahapan-tahapan dalam membuat tampilan multispectral adalah sebagai berikut: (dalam hal
ini yang digunakan adalah citra Landsat TM)
1. Tampilkan citra Landsat_TM_years_1985.ers dengan cara yang telah dilakukan pada point
3.2. Dan tampilan seperti dibawah ini dengan kombinasi RGB band 321.

2. Kemudian buka kotak dialog algorithm nya dari menu View > algorithm atau dengan klik pada
ikon
3. Kemudian akan muncul jendela algorithm dengan color mode RGB dimana Red layer adalah
band 3, Green layer adalah band 2 dan Blue layer adalah band 1. Dalam penginderaan jauh,
kombinasi band ini disebut dengan kombinasi 321 atau natural color (seperti contoh dibawah
ini). Dimana vegetasi berwarna hijau, tanah berwarna coklat dan laut berwarna biru kehitaman.

4. Untuk merubah tampilan warna dari citra tersebut, kita dapat merubah kombinasi band yang kita
inginkan pada RGB layer-nya.
5. Lakukan kombinasi band dimana Red layer adalah band 4, Green layer adalah band 3 dan Blue
layer adalah band 2. Warna apa yang saudara dapatkan?
6. Lakukan hal yang sama pada point 5, dimana Red layer adalah band 5, Green layer adalah band

4 dan Blue layer adalah band 3. Warna apa yang saudara dapatkan?
7. Sebagai informasi, band 4 pada Landsat TM merupakan band NIR (near infra red) yang peka
terhadap reflektansi dari vegetasi. Sedang pada citra SPOT, pendeteksi band NIR terdapat pada
band 3. Sehingga, kombinasi 321 pada SPOT merupakan standard false color bagi citra tersebut,
dimana vegetasi berwarna merah.
8. Lakukan informasi pada point 7 dengan membandingkan antara citra Landsat TM dan SPOT.
Silahkan pilih koleksi data citra yang terdapat pada //ERMapper/examples/Shared_data

3.4. Template Processing


Template processing merupakan salah satu keunggulan dari ERMapper dimana anda dapat
melakukan proses yang sama dengan file algorithm pada citra yang berbeda. Sebagai latihan kita
ingin membuat citra NDVI dari template yang ada. Citra NDVI (Normalized Difference Vegetation
Index) adalah sebuah transformasi citra penajaman spectral untuk menganalisa hal-hal yang
berkaitan dengan vegetasi.
Tahapan Template processing adalh sebagai berikut:
1. Buka menu ERMapper
2. Dari menu utama, pilih File > Open atau klik ikon
3. Kemudian

akan

muncul

jendela

Open.

Arahkan

directori

pada

ERMapper/examples/Data_Types/Landsat_TM kemudian pilih file Vegetation _DVI.alg


4.

Akan muncul jendela algorithm dan jendela tampilan citra Landsat TM yang telah dilakukan
transformasi citra NDVI. File citra yang ditransformasi adalah Landsat_TM_years_1985.ers.
Berikut gambar citra Landsat NDVI dan algorithm-nya

5. Kemudian untuk melakukan transformasi NDVI pada citra yang lain klik ikon Load Dataset

, (dengan catatan citra yang akan dilakukan transformasi adalah citra dengan sensor yang sama
yaitu Landsat TM).

6. Pilih

citra

Landsat

TM

dengan

lokasi

yang

berbeda,

ERMapper/examples/Shared_Data/Landsat_TM_20May91.ers.

yaitu

misal

Berikut

data

citra

gambar

citra

Landsat NDVI dan algorithm-nya.

7. Yang harus diperhatikan adalah dalam melakukan transformasi citra NDVI adalah band yang
digunakan pada Landsat TM adalah band 4 (NIR) dan band 3 (Red). Jadi harus diatur pada
proses Load Dataset-nya

8. Lakukan dan eksplorasi template processing ini pada data citra yang lain.