Anda di halaman 1dari 42

Spesifikasi:

Ukuran: 14x21 cm
Tebal: 340 hlm
Harga: Rp 74.800
Terbit pertama: Januari 2005
Sinopsis singkat:

Buku ini akan membahas penggunaan Linux Mandrake 10.0 secara praktis, namun tidak
melupakan konsep dasar Linux sendiri. Mandrake dikenal sebagai Linux yang banyak
digunakan pada workstation, karenanya pembahasan buku ini lebih menitikberatkan pada
penggunaan Linux Mandrake 10.0 sebagai sistem operasi workstation walaupun tidak
menutup kemungkinan untuk menggunakannya sebagai sistem operasi server. Pembahasan
dalam buku ini diawali dengan pengenalan dasar akan Linux, dilanjutkan dengan instalasi
dan konfigurasi Mandrake 10.0. Oleh karena buku ini menitikberatkan pembahasannya pada
penggunaan Linux Mandrake 10.0 untuk workstation, dibahas juga aplikasi-aplikasi yang
akan Anda gunakan sehari-hari. Anda akan kaget mengetahui koleksi software yang
disertakan Linux Mandrake 10.0 dalam distribusinya. Untuk Anda yang ingin mencoba
sesuatu yang berbeda, dibahas juga aplikasi Terminal dan pemrograman dasar di Linux.
Sebagai bonus, buku ini dilengkapi dengan lima keping CD Linux Mandrake 10.0 sehingga
Anda dapat langsung mempraktekkan seluruh isi buku ini. Selamat menjelah dunia Linux
Mandrake 10.0!
BAB 7

EDUTAINMENT DAN GAMES

Salah satu aplikasi yang akan Anda sukai dari Linux adalah
Edutainment dan Games. Bila Anda menginstal Mandrake 10.0
secara lengkap, Anda akan mendapati banyak sekali games
menarik di komputer Anda dengan tampilan grafis yang sangat
bagus. Bermain games tersebut merupakan pilihan yang cukup
menyenangkan ketika Anda merasa jenuh bekerja.
Edutainment juga menghibur seperti games, namun memiliki nilai
tambah dari segi pendidikan. Konsep education (pendidikan) dan
entertainment (hiburan) dipadukan secara apik di dalamnya. Apa
saja yang program aplikasi yang tersedia di menu ini? Mari kita
jelajahi.

7.1 Edutainment
Menu Edutainment di Mandrake 10.0 terbagi menjadi 3 kelompok
submenu, yaitu: Language, Science, dan Others. Selengkapnya
dapat dilihat di tabel berikut.
KHangMan Permainan tebak kata
Languages

Kiten Tool belajar bahasa Jepang (huruf kanji)


Tool belajar pronounciation alfabet bahasa
KLettres
asing (misalnya Inggris, Prancis, Belanda)

177
Permainan menyusun huruf membentuk
KMessedWords
kata
Tool belajar pembentukan kata kerja
KVerbos
bahasa Spanyol
Tool latihan perbendaharaan kata
KVocTrain
(vocabulary) bahasa asing
Simulasi sistem periodik unsur-unsur
Kalzium
kimia
Permainan berhitung operasi aritmetika
KBruch
pecahan
KDE
Tool menggambar grafik geometri secara
Science

Interactive
manual dan visual dengan cepat
Geometry
Tool menggambar grafik geometri dengan
KmPlot
input berupa persamaan matematika
KPercentage Permainan berhitung operasi pecahan
Simulasi virtual pengamatan astronomi
KStars
langit (planetarium)
FlashKard
Tools pendukung belajar (penerapan
KEduca-Editor metode Quantum Learning, dan
Others

sebagainya)
KEduca
KTouch Tool untuk latihan mengetik cepat

Kita hanya akan membahas beberapa program menarik di


antaranya. Selebihnya dapat Anda eksplorasi sendiri.

7.1.1 Kalzium
Kalzium adalah program aplikasi sistem periodik unsur-unsur
kimia yang sangat lengkap dan praktis. Kita bisa mencoba seluruh
menu yang ada di Toolbar untuk mengkonfigurasi Kalzium dan

178
menemukan lebih banyak lagi kelengkapannya, misalnya Kalzium
bisa menggambarkan sistem periodik unsur secara historis, mulai
dari zaman pertengahan ketika unsur masih sedikit dijumpai,
hingga zaman terkini ketka unsur dengan nomor atom 118 (Uun =
ununoktium) ditemukan.

Gambar 7.1 Susunan periodik unsur-unsur kimia di Kalzium

Kita bisa juga membuat versinya menjadi versi IUPAC atau


American. Selain itu, mouse-clicking pada satu kotak berlambang
unsur di atas akan menampilkan detail atribut unsur tersebut,
meliputi nomor atom, massa atom, titik didih, dan sebagainya.
Program ini sangat menyenangkan bagi mereka yang gemar
kimia/fisika.
Mengatur Konfigurasi Kalzium
1. Buka menu Setting.
2. Pilih Configure Kalzium.
3. Pada tab General Setting terdapat 2 fitur yang dapat dipilih:

179
9 Show detail info if click left on element: aktifkan fitur ini
maka bila kita mengklik ganda di salah satu elemen, akan
muncul jendela „Detail Info‰ yang memberikan deskripsi
rinci mengenai elemen tersebut, termasuk foto wujud zat
yang diambil dari laboratorium, konfigurasi elektron, data-
data kimia, energi, dan sebagainya, seperti tampak pada
Gambar 7.2 berikut ini.

Gambar 7.2 Tampilan informasi rinci unsur kimia di Detail Info Kalzium

9 Sebaliknya, fitur Show less info hanya menampilkan


informasi data secara umum saja.
4. Pada tab Colors, kita dapat melakukan pemilihan warna untuk
kelompok-kelompok unsur.
Menggunakan Fitur „Quiz: Test Your Knowledge‰
„Quiz: Test Your Knowledge‰ merupakan fitur menarik yang ada di
Kalzium untuk menguji sejauh mana wawasan Anda dalam bidang
kimia murni dan kimia modern (fisika-kimia).
1. Buka menu Quiz.
2. Klik „Test Your Knowledge‰.

180
3. Muncul tampilan seperti Gambar 7.3 di bawah ini dengan isi
pertanyaan berbeda-beda.

Gambar 7.3 Menggunakan fitur „Quiz: Test Your Knowledge‰ di Kalzium

4. Jawab pertanyaan-pertanyaan yang ada. Default-nya, Quiz


terdiri atas 10 pertanyaan yang harus dijawab berturut-turut.
5. Periksa skor akhir di bagian akhir. Kalzium juga akan
memberitahukan jawaban apa yang benar serta pembahasan
mengenainya.
Menggunakan Fitur Menu Operations
1. Buka menu Operations.
2. Di dalamnya terdapat beberapa pilihan fitur task, yaitu
Calculate, Plot, dan Search Data.
3. Calculate merupakan fungsi untuk melakukan satu macam
perhitungan, yaitu menghitung massa molekul. Kita cukup
memasukkan rumus kimia molekul di bagian Formula, klik
Calculate, maka aplikasi ini akan memberikan hasilnya, seperti
tampak pada Gambar 7.4 di bawah ini. Klik Clear untuk
membersihkan layar dan memasukkan input baru.

181
Penulisan rumus kimia yang diinput haruslah sesuai dengan
standard umum. Misalnya untuk molekul air kita tuliskan H2S,
untuk asam sulfat gunakan tanda kurung (H2)S(O4) untuk
membedakan indeks S dengan indeks O. Bila kita
menuliskannya H2SO4 saja, program ini hanya membacanya
sebagai H2S4 karena ia tidak mengenali unsur SO.

Gambar 7.4 Menghitung massa molekul relatif (MR) zat di Kalzium

4. Plot merupakan fungsi untuk menampilkan grafik kuantitatif


sifat-sifat kimia atau fisika tertentu (tergantung pilihan kita)
berdasarkan kenaikan jumlah atom. Jendela Plot tampak
seperti tampilan Gambar 7.5.
5. „Search data‰ akan menampilkan tabel rinci untuk pencarian
informasi lebih jauh dari semua unsur kimia yang ada.
Informasi yang dicari mencakup nama ilmiah unsur, simbol,
berat, elektronegativitas, kepadatan, orbit atom (konfigurasi
elektron), nomor kelompok blok pada sistem periodik, derajat
keasaman (pH), nomor kelompok grup pad asistem periodik,
titik lebur, titik didih, radius (jari-jari) atom, tingkat oksidasi,
hingga energi ionisasi pertama maupun ke dua. Kita dapat
pula menentukan range nomor unsur yang akan dicari

182
informasinya tersebut. Klik Apply bila telah selesai memilih
tipe jenis informasi yang ingin ditampilkan. Tersedia pula fitur
Export Data untuk menyimpan tampilan informasi ke format
lain agar dapat diakses kapan saja.

Gambar 7.5 Tampilan grafik kuantitatif sifat kimia dan fisika unsur-unsur

Gambar 7.6 Mencari informasi sifat unsur di Search data

183
Menggunakan Fitur Menu View
1. Buka menu View.
2. Pilih kelengkapan apa saja yang ingin kita tambahkan ke
dalam tampilan sistem periodik Kalzium, misalnya:
9 Color Scheme: mengatur pewarnaan sistem periodik, dapat
dilakukan berdasarkan kelompok derajat keasaman (pH),
blok maupun grup pada sistem periodik, atau
pengelompokan warna berdasarkan wujud zat.
9 Numeration: memberi indeks pengelompokan grup dapat
dipilih berdasarkan ketentuan IUPAC (International Union
of Pure and Applied Chemistry), CAS (Chemical Abstracts
Service), Old IUPAC (IUPAC sistem lama), atau tidak
melakukan penomoran blok sama sekali (numeration non-
active).
9 Show Timeline: menampilkan slider bar untuk penunjuk
tahun. Bila kita menggeser slider tersebut, kita akan
melihat kemunculan unsur-unsur baru menurut tahun
penemuannya masing-masing. Fitur ini membantu kita
dengan informasi historis penemuan unsur-unsur.
9 Show Quick Info: menampilkan info cepat utuk elemen
pada sistem periodik.
9 Show Legend: menampilkan informasi warna di bagian
bawah (fungsinya sama dengan legenda pada peta).

7.1.2 KStars
Bila penggemar kimia/fisika akan menyukai Kalzium, para pecinta
astronomi akan jatuh cinta pada program ini. Dengan KStars, kita
bisa mensimulasikan keadaan dan perubahan benda-benda langit
mirip dengan aslinya (sangat mendekati kenyataannya). KStars
membuat Anda bisa menjelajahi langit malam sambil duduk
dengan nyaman di depan komputer Anda. Simulasi pemandangan
bintang di langit malam, konfigurasi posisi perbintangan, dan lain
sebagainya, didesain seakurat mungkin sesuai dengan perhitungan
modern yang sesungguhnya berdasarkan hasil penemuan dan

184
percobaan para astronom saat ini. Dengan kata lain, simulasi ini
bersifat virtual reality.
Untuk mengkonfigurasinya, banyak menu yang bisa diakses dan
dicoba-coba, seperti mengubah-ubah filter magnitudo bintang
yang akan ditampilkan, yaitu menentukan tingkat kecerahan
minimal bintang-bintang yang masih dapat ditampilkan atau
terlihat di layar „planetarium‰ kita. Di sini kita bisa menampilkan
lebih banyak bintang dengan melonggarkan filternya, begitu pula
sebaliknya.

Gambar 7.7 Menjelajahi alam semesta dengan KStars

Dengan menggeser daerah dimana saja pada layar KStars, kita


bisa mengemudikan arah pandang „teleskop‰ kita. Kita juga bisa
menentukan posisi kita sebagai pengamat di bumi: misalnya kita
ingin mengambil posisi di kutub utara dan mengamati langit tepat
dari sana, atau di kutub selatan, khatulistiwa, dan sebagainya.
Kita juga bisa menampilkan bintang-bintang maupun benda-benda
langit tersebut dengan dilengkapi nama ilmiah, nama gugus,
angka magnitudo (penunjuk tingkat kecerahan), dan garis-garis
khayal gugusan bintang dengan berbagai konfigurasi tampilan.

185
Total jumlah objek benda langit yang bisa Anda jelajahi sangat
banyak, seperti bisa Anda lihat keterangannya di dokumentasi
KStars (help:/kstars).
9 126.000 bintang, hingga mencakup bintang bermagnitudo +9
(lebih redup dibandingkan bintang yang bisa disaksikan oleh
mata telanjang).
9 13.000 deep-sky-objects, cluster, nebula, galaksi, dan
sebagainya yang umumnya berupa objek yang besar dan
berkelompok membentuk gugusan amat besar dan banyak,
serta jaraknya sangat jauh dari bumi (KStars juga memiliki
katalog untuk objek Messier, NGC, dan IC).
9 Tata surya: matahari, bulan, dan seluruh planet.
9 Ratusan komet.
9 Ratusan asteroid.
9 Galaksi Bimasakti atau Milky Way. Disebut demikian karena
penampakannya yang membentuk jalur putih seperti „Jalan
Susu‰ (dongeng menarik tentang ini ada di legenda Yunani
Kuno).
9 88 konstelasi (rasi bintang).
9 Disertai dengan petunjuk garis khayal konstelasi, garis
equator, ekliptika, dan sebagainya. Seperti kita ketahui, semua
konstelasi yang bisa dilihat dari bumi telah dibuatkan garis
khayalnya oleh para astronomer, garis-garis antar objek-objek
pada satu konstelasi dirancang agar menyerupai gambar
bentuk tertentu yang khas dan mudah dikenali. Pemberian
nama konstelasi pun disesuaikan dengan gambar yang
terbentuk masing-masing, umumnya diambil dari nama-nama
di legenda Yunani Kuno.
Mau tidak mau, Anda terpaksa percaya bahwa KStars merupakan
fitur entertainment yang sangat menarik dan sangat mendidik,
khususnya dalam bidang pelajaran astronomi dan fisika.
Untuk mempelajari fungsi-fungsi tersebut, Anda mungkin
memerlukan waktu cukup lama untuk mengeksplorasi karena
fitur-fitur yang tersedia banyak sekali dan sangat menarik.

186
Mengemudikan Arah Pandang Teleskop Virtual
1. Klik dan drag bagian desktop ke arah manapun yang Anda
inginkan, dalam arah 360°.
2. Tampilan di layar akan seolah-olah bergerak mengikuti
perubahan arah target teleskop virtual yang Anda arahkan.
Bintang-bintang akan tampak bergeser dan pemandangannya
akan berubah sesuai arah gerak.
3. Bila Anda terus mengarahkan teleskop ke bawah, Anda akan
menjumpai daerah berwarna hijau, berarti pandangan teleskop
Anda telah mencapai permukaan tanah/horison.

Gambar 7.8 Tampilan KStars dengan permukaan tanah/horison

4. Selain pergerakan manual, Anda juga dapat mengarahkan


teleskop ke arah mata angin tertentu secara otomatis dan lebih
akurat:
9 Buka menu Pointing.
9 Pilih Zenith, North, East, West, atau South.

187
5. Bila Anda ingin menge-zoom suatu objek benda langit untuk
melihatnya lebih jelas, buka menu View | Zoom. Dari menu
View, Anda juga dapat mengatur koordinat ekuatorial dan
horisontal.
Mencari Lokasi Objek Benda Langit Tertentu
Anda tidak menjumpai planet Mars di layar KStars Anda dan tidak
tahu ke mana harus menggerakkan teleskop Anda? Bagaimana
jika Anda juga ingin mencari lokasi konstelasi bintang Cassiopeia,
misalnya? KStars menyediakan cara yang sangat mudah.
1. Buka menu Pointing.
2. Pilih Find Object. Akan muncul tampilan jendela pada
Gambar 7.9.

Gambar 7.9 Mencari lokasi objek benda langit (Find Object)

188
3. Ketikkan nama benda langit yang Anda cari (dapat berupa
nama bintang, satelit, galaksi, asteroid, planetoid, komet,
nebula, cluster, konstelasi atau rasi bintang, dan sebagainya).
4. Sebagai cara lain, bila Anda lebih cenderung ingin mengetahui
daftar nama yang terdaftar dalam kategori bintang, satelit,
galaksi, komet, asteroid, konstelasi, dan sebagainya, Anda
dapat menggunakan combo-box „Filter by‰ yang juga dapat
mempersempit kategori pencarian.
5. Hasilnya, layar KStars Anda akan langsung mengarah ke
lokasi tempat objek yang Anda cari tadi berada. Sangat mudah
bukan?
Menyimpan Gambar Panorama Bintang
Anda mungkin ingin menyimpan gambar panorama bintang yang
sedang tampak di layar KStars Anda. Mungkin Anda ingin
memakainya untuk background desktop, dicetak, diambil untuk
ilustrasi tulisan, dan sebagainya. Anda mungkin langsung berpikir
untuk menggunakan KSnapshot. Itu merupakan pilihan yang
bagus juga. Selain itu KStars juga menyediakan sendiri fasilitas
untuk screenshot layar panorama bintang dan menyimpannya ke
file.
1. Buka menu File | Save Sky Image.
2. Setelah muncul tampilan dialog untuk menyimpan file, cari
folder untuk tempat menaruh file gambar tersebut, ketikkan
nama dan ekstensinya.
Memilih Lokasi Geografis Pengamat di Bumi
Di mana Anda sebagai pengamat ingin mengambil lokasi
pengamatan virtual Anda? Anda bisa berpura-pura berada di kutub
utara, menyaksikan pemandangan langit malam tegak lurus dari
sana. Anda bisa juga memilih daerah khatulistiwa, Indonesia, India,
Peru, Kanada, Greenland, Finlandia, dan sebagainya sebagai
lokasi Anda. Tentunya pemandangan langit dari masing-masing
tempat di bumi akan berbeda pula.
1. Buka menu Setting | Set Geographic Location. Cara lain, klik
tombol Set Geographic Location di toolbar.

189
2. Ada beberapa cara menentukan lokasi pengamat:
9 Mengklik langsung titik tertentu pada gambar peta dunia.
9 Mengetikkan nama lokasi yang Anda cari, bisa berupa
kota, propinsi atau negara. Bila yang Anda ketikkan
propinsi atau negara, pada jendela navigator lokasi di
bagian kanan akan muncul nama-nama kota yang berada
pada wilayah propinsi atau negara itu. Anda cukup
mengklik yang sesuai dengan yang Anda cari.
9 Bila Anda ingin memilih-milih dulu lokasinya dari pilihan
yang ada di jendela navigator di sebelah kanan, Anda
dapat mencari sendiri di antara 2565 buah kota yang
tersedia.
9 Pada bagian paling bawah, Anda dapat mengkonfigurasi
lokasi beserta koordinat, longitude, dan sebagainya.

Gambar 7.10 Memilih lokasi pengamat di bumi


(Set Geographic Locations)

190
Menetapkan Waktu Pengamatan
Selain dapat menentukan posisi Anda, Anda juga dapat
menentukan kapan Anda ingin melakukan pengamatan. KStars
memiliki program simulasi yang dapat meramalkan keadaan,
posisi, dan peta konfigurasi bintang yang sedang terjadi pada
setiap saat, yang tentunya selalu mengalami perubahan yang
dapat diramalkan.
Misalnya untuk mendapatkan tampilan konstelasi Andromeda di
layar KStars Anda, Anda harus mengetahui posisi pengamat dan
waktu pengamatan yang tepat agar konstelasi tersebut dapat
dilihat dari teleskop Anda. Tentu sulit untuk mengetahui hal-hal
sedetail itu, tapi Anda akan cukup puas dengan mencoba-coba
semua fitur di KStars ini.
Memilih waktu pengamatan:
1. Buka menu Time.
2. Pilih cara pengaturan waktu:
9 Set Time To Now: menetapkan tanggal dan jam yang
daitur pada komputer Anda sebagai waktu pengamatan.
9 Set Time: menentukan secara manual waktu pengamatan.
Akan muncul jendela untuk memasukan tanggal dan jam
pengamatan yang Anda inginkan.
9 Set Clock: semacam toggle untuk menunjukkan lama
waktu yang telah dilalui selama pengamatan.
Selain itu, melalui menu Tools | What‰s up tonight?, Anda dapat
melihat summary objek-objek benda langit yang tampak
berdasarkan lokasi dan waktu yang Anda inputkan.
Mengkonfigurasi dan Memfilter Tampilan Panorama Bintang
1. Buka menu Setting | Configure KStars.
2. Muncul jendela Configure KStars yang terdiri atas 5 tab.
Masing-masing tab menyediakan konfigurasi tertentu yang
dapat Anda atur. Bagusnya, konfigurasi KStars akan langsung
diterapkan oleh KStars tanpa Anda perlu mengklik tombol

191
Apply atau OK terlebih dahulu sehingga Anda dapat langsung
melihat perubahan yang terjadi sesuai yang Anda atur.
3. Pada tab Catalog, Anda dapat mengatur hal-hal berikut:
9 Isi combo-box „For stars brighter than:‰ dengan magnitudo
maksimal objek bintang-bintang yang dapat ditampilkan di
layar KStars. Magnitudo adalah bilangan real yang
menyatakan tingkat kecerahan suatu benda langit. Makin
kecil angka magnitudo, benda langit itu semakin cerah dan
cemerlang menurut penglihatan kita maupun pengamatan
lewat teleskop. Sebaliknya, makin besar angka magnitudo,
benda langit itu semakin redup dan samar-samar. Coba
Anda perbesar angka magnitudo pada combo-box tersebut
dan Anda akan melihat bintang-bintang baru yang lebih
redup bermunculan di layar KStars. Perbesar lagi angka
magnitudo maksimal itu dan layar KStars akan makin
ramai dipenuhi bintang-bintang dari yang sangat cerah
sampai yang sangat redup.

Gambar 7.11 Mengkonfigurasi KStars (pada tab Catalog)

192
9 Beri tanda silang pada „Show name‰ untuk menampilkan
nama pada hampir semua bintang yang sedang
ditampilkan di layar KStars (umumnya bintang-bintang
yang paling besar dan terkenal).
9 Anda juga dapat mengatur konfigurasi magnitudo pada
objek dengan kategori „Deep Sky Objects‰, yaitu objek
benda langit yang mencakup cluster, nebula, dan galaksi.
4. Pada tab Solar System, Anda dapat mengatur hal-hal berikut:
9 Memilih anggota tata surya yang akan ditampilkan di layar
KStars. Di sana tersedia pilihan: matahari, bulan, dan 8
planet (selain bumi tentunya karena ia adalah planet
tempat pengamat berada). Bila objek tertentu tidak diberi
tanda silang, objek itu tidak akan ditampilkan ke layar
KStars meskipun lokasinya tersorot oleh teleskop Anda.
Tampilkan label namanya bila Anda inginkan.

Gambar 7.12 Mengkonfigurasi KStars (pada tab Solar System)

9 Tentukan angka magnitudo pada „Show asteroids brighter


than‰ untuk memfilter kecerahan minimal asteroid yang

193
dapat ditampilkan dan dilengkapi informasi nama masing-
masingnya.
9 Anda juga dapat memberi nama pada komet yang berada
dalam rentang jarak maksimal yang bisa ditentukan
(dalam satuan AU, Astronomy Unit).
5. Pada tab Guides, Anda dapat mengatur hal-hal berikut:
9 Pilih gambar/informasi tambahan yang ingin Anda
tambahkan di layar KStars, misalnya garis khayal
penghubung konstelasi bintang, nama konstelasi, area
galaksi Milky Way atau Bimasakti (akan ditampilkan
dengan warna putih-susu), grid koordinat, equator
celestial, bidang ekliptika, garis horison, dan „Opaque
ground‰. Jika Anda memilih „Opaque ground‰, teleskop
virtual Anda akan menerobos tanah yang menghalangi
hingga mampu menampilkan pemandangan di balik
belahan bumi yang berlawanan dengan posisi pengamat.
Tentu saja ini hanya simulasi, karena pada kenyataannya
hal ini tidak akan mungkin dilakukan.

Gambar 7.13 Mengkonfigurasi KStars (pada tab Guides)

194
6. Pada tab Colors, Anda dapat mengatur hal-hal berikut:
9 Pilih warna-warna untuk tiap objek benda langit yang Anda
suka.
9 Tentukan mode dan intensitas warna bintang di combo-
box.
9 Simpan Color Schema Anda dengan mengklik Save
Current Colors.

Gambar 7.14 Mengkonfiguasi KStars (pada tab Colors)

7. Pada tab Advance, Anda dapat mengatur hal-hal berikut:


9 „Correct for atmospheric refraction‰, yaitu penyesuaian
pandangan yang tampak pada teleskop KStars dengan
pembiasan atmosfer (yang pasti selalu ada pada real
observation atau pengamatan sebenarnya).
9 Konfigurasi objek-objek benda langit yang tersembunyi,
serta konfigurasi-konfigurasi lainnya.

195
Gambar 7.15 Mengkonfigurasi KStars (pada tab Advance)

Menggunakan Toggle untuk Filter


1. Konfigurasi/filter tampilan juga dapat kita lakukan di Toolbar
Toggle. Toggle berfungsi memfilter (memunculkan atau
menyembunyikan) tampilan tertentu. Ada 8 toggle yang ada di
KStars:
Fungsi Toggle
No. Icon Toggle
Menampilkan/menyembunyikan

1 Stars Objek bintang

Deep Sky Objek cluster, nebula, galaksi,


2
Objects dan sebagainya.

Solar
3 Objek tata surya
System

Constellation Garis khayal penghubung


4
Lines konstelasi

196
Constellation
5 Informasi nama bintang
Names

6 Milky Way Galaksi Bimasakti

Coordinat
7 Grid koordinat
Grid

Toggle
8 Permukaan tanah (horison)
Ground

2. Tombol-tombol toggle ini fungsinya sama dengan filter objek,


gambar, atau informasi tertentu. Anda dapat mengaktifkan/
menonaktifkan tombol-tombol tersebut untuk konfigurasi yang
lebih cepat dibandingkan harus mengatur filter di Configure
KStars.
Mengatur Properties Teleskop
1. Buka menu Device.
2. Muncul wizard untuk konfigurasi properties Device.
3. Pilih model Telescope dan perhatikan tips yang diberikan.
4. Verify Local Setting (mencakup Set Time dan Set Location).
5. Tentukan port teleskop.
6. Ikuti petunjuk mengenai konfigurasi selanjutnya dari Wizard.
Memanfaatkan AstroCalculator (Kalkulator Astronomi)
1. Buka menu Tools | Calculator.
2. AstroCalculator terdiri atas 3 tab (tampak pada bagian kiri),
masing-masing tab terdiri atas modul-modul. Fungsi modul-
modul pada AstroCalculator umumnya adalah untuk
melakukan perhitungan-perhitungan ilmiah dan akurat yang
berhubungan dengan astronomi dan pengamatan astronomi.
Anda akan setuju bahwa fasilitas ini sangat ilmiah dan canggih
untuk ukuran software gratis!

197
Gambar 7.16 Menggunakan kalkulator astronomi (AstroCalculator)

9 Tab Coordinat Converters, modul-modulnya adalah:


• Apparent Coordinates: untuk mengkonversi koordinat
katalog dari suatu titik di langit ke koordinat yang
tampak pada pengamatan.
• Equatorial/Galactic Coordinates: untuk konversi
koordinat equatorial ke koordinat galactic.
• Horisontal Coordinates: untuk konversi koordinat
equatorial ke koordinat horisontal.
• Precession: fungsinya mirip modul Apparent
Coordinates, tapi hanya menyangkut perhitungan
presesi.
9 Tab Earth Coordinates, modul-modulnya adalah:
• Geodetic Coordinates: untuk konversi koordinat yang
dihitung berdasarkan variabel umum bentuk bumi
(bulat sempurna), ke koordinat berdasarkan bentuk
bumi sebenarnya (elipsoid)
9 Tab Time Calculators, modul-modulnya adalah:

198
• Day Duration: untuk menghitung panjang hari,
termasuk terbitnya matahari, tengah hari, hingga
matahari terbenam, berdasarkan tanggal dan lokasi
yang kita inputkan.
• Julian Day: untuk konversi tanggal kalender antara
Penanggalan Julian dengan Penanggalan Julian Baru
(yang telah dimodifikasi).
• Sidereal Time: untuk konversi antara waktu universal
dengan waktu sidereal lokal.
Memanfaatkan Script Builder
1. Buka menu Tools | Script Builder.

Gambar 7.17 Memanfaatkan Script Builder di KStars

2. Script Builder mendukung tampilan interface GUI untuk scripts


DCOP yang dapat digunakan untuk mengatur lokasi peletakan
gambar, lokasi geografi pengamat, tanggal dan jam
pengamatan, level zoom, dan fungsi-fungsi lainnya, mirip
seperti aksi serupa yang dijalankan melalui command line.

199
Mempelajari Tata Surya
1. Buka menu Tools | Solar System.

Gambar 7.18 Tampilan Solar System (tata surya)

2. Matahari digambarkan sebagai titik kuning di pusat orbit-orbit.


Sementara jari-jari setiap orbit digambar dengan perbandingan
yang akurat terhadap perbandingan jarak sebenarnya (ke
matahari). Oleh karena itu Anda hanya akan melihat
setidaknya 5 planet terluar dari sistem tata surya (Jupiter,
Saturnus, Uranus, Neptunus, Pluto), karena jarak planet-planet
Merkurius, Venus, Bumi, dan Mars terlalu kecil dibandingkan
jarak kelima planet tersebut ke matahari.
3. Lakukan zoom-in dengan menekan tombol + (plus) dari
keyboard, atau zoom-out dengan tombol - (minus) dari
keyboard.
Mempelajari Satelit-satelit Jupiter
1. Buka menu Tools | ‰Jupiter‰s Moons‰.
2. Fitur ini menampilkan posisi dari 4 satelit terbesar Jupiter (Io,
Europe, Ganymede, dan Callisto) relatif terhadap Jupiter dan
sebagai fungsi waktu. Sumbu vertikal adalah fungsi waktu

200
(dalam satuan hari, hari 0.00 merupakan current waktu pada
komputer Anda). Sumbu horisontal menyatakan sudut angular
masing-masing satelit dari posisi Jupiter (dalam satuan derajat
menit). Sudut dihitung dari arah equator Jupiter.

Gambar 7.19 Mempelajari satelit-satelit Jupiter

3. Diagram tersebut dapat dimanipulasi dari keyboard:


9 Tekan + atau - untuk melebarkan atau menyusutkan
sumbu waktu.
9 Tekan [ atau ] untuk memilih waktu.

7.1.3 KDE Interactive Geometry


KDE Interactive Geometry merupakan aplikasi untuk menggambar
grafik matematika pada koordinat Cartesian secara manual/visual.

201
Disebut secara visual karena prosesnya tidak menggunakan
perhitungan persamaan matematika itu sendiri. Kita hanya perlu
mengklik salah satu tombol gambar di toolbar untuk menggambar
bentuk objek grafik yang kita inginkan.

Gambar 7.20 Menggambar kurva dengan KDE Interactive Geometry

Menggambar Objek Grafik ke Koordinat Cartesian


9 Pilih objek grafik yang diinginkan dari toolbar objek (sebelah
kiri).
9 Buka menu Objects dan pilih objek grafik dari opsi yang
tersedia: Lines (garis), Points (titik), Circles (lingkaran), Conics
(kerucut), Cubics (kubistis), Angles (sudut), atau Others
(bentuk lainnya).
Mentransformasikan Objek Grafik
9 Pilih jenis transformasi (pengubahan) yang diinginkan dari
toolbar transformasi (sebelah kanan).
9 Buka menu Transformations, lalu pilih jenis tranformasi dari
opsi yang tersedia: Translate (pergeseran), Reflect over point
(pencerminan terhadap titik tertentu), Mirror (pencerminan),
Rotate (rotasi atau pemutaran dengan sudut tertentu), Scale

202
(perbesaran positif ataupun negatif), Scale over Line
(perbesaran terhadap garis tertentu), Draw Projective Shadow
(pembentukan bayangan proyektif).
Mengatur Setting Koordinat Cartesian
1. Klik menu Setting.
2. Pilih sistem yang akan dipakai untuk koordinat Cartesian:
Euclidan (sistem skala x-y), atau Polar (sistem derajat sudut).

7.1.4 KmPlot
Berbeda dengan KDE Interactive Geometry, di KmPlot kita harus
memasukkan persamaan matematika untuk menggambarkan
grafik kurva dari persamaan tersebut.

Gambar 7.21 Menggambar kurva persamaan dengan KmPlot

Memasukkan Persamaan dan Membuat Grafik Kurvanya


1. Klik menu Functions.

203
2. Pilih submenu Functions.
3. Masukkan persamaan „f(x) = ... „ (isikan persamaan yang
diinginkan).
4. Setelah persamaan selesai dibuat:
9 Klik OK untuk memasukkan persamaan tersebut ke list
dan langsung menggambarkan grafik persamaan tersebut.
9 Klik Apply untuk memasukkan saja persamaan tersebut ke
dalam list persamaan.
9 Klik Edit untuk mengedit persamaan yang sudah
dimasukan ke list.
9 Klik Attributes untuk mengatur skala koordinat terhadap
besar konstanta pencarian.
5. Hasil penggambaran grafik kurva akan tampak di layar
koordinat.
Memilih Mode Tampilan Koordinat Cartesian
1. Buka menu View.
2. Pilih mode tampilan yang ada untuk koordinat Cartesian:
Sistem +, Sistem T, atau Sistem L. Untuk lebih jelasnya Anda
dapat melihat hasil pilihan mode tersebut yang tampak di layar
koordinat KmPlot.

7.1.5 KEduca
KEduca merupakan tools pembantu belajar yang cukup kompleks,
mirip database. Pertama kali menggunakan KEduca, kita harus
membuat file database KEduca terlebih dahulu, yaitu database
berisi paket-paket materi atau pertanyaan penting menyangkut
pelajaran. Setelah itu kita dapat menggunakannya misalnya untuk
ujian self-training, dan sebagainya.

7.1.6 FlashKard
Masing-masing orang belajar dengan menerapkan metode
Quantum Learning yang cocok untuk dirinya, misalnya dengan

204
cara membuat kartu-kartu berisi point-point penting yang harus
diingat, berupa pertanyaan di satu sisi kartu dan jawaban dari
pertanyaan tersebut dituliskan di sisi sebaliknya. Cara ini dapat
membantu mengingat materi pelajaran, khususnya rumus-rumus
atau yang bersifat hafalan atau tanya jawab singkat.

Gambar 7.22 Belajar dengan FlashKard

Membuat Question Cards


1. Klik kotak teks di bagian kiri bawah (berlabel Front), isi
dengan soal.
2. Klik kotak teks di bagian kanan bawah (berlabel Back), isi
dengan jawaban dari soal tadi.
3. Klik Add Card untuk menambahkan kartu soal tadi ke list.
4. Kotak teks bagian atas adalah list Question Cards yang telah
dibuat.
5. Buat beberapa Question Cards lagi. Kita juga bisa menghapus
kartu tertentu dengan mengkliknya dan menekan tombol
Delete Card. Setelah itu kartu-kartu siap digunakan untuk
Quiz.
Menggunakan Kartu Belajar dengan Fitur Quiz
1. Buka menu Function.
2. Pilih Quiz.
3. Question Cards yang telah kita buat tadi akan disodorkan
dalam bentuk soal yang harus kita jawab. Jawabannya dapat

205
dikatakan tersembunyi di balik masing-masing kartu tersebut
secara virtual.
Mengkonfigurasi FlashKard
1. Buka menu Setting.
2. Pilih Quiz Mode, yaitu urutan pengambilan Question Cards:
random atau terurut.
3. Tentukan rentang waktu FlashKard menampilkan jawaban
benar dari setiap Question Cards: Show Answers For (pilih 1
sampai 5 detik).
KEduca dan FlashKard dibuat untuk membantu kegiatan belajar
dengan cara seperti Flash Card biasa. Bedanya, kartu-kartu belajar
itu tidak lagi bersifat manual, melainkan elektronik
(terkomputerisasi).

7.1.7 KPercentage
KPercentage merupakan program latihan untuk perkalian persen
dengan bilangan bulat. Permainan ini mungkin akan cepat
membosankan karena kurang menarik dan terlalu mudah bagi
anak-anak sekolahan.

Gambar 7.23 Operasi aritmetika persentase dengan KPercentage

206
7.1.8 KBruch
Permainan KBruch juga hampir sama jenisnya dengan
KPercentage, hanya saja yang diproses di sini adalah bilangan
berbentuk pecahan.

Gambar 7.24 Operasi aritmetika pecahan dengan KBruch

7.1.9 KHangMan

Gambar 7.25 Bermain tebak kata dengan KHangMan

Bila Anda ingin permainan yang cocok untuk refreshing, tidak


cepat membosankan, dan mengasah untuk berpikir namun tidak

207
memaksa Anda memutar otak terlalu keras, Anda dapat memilih
KHangMan, yaitu menebak kata dengan huruf-huruf yang ada. Kita
hanya memiliki kesempatan beberapa kali untuk tebakan salah.
Bila tidak berhasil menebak kata yang dimaksud hingga
kesempatan terakhir, sesuai nama permainan ini, hukuman
gantung akan dijatuhkan.

7.1.10 KLettres
Gunakan speaker atau headset Anda di sini, karena KLettres
adalah permainan mengeja huruf dengan berbagai macam bahasa.
Anda akan mendengar suara pengarah yang mengejakan huruf
tersebut, lalu Anda harus mengetikkan kata yang dimaksud
dengan tepat di kotak pada tampilan Gambar 7.26 di atas.
Pilihan bahas yang tersedia adalah bahasa Ceko (Czech), Slovakia
(Slovak), Denmark (Danish), Prancis (French), dan Belanda
(Dutch).

Gambar 7.26 Tampilan KLettres

208
Sayangnya program ini baru dapat mengejakan huruf demi huruf.
Akan lebih bagus lagi bila kita dapat mempelajari cara
pengucapan kata dan kalimat dengan intonasi, dan sebagainya.
Juga akan lebih bagus bila bahasa yang tersedia lebih lengkap
lagi, seperti bahasa Jerman, Italia, dan sebagainya.

7.1.11 KMessedWords

Gambar 7.27 Bermain susun-huruf dengan KmessedWords

Gambar 7.28 Menambah vocabularies KMessedWords

209
Pada permainan ini, kita harus menyusun huruf-huruf acak yang
ditampilkan di layar KMessedWords untuk membentuk sebuah
kata. KMessedWords juga memiliki kamus yang bisa kita tambah
dengan perbendaharaan kata baru seperti tampak pada Gambar
7.28 berikut ini. Caranya langsung ketikkan kata yang ingin Anda
tambahkan pada kotak vocabularies di bawah baris paling akhir,
lalu simpan dengan Save Words.

7.1.12 KTouch
KTouch adalah program latihan mengetik cepat (10 jari) yang
cukup sederhana. Kita cukup mengetikkan kata-kata yang
terdapat di display KTouch. KTouch akan menghitung statistik
kecepatan, kesalahan, dan sebagainya dari proses latihan
mengetik tersebut. Program ini masih sangat sederhana dan
kombinasi kata-katanya tidak terlalu banyak.

Gambar 7.29 Berlatih mengetik cepat dengan KTouch

7.2 Games
Selain aplikasi Edutainment, Linux tentu juga dilengkapi dengan
berbagai games menarik. Anda dapat menjalankannya dari KMenu
| More Applications | Games. Bila Anda menginstal games dengan

210
lengkap, Anda akan menjumpai program-program permainan ini
dalam jumlah yang sangat banyak, terbagi atas 8 submenu:
No. Submenu Games Games yang Ada di Menu Ini:1

1 Arcade ArmageTron
Chromium
ClanBomber
CrackAttack
Cxhetris (dimodifikasi dari tetris)
Frozen-Bubble, Gnibbles (mirip RattleRace)
GNOME Robots, GNOME Stones
Gnometris (permainan Tetris)
KAsteroid
KBounce (permainan JezzBall)
KFoulEggs (mirip permainan Tetris)
KGoldrunner (permainan mencuri emas)
Klickety (modifikasi dari Tetris)
Kolf (sejenis golf)
KSirtet (dibaca dari belakang = „tetris‰)
KSmileTris (Tetris dengan modifikasi)
KSnakeRace (mirip RattleRace)
KSpaceDuel (pertempuran pesawat antariksa)
KTron (mirip RattleRace)
LBreakout2 (menjatuhkan barisan kotak-kotak
dengan pantulan bola dari bawah)
Maelstrom (perang bintang)
Mures (mengalihkan jalan tikus-tikus menuju ke
perangkap)
Power Manga (perang bintang)
Rocks „n Diamonds (sejenis permainan Digger, yaitu

1 Selengkapnya bisa Anda lihat di Lampiran KMenu (keseluruhan aplikasi yang ada
di Linux Mandrake 10.0).

211
penggali terowongan pencari harta karun)
SuperMethane Brothers (gunakan tombol space, Ctrl,
dan Esc untuk memulai dan mengakhiri permainan)
TowerToppler (menjelajahi menara)
Trophy (balap mobil)

2 Boards Atlantik
Gataxx (mirip permainan halma)
Glines
Gneck (permainan four-rows-win)
Gnome Chess (permainan catur)
KBattleship, KMahjongg, KReversi (sejenis
permainan Othello)
KWin4 (permainan four-rows-win)
XBoard (permainan catur)

3 Cards AisleRiot (sejenis Freecell di Windows)


Blackjack, KPoker
Lieutenant Skat (mirip permainan kartu „cangkulan‰)
Patience (sejenis Freecell)
Potato Guy (menyusun bagian-bagian wajah)
PySOL (juga sejenis Freecell)

4 Puzzles GNOME Mahjongg


GNOME Mines (mirip dengan Minesweeper di
Windows)
GNOME Tetravex (menyusun kotak bersimbol-
simbol tertentu, harus bersesuaian)
Gnotski ( permainan Klotski)

5 Sports Cannon Smash (permainan tenis meja)


Tuxracer (balap penguin, cukup menarik)

6 Strategy Freeciv Client, KAtomic (permainan menyatukan


atom-atom dalam gerakan garis lurus),
KJumpingCube, KMines (permainan Minesweeper),
KolorLines, Konquest, KSokoban, SameGame

7 Toys WorldClock (simulasi penunjuk waktu untuk seluruh

212
permukaan bumi)
TeaCooker
Mouspedometa (simulasi kecepatan gerak mouse)
MoonPhase
Mesa reflect (simulasi cermin)
Mesa morph (simulasi perubahan bentuk)
Mesa gears (simulasi gir atau gigi roda)
AMOR

8 Others GTali
Same GNOME (sejenis permainan SameGame)

Total keseluruhannya hampir mencapai 80 permainan yang meski


sederhana dan beberapa di antaranya mirip satu sama lain, namun
tetap menyenangkan. Dengan sedikit penjelasan pada tabel di atas
mungkin Anda bisa langsung mencoba permainan yang Anda
suka, karena tentu akan sangat menghabiskan waktu bila harus
mencoba satu per satu untuk menemukan games yang Anda sukai
tersebut. Anda juga bisa mencari penjelasan setiap program
games tadi di fasilitas Help Center Linux Mandrake.

Gambar 7.30 Bermain tenis meja di Cannon Smash

213
Gambar 7.31 GNOME Chess

Gambar 7.32 Permainan tetris di KSirtet

214
Gambar 7.33 Potato Guy

Gambar 7.34 Rocks „n Diamonds

215
Gambar 7.35 Lieutenant Skat

Gambar 7.36 WorldClock

216
Gambar 7.37 Trophy

217