Anda di halaman 1dari 7

PRAKTIKUM MANDIRI

TOOLBOX MATLAB KASUS MAMDANI


Petunjuk Praktikum Mandiri :
1) Sebelum anda melakukan praktikum sebaiknya anda baca dan
pelajari dahulu materi tentang Fuzzy Inference System dengan
metode Mamdani.
2) Diharapkan praktikum dilakukan secara mandiri
3) Setelah selesai melakukan praktikum diharapkan membuat laporan
praktikum yang berisi pembahasan dan print scren tampilan dari
matlab yang dikumpulkan pada perkuliahan minggu depan
4) Dilarang keras copy-paste
5) Penilaian

didasarkan

pada

kejelasan

dari

pembahasan

hasil

praktikum.
Soal Praktikum :
Suatu perusahaan soft drink akan memproduksi minuman jenis X. Pada 3
bulan terakhir biaya produksi untuk minuman jenis tersebut rata-rata
sekitar Rp 500,- per kemasan, dan maksimum mencapai Rp 1000,- per
kemasan. Banyaknya permintaan per hari rata-rata mencapai 30000
kemasan dan maksimum hingga mencapai 60000 kemasan. Sampai saat
ini, perusahaan baru mampu memproduksi barang maksimum 100000
kemasan per hari.
Apabila proses produksi perusahaan tersebut menggunakan 3 aturan
fuzzy sbb:
[R1] IF Biaya Produksi RENDAH And Permintaan NAIK THEN
Produksi Barang BERTAMBAH;
[R2] IF Biaya Produksi sesuai STANDAR THEN

Produksi Barang NORMAL;


[R3] IF Biaya Produksi TINGGI And Permintaan TURUN THEN
Produksi Barang BERKURANG;
Berapa jumlah minuman jenis X yang harus diproduksi, jika biaya untuk
memproduksi jenis minuman tersebut diperkirakan sejumlah Rp 800 per
kemasan, dan permintaannya diperkirakan mencapai 25000 kemasan per
hari.
Langkah-langkahnya :
1. Membuat himpunan dan input fuzzy
Ada 3 variabel fuzzy yang akan dimodelkan, yaitu:
Biaya produksi; terdiri-atas 3 himpunan fuzzy, yaitu: RENDAH,
STANDAR, dan TINGGI.

Permintaan barang; terdiri-atas 3 himpunan fuzzy, yaitu: TURUN,


BIASA, dan NAIK.

Produksi

barang;

terdiri-atas

himpunan

fuzzy,

yaitu:

BERKURANG, NORMAL, dan BERTAMBAH

2. S
3. Selesaikan soal diatas dengan menggunakan toolbox matlab dengan
metode Mamdani :
a) Tulis pada command line :
>> fuzzy
Maka akan tampil FIS Editor seperti pada gambar berikut :

b) Memasukkan variabel input dan Output


Pada layar akan terlihat ada 1 input yaitu input 1 dan 1 utput
yaitu output 1. Variabel input dan output dapat diedit dengan
cara :
Tekan sekali kotak berwarna kuning disisi kiri yang berlabel
input1, kotak tersebut kemudian akan berubah menjadi
berbingkai merah.
Pada kolom edit yang berwarna putih disisi kanan, ubah
kata input

1 dengan BiayaProduksi, kemudian tekan

enter
Untuk menambah jumlah variabel input (tidak hanya satu),
maka menu bar pilih edit add input. Ubah nama input2
dengan permintaan, kemudian tekan enter.
Untuk memasukkan variabel output, tekan sekali kotak
berwarna kuning di sisi kanan yang berlabel output1, kotak
tersebut

kemudian

akan

berubah

menjadi

berbingkai

merah.
Pada kolom edit yang berwarna putih di sisi kanan, ubah
kata output1 dengan ProduksiBarang
Mengubah Operator. Operator2 yang digunakan untuk And
Method dan Or Method dapat dipilih pada combobox.
Pilihan untuk And Method adalah (min, prod atau custom),

pilih min. Sedangkan pilihan Or method adalah (max,


probor, atau custom), pilih max.
Mengubah fungsi implikasi dapat dipilih pada combobox.
Pilihan yang ada (min, prod, custom). Pilih min.
Mengubah Metode Agregasi (Komposisi). Metode agregasi
dapat dipilih melalui combobox. Pilihan yang ada (max,
sum, probor, custom). Pilih max.
Mengubah fungsi Defuzzy. Fungsi defuzzy dapat dipilih
melalui combobox. Pilihan yang ada (centroid, bisector,
mom, lom, som, custom). Pilih centroid.
Simpan file anda dengan memilih menu-bar, pilih filesave to disk as....Beri nama kasus1.fis.
c) Membuat himpunan fuzzy dan fungsi keanggotaannya. Double
klik, kemudian akan muncul Membership Function Editor.
Fungsi Keanggotaan untuk variabel Biaya Produksi :
Klik kotak variabel Biaya Produksi (terletak di pojok kiri
atas), hingga bingkainya berwarna merah
Isikan Range dengan [0 1000]
Pilih add MFs pada menu Edit, kemudian tekan OK.
Klik mf1 hingga garisnya berwarna merah. Ganti mf1 dengan nama
RENDAH
Pilih fungsi keanggotaan dengan zmf
Ubah params dengan [0 500]
Klik mf2 hingga garisnya berwarna merah. Ganti mf2 dengan nama
STANDAR
Pilih fungsi keanggotaan dengan pimf
Ubah params dengan [0 500 500 1000]
Klik mf3 hingga garisnya berwarna merah. Ganti mf3 dengan nama
TINGGI
Pilih fungsi keanggotaan dengan smf
Ubah params dengan [500 1000]
Fungsi Keanggotaan untuk variabel Permintaan :
Klik variabel Permintaan (terletak di pojok kiri atas), hingga
bingkainya berwarna merah
Isikan Range dengan [0 60]
Pilih add MFs pada menu Edit, kemudian tekan OK.
Klik mf1 hingga garisnya berwarna merah. Ganti mf1 dengan nama
TURUN

Pilih fungsi keanggotaan dengan trapmf


Ubah params dengan [0 0 10 30]
Klik mf2 hingga garisnya berwarna merah. Ganti mf2 dengan nama

BIASA
Pilih fungsi keanggotaan dengan trimf
Ubah params dengan [0 30 50]
Klik mf3 hingga garisnya berwarna merah. Ganti mf3 dengan nama NAIK
Pilih fungsi keanggotaan dengan trapmf
Ubah params dengan [30 50 60 60]

Fungsi Keanggotaan untuk variabel Produksi Barang :


Klik variabel Produksi Barang (terletak di pojok kiri atas),
hingga bingkainya berwarna merah
Isikan Range dengan [0 100]
Pilih add MFs pada menu Edit, kemudian tekan OK.
Klik mf1 hingga garisnya berwarna merah. Ganti mf1 dengan nama
BERKURANG
Pilih fungsi keanggotaan dengan trapmf
Ubah params dengan [0 0 10 50]
Klik mf2 hingga garisnya berwarna merah. Ganti mf2 dengan nama
NORMAL
Pilih fungsi keanggotaan dengan trimf
Ubah params dengan [30 50 70]
Klik mf3 hingga garisnya berwarna merah. Ganti mf3 dengan nama
BERTAMBAH
Pilih fungsi keanggotaan dengan trapmf
Ubah params dengan [50 90 100 100]

d) Membuat aturan
Kembali ke gambar awal. Double klik kotak aturan atau pilih Edit rules
pada menu View. Maka akan muncul rule editor
Untuk membuat aturan ke-1 pilih dengan cara mengklik 1 kali RENDAH
pada listbox BiayaProduksi, NAIK pada listbox Permintaan dan
BERTAMBAH pada listbox ProduksiBarang. Kemudian tekan add
rule.

Untuk

membuat

BiayaProduksi,

aturan
None

ke-2

pilih

STANDAR

pada

listbox

pada listbox Permintaan dan NORMAL pada

listbox ProduksiBarang. Kemudian tekan add rule .


Untuk membuat aturan ke-3 pilih TINGGI pada listbox BiayaProduksi,
TURUN pada listbox Permintaan dan BERKURANG

pada listbox

ProduksiBarang. Kemudian tekan add rule.


Hasilnya dapat dilihat dari rule reviewer. Pilih View rules... pada menu
View. Akan muncul rule editor.
Untuk melihat kaitan ketiga variabel dalam bentuk surface, pilih View
surface... pada menu View. Akan muncul surface editor.