Anda di halaman 1dari 12

Comandos CCNP

EIGRP
Advertiseddistance (AD): El coste de la ruta a una red remota desde el vecino.
Feasibledistance (FD): La mtrica ms baja a una red remota.
Feasiblecondition (FC): Cuando un router tiene una AD ms pequea que su FD
FeasibleSuccessor (FS): Si un vecino reporta una AD ms pequea que el FD,
ser un FS.
Successor: El vecino con la segunda AD ms pequea que el FD ser el
sucesor.

SPLIT-HORIZON
Un router no anuncia la ruta de vuelta por la interfaz desde donde la recibi. Es
una caracterstica propia de los protocolos de vector distancia.
Para deshabilitarlo:
R1(config)#int s0/0
R1(config-if)#no ip split-horizon eigrp <AS> (para EIGRP)
R1(config-if)#no ip split-horizon (para RIP)

Frame-relay
R1(config)#int s0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay map ip<ipdestino><DLCI> broadcast

Configuracin de MD5 EIGRP

R1(config)#key chain CISCO


R1(config-keychain)#key 1
R1(config-keychain-key)#key-string CCNP
R1(config-keychain-key)#int s1/0
R1(config-if)#ip authentication mode eigrp 10 md5
R1(config-if)#ip authentication key-chain eigrp 10 CISCO

Configuracin de hello y hold time EIGRP (Se aplica en la interfaz)


R1(config)#int s1/0
R1(config-if)#ip hello-interval eigrp 10 10
R1(config-if)#ip hold-time eigrp 10 30

Balanceo de carga en enlaces desiguales (por defecto es 1)


R1(config)#router eigrp 10
R1(config-router)#variance 2

Modificar distancia administrativa EIGRP (el primer nmero es la distancia


interne y el segundo la externa)
R1(config)#router eigrp 10
R1(config-router)#distance eigrp 60 110

Modificar ancho de banda para el protocolo EIGRP


R1(config)#int s1/0
R1(config-if)#ip bandwidth-percent eigrp 10 80

OSPF
Configuracin bsica de OSPF
R3(config)#router ospf 1
R3(config-router)#network 10.0.3.0 0.0.0.255 area 0

R4(config)#interface fastEthernet 0/0


R4(config-if)#ipospf 1 area 0

R5(config-router)#network 192.168.0.5 0.0.0.0 area 0

R4(config)#interface fastEthernet 0/1


R4(config-if)#bandwidth 10

R4(config)#interface fastEthernet 0/1


R4(config-if)#ipospf cost 1

R4(config)#router ospf 1
R4(config-router)#auto-cost reference-bandwidth 1000

ELECCION DR (para redes multiacceso)


La eleccin de DR se determina segn las siguientes reglas en orden
descendente:
1.- Prioridad de la interfaz ms alta.
2.- Router-id ms alto.

3.- Interfaz loopback con la IP ms alta.


4.- Interfaz fsica con la IP ms alta.

Elevar la prioridad de una interfaz (por defecto es 1. Valor 0 no ser elegible


para DR o BDR, por lo que sirve para excluir a esos router de la eleccin)
Esta configuracin se hace en una interfaz usada en el protocolo.
R3(config)#interface fastEthernet 0/1
R3(config-if)#ipospf priority <0-255>

Configurar el router-id (el valor ms alto ser el DR, siempre y cuando no haya
una interfaz con prioridad ms alta)
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
(limpiar el proceso para que tome cambio)
R3#clear ipospf process

Configurar loopback
R3(config)#interface loopback 0
R3(config-if)#ip address 193.168.0.1 255.255.255.0

Configuracin de interfaces pasivas. El objetivo es impedir la difusin del


protocolo de enrutamiento hacia las LAN o redes que no lo requieren. En el
campo laboral es la forma ms utilizada.
R1(config)#router ospf 1
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface s1/0

Aadir vecino de forma manual, necesario en redes sin difusin.

R3(config)#router ospf 1
R3(config-router)#neighbor 192.168.0.1

Timers:

Por defecto OSPF tiene timers de 10-40. Al configurar interfaces ms lentas, los
timers son modificados. Deben ser iguales en ambos extremos.
R1(config)#int s1/0
R1(config-int)#ipospf hello-interval 10
R1(config-int)#ipospfdead-interval 40 (al configurar el hello-interval, el deadinterval se configura por defecto en 4 veces el hello, aunque es recomendable
configurarlo)

Verificar los tiempos actuales:


R2#show ipospf interface s1/0
Timerintervals....

Modificar distancia administrativa para manipular las rutas.


R2(config)#router ospf 1
R2(config-router)#distance 120
Para visualizarlo
R2#show iproute

Al configurar parmetros que son configurados automticamente de forma


normal, como la distancia administrativa o los timers, esa funcin se
deshabilita, siendo utilizados los configurados manualmente.

Autenticacin de OSPF

Texto simple
R1(config-if)#ipospf authentication-key <password>
MD5
R1(config-if)#ipospf message-digest-key <key-id> md5 <key>
R1(config-if)#ipospf authentication message-digest

Autenticacin por rea. La adyacencia se establece igual, pero si la


autentificacin no se cumple, la base de datos de OSPF no se poblar, ya que
las LSA no se enviarn.
R3(config)#router ospf 1
R3(config-router)#area 0 authentication message-digest

Para hacer vecindad, deben ser iguales:

-Area
-Hello/Dead
-MTU (se puede ignorar con ipospfmtu-ignore, configurandolo en la interfaz).
-Tipos de red compatible (que las redes elijan o no elijan DR/BDR)
-Banderas de STUB
-Autenticacin

-nico router-id.

Comandos de verificacin
R1#show ipospf
R1#show ipospf database
R1#show ipospf interface
R1#show ipospf neighbor
R1#show ip protocols
R1#show ip route
R1#debugipospf events
R1#debug ipospf packet
R1#debug ipospfspf statistic
R1#undebug all (para deshabilitar todos los debug)

OSPF en un rea:
- El algoritmo SPF si no hay cambios, se actualiza cada 30 minutos.
- Algoritmo corre ms frecuentemente cuando el rea es muy grande
- Tamao de la tabla de ruteo depende del nmero de routers en el rea
- Base de datos topolgica depende del nmero de routers en el rea
- Utilizacin de CPU y Memoria (latencia, congestin, convergencia, etc.)
- Overhead de LSU (sobrecarga de actualizaciones)

***OSPF multirea***
Tipos de router:
-INTERNAL ROUTER: Todas las interfaces en la misma rea.
-BACKBONE ROUTER: Router en AREA 0.

-AREA BORDER ROUTER (ABR): Conecta dos o ms reas.


-AUTONOMOUS SYSTEM BORDER (boundary) ROUTER (ASBR): Conecta con
otros dominios de ruteo.
Un ABR que est en el backbone, cumple dos funciones, siendo un ABR y
tambin Backbone.

LSA (Link-state advertisement)


Tipo 1: Router LSA
Generado por todos los router que participan dentro del proceso de un rea.
Fluyen slo dentro del rea al que pertenece, finalizando en el ABR. En la tabla
de ruteo aparece con una "O".
Tipo 2: Network LSA
Enviado slo por el DR. Son las redes que estn en esa rea. Slo fluyen dentro
de un rea. Aparece en la tabla con una "O"
Tipo 3: Summary LSA.
Enviado por el ABR, informando las redes interrea. Puede fluir en ms de un
rea. En la tabla de enrutamiento aparece como "O IA" (OSPF interrea)
Tipo 4: Summary LSA
Aparece la identificacin del router ASBR, generandose en el ABR para informar
a las otras reas la ubicacin del ASBR. Al visualizarlo en la tabla de ruteo
aparece como "O IA".
Tipo 5: External LSA
Generado por el ASBR para advertir redes emitidas por otros protocolos. En la
tabla de enrutamiento aparece como "O E1" u "O E2"
-E1: el costo cambia router por router.
-E2: el costo es constante en toda la topologa de OSPF. Las rutas por defecto
son E2.
Tipo 7: NSSA LSA
Generado por el ASBR, siempre y cuando ese router est dentro de un rea
Not-so-stubbyarea (NSSA). Aparecen en la tabla de enrutamiento como "O N1"
u "O N2"

-N1: El costo es acumulativo


-N2: es un costo esttico.

Redistribucin de EIGRP en OSPF


R6(config-router)#redistribute eigrp 1 subnets

Tipos de rea:
Para todos los tipos de rea es comn que con el comando network se defina
en qu rea se encontrar cada interface del router.
-Standard: Este tipo de rea puede recibir LSA de tipo 1 al 5. No se efecta
ninguna configuracin especial.
-Stub: Todos los router del rea deben estar de acuerdo con la bandera stub. Se
remueven los LSA externos de tipo 5. El ABR genera una ruta default. Las reas
stub no permiten la redistribucin de otro protocolo.
Para configurarlo se ingresan los siguiente comandos:
En el router ABR:
R3(config)#router ospf 1
R3(config-router)#area 2 stub
Configuracin en el resto de los router del rea:
R4(config)#router ospf 1
R4(config-router)#area 2 stub
-TotallyStubbyArea: Todos los router deben estar de acuerdo en la bandera
stub. El ABR transforma el rea stub en Totallystubby. Se remueven los LSA de
tipo 3,4 y 5. El ABR genera una ruta default. No se permite la redistribucin. Es
propietario de CISCO.
La configuracin es la siguiente:
En el router ABR:
R3(config)#router ospf 1
R3(config-router)#area 2 stub no-summary

Configuracin en el resto de los router del rea:


R4(config)#router ospf 1
R4(config-router)#area 2 stub
-NSSA (Not-so-stubbyarea): Todos los router del area deben estar con la
bandera NSSA. Se remueven los LSA de tipo 5. ABR no genera una ruta por
default de forma predeterminada. Se permite la redistribucin, la que es
enviada con LSA de tipo 7, siendo transformada en LSA de tipo 5 al pasar por el
ABR.
La configuracin es la siguiente:
En el router ABR:
R3(config)#router ospf 1
R3(config-router)#area 2 nssa
o, para generar una ruta default
R3(config-router)#area 2 nssa default-information-originate
Configuracin en el resto de los router del rea:
R4(config)#router ospf 1
R4(config-router)#area 2 nssa
-Totally NSSA: Igual que NSSA, removindose tambin las LSA de tipo 3 y 4. El
ABR genera una ruta default. Propietario de CISCO.
La configuracin es la siguiente:
En el router ABR:
R3(config)#router ospf 1
R3(config-router)#area 2 nssa no-summary
Configuracin en el resto de los router del rea:
R4(config)#router ospf 1
R4(config-router)#area 2 nssa
***NOTA***
Al cambiar un rea de un tipo a otra, hay que negar el comando anterior. Por
ejemplo para pasar el rea 2 desde T-Stub a NSSA se hace lo siguiente:

R3(config)#router ospf 1
R3(config-router)#no area 2 stub no-summary
R3(config-router)#no area 2 stub
R3(config-router)#area 2 nssa

Consideraciones de una red multirea:


-Tipo de rea
-CPU
-Bandwidth
-Si es una red NBMA
-Todas las redes en rea 0
-HUB en area 0 (como en las topologas hub and spoke).
-Links externos
-Sumarizacin
-Vecinos por router
-Nmero de reas

Virtual-Links
En las redes multirea, slo debe existir un slo rea 0. Todas las redes deben
"tocar" o tener conexin directa con el rea 0. En los casos que un rea no
tiene contacto directo con el rea 0, existen los virtual-links.
Los virtual-links sirven para corregir un mal diseo de la red. Se requiere
configurar router-id de forma manual. El rea de trnsito no puede ser STUB.
Para configurar virtual links, los comandos son los siguientes:
R4(config)#router ospf 1
R4(config-router)#area 3 virtual-link <router-id del router que "toca" el rea 0>

Redistribucin

Informar a otros protocolos de ruteo que no tienen informacin de redes. Puede


ser saliente y entrante.
-

Redistribucin en RIP

R4(config-router)#redistribute eigrp 1 metric <0-15> (IOS acepta cualquier


valor, pero RIP slo acepta 16 saltos.
-

Redistribucin en EIGRP

R4(config-router)#redistribute rip metric <ancho de banda> <delay>


<reliability> <load> <MTU> (se indica qu valor deben tener los valores K)
-

+ Si IOS permite redistribuir con mtrica algn protocolo, s o s


Redistribucin en OSPF

R4(config-router)#redistribute eigrp 1 metric <resultado de la frmula


explcita> subnets (puntaje adicional)

Prefix list.
R1(config-router)#distribute-list prefix LIST in fastEthernet 0/0
PBR
Set ip default next-hop 1.1.1.1 (primero lee la tabla de ruteo del router y si no
encuentra una opcin, utilizar el route-map)
Set ip next-hop 1.1.1.1 (enva todo el trfico que hace match al router 1.1.1.1.
Si no hay match, se descarta)