Anda di halaman 1dari 12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo
Home

DiagramasdeFlujoyAlgoritmos
Co lecci n d eejercicio sresu elt o sd ealg o rit mo sb sico su san d o d iag ramasd e
flu jo co n c d ig o fu en teen Java,VB,C#,Ph yto n ,CyC++.

Mostrandoentradasconlaetiquetapseudocodigo. Mostrartodaslasentradas
vi e r ne s,2 6 de ab r i lde 2 013

Realizarundiagramadeflujoparaescribirlos100
primerospares

Buscarenesteblog
Buscar

Realizarundiagramadeflujodeunprogramaquepermitaescribirenpantallalos100
primerosnmerospares.

1.478

Qusonlosdiagramasdeflujo?
FreeDFDDibujarySimular
DiagramasdeFlujo

Pseudocdigo
ProcesoCienPrimerosPares

Escribir"Los100primerosparesson"

num<0

Mientrasnum<200Hacer

Escribirnum

FinMientras

num<num+2

FinProceso
Pub li cadopor G e or ge Tacur i e n1: 03 2 com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,pr ogr am aci one str uctur ada,PS e I nt,pse udocodi go

Labels
algoritmo(569)
C(118)
C#(95)

m i r cole s,17de ab r i lde 2 013

VolumendeunPrismaDiagramadeFlujo
Realizarelalgoritmoydiagramadeflujoparacalcularelvolumendeunprismarecto.
Diagramadeflujo:
http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

C++(112)
codigofuente(616)
DFD(95)
diagramadeflujo(116)
diagramadeflujodedatos(95)
diagramaflujo(92)

1/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo
ejerciciosresueltos(665)
funciones(1)
Java(104)
problemaconversion(44)
programacionestructurada(547)
programacionmodular(21)
PSeInt(13)
pseudocodigo(12)
python(96)
Recursividad(11)
varios(1)
VisualBasic(96)

BlogArchive
2013(686)
abril(3)
Realizarundiagramadeflujo
paraescribirlos10...
VolumendeunPrisma
DiagramadeFlujo

Elvolumendeunprismarectoeselproductodelreadeunadelasbasesporladistancia
entreellas(altura)

Porcentajenumerosparese
imparesDiagramadeF...
marzo(18)

Pseudocdigo

febrero(121)

ProcesovolumenPrisma

enero(544)

Escribir"VOLUMENDEUNPRISMARECTO"

2012(52)

Escribir"Ingresarelareadelabase"
Leerabase
Escribir"Ingresarlaaltura"
Leeraltura
volumen<abase*altura
Escribir"Elvolumendelprismaes:",volumen
FinProceso

Pub li cadopor G e or ge Tacur i e n2 3 : 4 6 0com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,PS e I nt,pse udocodi go

Nosvisitan
m i r cole s,2 7de m ar zode 2 013

PermetrodeuntrianguloDiagramadeFlujo
Ejercicio:Realizareldiagramadeflujoparahallarelpermetrodeuntriangulo,elvalorde
losladosdeltriangulosedebeingresarporteclado.

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

2/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

LiveTrafficFeed
AvisitorfromLima,Peru
viewedOrdenarcrecienteo
decrecienteunalist...1minago
AvisitorfromSpainviewed
"ConvertirdegradosCelsiusa
gradosFahrenheityviceversa
CodigoFuenteenC#~Diagramas
AvisitorfromSpainviewed
deFlujoyAlgoritmos"1minago
"ConvertirdesegundosaHoras,
minutosysegundosCodigoFuente
enPython~DiagramasdeFlujoy
AvisitorfromQuito,Pichincha
Algoritmos"1minago
viewed"Determinarelmayorde
tresnmerosCodigoFuenteen
C++~DiagramasdeFlujoy
AvisitorfromLimaviewed
Algoritmos"2minsago
"Algoritmoquemuestralos
nmerosparesentre1y100
PseudocdigoDiagramadeFlujo~
DiagramasdeFlujoyAlgoritmos
AvisitorfromCaracas,Distrito
3minsago
Federalviewed"Calcularelreade
uncuadradoCodigoFuenteenJava
~DiagramasdeFlujoy
AvisitorfromZapopan,Jalisco
Algoritmos"4minsago
viewed"Determinarelreay
PermetrodeunCirculoCdigoen
C++~DiagramasdeFlujoy
AvisitorfromCaracas,Distrito
Algoritmos"4minsago
Federalviewed"Calcularelreade

Pseudocdigo
ProcesoPerimetroTriangulo
Escribir"PERIMETRODEUNTRIANGULO"
Escribir"Ingresarloslados:"
Escribir"Lado1:"
LeerL1
Escribir"Lado2:"
LeerL2
Escribir"Lado3:"
LeerL3

uncuadradoCodigoFuenteenJava
~DiagramasdeFlujoy
AvisitorfromUnitedStates
Algoritmos"6minsago
viewed"Ordenarcrecienteo
decrecienteunalistadeNnmeros
Diagramadeflujo~Diagramas
AvisitorfromSpainviewed
deFlujoyAlgoritmos"7minsago
"Determinarsiunnmeroesprimo
CodigoFuenteenC++~
DiagramasdeFlujoyAlgoritmos
AvisitorfromMedelln,Antioquia
8minsago
viewed"Determinarelmayorde
Realtimeview
GetFeedjit

perimetro<L1+L2+L3
Escribir"Perimetro=",perimetro
FinProceso

Pub li cadopor G e or ge Tacur i e n14 : 16 5com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,PS e I nt,pse udocodi go

dom i ngo,2 4 de m ar zode 2 013

Sumaypromediode10nmerosDiagramadeFlujo
Realizarundiagramadeflujodeunprogramaquepermitalacargade10valorespor
tecladoymuestrelasumadelosvaloresingresadosysupromedio.

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

3/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Pseudocdigo
ProcesoSumaNumeros
suma<0
//sepidequeseingreselosnumeros
Parai<1HastacantConPaso10Hacer
Escribir"Ingreseelnumero",i
Leernumero
suma<suma+numero
FinPara
Escribir"Lasumaes:",suma
Escribir"Elpromedioes:",suma/10
FinProceso

Pub li cadopor G e or ge Tacur i e n7: 50 1com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,PS e I nt,pse udocodi go

m i r cole s,2 0de m ar zode 2 013

SumadenmerosparesenunrangoDiagramade
Flujo
Elaborareldiagramadeflujodeunprogramaquerealicelasumadelosnmerosparesen
unrangodado,losnmerosinferiorysuperiordelrangodebenseringresadospor
teclado.

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

4/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Pseudocodigo
ProcesoSumaNumerosPares
Escribir"SUMADENUMEROSPARESENUNRANGO"
Escribir"Ingresenumeroinferior:"
Leerinferior
Escribir"Ingresenumerosuperior:"
Leersuperior
suma<0
Mientrasinferior<superiorHacer
//averiguamossielnumeroespar
Siinferior%2=0Entonces
suma<suma+inferior
FinSi
inferior<inferior+1
FinMientras
Escribir"Lasumadenumerospareses:",suma
FinProceso

Pub li cadopor G e or ge Tacur i e n2 3 : 55 1com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,PS e I nt,pse udocodi go

lune s,18de m ar zode 2 013

MediadelasnotasdeunestudianteDiagramade
FlujoCdigoenC++
Cuatroenterosentre0y100representanlaspuntuacionesdeunestudiantedeuncurso
deinformtica.Escribirunprogramaparaencontrarlamediadeestaspuntuacionesy
visualizarunatabladenotasdeacuerdoalsiguientecuadro:
MEDIA

PUNTUACION

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

5/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

90100

8089

7079

6069

Realizaranlisis
Realizardiagramadeflujodedatos
ElaborarelprogramaenC++

DiagramadeFlujo

Pseudocdigo
ProcesoMediaNotas

//cantidaddenotas

n<4

nota<0

//sedeclaraunarreglodenelementos

Dimensionnotas[n]

//sellenalasnotasenelarreglo

Parai<0Hastan1ConPaso1Hacer

Escribir"Ingresenota",i+1

Leernotas[i]

//comprobamosquelanotaingresadaseacorrecta

Sinotas[i]>=0Ynotas[i]<=100Entonces

Sino

Escribir"Notaincorrecta"

i<i1

FinSi

FinPara

//secalculalamedia

Parai<0Hastan1ConPaso1Hacer

FinPara

nota<nota/n

//imprimimoselresultado

Escribir"MEDIA

//sebuscaequivalenciaenlatabla

Sinota>=60Ynota<=69Entonces

Escribir"NotaOK"

nota<nota+notas[i]

PUNTUACION"

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

6/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Escribirnota,"D"

FinSi

Sinota>=70Ynota<=79Entonces

FinSi

Sinota>=80Ynota<=89Entonces

FinSi

Sinota>=90Ynota<=100Entonces

FinSi

Escribirnota,"C"

Escribirnota,"B"

Escribirnota,"A"

FinProceso

CdigoFuenteenC++
viewplain

01.
02.
03.
04.
05.
06.
07.
08.
09.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
43.

print

#include<iostream>
usingnamespacestd;

intmain(){

floati;
floatn;
floatnota;
floatnotas;

n=4;
nota=0;
for(i=0;i<=n1;i++){
cout<<"Ingresenota"<<i+1<<endl;
cin>>notas[i];
if(notas[i]>=0&&notas[i]<=100){
cout<<"NotaOK"<<endl;
}else{
cout<<"Notaincorrecta"<<endl;
i=i1;
}
}
for(i=0;i<=n1;i++){
nota=nota+notas[i];
}
nota=nota/n;
cout<<"MEDIAPUNTUACION"<<endl;
if(nota>=60&&nota<=69){
cout<<nota<<"D"<<endl;
}
if(nota>=70&&nota<=79){
cout<<nota<<"C"<<endl;
}
if(nota>=80&&nota<=89){
cout<<nota<<"B"<<endl;
}
if(nota>=90&&nota<=100){
cout<<nota<<"A"<<endl;
}

return0;

Pub li cadopor G e or ge Tacur i e n9 : 4 8 0com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: C + + ,codi gofue nte ,di agr am ade flujo,PS e I nt,pse udocodi go

Sumadelos10primerosparesDiagramadeFlujo
Realizareldiagramadeflujodeunprogramaparacalcularlasumadelos10
primerosnmerospares.

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

7/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Enpseudocodigo:
ProcesoSumaPares
num<0
sum<0
Mientrasnum<11Hacer
Sinum%2=0Entonces
sum<sum+num
FinSi
num<num+1
FinMientras
Escribir"Lasumadelos10primerospareses:",sum
FinProceso

Pub li cadopor G e or ge Tacur i e n9 : 11 1com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,pr ogr am aci one str uctur ada,PS e I nt,pse udocodi go

sb ado,16 de m ar zode 2 013

Determinarsiunnumeroesmltiplodeotro
DiagramadeFlujo
Hacereldiagramadeflujodeunprogramaquepermitadeterminarsiunnumero
esmltiplodeotro.

ProcesoMultiploDeOtro
Escribir'Ingreseunnumero'
Leern1
Escribir'Ingreseotronumero'
Leern2
Sin1>n2Entonces
Sin1MODn2=0Entonces
Escribir'Elnumero',n1,'esmultiplode',n2
Sino
http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

8/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Escribir'Elnumero',n1,'Noesmultiplode',n2
FinSi
Sino
Sin2MODn1=0Entonces
Escribir'Elnumero',n2,'esmultiplode',n1
Sino
Escribir'Elnumero',n2,'Noesmultiplode',n1
FinSi
FinSi
FinProceso

Cdigofuente

Pub li cadopor G e or ge Tacur i e n13 : 53 3 com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,pse udocodi go

dom i ngo,3 de m ar zode 2 013

Algoritmoquemuestralosnmerosparesentre1y
100PseudocdigoDiagramadeFlujo
Desarrollarelpseudocodigoydiagramadeflujodeunalgoritmoquemuestrelosnmeros
paresquehayentre1y100.

Pseudocdigo
ProcesoNumerosPares
Escribir"Losnumerosparesentre1y100:"
num<1
Mientrasnum<=100Hacer
Sinum%2=0Entonces
Escribirnum
FinSi
num<num+1
FinMientras
FinProceso

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

9/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Pub li cadopor G e or ge Tacur i e n12 : 3 1 1com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,e je r ci ci osr e sue ltos,PS e I nt,pse udocodi go

Imprimir10primerosnmerosenordeninverso
PseudocodigoyDiagramaFlujo
Realizarelpseudocodigoydiagramadeflujodeunprogramaqueimprimaenpantalla
los10primerosnmerosenordeninverso.

Pseudocdigo
ProcesoNumerosOrdenInverso
Escribir"Los10primerosnumerosenordeninverso:"
cont<10
Mientrascont>0Hacer
Escribircont
cont<cont1
FinMientras
FinProceso

Pub li cadopor G e or ge Tacur i e n12 : 01 0com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,PS e I nt,pse udocodi go

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

10/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

m i r cole s,2 7de fe b r e r ode 2 013

Programaqueapartirdeunatemperaturaengrados
CelciusdeterminasihacefroocalorDiagramade
flujo
Desarrollar el pseudocodigo y diagrama de flujo de un programa que lea una
temperaturaengradosCentgradosyqueimprimasihacefroocalorsegnelsiguiente
esquema:elclimaesmuyfro(temperaturamenora0C),esfro(temperaturaentre0y9
C),estemplado(temperaturaentre10y19C),esclido(temperaturaentre2026C)y
muycaliente(temperaturamayora26C).

PSEUDOCDIGO
ProcesoTemperaturaAmbiente
Escribir"Ingreseunatemperatura"
Leertemp
Si(temp<0)Entonces
Escribir"Elclimaesmuyfrio"
Sino
Si(temp<10)Entonces
Escribir"Elclimaesfrio"
Sino
Si(temp<20)Entonces
Escribir"Elclimaestemplado"
Sino
Si(temp<27)Entonces
Escribir"Elclimaescalido"
Sino
Escribir"Elclimaesmuycaliente"
FinSi
FinSi
FinSi
FinSi

FinProceso

Pub li cadopor G e or ge Tacur i e n17: 2 3 0com e ntar i os Enlace sae stae ntr ada

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

11/12

17/10/2015

DiagramasdeFlujoyAlgoritmos:pseudocodigo

Eti q ue tas: di agr am ade flujo,PS e I nt,pse udocodi go

m ar te s,2 6 de fe b r e r ode 2 013

Imprimir8primerosmltiplosdeunnumero
DiagramadeFlujoyPseudocdigo
Realizarelpseudocdigoyeldiagramadeflujodeunprogramaqueimprimalos8
primerosmltiplosdeunnumeroingresadoporelusuario.

PSEUDOCDIGO
ProcesoMultiplosNumero
Escribir"Ingreseunnumero:"
Leernum
Escribir"Los8primerosmultiplosde",num,"son:"
Parai<1Hasta8ConPaso1Hacer
Escribirnum*i
FinPara
FinProceso

Pub li cadopor G e or ge Tacur i e n18: 2 3 3 com e ntar i os Enlace sae stae ntr ada
Eti q ue tas: di agr am ade flujo,e je r ci ci osr e sue ltos,PS e I nt,pse udocodi go

Pginaprincipal

Entradasantiguas

( c) 2 009 D i a g r a m a s d e Flu jo y Alg or i tm os . B log g e r Te m p la te s cr e a te d b y D e lu xe Te m p la te s.ne t. W p b y w p th e m e sf r e e

http://diagramasdeflujo.blogspot.pe/search/label/pseudocodigo

12/12