Anda di halaman 1dari 34

PROTEL SCHEMATIC & PCB

(Modul Praktikum)

OLEH :

Arif Johar Taufiq, ST, MT

Fakultas Teknik
Program Studi Teknik Elektro
UNIVERSITAS MUHAMMADIYAH PURWOKERTO
2005

1. PROTEL SCHEMATIC
Setelah program Protel Schematic berhasil diinstall, ada beberapa cara untuk
memanggil Protel Schematic, antara lain:
1.

Lewat Start, Program, Advanced Schematic kemudian klik Schematic Editor.

2.

Atau anda dapat memanggilnya lewat Window Explorer, cari folder Pfwsch, kemudian
klik ganda file SCH.

3.

Dan dapat juga anda mencarinya file SCH lewat, Start, Run, Browse cari program
file SCH di folder Pfwsch, kemudian anda jalankan file SCH dengan mengeklik tombol
OK.

Tampilan pertama program Protel Schematic adalah tampak seperti pada gambar 2.1.

a
b
c
d
e
f
g
h
i
j

k
Gambar 2.1 Tampilan awal program Protel Schematic

Keterangan dari gambar 2.1, adalah sebagai berikut:


a. Menu File untuk membuat file baru, buka file sheet dan project, running program bantu, dan
keluar program.
Menu info berisikan informasi sistem dan Library berisikan menambah atau menghapus file
library (komponen) juga untuk mengedit.
b. Kumpulan icon shotcut perintah, keterangan dari masing-masing icon ini dapat anda lihat
pada point k, dengan cara tempatkan mouse di atas icon maka keterangan icon yang
ditunjuk akan muncul pada panel keterangan.
c.

List box untuk memilih library yang akan dipakai

d. Untuk menambah atau mengurangi library.


e. Kotak pilihan dari komponen yang akan dipakai, tanda * berarti semua komponen akan
ditampilakan semua dalam kotak komponen (f)
f. Kotak daftar komponen dari library yang dipilih
g. Tombol untuk edit komponen (jarang dipakai)
h. Tombol untuk meletakkan komponen yang dipilih (sering dipakai)
i. Kotak keterangan komponen yang sudah dipilih dalam gambar kerja
j. Untuk mengubah (change) dan lompat (jump to) ke komponen
k. Panel keterangan atau penjelasan icon shortcut.

2.1 MENGGAMBAR MENGGUNAKAN PROTEL SCHEMATIC


1. Klik Start, Program, Advance Schematic, kemudian klik Schematic Editor.
2. Klik icon Add/Remove Library (keterangan gambar 2.1d) untuk mengisikan library, pilih
library yang akan dipakai, misalnya demoprj.lib, protel.lib dengan menunjuk file tersebut
dengan mouse (file terpilih akan tersorot warna biru). Kemudaian klik tombol Add untuk
memasukkan library terpilih pada kotak Current file list dan Remove untuk
menghapusnya, lihat gambar 2.2.

Gambar 2.3 Memasukkan file library

File libray juga dapat anda tambahi sendiri dengan memilih file pada folder library,
misalnya: d_linier, d_mem, d_moto,d_device, d_ttl, dll.

3. Kemudian buat file baru dengan cara klik menu FILE, pilih NEW, dan settinglah ukuran
kertas lembar kerja dengan cara klik menu OPTION , SHEET lihat gambar 2.4.

Gambar 2.4. Mengatur sheet kertas

Sheet (ukuran kertas) dapat diatur jenis ukuran size A4 s/d E, document option (change)
untuk mengeset data-data yang pelu diisikan (Organisasi, alamat, no, revisi, dll). Kotak
Color, untuk memilih warna border dan sheet. Kotak Grid, untuk menampilan atau
menyembunyikan garis grid.

TIPS:
Sebelum menggambar pilihan kertas (sheet) harus sudah ditentukan terlebih dahulu,
karena mengubah ukuran kertas dari besar ke kecil akan membuat daerah kerja
gambar menjadi mengecil (gambar yang sudah terlanjur tergambar, akan berada
diluar area kerja/kertas).
4. Cara menempatkan komponen ke kertas kerja:
a. Pilih library komponen (lihat gambar 2.1c)
b. Pilih komponen dengan menyorot nama komponen (gambar 2.1f)
c. Klik tombol Place, kemudian taruh mouse ke kertas kerja dan klik kanan mouse, lihat
gambar 2.5.

Gambar 2.5 Menempatkan komponen ke kertas kerja

2.1 MENGISI DATA KOMPONEN


Pilih komponen dalam gambar (misal pada gambar 2.5), klik ganda komponen tersebut, isikan
data yang diperlukan (lihat gambar 2.6).

Gambar 2.6. Mengisi data part komponen

Label isian data disini sbb:


9 Designator : U1 (kode komponen)
9 Part type : 741 (tipe IC opamp yang dipakai)
9 Foot print : DIP8 ( pattern/footprint PCB IC 8 pin)
9 Orientation : 0 degre (letak komponen gambar, horisontal), sudut lainnya 90o, 180,
270).
Setelah selesai semua memasukkan data isian, kemudian klik OK .
TIPS
Untuk mengatur sudut komponen dan letak, cara cepat yaitu: klik komponen sekali,
kemudian klik seklai lagi, terus tekan Spacebar keyboard, untuk memilih peletakan posisi
komponen. Setelah sesuai keinginan (posisi dan sudut) kemudian klik kiri mouse sekali
untuk meletakkannya.
Untuk memindahkan komponen, letakkan mouse diatas komponen kemudian klik kiri
mouse bersamaan dengan menekan tombol Ctrl pada keyboard, geser ketempat tujuan
selanjutnya klik kiri mouse sesekali.

1.2. MENGHUBUNGKAN KOMPONEN


Agar gambar menjadi lengkap membentuk rangkaian maka masing-masing komponen
saling dihubungkan untuk membentuk suatu rangkaian, tools yang dipakai adalah Wiring
Tools. Untuk mengaktifkan menu Wiring Toolbar klik menu option kemudian pilih
WiringToolbar. Maka wiring tools akan muncul seperti pada gambar 2.7.
b

Gambar 2.7 Wiring Tools

Masing-masing fungsi icon dapat anda lihat pada kotak panel keterangan pada saat mouse
terletak di atas icon wiring tools, lihat gambar 2.1k.

Keterangan gambar 2.7, fungsi Icon:


a. Untuk menghubungkan komponen secara listrik
b. Untuk menggambar bus
c. Untuk masukan ke bus
d. Untuk menggambar VCC atau ground
e. Untuk membuat sambungan listrik.

PERHATIAN !!
Menghubungkan/merangkaikan komponen harus memakai WIRE (lihat gambar 2.7a), bukan
memakai LINE (drawing tools), karena kesalahan ini maka program protel tidak dapat
membuat daftar netlist dengan benar. Jika daftar netlist tidak benar maka nantinya gambar PCB
nantinya menjadi salah.

Cara menghubungkan komponen:


1. Tekan icon untuk menghungkan komponen
2. Letakkan mouse ke titik yang akan dihubungkan klik kiri mouse, tarik ke titik lainnya klik
kiri mouse, maka dua titik akan tehubung, untuk mengakhiri klik kanan mouse.
2. Untuk mengakhiri keseluruhan klik kanan mouse sekali lagi.

Cara membuat junction (sambungan elektrik):


1. Klik icon untuk membuat junction
2. Letakkan mouse ke titik yang akan dihubungkan klik kiri mouse, untuk mengakhiri klik
kanan mouse.

1.3. MENGHAPUS KOMPONEN:


Pilih kompone dengan mouse, setelah ada gambar kotak pada komponen tekan Del pada
keyboard. Menghapus kompone atau lainnya mempunyai banyak cara salah satunya
dnegan memilih obyek yang akan dihapus dengan cara: mengaktidkan menu Select
kemudian di hapus.

1.4. MEMILIH (Select) KOMPONEN:


Gerakkan mouse diatas komponen, klik kiri mouse sambl menekan tombol Shift
keyboard. Untuk membebaskan dari pilihan ulangi sekali lagi langkah di atas.

Lebih lanjut pilihan select dapat anda lihat pada menu EDIT.

1.5. MENYIMPAN GAMBAR


Klik menu File, pilih Save atau Save as, pilih direktori file yang akan disimpan ,
selanjutnya beri nama .

2.6 MEMBUAT NETLIST


Netlist adalah file yang berisikan data komponen, footprint/patern dan jaringan yang berfungsi
untuk dijalankan di program Protel PCB untuk membuat PCB secara otomatis. File netlist berekstension net (misal: alarm.net. net, artins.net)
Langkah:
1. Setelah anda selesai membuat gambar skema dengan benar, simpan dan beri nama.
2. Klik menu File, pilih Create Netlist, akan tampak seperti pada gambar 2.8.

Gambar 2.8 Membuat file netlist

3. Kemudian klik OK, secara default output adalah format protel dan bisa dipilihke format
netlist pcb lainnya.Jika masih ada kesalahan dapat di edit lewat text editor seperti notepad.
Dari contoh gambar 2.9.

Gambar 2.9 Alarm cahaya

Di dapat file netlist: alarm.net yang isinya sbb:

10

[
U1
DIP8
741
]

[
RELAY
]
[
VCC

[
Q2

]
BC109
(
N00001
VCC-1
U1-7
)

]
[
Q1
T0-52

(
GND_1
VCC-2
VCC-1
R1-1
Q2-E
R2-1
)

]
[
R1
AXIAL0.5
10K
]
[
R2
AXIAL0.5
10K

(
N00003
VCC-2
U1-4
)

Q1-C
R2-2
RELAY-7
)
(
N00005
Q1-E
R1-2
U1-2
)
(
N00006
R2-2
R2-1
U1-3
)
(
N00009
U1-6
Q2-B
)
(
N00010
Q2-C
RELAY-8
)

(
N00004

Format file netlist:


1. Data tentang komponen:
[

Awal data

U1

kode komponen yang dipakai

DIP8

kode PATTERN IC 8 pin untuk gambar PCB

741

Tipe atau nilai komponen

Akhir data

2. Data tentang jaringan:


(

Awal jaringan

N00009

Nama Jaringan (Network ke 9)

U1-6

IC U1 pin 6 berkoneksi dengan network 9 ini

Q2-B

Transistor Q2 kaki basis berkoneksi dnegan network 9 ini

Akhir jaringan

11

2.7 DAFTAR PATTERN KOMPONEN


Ada beberapa pattern untuk pin / kaki komponen, yang berguna untuk pembuat PCB otomatis
mupun manual, berikut ini tabelnya.

Tabel 2.1 Dafter pattern kaki komponen


KOMPONEN

FOOTPRINT/PATERN

IC 4 Pin s/d IC 52 pin

DIP4 s/d DIP52

Resistor

AXIAL0.3 s/d AXIAL1.0

Diode

DIODE0.4
DIODE0.7

Kapasitor polar

POLAR0.6 s/d POLAR1.2

Kapasitor (Elco)

RB.2/.4
RB.3/.6
RB.4/.8
RB.5/1.0

Kapasitor milar/keramik

RAD0.1 s/d RAD0.4

Transistor biasa
Transistor Jengkol
dsb

TO-5
TO-3

Lebih lanjut tentang daftar patern komponen dapat anda buka pada program Protel PCB seperti
pada gambar 2.10.

12

Gambar 2.10 Pattern IC 14 pin (DIP14)

13

3. MENGGAMBAR-1
(Pengenalan Komponen)

1. Tujuan yang ingin dicapai:


a. Memahami perintah dan menu-menu yang pada protel schematic
b. Dapat menyiapkan kertas kerja dengan benar (sheet)
c. Dapat menyiapkan library komponen yang diperlukan
d. Dapat memakai wiring tools dan drawing tools dengan benar sesuai dengan fungsinya.
e. Mengenal macam-macam komponen elektronik

2. Perintah:
1. Siapkan kertas kerja (sheet) ukuran A4, Style: standard
2. Tuliaskan data pada kertas kerja (memakai Drawing Tools):
a. Drawn by: (nama anda)
b. Number: (no dokumen)
c. Title : (PENGENALAN KOMPONEN ELEKTRONIK)
d. Revision: 0.0
3. Gambarkan macam-macam komponen elektronik dari library:
a.

Device

b.

TTL

c.

Analog

d.

Intel

e.

Linier

14

4. MENGGAMBAR-2
(Menggambar elektronika analog)

1.Tujuan yang ingin dicapai:


Dapat menggambar skema elektronik dengan baik dan benar

2. Perintah :
1 Siapkan kertas kerja (sheet) ukuran A4, Style: ANSI
2. Tuliskan data document options, dgn mengeklik change:
a. Organization:.
b. Address:.
c. Title : Pemancar FM 11 watt)
d. Revision: 0.0
3. Gambarlah sesuai dengan skema elektronik yang diberikan

15

4. MENGGAMBAR-3
(Menggambar Elektronika Digital)

1.Tujuan yang ingin dicapai:


a. Dapat menggambar skema elektronik digital dengan baik dan benar
b. Dapat menggambar bus dengan benar
c. Dapat mentransfer gambar skema ke files netlist

2. Perintah :
1 Siapkan kertas kerja (sheet) ukuran A4, Style: standard
2. Tuliaskan data pada kertas kerja:
e. Drawn by: (nama anda)
f. Number: (no dokumen)
g. Title :
h. Revision: 0.0
3. Gambar sesuai dengan skema elektronik yang diberikan

16

5. MENGGAMBAR-4
(Membuat Komponen Baru/Menambah library)

1.Tujuan yang ingin dicapai:


Dapat menambah library komponen

17

6. PROTEL PCB
Pasangan dari program Protel Schematic adalah Protel PCB, itu jika memanfaatkan hasil
gambar dari Protel Schematic akan ditransfer otomatis ke gambar PCB-nya dengan bantuan
netlist yang akan dikerjakan oleh Protel schematic. Namun demikian Protel PCB dapat juga
untuk membuat PCB secara manual, tergantung pada yang kita inginkan.

6.1 Memulai Protel PCB


Untuk memulai program Protel PCB ada bebera cara:
1. Klik Start, Programs, Protel For Windows, kemudian klik Protel For Windows .
2. Klik Start, Run, browse untuk mencari file pfw.exe kemudian di jalankan.

a
b

d
e

Gambar 6.3 Tampilan Protel PCB

Penjelasan gambar 6.3.


a. Menu program
b. Icon shortcut menu
c. Lembar kerja
d. Posisi kursor di lembar kerja

18

e. Menampilkan wire layer


f. Panel keterangan fungsi icon shortcut, akan muncul saat posisi mouse berapa di atas
icon shortcut.

6.2 Mengatur Lebar Track.


Track adalah jalur listrik PCB, secara default protel memberikan lebar track 0.3 mm.
Untuk mengubah sesuai dengan kehendak kita, mislanya selebar 0.75mm sbb:
Klik menu Curent, Track, Other. Dan isikan 0.75mm

Gambar 6.4 Mengatur lebar jalur PCB

6.3 Mengatur sudut jalur Track.


Sudut jalur Track adalah sudut yang dibentuk track, ada beberapa pilihan: any (bebas),
45, 90, 90 lengkung. Untuk mengubah sesuai dengan kehendak kita, Klik menu
Options, Track Mode, klik Any Angle.

19

Gambar 6.5 Mengatur sudut jalur PCB

6.4 Untuk mengubah unit satuan (mm ke mil atau mil ke mm)
Klik menu Options, klik Toggle Units.

Gambar 6.7 Mengubah satuan mm-mil

6.5 Keterangan fungsi ICON untuk menggambar


Lihat gambar 6.8 berikut ini:

Gambar 6.8 Icon Fungsi Protel PCB


Keterangan:
a. Untuk merefresh tampilan gambar agar kelihatan baik setelah proses editing
b. Untuk menghapus obyek
c. Untuk memilih obyek (select) dengan cara blok area.
d. Untuk memindah obyek yang sudah ter-select

20

e. Unttuk membuat track lingkaran


f. Untuk memanggil pattern komponen.
g. Untuk menggambar track isi persegi
h. Untuk menggambar pad (kaki atau pin)
i. Untuk membuat text (tulisan)
j. Untuk menggambar track
k. Untuk membuat Via (lubang penghubunga untuk PCB double layer)
l. Untuk browsing pattern komponen.

21

7. MENGGAMBAR -5
(Menggambar PCB Tanpa NETLIST (MANUAL))

1. Tujuan yang ingin dicapai:


a. Dapat membuat gambar PCB dari skema elektronik secara manual
b. Dapat mengeset lebar jalur, via, pad
2. Perintah:
Kerjakan contoh gambar PCB yang akan dibuat adalah sebagai berikut:

Gambar 7.1 Contoh gambar PCB secara manual

1. Klik menu File, New.


2. Tambahkan library komponen, menu Library, Components lihat gambar 7.1.
Kemudian tambahkan file library dengan klik Add, selanjutya cari file library. Setelah itu
tutup dengan mengeklik tombol Close.

22

Gambar 7.2 Menambah library komponen

3. Klik Menu Library, Componen, kemudian klik Display untuk menampilkan gambar pattern
dan pilihlah komponen AXIAL0.4 untuk komponen Resistor (atau klik icon gambar 6.8f,
isikan Name in Library : AXIAL0.4), klik Place dan isikan data sbb:
a. Componen designator : R1
b. Comment

: 470

Kemudian bawa kursor ke tempat yang sesuai dilembar kerja PCB.


Ulangi sampai dengan R5 dengan nilai resistor masing-masing.
4. Untuk komponen Capasitor, pilih RAD0.2 Isikan data sbb:
a. Componen designator : C1
b. Comment

: 22nF

Kemudian bawa kursor ke tempat yang sesuai dilembar kerja PCB.


5. Untuk komponen Transitor, pilih TO-5, isikan data sbb:
a. Componen designator : T1
b. Comment

: BC 547B

Kemudian bawa kursor ke tempat yang sesuai dilembar kerja PCB.


6.

Untuk komponen IC 8 pin, pilih DIP8, isikan data sbb:


a. Componen designator : IC1

23

b. Comment

: NE 555

Kemudian bawa kursor ke tempat yang sesuai dilembar kerja PCB.


7. Setelah letak sesuai dengan gambar 26, buatlah track (pilih icon gambar 6.8j ) untuk
menghubungkan ke masing-maning pin yang sesuai (atur dahulu lebar track: 0.75mm,
Sudut track : bebas). Jangan lupa pilih Bottom Layer (warna biru) untuk memilih track
PCB sisi bawah.

24

8. MENGGAMBAR -6
(Menggambar PCB dengan NETLIST (OTOMATIS))

1. Tujuan yang ingin dicapai:


a. Dapat membuat gambar PCB dari skema elektronik secara otomatis
b. Dapat mengeset lebar jalur, via, pad
2. Perintah:
Kerjakan contoh gambar PCB yang akan dibuat adalah sebagai berikut:
Misalkan kita sudah mempunyai file netlist dengan nama MINIMUM.NET, maka untuk
membuat PCB dari Netlist tersebut caranya adalah sebagai berikut:
1. Buka program protel PCB
2. Klik menu File, New.
3. Klik menu Netlist, Load. Kemudian masukkan file netlist yang akan dibuat gambar PCB
nya yaitu MINIMUM.NET selanjtnya klik OK.
4. Kemudian buatlah garis KEEP OUT LAYER, pilih layer Keep Out Layer, buat garis
(track) dengan menge-klik icon gambar 6.8j.
5. Klik menu Auto, Auto Place. Kemudian berikan nama untuk gambar PCB tersebut.
6. Setelah selesai proses auto place (OPTIMIZATION = 100%), atur kembali masing-masing
letak komponen agar menjadi lebih baik sesui dengan disian anda.
Cara cepat untuk memindahkan komponen yaitu:

Tekan tombol Control keyboard (CTRL), tunjuk komponen dengan mouse dan
pindahkan sesuia keinginan anda.

Untuk merubah posisi (putar), tekan CTRL, tunjuk komponen dan tekan tombol
Spacebar keyboad.

7. Atur track, hole, via, double layer (atas-bawah) dengan membuka menu Auto, Setup Auto
Route, lihar gambar 8.1.

25

Gambar 8.1 Setup Auto Route


Misal: Routing layer: Top (vertikal), Bottom (horisontal) berarti double layer
Routing grid (0,508mm), Track width (0,25 mm)
Via size (1,9 mm)

8. Atur track mode lewat menu Options, Track mode, kemudian pilih salah satu.
9. Kemudian untuk membuat jalur berdasarkan file netlist, klik menu Auto, Auto Route,
kemudian pilih:
a. All, jika ingin semua
b. Net, jika per-jaringan
c. Componen, jika antar komponen, dsb.

26

Contoh pattern pcb

T-3

TO-39

27

ANT
+12 VCC
D

R1
100K

C6
33uF/35V

AV IN

R5
150

IN4148

C1
C16
100nF
100nF

RFC
75uH

GND

L3
6L (0,5cm)

L4
7L (0,5 cm)

L5
8L (0,5cm)

L7
10L

C
GND
C5
10uF/35V
C2
15pF

DVaractor
MV2205

C17
100nF

L2
4L

GND

R2
6,8K

GND

C9

C10

C11

C12

10/33pF

20pF

25pF

47pF

L6

L8

2L

3L

C14

100pF

C4
Q1

Q2

Q3

C930

C710

Q4

BNC

Q5

25pF
C1215
L1
6L

C7
33pF

C2053

C15
100pF

C1971

C3
10pF

C13
100pF
R3
5,6K

C8
100pF

R4
1K

R6
1K

R7
220

R8
220

R9
100 (dililit email)

GND
TEKNIK ELEKTRO UMP
KAMPUS DUKUH WALUH
PO BOX 202
PURWOKERTO
PEMANCAR FM 15 WATT

Size
A4

FCSM No.

Scale

DWG No.
1

Rev
0
Sheet
1 of 1

U4

U2
Sensor Pintu
Sensor Jendela

Sirine
Lampu Tengah

1
2
3
4
5
6
7
8
13
12
15
14

31
C1
33pF

19
18

C2
33pF

9
17
16

4,43Mhz
XTAL

P10
P11
P12
P13
P14
P15
P16
P17

P00
P01
P02
P03
P04
P05
P06
P07

INT1
INT0

P20
P21
P22
P23
P24
P25
P26
P27

T1
T0
EA/VP

D0
D1
D2
D3
D4
D5
D6
D7

39
38
37
36
35
34
33
32
21
22
23
24
25
26
27
28

D0
D1
D2
D3
D4
D5
D6
D7

3
4
7
8
13
14
17
18
1
11

A8
A9
A10
A11
A12
A13
A14
A15

Q0
Q1
Q2
Q3
Q4
Q5
Q6
Q7

OE
LE
74LS373

RD
WR

2
5
6
9
12
15
16
19
A8
A9
A10
A11
A12

10
9
8
7
6
5
4
3
25
24
21
23
2
20
22
27
1

X1
X2
RESET

U6

U5

D0
D1
D2
D3
D4
D5
D6
D7

A0
A1
A2
A3
A4
A5
A6
A7
A8
A9
A10
A11
A12

D0
D1
D2
D3
D4
D5
D6
D7

D0
D1
D2
D3
D4
D5
D6
D7

11
12
13
15
16
17
18
19

34
33
32
31
30
29
28
27
5
36
9
8
35
6

CE
OE
PGM
VPP

J2

D0
D1
D2
D3
D4
D5
D6
D7

PA0
PA1
PA2
PA3
PA4
PA5
PA6
PA7

RD
WR
A0
A1
RESET
CS

PB0
PB1
PB2
PB3
PB4
PB5
PB6
PB7
PC0
PC1
PC2
PC3
PC4
PC5
PC6
PC7

2764
RXD
TXD
ALE/P
PSEN

10
11
30
29

+5V

8031
+5V

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

4
3
2
1
40
39
38
37
18
19
20
21
22
23
24
25

16PIN
J3

14
15
16
17
13
12
11
10

1
2
3
4
5
6
7
8

8255
8PIN
U3
A13 1
A14 2
A15 3

B
R1
10K

4
5
6

U1A
1

A
B
C

E1
E2
E3

Y0
Y1
Y2
Y3
Y4
Y5
Y6
Y7

15
14
13
12
11
10
9
7

74LS138

7414
+5V

C3
10uF/16V

S1
SW-PB

Title
Size
A4
Date:
File:
1

SISTEM MINIMUM 8031


Number

A
Revision

20022003-8031
17-Mar-2008
D:\PCBSCH\SKEMA803.SCH

0
Sheet 1of 1
Drawn By:
Arif JT
4