Anda di halaman 1dari 34

MODUL

ALTIUM DESIGNER

KADERISASI URO
2016

UNIT ROBOTIKA
INSTITUT TEKNOLOGI BANDUNG

SCHEMATIC & PCB

ALTIUM DESIGNER

MODUL PANDUAN DAN


WORKSHOP

DAFTAR ISI
HALAMAN JUDUL
DAFTAR ISI
1. MODUL PANDUAN ALTIUM DESIGNER
a. Sekilas tentang Altium Designer
b. Memulai Altium Designer 15
c. Membuat Project Baru dan Fasilitas Umum
Prosedur Setup

Menambahkan PART pada File Skematik


Konversi Skematik ke PCB dan Routing
d. Tips atau Hint

2. WORKSHOP
a. Desain PCB Sensor Garis (6 Sensor)
b. Desain PCB Shield Arduino

Kaderisasi URO
Sekilas tentang Altium Designer
Altium designer merupakan salah satu software CAD (Computer Aided Design) gambar 2 dimensi dan gambar 3
dimensi standar industri elektronik, software terpadu ini menawarkan perancangan atau design sistem
elektronik pada circuit board. Altium designer menyatukan berbagai aspek dari sebuah produk elektronik dalam
suatu sistem terpadu.
Versi terdahulu dari software ini lebih dikenal dengan Protel. Software ini membantu para engineer elektronika
untuk merancang sebuah PCB (printed circuit board) dari rangkaian yang sederhana maupun rangkaian yang
sangat kompleks, karena software ini juga mendukung untuk perancangan multi-layer PCB, dengan dukungan
simulasi dan hasilnya dapat ditampilkan dalam model 3D.

Memulai Altium Designer 15


1. Buka Altium Designer 2015 dengan Start > All Programs > Altium > Altium Designer atau DXP.exe

Kaderisasi URO
2. Akan muncul tampilan seperti berikut

3. Pada bagian kiri terdapat jendela files. Jendela dapat diganti-ganti sesuai kebutuhan. Jendela project dapat
dimunculkan dengan mengklik View > Workspace Panels > System > Projects

4. Pastikan Altium Designer 15 sudah terinstall dngan baik. Sehingga fitur fiturnya telah ada.

Kaderisasi URO
Membuat Project Baru dan Fasilitas Altium
Prosedur Setup
1. Membuka aplikas Altium Designer seperti pada langkah sebelumnya.
2. Membuat PCB project baru. File > New > Project

3. Lalu akan muncul jendela baru. Pilih PCB Project dan ganti nama project sesuai keinginan. Lalu klik Ok

4. Tambahkan file schematic dan file PCB pada project yang telah dibuat simpan pada satu direktori yang
sama semua file dan project tersebut.
a. klik kanan pada project > Add New to Project > Schematic
b. klik kanan pada project > Add New to Project > PCB

Kaderisasi URO

5. Simpan new project pada direktori yang sama untuk memudahkan pengaksesan data pada tahap
selanjutnya . Klik kanan the project > Save Project. Simpan lah dalam satu folder.

6. Ubah ukuran kertas dari default A ke Letter dan set up back up otomatis dengan cara
a. DXP > Preferences > Schematic > General > Default Blank Sheet Size > Letter
b. DXP > Preferences > System > Data Management > Backup > Check the Auto save every: box i. Untuk
mengantisipasi bila program berhenti/not responding di tengah jalan, system akan menyimpan file yang
akan kita modifikasi secara otomatis selama perioda yang telah diatur

Kaderisasi URO
Menambahkan PART pada file skematik
1. Libraries ialah tempat dimana part dapat ditemukan. Jika belum tersedia tab Libraries, Klik System pada
kanan bawah tampilan kemudian klik tombol Libraries.
2. Library akan tersusun secara otomatis berdasarkan part apa yang baru digunakan oleh pengguna software
ini.
3. Tambahkan beberapa Libraries sendiri. Caranya buka tab Libraries lalu klik Libraries. Akan muncul wizard,
pilih tab Installed kemudian klik Install.. > Install from File.. dan cari file library yang ingin ditambahkan. Kali
ini tambahkan file library agfa others component dan Motorolla analog comparator, minta lah pada
panitia jika belum diberikan. File tersebut berada pada folder Library tambahan didalam folder Altium
Designer yang telah didownload dari link yang diberikan panitia.

4. Tempatkan Komponen,
caranya:
b. Buka Libraries tab
c. Pilih
Miscellaneous
Devices library
d. Ketik Res3 ke dalam
textbox drop down pada list
library
e. Klik tombol Place Res3
f. kemudian kursor secara
otomatis akan membawa
part,
tempatkan
pada
tempat dan posisi yang
diinginkan, tekan space
untuk merubah orientasi
part
g. klik kanan untuk menempatkannya

Kaderisasi URO
Pada tutorial ini akan membuat rangkaian pada training 1, yakni penggunaan komparator.

5. Ikuti langkah diatas (penempatan komponen) untuk memperoleh komponen berikut :


Dari Miscelanous Device library :
(1) res1
Agfa other component :

(2) trimpot duduk

(1) LED sedang


Motorolla analog comparator :

(1) LM393N

Catatan: perbedaan antara LM393N dan LM393H hanya pada footprint yang kan dicetak pada PCB nantinya.
Perhatikan : LM393N telah di cerminkan terhadap posisi mulanya, Rotation dapat dilakukan dengan menekan
tombol space sedangkan pencerminan atau mirroring yaitu dengan klik ganda pada objek lalu checklist
Mirrored, lalu klik Ok
6. Sekarang waktunya untuk menghubungkan tiap part (wiring), dapat dilakukan dengan klik icon Place Wire
di toolbar atau pilih Place > Wire.
a. tempatkan kursor hingga terbentuk tanda X pada pin yang akan dihubungkan klik kemudian hubungkan
dengan pin pada part lan yang akan dihubungkan, temui tanda X lagi kemudian klik pada pin tujuan

Kaderisasi URO
7. Sekarang tinggal membuat referensi tegangan sumber
a. Klik VCC Power Port dan tempatkan sebagaimana gambar berikut. Port ini akan diberi nama VCC . Untuk
mengganti nama port maka tinggal double klik port kemudian muncul kotak dialog net kemudian ketikkan
nama port yang diinginkan.

8. Kita juga bisa menghubungkan antar part dengan memanfaatkan fasilitas net, tiap net dapat diandaikan
sebagai 1 nodal rangkaian jadi dengan fasilitas ini kita dapat menghubungkan 2 part yang berjauhan tanpa
harus menggunakan wire
a. pilih Place > Net Label.
b. gunakan spacebar untuk merotasinya
9. Sekarang kita akan menamai setiap komponen dalam rangkaian yang akan kita buat. Double klik pada
tanda ? di setiap rangkaian kemudian beri nama sesuai kegunaannya perhatikan nama komponen tidak
boleh sama antara satu dengan lainnya
Cara termudahnya ialah:
1. Tools > Annotate Schematics Quietly
2. Klik OK
3. Ini secara otomatis akan menamai seluruh komponen
Gambar skematik setelah wiring, pemberian catu daya, dan penamaan komponen

10. Kemudian Save file

Kaderisasi URO

Konversi Skematik ke PCB dan Routing

11. Sekarang kita bisa mengupdete to PCB file


a. Design > Update PCB Document nameOfProject.PcbDoc
b. Klik Validate Changes, periksa apakah semua bagian telah tervalidasi kemudian jika masih belum
tervalidasi lakukan pemeriksaan kembali pada rangkaian apakan ada bagian yang masih belum
terhubung dengan melihat bagian yang diberi tanda x
c. Klik Execute Changes,
d. Close update window

12. File pcb akan secara otomatis terbuka; pindahkan semua bagian rangkaian pada bagian hitam dengan
menggeser background coklat. Klik View > Fit Board untuk melihat board secara jelas
13. Jika footprint yang terlihat terlalu besar atau tidak sesuai dengan koimponen yang kita punya kita dapat
menggantinya dengan mengganti part pada file skematik kemudian mengupdate ulang pcb file
Kita kemudian akan merouting sebelum merouting ada tips sebelum merouting untuk mempermudah prose
merouting :
Dekatkan komponen komponen yang seharusnya dekat sedapat mungkin tidak ada bagian yang terpotong
antara garis 1 dengan yang lainnya
14. Untuk melakukan routing rangkaian pada file PCB dapat dilakukan dengan dua cara yaitu:
a. Dengan menggunakan fasilitas Autoroute
Cara ini dapat dilakukan dengan didahului dengan melakukan pengesetan pada rule wizard beberapa
fasilitas yang ddapat digunakan ialah :
Width yaitu untuk melakukan pengesetan terhadap lebar lintasan yang akan dibuat. Catatan: salah
satu contoh penggunaan pengaturan width ialah biasanya untuk memperlebar lintasan VCC dan
Ground untuk komponen hal ini dimaksudkan untuk memperkecil hambatan pada komponen power
rangkaian.
Clearance yaitu pengaturan jarak aman antar routing dapat dilakukan hal ini akan mengantisipasi
terjadinya alur arus kearah yang tidak diingikan pada proses penyolderan berikutnya
Selain itu rule wizard juga dapat menetukan prioritas routing. Kita dapat mengatur lebar lintasan yang
kita inginkan dengan membuat query tertentu. Misal pada tutorial ini pada width akan diatur nilai lebar
lintasan pada net GND, VCCl menjadi min 40mil, preffer 40 mill, max 40 mil sedangkan lintasan lainnya
min 30mil, preffer 30mil, max 30mil kemudian klik advance > query Builder

Kaderisasi URO

Kaderisasi URO
Kemudian seperti membuat pernyataan logika biasa dengan syntax yang sudah disediakan lakukan
pengesetan net mana yang akan kita atur lebar routing nya. Kotak dialog query builder sebagai berikut

Setelah semua pengturan diakukan terhadap masing masing net yang akan di route, kemudian dilakukan
auto route Auto Route > All... .banyak type autoroute yang dapat dilakukan dalam hal ini dilakukan
Default 2 Layer Board : Default strategy for routing two-layer boards
Maka yang dihasilkan sebagai berikut

Kaderisasi URO
b. Dengan cara manual
Juga diawali dengan melakukan pengesetan rule namun dengan manual kita dapat memastikan bahwa
semua bagian telah di routing terutama untuk rangkaian yang lebih complex, routing manual dapat
dilakukan dengan menggunakan fasilitas pada toolbar

Dimana yang sering digunakan ialah symbol routing paling kanan namun ingat perlakuan routing manual
secara umum dilakukan pada bottom layer oleh karenanya set layer pada kondisi botto mayer sebagai
berikut
Untuk memulai routing dapat dengan memilih tool
lalu hubungkan antar pin yang
perlu tersambung
15. Untuk melihat struktur 3 dimensi dari cetakan dapat digunakan fasilitas view > switch to3D
16. Sekarang ialah waktunya manufaktur yaitu. File > Fabrication Outputs > Gerber Files
a. pilih Layers pada dialog box dan klik Plot Layers
b. Pilih Used On
c. Klik OK untuk membuat Gerber files

17. Sekarang dapat dibuat lubang drill dengan


a. File > Fabrication Outputs > NC Drill Files
b. klik OK.

Kaderisasi URO
18. Jika kita ingikan rangkaian yang kita buat digunakan untuk membuat rangkaian lain kita dapat
mengintegrasikan menjadi satu library yaitu dengan Design > Make Integrated Library
Maka library akan segera dibuat dengan nama ProjectName.IntLib

Tips atau Hint


1. Cara cepat untuk menyimpan semua file dalam project. File > Save All
2. a. View > Fit Document untuk membuat seluruh komponen terlihat memenuhi layar tampilan pada file pcb
b. View > Fit All Objects untuk melakukan hal yang sama pada file skematik
3. Page Up dan Page Down dapat digunakan untuk zoom in zoom out pada kedua file (pcb maupun skematik)
4. Untuk memilih komponen yang sama pada satu file dapat digunakan tab PCB FILTER
a. Pilih PCB filter
b. klik Find items matching these criteria
c. ketik isDesignator dalam textbox.
d. klik Apply
Ini adalah sebagian kecil dari fasilitas software ini, kami harapkan cakru 8 URO dapat mempelajari secara
mandiri berbagai fasilitas lain dalam software ini, baik melalui internet atau buku panduan.

Kaderisasi URO
Desain PCB Sensor Garis (6 Sensor)
1. Buka Software Altium Designer
2. Buat Project PCB baru :

Kaderisasi URO
3. Tambahkan file PCB dan skematik pada PCB project

Kaderisasi URO
4. Save semua file dalam satu direktori (folder) save all

Kaderisasi URO
5. Tempatkan Komponen berikut pada skematik
Dari Miscelanous Device library : 12 x Res1
Dari Miscellaneous Connectors library : 1 x Header 5x2 (konektor)
Dari agfa others component library : 12 x LED sedang (6 sebagai LED, 6 sebagai photodioda)

Kaderisasi URO

6. Buat rangkaian seperti dibawah hubungkan dengan tools wiring dan net. Dan juga ganti nama komponen

Kaderisasi URO
7. Untuk menamai seluruh komponen dengan cepat lakukan hal berikut: pilih tools > annotate schematics

Checklist

Kemudian pilih update change list>accept

Kaderisasi URO
8. Update desain skematik kalian dalam pcbdoc dengan melakukan langkah berikut :

9. Pilih validate change > execute change bila masih ada tanda silang periksa lagi rangkaian,

Kaderisasi URO
10. Susunlah rangkaian untuk memudahkan routing
11. Ubahlah layer menjadi Bottom Layer
12. Jika ingin mengukur jarak antar komponen agar rapi dapat menggunakan dimension linear. Caranya Place
> Dimension > Linear

Dimension

Kaderisasi URO

Atur lah serapi mungkin dan agar fungsi sensor berjalan dengan baik

Kaderisasi URO
13. Tentukan aturan routing sesuai keinginan. Ingat net GND dan VCC diatur agar memiliki lebar yang lebih
besar

Coba buat pengaturan dalam bentuk query untuk memudahkan lakukan langkah dibawah:

Kaderisasi URO

Pengaturan diatas dibuat untuk menandakan net VCC dan GND diprioritaskan memiliki lebar jalur 30
mil dan akan di route pada prioritas awal sedangkan net lain akan mengikuti aturan default

14. Dengan menggunakan autoroute memberikan hasil sebagai berikut.

Kaderisasi URO
15. Jika ingin lebih fleksibel dan rapi maka dapat dengan cara routing manual. Contohnya saja seperti berikut :

16. Kemudian atur bentuk board sesuai kebutuhan dengan masuk ke Planning board mode. Atau dengan
menekan tombol 1.

Kaderisasi URO
Kemudian pilih Design > Edit Board Shape

Kaderisasi URO
Jika ingin membentuk board menjadi bentuk yang lebih fleksibel, yaitu dengan Design > Redefine board shape

Contoh board yang telah di rubah bentuknya :

Kemudian berilah lubang untuk memasang spacer/ baud pada board sensor.
Kira-kira seperti itulah penjelasan singkat untuk workshop Sensor Garis ini.

Kaderisasi URO
Desain Shield Arduino
1.
2.

Buka Software Altium Designer


Buat Project PCB baru :

Kaderisasi URO
3.

Tambahkan file PCB dan skematik pada PCB project

Kaderisasi URO
4.

Save semua file dalam satu direktori (folder) save all

Kaderisasi URO

5.

Tempatkan Komponen berikut pada skematik


Dari Miscelanous Device library : 1 x Res1, 1 x Inductor iron (Fuse)
Dari Miscellaneous Connectors library : 1xHeader 16 (LCD), 1 x Header 5x2 (konektor sensor), 2 x header2
Dari agfa others component library : 1 x pushbutton, 1 x LED sedang (indikator), 1 x Trimpot duduk
Dari HeaderUNO : 2 x POWER_UNO, 2 x AD, 2 x IOH, 2 x IOL

6.

Hubungkan semua komponen seperti gambar dibawah. Kemudian routing sebaik mungkin

Kaderisasi URO
Untuk penataan header, sesuaikan dengan dimensi dibawah. Akan tetapi diingat bahwa posisi dibawah perlu
di mirror untuk membuat shield.
Dimensi ARDUINO UNO sebagai referensi penataan shield yang akan dibuat :

Anda mungkin juga menyukai