Anda di halaman 1dari 42

Home Cisco routing Pengertian Routing Statik Dan Routing Dinamik

Pengertian Routing Statik Dan Routing


Dinamik
By Fiqih Nuryansyah on 11:20 AM

Static routing (Routing Statis) adalah sebuah router yang memiliki tabel routing statik
yang di setting secara manual oleh para administrator jaringan. Routing static
pengaturan routing paling sederhana yang dapat dilakukan pada jaringan komputer.
Menggunakan routing statik murni dalam sebuah jaringan berarti mengisi setiap entri
dalam forwarding table di setiap router yang berada di jaringan tersebut
Routing Dynamic (Routing Dinamik) merupakan type Routing dimana Router dapat
mempelajari sendiri Rute yang terbaik yang akan ditempuhnya untuk meneruskan paket
dari sebuah network ke network lainnya. Administrator tidak menentukan rute yang
harus ditempuh oleh paket-paket tersebut. Administrator hanya menentukan bagaimana
cara router mempelajari paket, dan kemudian router mempelajarinya sendiri. Rute pada
dynamic routing berubah, sesuai dengan pelajaran yang didapatkan oleh router.
Contoh Protokol Routing Dinamik
1. RIP (Routing Information Protocol)
2. IGRP (Internal Gateway Routing Protokol)
3. OSPF (Open Shortest Path First)

4. EIGRP (Enhanced Internal Gateway Routing Protokol)


5. BGP (Border Gateway Protokol) "Hanya pada router cisco"
Berikut ini tabel perbedaan yang spesifik untuk kedua jenis routing:
Routing Statik
Berfungsi pada protocol IP
Router tidak dapat
membagi informasi routing
Routing table dibuat dan
dihapus secara manual
Tidak menggunakan routig
protocol
Microsoft mendukung
multihomed system seperti
router
Cisco routing

Routing Dinamik
Berfungsi pada inter-routing
protocol
Router membagi informasi
routing secara otomatis
Routing table dibuat dan
dihapus secara otomatis
Terdapat routing protocol,
seperti RIP atau OSPF
Microsoft mendukung RIP
untuk IP dan IPX/SPX

Static Routing dan Dynamic Routing


30 November 2014
Assalamualaikum
Seperti yang sudah saya janjikan di postingan sebelumnya. Saya akan membahas antara static
routing, dan dynamic routing.
A. Static Routing
1. Pengertian static routing
Static routing adalah jenis routing yang dilakukan admin/pengelola jaringan untuk
mengkonfigurasi informasi tentang jaringan yang dituju secara manual.
2. Ciri-ciri static routing
a) jalur spesifik ditentukan oleh admin jaringan
b) pengisian tabel routing dilakukan secara manual oleh admin jaringan
c) biasanya digunakan untuk jaringan berskala kecil
d) Rute tidak berubah, kecuali jika diubah secara manual oleh administrator.
3. Cara kerja static routing
a) Konfigurasi router yang dilakukan oleh admin jaringan
b) Router melakukan routing berdasarkan informasi yang diterima dari tabel routing
c) Admin Jaringan menggunakan
perintah ip route secara manual untuk konfigurasi router dengan routing statis dan routing statis
berguna untuk melewatkan paket data yang ada pada jaringan.
4. Parameter yang ada pada routing
a) Destination, adalah alat tujuan dan network mask dan biasanya diisi dengan 0.0.0.0/0 untuk
semua jaringan
b) Gateway adalah datagram yang dapat dicapai melalui antarmuka
c) Pref. Source adalah alamat tujuan
paket dan meninggalkan roter melalui alamat IP
d) Distance (0-255) adalah jarak administrator jaringan dari router
5. Keuntungan routing static
a) Meringankan kinerja processor router, karena router hanya mengupdate sekali saja ip table
yang ada. (pada saat di konfigurasi)

b) Tidak ada bandwidth yang digunakan untuk pertukaran informasi dari tabel isi routing pada
saat pengiriman paket
c) Routing statis lebih aman dibandingkan routing dinamis, karena static router menyediakan
control penuh pada routing tabelnya
d) Routing Statis kebal dari segala usaha hacker untuk men-spoof dengan tujuan membajak
traffik.
e) Analisa kesalahan pada topologi jaringan lebih cepat diketahui.
f) Pengiriman paket data yang lebih cepat karena jalur-jalur (path) sudah di ketahui terlebih
dahulu.
6. Kerugian routing static
a) Administrator jaringan harus mengetahui semua informasi dari masing-masing router yang
digunakan
b) Hanya dapat digunakan untuk jaringan berskala kecil
c) Admisnistrasinya cukup rumit dibanding routing dinamis, terlebih jika banyak router yang
harus dikonfigurasi secara manual
d) Rentan terhadap kesalahan saat entri data routing statis yang dilakukan secara manual.
e) Selalu menggunakan rute yang sama yang kemungkinan bukan rute terbaik.
f) Jika route berubah, static router harus diupdate secara manual.
g) Konfigurasi static routing memiliki
kompleksitas yang bergantung pada jumlah network yang terhubung
h) Jumlah gateway terbatas
B. Dynamic Routing
1. Pengertian routing dinamik
Routing dinamik adalah sebuah router yang memiliki dan membuat tabel routing secara
otomatis, dengan mendengarkan lalu lintas jaringan dan juga dengan saling berhubungan antara
router lainnya. Protokol routing mengatur router router sehingga dapat berkomunikasi satu
dengan yang lain dan saling memberikan informasi satu dengan yang lain dan saling
memberikan informasi routing yang dapat mengubah isi forwarding table, tergantung keadaan
jaringannya. Dengan cara ini, router- router mengetahui keadaan jaringan yang terakhir dan
mampu meneruskan data ke arah yang benar. Dengan kata lain, routing dinamik adalah proses
pengisian data routing di table routing secara otomatis. Dynamic router mempelajari sendiri Rute
yang terbaik yang akan ditempuhnya untuk meneruskan paket dari sebuah network ke network
lainnya. Administrator tidak menentukan rute yang harus ditempuh oleh paket-paket tersebut.
Administrator hanya menentukan bagaimana cara router mempelajari paket, dan kemudian router
mempelajarinya sendiri. Rute pada dynamic routing berubah, sesuai dengan pelajaran yang
didapatkan oleh router.
2. Ciri-Ciri routing dinamik
a) Router berbagi informasi routing secara otomatis
b) Jumlah gateway sangat banyak.
c) Routing tabel dibuat secara dinamik.
d) Membutuhkan protokol routing
seperti RIP atau OSPF

3. Macam-macam routing dinamik


a) RIP (Routing Information Protocol)
b)IGRP (Internal Gateway Routing Protokol)
c) OSPF (Open Shortest Path First)
d) EIGRP (Enhanced Internal Gateway Routing Protokol)
e) BGP (Border Gateway Protokol)
4. Kelebihan routing dinamik
a) hanya mengenalkan alamat yang terhubung langsung dengan routernya (kaki-kakinya).
b) Tidak perlu mengetahui semua alamat network yang ada.
c) Bila terjadi penambahan suatu network baru tidak perlu semua router mengkonfigurasi. Hanya
router-router yang
berkaitan.
5. Kekurangan routing dinamik
a) beban kerja router lebih berat karena selalu memperbarui ip table pada setiap waktu tertentu.
b) kecepatan pengenalan dan kelengkapan ip table terbilang lama karena router membroadcast ke
semua router sampai ada yang cocok. Sehingga setelah konfigurasi
harus menunggu beberapa saat agar setiap router mendapat semua alamat ip yang ada.
C. Perbedaan Static Routing dan Dynamic Routing
1. Routing statik berfungsi pada protokol IP. Sedangkan routing dinamik Berfungsi pada interrouting protocol.
2. Pada routing statik, router tidak dapat membagi informasi routing. Sedangkan pada routing
dinamik, router membagi informasi routing secara otomatis.
3. Routing tabel di routing statik dibuat dan dihapus secara manual. Sedangkan pada routing
dinamik, routing tabel dibuat dan dihapus secara dinamis oleh router.
4. Routing statik tidak menggunakan routing protocol. Sedangkan pada routing dinamik, terdapat
routing
protocol, seperti RIP atau OSPF.
5. Routing statik, Microsoft mendukung multihomed system seperti router. Sedangkan routing
dinamik, Microsoft mendukung RIP untuk IP dan IPX/SPX.
Sumber:
tutorial-mj.blogspot.com/2012/12/pengertian-kelemahan-dan-kelebihan.html?m=1
https://benricop.wordpress.com/2010/10/28/perbedaan-statik-routing-dan-dynamic-routing/
juhdinpolnes.blogspot.com/p/routing-statik-dan-dinamik.html?m=1
amunz.blogspot.com/2011/08/keuntungan-dan-kerugian-routing-static.html?m=1
Sekian dulu dari saya. Semoga bermanfaat.
Wassalamualaikum

KONFIGURASI ROUTING DINAMIK DENGAN


PACKET TRACER
Kali ini saya akan menjelaskan tentang bagaimana caranya membuat Router Dinamik, saya akan
kasih contoh seperti pada router static yang saya buat di tutorial sebelumnya hanya saja ini
berbeda pada konfiguasi Routingnya saja. Pertama yang harus di buat adalah Buat 3 buah router,
3 buah switch, dan 2 PC pada masing masing router. Seperti contoh gambar di bawah ini:

Technical Order

Router ke router : Serial

Router ke switch : FastEthernet (boleh pake Ethernet tapi lebih cepat FastEthernet)

Switch ke PC : FastEthernet

Konektor yang warna merah menggunakan Serial DTE

(recommended) Sebaiknya menggunakan Routers yang Generic (Router-PT) agar kita


tidak perlu menambahkan modul pada komponen router.

(recommended) Untuk Switches gunakan Generic (Switch-PT)

Konfigurasi ini menggunakan CLI (command-line interface)

== KONFIGURASI ROUTER ==
Sterling
Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config-if)#no shutdown
Router(config-if)#interface serial 3/0
Router(config-if)#ip address 172.16.2.1.255.255.255.0
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 172.16.1.1. 255.255.255.0
Hoboken
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config-if)#no shutdown
Router(config-if)#interface serial 2/0
Router(config-if)#ip address 172.16.2.2.255.255.255.0
Router(config-if)#interface serial 3/0
Router(config-if)#ip address 172.16.4.1.255.255.255.0
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 172.16.3.1.255.255.255.0
Waycross
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config-if)#no shutdown

Router(config-if)#interface serial 2/0


Router(config-if)#ip address 172.16.4.2.255.255.255.0
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 172.16.5.1.255.255.255.0

== KONFIGURASI PC ==
STERLING
PC 0 : IP 172.16.1.2GW 172.16.1.1
PC 1 : IP 172.16.1.3 GW 172.16.1.1
HOBOKEN
PC 2 : IP 172.16.3.2GW 172.16.3.1
PC 3 : IP 172.16.3.3 GW 172.16.3.1
WAYCROSS
PC 4 : IP 172.16.5.2 GW 172.16.5.1
PC 5 : IP 172.16.5.3 GW 172.16.5.1

== KONFIGURASI ROUTER DINAMIK ==


Pada konfigurasi router Dinamik, Tambahkan semua network yang telah diatur pada masing
masing router. Misalnya tambahkan semua network pada Sterling ke dalam settingan Router
RIP pada Sterling. Untuk lebih jelasnya lihat konfigurasi di bawah ini:
Sterling
Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 172.16.2.0
Router(config-router)#network 172.16.1.0
Hoboken
Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 172.16.2.0

Router(config-router)#network 172.16.4.0
Router(config-router)#network 172.16.3.0
Waycross
Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 172.16.4.0
Router(config-router)#network 172.16.5.0
Semua sudah terkonfigurasi,setelah itu kita ping pada masing-masing PC/Router,seperti pada
contoh di bawah ini.

Menggabungkan 2 group yang sudah kita buat (static & dinamik) menjadi 1 group jaringan
dengan wireless

ROUTING STATIK DAN DINAMIK


Routing Statik dan Dinamik
Secara umum mekanisme koordinasi routing dapat dibagi menjadi dua, yaitu: routing statik dan
routing dinamik.
Pada routing statik, entri-entri dalam forwarding table router diisi dan dihapus secara manual,
sedangkan pada routing dinamik perubahan dilakukan otomatis melalui protokol routing.
Routing statik adalah pengaturan routing paling sederhana yang dapat dilakukan pada jaringan
komputer. Menggunakan routing statik murni dalam sebuah jaringan berarti mengisi setiap entri
dalam forwarding table di setiap router yang berada di jaringan tersebut.
Namun Anda tentu dapat membayangkan bagaimana jika harus melengkapi forwarding table di
setiap router yang jumlahnya tidak sedikit dalam jaringan yang besar. Apalagi jika Anda
ditugaskan untuk mengisi entri-entri di seluruh router di Internet yang jumlahnya banyak sekali
dan terus bertambah setiap hari. Tentu repot sekali!
Routing dinamik adalah cara yang digunakan untuk melepaskan kewajiban mengisi entri-entri
forwarding table secara manual. Protokol routing mengatur router-router sehingga dapat
berkomunikasi satu dengan yang lain dan saling memberikan informasi routing yang dapat
mengubah isi forwarding table, tergantung keadaan jaringannya. Dengan cara ini, router-router
mengetahui keadaan jaringan yang terakhir dan mampu meneruskan datagram ke arah yang
benar. Dengan kata lain, routing dinamik adalah proses pengisian data routing di table routing
secara otomatis.
Berikut ini tabel perbedaan yang spesifik untuk kedua jenis routing.
Perbedaan routing statik dan routing dinamik
Routing

Routing Dinamik

Statik
Berfungsi pada protokol IP
Berfungsi pada inter-routing protocol
Router tidak dapat membagi Router membagi informasi routing secara
informasi routing
otomatis
Routing tabel dibuat dan dihapus Routing tabel dibuat dan dihapus secara
secara manual
Tidak
menggunakan
protocol
Microsoft

dinamis oleh router


routing Terdapat routing protocol, seperti RIP

atau OSPF
mendukung Microsoft mendukung RIP untuk IP dan

multihomed system seperti router IPX/SPX


Contoh
Routing

protokol

Routinginformationprotkol(RIP)
Interiorgatewayroutingprotkol(IGRP)
Enhancedinteriorgatewayroutingprotkol(EIGRP)
Openshortestpathfirst(OSPF)
Routedprotkoldigunakanuntuktrafikuserlangsung.
Routedprotkolmenyediakaninformasiuntukmelewatkanpaketyangakanditeruskannyadari stau host
kehostyanglaiberdasarkanalamatnya.
ContohRoutedprotokol

-InternetProtokol(IP)
-Internetpaketexchange(IPX).
Informasiyangdibutuhkandalamrouting

-Alamattujuan/destinationaddress.
-Mengenalsumberinformasi
-Menemukanrute
-Pemilihan

rute

-Menjagainformasirouting.
Tabel routing : Sebuah router mempelajari informasi routing dari mana sumber dan tujuannya

yang kemudian di tempatkan pada tabel routing. Router akan berpatokan pada tabel ini. untuk
memberi tahu port yang akan digunakan untuk meneruskan paket ke alamat tujuan.

Distance Vector Routing


RIP dan IGRP keduanya menggunakan metoda distance vector routing, walaupun IGRP
menawarkan banyak pengembangan dari RIP.
Memahami Routing - Hop Count
Pada contoh berikut, kita menggunakan hop count sebagai suatu metric cost untuk mengetahui
network. Router #1 hanya mengetahui network-2 yang terhubung kepada router tersebut saja
yaitu network A dan B. Dan masing-2 network mempunyai harga 1 hop count untuk melintas
dari satu network A ke B atau sebaliknya. Pengetahuan ini di broadcast kepada router-2
tetangganya, sehingga router #2 yang hanya mengetahui network B dan C menambah dalam
tabelnya dengan pengetahuan network A yaitu 2 hop count.
Router #2 mengetahui network yang terhubung kepadanya saja yaitu network B dan C, dan
membroadcast pengetahuannya kepada router #3 dan router #1. Router #1 menambah dalam
tabelnya network C yang berharga 2 hop count. Router #3 yang hanya mengetahui network C
dan D menambah dalam tabelnya network B yang berharga 2 hop count. Begitu seterusnya
router-2 memperlajari routing information dari router disebelahnya sehingga bisa digambarkan
seperti pada table dibawah berikut ini setelah semua router mencapai convergence.
Router 1
Router 2
Router 3
Network A = 1 hop
Network A = 2 hop
Network A = 3 hop
Network B = 1 hop
Network B = 1 hop
Network B = 2 hop
Network C = 2 hop
Network C = 1 hop
Network C = 1 hop
Network D = 3 hop
Network D = 2 hop
Network D = 1 hop
Distance Vector routing mempunyai prinsip-2 berikut:

Router mengirim update hanya kepada router tetangganya

Router mengirim semua routing table yang diketahuinya kepada router tetangganya

Table ini dikirim dengan interval waktu tertentu, dimana setiap router dikonfigure dengan
interval update masing-2

Router memodifikasi tabelnya berdasarkan informasi yang diterima dari router


teangganya.

Karena router-2 menggunakan metoda distance vector routing dalam mengirim informasi table
routing secara keseluruhan dengan interval waktu yang tertentu, mereka ini rentan terhadap suatu
kondisi yang disebut routing loop (juga disebut sebagai kondisi count-to-infinity). Seperti halnya
dengan bridging loop pada STP, routing loop terjadi jika dua router berbagi informasi yang
berbeda.
Metoda-2 berikut dapat digunakan untuk meminimalkan efek dari routing loop:

Split horizon, metoda split ini memungkinkan router melakukan trackin terhadap datang
nya informasi dari router mana. Router tidak melaporkan informasi routing kepada router
pada jalur yang sama. Dengan kata lain router tidak melaporkan informasi kembali
kepada router yang memberi informasi tersebut.

Distance Vector - Hold down


Metoda Distance Vector mempunyai keuntungan berikut:

Relative terbukti stabil, yang merupakan algoritme original routing

Relative gampang dipelihara dan di implementasikan

Kebutuhan bandwidth bisa diabaikan untuk environment LAN typical.

Kerugian dari Distance vector adalah sebagai berikut:

Membutuhkan waktu yang relative lama untuk mencapai convergence (update dikirim
dengan interval waktu tertentu).

Router melakukan kalkulasi routing table nya sebelum mem-forward perubahan tabelnya

Rentan terjadinya routing loop

Kebutuhan bandwidth bisa sangat besar untuk WAN atau environment LAN yang
kompleks.

LINK STATE ROUTING


Pada dasarnya baik distance vector dan link state routing mempunyai tujuan yang sama yaitu
mengisi routing tables dengan route terbaik dan terkini. Akan tetapi perbedaanya terletak pada

bagaimana keduanya melakukan tugasnya mengisi routing tables. Perbedaan terbesar antara
kedua methoda adalah bahwa distance vector melakukan advertise informasi hanya sedikit. Pada
dasarnya distance vector routing protocols mengetahui router-router lain ada hanya jika routerrouter tersebut melakukan broadcast update routing kepadanya.
Jika distance vector protocol dalam suatu router menerima suatu routing update, update routing
tersebut tidak mengatakan banyak hal tentang router-router lain diluar router sekitarnya dari yang
mengirim update route tersebut. Jadi hanya neighboring router disekitarnya saja yang ia kirimkan
informasinya. Sebaliknya link state routing protocols melakukan advertise sejumlah data yang
besar tentang topology jaringan dan router melakukan computasi dengan memakan power CPU
yang besar untuk memahami data topology jaringan tersebut. Bahkan mereka mengenal router
tetangganya sebelum melakukan pertukaran routing informasi. Lihat juga topology untuk
jaringan

LAN.

Gambar berikut adalah diagram yang menyajikan secara grafis bagaimana router melakukan
advertise dengan link state routing protocol. Router B mengatakan kepada router A metric dari
masing-2 link yang bersangkutan yang ada pada jaringan, ketimbang router B mengatakan
berapa metric atau cost dari suatu route seharusnya, jadi terserah router yang menerima
bagaimana dia mengelolah data topology jaringan dengan masing-2 metric atau cost di setiap
link. Disamping itu juga router B mengatakan kepada router A semua router yang ada pada
jaringan termasuk subnet yang menempel pada masing-2 router dan juga statusnya. Jadi
semacam peta model matematis tentang topology jaringan yang ada.
Berikut adalah point-point yang perlu diketahui mengenai Link state routing protocol:
* Router melakukan broadcast LSP ke semua router yang umum disebut sebagai Flooding
*
Router
mengirim
informasi
hanya
mengenai
link
mereka
sendiri
* LSP dikirim dengan interfal regular dan juga jika salah satu kondisi berikut terjadi:

Datang neighbor baru

Neighbor telah pergi / mati

Cost ke neighbor berubah

Router menggunakan LSP untuk membangun routing table mereka dan melakukan
kalkulasi route terbaik

Router memilih route berdasarkan route terpendek dengan menggunakan suatu algoritma
yang disebut sebagai shortest path first (SPF)

Network administrator mempunyai fleksibilitas yang besar dalam men-setting metric


untuk digunakan kalkulasi route

Link state routing bersifat kurang rentan terhadap routing loops, akan tetapi
membutuhkan routines yang complex dan rumit untuk menemukan route dan mengkalkulasi
paths.
Problem
dan
Solusi
Mengenai
Link
State
Walaupun lebih stabil dibandingkan distance vector, metoda link state mempunyai
masalah berikut:

Membutuhkan resource router yang tinggi baik power dan memori

Menghasilkan traffic yang sangat tinggi saat pertama kali LSP membanjiri jaringan
(Flooded). Akan tetapi jika konfigurasi inisialisasi ini sudah stabil, maka traffic dari link
state ini sangat kecil dibandingkan dari distance vector

Memungkinkan delay atau bahkan lost, menyebabkan jaringan yang inkonsistant. Hal ini
umumnya menjadi masalah pada jaringan yang besar jika bagian-2 jaringan datang on
line pada saat yang berbeda atau jika link bandwidth antar link berbeda (misal pada
jaringan ISP yang lebar akan berbeda dengan jaringan lainnya). Masalah ini lah yang
biasanya jadi yang terbesar

Berikut adalah solusi yang sering di implementasikan untuk mengatasi beberapa effect mengenai
informasi LSP yang inkonsisten.
1. Rate dari LSP update dikurangi untuk menjaga informasi tetap konsisten
2. Router bisa dikelompokkan kedalam area. Router-2 berbagi informasi dalam satu area,
sementara router-2 yang ada pada area border saling bertukar informasi antar area.
3. LSP bisa diidentifikasi dengan suatu stempel waktu, sequence atau ID number, atau aging
timer untuk menjamin proper synchronization.
4. Satu router dalam masing-2 area di serahi tugas sebagai sumber authoritative dari routing
informasi (yang disebut sebagai designated router). setiap area router menerima update
dari designated router.

Keuntungan

dan

Kerugian

dari

Link

State

Link State mempunyai beberapa keuntungan dibanding distance vector:


1. Waktu convergence lebih cepat karena update diforward segera
2. Tidak rentan terhadap routing loops
3. Tidak rentan terhadap informasi yang salah karena hanya informasi tangan pertama saja
yang di broadcast
Kerugian dari Link State
1. Algoritma Link State memerlukan power CPU dan memory yang tinggi untuk melakukan
kalkulasi topology jaringan dan memilih route
2. Menaikkan traffic jika terjadi perubahan topology
Link State sangat handal dan banyak diterapkan pada jaringan Enterprise dan ISP.
Perbedaan dari RIP, RIPv2, IGRP, EIGRP???

RIP

- Routing Classfull

- Time converge lambat


- Tidak support VLSM
- Maks 15 hop berbeda

RIPv2

- Routing classless
- Support VLSM
- Update secara multicast

IGRP

- Routing Classfull
- Maks 225 hop
- Time convergence lambat
- Tidak support VLSM

EIGRP

- Routing Classless
- Time convergence cepat
- Cocok untuk jaringan besar
2. Perbedaan dari OSPF, IS-IS???

OSPF

- Semua vendor dapat menggunakan protokol ini


- Dapat memilih jalur routing yang memiliki nilai cost matrik yang paling kecil.
- Dirancang untuk IPv4

IS-IS

- Efisien dalam penggunaan bandwidth jaringan.


- Tidak menggunakan IP untuk membawa informasi routing pesan.
- Bisa untuk IPv4 dan IPv6
3. Pengertian Distance Vector dan Link State???
Keduanya adalah algoritma yang digunakan untuk mencari routing atau destination terbaik.
Distance Vector = menggunakan path hoop yang pendek.
Link State = menggunakan kalkulasi, bandwidth dan delay.

Border

Gateway

Protocol

Disingkat BGP adalah inti dari protokol routing Internet. Protocol ini yang menjadi backbone
dari jaringan Internet dunia. BGP adalah protokol routing inti dari Internet yg digunakan untuk
melakukan pertukaran informasi routing antar jaringan.

KOMPUTER

TEKNIK ENCODING, PENDETEKSI


ERROR, AUTO REPORT REQUES

January 10th, 2011

OSI LAYER DAN TCP / IP


TEKNOLOGI WAN DAN LAN

TEKNIK ENCODING, PENDETEKSI


ERROR, AUTO REPORT REQUES
Data Digital, Sinyal Digital
Elemen sinyal adalah tiap pulsa dari sinyal digital. Data binari / digital ditransmisikan dengan
mengkodekan bit-bit data ke dalam elemen-elemen sinyal.
Contoh : bit binari 0 untuk level tegangan rendah
bit binari 1 untuk level tegangan tinggi
kecepatan data signalling dalam bps (bit per detik)
Sinyal unipolar adalah semua elemen sinyal yang mempunyai tanda yang sama, yaitu positif
semua atau negatif semua. Sedangkan sinyal polar adalah elemen sinyal dimana salah satu logic
statenya diwakili oleh level tegangan positif dan yang lainnya oleh level tegangan negatif. Durasi
= panjang bit (1/R) adalah jumlah waktu yang dibutuhkan oleh transmiter untuk mengirimkan bit
dengan kecepatan R
Kecepatan modulasi :
kecepatan perubahan level sinyal dalam satuan baud (besaran eleman sinyal perdetik)
Mark menunjukkan binari 1, dan
Space menunjukkan binari 0
Faktor kesuksesan penerima dalam mengartikan sinyal yang datang :
Ratio signal to noise (S/N) : peningkatan S/N akan menurunkan bit error rate
Kecepatan data / data rate : peningkatan data rate akan meningkatkan bit error rate (kecepatan
error dari bit)
Bandwidth : peningkatan bandwidth dapat meningkatkan data rate.
Hubungan ketiga faktor tersebut adalah :
Kecepatan data bertambah, maka kecepatan errorpun bertambah, sehingga memungkinkan bit
yang diterima error.
Kenaikan S/N mengakibatkan kecepatan error berkurang
Lebar bandwidth membesar yang diperbolehkan, kecepatan data akan bertambah

5 faktor evaluasi
(faktor-faktor yang mempengaruhi coding) :
-Spektrum sinyal / signal spectrum ketidakadaan komponen frekuensi tinggIberarti diperlukan
bandwidth sempit untuk transmisi.
-Kemampuan sinkronisasi / clocking / signal synchronization capability untuk menghitung posisi
start dan stop dari tiap posisi bit dengan mekanisme sinkronisasi.
-Kemampuan mendeteksi error / signal error detecting capability kemampuan error detection
dapat diberikan secara sederhana dengan pengkodean natural.
-Tahan terhadap gangguan / signal interference and noise immunity digambarkan oleh kecepatan
bit error.
-Biaya dan kompleksitas / cost and complexity semakin tinggi kecepatan pensinyalan untuk
memenuhi data rate yang ada, semakin besar biayanya.
Teknik Data Digital, Sinyal Digital terbagi atas :
1. Non-Return to Zero / NRZ
2. Non return to zero inverted
3. Biphase
4. Delay Modulation
5. Multilevel Binary

Non-Return to Zero / NRZ


Level tegangannya tetap selama interval bit tidak ada transisi.
a.NRZ-L (NRZ-Level)
Kode yang digunakan untuk menghasilkan dan menginterprestasikan data digital oleh terminal
pemproses data / peralatan lainnya dan jika kode yang digunakan untuk transmisi berbeda. (tetap
seperti data awal)
b.NRZ-M (NRZ-Mark)
Keuntungan transmisi dengan kode defferensial, dimana sinyal dikodekan dengan
membandingkan polaritas elemen sinyal yang berdekatan dari harga absolut sinyal.
Keuntungannya : mudah dalam mendeteksi transisi noise
Bit = 1 jika transisi pada awal pulsa clock
Bit = 0 jika tidak ada transisi / perubahan
c.NRZ-S (NRZ-Space)
Sama dengan NRZ-M, tapi bedanya :
Bit = 1 jika tidak ada transisi / perubahan
Bit = 0 jika transisi pada awal pulsa clock
Return to Zero / RZ
Untuk melihat perbedaan antara kecepatan data dan kecepatan modulasi
Bit rate / kecepatan bit = 1/ tb, dan kecepatan maksimal modulasi = 2 / tb

Ukuran minimal elemen signal adalah pulsa untuk binari 1 besarnya panjang interval bit
Kecepatan maksimum modulasi = 2 / tB
Tidak memberikan perbaikan terhadap teknik NRZ, bandwidth sinyal besar
Bit = 1, pulsa berada pada awal interval
Bit = 0, tidak ada pulsa
Biphase
Diharapkan untuk mengatasi kerugian teknik pengkodean NRZ dan RZ
Sekurang-kurangnya memerlukan 1 transisi waktu bit dan sebanyak-banyaknya 2 transisi,
sehingga kecepatan maksimumnya 2 x NRZ
Keuntungannya adalah :
a. Synchronization, karena transisi dapat diramalkan selama masing-masing waktu bit sehingga
penerima dapat sinkron dalam transisi tersebut.
b. No-DC-Component, tidak mempunyai komponen DC, sehingga menghasilkan keuntungan
untuk mendeteksi error.
c. Error Detection, ketidak adaan transisi diharapkan dapat dipakai untuk mendeteksi error.
Jenis-jenis Biphase :
a. Biphase-L (biphase-level / manchester)
Bit = 1, transisi dari high ke low di tengah interval
Bit = 0, transisi dari low ke high di tengah interval
b. Biphase-M
Selalu terjadi transisi di awal interval
Bit = 1, transisi di tengah interval
Bit = 0, tidak ada transisi di tengah interval
c. Biphase-S
Selalu terjadi transisi di awal interval
Bit = 1, tidak ada transisi di tengah interval
Bit = 0, transisi di tengah interval
d. Differensial Manchester
Selalu terjadi transisi di tengah interval
Bit = 1, tidak ada transisi di awal interval
Bit = 0, transisi di awal interval
Delay Modulation (Miller-Codding)
Ada 1 transisi per 2 waktu bit dan pernah lebih dari 1 transisi per bit
Bit = 1, transisi di tengah interval
Bit = 0, tidak ada transisi jika diikuti 1, dan transisi pada akhir interval jika diikuti 0
Bipolar / Multilevel Binary
v Menggunakan lebih dari 2 level sinyal
v Mempunyai pusat bandwidth pada kecepatan bit
v Keuntungannya : tidak ada komponen DC / kemampuan sikronisasi yang baik dan pemakaian
bandwidth yang lebih kecil, dapat menampung bit informasi lebih.
v Kerugiannya : diperlukan receiver yang mampu membedakan 3 level (+A, -A, 0) sehingga
membutuhkan lebih dari 3 dB kekuatan sinyal dibandingkan NRZ untuk probabilitas bit error
yang sama.
v Bit = 1, pulsa pada tengah bit interval awal dan mempunyai polaritas

v Bit = 0, tidak ada pulsa


v Memberikan beberapa error detection capability jika 1 harus mempunyai tanda berlawanan
B8ZS
- Penggantian Bipolar With 8 Zeros
- Didasarkan pada bipolar-AMI
- Jika octet pada semua zero dan pulsa terakhir tegangan yang terdahulu adalah encode positif
sebagai 000+-0-+
- Jika octet pada semua zero dan pulsa terakhir tegangan yang terdahulu adalah encode negatif
sebagai 000-+0+- Karena dua pelanggaran pada kode AMI
- Tidak mungkin untuk terjadi seperti hasil noise
- Receiver mendeteksi dan menerjemahkan seperti octed pada semua zero
HDBB
- Kepadatan tinggi Bipolar 3 Zeros
- Didasarkan pada bipolar-AMI
- String pada empat zero digantikan dengan satu atau dua pulsa

PENDETEKSI ERROR
Parity Check :
a. Even parity (paritas genap), digunakan untuk transmisi asynchronous. Bit parity ditambahkan
supaya banyaknya 1 untuk tiap karakter / data adalah genap
b. Odd parity (paritas ganjil), digunakan untuk transmisi synchronous. Bit parity ditambahkan
supaya banyaknya 1 untuk tiap karakter / data adalah ganjil
Dengan bit pariti dikenal 3 deteksi kesalahan, yaitu :
a. Vertical Redundancy Check / VRC
Setiap karakter yang dikirimkan (7 bit) diberi 1 bit pariti. Bit pariti ini diperiksa oleh penerima
untuk mengetahui apakah karakter yang dikirim benar atau salah. Cara ini hanya dapat melacak 1
bit dan berguna melacak kesalahan yang terjadi pada pengiriman berkecepatan menengah, karena
kecepatan tinggi lebih besar kemungkinan terjadi kesalahan banyak bit.
Kekurangan : bila ada 2 bit yang terganggu ia tidak dapat melacaknya karena paritinya akan
benar.
Contoh :
ASCII huruf "A" adalah 41h
100 0001 ASCII 7 bit
1100 0001 ASCII dengan pariti ganjil
0100 0001 ASCII dengan pariti genap
Akibatnya huruf "A" kode ASCII dalam Hex :

- 41 bilamana pariti genap


- A1 bilamana pariti ganjil
b. Longitudinal Redundancy Check / LRC
LRC untuk data dikirim secara blok. Cara ini seperti VRC hanya saja penambahan bit pariti tidak
saja pada akhir karakter tetapi juga pada akhir setiap blok karakter yang dikirimkan. Untuk setiap
bit dari seluruh blok karakter ditambahkan 1 bit pariti termasuk juga bit pariti dari masingmasing karakter. Tiap blok mempunyai satu karakter khusus yang disebut Block Check Character
(BCC) yang dibentuk dari bit uji. dan dibangkitkan dengan cara sebagai berikut :
"Tiap bit BCC merupakan pariti dari semua bit dari blok yang mempunyai nomor bit yang sama.
Jadi bit 1 dari BCC merupakan pariti genap dari semua bit 1 karakter yang ada pada blok
tersebut, dan seterusnya"
Kerugian : terjadi overhead akibat penambahan bit pariti per 7 bit untuk karakter.
CYCLE REDUDANCY CHECK
Digunakan pengiriman berkecepatan tinggi sehingga perlu rangkaian elektronika yang sulit. Cara
CRC mengatasi masalah overhead dan disebut pengujian berorientasi bit, karena dasar
pemeriksaan kemungkinan kesalahan adalah bit / karakter dan menggunakan rumus matematika
khusus.
Satu blok informasi dilihat sebagai sederetan bit yang ditransmisikan. Bit yang ditransmisikan
dimasukkan kedalam register geser siklis yang disebut generator CRC. Operasi ini didasarkan
atas pembagian deretan bit dengan sebuah fungsi khusus.
Hasil bagi pembagian diabaikan. Sisanya disalurkan sebagai BCS (Block Check Sequence).
Fungsi khusus tersebut disebut generator polynominal.
Realisasi Generator CRC / Penguji
Data dimasukkan kedalam register geser pada berbagai titik melalui gerbang XOR yang
mempunyai hubungan langsung dengan generator polynominal yaitu rumus matematika untuk
membagi bit data. Lebih baik dari VRC / LRC, 99% error dapat terdeteksi.
Contoh hasil pada register geser 16 bit dengan gerbang XOR, dimana input pada bit 0, 5, 12 dan
output pada bit 15, maka :
CRC-CCITTT = X16 + X12 + X5 + 1
CRC-16 = X16 + X15 + X2 + 1
CRC-12 = X12 + X11 + X3 + X2 + 1
LRC = X8 + 1
RC-32 = X32 + X26 + X23 + X22 + X16
+ X12 + X11 + X10 + X8 + X7 + X5 + X4 + X2 + X1 + 1
3. Framing Check
Dipakai pada transmisi asinkron dengan adanya bit awal dan akhir. Data berada diantara bit awal
dan bit akhir. Dengan memeriksa kedua bit ini dapat diketahui apakah data dapat diterima
dengan baik atau tidak. Transmisi asinkron mempunyai bentuk bingkai sesuai dengan ketentuan
yang dipergunakan
Pendekatan yang umum dipakai adalah data link layer memecah aliran bit menjadi frame-frame

diskrit dan menghitung checksum setiap framenya. Ketika sebuah frame tiba di tujuan, checksum
dihitung kembali. Bila hasil perhitungan ulang checksum tersebut berbeda dengan yang terdapat
pada frame, maka data link layer akan mengetahui bahwa telah terjadi error dan segera akan
mengambil langkah tertentu sehubungan dengan adanya error tersebut (misalnya, membuang
frame yang buruk dan mengirimkan kembali laporan error).
Salah satu cara untuk melaksanakan pembuatan frame ini adalah dengan cara menyisipakn gap
waktu di antara dua buah frame, sangat mirip seperti spasi antara dua buah katan dalam suatu
teks. Akan tetapi, jaringan jarang memberikan jaminan tentang pewaktuan. Karena itu, mungkin
saja gap ini dibuang, atau diisi oleh gap lainnya selama proses transmisi, karena sangat besar
risikonya dalam menghitung pewaktuan untuk menandai awal dan akhir frame, telah dibuat
metode lainnya, yaitu 4 buah metoda :
1. Karakter penghitung
2. Pemberian karakter awak dan akhir, dengan pengisian karakter
3. Pemberian flag awal dan akhir, dengan pengisian bit
4. Pelanggaran pengkodean physical layer.
Metoda framing pertama menggunakan sebuah field pada header untuk menspesifikasikan
jumlah karakter di dalam frame. Ketika data link layer pada mesin yang dituju melihat karakter
penghitung, maka data link layer akan mengetahui jumlah karakter yang mengikutinya, dan
kemudian juga akan mengetahui posisi ujung frame-nya. Masalah yang dijumpai dalama
algoritma ini adalah bahwa hitungan dapat dikacaukan oleh error transmisi. Misal, bila hitungan
karakter 5 frame menjadi 7, maka tempat yang dituju akan tidak sinkron dan tidak dapat
mengetahui awal frame berikutnya. Bahkan bila cheksum tidak benar sehingga tempat yang
dituju mengetahui bahwa frame yang bersangkutan buruk, maka tidak mungkin untuk
menentukan awal frame berikutnya. Pengiriman kembali sebuah frame ke sumber untuk meminta
pengiriman ulangpun tidak akan menolong, karena tempat yang dituju tidak mengetahui jumlah
karakter yang terlewat untuk mendapatkan awal transmisi. Untuk alasan ini, metoda hitungan
karakter ini sudah jarang digunakan lagi. Metode framing yang kedua mengatasi masalah
resinkronisasi setelah terjadi suatu error dengan membuat masing-masing frame diawali dengan
sederetan karakter DLE STX ASCII dan diakhiri dengan DLE ETX (DLE=Data Link Escape,
STX=Start Of Text, ETX=End Of Text). Dalam metoda ini, bila tempat yang dituju kehilangan
track batas-batas frame, maka yang perlu dilakukan adalah mencari karakter-karakter DLE STX
dan DLE ETX. Masalah serius yang terjadi pada metoda ini adalah ketika data biner, seperti
program object, atau bilangan floating point, ditransmisikan. Karakter-karakter DLE STX dan
DLE ETX yang terdapat pada data mudah sekali menganggu framing. Satu cara untuk mengatasi
masalah ini adalah dengan membuat data link pengirim menyisipkan sebuah karakter DLE
ASCII tepat sebelum karakter DLE "insidentil" pada data. Data link layer pada mesin penerima
membuang DLE sebelum data diberikan ke network layer. Teknik ini disebut character stuffing
(pengisian karakter). DLE-DLE pada data selalu digandakan. Kerugian penting dalam memakai
metoda framing ini sangat berkaitan erat dengan karakter 8-bit secara umum dan kode karakter
ASCII pada khususnya. Dengan berkembangnya jaringan, kerugian dari melekatkan kode
karakter dalam mekanisma framing menjadi semakin jelas, sehingga suatu teknik baru perlu
dibuat untuk memungkinkan pemakaian karakter berukuran sembarang.
Teknik baru memungkinkan frame data berisi sembarang sejumlah bit dan mengijinkan kode
karakter dengan sembarang jumlah bit per karakter. Teknik ini bekerja seperti berikut, setiap

frame diawali dan diakhiri oleh pola bit khusus, 01111110 yang disebut flag. Kapanpun data link
layer pada pengirim menemukan lima buah flag yang berurutan pada data, maka data link layer
secara otomatis mengisikan sebuah bit 0 ke aliran bit keluar. Pengisian bit ini analog dengan
pengisian karakter, dimana sebuah DLE diisikan ke aliran karakter keluar sebelum DLE pada
data. Ketika penerima melihat 5 buah bit 1 masuk yang berurutan, yang diikuti oleh sebuah bit 0,
maka penerima secara otomatis mengosongkan (menghapus) bit 0 tersebut. Seperti halnya
pengisian karakter transparan sepenuhnya bagi network layer pada kedua buah komputer,
demikian pula halnya dengan pengisian bit. Bila data pengguna berisi pola flag 01111110, maka
flag ini akan ditransmisikan kembali sebagai 011111010 tapi akan disimpan di memory penerima
sebagai 01111110. Dengan pengisian bit, maka batas antara dua frame dapat dikenal jelas oleh
pola flag. Jadi bila penerima mengalami kehilangan track frame tertentu, yang perlu dilakukan
adalah menyisir input deretan flag, karena flag tersebut hanya mungkin terdapat pada batas frame
saja dan tidak pernah berada pada data.
Metode framing terakhir hanya bisa digunakan bagi jaringan yang encoding pada medium
fisiknya mengandung beberapa redundansi (pengulangan). Misalnya, sebagian LAN melakukan
encode bit 1 data dengan menggunakan 2 bit fisik. Umumnya, bit1 merupakan pasangan tinggirendah dan bit 0 adalah pasangan rendah-tinggi. Kombinasi pasangan tinggi-tinggi dan rendahrendah tidak digunakan bagi data. Proses itu berarti bahwa setiap bit data memiliki transisi di
tengah, yang memudahkan penerima untuk mencari batas bit. Manfaat kode fisik yang invalid
merupakan bagian standard LAN 802.2.
Automatic Repeat Request
Automatic Repeat reQuest (ARQ), juga dikenal sebagai Ulangi otomatis Query, adalah metode
error-kontrol untuk transmisi data yang menggunakan acknowledgment (pesan yang dikirim oleh
penerima menunjukkan bahwa ini benar menerima data frame atau paket) dan timeout
(ditentukan periode waktu diperbolehkan untuk berlalu sebelum pengakuan harus diterima)
untuk mencapai transmisi yang handal data melalui layanan tidak bisa diandalkan. Jika pengirim
tidak menerima pemberitahuan sebelum timeout, biasanya kembali mentransmisikan frame /
paket sampai pengirim menerima pengakuan atau melebihi jumlah yang telah ditentukan retransmisi.
The types of ARQ protocols include
Stop-and-wait ARQ
Gelective Repeat ARQ
Selective Repeat ARQ
SELECTIVE-REJECT AUTOMATIC REPEAT REQUEST :
Informasi tentang Selektif-menolak permintaan ulang secara otomatis (Selective-reject ARQ)
Selektif-menolak permintaan ulang otomatis (selektif-menolak ARQ) adalah teknik error kontrol
yang dalam pengiriman hanya memancarkan kembali blok yang salah.
STOP-AND-WAIT AUTOMATIC REPREAT REQUEST :
Informasi tentang Stop-dan-tunggu permintaan repreat otomatis (Stop-dan-tunggu ARQ)
Stop-dan-tunggu permintaan repreat otomatis (berhenti-dan-tunggu ARQ) merupakan koreksi

kesalahan teknik di mana pengirim mengirimkan suatu blok data dan kemudian menunggu
acknowledgment sebelum transmisi blok berikutnya....
Go-Back-N ARQ :
Go-Back-N ARQ adalah contoh khusus dari permintaan ulang otomatis (ARQ) protokol, di mana
proses pengiriman terus mengirimkan sejumlah frame ditentukan oleh ukuran jendela bahkan
tanpa menerima pengakuan (ACK) paket dari penerima. Ini adalah kasus khusus dari protokol
sliding window umum dengan mengirimkan ukuran jendela N dan menerima ukuran jendela 1.
Proses penerima melacak nomor urutan frame berikutnya mengharapkan untuk menerima, dan
mengirimkan nomor yang dengan setiap ACK yang dikirimkan. Penerima akan mengabaikan
setiap frame yang tidak memiliki nomor urut yang tepat itu mengharapkan - apakah frame yang
merupakan "masa lalu" duplikat dari bingkai itu sudah ACK'ed [1] atau apakah frame yang
merupakan "masa depan" bingkai masa lalu paket terakhir itu sedang menunggu. Setelah
pengirim telah mengirimkan semua frame di jendela, itu akan mendeteksi bahwa seluruh frame
frame yang hilang sejak pertama beredar, dan akan kembali ke nomor urutan ACK terakhir yang
diterima dari proses penerima dan isi jendela dimulai dengan bingkai tersebut dan melanjutkan
proses lagi.
Keuntungan differensial encoding :
lebih kebal noise
tidak dipengaruhi oleh level tegangan.
Kelemahan dari NRZ-L maupun NRZI :
keterbatasan dalam komponen dc dan kemampuan synchronisasi yang buruk

Sumber :
http://hazky.wordpress.com/2008/03/28/teknik-endcoding/
http://repository.binus.ac.id/content/H0174/H017436235.ppt
http://nryulia.staff.gunadarma.ac.id/Downloads/files/5161/Komdat4kom.datadigital.doc
Diposkan 17th January 2011 oleh NETWORKING
0

Tambahkan komentar
Memuat
Template Dynamic Views. Diberdayakan oleh Blogger.

keep fight to be freedom


12/27/11
Konfigurasi Jaringan Menggunakan Routing Dynamic pada Cisco
Setelah saya berhasil membuat jaringan dengan routing static pada posting sebelumnya,
sekarang saya mencoba untuk membuat sebuah jaringan dengan routing dynamic, yang mana
routing dinamik adalah cara yang digunakan untuk melepaskan kewajiban mengisi entrientri forwarding table secara manual. Protokol routing akan mengatur router-router sehingga
dapat berkomunikasi satu dengan yang lain dan saling memberikan informasi routing
yang dapat mengubah isi forwarding table, tergantung keadaan jaringannya.
Sterling

Hoboken

Waycross

contoh jaringan
Terdapat contoh jaringan diatas ini, untuk table IP nya sebagai berikut:
Device
Fast ether 0/0
Router 0
Serial 0/1/0
Fast ether 0/0
Router1
Serial 0/1/0
Serial 0/1/1
Fast ether 0/0
Router3
Serial 0/1/0
PC 0
PC 1
PC2
PC 3
PC 4
PC 5

IP

Subnet mask

Gateway

172.16.1.1

255.255.255.0

172.16.2.1

255.255.255.0

172.16.3.1

255.255.255.0

172.16.2.2
172.16.4.1

255.255.255.0
255.255.255.0

172.16.5.1

255.255.255.0

172.16.4.2
172.16.1.3
172.16.1.4
172.16.3.3
172.16.3.4
172.16.5.3
172.16.5.4

255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0

172.16.1.1
172.16.1.1
172.16.3.1
172.16.3.1
172.16.5.1
172.16.5.1

Pertama lakukan konfigurasi pada Router, langsung saja mari kita bermain CLI, hehehee..
Beri nama host sesuai yang terdapat pada jaringan.
Router0 / Sterling
Sterling>en
Sterling#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Sterling(config-if)#no shutdown
Sterling(config-if)#interface serial 3/0
Sterling(config-if)#ip address 172.16.2.1.255.255.255.0
Sterling(config-if)#exit
Sterling(config)#interface fastethernet 0/0
Sterling(config-if)#no shutdown
Sterling(config-if)#ip address 172.16.1.1. 255.255.255.0
Sterling>en
Sterling#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Sterling(config)#router rip
Sterling(config-router)#network 172.16.2.0
Sterling(config-router)#network 172.16.1.0

Router1 / Hoboken
Hoboken#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Hoboken(config-if)#no shutdown
Hoboken(config-if)#interface serial 2/0
Hoboken(config-if)#ip address 172.16.2.2.255.255.255.0
Hoboken(config-if)#interface serial 3/0
Hoboken(config-if)#ip address 172.16.4.1.255.255.255.0
Hoboken(config-if)#exit
Hoboken(config)#interface fastethernet 0/0
Hoboken(config-if)#no shutdown
Hoboken(config-if)#ip address 172.16.3.1.255.255.255.0
Hoboken>en
Hoboken#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Hoboken(config)#router rip
Hoboken(config-router)#network 172.16.2.0
Hoboken(config-router)#network 172.16.4.0
Hoboken(config-router)#network 172.16.3.0

Router2 / Waycross

Waycross#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Waycross(config-if)#no shutdown
Waycross(config-if)#interface serial 2/0
Waycross(config-if)#ip address 172.16.4.2.255.255.255.0
Waycross(config-if)#exit
Waycross(config)#interface fastethernet 0/0
Waycross(config-if)#no shutdown
Waycross(config-if)#ip address 172.16.5.1.255.255.255.0
Waycross>en
Waycross#conf ter
Enter configuration commands, one per line. End with CNTL/Z.

Waycross(config)#router rip
Waycross(config-router)#network 172.16.4.0
Waycross(config-router)#network 172.16.5.0

Berikan juga alamat IP (Internet Protokol) pada setiap PC, sesuai dengan yang terdapat pada
table IP diatas jangan lupa gateway_nya diisikan yahhh.., untuk caranya sebagai berkut:
Klik PC> Setting (isikan alamat Gateway_nya pada setiap PC sesuia table diatas):

Setting gateway
Untuk setingan IP nya, klik PC> FastEthernet(lakukan hal yang sama pada setiap PC sesuai
alamat IP pada table):

Setting FastEthernet

Selesai deh konfigurasi jaringannya, mari kita coba untuk mengeping untuk mengetes apakah
jaringan berhasil terhubung:
Dari PC0 ke PC1 dan PC2:

Ping PC0 ke PC2 dan PC3


Dari PC0 ke PC4 dan PC5:

Ping PC0 ke PC4 dan PC5


Terlihat dari hasil ping antar PC, bahwa jaringan berhasil terhubung,.. Jaringan diatas merupakan
topologi jaringan dengan menggunakan routing dynamic, selamat mencoba.,., heheee

Pengertian Dynamic Routing


Posted by hendi pradana on 19.24

Pengertian Dynamic Routing

Dynamic routing adalah fungsi dari routing protocol yang berkomunikasi dengan
router yang lain untuk saling meremajakan (update) tabel routing yang ada. Dengan
demikian, administrator tidak perlu melakukan updating jalur (path) jika terjadi
perubahan jalur transmisi (path). Dynamic routing umumnya digunakan untuk
jaringan komputer yang besar dan lebih kompleks.
Dynamic routing di bagi menjadi 2, yaitu:
1. Interior Gateway Protokol
2. Exterior Gateway Protokol
Open Shortest Path First (OSPF) adalah routing dinamic yang masing router memiliki
tabel daftar ID dari router-reiuter yang terkoneksi. Jalan yang akan di lalui adalah
route yang nilainya terpendek (sesuai dengan namanya). Routing model ini
termasuk smart route karena jika terputus akan mencari jalan lain secara otomatis.
Interior Gateway Routing Protocol (IGRP) adalah routing protokol distance vector
yang dibuat oleh Cisco. IGRP mengirimkan update routing setiap interval 90 detik.
Update ini advertise semua jaringan dalam AS.
Routing Information Protocol (RIP) adalah protokol routing dinamik yang
berbasisdistance vector. RIP menggunakan protokol UDP pada port 520 untuk
mengirimkan informasi routing antar router. RIP menghitung routing terbaik
berdasarkan perhitungan HOP. RIP membutuhkan waktu untuk melakukan converge.
RIP membutuhkan power CPU yang rendah dan memory yang kecil dari pada
protocol yang lainnya

dynamic routing merupakan metode yang paling umum digunakan. Mengapa? Karena jika kita
menggunakan metode static routing maka kita harus mengkonfigurasi semua router secara manual
dan ini tidak mungkin untuk seorang network administrator. Dengan menggunakan metode static
routing kita membutuhkan banyak konfigurasi, sedangkan pada dynamic routing kita dapat
mengkonfigurasi seminimal mungkin. Jadi sangat dimungkinkan metode dymanic routing untuk
mengembangkan bagaimana router berkomunikasi dengan protocol yang digunakan. Dynamic IP
routing adalah cara yang digunakan untuk melepaskan kewajiban mengisi masukan masukan ke
routing table secara manual.
Protokol routing mengatur router-router sehingga dapat berkomunikasi satu dengan yang lain dan

saling memberikan informasi routing yang dapat mengubah isi Routing table, tergantung keadaan
jaringannya. Dengan cara ini, router-router mengetahui keadaan jaringan yang terakhir dan mampu
meneruskan datagram ke arah yang benar.
Remote network dapat dikategorikan di tabel routing dengan menggunakan protokol dynamic routing.
Dynamic routing protocol contohnya sebagai berikut:
Network Discovery
Memelihara dan meng-update tabel routing- automatic network discovery. Network discovery adalah
kemampuan routing protokol untuk membagi informasi tentang jaringan dengan router lainnnya
dengan menggunakan routing protokol yang sama.
Daripada mengkonfigurasi router secara static, routing dinamik dapat secara otomatis membaca
jaringannya dari router-router lainnya. pemilihan jalur terbaik pada setiap jaringan terdapat pada tabel
routing dengan menggunakan routing dinamik.
Maintaining routing tables.
Setelah mengenal jaringannya, routing dinamik akan selalu meng-update dan menentukan jalurjalurnya pada tabel routing. Routing dinamik tidak hanya membuat jalur terbaik ke jaringan yang
berbeda, routing dinamik juga akan menentukan jalur baru yang baik jika tujuannya tidak tersedia (jika
topologinya berubah), untuk ini, routing dinamik mempunyai keuntungan lebih dari routing static.
router yang menggunakan dinamic routing akan secara otomatis membagi informasi routingnya
kepada router yang lain dan menyesuaikan dengan topologi yang berubah tanpa pengaturan dari
seorang admin jaringan.
IP routing protocol
ada beberapa routing dinamic untuk IP. dibawah ini adalah dinamik routing yang sering digunakan:
1. Routing Information Protocol (RIP)
Kelebihan
RIP menggunakan metode Triggered Update. RIP memiliki timer untuk mengetahui kapan router harus
kembali memberikan informasi routing. Jika terjadi perubahan pada jaringan, sementara timer belum
habis, router tetap harus mengirimkan informasi routing karena dipicu oleh perubahan tersebut
(triggered update)
Mengatur routing menggunakan RIP tidak rumit dan memberikan hasil yang cukup dapat diterima,
terlebih jika jarang terjadi kegagalan link jaringan
Kekurangan
Jumlah host Terbatas. RIP tidak memiliki informasi tentang subnet setiap route.
RIP tidak mendukung Variable Length Subnet Masking (VLSM). Ketika pertama kali dijalankan hanya
mengetahui cara routing ke dirinya sendiri (informasi lokal) dan tidak mengetahui topologi jaringan
tempatnya berada
2. Interior Gateway Routing Protocol (IGRP)
Kelebihan: support = 255 hop count
Kekurangan: Jumlah Host terbatas
3.Open Shortest Path First (OSPF)
Kelebihan. Tidak menghasilkan routing loop mendukung penggunaan beberapa metrik sekaligus dapat
menghasilkan banyak jalur ke sebuah tujuan membagi jaringan yang besar mejadi beberapa area.
Waktu yang diperlukan untuk konvergen lebih cepat
Kekurangan. Membutuhkan basis data yang besar. Lebih rumit
4. Enchanced Interior Gatway Routing Protocil (EIGRP)
Kelebihan. melakukan konvergensi secara tepat ketika menghindari loop. Memerlukan lebih sedikit
memori dan proses. Memerlukan fitur loop avoidance
Kekurangan. Hanya untuk Router Cisco

5. Exiterior Gateway Protocol (EGP)


Kelebihan. Sangat sederhana dalam instalasi
Kekurangan. Sangat terbatas dalam mempergunakan topologi

Pengertian, Perbedaan Routing Static dan


Routing Dynamic
Network Pengertian, Perbedaan Routing Static dan Routing
Dynamic yang akan kita bahas pada posting kali ini. Banyak perbedaan dari
beberapa routing yang telah ada sekarang dan biasanya routing itu sangat
dibutuhkan untuk menghubungkan jaringan antar lokal ataupun antar kota.
Routing adalah Konfigurasi yang akan dilakukan pada perangkat keras
Router. Jenis-jenis router pun berbeda-beda, konfigurasinya pun berbedabeda. Contoh CISCO produksi router CISCO banyak digunakan karena
konfigurasinya sudah familiar dan banyak instansi pendidikan pun sudah
dijadikan
matakuliah
agar
bisa
di
pelajari
lebih
lanjut. Secara
umum, router dibagi menjadi dua buah jenis, yaitu:

A. Static Routing ( Routing Statis)


Static routing (Routing Statis) adalah sebuah router yang memiliki
tabel routing statik yang di setting secara manual oleh para administrator
jaringan. Routing static pengaturan routing paling sederhana yang dapat
dilakukan pada jaringan komputer. Menggunakan routing statik murni dalam
sebuah jaringan berarti mengisi setiap entri dalam forwarding table di
setiap router yang berada di jaringan tersebut.
Penggunaan routing statik dalam sebuah jaringan yang kecil tentu
bukanlah suatu masalah, hanya beberapa entri yang perlu diisikan pada
forwarding table di setiap router. Namun Anda tentu dapat membayangkan
bagaimana jika harus melengkapi forwarding table di setiap router yang
jumlahnya
tidak
sedikit
dalam
jaringan
yang
besar.

Routing Static and Dynamic

CARA KONFIGURASI STATIC ROUTE PADA


ROUTER CISCO
Kekurangan dan kelebihan dari Routing Statis diantaranya sebagai berikut :
Dilihat
dari Kelebihan
Segi
Penggunaan
Dapat
mencegah
Next Hop
terjadinya error dalam
meneruskan paket ke
router tujuan apabila
router
yang
akan
meneruskan
paket
memiliki
link
yang
terhubung
dengan
banyak
router.
Itu
disebabkan
karena
router
telah
mengetahui next hop,
yaitu IP Address router
tujuan.
Penggunaan
exit interface

Proses lookup hanya


akan terjadi satu kali
saja ( single lookup )
karena
router
akan
langsung meneruskan
paket
ke
network
tujuan melalui interface

Kekurangan
static
routing
yang
menggunakan next hop
akan
mengalami
multiple lookup atau
lookup yg berulang.
lookup
yg
pertama
yang akan dilakukan
adalah
mencari
network tujuan,setelah
itu
akan
kembali
melakukan
proses
lookup untuk mencari
interface mana yang
digunakan
untuk
menjangkau
next
hopnya.
Kemungkinan
akan
terjadi
eror
keteka
meneruskan paket. jika
link router terhubung
dengan banyak router,
maka router tidak bisa
memutuskan
router

yang
sesuai
routing table

pada mana tujuanya karena


tidak adanya next hop
pada
tabel
routing.
karena
itulah,
akan
terjadi eror

Routing static dengan menggunakan next hop cocok digunakan untuk


jaringan multi-access network atau point to multipoint sedangkan untuk
jaringan point to point, cocok dengan menggunakan exit interface dalam
mengkonfigurasi static route.
Recursive route lookup adalah proses yang terjadi pada routing tabel
untuk menentukan exit interface mana yang akan digunakan ketika akan
meneruskan paket ke tujuannya.

CARA KONFIGURASI STATIC ROUTE PADA


ROUTER CISCO
B. Dynamic Routing (Routing Dinamis)
Dynamic Routing (Router Dinamis) adalah sebuah router yang memiliki
dan membuat tabel routing secara otomatis, dengan mendengarkan lalu
lintas jaringan dan juga dengan saling berhubungan antara router lainnya.
Protokol routing mengatur router-router sehingga dapat berkomunikasi satu
dengan yang lain dan saling memberikan informasi satu dengan yang lain
dan saling memberikan informasi routing yang dapat mengubah isi
forwarding table, tergantung keadaan jaringannya. Dengan cara ini, routerrouter mengetahui keadaan jaringan yang terakhir dan mampu meneruskan
data ke arah yang benar. Dengan kata lain, routing dinamik adalah proses
pengisian data routing di table routing secara otomatis.
Dynamic router mempelajari sendiri Rute yang terbaik yang akan
ditempuhnya untuk meneruskan paket dari sebuah network ke network
lainnya. Administrator tidak menentukan rute yang harus ditempuh oleh
paket-paket tersebut. Administrator hanya menentukan bagaimana cara
router mempelajari paket, dan kemudian router mempelajarinya sendiri. Rute
pada dynamic routing berubah, sesuai dengan pelajaran yang didapatkan
oleh
router.

Apabila jaringan memiliki lebih dari satu kemungkinan rute untuk tujuan
yang sama maka perlu digunakan dynamic routing. Sebuah dynamic routing
dibangun berdasarkan informasi yang dikumpulkan oleh protokol routing.
Protokol ini didesain untuk mendistribusikan informasi yang secara dinamis
mengikuti perubahan kondisi jaringan. Protokol routing mengatasi situasi
routing yang kompleks secara cepat dan akurat. Protokol routng didesain
tidak hanya untuk mengubah ke rute backup bila rute utama tidak berhasil,
namun juga didesain untuk menentukan rute mana yang terbaik untuk
mencapai tujuan tersebut.
Pengisian dan pemeliharaan tabel routing tidak dilakukan secara manual
oleh admin. Router saling bertukar informasi routing agar dapat mengetahui
alamat tujuan dan menerima tabel routing. Pemeliharaan jalur dilakukan
berdasarkan pada jarak terpendek antara device pengirim dan device tujuan.
Macam-Macam dari Routing Dinamis (Dynamic Router) adalah

RIP (Routing Information Protocol) Info Lanjut RIP >>

IGRP (Internal Gateway Routing Protokol) Info LanjutIGRP >>

OSPF (Open Shortest Path First) Info Lanjut OSPF >>

EIGRP (Enhanced Internal Gateway Routing Protokol) Info


Lanjut EIGRP>>

BGP (Border Gateway Protokol) Info Lanjut BGP>>

Berikut ini tabel perbedaan yang spesifik untuk kedua jenis routing:
Routing Statik
Berfungsi pada protocol IP

Routing Dinamik
Berfungsi pada inter-routing
protocol
Router
tidak
dapat Router membagi informasi
membagi informasi routing routing secara otomatis

Routing table dibuat dan


dihapus secara manual
Tidak menggunakan routig
protocol
Microsoft
mendukung
multihomed system seperti
router

Routing table dibuat dan


dihapus secara otomatis
Terdapat routing protocol,
seperti RIP atau OSPF
Microsoft mendukung RIP
untuk IP dan IPX/SPX

Demikian penjelasan mengenai Pengertian, Perbedaan Routing Static dan Routing Dynamic
semoga postingan ini bermanfaat.

AD JI Xroot
Dunia Teknologi dan Informasi

Home
Search her

TEchnologi

NETWORKING

Tips And Trick computer

Sitemap

About Me

Privacy Policy

Contact us

Home Cisco , NETWORKING Pengertian Dynamic Routing dan Contohnya | Cisco systems

Pengertian Dynamic Routing dan Contohnya


| Cisco systems
Written By Muhamad Adjie on Monday, May 18, 2015 | Monday, May 18, 2015
Malam cybermediainfo
Kali ini saya akan menejelaskan tentang routing dinamis atau dynamic routing.
Seperti yang sudah saya tulis di artikel sebelumnya ,yaitu Pengertian Routing dan Static
Routing .
Maka sesuai janji saya ,kali ini saya akan membahas tentang dynamic routing beserta
contoh-contohnya.
Seperti yang kita ketahui bahwa definisi atau arti kata dari routing adalah sebuah
proses untuk meneruskan paket paket jaringan ke network lain / jaringan lain yang tidak
terhubung langsung dengan si router melalui internetwork. dan routing static adalah
sebuah router yang tabel routingnya dikonfigurasi manual oleh administrator
jaringannya . Maka routing dinamis adalah kebalikannya dari routing static tersebut.
Karena routing dinamis adalah sebuah router yang tabel routing'nya dikonfigurasi

otomatis oleh protokol routing yang telah dipilih sebelumnya .


nah yang jadi pertanyaan'nya :

Apa sih routing dinamis / dynamic routing itu ?

Apa sih ciri-ciri dynamic routing itu ?

Apa sih tabel routing ?

Apa sih jenis jenis dari protokol routing dynamic tersebut ?

Sebelum itu kita lihat dulu gambar berikut ini

Gambar diatas adalah contoh routing dinamis menggunakan protokol routing OSPF
Single area, Oke akan saya jelaskan dibawah pengertian,dan jenis jenis dynamic
routing itu :
1. Pengertian dynamic routing
Dynamic routing adalah sebuah router yang memiliki dan membuat tabel routing
secara otomatis. Dengan menggunakan lalu lintas jaringan dan juga saling
berhubungan antara router lainnya . Protokol Routing mengatur router-router sehingga
dapat berkomunikasi satu dengan lain dan saling memberikan informasi antara satu
router dengan router lainnya dan juga saling memberikan informasi routing yang dapat
mengubah isi forwarding table, Tergantung keadaan jaringannya . Dengan cara ini ,
router router mengetahui keadaan jaringan yang terakhir dan mampu meneruskan data
kearah yang benar.
Dengan kata lain ,routing dinamik adalah proses pengisian data routing di table routing
secara otomatis
2. Ciri-Ciri Dynamic Routing

nah untuk ciri ciri dynamic routing tersebut adalah

Router berbagi informasi routing secara otomatis

Jumlah gateway sangat banyak .

Routing tabel dibuat secara dinamik.

Membutuhkan protokol routing (contohnya RIP ,OSPF, dll ).

3. Pengertian Tabel Routing


Tabel Routing adalah tabel yang memuat tentang seluruh IP address dari interfaces
router dan juga memuat tentang informasi routingnya.
Routing table hanya memberikan informasi sedangkan routing algoritma yang
menganalisa dan mengatur routing table. Intinya , router hanya tahu cara
menghubungkan network atau subnet yang terhubung langsung dengan router
tersebut.
dibawah ini adalah contoh dari routing table di packet tracer

4. Jenis-Jenis dari Protokol routing dinamis


Jenis jenis dari protokol routing dinamis itu beragam ,contohnya adalah :

RIP ( Routing Information Protocol ).

IGRP ( Internal Gateway Routing Protocol ).

EIGRP ( Enchanced Internal Gateway Routing Protocol ).

OSPF ( Open Shortest Path First ).

BGP ( Border Gateway Protocol ).

Demikian artikel saya mengenai routing dynamic ,untuk pengertian RIP ,EIGRP,
OSPF , dll nanti saya akan buatkan artikel khusus beserta konfigurasi'nya.
Related Posts :

Pengertian Routing dan Static Routi...

Pengertian MikroTik | MikroTik Know...

Cara Konfigurasi TP-LINK MR-3420 un...

7 OSI Layer dan Fungsinya | Penjela...