Anda di halaman 1dari 15

PERTEMUAN 5 PERANGKAT LUNAK APLIKASI

5. 1 Pendahuluan
Perangkat lunak aplikasi adalah perangkat lunak yang digunakan untuk melakukan
fungsi tertentu yang sesuai dengan kebutuhan pengguna. Berbeda dari Sistem Operasi,
perangkat lunak aplikasi tidak bertanggung jawab terhadap pengelolaan sumber daya
komputer maupun mengelola banyak pengguna.
Contoh perangkat lunak aplikasi adalah pengolah kata (seperti Microsoft Word),
pengolah angka (seperti Microsoft Excel), perangkat lunak untuk mengelola data statistik
(seperti SPSS), serta perangkat lunak untuk keperluan publishing, grafis dan multimedia.
Selain yang disebutkan di atas masih banyak terdapat bentuk dan jenis perangkat lunak
aplikasi untuk berbagai keperluan.
Dalam bab ini akan dipelajari mengenai perangkat lunak aplikasi pengolah kata,
pengolah data, pengolah data statistika, perangkat lunak aplikasi untuk desktop publishing,
grafis, dan multimedia. Setelah mempelajari bab ini mahasiswa diharapkan dapat
menggunakan perangkat lunak aplikasi tersebut.

5.2 Penyajian
Perangkat lunak aplikasi digunakan untuk melakukan fungsi tertentu sesuai dengan
kebutuhan pengguna. Perangkat lunak aplikasi dapat dikelompokkan ke dalam empat
kategori, yaitu bisnis, grafik dan multimedia, home/personal/pendidikan dan komunikasi
(Gambar 1). Perangkat lunak sistem yang telah dibahas pada pertemuan sebelumnya,
menyediakan interface antara pengguna, perangkat lunak aplikasi, dan hardware
komputer.

Gambar 1 Kategori perangkat lunak aplikasi

Dalam perangkat lunak aplikasi dengan antarmuka berbasis grafik, pengguna berinteraksi
dengan perangkat lunak tersebut melalui Window. Window merupakan area segi empat

Pertemuan 5 - Halaman 1
dari screen yang menampilkan program, data, dan/atau informasi. Kotak dialog
merupakan window khusus yang menyediakan informasi, menyajikan pilihan-pilihan yang
tersedia, atau permintaan respon (Gambar 2).

Gambar 2 Kotak dialog


Perangkat lunak aplikasi didistribusikan kepada pengguna melalui beberapa cara,
yaitu:
Packaged software: diproduksi secara masal untuk memenuhi berbagai kebutuhan
pengguna, bukan untuk pengguna tertentu saja. Sebagai contoh: MS. Word.
Custom software: melakukan fungsi spesifik untuk industri atau bisnis.
Open source: tersedia untuk digunakan, dimodifikasi, dan didistribusikan.
Biasanya dapat di-download dari Web secara gratis.
Shareware: copyrighted software, didistribusikan secara gratis untuk periode trial
Freeware: copyrighted software yang tersedia secara gratis
Public-domain software: freeware tanpa batasan copyright dan telah didonasikan
untuk penggunaan publik
Dalam Windows XP, program aplikasi dapat dipilih dari desktop, klik button Start,
pilih All Programs, dan klik pada nama perangkat lunak aplikasi. Setelah langkah tersebut
dilakukan, instruksi-instruksi program dimuat ke dalam memori.
Dalam perangkat lunak aplikasi, pengguna dihadapkan pada Window, yaitu area
segi empat dari screen yang menampilkan program, data, dan/atau informasi. Kotak dialog
merupakan Window khusus yang menyediakan informasi, menyajikan pilihan-pilihan yang
tersedia, atau permintaan respon dari pengguna.

Perangkat Lunak Pengolah Kata


Perangkat lunak pengolah kata adalah perangkat lunak yang memudahkan
pengguna untuk mengolah kata dalam sebuah dokumen. Contoh perangkat lunak pengolah
kata adalah WordStar, AmiPro, WordPerfect, Microsoft Word, dan masih banyak lagi.
Namun dari sekian banyak perangkat lunak pengolah kata, Microsoft Word (MS Word)

Pertemuan 5 - Halaman 2
merupakan program pengolah kata yang paling banyak dipakai saat ini dibandingkan
dengan program pengolah kata lainnya. Hal ini karena MS Word memiliki berbagai
kelebihan dari segi kemudahan penggunaan, tampilan yang lebih menarik dan user friendly
serta fasilitas tambahan yang ada didalamnya seperti kemampuan dalam membuat tabel,
menyisipkan gambar dan menyisipkan hasil dari program lain, dan lain sebagainya.
Secara umum kegunaan program pengolah kata adalah sebagai berikut:
1. Membuat dokumen sederhana sampai kompleks
Dengan menggunakan program pengolah kata membuat dokumen dengan berbagai
bentuk dan ukuran untuk berbagai keperluan menjadi sangat mudah. Program pengolah
kata umumnya dilengkapi dengan fasilitas untuk membantu pengguna dalam
melakukan penyuntingan atau modifikasi terhadap format dokumen yang diinginkan.
Mulai dari membuat dokumen sederhana seperti surat, label surat, amplop surat,
sampai dokumen yang lebih kompleks seperti laporan tahunan, proposal, laporan
ilmiah, dan lain sebagainya. Selain kata, kita dapat juga menyisipkan tabel dari MS
Excel atau dari program pengolah data lainnya, gambar, animasi dan bentuk-bentuk
lainnya dalam sebuah dokumen.

Gambar 3 Dokumen dalam perangkat pengolah kata


2. Membuat berbagai aplikasi cetakan
Selain dokumen yang berisi kata dalam bentuk yang stkitar, program pengolah kata
seperti MS Word juga dapat digunakan untuk membuat berbagai aplikasi cetakan
seperti brosur, leaflet, pampflet, bentuk majalah dan surat kabar, serta bentuk-bentuk
aplikasi cetakan lainnya.
3. Membuat surat masal
Sebuah surat seringkali tidak hanya ditujukan untuk satu atau dua orang saja. Dalam
sebuah organisasi atau instansi surat merupakan sebuah dokumen yang dikirimkan ke
banyak orang, misalnya surat undangan. Untuk surat yang dikirimkan secara masal MS
Word menyediakan sebuah fasilitas yang dapat memudahkan pembuat surat, yaitu
fasilitas Mail Merge. Dengan mail merge pembuat surat tidak perlu melakukan
personalisasi terhadap nama, alamat, dan data dari setiap penerima surat satu persatu.
Pembuat surat dapat berkonsentrasi pada suratnya, kemudian memasukkan data

Pertemuan 5 - Halaman 3
penerima surat ke dalam sebuah tabel. Tabel dan suratnya kemudian digabungkan
(merge) untuk personalisasi secara otomatis dan di cetak.

Perangkat Lunak Pengolah Angka


Perangkat lunak pengolah angka adalah perangkat lunak yang memudahkan
pengguna untuk mengolah data dalam bentuk angka (numerik). Contoh perangkat lunak
pengolah angka adalah Microsoft Excel (MS Excel). Karena dibuat untuk mengolah angka,
umumnya perangkat lunak pengolah angka memiliki daerah kerja berbentuk tabular/tabel,
yang terdiri dari baris dan kolom. Sebagai pengolah angka, perangkat lunak ini dilengkapi
dengan kemampuan untuk menghitung menggunakan rumus dan membuat grafik.
Perangkat lunak pengolah angka adalah perangkat lunak yang memudahkan pengguna
untuk mengolah data dalam bentuk angka (numerik). Dengan program pengolah angka,
daftar buku, majalah, surat kabar, dan bahan pustaka lainnya dalam perpustakaan sekolah
dapat dibuat dan dikelola dengan mudah. Penghitungan jumlah total bahan pustaka per
tahun dan persentase tiap bahan pustaka terhadap total bahan pustaka yang terdapat di
perpustakaan dapat dilakukan menggunakan rumus yang dimiliki oleh MS Excel.
Selain itu, dengan perangkat lunak pengolah angka, pembuatan grafik perkembangan
tahunan dari data-data bahan pustaka akan sangat mudah dilakukan. Tipe grafik yang dapat
dihasilkan pun beragam, mulai dari diagram batang, sampai diagram kue 3 dimensi.
Secara umum, program pengolah angka berguna untuk:
1. Mengolah data menggunakan rumus
Penggunaan rumus untuk melakukan perhitungan matematis, statistik, dan perhitungan
angka lainnya sangat mudah. Dengan memasukkan data yang akan diolah ke dalam
rumus yang akan digunakan, maka MS Excel akan menghitung secara otomatis. Jika
data asalnya diubah, maka hasil perhitungan rumus secara otomatis akan ikut berubah.
Pada Gambar 4 terlihat penggunaan rumus SUM untuk menghitung total bahan pustaka
(buku, modul, majalah, surat kabar, dan jurnal) pada tahun 1990.

Rumus Total
Penjumlahan

Gambar 4 Penggunaan rumus untuk menghitung total bahan pustaka.


Selain rumus yang umum digunakan seperti menghitung jumlah (SUM) atau rata-rata
(AVERAGE), MS Excel menyediakan banyak lagi fungsi yang dikelompokkan ke
dalam sejumlah kategori antara lain: Statistik, Keuangan, Tanggal & Waktu, Teks.
2. Pengelompokan dan pengurutan data.
Selain melakukan perhitungan, MS Excel juga dapat digunakan untuk pengelompokan
dan pengurutan data. Data nilai siswa pada Gambar 5 dapat dengan mudah
dikelompokkan, baik berdasarkan kelas atau nilainya. Pengelompokan ini juga dapat

Pertemuan 5 - Halaman 4
mengurutkan data tersebut, baik secara menaik (ascending) maupun secara menurun
(descending).

Gambar 5 Pengelompokan data siswa berdasarkan Kelas dan Nilai

Pada Gambar 5 pengelompokan dilakukan berdasarkan kelas dengan urutan menaik


(ascending), kemudian hasilnya diurutkan kembali berdasarkan nilai dengan urutan
menurun (descending).
MS Excel juga menyediakan fungsi Filter (penyaringan data) agar data yang muncul di
layar hanya data yang diinginkan.

Gambar 6 Hasil penyaringan data siswa kelas 3


Tabel yang tampak pada Gambar 6 adalah hasil yang diperoleh dari penyaringan data
siswa kelas 3 menggunakan fungsi filter.
3. Membuat grafik dari data yang ada

Gambar 7 Grafik sebaran bahan pustaka berdasarkan data bahan pustaka tahunan
MS Excel menyediakan fasilitas untuk membuat berbagai macam bentuk grafik
berdasarkan data yang ada (Gambar 7). Pembuatan grafik dalam MS Excel cukup

Pertemuan 5 - Halaman 5
mudah, yaitu dengan memasukkan lokasi data asal, dan memilih tipe serta format
grafik yang diinginkan., lalu MS Excel akan membuatkan grafik tersebut. Gambar 8
menunjukkan sejumlah grafik yang disediakan oleh MS Excel.

Gambar 8 Beberapa tipe grafik yang disediakan oleh MS Excel

Perangkat Lunak Pengolah Data Statistik


Untuk melakukan pengolahan data statistik telah banyak digunakan perangkat
lunak seperti SPSS, Microstat, SAS, Micro TSP, dan MINITAB. SPSS for Windows
digunakan untuk analisis statistika dan menyediakan sistem manajemen data dalam
lingkungan grafis. Terdapat tujuh windows dalam SPSS, yaitu:
Data Editor. Window menampilakn isi dari file data. Dalam Data Editor kita dapat
membuat file data yang baru atau memodifikasi file data yang telah ada sebelumnya. Data
Editor terbuka secara otomatis ketika pertama kali SPSS dijalankan. Berikut adalah
tampilan Data Editor:

Gambar 9 Tampilan Data Editor

Viewer. Semua hasil statistikal, tabel, dan chart ditampilkan dalam Viewer. Kita dapat
mengubah output dan menyimpannya untuk digunakan pada waktu mendatang. Window

Pertemuan 5 - Halaman 6
Viewer akan terbuka secara otomatis pada saat pertama kali pengguna menjalankan
prosedur untuk membangkitkan output.

Gambar 10 Tampilan Viewer

Draft Viewer, digunakan untuk menampilkan output sebagai teks sederhana.


Pivot Table Editor. Output yang ditampilkan dalam tabel-tabel pivot dapat dimodifikasi
dalam beberapa cara dengan Pivot Table Editor. Kita dapat mengedit teks, menukar data
dalam baris dan kolom, menambahkan warna, membuat tabel multidimensi, serta
menyembunyikan dan menampilkan hasil secara selektif.
Chart Editor, digunakan untuk memodifikasi chart resolusi tinggi dan plot dalam
windows Chart. Dalam Chart Editor dapat dilakukan pengubahan warna, pemilihan tipe
dan ukuran font, menukar sumbu horizontal dan vertical, merotasi scatterplot 3-D, dan
bahkan mengubah tipe chart.
Text Output Editor. Text output yang tidak ditampilkan dalam tabel pivot dapat
dimodifikasi dengan Text Output Editor. Dengan Text Output Editor output dan juga tipe,
gaya dan ukuran font dapat diubah.
Syntax Editor. Pilihan-pilihan pada kotak dialog dapat disalin ke dalam Window syntax,
dimana pilihan-pilihan tersebut muncul dalam bentuk syntax perintah. Sintaks tersebut
dapat diedit untuk penggunaan fitur khusus dari SPSS yang tidak tersedia dalam kotak
dialog. Perintah dapat disimpan dalam sebauh file untuk digunakaan dalam session-
session SPSS berikutnya.
Script Editor, digunakan untuk membuat dan memodifikasi script dasar. Scripting
memungkinkan pengguna untuk meng-customize tugas-tugas dalam SPSS.
Dalam Data Editor terdapat beberapa menu, yaitu:
File, berfungsi untuk menangani hal-hal yang berhubungan dengan file data, seperti
membuat file baru, membuka file tertentu, mengambil data dari program lain, mencetak isi
dari Data Editor.

Pertemuan 5 - Halaman 7
Edit, berfungsi untuk menngani hal-hal yang berhubungan dengan memperbaiki atau
mengubah nilai data (duplikasi data, menghilangkan data, mengubah data dan lainnya).
Selain itu, menu Edit juga berfungsi mengubah setting pada sub menu Options.
View, berfungsi untuk mengatur toolbar (status bar, value label dan lain-lain).
Data, berfungsi untuk membuat perubahan data SPSS secara keseluruhan, seperti
mengurutkan data, menyeleksi data berdasarkan kriteria tertentu, menggabungkan data dan
sebagainya.
Transform, berfungsi untuk membuat perubahan pada variabel yang telah dipilih dengan
kriteria tertentu.
Statistics, meupakan menu ini dari SPSS, yang berfungsi untuk melakukan semua
prosedur perhitungan statistik, seperti uji t, uji F, regresi, time series.
Graphs, berfungsi untuk membuat berbagai jenis grafik untuk mendukung analisis statistik
seperti Pie, Line, Bar dan kombinasinya.
Utilities, merupakan menu tambahan yang mendukung program SPSS, contohnya dalam
hal memberi informasi tentang variabel yang sedang dikerjakan, menjalankan script, dan
mengatur tampilan menu-menu lain.
Window, berfungsi untuk berpindah (switch) diantara menu-menu yang lain di SPSS.
Help, berfungsi untuk menyediakan bantuan informasi mengenai program SPSS yang bisa
diakses secara mudah dan jelas.

Perangkat Lunak Pengolah Grafis


Perangkat lunak pengolah grafis adalah jenis perangkat lunak aplikasi yang dapat
digunakan untuk membuat dan memodifikasi gambar. Ada banyak sekali perangkat lunak
pengolah grafis yang muncul di pasaran, beberapa diantaranya adalah Adobe Photoshop,
Corel Draw, dan Ulead Photoimpact. Adobe Photoshop adalah perangkat lunak pengolah
grafis yang mudah dioperasikan dan banyak digunakan. Oleh karena itu, pada bahasan kali
ini kita akan lebih fokus membahas Adobe Photoshop.
Adobe Photoshop merupakan program aplikasi untuk membuat dan mengolah
gambar secara profesional. Adobe Photoshop dibuat oleh Adobe System Incorporated.
Gambar yang diolah pada Adobe Photoshop dapat berupa gambar bitmap atau gambar
vektor. Kedua-duanya dapat diberi berbagai efek menarik sehingga gambar menjadi lebih
bagus dan indah.
Adobe Photoshop mendukung berbagai format file gambar. Adobe Photoshop juga
memberi kemudahan dalam hal pewarnaan dan penentuan resolusi gambar. Adobe
Photoshop dapat digunakan untuk desain logo, desain halaman web, membuat layout
percetakan, mengolah foto digital, atau bahkan melukis secara digital. Adobe Photoshop
sangat fleksibel dan mudah digunakan. Segala kelebihan yang dimiliki oleh Adobe
Photoshop telah membuatnya banyak digunakan oleh para desainer profesional. Hampir
semua desainer web di jagad raya ini pernah memakai Adobe Photoshop.
Antarmuka Adobe Photoshop dapat diatur sesuai keinginan pengguna, namun
biasanya Adobe Photoshop memiliki antarmuka sebagai berikut:

Pertemuan 5 - Halaman 8
Menu Bar Option Bar Palet -Palet

Tool Box Lembar kerja / Kanvas Status Bar

Gambar 11 Antarmuka Adobe Photoshop


Menu Bar berisi menu-menu utama Adobe Photoshop. Misalnya: menu [File] untuk
mengolah file, menu [Layer] untuk mengolah layer, menu [Filter] untuk memberi filter dan
beberapa menu lainnya. Pada masing-masing menu terdapat beberapa submenu yang lain.
Option Bar berisi berbagai tombol perintah yang dapat digunakan untuk mengolah
gambar, tampilan Option Bar akan berubah-ubah tergantung dari Tool yang sedang
digunakan.
Palet berisi berbagai fasilitas untuk melakukan manipulasi terhadap gambar.
Tool Box berisi tool-tool yang dapat digunakan untuk membuat gambar, manupalasi
gambar, membuat teks, mengatur warna dan lain-lain.
Lembar kerja merupakan tempat dimana gambar dibuat dan diolah.
Status Bar berisi keterangan mengenai file gambar yang sedang dibuka. Dalam Status Bar
juga dapat dilihat berbagai tips penggunaan Adobe Photoshop .
Dalam hal mewarnai gambar, Adobe Photoshop mengenal istilah Blending Mode.
Blending Mode adalah mode yang digunakan untuk proses pencampuran warna, yaitu
ketika sebuah warna pada gambar diganti/ditimpa dengan warna baru. Ada tiga buah warna
yang terlibat dalam proses pencampuran warna, yaitu: Base Color, Blend Color dan
Result Color.
Base Color adalah warna dasar sebelum proses pencampuran warna. Blend Color adalah
warna yang digunakan untuk menimpa warna awal. Result Color adalah warna hasil
pencampuran Base Color dengan Blend Color.

Pertemuan 5 - Halaman 9
Berikut ini adalah beberapa Blending Mode yang dapat digunakan :
Normal, mode stkitar dalam Adobe Photoshop, pada mode ini Blend Color akan langsung
menjadi Result Color tanpa memperhitungkan Base Color.
Dissolve, Result Color dapat berupa Base Color atau Blend Color secara acak, tergantung
dari opacity yang digunakan.
Behind, mengubah warna hanya pada bagian gambar yang transparan.
Clear, mengubah warna pada gambar menjadi transparan.
Darken, memilih warna yang paling gelap antara Base Color atau Blend Color lalu
menjadikannya sebagai Result Color.
Multiply, melihat informasi warna pada setiap channel warna lalu mengalikan antara nilai
Base Color dengan Blend Color. Result Color yang dihasilkan selalu berupa warna yang
lebih gelap dari Base Color.
Color Burn, melihat informasi warna pada setiap channel warna lalu mempergelap Base
Color untuk memantulkan Blend Color dengan meningkatkan kontras warna.
Linear Burn, melihat informasi warna pada setiap channel warna lalu mempergelap Base
Color untuk memantulkan Blend Color dengan menurunkan tingkat kecerahan warna
(brightness).
Lighten, memilih warna yang paling terang antara Base Color atau Blend Color lalu
menjadikannya sebagai Result Color.
Screen, melihat informasi warna pada setiap channel warna lalu mengalikan warna
kebalikan (inverse) Base Color dengan warna kebalikan Blend Color. Warna kebalikan
dari hitam adalah putih.
Color Dodge, melihat informasi warna pada setiap channel warna lalu mempercerah Base
Color untuk memantulkan Blend Color dengan menurunkan kontras warna.
Linear Dodge, melihat informasi warna pada setiap channel warna lalu mempercerah Base
Color untuk memantulkan Blend Color dengan menaikkan tingkat kecerahan warna
(brightness).
Overlay, melakukan proses multiply atau screen terhadap warna tergantung dari Base
Color yang digunakan.
Soft Light, mempergelap atau mempercerah warna, tergantung dari Blend Color.
Hard Light, melakukan proses multiply atau screen terhadap warna tergantung dari Blend
Color yang digunakan.
Vivid Light, melakukan proses burn atau dodge terhadap warna dengan meningkatkan
atau menurunkan kontras warna, tergantung dari Blend Color yang digunakan.
Linear Light, melakukan proses burn atau dodge terhadap warna dengan meningkatkan
atau menurunkan tingkat kecerahan warna, tergantung dari Blend Color yang digunakan.
Pin Light, mengganti warna tergantung dari Blend Color yang digunakan. Jika Blend
Color lebih cerah dari abu-abu, maka Base Color yang lebih gelap dari Blend Color akan
diganti. Jika Blend Color lebih gelap dari abu-abu, maka Base Color yang lebih terang dari
Blend Color akan diganti.
Difference, melihat informasi warna pada setiap channel warna lalu mengurangkan nilai
Base Color dengan Blend Color atau sebaliknya, tergantung dari nilai kecerahan yang

Pertemuan 5 - Halaman 10
dimiliki. Yang memiliki nilai kecerahan lebih besar akan dikurangkan dengan yang nilai
kecerahannya lebih kecil.
Exclusion, menghasilkan efek yang hampir sama dengan Diffrence tetapi warnanya tidak
terlalu kontras.
Hue, menghasilkan Result Color dengan luminance dan saturation dari Base Color, serta
hue dari Blend Color.
Saturation, menghasilkan Result Color dengan luminance dan hue dari Base Color, serta
saturation dan dari Blend Color.
Color, menghasilkan Result Color dengan luminance dari Base Color, serta hue dan
saturation dari Blend Color.
Luminosity, menghasilkan Result Color dengan hue dan saturation dari Base Color, serta
luminance dari Blend Color.

Ketika membuat atau memodifikasi gambar dengan Adobe Photoshop, Kita akan
menggunakan konsep Layering. Layer dapat diibaratkan seperti sebuah kertas transparan
dan disusun secara bertumpuk. Karena sifatnya yang transparan, maka kita dapat melihat
isi sebuah layer yang berada di bawah layer lain.
Kita dapat membuat atau meletakkan sebuah gambar pada masing-masing layer, serta
dapat memodifikasinya secara terpisah tanpa saling mengganggu satu sama lain.
Setiap layer dalam lembar kerja harus memiliki mode pewarnaan yang sama. Layer-layer
tersebut dapat dihapus, diubah urutannya, digabung atau diatur perataanya.

Gambar 12 Ilustrasi beberapa buah Layer yang bertumpuk


Kita juga dapat menambahkan beberapa Layer Style atau Filter saat memodifikasi gambar.
Layer Style digunakan untuk memberikan beberapa efek menarik pada Layer tempat
gambar tersebut berada. Kita dapat menggunakan beberapa Style sekaligus pada Layer
yang sama agar diperoleh efek yang dinginkan. Berikut ini adalah beberapa Style yang
dapat dipilih saat menambah Layer Style:
Drop Shadow, menambah bayangan di bagian belakang Layer.
Inner Shadow, menambah bayangan di bagian dalam tepi Layer.
Outer Glow dan Inner Glow, untuk menambah sinar yang muncul dari bagian dalam atau
bagian luar Layer.
Bevel and Emboss, untuk menambahkan efek timbul dengan bayangan dalam kombinasi
tertentu.
Satin, untuk memberikan efek seperti kain satin.
Color Overlay, Gradient Overlay, dan Pattern Overlay digunakan untuk menutupi
Layer dengan warna, gradasi warna atau pola tertentu.

Pertemuan 5 - Halaman 11
Strokes, memberi outline pada objek gambar dengan warna, gradasi warna atau pola
tertentu.
Filter digunakan untuk menghasilkan berbagai efek yang menarik langsung pada gambar.
Beberapa Filter tersebut antara lain : Artistic, Blur, Brush Strokes, Distort, Noise,
Pixelate, Render, Sharpen, Sketch, Stylize, Texture, Video dan lain-lain. Berikut ini
adalah contoh gambar yang dibuat dengan Adobe Photoshop:

Gambar 13 Contoh gambar yang dibuat dengan Adobe Photoshop

Perangkat Lunak Desktop Publishing


Perangkat lunak dekstop publishing adalah jenis perangkat lunak aplikasi yang
digunakan untuk mendesain dan memproduksi sebuah dokumen publikasi yang terdiri atas
teks dan gambar. Perangkat lunak dekstop publishing biasanya digunakan dalam industri
percetakan, majalah, dll. Contoh dari perangkat lunak dekstop publishing adalah
QuarkXPress, Adobe Pagemaker, dan Microsoft Publisher.

Gambar 14 QuarkXPress

Pertemuan 5 - Halaman 12
Perangkat Lunak Multimedia
Perangkat lunak multimedia adalah jenis perangkat lunak aplikasi yang digunakan
untuk menggabungkan atau menyusun teks, gambar, suara, video, dan animasi menjadi
sebuah produk multimedia yang enak dilihat serta enak didengar. Ada banyak sekali
perangkat lunak multimedia yang tersedia di pasaran, beberapa diantaranya adalah
Macromedia Flash MX, Swish, dll. Macromedia Flash MX adalah perangkat lunak
multimedia yang mudah dioperasikan dan banyak digunakan. Oleh karena itu, pada
bahasan kali ini kita juga akan lebih fokus membahas Macromedia Flash MX.
Macromedia Flash MX dibuat oleh Macromedia Inc, yang merupakan pengembangan dari
Macromedia Flash 5. Macromedia Flash MX termasuk dalam suite aplikasi Macromedia
Studio MX.
Macromedia Flash MX merupakan sebuah program aplikasi profesional untuk
menggambar grafis dan animasi. Animasi yang dibuat menggunakan Flash MX dapat
berupa animasi vektor atau gambar bitmap. Animasi tersebut biasanya digunakan untuk
membuat halaman web yang interaktif.
Selain untuk pembuatan web interaktif, Flash MX juga dapat digunakan untuk pembuatan
logo animasi, game, form interaktif, movie, iklan, screen saver, dan beberapa aplikasi lain
yang membutuhkan desain animasi yang cantik dan dinamis.
Macromedia Flash MX memiliki tampilan yang menarik serta didukung oleh tool-tool
yang mudah digunakan, sehingga Flash MX telah menjadi pilihan banyak Web
Programmer dan Web Desainer. Selain itu, Flash MX juga mendukung format file Flash 5,
sehingga memudahkan bagi setiap orang yang pernah menggunakan Flash 5.
Macromedia Flash MX memiliki antarmuka seperti berikut :

Gambar 15 Antarmuka Macromedia Flash MX

Pertemuan 5 - Halaman 13
Pada Gambar 15 ditampilkan beberapa bagian yang penting dan sering digunakan pada
saat proses desain animasi, yaitu :
Menu Bar: berisi menu-menu utama Macromedia Flash MX. Misalnya : menu untuk
mengolah file [File], menu untuk pengeditan [Edit], menu untuk mengatur tampilan [View]
dan lain-lain. Di dalam menu-menu tersebut juga akan terdapat beberapa sub-menu yang
lain.
Stage: Sebuah area untuk membuat animasi. Stage dapat diibaratkan kanvas untuk
mengkomposisi frame-frame sehingga membentuk sebuah movie.
Timeline Panel: Sebuah panel yang digunakan untuk mengatur isi sebuah movie.Pada
panel ini kita dapat mengatur kapan sebuah objek muncul dan kapan sebuah objek hilang.
Color Swatch Panel: Panel yang digunakan untuk pengaturan palet warna. Pada panel ini
terdapat contoh-contoh warna.
Color Mixer Panel: Sebuah panel untuk membuat atau mengubah warna serta gradasi
warna. Panel ini juga bisa digunakan untuk menambahkan warna baru pada Color Swatch
Panel.
Tools Box: Tempat tool-tool yang sering digunakan untuk membuat dan memodifikasi
objek, membuat teks, mengolah warna dan mengatur stage.
Actions Panel: Panel yang digunakan untuk membuat dan mengubah aksi pada movie
menggunakan Bahasa Pemrograman Action Script.
Property Inspector: Panel yang digunakan untuk mengubah atribut-atribut objek.
Tampilan Property Inspector selalu berubah tergantung dari objek yang kita pilih.
Components Panel: Panel yang berisi klip-klip movie khusus yang memiliki sarangkaian
method dan properti yang dapat di atur sesuai kebutuhan.

Ada beberapa istilah yang perlu Kita ketahui ketika menggunakan Macromedia Flash MX,
yaitu :
Artwork : Artwork dapat berupa objek gambar vektor, gambar bitmap, teks, video atau
obke-objek lain. Artwork dapat dibuat dengan memanfaatkan tool-tool yang tersedia dalam
Flash MX. Artwork juga dapat diimpor dari aplikasi lain.
Stroke dan Fill : Sebuah gambar bentuk dalam Flash MX terdiri dari garis luar yang
membatasi bentuk tersebut (Stroke) dan isi dari bentuk itu (Fill). Kedua komponen tersebut
dapat dipisahkan, sehingga masing-masing berdiri sendiri.
Layer : Lapisan-lapisan yang memuat Artwork. Layer biasanya bersifat transparan. Dalam
setiap Layer terdapat Frame atau Keyframe.
Frame : Bagian dari animasi yang menunjukan setiap perubahan yang terjadi.
Keyframe : Sebuah frame yang mendefinisikan perubahan objek dalam animasi.
Simbol : Image, tombol atau klip movie yang dapat dipergunakan kembali. Simbol cukup
dibuat sekali, dan dapat dipergunakan berulangkali.
Instance : Merupakan hasil cetakan dari simbol. Jika simbol diibaratkan sebagai cetakan
kue, maka instance adalah kue hasil cetakannya.
Animasi : Proses bergeraknya objek atau beberapa objek dari suatu posisi ke posisi lain.
Proses berubahnya ukuran atau bentuk suatu objek juga dapat disebut sebagai animasi. Ada

Pertemuan 5 - Halaman 14
dua jenis animasi yang dapat dibuat menggunakan Macromedia Flash MX, yaitu Animasi
frame-by-frame dan Animasi tweening yang terdiri atas motion tweening dan shape
tweening.
Movie : Movie adalah hasil dari Animasi. Serangkaian animasi dapat membentuk sebuah
Movie.
Berikut ini adalah contoh dari sebuah produk multimedia yang dibuat menggunakan
Macromedia Flash :

Gambar 16 Contoh produk multimedia yang dibuat dengan Macromedia Flash MX


Perangkat lunak lain yang banyak digunakan adalah
Perangkat lunak paint/image editing: digunakan untuk membuat dan memodifikasi
gambar grafis.
Perangkat lunak video dan audio editing: perangkat lunak video editing digunakan
untuk memodifikasi segmen video, dinamakan clip. Perangkat lunak audio editing
digunakan untuk memodifikasi audio clip.
Perangkat lunak multimedia authoring: digunakan untuk mengkombinasikan teks,
grafik, audio, video, dan animasi ke dalam sebuah presentasi interaktif.
Perangkat lunak basisdata: digunakan untuk membuat dan mengelola basis data
Perangkat lunak presentasi: digunakan untuk membuat alat bantu visual untuk
presentasi, yang sering dikenal sebagai slide show.
Perangkat lunak manajemen proyek: digunakan untuk merencanakan,
menjadwalkan, melacak, dan menganalisis event, sumber daya, dan biaya dari
sebuah proyek.
Computer-aided design (CAD): perangkat lunak yang digunakan untuk membuat
rancangan seperti rancangan arsitektur.

Pertemuan 5 - Halaman 15

Anda mungkin juga menyukai