Anda di halaman 1dari 6

Configuration NAT Static and Dynamic on Cisco Router

with GNS3 simulator


- GNU Public Licensed -

OK Guys...pada tulisan saya kali ini, saya ingin membahas tentang


Network Address Translation yang biasa disingkat dengan NAT. Sebelumnya
apa sich NAT itu ? Sejauh pemahaman saya bahwa NAT itu adalah cara /
metode pemetaan suatu ip private ke ip public agar si ip private itu
bisa diakses / mengakses WAN (Wide Area Networking). Kenapa begitu ?
Kita tahu bahwa pada dasarnya ip private itu tidak boleh dipakai pada
jaringan internet public, namun di sisi yang lain jumlah ip public yang
tersedia juga sangat terbatas. Padahal pengguna internet saat ini sudah
cukup banyak. Oleh karena itu muncul lah teknik NAT ini, selain untuk
mengatasi problem di atas, NAT juga terkadang digunakan untuk alasan
security.
Saat ini sudah banyak vendor router yang sudah mensupport fitur NAT ini,
mulai dari yang PC Router open source sampai dengan produk khusus untuk
Router yang cukup terkenal semuanya sudah support akan NAT. Salah satu
vendor router yang cukup terkenal adalah Cisco Systems. Di sini saya
memang tidak secara langsung menggunakan mesin Cisco router yang asli,
tapi saya melakukannya dengan sebuah mesin simulation yang berbasis open
source yang cukup powerfull yaitu GNS3. Simulator ini dapat Anda
download di internet secara gratis, tutorial mengenai cara installasi
dan pemakaian nya pun sudah banyak tersedia di Google. Untuk memulai nya
mungkin Anda bisa melihat network topology di bawah ini...
Keterangan :
− Gambar Awan = biasanya menggambarkan suatu WAN / LAN, tapi untuk kali
ini saya gunakan untuk menggambarkan sebuah mesin PC Client / Server.
− SW0 = Switch
− Rhea = Hostname dari mesin router, type router yang digunakan adalah
Cisco 3600 series.
− Untuk angka yang diawali tanda titik (misal; .10, .1, .2) itu berarti
nomor IP pada octave terakhirnya. Jadi untuk .10 berarti lengkapnya
adalah 167.205.0.10 karena angka .10 berada pada network
167.205.0.0/23

Sedangkan untuk file configuration nya bisa Anda dilihat di bawah ini:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname Rhea

boot-start-marker

boot-end-marker

no aaa new-model
ip subnet-zero

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Ethernet2/0

ip address 167.205.0.1 255.255.254.0

ip nat outside

no ip split-horizon
ip summary-address rip 167.205.0.0 255.255.254.0

half-duplex

interface Ethernet2/1

ip address 10.1.0.2 255.255.0.0

ip nat inside

no ip split-horizon

ip summary-address rip 10.1.0.0 255.255.0.0

half-duplex

interface Ethernet2/2

no ip address

shutdown

half-duplex

interface Ethernet2/3

no ip address

shutdown

half-duplex
!

router rip

version 2

network 10.0.0.0

network 167.205.0.0

no auto-summary

ip nat pool Yupiter 167.205.0.6 167.205.0.9 netmask 255.255.254.0

ip nat inside source list 10 pool Yupiter

ip nat inside source static 10.1.0.5 167.205.0.5 extendable

ip http server

ip classless

access-list 10 permit 10.1.0.0 0.0.255.255

control-plane

gatekeeper

shutdown
!

line con 0

line aux 0

line vty 0 4

login

!
!

end

Simpanlah file tersebut dengan extensi/type .cfg (misal Rhea.cfg). Lalu


gunakan file tersebut sebagai file startup-configuration router Anda.
Untuk melakukan testing apakah sudah berhasil atau belum bisa Anda
gunakan perintah-perintah berikut ;
Rhea#show ip nat translation
Rhea#show ip nat statistics
Rhea#debug ip nat

Untuk selengkapnya bisa Anda lihat pada dokumentasi Cisco tentang


Configuration Network Address Translation.

Selamat ber-eksperimen...(^_^)

Author
Rakhmadian Purnama, lahir 11 Desember 1987 di kota
Sidoarjo, Jawa Timur-IND. Pada saat membuat tulisan ini,
saya masih duduk sebagai mahasiswa di Institute Teknologi
Bandung jurusan Teknik Fisika angkatan 2006. Hoby baca
buku-buku IT, denger music, ngNet, Ngoprex, dan melakukan
hal-hal aneh lainnya. Bercita-cita sebagai seorang Network
Engineer yang bersertifikasi CCIE untuk Security track. Contact person

rakhmadian_purnama@yahoo.com