Anda di halaman 1dari 13

Tips Membuat Game Sederhana Pakai Blender

Ini adalah latar belakang saya menggunakan Blender.


Sebelumnya saya telah mengatakan bahwa “Blender sangat mudah digunakan untuk
membuat”, saya berkata demikian karena saya telah banyak memakai program untuk membuat game.
Dulu saya juga enggan menggunakan Blender, karena Blender belum terkenal dan saya belum bisa
menggunakannya.
Jadi saya menggunakan program lain untuk membuat game. Tetapi lama-kelamaan saya jadi
bosan menggunakan program lain karena dihadapi masalah dengan “ Download yang terlalu
besar,yang didownload pun trial hanya pakai beberapa hari dah gak bisa pakek lagi,mesti cari
‘cracknya, biar full,dan setiap kali ada update yang baru hanya bisa didownload yang demo,disitu
ditulis ‘Belilah kalau mau yang fullversion’. Kan itu membuat kita bosan.
Pertama kali saya menggunakan Blender,saya sangat bingung karena sudah terbiasa pakek
program lain. Tapi setelah beberapa bulan saya pakek Blender, saya sudah lumayan bisa dan karena
membaca tutorial-tutorial yang ada jadi saya sekarang sudah mahir menggunakan Blender.”Gak
mahir-mahir kali sih”.
Dari situlah awal saya menggunakan Blender.”Memang susah untuk mengubah sesuatu yang
telah lebih awal kita kenal”, seperti pacar pertama gitu, susah buat dilupakan dan diganti sama yang
baru. Begitu juga sama halnya dengan program-program yang telah kita kenal lebih dulu. “susah buat
diganti” hehehe.
Alasan saya menggunakan Blender adalah yang pertama ‘free’, bisa diupdate dengan
gratis,memiliki game engine sendiri,bisa dipakai untuk membuat FILM,GAME,dan EDUCATIONS,
fitur yang dimiliki blender cukup lengkap untuk membuat film,maupun game,karena dikembangkan
bersama-sama seluruh dunia, jadi Blender bisa dikatakan program yang dibuat sesuai kebutuhan dan
keinginan bersama.

Wrote by Elfazzikra@ymail.com
Mari kita mulai aja.
Pertama yang harus diperhatikan adalah anda harus sudah menguasai dasar-dasar Blender. Jika anda
sudah mahir, tidak akan terjadi masalah yang berarti. Jika belum silahkan baca tutorial disini
http://my.opera.com/elfaz

Disini kita akan mengenal antar muka blender terlebih dulu, ini merupakan antar muka Blender
Version 2.49. Minimal kamu membutuhkan Blender 2.46 atau lebih tinggi karena fiturnya sama
dengan yang 2.49, sedangkan untuk versi dibawah 2.46 mungkin ada perbedaan menu.

Tapi kamu lebih baik menggunakan versi yang baru, karena terdapat beberapa fitur baru, yang tidak
dimiliki oleh vesi lama.
Ω Mengenal Menu-menu di Blender
• Menu File.

# Save Game As Runtime berfungsi untuk membuat file EXE,(eksekusi)


# Export dan Import di Blender bisa dibilang cukup lengkap dan bisa menambahkan sendiri,
• Menu Game

# Star Game untuk memulai game atau tekan “P”


# Show Framerate and Profile untuk menampilkan Framerate
# Texture Face Materials adalah menggunakan hanya satu texture yang ada pada objek
# Blender Multitexture Materials adalah menggunakan campuran texture dan material
# Blender GLSL Materials untuk menggaktifkan “shader “. Untuk mengaktifkan fungsi ini
dibutuhkan VGA ATI X300/NVIDIA 6200.

• Menu SR adalah tampilan yang digunakan, (2-Model) berarti tampilan model yang aktif.
• Menu SCE adalah digunakan untuk membuat Scene.
• Menu Mode

Object Mode Edit Mode Vertex Paint Texture Paint

Untuk merubah “Mode”, tekan “Tab” dan “Tab” lagi.

• Menu Draw Type

Untuk merubah “Draw Type”,tekan “Z” atau “Alt+Z”.


• Game Logic dalah berfungsi sebagai tempat pemberian “action” pada sebuah objek 3D.
Dengan ini kita bisa mengatur pergerakan karakter tanpa menggunakan “script”.

Ω Membuat Game Sederhana Level 1


Disini kita akan mempelajari cara membuat game sederhana. Pertama rubahlah tampilan 3D nya dari
tampilan “Orthographic” ke tampilan “Perspective”. Klik menu View > Perspective, lalu putar
tampilannya seperti pada gambar dgn tekan tahan “Alt” + ”klik kiri”,lalu geser mousenya.

Atau buka file blendnya.


Kemudian pilih(select) objek “Cube” dengan klik kanan, lalu tekan “F4”, setelah itu klik pada setiap
tombol “Add”, kemudian sambungkan tiap menu, klik dari 1 drag ke 2. lalu isikan “0,01” pada Rot

sumbu Z. Kemudian pilih menu “Game” klik “Start Game”, atau tekan “P”. Exit dari game tekan
“Escape” Selesai. Lalu Save project gamenya, dan keluar dari Blender.
Ω Membuat Game Sederhana Level 2
Sekarang kita akan melanjutkan membuat game sederhana yang tadi telah kita buat. Disini kita akan
membuat objek “Cube” , berjalan kedepan, memutar kekiri dan memutar kekanan dengan menekan
tombol keyboard..
Sekarang buka blender, lalu rubah tampilannya menjadi seperti gambar berikut, kemudian pilih objek
“Cube”,setelah itu kita akan memberikan perintah. Atau buka file blendnya.

Pertama, tambahkan 3 menu di form “sensors”, klik tombol “always”,lalu pilih keyboard, kemudian
isikan sesuai gambar, lalu ganti kata “sensors” dengan kata “depan”, lalu isikan kata “sensor”
dengan “p kiri dan p kanan” .

Setelah itu klik di tombol “key” lalu tekan “W” pada keyboard, begitu juga dengan tombol key yang
lain. “ tombol key bisa disikan dengan tombol-tombol yang lainnya”.
Kemudian tambahkan 3 menu di form “Controllers”. Setelah itu tambahkan 3 menu lagi di form
“Actuators”. Lalu pada menu-menu di form “Actuators” isikan pada menu pertama, Loc = 0.10,
lalu pada menu kedua isikan Rot = 0.01, dan pada menu ketiga isikan Rot = - 0.01.

Atau lihat pada gambar di atas. Kemudian sambungkan menu-menu tersebut, seperti gambar di atas.
Lalu tekan “P” untuk memulai gamenya. Lalu save dan exit.

Ω Membuat Camera 3rd sederhana


Disini hanya membuat camera 3rd sederhana, jika ingin lebih bagus cameranya, gunakan “script”.
Pertama buka file Blend nya, lalu pilih(select) camera,

Kemudian pindahkan camera seperti gambar berikut.


Atau buka file blendnya.
Lalu tekan “N” akan muncul menu seperti ini, lalu isikan
LocX:-8.294
Loc Y:-0.010
LocZ:3.310
RotX:74.068
RotY:0.000
RotZ:-90.000
Kemudian tekan tahan “shift”+ klik kanan pada objek “cube”. Seperti gambar,

lalu tekan “Ctrl+P”. Dan klik pada Make parent. Lalu klik kanan pada objek “Camera”, lalu
tekan F7 .
Kemudian klik pada “SlowPar” dan TimeOffset isikan 50.

lalu klik menu “View” pilih “Camera /numpad 0”

Kemudian tekan “P” untuk mulai game, atau klik menu Game pilih “Star game”.
Ω Membuat Animation sederhana
Disini kita akan mempelajari cara membuat animation dan menggunakannya untuk game. Pertama
Bukalah file blend animation (house 1).

Kemudian pilih(select) objek “pintu”, lalu tekan “I” dan pilih “Rot”, pada jendela “Ipo” akan mucul
garis berwarna biru (horizontal),
kemudian geser garis hijau (vertikal) ke frame 20, lalu pada objek “pintu” tekan “R + Z” lalu tekan
angka 88 pada keyboard dan tekan “Enter”.
Kemudian tekan “I” dan pilih “Rot”. Lalu kembali ke Frame 1 setelah itu tekan “F4” dan
tambahkan menu-menu seperti pada gambar berikut.

Sesuaikan pada setiap menu-menu, sesuai dengan gambar diatas. Lalu tekan “P” untuk memulai.
Tekan “Space” untuk membuka dan menutup pintunya.

Ω Membuat Soft body dan Rigid body


Soft body adalah membuat objek menjadi seperti kain,bola, dll,
Rigid body adalah membuat objek mengikuti bentuknya,seperti bola,kubus,tabung dll
• Soft body
Pertama buka file blendnya, lalu pilih (select) objek “kain1” lalu klik tombol statik, lalu pilih “soft
body”. Kemudian isikan semuanya sesuai gambar. Tekan “P” untuk mulai.

• Rigid body
Pertama buka file blendnya, lalu pilih (select) objek “bola” lalu klik tombol statik, lalu pilih Rigid
body. Kemudian isikan semuanya sesuai gambar. Tekan “P” untuk mulai.

“Bounds” adalah jenis objek yg di rigid body, jika tidak ada, pilih “Convex Hull”
Ω Menggunakan Python script
Pertama buka file blendnya, lalu pilih (select) objek “gelombang” lalu tambahkan menu-menu
seperti gambar berikut. Isikan “Script dengan : “air”.
Kemudian tekan “P” untuk mulai gamenya.

Ω Membuat Text
Pertama buka file blendnya, lalu masuk ke “Edit mode” tekan “ Tab”.
kemudian open file “arial.tga”.

Lalu tekan “F9”, setelah itu klik pada tab “Texture Face”.
kemudian aktifkan semua tombol sesuai gambar berikut.
Setelah itu keluar dari “Edit mode” tekan “Tab”, lalu tekan “F4”,

Kemudian klik tombol “Add Property”, klik pada tombol “Float” lalu ganti dengan “String”, lalu
isikan Name dengan “Text”, kemudian ketikkan tulisan “Welcom”. Sekarang tulisannya sudah
terlihat.

Ω UV/Unwraping
Pertama buka file blendnya, kemudian masuk ke “Edit mode” dengan menekan tekan “Tab”, setelah
itu tekan “U” lalu pilih “Unwrap”, kemudian open gambar materialnya,

lalu tekan “Tab” untuk keluar dari “Edit mode”. Sekarang tekan “P” untuk mulai.

Reference:
http://www.tutorialsforblender3d.com

Blender 3D & Game Copyright(c) Juli 2009


Http://my.opera.com/elfaz Elfazzikra@ymail.com