Anda di halaman 1dari 20

Modul Pelatihan Routing dengan

Cisco Router
@Laboratorium NCC Teknik
Informatika ITS

Oleh:
Baskoro Adi Pratomo 5109201005
Hudan Studiawan 5109201038

Dosen:
Prof. Ir. Supeno Djanali, M.Sc, Ph.D
Ir. Muchammad Husni, M.Kom

Program Magister
Bidang Keahlian Komputasi Berbasis Jaringan
Jurusan Teknik Informatika
Fakultas Teknologi Informasi
Institut Teknologi Sepuluh Nopember
Surabaya
2009
Daftar Isi

Daftar Isi..................................................................................................................... 2
Sekilas LAN, Subneting, dan Routing..........................................................................3
LAN.......................................................................................................................... 3
Subneting ............................................................................................................... 3
Routing.................................................................................................................... 3
Topologi Uji Coba untuk Routing Statis.......................................................................3
Subnetting pada Topologi untuk Routing Statis..........................................................4
Perhitungan netmask..............................................................................................4
Perhitungan network id, broadcast, dan ip address................................................6
Special case.............................................................................................................7
Konfigurasi Routing Statis pada Cisco......................................................................10
Sekilas Routing Dinamis...........................................................................................16
Static Routing vs Dynamic Routing.......................................................................16
Link State Routing.................................................................................................16
OSPF...................................................................................................................... 17
Fitur-fitur OSPF...................................................................................................... 17
Shortest Path Algorithm........................................................................................18
OSPF Areas............................................................................................................ 18
Topologi Uji Coba untuk Routing Dinamis.................................................................19
Konfigurasi Routing Dinamis pada Cisco..................................................................19

2
Sekilas LAN, Subneting, dan Routing
LAN
• Salah satu arsitektur jaringan paling sederhana
• Bisa dikembangkan lebih luas
• Luas LAN: suatu area terdiri dari beberapa terminal yang saling berhubungan
• Penamaan tiap terminal à IP Address.

Subneting
• Cara membagi jaringan besar menjadi beberapa jaringan kecil
• Bila mungkin, hasil pembagian bisa dibagi menjadi jaringan lebih kecil
• Biasanya digunakan untuk membedakan bagian administratif.

Routing
• Proses penyampaian data dari pengirim ke tujuannya
• Jika pengirim dan tujuan berada pada jaringan berbeda, proses ini membutuhkan
router
• Secara umum dibagi dua: routing statis dan dinamis.

Topologi Uji Coba untuk Routing Statis


Uji coba routing akan dilakukan pada GNS3 yaitu sebuah software simulasi untuk
konfigurasi router Cisco. Berikut ini topologi jaringan yang akan digunakan untuk
melakukan routing statis.

2
A B
III

I II

Subnetting pada Topologi untuk Routing Statis


Subneting ini mempunyai dua tahap utama yaitu perhitungan netmask serta
perhitungan network id, broadcast, dan ip address. Perhitungan netmask dilakukan
dari bagian bawah topologi. Sedangkan perhitungan network id dan broadcast
dilakukan dari bagian atas topologi. Tahap-tahap subneting lebih detail dijelaskan di
bawah ini.

Perhitungan netmask
Pada topologi yang telah digambarkan pada subbab sebelumnya, subnet I
mempunyai 15 host, subnet II mempunyai 20 host, dan subnet III mempunyai 30
host. Sebelum melakukan perhitungan, perlu diketahui bahwa IP versi 4 mempunyai
32 bit yang dibagi menjadi dua bagian yaitu net id dan host id.

Untuk menghitung netmask tiap-tiap subnet maka langkah-langkahnya adalah


sebagai berikut.

1. Pilih subnet terdalam (level terendah) dengan host terbanyak yaitu subnet III
dengan 30 host. Maka, gunakan rumus:

2n ≥ jumlah host terbanyak + 1 network id + 1 broadcast

2n ≥ 30 + 1 network id + 1 broadcast

2n ≥ 32

2
n=5

n adalah jumlah bit yang akan digunakan sebagai host id. Sehingga, jumlah
bit yang akan digunakan sebagai net id bisa dihitung dengan rumus:

jumlah bit net id = 32 – n

= 32 – 5

= 27

32 merupakan jumlah bit yang masih tersisa pada IP v4. Selanjutnya,


netmask didapatkan dengan cara jumlah bit yang menjadi net id diberi nilai 1
semua sedangkan jumlah bit yang menjadi host id diberi nilai 0 semua. Agar
lebih jelas, simak ilustrasi di bawah ini:

32 bit IPv4 : ________.________. ________.________

27 bit net id :11111111.11111111.11111111.111__


___

5 bit host id :11111111.11111111.11111111.11100


000

Konversi ke desimal : 255.255.255.224

Jadi, netmask untuk subnet level terendah (subnet I, II, dan III) pada topologi
di atas adalah 255.255.255.224 atau bisa ditulis /27.

2. Selanjutnya dihitung netmask untuk subnet di level atasnya yaitu subnet A


dan B.

a. Perhitungan jumlah bit host id:

2
2n ≥ jumlah host terbanyak + 1 network id + 1 broadcast

2n ≥ 2 + 1 network id + 1 broadcast

2n ≥ 4

n=2

Jadi, jumlah bit host id = 2 bit.

b. Perhitungan net id:

jumlah bit net id = 27 – n

= 27 – 2

= 25

27 merupakan jumlah bit IPv4 yang masih tersisa dari subnet level
sebelumnya. Jadi, jumlah bit net id = 25 bit.

c. Perhitungan netmask:

32 bit IPv4 : ________.________. ________.________

25 bit net id :11111111.11111111.11111111.1_____


__

5 bit host id :11111111.11111111.11111111.10000


000

Konversi ke desimal : 255.255.255.128.

Jadi, subnet A dan B mempunyai netmask 255.255.255.128 atau bisa ditulis /


25.

Perhitungan network id, broadcast, dan ip address


Pada jaringan private, ip address yang bisa digunakan adalah 10.x.x.x. Pada subnet
A, netmask-nya adalah /25. Perhatikan ilustrasi di bawah ini:

2
32 bit IPv4 : ________.________. ________.________

10.x.x.x : 10. _ _ _ _ _ _ _ _ . _ _ _ _ _ _ _ _ . _ _ _ _ _ _ _ _

10.66.1.x : 10. 66. 1. 0| _ _


_____

Network id didapatkan dengan memberikan nilai 0 pada semua bit sisa. Bit sisa
ditandai dengan persegi merah pada ilustrasi di atas. Bit sisa bisa dihitung dengan

Bit sisa = 32 – jumlah bit pada netmask

= 32 – 25

= 7

Broadcast diperoleh dengan memberikan nilai 1 pada semua bit sisa.

10.x.x.x : 10. _ _ _ _ _ _ _ _ . _ _ _ _ _ _ _ _ . _ _ _ _ _ _ _ _

Network id : 10. 66. 1. 0|0 0


00000

Broadcast : 10. 66. 1. 0|1 1


11111

Jika dikonversi ke desimal, network id adalah 10.66.1.0/25 dan broadcast adalah


10.66.1.127. Nilai 66 dan 1 pada 10.66.1.x bisa dipilih secara sembarang. Dengan
cara yang sama, network id pada subnet B adalah 10.66.3.0/25 dan broadcast
adalah 10.66.3.127.

Special case
Kondisi jaringan yang kita konfigurasi seringkali berubah. Pada bagian ini, diberikan
suatu contoh kasus jika jaringan yang telah konfigurasi berubah. Perubahan terjadi
pada subnet A yaitu ditambahkan satu host baru. Maka, harus dilakukan
perhitungan ulang untuk menentukan network id dan broadcast pada subnet A.
Perhitungannya sebagai berikut:

1. Perhitungan jumlah bit host id:

2n ≥ jumlah host terbanyak + 1 network id + 1 broadcast

2
2n ≥ 3 + 1 network id + 1 broadcast

2n ≥ 5

n=3

Jadi, jumlah bit host id = 3 bit.

2. Perhitungan net id:

jumlah bit net id = 32 – n

= 32 – 3

= 29

Jadi, jumlah bit net id = 29 bit.

3. Perhitungan netmask, network id, dan broadcast

Netmask : 255.255.255.248

Network id : 10.66.1.8/29

Broadcast : 10.66.1.15

Untuk subnet B, kebutuhan ip address yang hanya sedikit (yaitu 2 ip address saja)
bisa dibuat lebih efisien dengan perhitungan di bawah ini.

1. Perhitungan jumlah bit host id:

2n ≥ jumlah host terbanyak + 1 network id + 1 broadcast

2n ≥ 2 + 1 network id + 1 broadcast

2n ≥ 4

n=2

2
Jadi, jumlah bit host id = 2 bit.

2. Perhitungan net id:

jumlah bit net id = 32 – n

= 32 – 2

= 30

Jadi, jumlah bit net id = 30 bit.

3. Perhitungan netmask, network id, dan broadcast

Netmask : 255.255.255.252

Network id : 10.66.3.4/30

Broadcast : 10.66.3.7

IP address bisa dipilih sembarang di antara network id dan broadcast. Setelah


konfigurasi selesai, maka contoh topologi yang telah lengkap bisa dilihat pada
gambar di bawah ini.

10.66.1. 10.66.3. N:
N:
10.66.3.4/30
10.66.1.8/29

A
10.66.1.
B
10.66.3. 10.66.3.

III
10.66.3.
N:

10.66.1. 10.66.3.

I II 10.66.3.
10.66.1.

N: N:

2
Konfigurasi Routing Statis pada Cisco
Routing statis disimulasikan dengan software GNS3 dan langkah-langkahnya akan
dijelaskan di bawah ini.

1. Buka software GNS3. Jika ada kotak dialog New Project, Cancel saja.

2. Letakkan router sesuai topologi pada layar kerja GNS3 dengan cara drag and
drop

2
3. Koneksikan router dengan pilihan koneksi fastEthernet

4. Nyalakan router dengan cara klik kanan pada router dan pilih Console

5. Nyalakan console dengan cara klik kanan pada router dan pilih Start

2
6. Tunggu sejenak sampai ada penawaran Would you like to enter the initial
configuration dialog? [yes/no]: dan ketikkan no saja.

7. Selanjutnya, terdapat pesan Press RETURN to get started! Dan tekan tombol enter
saja.

8. Setting ip address

Dari mode user exec, masuk ke privileged exec:

Router>
Router>enable
Router#

Dari mode privileged exec, masuk ke global configuration. Perintah configure


terminal bisa juga disingkat dengan conf t.

Router#
Router#configure terminal
Router(config)#

Tentukan interface yang akan diatur ip address-nya. Perintahnya secara umum


adalah:

Router(config)#interface [jenis interface] [nama interface pada router]

2
Contoh:

Router(config)#interface fastEthernet 1/0


Router(config-if)#

Tentukan ip address dengan perintah secara umum:

Router(config-if)#ip address [ip address] [netmask]

Contoh:

Router(config-if)#ip address 10.66.1.34 255.255.255.224


Router(config-if)#no shutdown

Jangan lupa memberikan perintah no shutdown untuk mengaktifkan interface yang


diberi ip address. Tunggu sejenak sampai tampil status interface telah menyala dan
diberi ip address dengan benar (up). Lakukan perintah setting ip address tersebut
untuk semua interface pada semua router. Jika proses berjalan dengan benar, maka
akan keluar seperti gambar di bawah ini:

Untuk melihat hasil konfigurasi ip address, perintahnya umumnya adalah:

Router#show interfaces [jenis interface] [nomor interface]

Contoh:

Router#show interfaces fastEthernet 1/0

Dan akan keluar tampilan seperti di bawah ini:

2
9. Setting gateway

Untuk melakukan pengaturan gateway, user harus masuk ke global configuration:


Router>
Router>enable
Router#configure terminal
Router(config)#

Selanjutnya perintah untuk pengaturan gateway secara umum adalah sebagai


berikut:

Router(config)#ip route 0.0.0.0 0.0.0.0 [ip gateway]

Contoh:

Router(config)#ip route 0.0.0.0 0.0.0.0 10.66.1.33

Lakukan pengaturan gateway untuk semua subnet.

10.Konfigurasi routing statis

Jika melihat topologi jaringan uji coba untuk routing statis, proses routing cukup
dilakukan pada router nomor 1 (R1) karena routing statis mengacu filosofi “kakek-
bapak-cucu”. Seorang “kakek” (dalam topologi uji coba bisa dianalogikan dengan
R1) bisa berkomunikasi dengan “cucu” (dianalogikan dengan R4) jika tahu “bapak”
(dianalogikan dengan R2). Routing bisa berjalan dengan lancar dengan syarat
semua subnet telah diatur ip address dan gateway-nya secara benar. Perintah
routing dilakukan dari router R1 ke semua subnet di bawahnya. Untuk melakukan
routing, user harus terlebih dulu masuk ke global configuration.

Router>
Router>enable
Router#configure terminal
Router(config)#

2
Setelah itu, lakukan routing dengan perintah sederhana sebagai berikut:

Router(config)#ip route [network id] [netmask] [ip untuk masuk ke subnet tujuan]

Contoh:

Router(config)#ip route 10.66.1.32 255.255.255.224 10.66.1.10

Untuk mempermudah pemahaman terhadap perintah routing, Perintah tersebut


bisa dibaca sebagai berikut:

“Lakukan routing ke subnet dengan network id 10.66.1.32 dan netmask


255.255.255.224 lewat pintu ip address 10.66.1.10”.

Perintah routing tersebut juga bisa diilustrasikan dengan gambar sebagai berikut:

“Kakek

Pintu masuk:
10.66.1.10

“Bapa
k”
Network id :
10.66.1.32
Netmask :
255.255.255.224

“Anak”

Untuk melihat hasil konfigurasi routing statis, perintahnya umumnya adalah:

Router#show ip route

Dan akan keluar tampilan seperti di bawah ini:

2
11.Pengetesan routing

Untuk melakukan pengetesan apakah routing yang dilakukan sudah benar atau
belum, tinggal menggunakan perintah ping [ip address tujuan].

Sekilas Routing Dinamis


Static Routing vs Dynamic Routing
1. Static Routing

a. Bentuk paling sederhana dari routing

b. Tidak bisa mengatasi koneksi yang terputus

c. Penggunaan bandwidth yang kecil

2. Dynamic Routing

a. Secara dinamis mencari tujuannya

b. Bisa mengatasi koneksi yang terputus

c. Penggunaan bandwidth yang lebih besar

Link State Routing


1. Setiap node memiliki salinan topologi

2. Jika ada node yang terputus, node yang lain bisa mencari jalan lain

2
3. Setiap node harus selalu memiliki gambaran kondisi jaringan yang sama

OSPF
1. Open Shortest Path First

2. Link State Routing paling banyak digunakan di internet

3. Sejarah :

a. 1989: RFC 1131 OSPF Version 1

b. 1991: RFC1247 OSPF Version 2

c. 1994: RFC 1583 OSPF Version 2 (revised)

d. 1997: RFC 2178 OSPF Version 2 (revised)

e. 1998: RFC 2328 OSPF Version 2 (current version)

Fitur-fitur OSPF
1. Ada mekanisme autentikasi

2. Load Balancing

2
3. Subnetting

4. Multicasting

5. Hierarchical Routing

Shortest Path Algorithm


1. Menggunakan algoritma Dijkstra

2. Link Cost → Metric

a. Metric = 108 / Bandwidth (dalam kilobits)

OSPF Areas
1. Mengurangi beban komputasi dan pemakaian memori

2. Teridentifikasi berdasarkan angka-angka

3. Terdiri dari:

a. Backbone Area

b. Stub Area

c. Not So Stubby Area

4. Aturan:

a. Semua paket yang tujuannya dalam 1 area, harus tetap berada di area itu

b. Semua paket yang tujuannya di luar area itu, harus melewati backbone
area

2
Topologi Uji Coba untuk Routing Dinamis

192.168.1.1

172.16.4.14
172.16.4.5

172.16.4. 172.16.4.13
6

172.16.4 192.168.3.1
192.168.2.1 172.16.4.1

Konfigurasi Routing Dinamis pada Cisco


Setting ip address dan gateway pada topologi sama dengan yang dilakukan pada
routing statis pada subbab sebelumnya. Untuk routing dinamis, perintahnya secara
umum adalah sebagai berikut.

Router(config)#router ospf 1
Router(config-router)#network [ip address] [wildcard] area [nomor area]

Contoh konfigurasi pada router R0 :

Router(config)#router ospf 1
Router(config-router)# network 192.168.1.1 0.0.0.0 area 0
Router(config-router)# network 172.16.4.5 0.0.0.0 area 0
Router(config-router)# network 172.16.4.14 0.0.0.0 area 0

Lakukan perintah routing ini pada semua router.

2
Kemudian untuk mengetahui jalannya paket, bisa digunakan perintah traceroute
[ip tujuan]