Anda di halaman 1dari 27

Pengolahan Data Peta

Dengan Quantum GIS


Oleh:
Ruslan Nuryadin
PT Webgis Indonesia

Dokumen ini terbuka dan gratis. Silahkan disebarkan, disalin,


dicetak dan digunakan sebagaimana mestinya.

Pengolahan Data Peta Dengan Quantum GIS 1


Daftar Isi
I.Pengantar.................................................................................................................. 3
II.Instalasi.................................................................................................................... 3
III.Konfigurasi Quantum GIS............................................................................................... 5
IV.Membuat Layer Baru..................................................................................................... 6
V.Tutorial: Membuat Layer Polygon......................................................................................7
VI.Tutorial: Membuat Layer Garis.......................................................................................17
VII.Tutorial: Membuat Layer Titik.......................................................................................19
VIII.File Projek Quantum GIS............................................................................................. 21
IX.Mengisi Data Atribut................................................................................................... 21
9.1 Mengubah Data Atribut Menggunakan Tombol Identity Features..........................................22
9.2 Mengubah Data Atribut Melalui Tabel Data Atribut..........................................................23
9.3 Mengubah Data Atribut Menggunakan Field Calculator.....................................................24
9.3.1 Mengubah Atribut Objek Peta Terseleksi...............................................................24
9.4 Mempermudah Pengisian Data Atribut Dengan Fitur Value Map...........................................26

Pengolahan Data Peta Dengan Quantum GIS 2


I. Pengantar
Quantum GIS merupakan salah satu perangkat lunak gratis dan open source untuk keperluan pengolahan
data peta. Tulisan ini akan menjelaskan penggunaan Quantum GIS untuk keperluan digitasi dan pengolahan
data peta dalam format vektor, sebagai alternatif dari perangkat lunak komersial seperti ArcView, ArcGIS
atau MapInfo Professional.

Meskipun Quantum GIS sendiri adalah perangkat lunak multi platform, dalam tulisan ini hanya akan
dijelaskan penggunaan pada platform Microsoft Windows.

II. Instalasi
Installer Quantum GIS dapat diunduh pada situs http://qgis.org/en/download.html. Untuk mengambil
versi terbaru, pilih tautan Current Version. Pada tulisan ini, versi yang digunakan adalah versi Windows-
Standalone 1.4.0 Enceladus, tanpa modul GRASS (Geographic Resources Analysis Support System), dengan
nama file: QGIS-1.4.0-1-No-GrassSetup.exe.

Untuk instalasi, jalankan file installer, kemudian ikuti petunjuk yang muncul di layar. Secara default,
Quantum GIS akan dipasang di direktori C:\Program Files\Quantum GIS Enceladus.
Setelah proses instalasi selesai, jalankan Quantum GIS dengan double click ikon Quantum GIS di desktop,
atau dengan memilih Start > All Programs > Quantum GIS Enceladus > Quantum GIS Enceladus. Tampilan
awal Quantum GIS seharusnya muncul seperti gambar berikut:

Pengolahan Data Peta Dengan Quantum GIS 3


Troubleshooting:

Quantum GIS memerlukan library Microsoft Visual C++ yang mungkin belum terpasang pada komputer kita.
Jika Quantum GIS tidak bisa dijalankan setelah proses instalasi seperti di atas, kita harus memasang
library Microsoft Visual C++ terlebih dahulu.
Pesan error yang mungkin muncul seperti di bawah ini:

Untuk mengatasi kegagalan instalasi tersebut, download dan kemudian install library Microsoft Visual C++
dari situs-situs berikut (untuk platform Windows 32 bit):
• Visual C++ Library Redistributable 2005:
http://www.microsoft.com/downloads/details.aspx?familyid=32bc1bee-a3f9-4c13-9c99-
220b62a191ee&displaylang=en
• Visual C++ Library Redistributable 2005 SP1:
http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-
389C36F85647&displaylang=en
• Visual C++ Library Redistributable 2008:
http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-
074B9F2BC1BF&displaylang=en
• Visual C++ Library Redistributable 2008 SP1:
http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-
3802B2AF5FC2&displaylang=en

Pengolahan Data Peta Dengan Quantum GIS 4


Jalankan file vcredist_x86.exe untuk memasang library Microsoft Visual C++ Redistributable. Jika kita
menggunakan versi Windows 64 bit, download dan pasang library versi 64 bit.

III. Konfigurasi Quantum GIS


Sebelum memulai menggunakan Quantum GIS, sebaiknya kita melakukan pengaturan global terlebih
dahulu, melalui menu Settings > Options (pada versi Linux, pengaturan konfigurasi global ada pada menu
Edit > Options). Tampilan dialog setting seperti gambar di bawah ini:

Setting konfigurasi dibagi menjadi beberapa bagian (bisa di-klik di sebelah kiri dialog): General, Rendering
& SVG, Map tools, Overlay, Digitising, CRS (Coordinate Reference System), Locale, serta Network & Proxy .
Bagian-bagian setting yang disarankan untuk diubah, disajikan dalam tabel berikut:

Bagian Setting Nilai Deskripsi


Rendering & Number of features to draw 1000 Diisi nilai 1000 agar progres
SVG before updating the display penggambaran peta kelihatan, terutama
untuk data berukuran besar
Make line appear less jagged at Check Aktifkan opsi ini agar gambar peta kita
the expense of some drawing (aktifkan) lebih bagus (halus). Nonaktifkan jiga
performance terasa memperlambat kinerja komputer
kita.
Map tools Mouse wheel action Zoom to Agar ketika zooming (in/out) dengan
mouse cursor mouse scroller, tampilan peta kita tidak
bergeser
Digitising Default snap mode To vertex and Agar kita bisa melakukan snapping
segment terhadap segmen, selain terhadap node
Default snapping tolerance 5 pixel Pilih 'pixel' agar proses snapping tidak
terpengaruh zoom level. Sesuaikan angka
piksel dengan preferensi kita. Angka 5 -
menurut pengalaman – cukup memadai.
Show marker only for selected Check Agar tidak semua node diberi marker

Pengolahan Data Peta Dengan Quantum GIS 5


features (aktifkan) (penanda), yang akan membuat tampilan
peta terlalu 'padat'
Marker style Semi Sesuaikan dengan selera kita
transparent
circle

IV. Membuat Layer Baru


Quantum GIS dapat digunakan untuk membuat layer peta baru (vektor), yang nantinya akan disimpan
sebagai file Shapefile (SHP). Untuk membuat layer baru, pilih menu Layer > New Vector Layer. Akan
muncul dialog pembuatan layer baru seperti di bawah ini:

Secara garis besar, proses pembuatan sebuah layer baru mengikuti langkah-langkah berikut:
1. Memilih tipe objek peta: Point (titik), Line (garis) atau Polygon. Sebagai contoh, jika kita ingin
mendigitasi data jalan, pilih tipe Line. Jika kita ingin mendigitasi bangunan, pilih tipe Polygon.
Pada dialog, pilih salah satu pilihan tipe objek peta.
2. Menentukan sistem koordinat (CRS - Coordinate Reference System). Kita bisa memilih koordinat
geografik (Lintang/Bujur) atau Projected (dalam sistem proyeksi tertentu, misalnya UTM –
Universal Transverse Mercator). Pada dialog, klik tombol Specify CRS, kemudian pilih salah satu
CRS dari dialog berikut:

Pengolahan Data Peta Dengan Quantum GIS 6


3. Menentukan data atribut. Data atribut pada layer baru kita bisa berupa:
• Text data, dapat diisi teks dengan panjang maksimum tertentu
• Whole number, dapat diisi angka/bilangan bulat
• Decimal Number, dapat diisi bilangan desimal/pecahan
Data atribut perlu minimal satu, dan bisa lebih dari satu. Pada dialog pembuatan layer baru,
lakukan langkah:
• Isi nama field (Name), misalnya ID
• Pilih tipe data (Type), misalnya Whole number
• Isikan lebar field (Width), misalnya 6
• Klik tombol Add to attribute list
Dalam daftar atribut, sekarang terdapat satu field tambahan:

Setelah ketiga langkah di atas dilakukan, klik tombol OK, kemudian pilih pilih nama file tempat layer yang
baru saja kita buat akan disimpan.

V. Tutorial: Membuat Layer Polygon


Pada tutorial ini, kita akan membuat sebuah layer berbentuk polygon, mewakili objek bangunan. Langkah-
langkah yang harus kita lakukan adalah sebagai berikut:
1. Pilih menu Layer > New Vector Layer. Pada dialog seperti di bawah, pilih tipe Polygon:

Pengolahan Data Peta Dengan Quantum GIS 7


2. Klik tombol Specify CRS. Akan muncul dialog berikut:

Pilih Geographic Coordinate System > WGS 84 dari daftar pilihan seperti bagian A pada gambar di
atas, atau klik tombol “WGS 84 (EPSG:4326)” dari bagian B pada gambar di atas. Bagian B akan
terdiri dari tombol-tombol yang dapat digunakan untuk memilih sistem proyeksi yang sering kita
gunakan.
Setelah CRS dipilih, tekan tombol OK untuk kembali ke dialog utama.

3. Pada dialog utama, tambahkan field dengan nama id, tipe Whole number, dengan lebar 6, seperti
gambar di bawah ini:

Pengolahan Data Peta Dengan Quantum GIS 8


Klik tombol Add to attribute list, sehingga pada daftar field sekarang bertambah satu field. Ulangi
langkah tadi untuk field kedua, dengan nama jenis, tipe Text data, lebar 20. Tampilan pada
daftar field sekarang menjadi seperti gambar di bawah:

4. Klik tombol OK. Kita akan diminta untuk menyimpan layer tersebut. Simpan pada direktori
C:\digitasi, sebagai file bangunan.shp, seperti pada gambar berikut:

Pengolahan Data Peta Dengan Quantum GIS 9


Setelah memilih nama file (tidak perlu menuliskan ekstensi SHP), klik tombol Save.

5. Pada Quantum GIS, sekarang akan ada tambahan satu layer, yakni layer bangunan yang bertipe
polygon, seperti gambar berikut:

Warna garis dan arsiran untuk layer polygon yang baru saja kita buat, akan dipilih secara acak oleh
Quantum GIS. Pada contoh di atas, arsiran layer polygon berwarna coklat dengan garis luar
berwarna hitam.

6. Untuk mulai manambahkan objek peta, layer bangunan tadi harus berada pada kondisi editable
(bisa diedit). Untuk mengubah status menjadi bisa diedit, kita bisa memilih menu Layer > Toggle
editing, atau menekan tombol (Toggle editing).

Tombol Toggle editing ini digunakan juga untuk mengakhiri pengeditan layer, dan menyimpan hasil
editing.

7. Ketika layer berada pada kondisi bisa diedit, maka tombol-tombol editing akan aktif, seperti pada
gambar berikut:

Fungsi masing-masing tombol editing adalah sebagai berikut:


Tombol Nama Fungsi
Toggle editing Untuk berganti status, dari tidak bisa diedit menjadi bisa diedit
(memulai editing), atau dari bisa diedit menjadi tidak bisa diedit
(mengakhiri editing dan menyimpan/membatalkan hasil editing).
Capture polygon Membuat objek polygon baru. Tombol ini hanya akan aktif kalau
layer yang sedang aktif dan bisa diedit adalah layer bertipe
Polygon, seperti pada contoh layer bangunan yang sedang kita
bahas.
Capture line Membuat objek garis baru. Tombol ini hanya akan aktif kalau layer
yang sedang aktif dan bisa diedit adalah layer bertipe Line.

Pengolahan Data Peta Dengan Quantum GIS 10


Capture point Membuat objek titik baru. Tombol ini hanya akan aktif kalau layer
yang sedang aktif dan bisa diedit adalah layer bertipe Point.

Move feature Menggeser sebuah objek peta (bisa titik, garis maupun polygon).

Node tool Digunakan untuk editing node, dengan fungsi-fungsi:


• menambah node garis atau polygon: double click pada
segmen yang ingin kita tambahi node
• menghapus sebuah node: klik node yang mau kita hapus,
kemudian tekan tombol 'Delete' pada keyboard komputer
kita
• menggeser sebuah node: klik node yang mau kita geser,
kemudian geser ke posisi yang kita inginkan
Proses menghapus dan menggeser node dapat kita lakukan
terhadap lebih dari satu node. Untuk memilih node kedua dan
seterusnya, klik node tersebut sambil menekan tombol Ctrl di
keyboard komputer kita.
Delete selected Menghapus objek-objek peta yang terseleksi. Seleksi objek peta
dapat dilakukan menggunakan tombol (Select features).

Proses seleksi objek peta dapat dilakukan dengan:


• klik objek peta untuk memilih satu objek peta
• Ctrl + klik objek peta lain untuk memilih objek peta
berikutnya
• menggunakan kotak seleksi untuk memilih objek-objek
peta yang berada pada area tertentu

Untuk menonaktifkan objek terseleksi, gunakan tombol


(Deselect features from all layers).

Tombol Delete selected hanya aktif kalau ada objek peta yang
terseleksi.
Cut features Menghapus objek-objek peta yang terseleksi, dan menyimpannya
di dalam clipboard, untuk nanti dipindah misalnya ke layer lain.
Tombol Cut features hanya aktif kalau ada objek peta yang
terseleksi.
Copy features Menyimpan objek-objek peta yang terseleksi, dan menyimpannya
di dalam clipboard, tanpa menghapus objek petanya.

Paste features Memindahkan objek-objek peta yang berada dalam clipboard ke


layer aktif yang sedang diedit.

Undo Membatalkan perintah sebelumnya.

Redo Menjalankan kembali perintah sebelumnya.

Simplify feature Menyederhanakan objek peta garis atau polygon, dengan cara
mengurangi jumlah node. Bentuk garis dan polygon hasil
penyederhanaan akan terlihat lebih kasar. Keuntungan
penyederhanaan objek antara lain dapat dibaca/ditulis dan
digambar lebih cepat.

Pengolahan Data Peta Dengan Quantum GIS 11


Add ring Membuat polygon berbentuk donat, dengan menambahkan satu
polygon lagi di dalam polygon yang sudah ada

Add part Membuat polygon multi part. Polygon multi part terdiri dari dua
atau lebih polygon (area tertutup), tetapi masih dianggap sebagai
satu objek peta. Contoh penggunaan polygon multi part antara
lain dalam penggambaran wilayah administratif yang terdiri dari
pulau-pulau, seperti wilayah Propinsi Kepulauan Riau. Propinsi
Kepulauan Riau bisa diwakili oleh polygon multi part, dengan
bagian-bagiannya (part) berupa pulau-pulau seperti Batam,
Rempang dan Galang.
Delete ring Membuang polygon dalam dari sebuah polygon berbentuk donat,
dengan cara meng-klik salah satu node pada polygon dalam.

Delete part Menghapus sebuah polygon yang menjadi bagian dari polygon multi
part, dengan cara meng-klik salah satu node dari polygon yang
mau dihapus
Reshape features Mengubah bentuk polygon atau garis, dengan cara mendigitasi
dengan mengawali dari satu node, dan diakhiri pada satu node
yang lain
Clip features Memotong polygon atau garis yang terseleksi, dengan
menggunakan sebuah garis sebagai garis pemotong

Merge selected Menggabungkan (merge) beberapa objek peta, baik titik, garis
features maupun polygon menjadi satu buah objek baru. Beberapa kondisi
berlaku ketika kita melakukan penggabungan (merging):
• Jika kita menggabung beberapa titik, hasilnya adalah
objek titik multi part
• Jika kita menggabungkan dua garis yang ujung-ujungnya
bertemu, maka hasilnya adalah satu garis single part, yang
merupakan gabungan dari kedua garis tadi
• Jika kita menggabungkan dua garis yang saling terpisah,
hasilnya akan berupa sebuah objek garis multi part
• Jika kita menggabungkan dua polygon yang saling beririsan
atau bersentuhan, maka hasilnya adalah satu buah polygon
single part, yang batas-batasnya mengikuti batas-batas
terluar kedua polygon
• Jika kita menggabungkan dua polygon yang tidak saling
beririsan atau bersentuhan, maka hasilnya adalah satu
objek polygon multi part
Rotate point Memutar simbol titik (belum bisa digunakan ketika tulisan ini
symbols dibuat)

8. Buat sebuah polygon, dengan terlebih dahulu memilih tombol (Capture polygon).
Klik node-node polygon dengan tombol kiri mouse. Klik tombol kanan mouse untuk mengakhiri
pembuatan polygon. Ilustrasi:

Pengolahan Data Peta Dengan Quantum GIS 12


4. Klik kanan

3. Klik kiri

1. Klik kiri

2. Klik kiri

1. Proses digitasi 2. Dialog pengisian atribut 3. Hasil digitasi

Pada waktu muncul dialog pengisian atribut, kita bisa mengisikan atribut sesuai keinginan, atau
bisa juga membiarkannya kosong terlebih dahulu, dan langsung menekan tombol OK.

Catatan:
Jika kita sedang mendigitasi sebuah polygon berukuran besar, yang batas-batasnya berada di luar
area peta yang tampil di layar monitor saat ini, kita perlu menggeser tampilan peta. Kita tidak
bisa menggeser tampilan peta menggunakan tombol penggeser (Pan the map), karena
tombol aktif kita sekarang adalah tombol Capture polygon.
Pada kondisi ini, kita mempunyai dua pilihan:
• Pertama, menggeser area peta dengan menggunakan tombol-tombol panah pada keyboard
komputer kita. Ini cara yang dianjurkan, karena dengan cara ini, zoom level peta kita
tidak berubah, yang artinya ketelitian kita melakukan digitasi tidak adakan berkurang
• Kedua, memperkecil tampilan peta dengan mouse scroll, agar area peta yang mau kita
digitasi terlihat seluruhnya di layar

9. Buat polygon baru dengan bentuk seperti polygon yang sudah kita buat tadi. Kita ingin mengubah
bentuk polygon sehingga menjadi seperti ini, dengan menggunakan tombol (Node tool) :

Urutan langkahnya seperti pada ilustrasi di bawah ini:

a b
b a
c
c

1. Buat 3 node baru, dengan cara double click 2. Tarik node b ke posisi baru
di titik-titik a, b dan c

Pengolahan Data Peta Dengan Quantum GIS 13


d
b
d b
a
c a
c

3. Buat node baru, dengan double click di 4. Tarik node d ke posisi baru
titik d

10. Buat polygon baru dengan bentuk seperti polygon yang pertama kita buat tadi. Kita ingin
mengubah bentuknya menjadi seperti ini, dengan menggunakan tombol (Reshape features):

Urutan langkahnya seperti pada ilustrasi di bawah ini:

d
c
a

1. Setelah mengaktifkan tombol Reshape 2. Hasil proses Reshape akan berbentuk seperti
features, klik kiri pada titik a, b dan c. gambar di atas
Kemudian klik kanan pada titik d. Titik a harus
cukup dekat ke node yang sudah ada. Titik d
harus cukup dekat ke segmen yang sudah ada.

11. Buat polygon baru dengan bentuk seperti polygon yang pertama kita buat tadi. Kita ingin membagi
polygon ini menjadi empat bagian, dengan menggunakan tombol (Split features).
Urutan langkahnya seperti pada ilustrasi di bawah ini:

Pengolahan Data Peta Dengan Quantum GIS 14


klik kiri

klik kanan

1. Pilih polygon asal, dengan menggunakan 2. Aktifkan tombol Split features, kemudian buat
tombol Select features sebuah garis memotong polygon yang terpilih
tadi. Pembuatan garis menggunakan klik tombol
kiri mouse, dan diakhiri dengan klik tombol
kanan mouse.

3. Polygon asal, akan terpotong menjadi dua 4. Pilih kedua polygon pada gambar 3, dengan
bagian seperti ini menggunakan tombol Select features (dengan
Ctrl + klik pada polygon kedua, atau
menggunakan kotak seleksi)

Pengolahan Data Peta Dengan Quantum GIS 15


5. Aktifkan tombol Split features, kemudian 6. Polygon asal, sekarang telah terbagi menjadi
buat garis yang memotong kedua polygon empat bagian
terpilih tadi

12. Kita akan menggabungkan dua polygon hasil langkah 11 tadi menjadi satu, dengan menggunakan
tombol (Merge selected features), dengan urutan langkah seperti ilustrasi berikut:

1. Gunakan tombol Select features untuk 2. Klik tombol Merge selected features, akan
memilih dua polygon muncul dialog pemilihan data atribut, mau diambil
dari atribut salah satu polygon atau mendefinisikan
atribut baru

3. Polygon baru hasil penggabungan kedua


polygon

Pengolahan Data Peta Dengan Quantum GIS 16


13. Sesudah kita membuat beberapa buah polygon, pilih lagi menu Layer > Toggle editing untuk
mengakhiri pembuatan layer bangunan. Kalau ada modifikasi terhadap layer, akan muncul dialog
konfirmasi seperti ini:

Klik Save untuk menyimpan hasil perubahan.


Sampai tahap ini, kita sudah punya layer bangunan yang terdiri dari beberapa polygon. Tampilan
layer bangunan kira-kira seperti gambar di bawah ini:

VI. Tutorial: Membuat Layer Garis


Pada tutorial ini, kita akan membuat layer jalan, yang bertipe garis. Sebagai langkah awal, ikuti 3 langkah
awal pembuatan layer polygon seperti sudah kita bahas, hanya saja, ketika menentukan tipe layer, pilih
Line. Tambahkan dua buah field untuk data atribut, masing-masing:
• id, tipe Whole number, lebar 6
• kelas_jalan, tipe Text data, lebar 20
Tampilan dialog pembuatan layer baru seperti gambar di bawah ini:

Pengolahan Data Peta Dengan Quantum GIS 17


Simpan layer ini di direktori C:\digitasi, dengan nama jalan.shp. Selanjutnya, ikuti langkah-langkah
berikut untuk menambahkan objek peta berupa garis:

1. Buat sebuah garis, dengan terlebih dahulu memilih tombol (Capture line).
Klik node-node garis dengan tombol kiri mouse. Klik tombol kanan mouse untuk mengakhiri
pembuatan garis. Ilustrasi:

1. Klik kiri

2. Klik kiri
3. Klik kiri

4. Klik kanan

1. Pembuatan garis 2. Dialog pengisian atribut

3. Gambar garis hasil digitasi

Pengolahan Data Peta Dengan Quantum GIS 18


2. Buat garis kedua, dengan titik awal menempel pada node atau segmen garis yang tadi sudah kita
buat. Ilustrasi:

1. Klik kiri

2. Klik kiri

3. Klik kanan

1. Klik titik awal garis, harus cukup dekat 2. Sesudah garis kedua selesai didigitasi
sehingga menempel ke segmen garis yang
pertama. Kemudian klik kiri pada node
berikutnya, akhiri dengan klik kanan

3. Buat garis-garis berikutnya, kemudian simpan data dengan memilih menu Layer > Toggle editing.
Pada layer bertipe garis, kita dapat menggunakan tombol Node tool, Reshape features, Split
features dan Merge selected features seperti pada layer polygon. Silahkan dicoba sendiri
bagaimana menggunakan tombol-tombol tersebut pada layer garis.
Tampilan layer jalan ketika ditumpuk dengan layer bangunan, kira-kira berbentuk seperti gambar
di bawah ini:

VII. Tutorial: Membuat Layer Titik


Pada tutorial ini, kita akan membuat layer reklame, yang bertipe titik, dan akan menggambarkan titik-
titik baliho, tempat pemasangan iklan. Untuk pembuatan layer garis, pilih tipe layer Point pada dialog
pembuatan layer baru. Tambahkan dua buah field untuk data atribut, masing-masing:

Pengolahan Data Peta Dengan Quantum GIS 19


• id, tipe Whole number, lebar 6
• jenis, tipe Text data, lebar 20

Tampilan dialog pembuatan layer baru seperti gambar di bawah ini:

Simpan layer ini di direktori C:\digitasi, dengan nama reklame.shp. Selanjutnya, ikuti langkah-langkah
berikut untuk menambahkan objek peta berupa titik:

1. Buat sebuah titik, dengan terlebih dahulu memilih tombol (Capture point).
Klik titik lokasi yang diinginkan dengan tombol kiri mouse.
2. Buat titik-titik berikutnya, kemudian simpan data dengan memilih menu Layer > Toggle editing.
Tampilan layer reklame ketika ditumpuk dengan layer bangunan dan jalan, kira-kira berbentuk
seperti gambar di bawah ini:

Pengolahan Data Peta Dengan Quantum GIS 20


VIII. File Projek Quantum GIS
Kita dapat menyimpan pekerjaan kita sebagai file projek. File projek Quantum GIS akan menyimpan
informasi layer apa saja yang sedang aktif, zoom level, pewarnaan layer dan sebagainya. Dari tampilan
yang terdiri dari tiga layer yang sudah kita buat (bangunan, jalan dan reklame), simpan sebagai projek
Quantum GIS dengan memilih menu File > Save Project, atau menu File > Save Project As. Simpan pada
direktori C:\digitasi, dengan nama projek digitasi.qgs (ekstensi .qgs akan diberikan secara otomatis,
sebagai penanda bahwa file tersebut adalah file projek Quantum GIS).

Untuk membuka kembali file projek yang sudah kita simpan, pilih menu File > Open Project.

IX. Mengisi Data Atribut


Pada kondisi default (tanpa perubahan konfigurasi), ketika kita selesai membuat sebuah objek peta baru,
akan muncul dialog untuk mengisikan data atribut bagi objek peta tersebut. Kita bisa memilih untuk

Pengolahan Data Peta Dengan Quantum GIS 21


mengisikan data atribut saat itu, atau ditunda dulu dan data atributnya diisikan atau diubah belakangan.

Pada bagian ini kita akan membahas beberapa hal mengenai cara pengisian data atribut.

9.1 Mengubah Data Atribut Menggunakan Tombol Identity Features

Salah satu cara mengubah data atribut sebuah objek peta, adalah dengan menggunakan tombol

(Identify features). Ikuti urutan langkah-langkah di bawah ini untuk mengubah atribut objek peta. Kita
akan menggunakan layer bangunan yang sudah kita punya, sebagai contoh.

1. Pastikan agar layer bangunan aktif dan berada pada kondisi bisa diedit, dengan menekan tombol
Toggle editing, atau memilih menu Layer > Toggle editing.

2. Aktifkan tombol Identify features, kemudian klik salah satu polygon pada layer bangunan yang
ingin kita ubah data atributnya. Ilustrasi:

1. Tampilan setelah klik salah satu objek peta 2. Pada popup menu, pilih Edit feature form
pada layer bangunan. Selanjutnya klik kanan
pada daerah yang ditandai kotak merah pada
gambar di atas

3. Isikan data atribut, kemudian klik OK untuk


menyimpan

Setelah data atribut diubah sesuai kebutuhan, simpan kembali hasil perubahan dengan memilih menu
Layer > Toggle editing.

Pengolahan Data Peta Dengan Quantum GIS 22


9.2 Mengubah Data Atribut Melalui Tabel Data Atribut

Selain melalui penggunaan tombol Identify features, kita dapat mengubah data atribut melalui tabel data
atribut. Untuk mengubah data atribut layer bangunan melalui tabel data atribut, ikuti langkah-langkah
berikut:

1. Pastikan agar layer bangunan aktif dan berada pada kondisi bisa diedit, dengan menekan tombol
Toggle editing, atau memilih menu Layer > Toggle editing.

2. Tampilkan tabel data atribut dengan mengklik tombol (Open attribute table), atau
memilih menu Layer > Open attribute table. Ilustrasi:

1. Tampilan tabel data atribut 2. Kita bisa pilih objek pada peta dengan
menggunakan tombol Select features, atau klik
kolom paling kiri pada tabel data atribut. Hasil
seleksi sinkron antara data peta dengan
atributnya.

3. Untuk mengubah sebuah data, double click 4. Tutup jendela tabel data atribut ketika
pada sel tempat data tersebut proses perubahan data sudah selesai

Setelah data atribut diubah sesuai kebutuhan, simpan kembali hasil perubahan dengan memilih menu
Layer > Toggle editing.

Pengolahan Data Peta Dengan Quantum GIS 23


9.3 Mengubah Data Atribut Menggunakan Field Calculator

Field calculator terdapat pada tabel data atribut, yang salah satu fungsinya untuk melakukan perubahan
data atribut terhadap banyak data sekaligus. Untuk menampilkan dialog Field calculator, klik tombol

(Field calculator) dari tampilan tabel data atribut. Gambar di bawah ini menunjukkan cara menampilkan
Field calculator untuk layer bangunan:

1. Tampilan tabel data atribut, dengan tombol Field 2. Tampilan Field calculator
calculator

Kita akan mencoba hal-hal yang bisa dilakukan melalui Field calculator pada bagian-bagian di bawah ini.
Dalam contoh-contoh ini kita akan menggunakan layer bangunan, jadi pastikan dahulu layer ini aktif dan
berada dalam kondidi bisa diedit.

9.3.1 Mengubah Atribut Objek Peta Terseleksi

Dengan menggunakan Field calculator, kita dapat mengubah semua data atribut objek peta yang terseleksi
dengan sebuah nilai tertentu, seperti yang digambarkan pada tutorial berikut:

Pengolahan Data Peta Dengan Quantum GIS 24


1. Pilih/seleksi beberapa objek peta, dengan 2. Klik tombol Open attribute table. Data-data
menggunakan tombol Select features dari objek peta yang terseleksi akan kelihatan
sebagai baris-baris yang terseleksi juga di sini

3. Kita akan mengisi data field jenis untuk semua objek yang terseleksi, dengan nilai 'Rumah':
a) Update existing field: pilih jenis
b) Check pilihan Only update selected features, agar hanya field yang terseleksi saja yang
diubah nilainya.
c) Pada Field calculator expression, isikan 'Rumah'. Harus diisikan dengan diapit tanda petik
tunggal, karena field jenis tipenya teks. Jika field yang kita ubah, tipe datanya numerik,
datanya tidak perlu diapit tanda petik tunggal.

Pengolahan Data Peta Dengan Quantum GIS 25


4. Hasil akhir, isi field jenis dari semua data
terseleksi telah berubah menjadi 'Rumah'

9.4 Mempermudah Pengisian Data Atribut Dengan Fitur Value Map

Kita sudah mencoba mengisikan data atribut dengan cara mengetikkan nilai yang kita inginkan, secara
bebas, seperti pada contoh di bagian 9.1 dan 9.2. Dalam banyak kasus, kita sebenarnya tidak
diperbolehkan mengisi data atribut secara bebas, tetapi harus memilih salah satu dari beberapa pilihan.
Sebagai contoh, dalam pengisian jenis bangunan, pilihannya hanya ada tiga: rumah, toko, atau pabrik.
Contoh lain, dalam pengisian kelas jalan, pilihannya hanya jalan nasional/arteri, jalan kolektor atau jalan
lokal.

Dengan Quantum GIS, kita dapat memberikan pilihan ketika mengisikan data atribut pada field tertentu.
Kita akan menggunakan contoh layer bangunan, dengan tiga pilihan ketika mengisi field jenis: Rumah,
Pabrik, atau Toko. Untuk melakukan hal tersebut, ikuti langkah-langkah di bawah ini:

1. Pastikan agar layer bangunan aktif dan berada pada kondisi bisa diedit, dengan menekan tombol
Toggle editing, atau memilih menu Layer > Toggle editing.

2. Tampilkan jendela Layer Properties dengan memilih menu Layer > Properties, pilih bagian
Attributes, kemudian ikuti langkah-langkah seperti pada ilustrasi di bawah ini:

1. Tampilkan Layer Properties, dengan klik 2. Pada tampilan Layer Properties, pilih bagian
kanan pada layer bangunan, atau memilih menu Attributes. Setelah itu, klik tombol Edit widget
Layer > Properties (Line edit), untuk field jenis

Pengolahan Data Peta Dengan Quantum GIS 26


3. Pada pilihan Attribute edit dialog, pilih Value 4. Isikan Rumah, Toko dan Pabrik pada daftar
map nilai yang boleh dipilih, seperti pada tampilan
di atas. Klik OK jika sudah selesai membuat
pilihan

5. Model pengisian field jenis sekarang telah 6. Coba lagi ubah data atribut seperti
berubah, dari Line edit menjadi Value map. Klik penjelasan pada bagian 9.2. Sekarang model
OK untuk menyimpan konfigurasi layer. pengisian field jenis sudah berubah menjadi
tiga pilihan: Rumah, Toko atau Pabrik.

Gunakan Value map untuk membatasi pengisian field kelas_jalan pada layer jalan, supaya hanya boleh
diisi: Jalan Nasional, Jalan Kolektor, atau Jalan Lokal. Gunakan juga Value map untuk membatasi
pengisian field jenis pada layer reklame, supaya hanya boleh diisi: Iklan Makanan, Iklan Minuman, atau
Iklan Rokok.

Pengolahan Data Peta Dengan Quantum GIS 27