Anda di halaman 1dari 18

DHCP Server

NAT dan TFTP

Jaringan Komputer 2 – Pertemuan 5

STMIK | Widya Pratama


Slamet Joko Prasetiono

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 1


DHCP
 Delapan langkah mengkonfigurasikan DHCP lewat CLI
1. Membuat DHCP Address Pool
2. Menentukan Subnet
3. Pengecualian IP Address
4. Menentukan Domain Name
5. DNS Server IP Address
6. Menentukan Default Router
7. Menentukan Lama Penggunaan Informasi DHCP
8. Memeriksa Konfigurasi

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 2


1. Membuat DHCP Pool Access
 Masuk ke privileged EXEC mode.
 Masuk ke Global Configuration Mode.
 Kemudian buat sebuah nama untuk DHCP server
address pool.
 Lebih dari sebuah address pool dimungkinkan.
 Perintahnya adalah sebagai berikut :
Router> enable
Router# conf t
Router(config)# ip dhcp address pool LAN-STMIKWP
 Pada contoh di atas nama dhcp server address pool
adalah “LAN-STMIKWP”

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 3


2. Menentukan Subnet

 Tentukan network atau subnet network dan subnet


mask DHCP address pool.
 Gunakan perintah :
Router(dhcp-config)# network 172.16.0.0 255.255.0.0

 Tergantung dari versi IOS yang digunakan, subnet


mask mungkin dapat juga dituliskan /16 untuk contoh di
atas.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 4


3. Pengecualian IP Address

 Pada prinsipnya semua client yang menggunakan


layanan DHCP server akan diberikan IP address
secara otomatis oleh DHCP server.
 Namun dengan pengecualian ini maka DHCP server
tidak akan memberikan alamat yang dimaksud.
 Perintahnya adalah :
Router(config)# ip dhcp excluded-address 172.16.1.100
172.16.1.103

 Pada contoh diatas ada 4 alamat IP (.1.100 s/d .1.103)


yang dapat dimasukkan secara statis oleh administrator
karena tidak diberikan oleh DHCP server.
© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 5
4. Menentukan domain name

 Perintah yang digunakan adalah


Router(dhcp-config)# domain-name stmik-wp.ac.id

 Client pada contoh ini akan menggunakan domain


name “stmik-wp.ac.id”.
 Domain name ini hanya bersifat optional tergantung
dari keinginan administrator, akan digunakan atau
tidak.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 6


5. DNS Server IP Address

 Berikutnya adalah menentukan IP Address dari DNS


server yang akan digunakan oleh client.
 Minimal satu IP address digunakan dan maksimal 8 IP
dalam satu baris perintah.
 Perintah yang digunakan adalah :
Router(dhcp-config)# dns server 172.16.1.103 172.16.2.103

 Pada contoh diatas digunakan primary dns server dan


secondary dns server.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 7


6. Menentukan Default Router

 Langkah berikutnya adalah menentukan default router


yang akan digunakan oleh client sebagai default
gateway.
 Perintahnya adalah :
Router(dhcp-config)# default router 172.16.1.100

 Pada contoh diatas client-client akan menggunakan IP


address 172.16.1.100 sebagai default gateway.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 8


7. Lama penggunaan DHCP

 Pada dasarnya DHCP Server akan memberikan


informasi DHCP kepada client langsung ketika client
dinyalakan dan terkoneksi ke jaringan.
 Dan lama penggunaannya adalah sehari, namun hal
tersebut dapat diubah dengan perintah :
Router(dhcp-config)# lease infinite

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 9


8. Memeriksa konfigurasi
 Perintahnya adalah show running-config
 Contoh hasil konfigurasi :
!
ip dhcp pool LAN-STMIKWP
domain-name stmik-wp.ac.id
network 172.16.0.0 255.255.0.0
ip dhcp excluded-address 172.16.1.100 172.16.1.103
dns server 172.16.1.103 172.16.2.103
default router 172.16.1.100
lease infinite
!

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 10


NAT
 NAT digunakan pada jaringan agar host yang berada di
bagian dalam (inside) dengan IP address private dapat
berkomunikasi dengan Internet.
 Ketika mengkonfigurasikan NAT, setidaknya satu
interface harus dikonfigurasikan sebagai inside
interface, artinya dia terkoneksi dengan jarinagn
bagian dalam (LAN) atau private network.
 Interface lainnya biasanya sebagai external interface
yang digunakan untuk mengakses Internet, harus
dikonfigurasikan sebagai outside interface.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 11


1. Menentukan Interface
 Masuk ke privileged EXEC mode.
 Masuk ke Global Configuration Mode.
 Kemudian pilih interface yang akan dijadikan sebagai
inside interface
 Contohnya adalah sebagai berikut :
Router> enable
Router# conf t
Router(config)# interface fastethernet 0/0

 Pada contoh di atas interface fa 0/0 dijadikan sebagai


inside interface.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 12


2. Memberi IP Address Inside Interface

 Perintah yang digunakan adalah :


Router(config-if)# ip add 172.31.232.182 255.255.255.0

3. Mengidentifikasi Inside Interface

 Perintah yang digunakan adalah :


Router(config-if)# ip nat inside
Router(config-if)# exit

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 13


4. Menentukan Interface
 Pilih interface yang akan dijadikan sebagai outside
interface.
 Pada contoh di bawah interface serial 0/0 dijadikan
sebagai outside interface.
Router(config)# interface serial 0/0

5. Memberi IP Address Outside Interface


 Perintah yang digunakan adalah :
Router(config-if)# ip add 209.165.201.1 255.255.255.252

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 14


6. Mengidentifikasi Outside Interface

 Perintah yang digunakan adalah :


Router(config-if)# ip nat outside
Router(config-if)# exit

7. Mentranslasikan Inside ke Outside


 Perintah yang digunakan adalah :
Router(config-if)# ip nat inside source statis
172.31.232.14 209.165.202.130

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 15


8. Memeriksa Konfigurasi NAT

 Gunakan perintah show running-config.


 Hasil yang didapatkan :
!
interface fastethernet 0/0
ip address 172.31.232.182 255.255.255.0
ip nat inside
!
interface serial 0/0
ip address 209.165.201.1 255.255.255.252
ip nat outside
!
ip nat inside source statis 172.31.232.14 209.165.202.130
© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 16
Backup dan Restore TFTP Server
 Dikuatirkan jika NVRAM rusak atau file menjadi korup
maka sebuah ide yang baik apabila membuat file
cadangan ke dalam server TFTP.
 Perintah Backup
Router# copy startup-config tftp
 Perintah Restore
Router# copy tftp startup-config
 Yang dibutuhkan adalah IP address TFTP server dan
nama file yang akan di-backup atau di-restore.

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 17


Local Academy Cisco
STMIK Widya Pratama Pekalongan

© 2007 Cisco Systems, Inc. All rights reserved. Cisco Public 18