Anda di halaman 1dari 73

Perangkat Lunak Basis Data

BAB 1

KONSEP DATABASE
DAN PENGENALAN MICROSOFT ACCESS

Tujuan Materi: mahasiswa dapat memahami konsep database dan


dapat menjalankan program Microsoft Access

1.1 PERLUNYA DATA

Data diperlukan dalam segala hal, baik berupa pengukuran,


pencatatan, pengumpulan informasi, maupun pengambilan
keputusan semuanya memerlukan data. Dengan kata lain data
sangat dibutuhkan karena informasi yang ada akan memberikan
arti yang sangat penting baik untuk saat ini maupun untuk akan
datang.

1.2 PENGERTIAN DATABASE

Database adalah suatu kumpulan data-data yang disusun


sedemikian rupa sehingga membentuk informasi yang sangat
berguna. Database terbentuk dari sekelompok data-data yang
memiliki jenis/sifat sama. Contohnya : data mahasiswa, data dosen,
data pegawai, dll.

Demikian juga, kumpulan dari data-data mahasiswa, data-data


dosen, data-data keuangan dan lainnya dapat dikumpulkan lagi
menjadi kelompok besar, misalkan data-data POLITEKNIK ACEH.
Bahkan dalam perkembangannya, data-data tersebut dapat
berbentuk berbagai macam data, misalkan dapat berupa program,
lembaran-lembaran untuk entry (memasukkan) data, laporan-
laporan. Kesemuanya itu dapat dikumpulkan menjadi satu yang
disebut dengan database.

Beberapa alasan mengapa database diperlukan adalah sebagai

1
Perangkat Lunak Basis Data

berikut:
1. Salah satu komponen penting dalam sistem informasi, karena
merupakan dasar dalam menyediakan informasi
2. Menentukan kualitas informasi : akurat, tepat pada waktunya
dan relevan. Informasi dapat dikatakan bernilai bila manfaatnya
lebih efektif dibandingkan dengan biaya mendapatkannya.
3. Mengurangi duplikasi data (data redudancy)
4. Hubungan data dapat ditingkatkan (data relatability)
5. Untuk memberikan kemudahan dan efisiensi saat kita ingin
menyimpan data/informasi dan mengambilnya kembali

1.3 DEFINISI DASAR

1. Database : Sekumpulan data yang saling berhubungan untuk


mencapai suatu tujuan.
2. Data : fakta-fakta yang dapat disimpan dan mempunyai
arti tertentu
3. Tabel : Tempat untuk menyimpan data, tabel terdiri dari
field dan record
4. Field : disebut juga dengan kolom, yaitu bagian tabel
tempat menyimpan sebuah item data. Sehingga
sebuah field merepresentasikan suatu atribut dari
record yang menunjukkan suatu item dari data,
seperti misalnya nama, alamat dan lain
sebagainya. Kumpulan dari field membentuk suatu
record, yang harus memenuhi komponen berikut
ini:
• field name: Field harus diberi nama
untuk membedakan field
yang satu dengan lainnya
• field representation: harus didefinisikan tipe
field (karakter, teks,
tanggal, angka, dsb),

2
Perangkat Lunak Basis Data

lebar field (ruang


maksimum yang dapat
diisi dengan karakter-
karakter data).
• field value: isi dari field untuk
masing-masing record.
5. Record : disebut juga dengan baris, yaitu satu bagian
informasi yang disimpan dalam tabel, misal data
seorang mahasiswa akan disimpan dalam satu
record yang terdiri dari beberapa kolom/field

Berikut ini adalah sebuah contoh tabel, yang berisi data Dosen:

Field

NAMA NIP ALAMAT

Aang Afandi, SE, MM 132 311 347 Jl. Teuku Umar 33 Lhokseumawe
Drs. A. Jarnuzi, Ak, M.Si 132 057 613 Jl. Mawar No. 176 Lhokseumawe Baris
Record
Andi K. Indrawan, S. Kom 132 310 106 Jl. Dr. Wahidin 28 Lhokseumawe ke 1….n
Dra. Anik K, MM 131 789 043 Jl. P. Diponegoro 55 Lhokseumawe

Data
Value
Gambar 1.1 Komponen Table

Ada beberapa sifat yang melekat pada suatu tabel :


1. Tidak boleh ada record yang sama (kembar)
2. Urutan record tidak terlalu penting, karena data dalam record
dapat diurut sesuai dengan kebutuhan.
3. Setiap field harus mepunyai nama yang unik (tidak boleh ada
yang sama).
4. Setiap field mesti mempunyai tipe data dan karakteristik

3
Perangkat Lunak Basis Data

tertentu.

1.4 MEMULAI MICROSOFT ACCESS

Microsoft Access adalah salah satu dari Relasional


Database Management System (DBMS). DBMS adalah sebuah
program yang memiliki fasilitas penyimpanan dan pemanggilan
struktur informasi pada sistem komputer.
Data dalam Microsoft Access disimpan ke dalam suatu
Tabel. Selain tabel, sebuah file database Access juga berisi
bermacam-macam obyek database yang lain diantaranya:
1. queri untuk mengorganisasi data,
2. forms untuk berinteraksi dengan data pada layar,
3. reports untuk mencetak hasil,
4. macros dan program Visual Basic untuk memperluas
fungsionalitas dari aplikasi database.
Semua obyek ini disimpan dalam file <filename>.mdb.
Untuk memulai microsoft Access dimulai dengan klik tombol Start
– All Program –Microsoft Office > Microsoft Access 2003

Gambar 1.2 Langkah Memulai Microsoft Access

Berikutnya and akan mendapati jendela Micosoft Access sebagai

4
Perangkat Lunak Basis Data

berikut:

1 2

Klik Untuk membuat


sebuah file database baru

Gambar 1.3 Jendela Microsoft Access

Untuk memulai membuat sebuah filedatabase baru, klik Tombol


‘New » pada standart toolbar, akan tampil Task Pane New, dan klik
( new Database ) pada Task Pane, anda akan mendapatkan jendela
dialog penyimpanan file sebagai berikut :

Lokasi
Penyimpanan

Nama File

Type File

Gambar 1.4 Jendela Dialog Membuat Sebuah File Baru

Klik tombol Create, maka anda akan mendapatkan sebuah jendela


yang berisi obyek-obyek sebuah file database sebagai berikut :

5
Perangkat Lunak Basis Data

Gambar 1.5 Jendela Obyek Dalam File Database

Penjelasan masing-masing obyek tersebut adalah sebagai berikut:

OBJECT KETERANGAN
Table Merupakan struktur data untuk menentukan nama field-
field beserta perancangan suatu table, dan tempat untuk
menyimpan data.
Form Untuk membuat rancangan dalam tampilan form sebagai
bahan untuk memasukan data.
Queries Untuk membuat relasi, mengorganisasi data atau
pengabungan dari beberapa table.
Reports Untuk menampilkan bentuk laporan dari hasil output yang
sesuai dengan data yang diproses dan di entri.
Macros Untuk mengkoordinasikan dari menu Tabel, form. Report,
Query menjadi tombol dan menu secara otomatis.
Pages Untuk merancang tampilan data access pada halaman
web melalui system jaringan(server).
Modules Untuk membuat rancangan modul pengolahan database
yang dibuat dengan menggunakan kode pada Visual Basic
untuk aplikasinya.

1.5 MENUTUP FILE DATABASE DAN KELUAR DARI MICROSOFT

ACCESS

6
Perangkat Lunak Basis Data

Bila Anda telah selesai bekerja dengan file database MS Access


maka sebelum menutup file simpan seluruh data yang pernah Anda
buka untuk menutup file database salah satu langkah. Berikut ;
1. Klik Menu File pilih Close
2. Klik Icon control Menu yang terletak disudut kiri atas pilih Close
3. Klik ganda pada icon control menu yang terletak di bagian sudut
kiri atas dari jendela database.
4. Tekan tombol kombinasi shorcut Key Ctrl + F4 atau Ctrl + W
5. Tekan Tombol Close yang ada dibagian sudut kanan atas dari
jendela database
6. Untuk Keluar dari MS Access, Klik menu File Exit, atau klik
tombol Close pada pojok kanan atas.

7
Perangkat Lunak Basis Data

LATIHAN 1

1. Soal teori (Essay/Multiple Choice)


• Jelaskan pengertian tentang konsep Database dan definisi
dasarnya
• Berikan ilustrasi komponen tabel yang terdiri dari field (kolom)
dan record (baris)
2. Soal praktek
Jalankan Microsoft Access dan buat database baru dengan nama
Penjualan.mdb. Kerjakan sesuai dengan petunjuk langkah-langkah
berikut :
• Langkah-langkah untuk menjalankan microsoft access adalah :
• Siapkan instalasi Microsft Acces yang merupakan satu paket
dengan Microsoft Office.
• Pilih menu Microsoft Access pada menu yang tersedia dalam
windows.
• Kemudian pilih Blank Database untuk membuat database yang
baru.

8
Perangkat Lunak Basis Data

BAB 2

MEMBUAT TABEL

Tujuan Materi: mahasiswa dapat membuat tabel dan menyimpan


data ke dalam tabel di Microsoft Access

2.1 MEMBUAT TABLE

Tabel adalah obyek untuk tempat menyimpan informasi,


tempat menyimpan, dan mengelola data dalam database sama
seperti Excel kertas kerja menyimpan informasi dalam buku kerja.
Pada saat akan membuat sebuah database, Langkah awal
yang harus dikerjakan adalah harus merancang table yang akan
dibuat, bagaimana struktur table tersebut dan seperti apa
hubungan/relasi antar table satu dengan table lain jika
informasinya terpadu.
Untuk membuat sebuah table baru, maka lakukan langkah
berikut ini:
1. Klik object table

Klik untuk membuat


sebuah table baru

Gambar 2.1 Membuat Table


Access menyediakan tiga cara untuk membuat tabel yang mana

9
Perangkat Lunak Basis Data

ada icon dalam Database Window. Klik ganda pada icon untuk
membuat tabel.
• Create table in Design view akan mengijinkan anda untuk
membuat field tabel. Ini adalah cara umum untuk membuat
tabel dan penjelasannya ada dibawah.
• Create table using wizard langkah anda dalam membuat
tabel.
• Create table by entering data akan memberi anda
datasheet kosong tanpa kolom label yang kelihatan seperti.
Excel worksheet. Masukkan data pada sel dan klik tombol
Save. Anda akan dihadapkan dengan pilihan untuk
memasukkan primary key field. Setelah tabel disimpan, sel
kosong datasheet akan dihias. Field diberi nama umum
seperti "Field1", "Field2", dll. Untuk menggantinya dengan
julul lain, Pilih Format|Rename Column dari menu bar atau
sorot kolom, klik kanan didalamnya, dan pilih Rename
Column dari shortcut menu.

2. Pilih create table in design view, anda akan mendapatkan


tampilan sebagai berikut:

Gambar 2.2 Dialog Perancangan Table


3. Ketik struktrur table yang akan dibuat, sesuai dengan
perancangan informasi yang akan dibangun. Ketik nama
fieldnya, tentukan juga type datanya dan atur lebarnya data,
pilih Field Size.

10
Perangkat Lunak Basis Data

Gambar 2.3 Struktur Table


Keterangan :
Field name : Untuk memasukan nama-nama field yang akan
dibuat
Data Type : Untuk membedakan jenis atau type data yang
akan diolah. Macam-macam type data adalah
sebagai berikut:
• Text: Serangkaian huruf, angka, spasi dan
tanda baca Memo: Serangkaian kata yang
sangat panjang berupa data
• campuran antara huruf, spasi, dan tanda
baca.
• Number: Data berupa angka, perihitungan

11
Perangkat Lunak Basis Data

secara matematik.
• Date/Time: Data berupa tanggal atau waktu
Currency: Data yang berupa nilai mata uang
• AutoNumber: Bilangan atau penomeran yang
beraturan atau berurutan secara otomatis.
• Yes/No: Data yang berupa object atau
gambar
• OLE Object: Data yang berupa object atau
gambar Hyperlink: Data yang dapat
dihubungkan dengan alamat hyperlink pada
lokasi penyimpanan.
• Lookup Wizard: Memasukan data dengan
memilih salah satu data pada daftar table.
Description : Menjelaskan dari nama Field

Field Properties :
Field Size : Untuk menentukan lebar dari nama-nama
field tersebut.
Format : Untuk menentukan dan mengatur bentuk
dari nama field tersebut, format tanggal,
format angka, waktu dll.
Input Mask : Untuk penulisan data pada saat data
dimasukan, karakter atau label diwakili
dengan huruf “L” dan numeric diwakili
dengan “9”.
Decimal Place : Untuk memasukan data sesuai dengan
format angka decimal.
Caption : Untuk penulisan judul atau title pada
pembacaan Form, report dsb.
Default value : Untuk menentukan nilai atau harga awal
dari sebuah bilangan secara otomatis sesuai
dengan format yang ada.
Validasi Rule : Untuk menentukan nulai atau batasan dan

12
Perangkat Lunak Basis Data

aturan pemasukan data pada sebuah field.


Validasi text : Untuk mengatur dan mengontrol
pemasukan data pada sebuah field, sesuai
dengan aturan yang telah ditentukan oleh
Validasi Rule.
Required : Untuk menentukan batasan pemasukan
data, jawab “Yes” apakah data akan diisi
atau “No” data akan dikosongkan.
Allow Zero Length : Untuk menentukan pemasukan data pada
sebuah field jika data tersebut valid atau
tidak.
Indexed : Untuk menentukan index pada field
tersebut.
Left : Fungsi string untuk mngambil N karakter
dari kiri(Field,N)
Right : Fungsi string untuk mngambil N karakter
dari kanan(Field,N).
Mid : Membaca N karakter dari posisi yang
diinginkan (Field,N,N).
4. Tentukan konstring, batasan-batasan table, bila suatu field
digunakan sebagai kunci utama,maka field tersebut harus
menjadi Primary Key Struktur table diatas, field sebagai Primary
Key adalah KodeBukukarena sebagai informasi utama yang
membedakan Buku satu dengan Buku lain, dan selalu bersifat
Unique.
Cara membuat field menjadi Primary Key :
• Letakkan kursor di field tersebut yaitu KodeBuku
• Klik kanan maka akan muncul menu menentukan Primary
Key sebagai berikut :

13
Perangkat Lunak Basis Data

Gambar 2.4 Menentukan Primary Key

Maka Field yang merupakan primary key akan ditandai


dengan gambar kunci disebelah kiri field tersebut.

5. Bila ingin memberi aturan atau validasi rule pada fields tertentu
misalnya KodeBuku dengan tujuan agar Kode Buku yang
dimasukan memiliki bentuk kode yang standart sehingga tidak
sembarang entri kode bisa diterima, misalkan diberikan
ketentuan sebagai berikut : “Input Mask : L99”
Bila ingin membuat format entri Kode Buku karakter pertama
harus berupa abjad dan diikut dengan dua angka numerik.
Sebagai berikut: Validasi Rule : Left([KodeBuku ],1)=”H” or
Left([KodeBuku ],1)=”D”
Melakukan validasi, abjad pertama dari kiri yang bisa di entri
adalah huruf H dan D.Selain itu tidak diijinkan memasukan data

14
Perangkat Lunak Basis Data

sembanrang selain huruf H atau D.


Validasi Text : “Tidak boleh sembarang memasukan data”
6. Simpan perancangan struktur table diatas, klik menu File, lalu
pilih simpan maka beri nama table tersebut.

Gambar 2.5 Menyimpan Tabel

15
Perangkat Lunak Basis Data

LATIHAN 2

1. Buatlah sebuah folder dengan nama :ACCESS-KELAS-NO ABSEN,


selanjutnya anda harus menyimpan semua pekerjaan pada foder
tersebut!
2. Bukalah Microsoft Access, dan buatlah sebuah file baru, simpan
dengan nama Latihan2.mdb pada folder anda.
3. Buat file untuk menyimpan data Buku yang ada di ruang referensi
Jur. Akuntansi. File tersebut memiliki tabel sebagai berikut (tanpa
Primary Key):

4. Isikan datanya dengan data berikut ini:

16
Perangkat Lunak Basis Data

BAB 3

MENGELOLA TABEL

Tujuan Materi: mahasiswa dapat mengelola data/record yang ada


dalam tabel di Microsoft Access

3.1 MENGEDIT RECORDS

Untuk mengedit arsip, mudah saja tempatkan kursor dalam arsip


yang akan diedit dan buat perubahan yang penting. Gunakan
panah untuk memindahkan arsip. Sebelumnya, selanjutnya,
pertama, dan akhir tombol arsip pada bawah datasheet membantu
dalam manuver datasheet.

3.2 MENGHAPUS RECORDS

Menghapus arsip pada dataseheet dengan menempatkan kursor


dalam baris dan pilih Edit|Delete Record dari menu bar atau klik
tombol Delete Record pada datasheet toolbar.

Letakkan Kursor di sini, Letakkan Kursor di sini,


untuk menghapus untuk mengedit

Gambar 3.1 Menghapus dan Mengedit Record

3.3. MEMASUKKAN DAN MENGHAPUS KOLOM

Walaupun yang terbaik adalah membuat field baru (tampilan


kolom dalam datasheet) pada design view karena banyak pilihan

17
Perangkat Lunak Basis Data

disediakan, mereka bisa juga dengan cepat memasukkannya dalam


datasheet view. Sorot kolom yang merupakan kolom baru yang
ditampilkan ke sebelah kiri dengan mengklik label di atas datasheet
dan pilih Insert|Column dari menu bar. Memasukkan kolom bisa
juga dengan menghapus dengan menempatkan kursor dalam
kolom dan memilih Edit|Delete Column dari menu bar.

3.4 MENGUBAH UKURAN BARIS DAN KOLOM

Tinggi baris dalam datasheet bisa diubah dengan mendrag garis


abu antara label baris diatas dan bawah dengan mouse. Dengan
mengubah tinggi satu baris, tinggi semua baris dalam datasheet
akan berubah menjadi value yang baru. Lebar kolom bisa diubah
dalam beberapa cara dengan mendrag ukuran baris antara kolom.
Klik ganda pada baris untuk mendapatkan kolom otomatis cocok
untuk value yang panjang dari kolom. Tidak seperti baris, kolom
pada datasheet bisa berbeda lebarnya. Ukuran nya bisa diubah
dengan memilih Format|Row Height atau Format|Column
Width dari menu bar.

3.5 FREEZING COLUMNS

Sama seperti dalam Excel, Kolom pada tabel Access table bisa
dibekukan (Freezing). Ini membantu jika datasheet memiliki banyak
kolom dan data relevan akan tidak tampak dilayar pada saat
bersamaan. Freeze kolom dengan cara menempatkan kursor pada
suatu arsip dalam kolom lalu pilih Format|Freeze Columns dari
menu bar. Pilih option yang sama untuk menghilangkan freeze
kolom atau pilih Format|Unfreeze All Columns.

18
Perangkat Lunak Basis Data

Gambar 3.2Melakukan Freeze Pada Kolom

3.6 MENYEMBUNYIKAN KOLOM

Kolom bisa juga disembunyikan dari tampilan dalam datasheet


walaupun mereka tidak akan dihapus dalam database. Untuk
menyembunyikan kolom, tempatkan kursor pada sembarang arsip
dalam kolom atau sorot beberapa kolom yang bersebelahan
dengan mengklik dan mendrag mouse sepanjang kolom header,
dan pilih Format|Hide Columns dari menu bar Untuk
menampilkan kolom yang disembunyikan, pilih Format|Unhide
Columns dari menu bar. Jendela akan menampilkan semua field
dalam tabel daftar dengan daftar kotak disamping masing-masing
nama field. Ceklist kotak disaming semua field yang ingin
ditampilkan pada tabel data dan klik tombol Close.

Gambar 3.3 Melakukan Unhide Kolom


3.7 MENCARI DATA DALAM TABEL

19
Perangkat Lunak Basis Data

Data dalam datasheet bisa dengan cepat ditemukan lokasinya


dengan menggunakan perintah Find
1. Buka tabel dalam tampilan datasheet.
2. Tempatkan kursor dalam suatu arsip dalam field yang ingin
dicari dan pilih Edit|Find... dari menu bar
3. Masukkan nilai kriteria value dalam kotak Find What: .
4. Dari Look In: menu panah kebawah, gambarkan area pencarian
dengan memilih keseluruh tabel atau hanya field dalam tabel
yang tempat anda meletakkan kursor dalam langkah ke 2.
5. Pilih kriteria yang sesuai dari Match: dan klik tombol >> untuk
menambahkan parameter pencarian.
6. Ketika semua kriteria pencarian diset, klik tombol Find Next.
Jika lebih dari satu arsip menemukan kriteria, terus klik Find
Next sampai anda mencapai arsip yang benar.

Gambar 3.4 Jendela Dialog Find

3.8 MENCARI DAN MENGGANTI

Fungsi Find and Replace mengijinkan anda untuk secara cepat


mengganti data tunggal denan value baru atau mengganti semua
kejadian dalam tabel
1. Pilih Edit|Replace... dari menu bar (atau klik Replace tab jika
menemukan jendela telah terbuka.).

20
Perangkat Lunak Basis Data

2. Ikuti langkah prosedur pencarian data untuk mengganti dan


mengetik nilai baru dari data dalam kotak Replace With:.
3. Klik tombol Find Next dan tombol Replace untuk membuat
pergantian tunggal. Klik Replace All untuk mengganti semua
data dalam satu langkah.

Gambar 3.5Jendela Dialog Find and Replace

21
Perangkat Lunak Basis Data

LATIHAN 3

1. Copykan File LATIHAN 2.MDB, menjadi file baru dengan nama


LATIHAN 3,MDB,, pada folder anda

2. Ubahlah Field KodeBuku, menjadi Primary Key


3. Ubahlah Record dengan kode K01, pada filed Judul : Pemrograman
C, menjadi Pemrograman C++
4. Hapuslah Record dengan KodeBuku K03.
5. Tambahkan Record-Record berikut ini:
KodeBuk Judul TahunTerb Eksempla Pengarang
u it r
K07 Tip dan Trik 2008 17 Siti
Microsoft Access Sunrowiyati
2003
K07 Linux Red Hat 2006 12 Andy
Syahputra
V.10

22
Perangkat Lunak Basis Data

BAB 4

MERELASIKAN TABEL

Tujuan Materi: mahasiswa dapat membuat relasi antar tabel di


Microsoft Access

4.1 MERELASIKAN TABEL

Untuk mencegah duplikasi informasi dalam database dengan


pengulangan fields dalam satu tabel, hubungan dapat dibentuk
untuk link field tabel secara bersama. Ikuti langkah dibawah untuk
membuat hubungan database.
1. Klik tombol Relationships pada toolbar.
2. Dari jendela Show Table (klik tombol Show Table pada toolbar
untuk membuat tampilan ), Klik ganda pada nama tabel yang
akan dimasukkan ke dalam hubungan. Ketika anda selesai
memasukkan tabel, klik Close.
3. Untuk link field dalam dua tabel yang berbeda, klik dan drag
field dari satu tabel ke field yang sesuai dalam tabel yang lain
dan lepaskan tombol mouse. Edit Relationships window akan
muncul. Dari window ini, pilih field yang berbeda jika perlu dan
pilih option dari Enforce Referential Integrity jika perlu. Pilihan
ini memberikan Access izin untuk secara otomatis membuat
perubahan tabel petunjuk jika kunci arsip dalam satu tabel yang
dihapus. Ceklist kotak Enforce Referential Integrity untuk
memastikan hubungan bisa dilakukan dan data bukan secara
kebetulan dihapus ketika data dimasukkan, diedit atau dihapus.
Klik Create untuk membuat link.
4. Baris sekarang menghubungkan dua field dalam hubungan
relationships window.
5. Datasheet suatu hubungan tabel akan menyediakan perluasan
dan tanda penghapusan untuk melihat isi subdatasheets

23
Perangkat Lunak Basis Data

informasi yang sesuai dari tabel lain.. Untuk memperluas atau


menghilangkan semua subdatasheets sekaligus, pilih Format|
Subdatasheet|Expand All atau Collapse All dari menu
toolbar.

4.2 MEMBUAT RELASI ANTAR TABEL

Untuk membuat relasi antar tabel, lakukan langkah-langkah berikut


ini:
1. pada menu, klik Tools -> Relationships
2. Klik Kanan pada Mouse, pilih Add table

Gambar 4.1Menambahkan Tabel Pada Jendela Relationship

3. Tambahkan tabel-tabel yang akan digunakan pada relasi


4. Tambahkan tabel satu persatu, pilih tabel kemudian klik tombol
Add.
5. Terakhir klik tombol Close
6. Anda akan mendapatkan tampilan berikut ini:

Gambar 4.1Tabel Yang Siap Direlasikan

7. Relasikan dengan Mengklik salah satu field pada tabel, dan drag
ke field yang akan direlasikan pada table lain, tekan tombol

24
Perangkat Lunak Basis Data

“create” untuk membuat relasi.


8. Hasilnya tampak seperti ini:

Gambar 4.3Tampilan Relashionship

Gambar 4.4Tabel yang telah direlasikan

25
Perangkat Lunak Basis Data

LATIHAN 4

1. Buatlah sebuah file database, simpan dengan nama LATIHAN 4.MDB


pada folder anda.
2. Buatlah tabel-tabel di bawah ini, untuk struktur tabel silahkan anda
tentukan sendiri.
Tabel Barang Tabel Detail_Order
NomerBrg NamaBrg Harga NomerOrder NomerBrg Jumlah
B01 Pensil Staedler 2B 1500 1 B02 3
B02 Bolpoint Weiyada Hitam 2000 5 B02 12
B03 Bolpoint Weiyada Merah 2000 1 B03 3
B04 Bolpoint Weiyada Biru 2000 2 B04 15
B05 Spidol Board Marker Swallow Hitam 4500 2 B05 2
B06 Spidol Board Marker Swallow Merah 4500 3 B05 6
B07 Spidol Board Marker Swallow Biru 4500 8 B06 5
B08 Gunting Kecil 5000 4 B07 2
B09 Stapler 10250 6 B09 5
B10 Staples,500 3000 9 B09 10
B11 Staples,250 2500 1 B11 3
B12 Notes Kecil 7000 2 B12 2
B13 Kertas Surat 2500 8 B14 10
B14 KotakPensil 13000 7 B16 4
B15 Penghapus Staedler Kecil 8250 4 B17 2
B16 Penghapus Staedler Besar 12500 9 B19 19
B17 Penggaris Besi 30 Cm 6000 9 B22 12
B18 Penggaris Besi 20 Cm 4000 7 B26 10
B19 Cutter Besar Kenko 15000 8 B29 10
B29 Cutter Kecil Kenko 10000 7 B31 5
B30 Isi Cutter Besar 4000 4 B34 2
B31 Isi Cutter Kecil 2500 6 B35 10
B32 Kertas A4 Sinar Dunia 24000
B33 Kertas F4 Sinar Dunia 29000
B34 Correction Fluid Kenko 14000
B35 Correction Pen Tipex 17000

26
Perangkat Lunak Basis Data

Tabel Order
NomerOrder NomerPlg TanggalOrder
1 P01 07/05/2008
2 P01 07/05/2008
3 L01 08/05/2008
4 L02 08/05/2008
5 L01 08/05/2008
6 P02 09/05/2008
7 P03 09/05/2008
8 L03 10/05/2008
9 L04 10/05/2008

Tabel Pelanggan
NomerPlg NamaPlg Alamat Kota Telpon
L01 Toharudin Jl. Anggrek 66 Lhokseumawe 08123334455
L02 Abubakar Husin Jl. Rinjani 33 Lhokseumawe 08156622111
L03 Iffa Soraya Jl. Danau Kintamani 44 Lhokseumawe 08172299999
L04 Habadal Arif Jl. Borobudur 67 Lhokseumawe 08585667799
P01 Diana Pungki Jl. Dr. Soetomo 11 Lhokseumawe 08585663322
P02 Saleh Al Habsi Jl. Dahlia 90 Lhokseumawe 08195558888
P03 Ali Mansyur Jl. Teluk Etna 77 Lhokseumawe 08585992222

3. Relasikan tabel-tabel tersebut, sehingga Realtionshipnya memiliki


tampilan sebagai berikut:

27
Perangkat Lunak Basis Data

4. Sedangkan Tabel Pelanggan, jika dibuka mempunyai tampilan


sebagai berikut:

28
Perangkat Lunak Basis Data

BAB 5
MENGURUTKAN DAN MENYARING DATA

Tujuan Materi: mahasiswa dapat mengurutkan dan menyaring


data/record dalam tabel di Microsoft Access

5.1 SORTING

Anda boleh melihat arsip dalam tabel dalam perintah berbeda


dari yang mereka tampilkan seperti menyortir dalam tanggal atau
memberi perintah secara alphabet, untuk contoh. Ikuti langkah
untuk menyortir arsip dalam tabel dengan menggunakan angka
pada satu field.
1. Pada tabel view, tempatkan kursor dalam kolom yang ingin di
sortir.
2. Pilih Records|Sort|Sort Ascending atau Records|Sort|Sort
Descending dari menu bar atau klik Sort Ascending atau
tombol Sort Descending pada toolbar.

Untuk menyortir lebih dari satu kolom (seperti menyortir dalam


tanggal dan lalu menyortir arsip dengan tanggal yang sama
dalam alphabet), sorot kolom dengan mengklik dan mendrag
mouse melewati label field dan pilih satu dari metode diatas.

5.2 FILTER BY SELECTION (MENYARING DENGAN MEMILIH)

Fitur ini akan menyaring arsip yang berisi data identik


bernilai pada field seperti menyaring semua arsip yang
berhubungan dengan "Smith" dalam field. Untuk memfilter
dengan memilih, tempatkan kursor dalam filed yang ingin disaring
dalam arsip dan klik tombol Filter by Selection dalam toolbar
atau pilih Records|Filter|Filter By Selection dari menu bar.
Seperti dalam contoh dibawah, kursor ditempatkan dalam City
field pada arsip kedua yang berbubungan dengan "Ft. Myers" lau

29
Perangkat Lunak Basis Data

penyaringan tabel akan menunjukkan hanya arsip dimana city


dari Ft. Myers.

5.3 FILTER BY FORM

Jika tabel sangat luas, sangat sulit untuk mencari arsip yang berisi
hubungan yang ingin disaring, dengan menggunakan Filter by
Form akan sangat menguntungkan. Metode ini membuat versi
kosong dari tabel dengan menu panah kebawah untuk masing-
masing field berisi hubungan nilai yang ditemukan dalam arsip
pada field. Dibawah default Look for tab dalam jendela Filter by
Form, klik dalam field untuk masuk ke kriteria filter. Untuk
menetapkan suatu kriteria jika arsip berisi satu dari dua nilai
spesifik, klik Or tab pada bawah jendela dan pilih kriteria lain dari
menu panah bawah. Lebih Or tabs akan muncul setelah satu
kriteria diset untuk mengijinkan anda untuk memasukkan lebih
kriteria dengan filter. Setelah anda memilih semua kriteria yang
diinginkan untuk disaring, klik tombol Apply Filter pada toolbar.

Metode berikut dapat digunakan untuk memilih arsip berdasar


arsip yang dipilih dengan tidak memiliki nilai yang sama persis.

30
Perangkat Lunak Basis Data

Ketikan format ini ke dalam field dimana menu panah kebawah


akan tampil sebagai pengganti pemilihan nilai absolut.

5.4 MENYIMPAN FILTER

Isi dari dari saringan tabel bisa disimpan dengan memilih File|
Save As Query dari menu bar. Masukkan nama dari query dan
klik OK. Query sekarang disimpan dalam database

31
Perangkat Lunak Basis Data

LATIHAN 5

1. Copy file LATIHAN 4.MDB , menjadi sebuah file baru dengan nama
LATIHAN 5.MDB pada folder anda.
2. Buka Tabel Pelanggan, urutkan berdasar nama, secara Ascending
sehingga mempunyai tampilan sebagai berikut:

3. masih menggunakan tabel Pelanggan, urutkan berdasar nama,


secara Descending sehingga mempunyai tampilan sebagai berikut:

4. Buka Tabel Barang, Gunakan Filter By Selection Untuk Menampilkan


Banang yang harganya Rp. 2000, sehingga memiliki tampilan
sebagai berikut:

32
Perangkat Lunak Basis Data

5. Buka Tabel Barang, Gunakan Filter By Form Untuk Menampilkan


Banang yang harganya >Rp. 2000, simpan sebagai Query dengan
nama Query Harga > 2000.
6. Jalankan Query pada soal No 4, di atas sehingga memiliki tampilan
sebagai berikut:

BAB 6

33
Perangkat Lunak Basis Data

MEMBUAT OBYEK QUERIES

Tujuan Materi: mahasiswa dapat membuat obyek query di Microsoft


Access

6.1 MEMBUAT QUERY DALAM DESIGN VIEW

Membuat Queries pada dasarnya adalah perintah untuk menyajikan


informasi dengan menggunakan hubungan antara variable yang
saling melengkapi informasinya, sehingga informasi bias sesuai
dengan kebutuhan yang dicari maupun yang akan dilaporkan.

Ikuti langkah dibawah untuk membuat new query dalam Design


View:
1. Buka object/menu Query seperti sebagai berikut :

.
Gambar 6.1 Membuat Query

2. Pilih Create Query in design, maka akan muncul dialog memilih


query seperti dibawah ini :

34
Perangkat Lunak Basis Data

Gambar 6.2 Memilih Query

3. Pilih semua tabel (Klik Tabel Barang, sambil menekan tombol


Shift. Klik Tabel Pelanggan)  Tekan tombol Add  Tekan Tombol
Close, anda akan mendapatkan Tampuilan sebagai berikut:

Gambar 6.3 Hasil pemilihan query table

4. Lalu tentukan informasi yang akan ditampilkan, pilih Field pada


table yang berisi informasinnya, seperti sebagai berikut :

35
Perangkat Lunak Basis Data

Gambar 6.4 Menentukan informasi relasi antar table

5. Untuk menyimpan Query : Pilih File dan klik Save, lalu beri nama
Query Penjualan

6. Untuk Menjalankan hasil Query , Klik Tombol Run pada


toolbar, maka anda akan mendapatkan tampilan sebagai berikut

Gambar 6.7 Tampilan Query

6.2 MENAMBAHKAN FIELD BERISI PENJUMLAHAN PADA QUERY

Anda bisa menambahkan satu atau beberapa Field dalam


sebuah Query, yang berisi penjumlahan ataupun perkalian dari
field-fiel yang ada. Untuk membuatnya, letakkan kursor pada field
yang diinginkan, kemudian tuliskan formulanya sebagai berikut:

36
Perangkat Lunak Basis Data

Nama Field baru:[Field..1]*[Field..2]*[Field..n]


Misal: kita mebuat sebuah Query penjualan, dengan susunan field-
field sebagai berikut:

Field yang dibuat dengan


menggunakan Rumus

Gambar 6.8 Design Query, dengan field yang ditambahkan

Maka jika Query tersebut dijalankan, anda akan mendapatkan


tampilan sebagai berikut:
Field Baru

Gambar 6.9 Tampilan Query, dengan field yang ditambahkan


6.3 MENAMBAHKAN KRITERIA PADA QUERY

37
Perangkat Lunak Basis Data

Bila ingin ingin menyajikan hasil queri dengan memberikan criteria,


misalnya menampilkan pembelian yang hanya dilakukan oleh
Toharudin, maka pada Field Anggota, tuliskan kriteria yang
ditentukan. bila sebagai criteria berupa data teks, harus diapit
tanda “ ”, bila numeric tanpa tanda “ ”, bila ingin menyajikan data
pembali yang membeli mulai tanggal 08/05/2008 maka pada
Criteria tanggal isi dengan >#20/2/2006#.

Sebagai Contoh, kita akan menampilkan pembelian yang dilakukan


oleh Toharudin, maka design Query-nya adalah sebagai berikut:

Gambar 6.10 Query dengan Kriteria


Hasilnya adalah sebagai berikut:

Gambar 6.11 Hasil Query dengan Kriteria


6.4 MENGHAPUS RELASIONSHIPS ANTAR TABLE

38
Perangkat Lunak Basis Data

Untuk menghapus relasi antar tabel maka, hubungan antar table


tersebut, klik garis penghubung antar tabel atau ditunjuk dengan
mouse lalu klik kanan maka akan muncul seperti dibawah ini, lalu
pilih Delete, maka tanda [penghubung akan terhapus.

Gambar 6.12 Menghapus Relasi Query

39
Perangkat Lunak Basis Data

LATIHAN 6

1. Buatlah sebuah file database dengan nama LATIHAN 6.MDB,


simpan pada folder anda masing-masing.
2. Adapun tabel struktur tabel-tabelnya adalah sebagai berikut:

Tabel: Produk
Field Name Data Type Decription
IdProduk Autonumber
NamaProduk Text
Katagori Text
HargaPerUnit Text
LevelOrder Number Jumlah persediaan
minimum
LeadTime Number Waktu pemesanan

Tabel: Katagori
Field Name Data Type Decription
IdKatagori Autonumber
Katagori Text

3. Adapun isi tabelnya adalah sebagai berikut:

40
Perangkat Lunak Basis Data

3. Buatlah sebuah relasi antar tabel Katagori dan Tabel Produk,


dengan menggunakan Field Katagori sebagai field relasi.
4. Tampilkan Relationship, dan lihatlah jenis relasi apa yang dimiliki
5. Buatlah sebuah Query untuk menampilkan field-field : IdProduk,
NamaProduk, Katagori, HargaPerUnit, LevelOrder, LeadTime,
IdKatagori, Katagori
6. Buatlah sebuah Query untuk menampilkan field-field : IdProduk,
NamaProduk, Katagori, HargaPerUnit, LevelOrder, LeadTime,
IdKatagori, Katagori, untuk produk makanan
7. Buatlah sebuah Query untuk menampilkan field-field : IdProduk,
NamaProduk, Katagori, HargaPerUnit, LevelOrder, LeadTime,
IdKatagori, Katagori, untuk produk yang Level Ordernya kurang dar
25.
8. Simpan File LATIHAN 6.MDB, dengan nama baru File LATIHAN
6A.MDB, dan lakukan perubahan sebagai berikut:
a. Hapus relasi yang dimiliki Tabel Katagori dan Tabel Produk.
b. Ubahlah struktur tabel Produk, untuk field Katagori, menjadi
data type “Lookup Wizard”, yang merujuk pada Field Katagori pada
Tabel: Katagori.
Tampilkan Relationship, dan lihatlah jenis relasi apa yang dimiliki

41
Perangkat Lunak Basis Data

BAB 7

MEMBUAT OBYEK FORM

Tujuan Materi: mahasiswa dapat membuat obyek form di Microsoft


Access

7.1 MEMBUAT FORM DENGAN WIZARD

Form dibuat dengan tujuan untuk memberikan tampilan hasil


pengelolaan informasi yang disajikan dengan lebih mudah, lebih
menarik serta informatif menggunakan Graphical User Interface.
Form digunakan untuk menginputkan data dan memodifikasi data
yang ada dalam tabel. Dalam aplikasi database, form dapat
dibedakan menjadi :
• Form master : yaitu form yang digunakan untuk data pada
tabel master, contoh form siswa, form barang,
dll.
• Form transaksi : yaitu form yang digunakan untuk data
transaksi, contoh : form penjualan, form entri
nilai, dll.
Langkah-langkah :
1. Buka database CV FAJAR UTAMA
2. Klik Obyek Form

42
Perangkat Lunak Basis Data

Gambar 7.1 Create Form By Using Wizard

3. Double Click Create Form By Using Wizard, anda akan


memperoleh tampilan sebagai berikut:Pilih dan klik Form Wizard

Untuk memilih tabel


source

Untuk memindah 1 field

Untuk memindah semua


field

Gambar 7.2 Form Wizard memilih tabel dan field

4. Pilih table yang akan dibuat form entrinya. Misal tabel DATA
PRIBADI
5. maka masukan field-field yang dibutuhkan yang nampak dalam
kotak Available Fields, Cara memilih dengan menekan tombol
botton panah satu bila ingin menyeleksi satu persatu dan pilih
tombol panah dua jika seluruh field diinginkan.Seperti namap
berikut seperti nampak dibawah ini:

43
Perangkat Lunak Basis Data

Gambar 7.3 Memilih Tabel dan Field yang dimasukan di Form

6. Klik Next ke langkah selanjutnya, anda akan mendapatkan


jendela pemilihan Layout sebagai berikut:

Gambar 7.4 Memilih Layout Form

7. Pilih Layout Form yang diinginkan, apakah Columnar, Tabular,


dan lain-lain, dengan tampilan yang diinginkan :
8. Pilih Next jika sudah menentukan jenis layout yang diinginkan,
misalnya tadi dipilih Columnar, maka akan muncul dialog jenis-
jenis style yang diinginkan dalam form nantinya. Ini ditunjukkan
dalam gambar berikut ini:

44
Perangkat Lunak Basis Data

Gambar 7.5 Style Form Wizard


9. Pilih Next untuk melanjutkan bila sudah ditentukan jenis style
yang diinginkan. Misalnya pilih Expedition untuk contoh style
diatas.
10. Pilih Next untuk melanjutkan maka akan diminta
memasukan judul dalam form yang akan ditampilkan: DATA
PRIBADI

Gambar 7.6 Memberi Nama pada Form Wizard

11. Bila ingin memodifikasi atau merubah rancangan form maka


pilih Modify the form’s design.

45
Perangkat Lunak Basis Data

Gambar 7.7 Form Design untuk merubah Desain Form


12. Jika anda tidak ingin memodifikasi atau merubah rancangan
form maka pilihlah Open The Form To View or Enter Information,
kemudian klik Finish, maka anda akan mendapatkan tampilan
Form sebagai berikut:

Gambar 7.8 Tampilan Form DATA PRIBADI

7.2 MEMBUAT FORM DENGAN DESIGN VIEW

46
Perangkat Lunak Basis Data

Tujuannya untuk membuat rancangan form yang kosong dengan


memasukan nama-nama field dengan cara menarik dari form ke
kiri dan ke kanan, ke atas dan ke bawah.
Langkah-langkah :
1. Pilih menu Insert, dan Form lalu, pilih Design View.
2. Pilih Tabel/Query yang akan digunakan sebagai source-nya

Gambar 7.9 Merancang form dengan Desin View

Gambar 7.10 Lembar design view dalam form


Lalu field dalam table yang telah tampil diatas pilih dan geser,
letakan pada lembar yang telah disediakan oleh section detail.
Sehingga nampak seperti dibawah ini :

47
Perangkat Lunak Basis Data

Klik dan Drag

Gambar 7.11 Memasukan Field di Lembar Detail dalam form

Gambar 7.12. Hasil running perancangan form dengan Design


View

7.3 MEMODIFIKASI FORM

Kita bisa memodifikasi form, baik yang kita buat melalui Form
Wizard, maupun dengan menggunakan Design view.
Berikut ini adalah bagian-bagian dari sebuah form, dalam tampilan
Design View:

48
Perangkat Lunak Basis Data

Gambar 7.12 Hasil running perancangan form dengan Design View

Pada gambar di atas, anda bisa meletakkan kursor di batas antara


Form Header dan Detail, kemudian klik dan drag untuk
memperlebar jaraknya sehingga cukup tercipta satu ruang.

Anda juga dapat memperlebar batar grid (garis kotak-kotak0 juga


dengan melakukan klik dan drag. Untuk memindahkan label dan
data, lakukan juga klik dan drag.

1. Menambahkan form header, berupa nama perusahaan.


Klik pada form header, kemudian pilih label pada toolbox,
buatlah sebuah texbox pada form header dan tuliskan nama
perusahaan

Gambar 7.13 Menambahkan Nama perusahaan menggunakan Label

49
Perangkat Lunak Basis Data

2. Merubah Type Font dan Ukuran Font


Untuk merubah ukuran dan type font, klik label yang anda buat,
kemudian ubahlah ukuran dan type font menggunakan fasilitas
yang ada pada standar toolbar. Hasilnya adalah sebagai berikut:

Gambar 7.14 Merubah Font Type dan Font Size


Dengan cara yang sama, lengkapi juga dengan Alamat dan
Nomor telpon perusahaan
3. Menambahkan Logo Perusahaan
Anda juga bisa menambahkan logo perusahaan, maupun ClipArt.
Caranya adalah:
Klik pada lokasi Form Header  Insert  Picture, (tenbtukan
lokasi gambar/ClipArt yang diinginkan.
Hasil akhir nya adalah sebagai berikut:

50
Perangkat Lunak Basis Data

Gambar 7.15 Tampilan Akhir Dalam Form Design

Gambar 7.14 Tampilan Form Data Pribadi

51
Perangkat Lunak Basis Data

LATIHAN 7

1. Buatlah tabel DATA PRIBADI, dengan struktur sebagai berikut:

2. Buatlah tabel TARIF UPAH LEMBUR, dengan struktur sebagai berikut:

3. Buatlah tabel DATA KERJA, dengan struktur sebagai berikut:

4. Buatlah SEBUAH Form untuk mengisikan DATA PRIBADI Karyawan,


simpan dengan nana FORM DATA PRIBADI, yang memilki tampilan
sebagai berikut:

52
Perangkat Lunak Basis Data

Form
header

Detail

5. Melalui Form tersebut isikan Data Pribadi Karyawan, yang memilki isi
sebagai berikut:
Tabel: DATA PRIBADI
NIP NAMA GOLONGAN ALAMAT KOTA
95001 ZAINAL ARIFIN 3 JL. CEMARA 34 BANDA ACEH
95002 AHMAD SYARIF 2 JL. Dr. SOETOMO 56 BANDA ACEH
95003 CUT MEUTIA 2 JL. DIPONEGORO 78 BANDA ACEH
96006 K. LUMBAN BATU 2 JL. MERAPI 90 KOTABARU
96007 MARIA ULFAH 1 JL. SLAMET RIYADI 66 BANDA ACEH
97010 TENGKU RAFLI 1 JL. RAYA 135 KOTABARU
98012 SUMARDI 1 JL. PANGLIMA POLIM 99 BANDA ACEH
99014 ZASKIA HASAN 1 JL. CUT NYA' DIN 21 BANDA ACEH
99015 MARDIANSYAH 1 JL. HASANUDIN 19 KOTABARU
99017 TOGAR SIMATUPANG 1 JL. DANAU TOBA 35 BANDA ACEH

6. Buatlah Form untuk mengisikan Tabel DATA KERJA dan TARIF UPAH
LEMBUR. simpan dengan nama form yang sama dengan nama
tabelnya, Atur tampilannya sehingga tampak menarik. Bentuk Form
anda atur sendiri, dengan bagian Form Header buat sama dengan
foRM data pribadi

53
Perangkat Lunak Basis Data

7. Isikan tabel-tabel di atas dengan data berikut ini. Gunakan Form


untuk mengentry data:
Tabel: TARIF UPAH LEMBUR
GOLONGAN UPAH PER HARI LEMBUR PER JAM
1 15000 1500
2 20000 2000
3 25000 2500

Tabel: DATA KERJA


NIP BULAN HARI KERJA JAM LEMBUR
95001 MEI 24 3
95001 JUNI Tabel: 22 5
95002 MEI 25 12
95002 JUNI 26 12
95003 MEI 24 0
95003 JUNI 22 0
96006 MEI 23 5
96006 JUNI 22 0
96008 MEI 26 12
96008 JUNI 25 8
97010 MEI 22 0
97010 JUNI 24 10
98012 MEI 25 8
98012 JUNI 23 2
99014 MEI 20 0
99014 JUNI 25 5
99015 MEI 22 3
99015 JUNI 26 12
99017 MEI 26 15
99017 JUNI 22 0

54
Perangkat Lunak Basis Data

BAB 8

MENAMBAHKAN COMMAND BUTTON PADA FORM

Tujuan Materi: mahasiswa dapat menambahkan obyek command


button dalam form di Microsoft Access

8.1 MENAMBAHKAN COMMAND BUTTON

Command Button adalah tombol-tombol yang bisa ditambahkan


pada Form, dan yang jika diklik maka aka\n menjalankan suatu
perintah tertentu.

Untuk menamambahkan command button, Form harus berada


pada tampilan Form Design.

1. Klik tombol command button. Pastikan


tombol ini
aktif

Tombol
command
button

Gambar 8.1 Toolbox


2. Pilih Catagories dan Actions.

55
Perangkat Lunak Basis Data

Gambar 8.2 Memilih katagori dan Action

3. Pilih gambar untuk simbol command button.

Gambar 8.3 Memilih Simbol untuk Button

4. Tentukan nama command button (dapat diabaikan)

56
Perangkat Lunak Basis Data

Gambar 8.4 Memilih nama untuk command Button

Gambar 8.5 Form Design Dengan Tambahan Command Button

Gambar 8.6 Form Design Dengan Tambahan Command Button

57
Perangkat Lunak Basis Data

LATIHAN 8

1. Copykan file LATIHAN 7.MDB, menjadi file baru dengan nama baru
LATIHAN 8.MDB
2. Tambahkan beberapa command button, Serta pada Form Footer,
tambahkan Tulisan “Design By: Nama anda”. Sehingga memiliki
tampilan sebagai berikut:

Exit Form

Add New Record Delete Record Save Record

Record Navigation

3. Tambahkan beberapa command button, Serta pada Form Footer,


tambahkan Tulisan “Design By: Nama anda”. Untuk 2 Form Lainnya,
aturlah sesuai selera anda.

58
Perangkat Lunak Basis Data

BAB 9

OBYEK REPORT

Tujuan Materi: mahasiswa dapat membuat obyek report di Microsoft


Access

9.1 MEMBUAT LAPORAN MELALUI REPORT BY USING WIZARD

Data yang telah dimasukan dalam table, tidak cukup dilihat dalam
form, akan tetapi dibutuhkan report untuk keperluan pelaporan
yang sesuai dengan kebutuhan manajemen, laporan dapat
dipreview atau dicetak ke kertas.Membuat laporan dalam acces
ada dua fasilitas, yaitu Create Report in Design View dan Create
Report by Using Wizard.
Langkah-langkah :
1. Buka database, dan Pilih Report Wizard, tabelnya, missal table
buku, seperti contoh berikut :

Gambar 9.1 Memilih Source dan Field


2. Klik Next untuk melanjutkan ke step berikutnya, yaitu
menentukan Field apa yang digunakan sebagai dasar

59
Perangkat Lunak Basis Data

pengelompokkan, (misal kita ikuti pilihan yang disediakan,


yaitu berdasar GOLONGAN) :

Gambar 9.2 Memilih Source dan Field

3. Klik Next untuk melanjutkan ke step berikutnya, yaitu


menentukan Field apa yang digunakan sebagai dasar
pengurutan (sorting)

Gambar 9.3 Memilih Field Untuk Dasar Pengurutan

60
Perangkat Lunak Basis Data

4. Klik Next untuk melanjutkan ke step berikutnya, yaitu


menentukan Layout dan style apa yang diinginkan.

Gambar 9.4 Memilih layout report

Gambar 9.5 Memilih style report

5. Klik Next untuk melanjutkan ke step berikutnya, yaitu


menentukan nama Report yang akan disimpan.

61
Perangkat Lunak Basis Data

Gambar 9.6 Menentukan Nama Obyek Report

6. Klik Tombol Finish untuk melihat hasilnya, sebagai berikut:

Gambar 9.7 Tampilan Hasil Report

62
Perangkat Lunak Basis Data

LATIHAN 9

1. Copykan file LATIHAN 7.MDB, menjadi file baru dengan nama baru
LATIHAN 9.MDB
2. Buatlah sebuah Query, yang memilik tampilan sebagai berikut:

3. Buatlah sebuah Query, yang memiliki tampilan sebagai berikut:


TOTAL GAJI JUNI
BULAN NIP NAMA GAJI LEMBUR TOTAL GAJI
JUNI 95001 ZAINAL ARIFIN 550000 12500 562500
JUNI 95002 AHMAD SYARIF 520000 24000 544000
JUNI 95003 CUT MEUTIA 440000 0 440000
JUNI 96006 K. LUMBAN BATU 440000 0 440000
JUNI 97010 TENGKU RAFLI 360000 15000 375000
JUNI 98012 SUMARDI 345000 3000 348000
JUNI 99014 ZASKIA HASAN 375000 7500 382500
JUNI 99015 MARDIANSYAH 390000 18000 408000
JUNI 99017 TOGAR 330000 0 330000
SIMATUPANG

63
Perangkat Lunak Basis Data

4. Buatlah sebuah Report, yang halaman 1 memiliki tampilan sebagai


berikut:

64
Perangkat Lunak Basis Data

BAB 10

OBYEK REPORT DENGAN SUMMARY OPTION

Tujuan Materi: mahasiswa dapat membuat obyek report dengan


bantuan fasilitas report wizard di Microsoft Access

10.1 Menggunakan Summary Option


Kita bisa melakukan rangkuman perhitungan pasa saat membuat
sebuah report. Fasilitas ini disebut sebagai Summary option

Gambar 10.1 Menentukan Source Dan Field

Gambar 10.2 Jendela menentukan Group Level

65
Perangkat Lunak Basis Data

Gambar 10.3 Jendela menentukan Group Level

Gambar 10.4 Menentukan layout

66
Perangkat Lunak Basis Data

Gambar 10.5 Menentukan Style

Gambar10.6 Menentukan Nama Report

67
Perangkat Lunak Basis Data

Gambar 10.7 Report Dengan Summary Option

68
Perangkat Lunak Basis Data

LATIHAN 10

1. Copykan File LATIHAN 4.MDB, menjadi sebuah file baru dengan nama
LATIHAN 10.MDB
2. Buatlah Query, simpan dengan nama Query Penjualan, dengan hasil
sebagai berikut:

Query Penjualan
NamaPlg NomerOrder TanggalOrder NamaBrg Harga Jumlah Total
Diana Pungki 1 07/05/2008 Staples,250 2500 3 7500
Diana Pungki 1 07/05/2008 Bolpoint Weiyada Hitam 2000 3 6000
Diana Pungki 1 07/05/2008 Bolpoint Weiyada Merah 2000 3 6000
Diana Pungki 2 07/05/2008 Spidol Board Marker 4500 2 9000
Swallow Hitam
Diana Pungki 2 07/05/2008 Bolpoint Weiyada Biru 2000 15 30000
Diana Pungki 2 07/05/2008 Notes Kecil 7000 2 14000
Toharudin 3 08/05/2008 Spidol Board Marker 4500 6 27000
Swallow Hitam
Abubakar Husin 4 08/05/2008 Correction Fluid Kenko 14000 2 28000
Abubakar Husin 4 08/05/2008 Penggaris Besi 30 Cm 6000 2 12000
Abubakar Husin 4 08/05/2008 Spidol Board Marker 4500 2 9000
Swallow Biru
Toharudin 5 08/05/2008 Bolpoint Weiyada Hitam 2000 12 24000
Saleh Al Habsi 6 09/05/2008 Correction Pen Tipex 17000 10 170000
Saleh Al Habsi 6 09/05/2008 Stapler 10250 5 51250
Ali Mansyur 7 09/05/2008 Penghapus Staedler Besar 12500 4 50000
Ali Mansyur 7 09/05/2008 Isi Cutter Kecil 2500 5 12500
Iffa Soraya 8 10/05/2008 KotakPensil 13000 10 130000
Iffa Soraya 8 10/05/2008 Spidol Board Marker 4500 5 22500
Swallow Merah
Iffa Soraya 8 10/05/2008 Cutter Kecil Kenko 10000 10 100000
Habadal Arif 9 10/05/2008 Stapler 10250 10 102500
Habadal Arif 9 10/05/2008 Cutter Besar Kenko 15000 19 285000

Catatan:
Total= Harga*Jumlah

3. Buatlah Query, simpan dengan nama Query Barang Terjual, dengan


hasil query sebagai berikut:

69
Perangkat Lunak Basis Data

Query Barang Terjual


NamaBrg NomerOrder TanggalOrder Jumlah
Staples,250 1 07/05/2008 3
Bolpoint Weiyada Hitam 1 07/05/2008 3
Bolpoint Weiyada Merah 1 07/05/2008 3
Spidol Board Marker Swallow Hitam 2 07/05/2008 2
Bolpoint Weiyada Biru 2 07/05/2008 15
Notes Kecil 2 07/05/2008 2
Spidol Board Marker Swallow Hitam 3 08/05/2008 6
Correction Fluid Kenko 4 08/05/2008 2
Penggaris Besi 30 Cm 4 08/05/2008 2
Spidol Board Marker Swallow Biru 4 08/05/2008 2
Bolpoint Weiyada Hitam 5 08/05/2008 12
Correction Pen Tipex 6 09/05/2008 10
Stapler 6 09/05/2008 5
Penghapus Staedler Besar 7 09/05/2008 4
Isi Cutter Kecil 7 09/05/2008 5
KotakPensil 8 10/05/2008 10
Spidol Board Marker Swallow Merah 8 10/05/2008 5
Cutter Kecil Kenko 8 10/05/2008 10
Stapler 9 10/05/2008 10
Cutter Besar Kenko 9 10/05/2008 19

4. Buatlah sebuah Report Berdasar Query Penjualan, dengan tampilan


halaman 1,sebagai berikut

70
Perangkat Lunak Basis Data

5. Buatlah sebuah Report Berdasar Query Barang Terjual , dengan


tampilan halaman 1, sebagai berikut

Selamat Bekerja

71
Perangkat Lunak Basis Data

REFERENSI

72
Perangkat Lunak Basis Data

CURRICULUM VITAE

Nama: Drs. Mohamad Arief Setiawan, M.Kom.


Alamat : Jl. Jend. A. Yani III/22A Blitar 66131
Telp./HP : (0342) 802047 / 0816553781
Email : mohariefs@yahoo.com

73