Anda di halaman 1dari 54

Modul MapInfo

Sistem Informasi Geografis, dapat dikatakan sebagai komputerisasi dari data spasial
dan informasi deskriptif guna memudahkan dalam pengumpulan, pengolahan,
pemeliharaan dan penyajiannya serta untuk melakukan berbagai analisa. GIS bukanlah
sekedar peta, namun merupakan suatu system informasi terpadu yang menggabungkan
data atribut/tabular dengan data spasial/geografik yang ditunjang dengan berbagai
keahlian/disiplin/profesionalisme sehingga menjadikan GIS sebagai prasyarat utama bagi
perencana untuk melaksanakan perencanaan pembangunan, penetapan kebijakan/
peraturan, pengambilan keputusan, dan pemecahan masalah.

1. Membuka Progam
Pilih StarMenu  All Programs  MapInfo MapInfo Profesional 6.0
Maka akan muncul tampilan sebagai berikut.

Gambar 1 Tampilan Awal MapInfo


Setiap kali kita melakukan pembukaan aplikasi MapInfo dengan prosedur diatas kita
akan mendapatkan suatu kotak dialog yang berisi tentang pekerjaan apa yang akan
kita lakukan berikutnya dan menggunakan apa.
Terdapat pilihan-pilihan sebnagai berikut:

Gambar 2 Kotak Dialog Quick Start


Restore Previous Session  Digunakan untuk menampikan pekerjaan terakhir.
Open Last Used Workspace: Bandung.WOR  Digunakan untuk menampilkan
workspace yang dikerjakan terakhir. 1
Open a Workspace  Digunakan untuk membuka workspace yang tersimpan dalam
media pemyimpanan semisal harddisk.
Open a Table  Digunakan untuk membuka table dalam workspace baru.

Pilihlah opsi yang diinginkan atau tidak memilih satupun dengan menekan tanda
cancel. Pada Modul ini tidak melakukan pemilihan opsi jadi hanya menekan tombol
cancel. Setelah melakukan pemilihan opsi Quick Start. Maka akan muncul tampilan
sebagai workspace kosong.
2. Bagian-bagian MapInfo
a. WorkSpace, tempat dimaka kita bekerja yang merupakan Teksfile link
dari data yang kita gunakan.
b. Table, Data Spasial yang kita operasikan.
c. Mapper, tempat mengoperasikan table dalam sisi tampilan atau grafik.
d. Browser, tempat mengoperasikan table dalam sisi tabular data
e. Toolbar, tempat tool-tool yang digunakan untuk mengoperasikan MapInfo
1
Perbedaan perintah Restore Previous Session dengan Open Last Used Workspace: Bandung.WOR adalah
pada bagian penyimpanan untuk perintah pertama apapun pekerjaan terakhir yang dilakukan akan diload
kembali semisal membuka table tanpa menyimpannya dalam workspace maka hanya membuka table dalam
workspace yang baru. Ataupun ketika kita menutup MapInfo yang didalamnya tidak ada satu table pun
maka akan ditampilkan MapInfo workspace kosong.
Mapper
Toolbar

Browser

Workspace

Gambar 3 Bagian dari MapInfo


3. Membuka Table
Sebagai catatan bahwa untuk asosiasi Table bukan hanya untuk referensi pada data
atribut tabular (tabel) saja tapi juga mereferensi pada data spasial (gambar).
Langkah-langkah membuka Table adalah sebagai berikut:
a. Pilih Menu File Open Table atau

b. Tekan Tombol Open


Maka akan muncul kotak dialog Open Table. Cari file .tab yang kita perlukan
dalam modul ini akan diload/tampilkan data kecamatan.tab, Desa.tab, Kota.tab

Gambar 4 Kotak Dialog Open Table


Setelah menemukan File yang diinginkan tekan tombol “Open”. Untuk
menambahkan table ulangi langkah-langkah di atas.
Maka akan muncul Tampilan Sebagai berikut:

Gambar 5 Tampilan Mapper


4. Mengatur Tampilan Mappper
a. Membuka Mapper Baru
Caranya : pilih Menu Window  New Map Window, kemudian akan muncul
Kotak dialog New Map Window.

Gambar 6 kotak dialog New Map Window


Kemudian menggunakan Combo box pilih dan urutkan Table-table yang akan
ditampilkan. Kemudian tekan OK.
b. Menghilangkan Dan Menampilkan Toolbar
Dalam Tampilan Mapper kita akan diberikan beberapa toolbar untuk
memudahkan dalam mengoperasikan MapInfo, namun terkadang toolbar tersebut
menggangu pandangan, maka dita bisa menghilangkan toolbar dengan cara
mengklik tombol silang dalam setiap toolbar

Gambar 7 Toolbar Drawing

Atau dengan langkah pilih Menu option  Toolbar

Gambar 8 Tampilan Menu Option toolbar


Maka akan muncul tampilan berikut:

Gambar 9 Kotak Dialog Toolbar Option


Jika untuk menghilangkan Toolbar Hilangkan Centang yang ada dalam satah satu
toolbar yang ada. Untuk memunculkan kembali dengan memberi Centang pada
toolbar yang diinginkan.
c. Mengatur Satuan Ukuran
Dalam Mapper kita juga harus dapat menentukan satuan –satuan ukuran untuk
Jarak dan Koordinat. Langkahnya dalah sebagai berikut:
Penentuan penggunaan satuan mengacu pada saat melakukan digitasi dan
registrasi proyeksi(akan dibahas kemudian).
Pilih Menu Map  Option
Maka akan muncul kotak dialog Map Option

Gambar 10 kotak Dialog Map Option


Dalam contoh ketika melakukan digitasi dan registrasi menggunakan satuan peta
adalah derajad maka dipilih untuk bagian Coordinat Units adalah Degree dan
satuan jarak yang dipakai adalah kilometer. Maka untuk Distance Units adalah
meters dan untuk Area Units dapat diberikan Acre atau Hectares. 2
Setelah itu dapat tekan tombol ok dan perubahan dapat dilihat pada bagian Zoom
pada pojok kiri bawah.

2
Untuk penentuan satuan Distance Units dan Area Units dapat dipertimbangkan dari luas area yang
dipakai, dalam modul hanya menggunakan meters dan acre karena area yang digunakan relatif kecil.
Lihat Perubahannya

Gambar 11 Perubahan satuan ukuran peta


d. Memperbesar dan mengecilkan Tampilan (Zooming)
Untuk melakukan Zoom(perbesaran atau pengecilan tampilan) ada 3 cara yaitu:
- Mengklik

Langkahnya : pilih Tool Zoom pada toolbar Main kemudian


posisikan kursor pada titik tengah bagian yang akan dilakukan Zoom
kemudian klik dan lepas pada bagian tersebut.
- Scroll
Langkah melakukan zoom dengan scroll hanya dengan memutar scroll mouse.
- Drag and Drop
Langkahnya : pilih Tool Zoom pada toolbar Main kemudian posisikan kursor
pada bagian terluar dari peta yang akan di Zoom kemudian di klik dan di
Tekan (jangan dilepas) kemudian geser(drag) sampai menentukan area yang
diinginkan, kemudian lepas.
Gambar 12 Melakukan Zoom dengan metode Drag and Drop

- Tool Change View


Informasi tampilan ini berkaitan dengan perbesaran Tampilan (Zoom), Skala
dan titik pusat peta. Dan informasi ini dapat diubah untuk mendapatkan
besaran Tampilan yang diinginkan.

Gambar 13 Kotak Dialog Change View


e. Menggeser Tampilan (Grapping)
Grapping hampir sama dengan Zoom metode drag and drop. Gunakan tool grap

dan lakukan drag and drop.

f. Melihat Informasi Atribut (Info Tool)


Melihat informasi yang terkandung dalam peta dapat menggunakan Info Tool

, caranya dengan mengklik daerah yang diininkan maka akan muncul kotak
informasi dari beberapa layer yang di pilih.

Gambar 14 kota Info Tool


5. Mengatur Layer
a. Mengatur Tata urutan Layer
Tata urutan layer sangat berpengaruh pada tampilan dalam Mapper, jika terjadi
kesalahan pada pengurutan layer maka kemungkinan besar layer-layer tersebut
tidak akan muncul semua, karena tertutup oleh layer yang lain. Tata urutan layer
adalah Urutan teratas adalah untuk layer-layer yang berbentuk/bertipe
Point/titik/Simbol, Urutan selanjutnya adalah untuk layer-layer berbentuk
Line/Garis , Urutan terbawah adalah untuk layer Region/Area.
Langkah-langkah mengatur urutan layer adalah sebagai berikut:

Pilih menu map  Layer Control atau pada toolbar pilih , kemudain akan
muncul kotak dialog Layer Control, pilih layer dan tekan tombol Up/Down.
Kemudian tekan Ok untuk mengakhir

Gambar 15 Kotak Dialog layer Control sebelum dan setelah pengaturan


Untuk menghapus Layer dalam Mapper dapat mengunakan Tombol Remove pada
Layer Control, sedangkan untuk menambah Layer dalam Mapper dengan
menggunakan tombol Add3.
b. Mengatur Tampilan Layer
Langkahnya adalah: Pilih menu MapLayer Control pilih layer yang akan
diatur, kemudan tekan tombol Display…., Maka akan muncul kotak dialog
“Layer” Display Options

Gambar 16 “Kota” Display Options


- Mengatur bentuk dan warna Layer
Centang opsi Style Override kemudian tekan tombol dibawahnya, maka akan
muncul Option Style yang sesuai dengan tipe layer. Contoh menggunakan
Kota yang bertipe Simbol/titik. Ubah sesuai kebutuhan, kemudian tekan ok

Gambar 17 Line Style

3
Penambahan Layer jika layer yang dimaksud ada dalam workspace, jika belum gunakan Langkah Open
Tabel.
- Mengatur Zoom Layer
Digunakan untuk membatasi pemunculan layer pada ukuran tertentu.
Min Zoom untuk membatasi pemunculan layer pada ukuran skala kecil.
Max Zoom untuk membatasi pemunculan layer pada ukuran skala besar.
Pada gambar 14, diisikan pada Min Zoom nilai 4000 dan pada Max Zoom
berisi 50000. artinya ketika Mapper memiliki skala diantara 4000-50000 maka
layer Kota akan ditampilkan didalam Mapper. Sedangkan jika Mapper berada
pada skala kurang dari 4000 atau lebih dari 50000 maka layer Kota akan
dihilangkan dari Mapper.
- Pengaturan lain
Pengaturan lain digunakan untuk penjelasan tentang alur layer seperti ketika
pembuatan layer tersebut.
Show Line Directions  untuk memperlihatkan alur garis
Show Node untuk memperlihatkan titik pembentukan suatu Feature/Objects
Shw Centoids  untuk memperlihatkan titik tengah Feature/Object
c. Pengaturan Label
Pilih menu MapLayer Control pilih layer yang akan diatur, kemudan tekan
tombol Label…., maka akan muncul kotak dialog “Layer” Label Options

Gambar 18 “Kota” Label Options


- Label With
Digunakan untuk dasar dari pemberian label. Pemberian label dapat berasal
dari 1 kolom pada tabel atribut(dijelaskan kemudian) dalam contoh terdapat
beberapa kolom seperti dalam gambar 17. kita dapat pilih salah satu misal
“nama_kota”. Kemudian tekan OK untuk mengakhiri.

Gambar 19 Isi dari Label with


Kita juga dapat memberikan label dari kombinasi beberapa kolom. Caranya
pilih pada bagian label with  Expression.. akan muncul kotak dialog
Expression. Ketikkan Sintaks berikut :
4
Nama_kota+Chr$(13)+Jenis_kota

Gambar 20 Kotak dialog Expression


Setelah selesai mengisikan sintak kemudian tekan Verify untuk memastikan
bahwa sintak yang diisikan benar. Jika salah ulangi pengetikan sintak dan jika
sudah benar tekan OK, Kemudian OK dan OK. Maka akan muncul label sebagai
berikut:

4
Sintak ini tergantung pada nama kolom yang ada dalam layer.
Gambar 21 layer Berlabel

- Visibiliy
Seperti halnya pembatasan Zoom pada layer, label pun memiliki pembatasan
zoom untuk ditampilkan dalam Mapper.
- Style
Untuk mengatur bentuk font label
- Position
Menentukan peletakkan label yang diinginkan

6. Digitasi dan Registrasi


Digitasi atau penggambaran adalah kegiatan transformasi membuat Peta dengan SIG
MapInfo. Ada beberapa cara yang dapat dilakukan untuk digitasi yaitu dengan GPS,
Data Tabular dan dengan Raster Image. Dalam Modul ini hanya dijelakan 1 cara
digitasi saja.
Dengan Raster Image
Langkahnya adalah
- Pilih Peta Raster yang akan digunakan sebagai dasar digitasi.5
- Kemudian pada MapInfo pilih menu File  Open Table
Pada bagian File Of Tipe pilih tipe Raster Image¸ kemudian tekan Open

5
Syarat Peta dapat digunakan sebagai dasar digitasi adalah memiliki koordinat dan skala yang jelas
Gambar 22 Open Table Raster Image
- Akan muncul kotak dialog Register sebagai berikut:

Gambar 23 Register
Jika gambar Raster tersebut sudah dilakukan registrasi maka tekan tombol
Display, jika belum maka lakukan Registrasi dengan tekan Register, maka akan
muncul kotak dialaog Image Registration.

Salah Satu koordinat


titik acuan

Gambar 24 kotak dialaog Image Registration.


Langkah-langkah registrasi
• Pastikan telah mendokumentasikan titik koordinat acuan yang akan
digunakan sebagai acuan registrasi peta. Dalam contoh digunakan titik
koordinat utama yang ada dalam peta raster.6
Tabel 1. Daftar titik Koordinat acuan
Nama X(DMS) Y (DMS)
Pt1 1100 21’00” BT (70 46’00”)LS
Pt2 1100 24’00”BT (70 46’00”) LS
Pt3 1100 21’00”BT (70 50’00”) LS
Pt4 1100 24’00”BT (70 50’00”) LS

• Posisikan Kursor pada titik acuan pertama dalam modul ini adalah
koordinat titik Pt1(1100 21’00” : 70 46’00”), masukan kedalam kotak
dialog Edit Control Point

Gambar 25 kotak dialog Edit Control Point


• Namun karena koordinat yang digunakan adalah masih dalam koodinat
DMS(Degree Minute Second) maka perlu dikonfersi menjadi DD (decimal
Degree) dengan cara sebagain berikut:
Setiap DMS memiliki 3 kombinasi D M S, seperti contoh Pt1 X(1100
21’00”) dan Pt1 Y(70 50’00”) LS
Pt1 X : D=110, M=21, S=00 BT Pt1 Y : D=7, M=46, S=00 LS

6
Titik acuan juga dapat dibuat sebelumnya berdasarkan pengetahuan koordinat yang ada.
Rumus =(D/1+ M/60 + S/3600)
DD Pt1 X = 110/1 + 21/60 +0/3600 DD Pt1 Y = 7/1 + 46/60 +0/3600
=110 + 0.35 +0 =7 + 0.766667 +0
=110.35 =7. 766667 LS
= -7. 766667

Karena digaris Bujur Timur nama nilai X tetap positif, karena berada di
lintang selatan maka nilai Y adalah negatif.7
• Setelah memasukan nilai titik acuan kemudian tekan OK. Dan ulangi
kegiatan diatas sampai semua titik acuan terpenuhi, minimal pemasukan
titik koordinat acuan 4 titik.
• Jika semua telah selesai dimasukkan perhatikan ulang pada bagian Error
(Pixels) pastikan bahwa nilai nya 0 atau dibawah 0,004. Jika belum benar
maka terjadi kesalahan registrasi dan ulangi kegiatan di atas atau lakukan
pengeditan nilai dengan memilih titik yang dianggap salah kemudian
tekan tombol Edit

Gambar 26 Cek Error


• Jika dirasa telah mendapatkan koordinat yang benar kemudian tekan OK,
maka kita akan mendapatkan tampilan sebagai berikut:

7
Ingat nilai derajat positif pada garis Bujur Timur dan Lintang Utara dan nilai negatif pada Bujur Barat dan
Lintang Selatan
Gambar 27 Mapper dengan Peta dasar Terregistrasi

7. Membuat Layer-Layer Baru


a. Membuat Layer Region/Area
Menu File New table akan uncul kota dialog sebagai berikut:

Gambar 28 New Table


Pilih Bagian Add to Current Mapper, kemudian tekan Creater, muncul Kotak
dialog New Table Structure
Gambar 29 New Table Structure
Tekan tombol add Field kemudian Ubah Name Field dan tipe data serta width,
seperti pada contoh gambar 28. kemudian tekan create.

Gambar 30 Create New Table


Letakkan dalam direktori kerja, beri nama table dan tekan Save. Maka kita dapat
melakukan Penggambaran dengan peta dasar tersebut.
Menggambar Object Region
Setelah membuat Table saatnya untuk menggambar object8. Perhatikan pada
Layer Control apakah Layer yang akan kita gambarkan object telah dalam status
Editing yaitu pada bagian editing telah tercentang, jika belum, centang pada
bagian editing. Kemudian tekan OK.

8
Hal yang perlu diperhatikan dalam menggambar object dalam Layer adalah tipe dari object. Setiap Layer
sebaiknya hanya memiliki 1 tipe object misal untuk layer Desa bertipe Region atau area. Kota bertipe titik,
dan sebagainya.
Editing Select
Visible
Label

Gamabar 31 Layer Control Untuk Mengaktifkan Status Editing


Kembali ke Mapper, pada toolbar Drawing gunakan tool polygon untuk membuat
object desa.

Polygon Tool

Membuat Point
Membuat Garis Membuat Poligon Membuat Teks
Gambar 32 Tool Pembentuk Object

Kemudian dengan berdasar pada peta raster yang telah ada, buat masing-masing
object desa yang ada berdasarkan batas wilayah desa.

Poligon tool

Gambar 33 Pembentukkan Object Desa


Mengedit Bentuk Object
Jika dirasa object yang kita buat belum tepat, object dapat diubah dengan
menggunakan Edit Verteks dengan cara:

Pilih object yang akan diubah bentuknya dengan tool select , kemudian

gunakan tool edit Verteks untuk mengubah titik pembentuk object tersebut.

Salah satu titik


pembentuk object

Gambar 34 Titik Pembentuk Object


- Menambah Titik Pembentuk Object
Jika dirasa object yang kita buat kekurangan titik pembentuk object dapat
ditambahan setelah menggunakan Edit Verteks kemudian pilih tool Add Node
dan lakukan penambahan dengan cara:

Pilih object yang akan diubah bentuknya dengan tool select , kemudian

gunakan tool edit Verteks untuk mengubah titik pembentuk object

tersebut. tool Add Node kemudian tambahkan Node/titik yang


diinginkan dengan cara men-double click pada daerah yang ingin
ditambahkan node.

2 node yang
ditambahkan

Gambar 35 Penambahan Pembentuk Object


Penambahan Object dengan Snap9
Caranya: Pilih Tool Polygon, Kemudian Aktifkan Snap dengan menekan tombo S
pada keybord maka Snap akan aktif dengan tanda tertulis SNAP. Kemudian
dengan tool polygon lakukan pembuatan object dari titik pembentukan object
pertama dengan object yang akan dibentuk10. Lakukan pembuatan object sampai
semua object dalam peta selesai.

Gambar 36 Pembentukan Object dengan bantuan SNAP


PolygonTo
b. Membuat Layer Garis ol
Caranya: Menu File New table akan muncul kota dialog
Verteksseperti pada gambar
Edit
27. kemudian Pilih Bagian Add Object
to Current Mapper, kemudian tekan Creater,
dengan
muncul Kotak dialog New Table SNAP
Structure. TekanTitik
tombol add Field kemudian
pembentuk
Ubah Name Field dan tipe data serta width,kedua
seperti pada contoh gambar 36
object
kemudian tekan create.

9
Jika tanpa bantuan SNAP kemungkinan besar kita mendapatkan object yang tidak akurat akan terjadi gap
atau tumpang tindih object.
10
Langkah Snapping lihat hal Melakukan Snap
Gambar 37 New Table Structure
Kemudian akan muncul kotak dialog Create New Table seperti pada gambar 29,
Letakkan dalam direktori kerja, beri nama table dan tekan Save. Maka kita dapat
melakukan Penggambaran dengan peta dasar tersebut.
Menggambar Object Line
Perlakuan sama seperti kita ingin menggambar object Region, yaitu pastikan layer
dalam status Editing, yang terlihat dalam Layer Control.
Kembali ke Mapper, karena kita sekarang memiliki lebih dari 1 layer maka
pastikan juga ketika kita ingin menggambar pada layer yang tepat misalnya ketika
kita akan menggambar/mengedit Layer Jalan, maka yang aktif harus layer Jalan,
dan seterusnya.

Gambar 38 Memilih Layer yang akan diedit


Setelah pasti layer mana yang kita pilih, pada toolbar Drawing gunakan tool

Polyline untuk membuat object Jalan. Lakukan pembuatan Object seperti


ketika membuat object Region pada Desa, Pilih salah satu jalan dan klik bagian
ujung jalan kemudian untuk geser sampai ujung jalan lainnya dan double klik
untuk mengakhiri. Untuk membuat tambahan object gunakan metode SNAP jika
ada jalan yang saling berhubungan. Lakukan sampai semua jalan terbentuk.

3 node jalan yang


berhubungan

Gambar 39 Pembuatan Object garis Pada Layer Jalan


c. Membuat Layer Titik
Caranya: Menu File New table akan muncul kota dialog seperti pada gambar
27. kemudian Pilih Bagian Add to Current Mapper, kemudian tekan Creater,
muncul Kotak dialog New Table Structure.

Gambar 40 New Table Structure


Tekan tombol add Field kemudian Ubah Name Field dan tipe data serta width,
seperti pada contoh gambar 40 kemudian tekan create. Kemudian akan muncul
kotak dialog Create New Table seperti pada gambar 29, Letakkan dalam direktori
kerja, beri nama table dan tekan Save. Maka kita dapat melakukan Penggambaran
dengan peta dasar tersebut.
Menggambar Object Titik
Perlakuan sama seperti kita ingin menggambar object Region dan Line, yaitu
pastikan layer dalam status Editing, yang terlihat dalam Layer Control.
Kembali ke Mapper, karena kita sekarang memiliki lebih dari 1 layer maka
pastikan layer yang dipakai adalah layer Kota

Gambar 41 Memilih Layer yang akan diedit


Setelah pasti layer mana yang kita pilih, pada toolbar Drawing gunakan tool

Polyline untuk membuat object Kota. Kemudian posisikan kursor pada titik
dimana kota tersebut berada.

Beberapa object titik


yg terbentuk

Gambar 42 Penempatan Object Titik


8. Merubah Warna, Style, Ukuran Object
Merubah Warna, Style dan Ukuran Object dapat dilakukan dengan beberapa cara,
antara lain sebagai berikut:
- Pilih Menu Map Layer Control  Pilih Layer Yang akan
dirubah Tekan Display
Centang Style Override  tekan Tombol dibawahnya.
Akan Muncul Style Options Ubahlah sesuai kebutuhan, Kemudian Tekan OK,
OK OK.

(a)

(b) (c)
Gambar 43 Kotak dialog Style Options Line(a), Region(b), Symbol/titik (c)
- Pilih Salah satu object yang ingi dirubah, kemudian pilih Menu
Options “Layer”11 Style, maka akan muncul salah satu seperti pada gambar 43.
9. Berkerja dengan Tabel /browser
11
Layer disini dimaksudkan adalah tipe dari layer tersebut misal Desa tipe Layer Region, maka pilih
Region Style.
a. Mengatur Struktur Table
 Membuat Table
Caranya : Menu File New Table maka akan muncul seperti gambar 27.
pilihan yang diberikan dimaksudkan untuk:
- Open New Browser  untuk membuka Table dengan browser
untuk data tabular.
- Open New Mapper  untuk membuka Table dengan Mapper
baru untuk mengolah data Spasial gambar.
- Add to Current Mapper untuk menambahkan table dalam map
yang telah ada.
Untuk Kali ini gunakan Opsi Open New Browser. Kemudian tekan Create,
Maka Akan muncul tampilan kotak dialog New Table Structure seperti pada
gambar 28. Buatlah struktur table sesuai kebutuhan12. Jika telah selesai
membuat struktur table tekan tombol create.

Gamabar 44 NewTable Structure


 Membuka Table dengan Browser baru
Langkahnya : Pilih Menu Window  New Browser Windows ..

12
Pelajari pembuatan table dalam membuat Table Database, yang pasti buatlah struktur table yang
memiliki field unik dalam membedakan setiap object/record yang ada.
Gambar 45 Browser Window
Kemudian pilih salah satu Table yang diinginkan, kemudian tekan OK. Maka
akan muncul Browser Window Table tersebut.

Gambar 46 Browser Window Jalan

 Menghapus Table13
Pilih Menu Table  Maintenance  Delete Table, Kemudian pilih Table
yang ingin dihapus pada kotak dialog Delete Table.

Gambar 47 Kotak Dialog Delete Table

13
Table akan dihapus secara permanen dalam media penyimpanannya, jadi tidak bisa digunakan lagi.
Kemudian tekan tombol Delete, maka akan muncul tampilan pada gambar ,
jika yakun akan menghapus table tersebut maka tekan OK, jika tidak tekan
Cancel.

Gambar 48 Verifikasi Penghapusan Table


 Mengepak Table
Mengepak Table dilakukan ketika table tersebut telah mengalami
penghapusan Row/baris data table sehingga terjadi gap baris. Cara
menghilangkan gap tersebut adalah :

Gap Baris
Data

Gambar 49 Browser Table Kota hasil penghapusan Row/baris belum di pack

Pilih Menu Table  Maintenance Pack Table


Gambar 50 Pack Table
Kemudian pilih table yang akan dipack kemudian pilih opsi penge-Pack-kan
ddan Tekan OK. Jika dalam penge-pack-kan Table masih belum disimpan
maka akan ada perintah penyimpanan dan sebaiknya disimpan kemudian
tekan OK, Maka Table akan hilang dari Mapper dan Browser. Untuk
menampilkan kembali dalam Mapper gunakan Layer Control  Add. Dan
untuk melihat Browser gunakan Menu Window  New Browser Window.
Maka tampilan pada Browser Sebagai berikut:

Gambar 51 Browser Table Kota hasil peng–Pack-kan

 Merubah Nama Table


Caranya: Pilih Menu Table  Maintenance  Rename Table.
Kemudian muncul kotak dialog Rename Table untuk memilih table yang akan
di Rename, pilih salah satu table kemudian tekan Rename. Maka akan muncul
kotak dialog Rename Table untuk menyimpan baru table tersebut, ubah nama
table dan tekan Save untuk mengakhiri.
b. Membuat/Menambah/Menghapus Field
- Membuat Field
Caranya : pilih Menu Table  Maintenance  Table Structure, maka akan
muncul seperti kotak dialog Table Structure. Muncul kotak dialog
View/Modified Table Structure.
Gambar 52 View/Modify Table Structure

Yang perlu diperhatikan dalam mengisi kotak dialog New Table Structure
adalah Pemberian Nama Field dilarang menggunakan karakter spesial seperti
*&^%[spasi] dll.
- Menambah Field
Untuk menambah Field tekan tombol Add Field dan isi nama field dan tipe
datanya.
- Menghapus Field
Untuk menghapus field gunakan tombol Remove Field pada field yang akan
dihapus.
c. Mengisi Field
 Menambah Row
Untuk menambah Row baru dalam tabel caranya : pilih menu Edit New
Row. Atau dengan menekan secara bersamaan Ctrl + E

Gambar 53 Menambahkan Row dalam Table.


 Manual
Untuk mengisi field secara manual, pilih Browser window dan klik pada
bagian Row/ baris yang ingin diisikan.
 Otomatis dengan Update Column
Misalkan kita ingin mengisikan jenis kelamin dari pelanggan kita adalah
Wanita semua maka kita dapat mengisi secara otomatis semua field yang ada
dengan cara: pilih menu Table  Update Column Maka akan muncul kotak
dialog Update Column, Kemudian isi seperti gambar 54, kemudian tekan OK.

Gambar 54 Gambar Update Column untuk mengisi Jenis kelamin dengan F


d. Memilih Data
 Manual dengan kursor
Memilih data atau select secara manual dapat dilakukan dengan 2 cara yaitu
pada mapper dan pada browser dengan perlakuan yang sama yaitu pilih kursor

select kemudian pilih object yang diinginkan.


 Dengan Select
Penggunaan Select ini dimaksudkan untuk mempermudah dalam mencari data
berdasarkan kondisi tertentu. Misal dalam Browser Kota ingin mencari data
yang jenisnya “kecamatan”. Maka dapat dilakukan dengan cara Pilih Menu
Query Select Maka akan muncul kotakl dialog Select
Gambar 55 Kotak dialog Select
Pilih table yang akan diselect (table Kota), kemudian tekan tombol Assist,
maka akan muncul kotak dialog Expression.

Gambar 56 Kotak dialog Expression


Gunakan Combobox Colums untuk mencari field table Kota, gunakan
Operators untuk mencari operator “=” dan ketikkan dengan tanda petik dua
(“”) nilai yang diinginkan yaitu “Kecamatan”. Lakukan verifikasi sistak
dengaan menekan tombol Verify, jika salah ulangi penulisan sintak dan jika
benar takan tombol OK. Maka Akan kembali ke kotak dialog sebelumnya dan
tekan OK untuk mengakhiri. Maka tampilannya sebagai berikut.

Gambar 57 Browser Hasil Penyeleksian


 Dengan SQL Select
Penggunaan SQL Select hampir sama dengan Select hanya lebih terperinci.
Jika kita ingin melakukan pen-seleksian seperti contoh diatas dengan
mengubah sedikit, misal yang akan kita seleksi adalah jenis=”Desa”, maka
langkahnya sebagai berikut. Pilih menu QuerySQL Select maka akan
muncul kotak dialog SQL select pada gambar 57.
Gambar 58 kotak dialog SQL Select
Pilik Table yang digunakan (Table Kota) dari combobox Tables, untuk where
kondisi diisikan sama seperti pada select  pilih colums Jenis, kemudian
pilih Operator ==, kemudian ketika nilai yaitu “Desa”, Kemudian Tekan
OK.

Gambar 59 Browser Hasil Penyeleksian dengan SQL Select


10. Membuat Legenda
Caranya : Menu Map  Create Legend, akan muncul kotak dialog Create Legenda,
Pilih Table apa yang akan dimasukkan dalam Lagenda dalam modul ini semua Layer
(step 1). Kemudian tekan Next, dan isikan nama legenda sampai subtitle legenda
Sesuai dengan kebutuhan (step 2), kemudian next dalam step ini diminta untuk
memberikan title untuk setiap layer dan berdasarkan apa pembagaian dari setiap
layer. Dalam contoh untuk layer desa berdasar pada ID_Kecamatan, maka pada Style
From gunakan opsi kedua yaitu unique values in column. Dan isikan field ID_Camat.
Kemudian untuk label style with gunakan Field ID_Camat. Kemudian tekan Save
Frame settings to Metadata. Lakukan kegiatan di atas untuk 2 table yang lain yaitu
Kota dan jalan (step 3).
Untuk kota field yang dipakai adalah jenis_kota, dan untuk jalan field yang dipakai
adalah field =jenisJLN. Jika telah selesai tekan Finish.

Gambar 60 Kotak dialog Create Legenda Step 1 dan Step 2

Gambar 61 Kotak dialog Create Legenda Step 3


Gambar 62 Legenda

11. Membuat Peta Tematik


Peta tematik digunakan untuk memberikan Informasi sesuai dengan kebutuhan dari
analisis atau dalam pembacaan peta.
Langkahnya:
Pilih menu Map  Create Thematic Map maka akan muncul tampilan kotak dialog
Create Thematic Map Kemudian pilih Templete yang sesuai dengan tipe yang
dipakai. Tipe-tipe tersebut antara lain:
a. Ranges  Untuk memberikan pengelompokan
Object berdasarkan Range atau jangkauan suatu nilai dalam field menggunakan
warna/gradasi/ pola.
b. Bar Chart Untuk memberikan penampilan peta
berdasarkan beberapa data dari beberapa field ditampilkan menggunakan bentuk
Grafik batang.
c. Pie Chart  Untuk memberikan penampilan peta
berdasarkan beberapa data dari beberapa field ditampilkan menggunakan bentuk
Grafik Pie.
d. Graduated Membuat pengelompokkan Object
berdasarkan nilai gradasi dalam field, menggunakan simbol.
e. Dot Density  Membuat pengelompokkan Object
berdasarkan nilai dalam field, menggunakan pola persebaran titik. Biasanya untuk
melihat kepadatan populasi.
f. Individual  Membuat pengelompokkan Object
berdasarkan nilai Unik dalam field, menggunakan warna.
g. Grid  Membuat peta thematik yang memberntuk
suatu area raster yang dibentuk menggunakan interpolasi data Point/Simbol.
Menghasilkan gradasi warna setiap titiknya.
Contoh : Menu Map  Create Thematics Map Pilih tipe Ranges  pilih
Templete Region Ranges, Solid Red-Yellow-Grenn, Light, Kemudian Tekan Next.

Pilih Table yang akan dibuat Tematiknya, misal desa karena berbentuk region.
Kemudian pilih field yang digunakan misal Jml_penduduk Next, kemudian
Ada tiga pilihan untuk mengedit tampilan Tematikua diantaranya Range untuk
mengubah Jangkauan, kemudian Style untuk warna dan bentuknya, dan Legenda.
Sebagai contoh kita ubah range menjadi 10. caranaya klik tombol Ranges

Kemudian akan masuk ke kotak dialog Costumize Ranges pilih pada bagian # of
Ranges =10. kemudian lakukan Recalc , kemudian tekan OK.
Maka akan peta thematik seperti berikut.

12. Geocode
Geocode adalah melakukan referensi Layer berdasarkan berdasarkan layer yang telah
ada karena memiliki kecocokan data dalam tabel /data tabularnya.
a. Geocoding dengan Alamat
Melakukan geokode dengan melihat kecocokan dari alamat yang ada dalam tabel.
b. Geocoding dengan Boundery
Melakukan geokode dengan melihat kecocokan boundery name pada table dengan
boundery name pada search tabel. Dan MapInfo akan menentukan koordinat
Boundary centroid X dan Centroid Y pada record data.
c. Geocoding dengan menggunakan ZipInfo
Dmengguankan base ZipInfo paket yang berisi tentak Zipcode di setiap negara
bagian Amerika Serikat, jadi ini digunakan untuk pengguna Amerika.
Prosedur Umum Geocoding
Buat Table Referensi yang memiliki koordinat X dan Y. Kemudian pastikan Table
tersebut telah diindexkan. Untuk menggunakannya pilih table yang akan di-geocode-
kan dan lakukan prosedur Geocode
Contoh:
a. Menentukan Table Referensi, Misal Table Jalan
b. Memastikan table referensi telah di-index-kan
Pilih menu Table  Maintenance  Table Structure , kemudian pilih tabel
Jalan. Kemudian tekan OK, dan muncul kotak dialog Table Structure,
kemudian centang pada bagian index untuk field yang digunakan untuk
referensi, seperti pada gambar dibawah ini. Kemudan tekan OK
c. Melakukan Geocode
Pilih menu Table  Geocode
Pilih Table yang ingin di-geocode-kan misal pelanggan, kemudian pilih field
yang memiliki kecocokan nilai pada table referensi yaitu alamat,

kemudian pilih Table referensi yang akan yaitu table Jalan dan kemudian pilih
Field referensi yaitu NamaJLN kemudian tekan OK

Maka Akan muncul kotak dialog informasi menunjukkan berapa Field yang
berhasil di-geocode-kan dan yang tidak. Kemudian tekan OK.
Akan muncul kotak dialog Informasi Berapa field yang berhasil dan yang tidak
sepeti pada gambar berikut:
Jika terdapat field yang belum ter-geocode-kan maka ulangi langkah geocode
diatas. Dan pastikan bahwa nilai field sama dengan table referensi. Dan jika tidak
ingin ada field yang kurang tepat tapi ingin di-geocode-kan maka pada bagian
mode pilih intreraktif maka akan muncul tampilan seperti pada gambar berikut.

Mode
Interaktif
Kemudian cari nama jalan yang sesuia dengan jalan yang diinginkan, misal
seperti pada gambar diatas. Kemudian tekan OK. Maka akan muncul seperti
berikut:

Untuk melihat hasilnya dalam Mapper maka Pilih Map  Layer Control  Add,
kemudian pilih table pelanggan. Tekan OK, dan OK.
Hasil Geocode

13. Analisis Sederhana


a. Membuat Buffer
Buffer digunakan untuk menentukan jangukauan dari suatu/beberapa object.
Langkah:
14
Pastikan Layer yang digunakan dalam status editing , kemudian pilih 1 atau
beberapa object yang akan diberi buffer dalam contoh Layer yang digunakan
adalah Pelanggan dan menggunakan 2 Object.

14
Lihat Bagian Lalu Mengedit Object
Kemudian pilih menu Object Buffer. Maka akan muncul kotak dialog dan
masukkan dalam Value nilai yang diinginkan misal 1 dan units yang dipakai
satuannya Kilometers. Untuk Smoothness lebih besar lebih baik misal 100, pilih
One Buffer to All Object, kemudian tekan OK, seperti pada gambar berikut.
Maka akan muncul pada mapper seperti gambar dibawah ini,

b. Geoprosessing Sederhana
Dalam Geoprosesing ini menggunakan beberapa tool yang telah ada di atas
sehingga untuk melihat langkah detailnya sebagai referensi lihat di atas.
1) Menggabungkan
Dalam contoh akan menggabungkan Desa menjadi satu table lagi yaitu
kecamatan, langkahnya:
- Duplikasi layer desa : pilih menu File Save Copy As,
kemudian pilih table Desa, tekan Save As. Beri nama Kecamatan dan
Save.
- Buka table Kecamatan, dan Aktifkan Status Editing dan pilih
desa-desa yang memiliki berada dalam Kecamatan yang sama, dapat
dilakukan dengan seleksi manual namu dalam contoh akan dilakukan
dengan menggunakkan metode Select.
Gunakan Metode Select15, Kemudian pada that satisfy isikan sintak
berikut : ID_CAMAT=1, kemudian tekan OK. Kemudian tutup Browser

15
Lihat bagian Memilih data
Maka akan muncul Browser Window yang terbentuk mana tutup Window
tersebut, dan masuk dalam Mapper Kemudian pilih menu Object 
Combine, maka akan muncul kotak dialog, pilih semua field yang ada
dengan menggunakan kombinasi klik dan tombol Shift. Kemudian tekan
OK,
Maka Object-object trersebut akan tergabung. Seperti pada gambar .
Lakukan penyeleksian desa-desa dengan metode select dan ubahlah
id_camat dengan nilai yang sesuai yaitu 2-14 .16 Dan lakukan Combine.
Hingga semua kecamatan terbentuk.

2) Pemotongan
Caranya:
Buat table baru dan buat object seperti berikut

16
karena pada table yang digunakan dalam modul memiliki 14 kecamatan
Kemudian seleksi semua object dalam Kecamatan, kemudian pilih menu
Object  Set Target, kemudian pilih pilih Object Pemotong, kemudian pilih
menu Object  Erase Outsite, maka akan membentuk seperti berikut

Uuntuk melihat hasilnya hapus layer pemotongnya.


c. Membuat Hotlink
Langkahnya;
Membuat field tambahan: Menu Table  Maintenance Table Structure
Pilih table Kota. Kemudian tambahkan 1 field yaitu Hotling dengan tipe data
Character dengan width 50(sesuaikan dengan URLnya).
Kemudian masuk ke Browser Windows Kota inikan URLnya seperti pada gambar
berikut :
Sesuaikan Link
yang benar

Kemudian pilih Map  Layer Control, pilih layer Kota, kemudian tekan tombol
hotlink. Pada filename Expression pilih field Hotlink, pada activate Hotlink on
pilih Label & Objects, kemudian OK, dan OK

Untuk melihat hasilnya kembali ke Mapper, dan pilih Tool Hotlink dan
arahkan pada salah satu simbol kota maka akan seperti pada gambar berikut
14. Membuat Graph/Chart
Caranya : Pilih menu Window  New Graph Window, Kemudian pilih Bentuk
Graph yang diinginkan dan jenisnya, kemudian next, kemudian plih table yang
diinginkan dalam contoh adalah desa dan masukkan field Of Graph dengan
JML_Penduduk dan Label with column adalah Nama. Kemudian OK
15. Membuat LayOut
Caranya : pilih menu Window Pilih New Map Window, kemudian masukkan table
yang ingin dibuat layer, dan kemudian buatlah peta tematiknya dan jika perlu buat
legendanya, dan tambahkan chart yang dibutuhkan. Posisikan Layer sedemikian rupa
sehingga layer sesuai keinginan, dan beri buatlah Simbol utara dengan memilih
simbol dalam Simbol Style. Kemudian pilih Scala Tool dalam menu Tool  tool
manager, kemudian cari Scalebar  centang pada bagian Loaded kemudian OK.
Pilih tool Scale, posisikan kursor dimana Skala akan ditampilkan dan klik maka akan
muncul kotak dialog maka pilih satuan yang akan digunakan untuk skalanya,
kemudian tekan OK

Maka tampilan yang akan dijadikan layout seperti gambar berikut:


Menampilkan Layout : Menu Window  New Layout, kemudian pilih Mapper yang
akan ditampil kemudian tekan OK. Mata tampilan seperti berikut
Tambahkan Frame untuk membuat Layout lebih memiliki informasi seperti
berikut
Melakukan SNAP

Setlah menekan tombol S pada keyboard arahkan not yang akan dihubungkan dengan
node lain sampai membentuk Kursor + putus-putus menandakan bahwa node-node
tersebut talah terhubung.

Node telah
terhubung

(a) (b)
Gambar Sebelum Snapping (a) dan setelah Snaping(b)