Anda di halaman 1dari 28

MENGOPERASIKAN SOFTWARE APLIKASI

BASIS DATA
SWR.OPR.303(2).A

Disusun Oleh :

EKO SUGIHARTO

SMK TEKNOLOGI INFORMASI


DADAHA INFORMATIK
TASIKMALAYA

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 0


Microsoft Office Access 2003

Pendahuluan

1. Pengertian
Microsoft Access (Ms. Access) adalah “Program aplikasi yang dititikberatkan pada
pengolahan sistem Database”. Ms. Access mampu menangani masalah yang berhubungan dengan
dengan database seperti data pegawai, data siswa, sistem inventory, dan masih banyak yang lainnya
secara cepat dan akurat, baik hanya sebagai database-nya saja maupun sebuah aplikasi siap pakai.
Database adalah “Kumpulan beberapa berkas data yang terpadu dan memiliki keterkaitan
(relationship) antara satu dengan yang lainnya”.
Ekstensi file dari database Ms. Access adalah .mdb (master database). Selain Ms. Access,
program database lain yang sering digunakan diantaranya MySQL, Ms. SQL Server, Oracle, Foxpro,
dan masih banyak yang lainnya.

2. Objek (Komponen) Ms. Access


Objek (komponen) yang terdapat pada Ms. Access adalah :
a. Table digunakan untuk menyimpan data yang diolah pada sebuah database
b. Query digunakan untuk memanipulasi data sekaligus menyimpan data
c. Form digunakan untuk memasukan dan menampilkan data yang diolah
d. Report digunakan untuk membuat hasil/laporan data untuk dicetak
e. Page digunakan untuk membuat sebuah Web Page (Halaman Web)
f. Macro digunakan untuk membuat fungsi atau perintah secara otomatis
g. Module digunakan untuk membuat kode program berbasis Visual Basic.

3. Tipe Data (Data Type) pada Ms. Access 2003


Hal penting yang harus diperhatikan dalam merancang sebuah Database adalah efisiensi dari
penggunaan memori (ruang penyimpanan). Hal ini berkaitan dengan tipe data yang seharusnya
digunakan dalam pembuatan tabel karena setiap field memiliki tipe data yang harus ditentukan. Tipe
data yang sediakan akan diuraikan dalam tabel berikut ini.

Tabel 1. Jenis Tipe Data pada Microsoft Access

Tipe Data Memori Keterangan


Text 0 – 255 karakter Karakter, yaitu kombinasi teks dan angka yang tidak diperlukan
dalam operasi perhitungan

Memo 0 – 65.536 karakter Kombinasi teks dan angka, tetapi jangkauannya lebih luas

Number 1,2,4 atau 8 byte Angka atau Numerik yang berlaku untuk operasi perhitungan

Date/Time 8 byte Format Tanggal dan Waktu

Currency 8 byte Data Keuangan atau Numerik yang digunakan pada perhitungan
matematika, meliputi data satu sampai empat desimal.

AutoNumber 4 byte Angka yang ditambahkan satu secara otomatis (berurutan) pada
Ms. Access ketika record baru dimasukkan. Data AutoNumber tidak
dapat dirubah

Yes/No 1 bit Data pernyataan yang terdiri dari dua kondisi (Yes/No),
(True/False), dan (On/Off)

OLE Object 0 – 1 gigabyte Sebuah Objek (seperti gambar, dokumen dari Ms. Word, grafik dan
(tergantung kapasitas lain-lain
HardDisk)

Hyperlink setiap bagian dapat Teks atau Objek yang bisa menghubungkan ke media lain
berisi 0 – 2.046
karakter

Lookup Wizard umumnya 4 byte Field yang dibuat untuk memilih sebuah nilai dari tabel lain atau
daftar nilai yang dibuat sendiri menggunakan list box atau combo
box

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 1


Mengenal Fasilitas pada Ms. Access 2003

1. Memulai Ms. Access 2003


Langkah pertama adalah mengaktifkan terlebih dahulu Ms. Access 2003 dengan langkah-
langkah sebagai berikut :
a. Klik Start
b. Klik Programs
c. Klik Microsoft Office
d. Klik Microsoft Office Access 2003

Kemudian akan tampil program Ms. Access dalam keadaan kosong (blank), kemudian untuk
membuat file database baru, lakukan langkah-langkah berikut ini :
a. Klik menu File
b. Klik New
c. Klik Blank Database pada kota Task Pane disisi kanan layar
d. Selanjutnya tampil kotak dialog File New Database
e. Tentukan direktori penyimpanan dan nama file database.
f. Klik tombol Create
1 : Tentukan directory
penyimpanan

2 : Ketik Nama File Database

3 : Klik Create

gbr. 1 File New Database

g. Kemudian akan tampil jendela Database (Database Window)

gbr. 2 Jendela Database

2. Tabel
a. Pengertian
Tabel adalah tempat untuk menyimpan semua data yang diolah pada suatu database.
Tabel adalah komponen yang sangat penting dalam Ms. Access; tanpa tabel, database tidak
akan berfungsi.
b. Langkah Membuat Tabel
Terdapat beberapa cara untuk membuat sebuah tabel, salah satunya adalah :
- Klik objek Tables pada jendela Database
- Klik ganda (double click) pada pilihan Create table in Design View

2 : Klik Ganda
1 : Klik

gbr. 3 Create table in Design View

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 2


- Kemudian akan tampil jendela Tabel

gbr. 4 Jendela Tabel

- Ketik Field Name, tentukan Data Type dan Field Size dan ketik pada Description bila perlu.
2 : Tentukan
Data Type

1 : Ketik Field 4 : Ketik


Name Description

3 : Tentukan
Field Size

gbr. 5 Membuat Tabel

c. Primary Key
Primary Key merupakan identifikasi yang menjadi identitas suatu data. Primary Key adalah
sebuah field yang memiliki data yang unik, yaitu data yang beda antara satu dengan yang lainnya.
(tidak boleh sama).
Primary Key berfungsi untuk mencegah proses penginputan data yang sama dan sebagai
penghubung pada fasilitas Relationship yang nanti akan dipelajari lebih lanjut.
Cara membuat Primary Key :
- Simpan kursor di sebuah field yang dianggap unik
- Kemudian klik icon Primary Key

1 : Simpan 2 : Klik icon


Kursor Primary Key

gbr. 6 Primary Key

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 3


d. Lookup Wizard
Lookup wizard adalah jenis data yang bisa mengambil/mencari dari table/query atau
membuat daftar sendiri sebagai sumber datanya.
Cara membuat Lookup Wizard dengan membuat daftar sendiri :
- Pilih Tipe Data Lookup Wizard

Pilih tipe Lookup Wizard

gbr. 7 Tipe Data Lookup Wizard

- Setelah itu tampil kotak dialog Lookup Wizard


- Pilih I will type in the values that I want, kemudian Next

1 : Pilih Option ini

2 : Klik Next

gbr. 8 I will type in the values that I want

- Ketikan nilai/daftar untuk dipilih pada Col1, kemudian Next

1 : Masukan nilai

2 : Klik Next

gbr. 9 Memasukan Nilai pada Lookup Wizard

- Klik Finish

Klik Finish

gbr. 10 Mengakhiri Proses Lookup Wizard

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 4


e. Menyimpan Tabel
Setelah membuat tabel, kemudian simpan tabel dengan cara :
- Klik File – Save
- Ketik nama tabel pada Table Name
- Klik OK

2 : Klik OK
1 : Ketik nama
tabel

gbr. 11 Memberi Nama Tabel

Setelah selesai membuat dan menyimpan tabel, klik Close pada jendela Tabel mode
Design View. Kemudian double click tabel pada jendela Database hingga muncul tampilan Tabel
mode Datasheet View.

gbr. 12 Tabel mode Datasheet View

3. Query dan Relationship (Relasi)


a. Pengertian dan Fungsi
Query adalah permintaan sekumpulan data dari suatu tabel atau query lain. Query
berfungsi memanipulasi data yang terdapat pada suatu tabel atau query lain seperti :
- Menggabungkan dua buah tabel atau lebih
- Menampilkan data-data tertentu sesuai dengan kriteria
- Mengurutkan data (Sorting)
- Menyaring data (Filtering)
- Melakukan operasi perhitungan
- Dan lain-lain.
b. Relationships
Relasi atau Relationships merupakan fasilitas yang berfungsi untuk
menghubungkan/mengaitkan antara tabel satu dengan tabel lainnya. Hasil hubungan tersebut
dapat dimanfaatkan sebagai dasar dalam pembuatan query.
Cara yang digunakan untuk membuat relationship adalah sebagai berikut :
- Klik Tools – Relationships
- Muncul kotak dialog Show Table dan jendela Relationships
- Pilih tabel yang akan dihubungkan, kemudian klik Add
- Klik Close pada Show Table jika sudah selesai memasukan tabel

2 : Klik Add
1 : Gunakan Shift
3 : Klik Close
untuk menyeleksi
lebih dari satu tabel
sekaligus

gbr. 13 Memilih Tabel untuk Relationships

- Pada jendela Relationships terlihat field Primary Key tertulis lebih tebal
- Klik tahan dan Drag field Primary Key di tabel pertama ke field yang sama di tabel kedua

Klik tahan dan Drag


sesuai dengan arah
panah

gbr. 14 Membuat Relationships

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 5


- Muncul kotak dialog Edit Relationships
- Aktifkan semua Ceklist
- Klik Create

2 : Klik Create

1 : Aktifkan semua
ceklist

gbr. 15 Edit Relationships

- Terlihat hasil relationships seperti contoh

gbr. 16 Hasil Relationships

- Tutup jendela Relationships. Jika ada pertanyaan, jawab Yes untuk menyimpan Relationships

c. Pembuatan Query
Salah satu pembuatan query yang termudah yaitu menggunakan fasilitas Design View,
yaitu dengan cara :
- Klik object Queries pada jendela Database
- Klik ganda (double click) pada pilihan Create query in Design View

2 : Klik Ganda

1 : Klik

gbr. 17 Create query in Design View

- Kemudian akan tampil kotak dialog Show Table


- Klik tabel/query lain yang akan ditambahkan pada query baru - Klik Add
- Klik Close bila tabel/query yang dibutuhkan sudah ditambahkan

2 : Klik Add
1 : Gunakan Shift
3 : Klik Close
untuk menyeleksi
lebih dari satu tabel
sekaligus

gbr. 18 Memilih tabel untuk Query

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 6


- Masukan field-field yang dibutuhkan dari tabel/query yang telah ditambahkan sebelumnya
dengan cara double click pada setiap field hingga field-field tersebut menjadi bagian query
yang sedang kita rancang

Klik ganda pada field-


field yang dibutuhkan

gbr. 19 Memasukkan field pada Query

- Setelah semuanya selesai, untuk melihat hasilnya, jalankan dengan meng-klik icon Run ( )
- Tampak contoh hasil query yang dijalankan.

gbr. 20 Hasil query saat dijalankan (Datasheet View)

d. Menyimpan Query
- Klik File – Save
- Ketik nama Query pada Query Name
- Klik OK

2 : Klik OK
1 : Ketik nama
query

gbr. 21 Memberi Nama Query

4. Form
a. Pengertian
Form adalah media untuk memasukkan data (entry data) dan menampilkan (display) data
dengan tampilan yang lebih menarik.
Sebuah data bisa diinput pada tabel/query secara langsung, tetapi disarankan agar lebih
profesional dalam memasukkan data gunakanlah fasilitas form.
b. Membuat Form
Untuk membuat form sebagai media input data, otomatis diperlukan tabel atau query
sebagai acuan tempat penyimpanan data.
Ada beberapa cara untuk membuat sebuah form, diantaranya dengan cara Wizard dan cara
manual.
1) Cara Wizard
Cara termudah untuk membuat form adalah dengan cara wizard, berikut ini langkah-
langkah pembuatannya.
- Klik objek Form pada jendela Database
- Klik ganda (double click) pada pilihan Create form by using wizard

2 : Klik Ganda

1 : Klik

gbr. 22 Create form by using wizard

- Kemudian muncul kotak dialog Form Wizard


- Pada pilihan Tables/Queries, pilih tabel/query yang akan dijadikan tempat menyimpan
data
- Klik tombol .>>. untuk memasukkan seluruh field yang dibutuhkan pada form – Klik Next

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 7


1 : Pilih tabel/query

2 : Klik Tombol ini

3 : Klik Next

gbr. 23 Memilih tabel dan memasukan field

- Pada Form Layout, misal pilih Columnar – Klik Next

1 : Pilih Jenis Layout


Form

2 : Klik Next

gbr. 24 Memilih Form Layout

- Pada Form Style, misal pilih Standard – Klik Next

1 : Pilih Jenis Style


Form

2 : Klik Next

gbr. 25 Memilih Form Style

- Pada isian Form Title, ketik nama form yang anda inginkan, kemudian Klik Finish
(secara otomatis form telah tersimpan)

Klik Finish

gbr. 26 Memberi Title pada Form

- Hingga tampil form dalam mode Form View seperti contoh berikut ini.

gbr. 27 Tampilan Form pada mode Form View

2) Cara Manual (Design View)


Sebagai seorang Programmer Profesional anda dituntut untuk membuat form dengan
cara manual. Cara ini fleksibel, sesuai dengan keinginan kita dan juga membutuhkan suatu
kreatifitas dan keuletan dari seorang programmer.

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 8


Berikut ini langkah-langkah pembuatan form cara manual :
- Klik objek Form pada jendela Database
- Klik ganda (double click) pada pilihan Create form in Design View

2 : Klik Ganda

1 : Klik

gbr. 28 Create form in Design View

- Kemudian tampil area form dengan mode design view dalam keadaan kosong (blank)
- Klik kanan di pojok kiri atas – klik Properties
1 : Klik Kanan

2 : Klik
Properties

gbr. 29 Menampilan Form Properties

- Klik tab Data


- Pada properties Record Source, ubah combo pada pilihan tabel/query yang dijadikan
tempat penyimpanan atau sumber data

1 : Klik

2: Pilih Tabel/Query

gbr. 30 Memilih Data Source Form

- Muncul Field List


- Blok semua field yang dibutuhkan pada sebuah form
- Klik dan Drag pada area form
Klik tahan dan drag
pada posisi yang
ditunjuk panah

gbr. 31 Memasukkan field list pada area Form

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 9


- Hasilnya akan terlihat seperti berikut

gbr. 32 Hasil Memasukkan Field

- Tutup terlebih dahulu jendela Form, jika ada pertanyaan jawab Yes untuk menyimpan
form.
- Ketik nama Form – Klik OK
- Untuk melihat hasilnya, double click form yang telah dibuat pada jendela Database
- Hasil tampilannya seperti berikut

gbr. 33 Hasil Tampilan Form

c. Modifikasi Form
Form yang telah anda buat sebelumnya baik dengan cara wizard atau manual, bisa anda
modifikasi agar form terlihat lebih menarik dan juga interaktif, seperti menambah teks untuk judul,
image untuk logo/gambar, command button untuk tombol perintah, dsb. Modifikasi yang dibahas
disini diutamakan pada pembuatan form dengan cara manual.
Dalam memodifikasi form, salah satu peralatan/fasilitas yang sering digunakan adalah
Toolbox. Berikut ini bagian-bagian dari Toolbox :
Select Objects
Control Wizards
Label
Texbox
Option Group
Toggle Button
Option Button
Check Box
Combo Box
List Box
Command Button
Image
Unbound Object Frame
Bound Object Frame
Page Break
Tab Control
Subform/Subreport
Line
Rectangle
More Controls
gbr. 34 Toolbox

Untuk memulai modifikasi form, pastikan anda telah mengaktifkan form yang akan
dimodifikasi, kemudian atur tampilan pada mode Design dengan mengklik ikon Design View
( ), selanjutnya ikuti langkah-langkah berikut ini :
1) Menampilkan Form Header/Footer
- Klik kanan di dalam area form
- Klik Form Header/Footer

1 : Klik kanan di
area Form

2 : Klik Form Header/Footer

gbr. 35 Menampilan Form Header/Footer

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 10


2) Menambah Label (Teks)
- Klik icon Label pada Toolbox
- Simpan kursor di area Form Header
- Ketik teks yang diinginkan
- Untuk mengatur Format Teks (jenis, ukuran, warna huruf), klik di area form kemudian klik
kembali teks/label yang telah anda ketik

1 : Klik icon Label

2 : Simpan Kursor,
kemudian ketik
Teks

gbr. 36 Menambahkan Label pada Form

3) Menambah Image (Gambar)


- Klik icon Image pada Toolbox
- Drag di area form yang dikehendaki

2 : Drag di area ini


1 : Klik icon Image

gbr. 37 Menambahkan Image pada Form

- Kemudian muncul kotak dialog Insert Picture


- Cari file gambar yang akan ditambahkan pada form – klik OK

1 : Cari dan Pilih


Gambar

2 : Klik OK

gbr. 38 Memilih Gambar

4) Menambah Command Button (Tombol Perintah)


- Klik icon Command Button pada Toolbox
- Drag di area Detail bagian bawah atau Form Footer

1 : Klik icon Command


Button

2 : Drag di area ini

gbr. 39 Menambahkan Command Button pada Form

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 11


- Muncul kotak dialog Command Button Wizard
- Pilih jenis Categories dan Actions – Klik Next

1 : Pilih Categories

2 : Pilih Actions

3 : Klik Next

gbr. 40 Memilih Categories dan Actions

- Ketik untuk caption tombol pada pilihan Teks – Klik Next

1 : Ketik Caption
Command Button

2 : Klik Next

gbr. 41 Memberi Caption untuk Command Button

- Ketikkan nama untuk Command Button yang anda buat


- Klik Finish

1 : Ketik Nama untuk


Command Button

2 : Klik Finish

gbr. 42 Memberi Nama Command Button

- Terlihat hasil seperti contoh berikut

gbr. 43 Hasil pembuatan Command Button

Dibawah ini terdapat daftar Categories dan Actions yang bisa tersedia pada Command Button
Wizards.
Tabel 2. Daftar Categories dan Actions pada Command Button Wizard

Categories Actions Keterangan


Find Next Mencari record selanjutnya
Find Record Mencari record
Go To First Record Menuju ke record pertama
Record Navigation
Go To Last Record Menuju ke record terakhir
Go To Next Record Menuju ke record selanjutnya
Go To Previous Record Menuju ke record sebelumnya
Add New Record Menambah record baru
Delete Record Menghapus record
Duplicate Record Menduplikat record
Record Operations
Print Record Mencetak record
Save Record Menyimpan record
Undo Record Membatalkan perubahan record

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 12


Apply Form Filter Menyaring data form
Close Form Menutup form
Edit Form Filter Mengedit penyaringan form
Open Form Membuka form
Form Operations
Open Page Membuka halaman web
Print a Form Mencetak form
Print Current Form Mencetak form yang sedang aktif
Refresh Form Data Memperbaharui data form
Mail Report Mengirim laporan via e-mail
Preview Report Melihat preview report
Report Operations
Print Report Mencetak report
Send Report To File Menyimpan report/laporan ke dalam file
Quit Application Keluar dari Aplikasi Ms. Access
Run Application Menjalankan aplikasi
Application Run MS Excel Menjalankan Microsoft Excel
Run MS Word Menjalankan Microsoft Word
Run Notepad Menjalankan Notepad
Auto Dialer Menulis nomor telephone
Print Table Mencetak tabel
Miscellaneous
Run Macro Menjalankan macro
Run Query Menjalankan query

5) Mengatur Tampilan Form


- Klik kanan di pojok kiri atas form – Klik Properties
1 : Klik Kanan

2 : Klik
Properties

gbr. 44 Menampilkan Form Properties

- Klik tab Format


- Atur beberapa properties form seperti
• Caption untuk Title Form
• Scroll Bars ubah jadi Neither
• Record Selector ubah jadi No
• Navigation Buttons ubah jadi No
• Dividing Lines ubah jadi No
• Auto Center ubah jadi Yes
• Control Box ubah jadi No

Klik Format

gbr. 45 Mengatur Format Form

- Tutup desain form, apabila ada konfirmasi jawab Yes untuk penyimpanan ulang
kemudian aktifkan kembali form tersebut dan lihat hasil modifikasinya.

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 13


6) Special Effect pada Objek
- Klik icon Rectangle
- Drag di area form layaknya sebuah bingkai

1 : Klik icon Rectangle

2 : Drag di area ini

gbr. 46 Menambahkan Rectangle pada Form

- Klik kanan pada objek tersebut


- Pilih Special Effect

1 : Klik kanan tepat


di garis
Rectangle

2 : Pilih Special Effect

gbr. 47 Menambahkan Special Effect pada Rectangle

5. Report
a. Pengertian
Pada saat kita membutuhkan laporan dalam bentuk hardcopy, tentu saja kurang menarik
kalau kita sajikan dalam bentuk tabel/query yang masih mentah. Untuk itu kita perlu memberi hasil
tampilan yang lebih menarik dan interaktif dengan menggunakan objek Report.
Report adalah bentuk output hasil pengolahan database untuk keperluan pencetakan dari
sebuah tabel/query sebagai sumber datanya.
b. Membuat Report
Secara prinsip, pembuatan Report hampir sama dengan cara pembuatan pada Form,
terdapat beberapa cara dan pilihan untuk membuat sebuah report, salah satu yang termudah yaitu
dengan cara Wizard
Berikut langkah-langkah pembuatan report dengan wizard :
- Klik object Report pada jendela Database
- Klik ganda (double click) pada pilihan Create report by using wizard

2 : Klik Ganda

1 : Klik

gbr. 48 Create report by using wizard

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 14


- Setelah itu tampil kotak dialog Report Wizard
- Pada pilihan Table/Queries, pilih tabel/query yang akan dibuat report
- Untuk memasukkan semua field yang ada di tabel/query klik tombol .>>. – Klik Next

1 : Pilih tabel/query

2 : Klik Tombol ini

3 : Klik Next

gbr. 49 Memilih tabel/query dan memasukkan field

- Untuk sementara abaikan saja pilihan grouping levels – Klik Next

Klik Next

gbr. 50 Grouping Levels

- Pilih field yang akan dijadikan acuan dalam pengurutan data pada sebuah database – Klik
Next

1 : Pilih field yang akan


jadi acuan dalam
pengurutan data

2 : Klik Next

gbr. 51 Memilih field untuk pengurutan data

- Pilih bentuk Layout dan Orientation untuk posisi kertas – Klik Next

1 : Pilih bentuk layout dan


orientation kertas

2 : Klik Next

gbr. 52 Memilih Layout dan Orientation

- Pilih jenis Style untuk report yang kita buat – klik Next

1 : Pilih jenis Style

2 : Klik Next

gbr. 53 Memilih Report Style

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 15


- Terakhir pada isian Title, ketik Nama atau Judul Report
- Klik Finish

1 : Ketik Nama atau Judul


Report

2 : Klik Finish

gbr. 54 Memberi Nama/Judul Report

- Kemudian muncul Report dalam mode Print Preview

gbr. 55 Report mode Print Preview

c. Modifikasi Report
Bila hasil pembuatan report menggunakan fasilitas wizard dianggap kurang memuaskan,
anda bisa memodifikasi report sesuai dengan keinginan anda seperti, mengatur ukuran dan batas
kertas, mengganti warna background, menambahkan beberapa objek pada toolbox dan masih
banyak yang lainnya.
Berikut ini beberapa hal yang bisa dilakukan untuk memodifikasi report.
1) Mengatur ukuran dan batas kertas
Untuk mengatur ukuran dan batas kertas, hampir sama dengan mengatur ukuran dan
batas kertas pada program Ms. Word yaitu melalui menu File – Page Setup
2) Mengganti warna background
Ubah terlebih dahulu tampilan report pada mode Design View. Jika sudah, terlihat
beberapa bagian yang terdapat pada tampilan report yaitu :
a) Report Header berada di posisi bagian atas report, report header hanya akan tampil di
halaman pertama saja
b) Page Header berada di bawah Report Header, page header akan tampil di setiap
halaman report
c) Detail berada di bagian utama report, detail akan menampilkan data yang tersimpan pada
sebuah tabel/query
d) Page Footer berada di bagian bawah report diatas Report Footer, page footer akan tampil
di setiap halaman report
e) Report Footer berada paling bawah sebuah report, report footer hanya tampil di halaman
terakhir saja.
Jika anda sudah mengenali setiap bagian pada report mode design view, langkah
selanjutnya untuk mengubah warna background yaitu klik kanan pada bagian report
kemudian aktifkan properties, klik tab Format kemudian pilih Back Color.

6. Macro
a. Pengertian
Macro adalah perintah atau fungsi yang telah disediakan yang dapat dijadikan perintah
otomatis. Namun sebuah macro tidak bisa dijalankan begitu saja, harus disisipkan pada sebuah
kejadian (event) suatu objek. Misalnya, saat form dibuka, form ditutup, form aktif, form tidak aktif,
command button di klik, command button di double click, dan lain sebagainya.
b. Membuat Macro
Berikut ini langkah-langkah membuat macro :
- Klik objek Macros pada jendela Database
- Klik tombol New

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 16


2 : Klik New

1 : Klik Macros

gbr. 56 New Macro

- Pilih jenis Action


- Atur beberapa pengaturan pada Action Arguments untuk melengkapi Action pada Macro

1 : Pilih Jenis
Action

2 : Atur beberapa
Action Arguments

gbr. 57 Setting Macro

c. Menyimpan Macro
Berikut cara menyimpan macro :
- Klik File – Save
- Beri nama macro – Klik OK

Membuat Aplikasi Sederhana pada MS. Access 2003

Pada bagian ini kita akan membahas tentang sistem informasi sederhana tentang Data Nilai Siswa
pada salah satu mata pelajaran. Dimana aplikasi tersebut bisa menampilkan keterangan dari nilai yang
diperoleh masing-masing siswa baik dalam bentuk soft copy maupun hard copy bila diperlukan.
Di bagian ini pula akan dibahas dari mulai merancang database hingga menjadikan sebuah aplikasi
siap pakai menggunakan menu pulldown kreasi sendiri.
1. Merancang database
a. Buatlah sebuah file database dengan nama “Aplikasi Data Siswa” di folder masing-masing.
b. Membuat Tabel
- Tbl_Siswa
Tabel pertama yang akan dibuat berfungsi menyimpan semua data siswa secara umum.
Rancang tabel sesuai dengan ketentuan berikut ini :
Field Name Data Type Field Size
* No_Induk Text 10
Nama Text 25
Kelas Text 10
Jenis_Kelamin Lookup Wizard -
Alamat Text 50
Ket : * = Primary Key

- Tbl_Nilai
Tabel kedua adalah tabel dasar yang akan menyimpan data nilai siswa, tabel ini nantinya
akan disempurnakan dengan query, intinya tabel ini hanya tabel dasar untuk pembuatan
query. Berikut ini ketentuannya :
Field Name Data Type Field Size Decimal Places Default Value
No_Induk Text 10 - -
Afektif Number Single 0 -
Psikomotor Number Single 0 -
Kognitif Number Single 0 -
Ket : Tabel ini tanpa Primary Key, jika saat penyimpanan tabel terdapat konfirmasi primary key jawab No
c. Membuat Relationships
Untuk pembuatan relationships, lihat kembali pada pembuatan relationships yang telah
dibahas sebelumnya.
d. Membuat Query
Seperti telah disinggung sebelumnya bahwa Tbl_Nilai akan disempurnakan dengan query.
Query inilah yang akan kita bahas sekarang ini. Query ini akan melengkapi beberapa fasilitas

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 17


yang tidak bisa diselesaikan menggunakan objek Tabel, seperti mencari rata-rata nilai per siswa
dan juga menampilkan keterangan kelulusan siswa.
Masukan kedua tabel pada rancangan query seperti yang terdapat pada contoh di
pembahasan pembuatan query sebelumnya. Masukkan field-field yang dibutuhkan dengan
memperhatikan tabel sumbernya.
Sebagai ilustrasi lihat contoh di bawah ini !
1 : Nama Field

2 : Tabel Sumber

gbr. 58 Desain Query Nilai

Kemudian tambahkan dua buah field baru di sebelah kanan field Kognitif dengan
mengetikan :
• Field Pertama : Rata-rata:([Afektif]+[Psikomotor]+[Kognitif])/3
• Field Kedua : Keterangan:Iif([Rata-rata]<50;”Tidak Lulus”;”Lulus”)
Hingga terlihat seperti contoh berikut ini :

gbr. 59 Menambah Field Baru pada Query

Simpan query tersebut dengan nama Data_Nilai.


e. Membuat Form
Seperti sudah dibahas sebelumnya bahwa form berfungsi untuk menginput data pada
sebuah database dengan tampilan yang lebih interaktif dan menarik. Pada aplikasi ini, kita
membutuhkan dua buah form yang akan dijadikan media input data.
- Form Data Siswa
Form pertama ini dirancang untuk meng-input data siswa dengan Tbl_Siswa sebagai
data source-nya atau tempat menyimpan data-data yang kita input pada form Data Siswa.
Untuk selanjutnya, cara pembuatan form bisa anda lakukan dengan cara wizard ataupun
manual seperti yang telah dibahas sebelumnya. Silakan anda mencoba merancang sendiri
sebuah form, sebagai acuan perhatikan gambar dibawah ini.

gbr. 60 Tampilan Form Siswa

Setelah itu ikuti langkah-langkah berikut ini :


• Tambahkan satu buah combo box untuk fasilitas Cari pada Form. Tempatkan tepat diatas
text box NoInduk

Drag di Area ini

gbr. 61 Menambah Combo Box Cari

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 18


• Muncul kotak dialog Combo Box Wizard
• Pilih option paling bawah – Klik Next

1: Klik pada Option ini

2: Klik Next

gbr. 62 Combo Box Wizard

• Pilih field NoInduk dan Nama, tambahkan field tersebut dengan meng-klik tombol . > . –
Klik Next

1: Klik pada Tombol ini

2: Klik Next

gbr. 63 Memasukkan Field pada Combo Box

• Non-aktifkan ceklist pada Hide key column (recommended) – Klik Next

1: Non-aktifkan Cek List

2: Klik Next

gbr. 64 Me-non aktifkan Cek List

• Ketik Cari pada label combo box – Klik Finish

1: Ketik Cari

2: Klik Finish

gbr. 65 Memberi Nama Label Combo Box

• Hasilnya tampak seperti contoh berikut ini

gbr. 66 Hasil Tampilan Combo Box Cari

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 19


• Kemudian tambahkan tiga buah Command Button di Form Footer dengan ketentuan
sebagai berikut :
Categories Actions Text Nama
Record Operations Add New Record &Tambah cmd_Tambah
Record Operations Delete Record &Hapus cmd_Hapus
Form Operations Close Form &Selesai cmd_Selesai

Sehingga tampak seperti contoh berikut ini :

Tambahkan 3 buah Command


Button
gbr. 67 Hasil Tampilan Command Button

• Aktifkan Properties Form


• Klik tab Format, kemudian atur beberapa properties berikut ini :
¾ Caption isi dengan SMKTI Dadaha Informatik
¾ Scroll Bars ubah jadi Neither
¾ Record Selector ubah jadi No
¾ Navigation Buttons ubah jadi No
¾ Dividing Lines ubah jadi No
¾ Auto Center ubah jadi Yes
¾ Control Box ubah jadi No
• Kemudian klik tab Event, pilih baris On Open untuk menambahkan baris kode
pemrograman agar setiap kali form dibuka, menambah record baru.
• Pilih Event Procedure – Klik icon Builder (titik tiga)

Pilih Event Procedur,


kemudian klik icon Builder
gbr. 68 Mengatur Event On Open

• Tulis kode program pada Visual Basic Editor seperti contoh berikut ini :
Private Sub Form_Open(Cancel As Integer)
DoCmd.GoToRecord , , acNewRec
End Sub
• Tutup jendela Visual Basic Editor
• Jika perlu tambahkan beberapa objek lain seperti Line (garis) dan Rectangle (kotak
persegi) pada Form
• Simpan Form dengan nama Form Data Siswa
• Berikut ini contoh tampilan form mode Form View

gbr. 69 Tampilan Form Siswa mode Form VIew

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 20


- Form Data Nilai
Form kedua ini berfungsi untuk meng-input nilai yang diperoleh masing-masing siswa
sekaligus hasil kelulusannya. Data Source form ini adalah query Data_Nilai. Silakan anda
rancang form bisa menggunakan cara wizard ataupun manual.
Sebagai ilustrasi, perhatikan contoh berikut ini.

gbr. 70 Form Data Nilai mode Design View

Pada text box NoInduk perlu dimodifikasi menjadi combo box agar control Nama dan
Kelas secara otomatis terisi berdasarkan NoInduk yang kita pilih atau isi sesuai dengan data
yang ada pada Data Siswa. Untuk itu lakukan langkah-langkah berikut ini :
• Klik kanan pada text box NoInduk
• Pilih Change To – Klik Combo Box

2: Pilih Change To

1: Klik Kanan

3: Klik Combo Box

gbr. 71 Change To Combo Box

• Hasilnya text box NoInduk berubah menjadi Combo Box


• Aktifkan Properties Combo Box NoInduk
• Klik tab Data – Pilih baris Row Source, kemudian klik icon Builder (titik tiga)

Klik Icon Builder pada Baris


Row Source

gbr. 72 Menentukan Row Source

• Muncul Kotak Show Tabel – Masukan Tbl_Siswa – Klik Close


• Masukkan field NoInduk dan Nama pada SQL Statement : Query Builder

Sisipkan Field NoInduk dan


Nama

gbr. 73 Tampilan SQL Statement

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 21


• Tutup Jendela SQL Statement – Klik Yes
• Klik tab Format, atur beberapa properties di bawah ini
¾ Column Count ganti dengan 2
¾ Column Widths isi dengan 2cm;5cm
¾ List Width ganti dengan 7cm
• Klik tab Event – pilih baris After Update
• Pilih Event Procedure – Klik icon Builder (titik tiga)
• Ketik kode program berikut ini
Private Sub NoInduk_AfterUpdate()
Afektif.SetFocus
End Sub
• Kemudian lengkapi beberapa objek lainnya seperti Combo Box Cari, Tiga buah
Command Button, Line dan Rectangle dan juga kode program (event procedure) On
Open seperti pada form sebelumnya hingga tampilannya kurang lebih seperti contoh
dibawah ini.
• Simpan form dengan nama Form Data Nilai

gbr. 74 Tampilan Form Data Nilai mode Form View

f. Membuat Report
Jika suatu saat kita membutuhkan informasi dari aplikasi database dalam bentuk hard copy
atau dicetak pada kertas sebagai laporan data, maka kita harus merancang report. Begitu juga
dalam aplikasi ini kita membutuhkan dua buah report, masing-masing Data_Siswa dan Data_Nilai.
Silakan anda coba rancang sendiri sebuah report dengan fasilitas wizard seperti yang telah
dibahas sebelumnya. Sebagai acuan perhatikan beberapa aturan berikut ini.
- Data_Siswa
• Data Source : tabel Tbl_Siswa
• Orientation (Orientasi Kertas) : Potrait
• Label : Data_Siswa

gbr. 75 Report Data Siswa mode Design View

- Data_Nilai
• Data Source : query Data_Nilai
• Orientation (Orientasi Kertas) : Landscape
• Label : Data_Nilai

2. Membangun Aplikasi
Setelah kita selesai merancang struktur database, tentu saja kita tidak bisa menyajikan
langsung secara mentah begitu saja. Untuk itu kita perlu membangun sebuah aplikasi database yang
aman dari ancaman tangan-tangan usil dan juga membuat aplikasi lebih profesional seolah-olah
berdiri sendiri (stand alone). Berikut ini langkah-langkah untuk membangun sebuah aplikasi database
profesional.

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 22


a. Membuat Macro
Macro yang akan dibuat disini, nantinya akan digunakan untuk mengaktifkan menu hasil
kreasi sendiri. Dengan kata lain, agar menu yang nantinya kita rancang bisa berfungsi sesuai
dengan yang kita inginkan dibutuhkan fasilitas yakni macro. Berikut ini daftar macro yang akan
kita buat.
Form Name /
No Action View Nama Macro
Report Name
1 Open Form Form Data Siswa Form Data_Siswa
2 Open Form Form Data Nilai Form Data_Nilai
3 Open Report Data_Siswa Print Preview Lap_DataSiswa
4 Open Report Data_Nilai Print Preview Lap_DataNilai
5 Quit - - Keluar

b. Membuat Menu dan Submenu


Sebelum anda membuat menu dan submenu, supaya lebih jelas perhatikan
struktur/diagram menu berikut ini.

Master Laporan Utility

Data Siswa Informasi Siswa Compact and


Repair
Data Nilai Informasi Nilai

Keluar ¬ Print

gbr. 76 Struktur Menu dan Submenu

Terlihat bahwa terdiri dari 3 menu utama, yaitu menu Master, Laporan dan Utility dan
masing-masing menu mempunyai submenu yang jumlahnya 7 buah submenu.
Berikut ini langkah-langkah untuk membuat menu dan submenu.
• Menu Utama
- Klik menu View
- Pilih Toolbars
- Klik Customize

1: Klik View

2: Pilih Toolbors

3: Klik Customize

gbr. 77 Customize Toolbars

- Muncul jendela Customize


- Klik tab Toolbars – Klik New

1: Klik Toolbars

2: Klik New

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 23


Gbr. 78 Membuat New Toolbar
- Ketik Menu Utama pada Toobar Name – Klik OK

1: Ketik Menu Utama

2: Klik OK
gbr. 79 Memberi Nama Toolbar

- Klik Properties
- Muncul Jendela Properties
- Pada pilihan Type, pilih Menu Bar – Klik Close

1: Pilih Menu Bar

2: Klik Close

gbr. 80 Mengganti Tipe menjadi Menu Bar

- Klik tab Commands


- Pada bagian Categories pilih New Menu (paling bawah)
- Pada bagian Commands, drag New Menu ke area Menu Utama yang telah kita buat.

Drag New Menu ke area Menu Utama

gbr. 81 Memasukkan Menu ke dalam Menu Utama

- Tambahkan 2 buah Menu lagi sehingga hasilnya tampak sebagai berikut

gbr. 82 Membuat 3 buah Menu

Setelah selesai membuat 3 buah menu, langkah selanjutnya adalah mengganti Property
dengan memberi nama pada masing-masing menu yaitu dengan cara :
- Klik kanan pada New Menu
- Pada bagian Name ketik &Master

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 24


1: Klik Kanan
2: Ketik &Master

gbr. 83 Mengganti Property Name Menu


Keterangan : Menambahkan simbol (&) berfungsi untuk memberikan shortcut pada menu.
Contohnya Alt + M untuk menu Master
- Selanjutnya berikan nama pada menu selanjutnya dengan nama &Laporan dan &Utility

gbr. 84 Tampilan Menu Utama


• Submenu
Berikut ini langkah-langkah menambahkan submenu pada Menu Utama
- Masih di jendela Customize, pada bagian Categories pilih File
- Pada bagian Commands pilih Custom
- Drag Custom ke menu Master

Drag Custom ke area menu Master

gbr. 85 Menambahkan Submenu

- Hasilnya seperti pada contoh gambar berikut ini

gbr. 86 Hasil Penambahan Submenu

- Tambahkan lagi 2 buah Custom ke menu Master, sehingga menu Master mempunyai 3
buah submenu (lihat kembali gambar struktur menu dan submenu gbr. 76)
- Pada menu Laporan, tambahkan submenu Print yang telah tersedia pada bagian
Commands
- Pada menu Utility, tambahkan submenu Compact and Repair Database yang terdapat
pada bagian Categories Tools

Untuk selanjutnya kita juga dapat mengganti nama dan menambahkan gambar/icon pada
masing-masing submenu dengan cara :
- Klik kanan pada submenu yang akan diedit
- Pada bagian Name ketik nama submenu, contoh Data &Siswa
- Pada bagian Change Button Image silakan ada pilih icon yang anda sukai

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 25


1 : Klik kanan pada Submenu

2 : Ketik nama Submenu

3 : Pilih gambar/icon

Gbr. 87 Mengatur Beberapa Property pada Submenu

- Khusus pada submenu Keluar, kita bisa menambahkan property Begin a Group

gbr. 88 Menambahkan Property Begin a Group

Kemudian supaya submenu yang telah kita buat dapat berfungsi, maka kita perlu menyisipkan
macro-macro yang telah kita buat sebelumnya yaitu dengan cara
- Klik kanan pada submenu yang ingin disisipkan macro
- Klik Properties
- Pada bagian On Action pilih Macro yang sesuai dengan fungsi submenu tersebut.
- Klik Close

1 : Pilih Macro

2 : Klik Close

gbr. 89 Menyisipkan Macro pada Submenu

c. Membuat Startup
Dan akhirnya langkah terakhir dalam merancang aplikasi database menggunakan Ms.
Access adalah mengatur Fitur Startup. Fasilitas ini berpengaruh pada file aplikasi database setiap
kali file tersebut dijalankan secara Run Time.
Ada beberapa yang perlu disetting agar hasil akhir file aplikasi kita terlihat seperti halnya
aplikasi yang dihasilkan oleh software Bahasa Pemrograman yang bersifat Stand Alone (berdiri
sendiri) dan juga dapat mencegah file aplikasi dari sifat jahil orang-orang yang tidak bertanggung
jawab. Berikut ini langkah-langkahnya :

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 26


- Klik menu Tools
- Klik Startup
- Muncul kotak dialog Startup
- Pada bagian Application Title kita dapat ketik Aplikasi Data Siswa
- Non-aktifkan ceklist pada bagian Display Database Window dan Allow Built-in Toolbars
- Klik OK

Klik OK

Gbr. 90 Mengatur Startup

Setelah anda selesai melakukan pengaturan pada Startup, coba anda tutup file aplikasi
terlebih dahulu kemudian aktifkan kembali file aplikasi tersebut. Hasilnya tampak tampilan baru
yaitu dengan tidak adanya jendela database dan deretan menu yang tampil ada menu yang telah
kita rancang sebelumnya.
Dan akhirnya program aplikasi tersebut tampil dengan tampilan yang lebih profesional.
(Good Luck…!!!).

Mengoperasikan Software Aplikasi Basis Data – Eko Sugiharto ____________________________ >> 27