Anda di halaman 1dari 2

Menghitung Luas Areal di ESRI ArcView

Pada dasarnya, kalau Anda membangun suatu topologi poligon di ESRI ArcView, secara
otomatis akan terbentuk field Area dan Perimeter, dimana Area mewakili 'luas', dan
Perimeter mewakili 'keliling'. tapi, bagaimana kalau setelah selesai membangun poligon
(baik dengan cara digitasi atau konversi polyline ke polygon) ternyata tidak terbentuk
field Areal? setidaknya ada 3 cara yang bisa Anda gunakan untuk 'memunculkan' field
luasan ini, yaitu (a) cara manual menggunakan formula RETURN, (b) cara otomatis
menggunakan ekstensi Xtools, dan (c) cara otomatis menggunakan ekstensi SHAPE
Enhancement.

(a) Cara manual menggunakan formula RETURN


Cara manual menggunakan formulasi RETURN bisa dibilang simpel, namun terkesan
tidak praktis. cara ini setidaknya bisa Anda praktikkan ketika ~ entah bagaimana ~
piranti lunak ESRI ArcView Anda tidak memiliki ekstensi Xtools dan SHAPE
Enhancement sama sekali.
anggap saja Anda sudah selesai mendigit poligon, dan Anda baru nyadar kalau field
Areal tidak muncul di data atribut theme poligon.shp. apa yang kudu Anda lakukan?
Gunakan menu Table> Start Editing.sekarang data atribut Anda sudah dalam mode
editing. pilih menu Edit> Add Field.

Berikutnya akan muncul jendela Field Definition, yang berisi beberapa isian sebagai
berikut:
Name: Luas (nama bebas, terserah Anda)
Type: Number (karena yang akan diisikan adalah informasi numerik)
Width: 15 (lebar kolom)
Decimal Places: 2 (ketelitian angka desimal di belakang koma)

Bila Anda sudah selesai mengisi isian di atas, tekan OK, sehingga akan muncul field
baru berjudul 'Luas'.
Sekarang, tekan bagian judul Field Luas, lalu tekan tombol Calculate
Pada bagian Fields, klik ganda [Shape] hingga masuk ke dalam kolom formula, yang
dalam kasus ini bertuliskan [Luas]3D, lalu ketikkan ".returnarea", sehingga keseluruhan
formula menjadi:
[Shape].returnarea
Maka secara otomatis field Luas Anda sudah berisi informasi luas dari poligon Anda.

(b) Cara otomatis menggunakan ekstensi Xtools


Xtools merupakan ekstensi advanced editing populer, yang sering digunakan selain Edit
Tools. selain mampu menangani konversi dan berbagai macam hal lainnya, Xtools juga
bermanfaat untuk mengupdate luasan hingga keliling!
Aktifkan ekstensi Xtools dari menu File> Extensions...> XTools 6/1/01
Set aktif theme poligon.shp, lalu pilih menu XTools> Calculate Area, Perimeter,
Length, Acres, Hectares
Hanya dengan sekali klik, kini data atribut theme poligon.shp Anda sudah memiliki
field; Area_meters (Area dalam meter persegi), Perimeter_meters (keliling dalam meter),
Acres, dan Hectares (area dalam hektar)

(c) Cara otomatis menggunakan ekstensi SHAPE Enhancement


SHAPE Enhancement juga tak kalah mudahnya dibandingkan dengan Xtools, meski
field yang dihasilkan 'hanya' Area dan Perimeter saja.
aktifkan ekstensi SHAPE Enhancement dari menu File>Extensions...>SHAPE
Enhancement
dari menu SHAPETools, pilih opsi Calculate Features
maka secara otomatis, field Area dan Perimeter akan terbentuk di atribut dari theme
poligon.shp

Supplement
Men ghitung jarak/panjang suatu theme bertopologi garis
Bingung mengetahui jarak atau panjang suatu segmen fitur dari theme bertopologi garis?
Anda bisa memanfaatkan ekstensi Xtools. seperti yang sudah Saya sebutkan di atas,
salah satu opsi yang dimiliki Xtools adalah untuk menghitung "APLAH", alias Area,
Perimeter, LENGTH, Acres, dan Hectares. sehingga cukup dengan menekan opsi
Calculate Area, Perimeter, Length, Acres, Hectares saja, Anda sudah mendapatkan
informasi jarak atau panjang segmen garis dari theme bertopologi garis Anda dalam field
berjudul Length.
Kalau Anda tidak punya ekstensi Xtools? Anda bisa menggunakan formula RETURN.
bagaimana caranya? langkahnya sama dengan langkah untuk menghitung luas areal
poligon di atas. hanya saja, theme-nya adalah theme bertopologi garis, dan untuk
formulasinya, Anda tinggal mengubah RETURNAREA dengan RETURNLENGTH,
sehingga formulasinya menjadi:
[Shape].returnlength
gampang 'kan?