Anda di halaman 1dari 22

2011

Membangun Basistdata Geospasial dengan ArcGIS Diagrammer (AD)


Building Geospatial Database using ArcGIS Diagrammer (AD)

Dipersiapkan Oleh: Aji Putra Perdana, S.Si


Cibinong, Bogor, 27 Juni 2011

Page 1 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

KATA PENGANTAR Segala Puji bagi Allah SWT, yang telah melimpahkan rahmat-Nya kepada kita semua. Tuhan yang menganugerahi kita segala kesempatan dan keadilan dalam berbuat kebaikan. Petunjuk ataupun modul sederhana Membangun Basisdata Geospasial dengan ArcGIS Diagrammer ini merupakan penterjemahan dari petunjuk ArcGIS Diagrammer keluaran dari ESRI dan merupakan salah satu bagian atau bahan dalam Pelatihan Sistem Informasi Geografis Tingkat Lanjut yang telah dilaksanakan oleh PT. Geovisi Mitratama serta disusun pada bulan Agustus 2009. Modul ini dikemas ulang menjadi bagian terpisah dengan harapan dapat bermanfaat bagi masyarakat yang berkecimpung di dunia Geospasial Indonesia. Tidak memungkiri adanya kekurangan dan kekhilafan dalam penyusunan petunjuk ini sehingga kritik dan saran yang membangun dari para pembaca dan pengguna sangat kami harapkan. Terima Kasih. Cibinong, 27 Juni 2011 Aji Putra Perdana

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 2 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

Daftar Isi
KATA PENGANTAR ...................................................................................................... 1 ArcGIS Diagrammer (AD) ........................................................................................... 3 Download, Instalasi ArcGIS Diagrammer ................................................................. 3 Designing A Geodatabase .......................................................................................... 4 Modifying the Schema of an Existing Geodatabase.............................................. 17 Referensi ................................................................................................................... 21

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 3 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

ArcGIS Diagrammer (AD)

ArcGIS Diagrammer adalah alat yang produktif bagi para profesional GIS untuk membuat, mengedit atau menganalisis skema geodatabase. Skema ini disajikan sebagai grafis dapat diedit di lingkungan yang familiar bagi pengguna Microsoft Visual Studio 2005. Dasarnya ArcGIS Diagrammer adalah visual editor ESRI's Xml Workspace Dokumen yang diciptakan oleh ArcCatalog, aplikasi manajemen dalam paket produk Desktop ArcGIS. Download, Instalasi ArcGIS Diagrammer 1. ArcGIS Diagrammer dapat didownload melalui website ESRI ArcScript: http://arcscripts.esri.com/details.asp?dbid=15166 2. Instalasi ArcGIS Diagrammer, buka windows explorer dan arahkan ke folder yang berisi file zip download dari situs web ArcScripts. 3. Ekstrak ESRI.ArcGIS.Diagrammer.Setup.2007xxxx.msi dari file Zip dan double klik untuk memulai ESRI.ArcGIS.Diagrammer.Setup.2007xxxx.msi installer. Ketika pertama installer akan menampilkan splash screen. Tekan Next>

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 4 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

4. Klik Next, dan pilih I Agree lalu tekan Next lagi, kemudian pilih lokasi instalasi, klik Next dan tekan Finish. Proses akan berjalan dan apabila sudah selesai klik Close.

MICROSOFT .NET FRAMEWORK ArcGIS Diagrammer requires Microsoft .Net Framework version 2.0. Designing A Geodatabase Sebelum ArcGIS Diagrammer (AD) ada dua cara pembuatan skema geodatabase, desainer dapat menggunakan ArcCatalog atau pihak ketiga CASE tools seperti IBM "s Rational Rose atau Microsoft" s Visio. ArcCatalog adalah aplikasi yang sangat terfokus untuk pembuatan skema. Tapi, tentu saja, nongrafis membuat desain kolaborasi dan validasi sulit. Untuk desain yang kompleks, pembuatan skema dengan ArcCatalog akan sangat memakan waktu. CASE tools memungkinkan desainer untuk membuat standar diagram UML tapi masalahnya ialah performa dengan desain yang kompleks. Selain itu, beberapa objek seperti geodatabase topologi dataset dan penjelasan kelas fitur tidak didukung.
2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer
Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 5 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

Dalam latihan ini Anda akan menemukan metode ketiga pembuatan skema. Mari memulai latihan ini dengan memulai AD dari jendela menu start. 1. Pada komputer dengan Windows XP klik Start> All Programs> ArcGIS> ArcGIS Diagrammer> ArcGIS Diagrammer seperti yang ditunjukkan di bawah ini. 2. Untuk membuat diagram baru pilih File > New. 3. Pada jendela Pallete di-scroll ke bawah sampai muncul item Fitur Dataset. Jika Anda letakkan kursor di atasnya maka akan muncul ballon tooltip.

4. Drag item fitur dataset dari pallete dan letakkan pada diagram. Secara default, dataset yang ditambahkan akan bereferensi spasial WGS84.

5. Silahkan merubah nama fitur dataset dengan klik kiri atau pada jendela Properties, sorot text Empty pada isian Name.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 6 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

6. Ketikkan WORLD dan kemudian tekan ENTER untuk meng-update fitur dataset.

7. Scroll up dafatar objek pada Geodatabase di jendela Palette dan arahkan ke item Polygon dibawah kategori FeatureClasses. Lalu drag dan letakkan pada diagram.

8. Lakukan hal yang sama untuk menambahkan Raster Dataset dan Raster Band ke dalam diagram, seperti yang ditunjukkan di bawah ini.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 7 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

9. Selanjutkan kita harus menentukan struktur Geodatabase, yakni fitur class harus diasosiasikan dengan fitur dataset dan raster band dengan raster dataset. Untuk melakukan hal ini ubahlah ke Link Mode. Klik Tools > Link Mode

10. Silahkan hubungkan fitur class ke fitur dataset dan raster band ke raster dataset dengan drag link dari dan ke objek yang dituju.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 8 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

11. Sebelum melanjutkan lagi, ubahlah ke Normal Mode dengan klik Tools > Normal Mode

12. Kembali ke pallete, drag dan drop coded value domain ke diagram.

13. Pada tahap sebelumnya Anda telah mengubah nama fitur dataset dari Empty ke World. Kali ini ubahlah nama domain yang baru ditambahkan tadi ke Languange.
2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer
Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 9 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

14. Kita akan menggunakan coded value domain ini sebagai tempat untuk daftar nama bahasa dan kodenya. Pilih pada Domain Languange dan lihatlah di propertiesnya. Tulislah kode EN dan bahasanya English pada jendela properties.

15. Untuk menambahkan item coded value, klik kanan pada domain dan pilih Add Coded Value Item. Ulangi langkah ini dan lakukan hingga diperoleh dua blank item coded value. Pilih coded value kedua dan ubahlah nama dan kodenya dengan DE dan German, lakukan juga untuk coded value yang ketiga dengan nama ES/Spanish.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 10 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

16. Langkuh yang paling mudah untuk melihat objek yang ada di diagram Anda pergunakanlah Jendela Catalog. Jika jendela Catalog ini tidak muncul pilih View > Catalog dan klik tombol Refresh untuk update diagram, seperti gambar berikut.

17. Jendela Catalog mempunyai tiga tipe. Pertama dan default view adalah sama dengan struktur tree yang tampil pada ArcCatalog.

18. Silahkan klik pada Categories View, Alphabetical View, untuk melihat dan mengamati data yang sudah dibuat dalam diagram ini.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 11 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

19. Sejauh ini Anda telah menambahkan domain, fitur dataset, fitur class, raster dataset, raster band dan mengasosiasikannya. Sebelum melanjutkan, silahkan validasi diagram ini. Validasi adalah proses scanning diagram dari eror dan ketidakkonsistenan dari data. Pilih Tools > Validate.

20. Jika jendela Error List tidak muncul klik View > Error List. Seperti gambar berikut. Dari ketiga errors, dua mempunyai penjelasan bahwa Dataset name Empty is duplicated. Hal ini dikarenakan konflik penamaan, silahkan mulai dengan mengarahkan oada objek tersebut. Pilih kedua eror, gunakan CONTROL key untuk memilih lebih dari satu. Klik kanan pada salah satu dan klik Flash.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 12 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

21. Salah satu harus diubah namanya, pilih fitur class dan ubahlah namanya menjadi Countries. Ubahlah nama raster dataset Empty ke Temperature.

22. Refresh eror dengan klik Tools > Validate. Sekarang Anda hanya memiliki satu eror yakni Field [SHAPE_Length] is too long. Silahkan pilih untuk mengetahui table atau fitus class yang mana.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 13 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

23. Fitur Countries terpilih pada diagram. Untuk memvalidasinya menggunakan database specific validator. Pilih validator dropdown pada error list, pilih File Geodatabase.

24. Revalidasi diagram dengan klik Tools > Validate.

25. Sekarang, kita hanya memiliki satu peringatan (single warning). Semua table dan field adalah valid untuk file geodatabases. Penjelasan dari peringatan tadi adalah tidak digunakannya domain Language. Hal ini termasuk ke dalam peringatan karena tidak akan
2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer
Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 14 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

menyebabkan eror pada target geodatabase. Oleh karena itu, peringatan ini dapat diabaikan. Untuk kasus ini, silahkan buat field baru pada fitur class Countries dan tandai dengan domain Languages di dalamnya. Untuk membuat field baru, klik kanan pada fitur class dan pilih Add Field...

26. Pilih field baru tersebut. Update properties-nya dan isikan sebagai berikut.

27. Catatan, bahwa pada Domain dan Fieldtype ada pilihan menu dropdown, untuk menghindari typographical errors. Kemudian lakukan Validasi lagi. 28. Apabila kesalahan sudah dihilangkan, maka kita dapat membuat xml workspace document dari diagram ini. Klik File > Save Untitled AsSimpan dan berinama pada file tersebut lalu klik Save.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 15 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

29. Selanjutnya, jalankan ArcCatalog dari Start > All Program > ArcGIS > ArcCatalog. Arahkan pada lokasi penyimpanan dokumen XML tadi. Lalu pada menu utama ArcCatalog, klik File > New > File Geodatabase. 30. Klik kanan pada file Geodatabase tersebut dan pilih Import > XML Workspace Document. Kemudian pilih Schema Only, klik Next dan Finish. Proses importing akan berjalan, setelah usai klik View > Refresh.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 16 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

31. Klik kanan pada fitur class Countries dan pilih Properties. Klik pada tab Field dan spokeLanguange field list. Amati apakah sesuai dengan yang dibuat di AD. Lalu klik Cancel.

32. Kembali ke aplikasi AD dan tutuplah, klik File > Close.

SELAMAT ANDA TELAH MEMBUAT SEBUAH GEODATABASE MENGGUNAKAN ARCGIS DIAGRAMMER (AD)
2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer
Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 17 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

Modifying the Schema of an Existing Geodatabase Pada latihan pertama Anda telah memulai dengan diagram kosong dan membuat skema geodatabase dengan menambahkan item-item dari pallete. Untuk latihan kali ini Anda akan menggunakan skema geodatabase yang sudah ada, memodifikasinya di ArcGIS Diagrammer dan mengaplikasikannya sebagai Geodatabase baru. Latihan ini akan menggunakan data Montgomery_full.gdb. 1. Jalankan ArcCatalog dan arahkan pada direktori lokasi Montgomery_full.gdb. Klik kanan pada gdb tersebut dan pilih Export > XML Document.

2. Lalu pilih Schema Only, tentukan lokasi penyimpanan XML, klik Next dan selanjutnya klik Finish.

3. Setelah proses selesai. Jalankan AD, pilih File > Open dan arahkan ke Montgomery.xml tadi.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 18 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

4. Kemudian silahkan amati diagram dari Geodatabase Montgomery ini. 5. Diagram yang ada seringkali lebih besar dari layar monitor Anda. AD menyediakan tiga jalan untuk navigasi diagram ini yakni dengan scroll bar di kanan dan bawah diagram, kedua dengan jendela overview, klik View > Overview. Atau yang ketiga dengan menggunakan jendela Catalog.

6. Pada jendela Catalog, pilihlah fitur dataset Landbase dan fitur class Parcel, klik kanan pada Non-Residential dan pilih Scroll.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 19 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

7. Selanjutnya, arahkan pada domain Fitting Type. Pada jendela Catalog, klik kanan pada Fitting Type dan pilih Scroll. Klik kanan pada Fitting Type dan pilih Open Diagram, Buka domain diagram.

8. Jadikan tampilan diagram ke dalam 50%. Silahkan bereksperimen dengan AD dalam memodifikasi Geodatabase yang sudah ada.

9. Kita bisa meng-eksport diagram yang ada ke dalam bentuk gambar (misalnya, *.jpg)

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 20 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

10. Menyimpan hasil modifikasi ke dalam file baru.

11. Contoh hasil export dan penyimpanan file baru.

12. Untuk melihat hasil modifikasi, silahkan buat geodatabase baru dan import dokumen XML yang telah dibuat di AD.
2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer
Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,

Page 21 of 21

Membangun Basisdata Geospasial

ArcGIS Diagrammer (AD)

Referensi ESRI. 2007. ArcGIS Diagrammer. ESRI, 380 New York Street, Redlands, CA 92373-8100, USA.

2011 Geospatial Learning: Design Geodatabase using ArcGIS Diagrammer


Aji Putra Perdana Blog: http://ajiputrap.blogspot.com,