Anda di halaman 1dari 4

ADC/11/04/07 F: \ CCA \ 3DGS \ tutorial \ LATIHAN 1 \ 3D STUDIO PERTANDINGAN - LATIHAN 1.

doc 1 dari 6 3D Game Studio - TUTORIAL LATIHAN # 1 MENCIPTAKAN DUNIA 3D DENGAN dibatasi medan dan SKY Dalam latihan ini kita akan belajar dasar-dasar bagaimana menggunakan 3D GameStudio (3DGS) oleh pemodelan dunia 3D dasar (atau "tingkat"). Tutorial harus mengambil sekitar 6 jam (yaitu dua kelas). Berikut ini akan dicapai dalam latihan ini: Mengatur modul script (atau "template") untuk sebuah permainan dasar Mengatur batas-batas dari permainan Menerapkan "kubus langit" ke langit model dan medan jauh. Tambahkan model pemain, kamera, dan perilaku tambahkan CATATAN: Sebelum menjalankan 3D GameStudio pastikan Anda login ke account Anda menggunakan username: CCA, password: CCA. Semua pekerjaan harus diselesaikan menggunakan folder sementara pada mesin lokal dan disimpan baik ke drive USB atau ke account pengguna Anda di akhir masing-masing kelas. Ketika referensi dibuat untuk folder GStudio6, ini berarti folder ini: C: \ Program Files \ Game \ GStudio6 Ini adalah langkah demi langkah prosedur rinci: 1. Buat folder pada komputer lokal disebut "3dgs_exercise1". Hal ini disebut sebagai "direktori kerja". 2. Ke dalam copy direktori MDL pemain. Model dari direktori GStduio6 \ kerja \. Tidak peduli apa pemain terlihat seperti karena tidak akan terlihat dalam permainan. (Anda bisa memilih bentuk abstrak seperti kubus jika Anda ingin.) Namun, untuk menghindari kebingungan, gunakan warlock.MDL (favorit saya), witch.MDL atau woman.MDL. 3. Pergi ke Terminal 26 (http://www.terminal26.com/) dan klik pada "Textures Gratis", kemudian klik pada "Cube Sky". Download file zip ke direktori kerja Anda. Klik kanan pada file ini dan Ekstrak ke lokasi yang sama, CATATAN: Terminal 26 memiliki banyak model gratis dan sumber daya lain untuk digunakan dalam proyek masa depan. 4. Kubus langit dalam format jpg dan. Perlu diubah ke format tga. Untuk digunakan dalam 3DGS. Buka di Photoshop salah satu gambar langit kubus yang memiliki 512 6 pada akhir namanya (kubus adalah 512 pixel tinggi). Simpan gambar ke direktori kerja Anda sebagai file (Targa) tga. (24 bit per pixel). [Catatan untuk referensi di masa mendatang: Anda dapat menggunakan medan gratis program generator Terragen (http://www.planetside.co.uk/terragen/) untuk membuat sendiri batu langit. Anda juga bisa membuat sebuah kubus langit keluar dari setiap gambar yang Anda inginkan, termasuk bangunan, foto, atau seni abstrak.] 5. Terbuka Rab Pergi ke Start> Programs> 3d Game Studio> GameStudio. 6. Buka File> Preferences> Advanced dan pastikan Reload eksternal file diubah diperiksa sebagai Auto. Tutup preferensi. ADC/11/04/07 7. Mulai tingkat baru dengan File> New. 8. File> Save As ke direktori kerja Anda sebagai "latihan 1".

9. Buka File> Properties Peta dan ke kanan klik kotak Script pada ikon. Pilih _A6_template_project. Sebuah script utama baru akan dihasilkan dengan nama yang sama dengan 8. di atas. Tutup kotak ini. 10. WED menunjukkan atas, samping, belakang, dan gambar 3d dari tingkat, yang saat ini kosong. Gunakan roda gulir mouse untuk zoom in dan out. Klik kanan dan drag untuk menjelajah. Ini adalah diagram dari sistem koordinat yang digunakan oleh 3DGS: Klik pada jendela kiri atas, kemudian pergi ke Object> Tambah Cube> Besar. F: \ CCA \ 3DGS \ tutorial \ LATIHAN 1 \ 3D STUDIO PERTANDINGAN - LATIHAN 1.doc 2 dari 6 11. Memperbesar kubus. Klik pada ikon alat skala. Dan skala kubus di atas, samping, dan pemandangan kembali dengan menyeret dengan mouse. Tahan tombol ctrl sambil menyeret untuk memperbesar merata di semua 3 dimensi pada waktu yang sama. Kubus harus sekitar 2 kotak besar dengan 2 kotak besar bila Anda memperbesar tampilan langsung keluar. Ukuran yang tepat tidak penting, Untuk melihat versi besar jendela apapun hanya memaksimalkan melalui tool bar nya.Jika Anda tidak dapat melihat kubus dalam sebuah tampilan, terus menekan + pada keypad numerik (untuk meningkatkan kedalaman melihat) sampai muncul. 12. Klik pada ikon alat seleksi. Pilih kubus kemudian pergi ke Edit> Blok Hollow. Ini blok berongga mendefinisikan batas-batas dunia permainan kami. Catatan: sebelum Anda dapat memilih apa pun yang Anda harus klik pada ikon alat seleksi. Ketika sesuatu dipilih, ternyata merah. Jika Anda sekarang memperbesar tepat di Anda akan melihat bahwa kubus memiliki dinding tipis. Kami telah menciptakan kotak pembatas untuk tingkat permainan kami.Perhatikan bahwa kotak muncul di tab "Level" sebagai Kelompok enam blok - satu untuk setiap sisi kubus. x TOP y z DEPAN SISI ADC/11/04/07 13. Sekarang kita perlu menambahkan model dan script orang pertama kamera sehingga kita dapat melihat apa dunia tampak seperti ketika kita menjalankan tingkat. Pergi ke Object Model> Tambah. Sebuah jendela akan muncul (lihat di bawah) klik pada direktori kerja Anda yang harus tercantum di sebelah kiri. Model yang Anda disalin akan muncul di sebelah kanan. Pilih itu dan klik OK. 14. Klik pada karakter wire frame model dan tarik sampai berdiri di bawah kubus cekung. (Model ini akan memiliki dua panah (sumbu) menempel kami dari itu.) Simpan proyek. Model harus di tengah jendela (XY) Top dan di bagian bawah Kembali (XZ) dan Side (YZ). F: \ CCA \ 3DGS \ tutorial \ LATIHAN 1 \ 3D STUDIO PERTANDINGAN - LATIHAN 1.doc 3 dari 6 ADC/11/04/07

15. Untuk dapat melakukan apa saja dengan model yang kita perlu menambahkan tindakan untuk itu. Buka File Manager> Proyek. Klik pada tab "Tambah". Gunakan menu drop-down untuk mengubah "Kelas" menjadi "PLAYER". Dalam menu di bawah pilih "Pemain Biped (01)". Klik "Script Tambahkan ==>>". Sekelompok skrip (kode objek komputer) yang diperlukan untuk menyediakan fungsionalitas untuk pemain orang pertama yang ditambahkan ke proyek tersebut. 16. Dalam cara yang sama, mengubah "Class" CAMERA ", pilih" Orang Kamera Pertama "Script dan klik" Tambah Script ==>>". Script yang diperlukan lainnya lagi secara otomatis ditambahkan ke proyek tersebut. Ini adalah komponen kode yang mengontrol apa yang dilihat oleh pemain. Tutup jendela Project Manager. 17. Kami telah menambahkan script ini untuk proyek dan sekarang kita perlu menambahkannya ke model pemain. Klik dan pilih model. Klik kanan pada model dan pilih Perilaku. Pilih "plBiped01", klik OK, dan tutup jendela itu. Simpan proyek. Kami sekarang memiliki model orang pertama dengan fungsi dasar. Jika Anda klik kanan pada model dan pilih "Properties" Anda akan melihat daftar parameter default untuk pemain (Kesehatan, Armor, dll). 18. Kami sekarang akan tekstur kubus cekung. Pertama, kita perlu menambahkan satu set tekstur untuk proyek. Klik pada tab "Tekstur", klik pada bar "default.wad", klik kanan di dalamnya dan pilih "Manajer Tekstur". Klik pada "WAD Tambah" dan Anda akan dibawa ke direktori segepok Gstudio6 \.Pilih "standard.wad" dan klik Open. Klik OK pada kotak dialog WAD. Sekarang ketika Anda mengklik pada tab Tekstur di kiri jendela utama, ada satu set tekstur dipilih. Klik pada bar standard.wad. 19. Hapus model (Edit Tidak> Pilih). Pilih kubus cekung. Pergi ke tab Tekstur dan klik ganda pada salah satu dari tekstur langit (mereka berada di bawah jendela standard.wad. Para seluruh blok mengambil tekstur langit. Periksa bahwa kubus memiliki atribut langit dengan mengklik kanan pada blok berongga, memilih properti, maka <blocks>, dan memeriksa bahwa kotak centang dicentang langit. Simpan proyek. 20. Waktu untuk melihat dunia kita. Membangun tingkat dengan mengklik ikon membangun. WED mengkompilasi proyek. Kemudian jalankan tingkat dengan mengklik ikon dijalankan. F: \ CCA \ 3DGS \ tutorial \ LATIHAN 1 \ 3D STUDIO PERTANDINGAN - LATIHAN 1.doc 4 dari 6 ADC/11/04/07 Untuk melihat tingkat dalam mode layar penuh tekan ALT + ENTER. 21. Anda harus melihat bagian dalam sebuah kotak besar tercakup dalam pola berputar - Anda tingkat pertandingan pertama! Ini OK jika lantai berwarna hitam. Tidak mengesankan, tapi kami belum selesai ... ... ..

22. Periksa bahwa gambar langit kubus Anda tersedia untuk digunakan dalam direktori kerja Anda. Ini harus dalam format ini: "nama file +6 tga.". +6 Memberitahu 3DGS bahwa gambar adalah sebuah dilipat enam sisi kubus langit. Catatan: Gambar kubus langit harus sesuai dengan persyaratan sebagai berikut: lebarnya harus enam kali lebih besar dari ketinggian. Setiap frame harus menjadi kekuatan dari 2 ukuran, seperti 512x512. Gambar kubus sisi harus diatur dalam urutan bk, rt, ft, Jika, dn, naik dari kiri ke kanan. 23. Sebuah fungsi kode mengontrol bagaimana kubus langit akan melilit kubus berongga. Fungsi ini harus ditambahkan ke script tingkat utama. Klik pada tab "Resources", kemudian rentangkan folder file script. Klik kanan pada script utama Anda (yang harus di bagian atas daftar dan menjadi sesuatu seperti "exercise1.wdl") dan pilih Buka. Script terbuka di script editor (SED). 24. Masukkan kode berikut setelah "termasuk" file dan sebelum "fungsi utama ()" / / Pertama saya langit kubus langit cubesky { type = <filename+6.tga>; lapisan = 1; materi = mat_sky; flag = kubus, terlihat; } Ganti nama file +6. Tga dengan nama kubus langit Anda. Klik simpan. Perhatikan bahwa dua garis miring ke depan menunjukkan sebuah komentar dalam kode yang diabaikan oleh compiler. 25. Kembali ke WED dan menyimpan proyek. Kemudian membangun dan kemudian jalankan tingkat. Langit dan daerah (jika ada dalam gambar kubus langit asli) akan muncul. F: \ CCA \ 3DGS \ tutorial \ LATIHAN 1 \ 3D STUDIO PERTANDINGAN - LATIHAN 1.doc 5 dari 6 ADC/11/04/07 F: \ CCA \ 3DGS \ tutorial \ LATIHAN 1 \ 3D STUDIO PERTANDINGAN - LATIHAN 1.doc 6 dari 6 26. Anda dapat melihat-lihat di langit dan di tingkat daerah Anda, tetapi tampaknya Anda tidak akan mampu bergerak. Hal ini karena kubus langit mengikuti pemain. Untuk melihat gerakan pemain kebutuhan untuk bergerak di permukaan atau bangunan. Ini akan menjadi bagian dari Latihan # 2.