Anda di halaman 1dari 11

17

Setting Mikrotik Untuk Speedy


Hehehehheh, sebelumnya saya minta maaf kalo lancang berani menulis setting mikrotik
untuk speedy, karena saya sendiri juga masih baru belajar. Akan tetapi mungkin dan
semoga sedikit tips yang saya dapetnya juga dari tutorial di blog masjitos.blogspot.com/
atau juga berdasarkan referensi tutorial - tutorial yang laen. Saya hanya memberikan
sedikit saja sebatas sebisa saya. Saya juga cuma kopi paste dari blog tersebut blog
masjitos, silahkan anda liat sendiri
Sebelumnya saya gambarkan dulu skema jaringannya:

LAN —> Mikrotik RouterOS —> Modem ADSL —> INTERNET

Untuk LAN, kita pake kelas C, dengan network 192.168.0.0/24. Untuk Mikrotik
RouterOS, kita perlu dua ethernet card. Satu (ether1 - 192.168.1.2/24) untuk
sambungan ke Modem ADSL dan satu lagi (ether2 - 192.168.0.1/24) untuk sambungan
ke LAN. Untuk Modem ADSL, IP kita set 192.168.1.1/24.

Sebelum mengetikkan apapun, pastikan Anda telah berada pada root menu dengan
mengetikkan “/” Set IP untuk masing² ethernet card
ip address add address=192.168.1.2/24 interface=ether1
ip address add address=192.168.0.1/24 interface=ether2

Untuk menampilkan hasil perintah di atas ketikkan perintah berikut:


/ip address print

Kemudian lakukan testing dengan mencoba nge-ping ke gateway atau ke komputer yg


ada pada LAN. Jika hasilnya sukses, maka konfigurasi IP Anda sudah benar ping
192.168.1.1
ping 192.168.0.10
Menambahkan Routing
ip route add gateway=192.168.1.1
Setting DNS
ip dns set primary-dns=202.134.1.10 allow-remote-requests=yes
ip dns set secondary-dns=202.134.0.155 allow-remote-requests=yes

Karena koneksi ini menggunakan Speedy dari Telkom, maka DNS yg aq pake ya punya
Telkom. Silahkan sesuaikan dengan DNS provider Anda. Setelah itu coba Anda lakukan
ping ke yahoo.com misalnya: ping yahoo.com Jika hasilnya sukses, maka settingan DNS
sudah benar Source NAT (Network Address Translation) / Masquerading Agar semua
komputer yg ada di LAN bisa terhubung ke internet juga, maka Anda perlu
menambahkan NAT (Masquerade) pada Mikrotik.
/ip firewall nat add
chain=srcnat
action=masquerade
out-interface=ether1
Sekarang coba lakukan ping ke yahoo.com dari komputer yang ada di LAN ping
yahoo.com Jika hasilnya sukses, maka setting masquerade sudah benar DHCP
(DynamicHost Configuration Protocol) Karena alasan supaya praktis, temenku pengin
pake DHCP Server. Biar klo tiap ada klien yang konek, dia ga perlu setting IP secara
manual. Tinggal obtain aja dari DHCP Server, beres dah. Untungnya Mikrotik ini juga
ada fitur DHCP Servernya. Jadi ya ga ada masalah..
Membuat IP Address Pool
/ip pool add name=dhcp-pool
ranges=192.168.0.2-192.168.0.254
Menambahkan DHCP Network
ip dhcp-server network add address=192.168.0.0/24
gateway=192.168.0.1
dns-server=202.134.1.10,202.134.0.155

Menambahkan Server DHCP


/ip dhcp-server add name=DHCP_LAN
disabled=no
interface=ether2
address-pool=dhcp-pool

Sekarang coba lakukan testing dari komputer klien, untuk me-request IP Address dari
Server DHCP. Jika sukses, maka sekali lagi, settingannya udah bener Bandwidth
Control Agar semua komputer klien pada LAN tidak saling berebut bandwidth, maka
perlu dilakukan yg namanya bandwidth management atau bandwidth control Model yg
saya gunakan adalah queue trees. Untuk lebih jelas apa itu, silahkan merujuk ke
situsnya Mikrotik Kondisinya seperti ini: Koneksi Speedy kan katanya speednya sampe
384/64 Kbps (Download/Upload), nah kondisi itu sangat jarang tercapai. Jadi kita
harus cari estimasi rata²nya. Maka saya ambil minimalnya untuk download bisa dapet
sekitar 300 Kbps dan untuk upload aq alokasikan 50 Kbps. Sedangkan untuk yg
maksimumnya, untuk download kira² 380 Kbps dan upload 60 Kbps. Lalu, jumlah
komputer klien yang ada saat ini adalah 10 buah. Jadi harus disiapkan bandwidth itu
untuk dibagikan kepada 10 klien tersebut. Perhitungan untuk masing² klien seperti ini:
Minimal Download: 300 / 10 * 1024 = 30720 bps Maximal Download: 380 / 10 * 1024 =
38912 bps Minimal Upload: 50 / 10 * 1024 = 5120 bps Maximal Upload: 60 / 10 * 1024
= 6144 bps Selanjutnya kita mulai konfigurasinya:

Tandai semua paket yg asalnya dari LAN


/ip firewall mangle add src-address=192.168.0.0/24
action=mark-connection
new-connection-mark=Clients-con
chain=prerouting
/ip firewall mangle add
connection-mark=Clients-con
action=mark-packet
new-packet-mark=Clients
chain=prerouting
Menambahkan rule yg akan membatasi kecepatan download dan upload
/queue tree add
name=Clients-Download
parent=ether2
packet-mark=Clients
limit-at=30720
max-limit=38912
/queue tree add name=Clients-Upload
parent=ether1
packet-mark=Clients
limit-at=5120 max-limit=6144

Sekarang coba lakukan test download dari beberapa klien, mestinya sekarang tiap2
klien akan berbagi bandwidthnya. Jika jumlah klien yg online tidak sampai 10, maka
sisa bandwidth yang nganggur itu akan dibagikan kepada klien yg online. Graphing
Mikrotik ini juga dilengkapi dengan fungsi monitoring traffic layaknya MRTG biasa.
Jadi kita bisa melihat berapa banyak paket yg dilewatkan pada PC Mikrotik kita. tool
graphing set store-every=5min Berikutnya yang akan kita monitor adalah paket² yg
lewat semua interface yg ada di PC Mikrotik kita, klo di komputerku ada ether1 dan
ether2.
/tool graphing interface add-interface=all store-on-disk=yes

Sekarang coba arahkan browser anda ke IP Router Mikrotik. Klo aq di sini:


http://192.168.0.1/graphs/ Nanti akan ada pilihan interface apa aja yg ada di router
Anda. Coba klik salah satu, maka Anda akan bisa melihat grafik dari paket2 yg lewat
pada interface tersebut. Dari tutorial diatas saya cuma sampai mengambil langkah pada
setting penambahan NAT ( masquerade ) saja. Karena menurut saya DHCP yang
sifatnya berubah ubah jadi nanti saat mau limit BW nya terkadang ip tidak sama.
CMIIW. dan untuk setting limit saya melakukannya pada remote winbox yang lebih
mudah, nah pertanyaan untuk saya sendiri. Kapan graph tool nya kamu install nak ?
hehehhee... ok semoga berguna semuanya.

SPEEDY DENGAN MIKROTIK ROUTERS

Ditulis oleh abu aisyah di/pada Juli 15 , 2007


MikroTik RouterOS? adalah sistem operasi dan perangkat lunak yang dapat digunakan untuk
menjadikan komputer manjadi router network yang handal, mencakup berbagai fitur yang dibuat
untuk ip network dan jaringan wireless, cocok digunakan oleh ISP dan provider hostspot.
Kemarin, ada temen yg minta tolong di-setting-kan PC routernya. Dia pake Mikrotik RouterOS.
Aq juga ga tau knapa kok dia milih Mikrotik.. Aneh² ae.. Klo untuk Linux seh aq udah biasa
pake + nyetting, tapi klo yg namanya Mikrotik blom pernah sama sekali. Tapi menurutku paling
ya gitu² aja kaya Linux OS yg laen.. Ya udah aq sanggupin aja..
Oia, aq ga akan mbahas gmn cara instalasinya Mikrotik RouterOS. Jadi untuk instalasinya
silahkan merujuk ke situsnya Mikrotik.
Sampai di lokasi, aq coba ngeliat seperti apa seh Mikrotik itu Seperti biasa, klo pertama kali aq
berhadapan dengan console, perintah pertama yg aq ketikkan adalah ls untuk ngeliat isinya
direktori. Tapi apa hasilnya? Ternyata perintah ls ga dikenali di Mikrotik.. Aq coba perintah²
Linux laennya, hasilnya jg sama, ga dikenali. Hmm.. Trus aq coba tekan tombol TAB, voila..
Terus kluar sederetan perintah² gitu.. Ternyata fungsinya sama kaya bash completion di Linux..
Aq liat isinya.. Ohh.. Ternyata gini toh Mikrotik itu.. Aq coba ketik ip, maka kita langsung masuk
ke sub menu ip. Aq tekan TAB lagi, trus aq ketik address, tekan tombol ENTER, maka langsung
masuk ke sub menu ip address. Terus aq coba ketik “..” (without quotes) ternyata langsung
kembali ke sub menu ip lagi. Ohh.. I see.. Jadi gini ya.. Klo misal dari sub menu apapun dan kita
pengin kembali ke root menu, langsung ketik aja “/“.
Oke.. Aq rasa perkenalannya udah cukup. Sekarang saatnya kita “menggarap” si Mikrotik ini
biar bisa berfungsi sebagaimana yg diharapkan..
Sebelumnya saya gambarkan dulu skema jaringannya:
LAN —> Mikrotik RouterOS —> Modem ADSL —> INTERNET
Untuk LAN, kita pake kelas C, dengan network 192.168.0.0/24. Untuk Mikrotik RouterOS, kita
perlu dua ethernet card. Satu (ether1 - 192.168.1.2/24) untuk sambungan ke Modem ADSL dan
satu lagi (ether2 - 192.168.0.1/24) untuk sambungan ke LAN. Untuk Modem ADSL, IP kita set
192.168.1.1/24.
Sebelum mengetikkan apapun, pastikan Anda telah berada pada root menu dengan mengetikkan
“/”
Set IP untuk masing²ethernet card
ip address add address=192.168.1.2/24 interface=ether1
ip address add address=192.168.0.1/24 interface=ether2
Untuk menampilkan hasil perintah di atas ketikkan perintah berikut:
ip address print
Kemudian lakukan testing dengan mencoba nge-ping ke gateway atau ke komputer yg ada pada
LAN. Jika hasilnya sukses, maka konfigurasi IP Anda sudah benar
ping 192.168.1.1
ping 192.168.0.10
Menambahkan Routing
ip route add gateway=192.168.1.1
Setting DNS
ip dns set primary-dns=202.134.1.10 allow-remote-requests=yes
ip dns set secondary-dns=202.134.0.155 allow-remote-requests=yes
Karena koneksi ini menggunakan Speedy dari Telkom, maka DNS yg aq pake ya punya Telkom.
Silahkan sesuaikan dengan DNS provider Anda.
Setelah itu coba Anda lakukan ping ke yahoo.com misalnya:
ping yahoo.com
Jika hasilnya sukses, maka settingan DNS sudah benar
Source NAT (Network Address Translation) / Masquerading
Agar semua komputer yg ada di LAN bisa terhubung ke internet juga, maka Anda perlu
menambahkan NAT (Masquerade) pada Mikrotik.
ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
Sekarang coba lakukan ping ke yahoo.com dari komputer yang ada di LAN
ping yahoo.com
Jika hasilnya sukses, maka setting masquerade sudah benar
DHCP (DynamicHost Configuration Protocol)
Karena alasan supaya praktis, temenku pengin pake DHCP Server. Biar klo tiap ada klien yang
konek, dia ga perlu setting IP secara manual. Tinggal obtain aja dari DHCP Server, beres dah.
Untungnya Mikrotik ini juga ada fitur DHCP Servernya. Jadi ya ga ada masalah..
Membuat IP Address Pool
ip pool add name=dhcp-pool ranges=192.168.0.2-192.168.0.254
Menambahkan DHCP Network
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-
server=202.134.1.10,202.134.0.155
Menambahkan Server DHCP
ip dhcp-server add name=DHCP_LAN disabled=no interface=ether2 address-pool=dhcp-pool
Sekarang coba lakukan testing dari komputer klien, untuk me-request IP Address dari Server
DHCP. Jika sukses, maka sekali lagi, settingannya udah bener
Bandwidth Control
Agar semua komputer klien pada LAN tidak saling berebut bandwidth, maka perlu dilakukan yg
namanya bandwidth management atau bandwidth control
Model yg saya gunakan adalah queue trees. Untuk lebih jelas apa itu, silahkan merujuk ke
situsnya Mikrotik
Kondisinya seperti ini:
Koneksi Speedy kan katanya speednya sampe 384/64 Kbps (Download/Upload), nah kondisi itu
sangat jarang tercapai. Jadi kita harus cari estimasi rata²nya. Maka saya ambil minimalnya untuk
download bisa dapet sekitar 300 Kbps dan untuk upload aq alokasikan 50 Kbps. Sedangkan
untuk yg maksimumnya, untuk download kira² 380 Kbps dan upload 60 Kbps.
Lalu, jumlah komputer klien yang ada saat ini adalah 10 buah. Jadi harus disiapkan bandwidth
itu untuk dibagikan kepada 10 klien tersebut.
Perhitungan untuk masing² klien seperti ini:
Minimal Download: 300 / 10 * 1024 = 30720 bps\
Maximal Download: 380 / 10 * 1024 = 38912 bps
Minimal Upload: 50 / 10 * 1024 = 5120 bps
Maximal Upload: 60 / 10 * 1024 = 6144 bps
Selanjutnya kita mulai konfigurasinya:
Tandai semua paket yg asalnya dari LAN
ip firewall mangle add src-address=192.168.0.0/24 action=mark-connection new-connection-
mark=Clients-con chain=prerouting
ip firewall mangle add connection-mark=Clients-con action=mark-packet new-packet-
mark=Clients chain=prerouting
Menambahkan rule yg akan membatasi kecepatan download dan upload
queue tree add name=Clients-Download parent=ether2 packet-mark=Clients limit-at=30720
max-limit=38912
queue tree add name=Clients-Upload parent=ether1 packet-mark=Clients limit-at=5120 max-
limit=6144
Sekarang coba lakukan test download dari beberapa klien, mestinya sekarang tiap2 klien akan
berbagi bandwidthnya. Jika jumlah klien yg online tidak sampai 10, maka sisa bandwidth yang
nganggur itu akan dibagikan kepada klien yg online.
Graphing
Mikrotik ini juga dilengkapi dengan fungsi monitoring traffic layaknya MRTG biasa. Jadi kita
bisa melihat berapa banyak paket yg dilewatkan pada PC Mikrotik kita.
tool graphing set store-every=5min
Berikutnya yang akan kita monitor adalah paket² yg lewat semua interface yg ada di PC Mikrotik
kita, klo di komputerku ada ether1 dan ether2.
tool graphing interface add-interface=all store-on-disk=yes
Sekarang coba arahkan browser anda ke IP Router Mikrotik. Klo aq di sini:
http://192.168.0.1/graphs/
Nanti akan ada pilihan interface apa aja yg ada di router Anda. Coba klik salah satu, maka Anda
akan bisa melihat grafik dari paket2 yg lewat pada interface tersebut.
Wew.. Akhirnya selesai juga perkenalan kita dengan Mikrotik RouterOS Silahkan Anda
simpulkan sendiri. Menurut Anda enak mana, pake Mikrotik atau pake Linux biasa? Klo aq seh
mending pilih Linux, soalnya udah biasa.. Tapi Mikrotik juga lumayan kok.. Meski awalnya
rada² bingung ama command²nya..
Setting dan konfigurasi Router Mikrotik

LAN —> Mikrotik RouterOS —> Modem ADSL —> INTERNET

Untuk LAN, kita menggunakan ip address class C, dengan network


192.168.10.0/24. Untuk Mikrotik RouterOS, kita perlu dua ethernet card. Satu
(ether1 - 192.168.1.2/24) untuk sambungan ke Modem ADSL dan satu lagi (ether2
- 192.168.10.1/24) untuk sambungan ke LAN. Untuk Modem ADSL, IP kita set
192.168.1.1/24.

Sebelum mengetikkan apapun, pastikan Anda telah berada pada root menu dengan
mengetikkan “/”

1. Set IP untuk masing² ethernet card

Kutip
ip address add address=192.168.1.2/24 interface=ether1 (public)

ip address add address=192.168.10.1/24 interface=ether2 (local)

Untuk menampilkan hasil perintah di atas ketikkan perintah berikut:

ip address print

Kemudian lakukan testing dengan mencoba nge-ping ke gateway atau ke komputer


yg ada pada LAN. Jika hasilnya sukses, maka konfigurasi IP Anda sudah benar

Kutip
ping 192.168.1.1

ping 192.168.10.10

2. Menambahkan Routing

ip route add gateway=192.168.1.1

3. Setting DNS

Kutip
ip dns set primary-dns=202.134.1.10 allow-remote-requests=yes
ip dns set secondary-dns=202.134.0.155 allow-remote-requests=yes

Karena koneksi ini menggunakan Speedy dari Telkom, maka DNS yg aq pake ya
punya Telkom. Silahkan sesuaikan dengan DNS provider Anda.

Setelah itu coba Anda lakukan ping ke yahoo.com misalnya:

ping yahoo.com

Jika hasilnya sukses, maka settingan DNS sudah benar

4. Source NAT (Network Address Translation) / Masquerading

Agar semua komputer yg ada di LAN bisa terhubung ke internet juga, maka Anda
perlu menambahkan NAT (Masquerade) pada Mikrotik.

ip firewall nat add chain=srcnat action=masquerade out-interface=ether1

Sekarang coba lakukan ping ke yahoo.com dari komputer yang ada di LAN

ping yahoo.com

Jika hasilnya sukses, maka setting masquerade sudah benar

5. DHCP (Dynamic Host Configuration Protocol)

Karena alasan supaya praktis, temenku pengin pake DHCP Server. Biar klo tiap ada
klien yang konek, dia ga perlu setting IP secara manual. Tinggal obtain aja dari
DHCP Server, beres dah. Untungnya Mikrotik ini juga ada fitur DHCP Servernya. Jadi

ya ga ada masalah..

* Membuat IP Address Pool

ip pool add name=dhcp-pool ranges=192.168.0.2-192.168.0.254

* Menambahkan DHCP Network

ip dhcp-server network add address=192.168.10.0/24 gateway=192.168.10.1 dns-


server=202.134.1.10,202.134.0.155

* Menambahkan Server DHCP

ip dhcp-server add name=DHCP_LAN disabled=no interface=ether2address-


pool=dhcp-pool

Sekarang coba lakukan testing dari komputer klien, untuk me-request IP Address
dari Server DHCP. Jika sukses, maka sekali lagi, settingannya udah bener

6. Management Bandwidth

Agar semua komputer klien pada LAN tidak saling berebut bandwidth, maka perlu
dilakukan yg namanya bandwidth management atau bandwidth control, idea: (saya
menggunakan simple queue supaya lebih mudah ;

Kutip
queue simple add name=”Billing” target-address=192.168.10.2/32 dst-address=0.0.0.0/0
interface=Local queue=default priority=8 limit-at=16000/32000 max-limit=16000/64000

queue simple add name=”Kasir” target-addresses=192.168.10.3/32 dst-address=0.0.0.0/0


interface=Local parent=Shaping priority=8 queue=default/default limit-at=0/8000 max-
limit=0/256000 total-queue=default

Lanjutkan perintah tersebut untuk semua client yang ingin di limit bandwidth nya.

7. Graphing

Mikrotik ini juga dilengkapi dengan fungsi monitoring traffic layaknya MRTG biasa.
Jadi kita bisa melihat berapa banyak paket yg dilewatkan pada PC Mikrotik kita.

tool graphing set store-every=5min

Berikutnya yang akan kita monitor adalah paket² yg lewat semua interface yg ada
di PC Mikrotik kita, klo di komputerku ada ether1 dan ether2.

tool graphing interface add interface=all store-on-disk=yes

Sekarang coba arahkan browser anda ke IP Router Mikrotik. Klo aq di sini:

http://192.168.10.1/graphs/

Nanti akan ada pilihan interface apa aja yg ada di router Anda. Coba klik salah
satu, maka Anda akan bisa melihat grafik dari paket2 yg lewat pada interface
tersebut.
Setting Mikrotik RouterOS PPPoE Client Sebagai Internet Gateway
Telkom Speedy
Kita mulai setup dari modem adsl nya sebagai brigding protocol mode. Settingnya dapat anda
temukan dari manual masing-masing modem. Contoh setting bridging protocol pada modem TECOM
AR1031 pada menu Advance setup > WAN.

Ikuti petunjuk gambar dibawah ini kemudian lakukan save/reboot.

Selesai setting modem sebagai bridging yang tidak menyimpan password dan user ID anda di modem,
bagi anda yang ingin mencoba mengganti IP address default modem bisa di konfigurasi terlebih
dahulu melalui PC client.
Caranya : kita ubah terlebih dahulu IP modem pada Advance Setup > LAN IP Address contoh
192.168.100.1 lakukan save/reboot. Kemudian lakukan pengubahan selanjutnya di IP client PC ke
192.168.100.2 selesai. Silahkan anda coba ketik di web browser anda IP modem (192.168.100.1).
Berhasil?
Kita lanjut ke CPU Mikrotik RouterOS nya.
Tentukan IP Address masing-masing LAN card anda, misal LAN connector dari modem
202.202.202.202 (public), dan 192.168.100.1 ke jaringan lokal anda (lokal). Lakukan perintah ini
terlebih dahulu jika anda ingin menspesifikasikan nama ethernet card anda.
/interface ethernet set ether1 name=public
/interface ethernet set ether2 name=lokal
Pastikan kembali dalam menentukan nama dan alur kabel tersebut, kemudian kita lanjut ke setting IP
Address.
/ip address add address=202.x.x.x/24 interface=public
/ip address add address=192.168.100.1/24 interface=local
/ip address> print
Pastikan LAN card anda tidak dalam posisi disabled. Selanjutnya anda bisa memasukkan entry PPPoE
Client.
/interface pppoe-client add name=pppoe-user-mike user=mike password=123 interface=public
service-name=internet disabled=no
Sebetulnya perintah diatas dapat anda lakukan di winbox, jika ingin lebih mudah sambil cek koneksi
jaringan anda ke mikrotik. Menentukan Gateway dan Routingnya dilanjutkan ke masquerading
/ip route add gateway=125.168.125.1 (IP Gateway Telkom Speedy anda)
/ip route print
IP gateway diatas belum tentu sama, lihat terlebih dahulu ip PPPoE client anda. Jika anda belum yakin
100% ip client anda dan gateway nya, lakukan login dan dialing melalui modem anda terlebih dahulu
bukan pada mode bridging seperti diatas. Pada menu Device Info akan tampil informasi Default
Gateway dan IP client pppoe anda. Ok?
Selanjutnya masquerading, untuk penerusan perintah dari routing yang diteruskan ke nat firewall
mikrotik untuk proses routing ke semua client yang terkoneksi
/ip firewall nat add chain=srcnat action=masquerade
Selesai.. tahap routing sudah terlaksanakan. Coba lakukan ping ke mikrotik dan gateway nya. Jika
anda ingin sharing ke komputer client jangan lupa masukkan ip gateway pada settingan Network
Connection (windows) sesuai dengan IP lokal pada mikrotik anda.
Banyak sekali settingan mikrotik yang dapat anda pelajari dari berbagai sumber. Jika terkesan terlalu
rumit dengan sistem pengetikan anda bisa melakukannya dengan winbox mode, setiap tutorial yang
anda butuhkan pun dapat anda copy dan paste ke winbox nya mikrotik.
Setting DNS dan Web Proxy Transparant
Input DNS dan web-proxy pun terasa lebih mudah di winbox mode, masukkan primary, secondary dan
allow remote request nya, atau dengan perintah di terminal winbox.
/ip dns set primary-dns=203.130.206.250
/ip dns set primary-dns=202.134.2.5
/ip dns allow-remote-request=yes
/ip web-proxy set enabled=yes port=8080 hostname=proxy.koe transparent-proxy=yes
/ip firewall nat add in-interface=lokal dst-port=80 protocol=tcp action=redirect to-ports=8080
chain=dstnat dst-address=!192.168.100.1/24
Semoga membantu.
Dari : Jags Blog