Anda di halaman 1dari 20

Materi Modul

Microsoft Access
Get External Data

Microsft Access adalah program aplikasi pengolahan basis data yang merupakan bagian dari Microsoft Office. Paket program ini merupakan sistem manajemen database relasional untuk Microsoft Windows yang memiliki kemampuan untuk menyortir, mengatur serta melaporkan informasi penting yang dibutuhkan. Dengan adanya versi yang terus diperbaharuhi ini Access semakin dilengkapi dengan fasilitas-fasilitas penting seperti interaksi dengan Internet.

Database Access disimpan ke dalam sebuah file yang berekstensi mdb. Sebuah file database terdiri dari bagian-bagian yaitu : Tables, Queries, Forms, Reports, Pages, Macros, dan Modules.

Tabel adalah sekumpulan data atau informasi spesifik tentang subjek tertentu yang disusun dalam bentuk kolom dan baris. Tabel merupakan komponen utama dan pertama dari sebuah database yang harus dibuat.

Kolom atau yang lebih dikenal dengan istilah field berisi judul yang mewakili sekumpulan baris. Sedangkan baris atau yang lebih dikenal dengan istilah record berisi kumpulan data yang memiliki karakteristik pengertian yang sama. Jadi satu record mewakili mewakili satu data atau informasi tentang suatu entitas subjek secara lengkap.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

Micosoft Access mempunyai kemampuan untuk memindahkan isi sebuah file dari beberapa aplikasi, seperti Excel, SQL, HTML, dBASE, Paradox, Microsoft Outlook, dan sebagainya menjadi tabel dalam file mdb.Perhatikan gambar di bawah ini.

EXCEL

HTML

SQL

dBASE

Paradox

.mdb
Tabel

Get External Data merupakan sebuah fungsi built-in yang sudah disediakan oleh Microsoft Access untuk mengimport data masukan. Data masukan yang harus disiapkan harus dalam bentuk tabel.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

TUTORIAL 11-1 MEMAHAMI PROSEDUR PENGOPERASIAN APLIKASI

Untuk memulai microsoft Access pada dasarnya hampir sama antara Task bar Windows 95 2000 yaitu dimulai dengan tombol Start Program Pilih Program MS-Access .

LEMBAR KERJA MS- ACCESS Pada saat anda pertama kali menjalankan microsoft Access maka akan tampil kotak dialog dimana memungkinkan anda dapat membuat data base baru dengan dua cara 1. Blank Access Database 2. Access database Wizards. Pages end Projects dan adalagi pilihan yang disediakan yaitu 3. Open Existing File.

dbImport.mdb

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

TUTORIAL 11-2 MEMPERSIAPKAN APLIKASI DATA MASUKAN


A. Data Masukan dari Excel Menyiapkan Data Excel Langkah-langkah a. Membuat Aplikasi Microsoft Excel

b. Simpanlah tabel dengan menggunakan salah satu perintah berikut Dari menu file klik Save dan beri nama filenya DataPenjualan.xls Pada Toolbar desain Klik Tombol save atau tekan Kombinasi tombol Ctrl + S c. Untuk menutup Microsoft Excel dapat menggunakan alternatif perintahnya sebagai berikut Perintah Close dari menu file Klik Ctrl Menu dan pilih perintah Close, Klik Ganda pada Ctrl menu klik tombol Close tekan tombol Ctrl + F4 Dalam penyiapan data masukan file Microsoft Excel yang harus diperhatikan adalah : Record data yang pertama harus diletakkan pada Row pertama. Penulisan Field harus menghindari tanda spasi atau tanda baca.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

10

B. Data Masukan dari HTML Menyiapkan Data HTML Langkah-langkah a. Membuat Aplikasi HTML

Tag ini menjadi Nama Tabels

Tag ini menjadi data Tabels

b. Simpanlah tag HTML tersebut dengan cara Dari menu klik File - Save Tekan Kombinasi tombol Ctrl + S

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

11

c. Untuk menjalankan aplikasi HTML dengan menggunakan Browser, misalnya Internet Explorer Klik Start - Program pilih Internet Explorer Klik File - Open - Browse pilih lokasi file - .html

d. Untuk menutup Internet Explorer dapat menggunakan alternatif perintahnya sebagai berikut Perintah Close dari menu file Klik Ctrl Menu dan pilih perintah Close, Klik Ganda pada Ctrl menu klik tombol Close tekan tombol Ctrl + F4

Dalam penyiapan data masukan file HTML yang harus diperhatikan adalah tag HTML yang dapat diimport adalah : Data yang ada dalam <tabel> <\tabel> Data yang ada dalam <title><\title>

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

12

TUTORIAL 11-3 MEMINDAH DATA MASUKAN MENJADI DATA APLIKASI


A. Mengimpor Data dari Excel Langkah-langkah c. Klik menu File Get External Data pilih Import

d. Pada kotak Files of type, pilih Microsoft Excel, tentukan lokasi file dan folder pada kotak Look In.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

13

e. Klik Import. Kotak dialog Import Spreadsheet Wizard akan muncul, pilih Show Worksheet, lalu klik Next

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

14

f. Klik tombol radio First Row Contains Heading. Klik Next.

g. Selanjutnya tentukan lokasi penyimpanan tabel. Pilih In a New Table untuk menyimpan hasil pengimporan ke tabel baru. Klik Next.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

15

h. Selanjutnya akan ditampilkan untuk memberikan konfirmasi data yang Anda impor ke tabel DataPenjualan.

i. Kotak wizard selanjutnya adalah menentukan primary key dalam tabel data. Pilihlah No primary key

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

16

j. Langkah terakhir adalah dengan menekan button Finish

k. Berikut ini hasil import data file Excel menjadi sebuah tabel dalam file access . mdb

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

17

B. Mengimpor Data dari HTML Langkah-langkah a. Klik menu File Get External Data pilih Import

b. Pada kotak Files of type, pilih HTML Documents, tentukan lokasi file dan folder pada kotak Look In.

c. Klik tombol radio First Row Contains Heading. Klik Next.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

18

d. Selanjutnya tentukan lokasi penyimpanan tabel. Pilih In a New Table untuk menyimpan hasil pengimporan ke tabel baru. Klik Next.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

19

e. Selanjutnya akan ditampilkan untuk memberikan konfirmasi data yang Anda impor ke tabel DataPenjualan.

f. Kotak wizard selanjutnya adalah menentukan primary key dalam tabel data. Pilihlah No primary key

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

20

g. Langkah terakhir adalah dengan menekan button Finish

h. Berikut ini hasil import data file HTML menjadi sebuah tabel dalam file access . mdb

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

21

TUTORIAL 11-4 MENGECEK HASIL ENTRY DATA


Setelah data dimasukkan program database diperiksa proses pemindahan dan pemasukan data apakah sesuai dengan prosedur atau intruksi kerja Memilah hasil pemindahan dan pemasukan data sesuai dengan prosedur dan intruksi kerja. Mengidentifikasi keberhasilan pemindahan dan pemasukan data kedalam program data base dari file data ke media penyimpan data

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

22

TUTORIAL 11-5 MENGISI CHECK LIST ENTRY DATA


Mengidentifikasi langkah-langkah operasional dan keberhasilan proses pemindahan dan pemasukan data Mengatur Design Repot dalam sebuah lembar kerja Preview mengubah teksteks yang terdapat didalam lembar kertja design tersebut agar menjadi diskristif dan memindahkan label sehingga dapat tampil sejajar dengan Ctrl Ctrl yang lain. Menambahkan bebrapa informasi lain dibagian Footer.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

23

TUTORIAL 11 - 6 EVALUASI PRAKTIKUM


1. Perhatikan data-data dalam tabel di bawah ini !

DATA GURU SMK JAYA ABADI


NIP NAMA 131020132 Agus Kartika 131020133 Budi Setiawan 131020156 Lica Ayunda GOLONGAN NO_TELPON III B 0341-34782 III A 031-763812 III A 0343-988288 ALAMAT Malang Surabaya Pasuruan

Petunjuk Praktikum : Gunakan Microsoft Excel untuk menyimpan data di atas sebagai data masukan. Pindahkan File Excel(.xls) tersebut menjadi File Access ( .mdb) Periksa apakah data yang di import ada perubahan atau tidak. o Jika ada perubahan data --> Proses pemindahan data gagal. o Jika tidak berubah --> Proses pemindahan berhasil. 2. Perhatikan data Internet Explorer di bawah ini !

Petunjuk Praktikum : Gunakan Tag HTML untuk membuat tampilan di atas sebagai data masukan. Pindahkan File HTML(.html) tersebut menjadi File Access ( .mdb) Periksa apakah data yang di import ada perubahan atau tidak. o Jika ada perubahan data --> Proses pemindahan data gagal. o Jika tidak berubah --> Proses pemindahan berhasil.

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

24

Ringkasan Modul
PROSEDUR PENGOPERASIAN APLIKASI Untuk memulai microsoft Access pada dasarnya hampir sama antara Task bar Windows 95 2000 yaitu dimulai dengan tombol Start Program Pilih Program MS-Access . MEMPERSIAPKAN APLIKASI DATA MASUKAN
Data Masukan dari Excel

Dalam penyiapan data masukan file Microsoft Excel yang harus diperhatikan adalah : Record data yang pertama harus diletakkan pada Row pertama. Penulisan Field harus menghindari tanda spasi atau tanda baca.
Data Masukan dari HTML

Dalam penyiapan data masukan file HTML yang harus diperhatikan adalah tag HTML yang dapat diimport adalah data yang ada dalam tabel

MEMINDAH DATA MASUKAN MENJADI DATA APLIKASI Micosoft Access mempunyai kemampuan untuk memindahkan isi sebuah file dari beberapa aplikasi, seperti Excel, SQL, HTML, dBASE, Paradox, Microsoft Outlook, dan sebagainya menjadi tabel dalam file mdb.Get External Data merupakan sebuah fungsi built-in yang sudah disediakan oleh Microsoft Access untuk mengimport data masukan. Data masukan yang harus disiapkan harus dalam bentuk tabel.

MENGECEK HASIL ENTRY DATA


Setelah data dimasukkan program database diperiksa proses pemindahan dan pemasukan data apakah sesuai dengan prosedur atau intruksi kerja

MENGISI CHECK LIST ENTRY DATA


Mengidentifikasi langkah-langkah operasional dan keberhasilan proses pemindahan dan pemasukan data

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

25

Daftar Pustaka
1. Budi Permana, 36 Jama Belajar Komputer Microsoft Access 2000 ,Cetakan V, Elek Media Komputindo, Jakarta,2000 2. Hengky W.Pramana, Aplikasi Penjualan Berbasis Access(97/2000/XP) Elek Media Komputindo, Jakarta,2004 3. Yuswanto,Panduan Belajar Pustaka Surabaya,2001 SQL Microsoft Access 2002,Prestasi

Modul: Memindahkan isi sebuah file menjadi data aplikasi dengan menggunakan utilitas aplikasi

26

Anda mungkin juga menyukai