P. 1
Visual Foxpro 9

Visual Foxpro 9

|Views: 645|Likes:
Dipublikasikan oleh dhaneps

More info:

Published by: dhaneps on Feb 03, 2012
Hak Cipta:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

12/29/2012

pdf

text

original

MICROSOFT VISUAL FOXPRO 9.

0

Foxpro

Foxbase

Dbase

Visual Foxpro

Foxpro adalah sebuah Sistem Database Manajemen (Database Manajement System/DMBS) elektronik, yang berfungsi untuk mengumpulkan, mengambil dan menampilkan data. Visual Foxpro adalah bahasa pemrograman visual yang berorientasi pada obyek (Obyek Oriented Programming/OOP) dan juga sebagai Sistem Manajemen Database Relasional (RDMS/Sistem Basis Data). Project Manajer : Untuk mengatur pengembangan, integrasi dan pembuatan aplikasi. Yang dinamakan project adalah kumpulan file, data, dokumen dan obyek yang digunakan dalam Visual Foxpro 6.0 dan mempunyai ekstensi .PJX. Project Manajer memudahkan pemakai untuk mengatur dan mengorganisasikan database, tabel, form, laporan dan query selama pembuatan aplikasi. Database Tabel View : : : Kumpulan dari tabel, view, dan connection. File database berekstensi .DBC Tempat penyimpanan data (berekstensi .DBF) Tabel yang dibentuk dengan mengambil sebagian/seluruh field dari satu/beberapa tabel/view lain. Connection : Penghubung antara tabel dengan data dari sumber lain yang formatnya berbeda (seperti : MS. Acces, Oracle, SQL.Excel, Paradox, dll).

Tabel pada Visual Foxpro dibedakan menjadi dua macam : 1. 2. Tabel yang menjadi bagian suatu database Tabel yang tidak menjadi bagian dari suatu database (tabel bebas).

Untuk menambah record : Append Untuk memodifikasi tabel : modi stru Pindah baris Mis: go top >>pindah ke baris paling atas Go bottom>>pindah baris paling bawah Goto 1 >>pindah baris ke 1 Skip >>loncat 1 baris ke bawah Skip -1 >>loncat 1 baris ke atas Locate >> untuk meletakkan pointer ke record yang dicari Mis : locate for alamat=”Jakarta” ?recno() Untuk menghapus tabel : delete Mis: goto 2 >> menuju record yang akan di hapus ,adalah record 2 Delete Untuk membatalkan hapusan ketik recall Untuk menhapus secara permanent ketik pack Menempatkan record menggunakan replace Mis : goto 3 Replace telepon with “88796456” Jika ingin menempatkan semuanya maka gunakan replace all Mis: replace all telepon with ”88957654” Menempatkan isi record dengan criteria dengan perintah replace all jurusan with iif…. Untuk mengisi jurusan gunakan criteria berdasarkan nim (2 karakter sebelah kiri sebanyak 2 >>left), kanan>>right, tengan>>substr Mis : replace all jurusan with iif(left(nim,2)=”11”,”KA”,iif(left(nim,2)=”12”,”MI”,”TK”)) Untuk melihat data gunakan kata list Melihat data nim saja >> list nim Melihat data yang nim nya “1237922” >> list nim for “12037922” Membuat index use mhs index on nim to mhs mencari data berdasarkan index set order to tag nim seek "12037922" ?found() Contoh: Buatlah Sebuah Table Bebas Dengan Menggunakan Command Window dengan nama mhs.dbf

Command Window
Command Window adalah suatu jendela yang digunakan mengetikkan suatu barisan perintah pada Ms.Visual Foxpro. Adapun cara menampilkannya : Klik menu Window pada Menu Bar Lalu pilih Command Window atau tekan secara bersamaan <Ctrl + F2>. Perintah-perintah dasar Menggunakan Command Window dalam Ms.Visual Foxpro: 1. 2. 3. 4. 5. Membuat sebuah project => ketikkan perintah Create project pada Command Window, lalu simpan. Membuat sebuah database => ketikkan perintah Create Database pada Command Window, lalu simpan. Membuat sebuah table => ketikkan perintah Create pada Command Window, lalu simpan. Membuat sebuah form => ketikkan perintah Create Form pada Command Window. Membuat sebuah laporan => ketikkan perintah Create Report pada Command Window.

1.

Isi Fieldnya Nama Field Nim Nama Alamat Jurusan

Tipe Character Character Character Character

Width 8 30 35 5

Desimal

Index Ascending

Indexes

2.

Isi Data Sebanyak 5 Record Nim Nama 12054965 Budi 11024856 Anita 13258896 Dedi 11202563 Nina 13205255 Anto

Alamat Jakarta Bandung Tanggerang Bekasi Jakarta

Jurusan MI KA TK KA TK

Memodifikasi tabel:

Jawab: Membuat directory dengan MD (make directory)

isi data. New Form Properties . OK Isi Datanya =>ketikkan perintah Append pada Command Window. tekan <Ctrl + W> untuk menyimpan sekaligus keluar. ToolBox Form . Untuk melihat hasilnya ketikkan perintah Browse pada Command Window.1.Misal : MD C:\Latihan Mengaktifkan folder yang telah dibuat dengan CD (change directory) Misal : CD C:\Latihan Membuat Tabel Misal : Create mhs Isi Fieldnya. BEKERJA DENGAN FORM Membuat form dengan cara mengetikan perintah create form [Nama Form] pada jendela Command atau dari Klik Menu File>New>Pilih Form>Klik New File Gambar 2.

dbf Field Kodebar Namabar Harga Jumbar Ketik kode ini Type Character Character Numeric Numeric Width 6 30 8 3 Index Ascending.dbc 1.dbf Field Type Kodebar Character Namabar Character Harga Numeric Jumbel Numeric Total Numeric 3. New table. Buat Tabel <Pada jendela database designer klik kanan. Kemudian pada saat dijalankan visual foxpro akan menampilkan konfirmasi sebagai berikut. Primary Width 6 30 10 3 10 Index Gambar 2. # Relasi One To Many Buat Database dengan nama Penjualan. 2.4 Menyimpan Form Width 6 8 Index Ascending. Project. Klik Yes untuk menyimpannya. New. New File => muncul jendela Project Manajer Gambar 2. Tabel Barang. klik menu Program >DO atau Klik icon (Crtl+E). New table.2 Form Latihan 1 Ubahlah Properties Sebagai berikut: Objek Properties Caption Form1 Name Labe1l Caption Command1 Caption Name Setting Form Latihan 1 Frmlatihan1 Selamat Belajar Visual Foxpro \<Keluar Cmdkeluar Kemudian Klik dua kali pada command keluar 2.1. New.dbf Field Type Kodecus Character Namacus Character Alamat Character Telepon Character 3.dbf Field Type Nofak Character Tanggal Date Width 6 30 30 15 Index Ascending. Tabel Sementara. File. Simpan> sbb : 1. Primary Gambar 2. Simpan => muncul jendela database designer. New Database. Database. Tabel Customer. Regular . Latihan Form 1 Buatlah form sebagai berikut: MEMBUAT DATABASE Database => Sukumpulan tabel-tabel. Tabel Transaksi.3 Kode Program Form Latihan 1 Untuk menjalankan progrm. Pilih Tab Data.

value=”” Select 2 Thisform.enabled=.value=”” Select 1 Thisform.setfocus Endif Thisform.value=”” Set order to tag kodebar Thisform. form.f.grid1.value=”” Set order to tag kodecus Form1 Kondisiawal Select 3 Thisform.enabled=.value Replace jumbel with val(thisform.value Replace kodebar with sementara. Kondisiawal.f.txttotal.txtnofaktur.value) Replace total with thisform. Thisform.value Thisform.txtjumbel. new form> Thisform.kodebar Repace jumbel with sementara.cmdbatal.width=100 Thisform.txtjumbel. Thisform.txtnamacus.cmbkodebar.column4.enabled=. Thisform.txtnofaktur.refresh Cmdlihat Do form browsetransaksi.enabled=.txtnamacus.width=100 Cmdlagi Select 3 Append blank Click Replace kodebar with thisform.f.enabled=. tab document.setfocus Return Endif If seek(trim(thisform.Kodebar Kodecus Jumbel Total Character Character Numeric Numeric 5 5 3 10 Buat Form dengan nama pembelian.enabled=.aturgrid Thisform.cmdlihat.jumbarsementara. Cmdbatal Thisform.t. Thisform.width=100 Thisform.cmbkodecus.column5.enabled=.txttotal.enabled=.value=”” Use barang Thisform. Thisform.f.setfocus Return Else Thisform.refresh Thisform.txtnamabar. Thisform.txttotal.enabled=.t.”Pesan”) Thisform. Thisform. Delete all Pack Form1 Load Close all Form1 Bersih Set default to “C:\Nim\onetomany” Thisform.column1.cmbsimpan.setfocus() Thisform.enabled=.txtnofaktur.txtnamabar.value Replace tanggal with thisform.f.value=”” Thisform. Aturgrid Listing Program : Use transaksi Form1 Activate Set order to tag nofak Thisform.cmbbatal.grid1.cmdlagi.f.cmdlagi.enabled=.jumbel Select 3 Endscan Sele 3 Dele all Pack Thisform.cmbkodebar.enabled=.value Replace kodecus with thisform.txtjumbel.width=100 Thisform.txtnofaktur. Form.width=100 Thisform. Thisform. Cmdlsimpan Select 3 Scan Click Combobox dan Grid menggunakan Builder <Klik kanan.txtnamacus.48.cmbkodecus.cmbkodecus.value=”” Thisform.txtjumbel.cmbkodecus.cmbkodebar.setfocus Click Select 4 Append blank Replace nofak with thisform.kondisiawal Thisform.grid1.f.value=”” Thisform.enabled=.visible=.enabled=.txtnofaktur.value=”” Thisform.scx Txtjumbel Click Lostfocus .value Replace namabar with thisform.txttanggal. Thisform.cmbkodebar.txtjumbel.f.grid1.t.value=”” Select 4 Cmdtambah Click Select 4 If empty(thisform.recordsource=”sementara” Thisform.txtharga.cmbkodebar.cmbkodecus. Thisform.total Select 1 Replace jumbar with barang.cmdsimpan.f.column2.aturgrid Thisform.value)) Mssagebox(“No Faktur sudah ada”.value=”” Thisform.enabled=.cmbkodecus.setfocus Thisform.txtnofaktur.”Pesan”) Thisform.column3. Thisform. Thisform.f. new.bersih Use sementara Thisform.cmdbatal.f.txtnamabar.value=”” Thisform.enabled=.value) Messagebox(“No Faktur Harus Diisi”. Thisform. Thisform.t.txtnofaktur. Thisform.jumbel Replace total with sementara.t.f.kondisiawal Select 3 Thisform.txttotal.value=”” Use customer Thisform.txtnofaktur.enabled=.scx <pd jendela project designer. Thisform.txtharga.value=”” Thisform.value=”” Thisform.t. Form1 Aturgrid Thisform. Builder> : Objek Name Database Or Table Combobox1 Cmbkodecus Customer Combobox2 Cmbkodebar Barang Grid1 Grid1 Sementara Field Kodecus Kodebar Semua Field Buat Methode Baru <Pd menu bar . New Method> : Bersih.cmbkodecus.txtnofaktur.value=Mtgl Set relation to kodecus into customer additive Public isi Select 3 Isi=.value Replace harga with thisform.txtharga.t.enabled=.txtnofaktur.cmbkodebar.txtnamabar.enabled=.grid1.t. Thisform.grid1.txttanggal.txtnofaktur.txtnofaktur.value=”” Thisform. Thisform.txtharga.f.kondisiawal Set date british Mtgl=date() Set relation to kodebar into barang Thisform.enabled=.value=”” Thisform.t.value=”” Thisform.txttotal.48.

txtjumbel.value=round(thisform.txttotal.release Click Field Semua Sampai tampil modul design item menu “File” spt ini : MEMBUAT MENU Jangan lupa untuk sample kali ini nama menunya “mn_siswa”.value).36. value*val(thisform. 1 2 3 Ketik modul2 untuk item menu “File” spt ini : 4 Kemudian klik tombol “New” sampai tampil dialog box “New Menu” Klik tombol “Menu” yg kiri sampai tampil modul spt di bawah ini.txharga.”Info”)=6 Thisform. Dari panel “Project Manager .0) Cmdkeluar Click If messagebox(“Keluarrrr?”.Thisform.Siswa” klik tab “Other”. Selanjutnya klik tombol “Create” yg sejajar dg prompt “File” untuk membuat bagian2/item menu “File” ini.release Endif Buat Form Ke-2 dengan nama Browsetransaksi. Grid1 pada Builder : Objek Database Or Table Grid1 Transaksi Cmdkembali Thisform.scx Ketik di bawah “Prompt” File terus dibawah nya lagi Laporan (spt tampak dalam gambar). Perhatikan “Result” anda ubah ke “Command” untuk “Entri Siswa” dan “Exit” . Ini berarti menu anda nanti akan terdiri atas [ File ] [ Laporan ] Bagian2 yg lain jangan di ubah. pastikan spt tampak di atas.

scx” (form ini nanti baru akan kita buat).scx”. Selanjutnya anda kembali ke menu level “Menu Bar” Dan kembali ke Menu Designer kembali : Sampai kembali tampil modul “Menu Designer” kembali. Sedangkan jika user klik “Exit” maka program akan keluar.scx”. modul ini berguna untuk memberi kesempatan user misalnya hanya ingin mencetak data siswa tertentu saja atau sesuai kriteria/syarat lain yg di inginkan.scx” spt tampak di gambar berikut : Sedangkan di belakang “command” Exit anda isi dg command “clear events”. Catatan : Dengan demikian kita sudah sekenariokan jika user klik menu [ File ] dan memilih item menu “Entri Siswa” maka aplikasi akan menjalankan form/modul “frmsiswa.Ketik di belakang “command” Entri Siswa dg command “do form frmsiswa. Setelah selesai design item menu “File” ini kita kembali ke menu level “Menu Bar” dg cara : Di “Menu Level” klik combo yg ada disitu dan pilih “Menu Bar”. Sebagai contoh modul/form ini nanti kita beri nama “frmcetak. atau proses “menunggu” program di akhiri. Ketik di prompt “Lap Data Siswa” dan di belakang “command” anda ketik perintah “do form frmcetak. Ini di tandai dengan di jalankan nya command “clear events” sebagai lawan dari “read events”. Untuk design modul item menu “Laporan” klik combol “Create” sampai tampil : Untuk save menu yg telah di buat klik tombol close “X” sampai tampil dialog box spt di bawah : . Untuk mencetak data siswa anda masih memerlukan modul/interface form. Jika anda perhatikan tombol “Create” telah berubah menjadi “Edit” artinya jika anda ingin merubah item menu yg ada anda klik saja tombol “Edit” ini.

. klik tombol New =>tampil jendela new report 4. Klik Report 3. Pilih new report.MEMBUAT REPORT(LAPORAN) 1. Tab Documents 2. Dengan demikian proses pembuatan menu sudah selesai. Klik tombol “Yes” Simpan dg nama “mn_siswa” dan pastikan tersimpan di directory “Menu” 2 1 3 4 Klik tombol “Save” maka sekarang anda sudah memiliki menu. Pada Jendela Project Manajer.

Buatlah Project baru dengan nama : ProNilai 2.scx Klik tambah maka semua akan kosong dan kursor berada pada txtmatakuliah Klik simpan maka akan menyimpan . Klik Lihat maka akan membuka Form Browsenilai. Rancang Form sbb : Index <Ascending> Keterangan Primary Index <Ascending> Keterangan Regular Index Keterangan 6.dbf Name Type Width Nim Character 8 Nama Character 20 Kelas Character 6 n_mhs.LATIHAN ONE TO MANY 1. Buat Tabel sbb : Mahasiswa.dbf Name Type Width Matkul Character 20 Uts Number 3 Uas Number 3 Akhir Number 3 4. Buat Database : Nilai 3.dbf Name Type Width Nim Character 8 Matkul Character 20 Uts Number 3 Uas Number 3 Akhir Number 3 sementara. Atur grid Total = (50%*Uas)+(30%*Uts)+(20%*Akhir) Buat Sebuah Form Browsenilai dan simpanlah dengan nama browsenilai. Awal. Ketentuan : Buatlah New Method : Bersih. Ketentuan Grade : Grade A jika Total >80 Grade B jika Total >70 Grade C jika Total >50 Grade D jika Total <50 Grade E jika Total <30 ########### Selamat Mengerjakan ############ .dbf 5.scx Klik keluar maka akan keluar dari form. Grid adalah tampilan pada tabel sementara.

You're Reading a Free Preview

Mengunduh
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->