Anda di halaman 1dari 24

Analisis Regresi Linier dengan Program Minitab for Windows

Panduan Praktis

ANALISIS REGRESI LINIER DENGAN PROGRAM MINITAB FOR WINDOWS


Oleh: Tatang Tiryana Departemen Manajemen Hutan, Fakultas Kehutanan IPB

I. PENGANTAR
Penggunaan komputer dewasa ini semakin meluas dalam segala bidang pekerjaan. Begitu pun untuk keperluan analisis data, dewasa ini tersedia banyak pilihan program-program statistik (statistical software) yang dapat digunakan untuk mempermudah dan mempercepat analisis data dengan hasil yang akurat. Program-program statistik yang sekarang beredar antara lain : SAS (Statistical Analysis System), SPSS (Statistical Packages for Social Sciences), Minitab, Statistica, dsb, yang mana masing-masing program memiliki keunggulan dan kekurangan tersendiri dibanding program lainnya. Dalam tulisan ini, penulis hanya akan memperkenalkan salah satu program statistik saja yakni Minitab for Windows yang merupakan salah satu software statistik yang cukup terkenal dan mudah dalam pengoperasiannya. Dalam perkembangannya, program ini dirilis mulai dari sistem operasi DOS hingga saat ini pada versinya yang terakhir (Minitab for Windows Release 13) telah berbasis sistem operasi Windows. Untuk kemudahan pengoperasiannya, penulis menyarankan sebaiknya digunakan Minitab yang sudah menggunakan sistem operasi Windows, yakni mulai Minitab Release 10 ke atas. Secara khusus, tulisan ini dimaksudkan untuk memperkenalkan secara umum kepada mahasiswa tentang prosedur analisis regresi linier sederhana dan berganda dengan bantuan program Minitab. Pembahasan lebih ditekankan kepada prosedur operasional software Minitab melalui suatu contoh kasus serta dilengkapi pula dengan interpretasi dari hasil analisis data. Untuk itu, pemahaman dasar cara-cara pengoperasian komputer dan dasardasar teori tentang analisis regresi (yang sebelumnya pernah dipelajari dalam M.a. Metode Statistika atau Analisis Statistika) sangat diperlukan untuk kelancaran analisis data.

II. CONTOH KASUS


Untuk mempermudah dalam pemahamannya, dalam tulisan ini akan digunakan contoh kasus berikut ini: Misalkan kita ingin membuat model hubungan antara diameter pohon (D, cm) dengan volume pohon (V, m3) serta model hubungan antara diameter dan tinggi (T, m) dengan volume pohon. Dalam hal ini, model pertama hanya terdiri dari satu peubah bebas saja, yakni diameter (D), sedangkan model kedua terdiri dari dua peubah bebas (D, T); dan masing-masing menggunakan satu peubah tak bebas, yakni volume pohon (V). Adapun model-model regresi yang akan dicobakan adalah sebagai berikut:
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

1). 2). 3). 4).

V = b0 + b1 D

V = b0 .D b1 V = b0 + b1 D + b2T

V = b0 D b1 T b2

Untuk penyusunan model-model regresi tersebut, digunakan data seperti tertera pada Tabel 1. Tabel 1. Data dimensi pohon (diameter, tinggi, dan volume) untuk penyusunan model regresi
No. Pohon 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 Diameter (D) 27 25 28 36 33 40 45 49 50 40 53 52 56 50 52 Tinggi (T) 14 19 22 14 21 29 31 28 23 22 30 29 29 29 29 Volume (V) 0,337 0,278 0,418 0,482 0,603 1,002 1,273 1,399 1,345 0,753 1,889 1,442 1,983 1,275 1,596

Marilah kita coba analisis data tersebut dengan program Minitab. Dalam tulisan ini, penulis menggunakan program Minitab for Windows Release 13.3. Namun demikian, apabila versi tersebut tidak Anda miliki, masih dapat digunakan versi sebelumnya asalkan yang sudah menggunakan sistem operasi Windows (misalnya: Minitab Release 10, 11 atau 12).

III. TAHAPAN ANALISIS DATA


Pada dasarnya, analisis data dengan program Minitab terdiri atas : input data, proses analisis data, serta interpretasi dari output program. Berikut ini, akan diuraikan masing-masing tahapan tersebut secara terperinci.

3.1. Input Data Pemasukan (input) data merupakan langkah awal yang harus dilakukan untuk memberikan masukan kepada komputer tentang analisis yang harus dilakukannya. Dalam Minitab, input data dapat dilakukan dengan dua cara, yakni : Input data secara langsung, yakni dengan mengetikkan data langsung pada lembar kerja (worksheet) yang telah disediakan oleh Minitab.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

Input data secara tidak langsung, yakni pemasukan data tidak dilakukan langsung dengan mengetikkannya pada lembar kerja Minitab melainkan dengan mengimport data yang dibuat dengan program pengolah angka seperti : MS Excel, Lotus, dll.

3.1.1. Input Data Secara Langsung Cara ini tidak memerlukan bantuan software lain karena data langsung diketikkan pada lembar kerja Minitab. Namun, untuk data yang banyak dan nilainya diperoleh dari hasil perhitungan data lainnya, terkadang cara ini kurang efektif karena pengolahan data pada worksheet Minitab tidak semudah dan seleluasa dibanding program Excel (misalnya). Untuk input data contoh di atas (lihat Tabel 1), ikutilah langkah-langkah berikut ini : 1). Bukalah program Minitab dengan cara : klik tombol Start yang ada di taskbar, kemudian pilih dan klik menu Program, Minitab 13 for Windows, Minitab. Sesaat kemudian, akan terlihat jendela kosong yang terdiri dari : Session window dan Worksheet window, seperti terlihat pada Gambar 1. Arahkan dan klik kursor pada Worksheet Window untuk memulai pemasukan data. Perhatikanlah bahwa dalam Minitab data dimasukkan menurut baris atau kolom. Berilah nama pada tiap kolom (C1, C2, C3, dst) sesuai nama peubah yang dikehendaki (misalnya : D, T, V, yang masing-masing menyatakan diameter, tinggi, dan volume), dengan cara mengklik sel kosong dibawah C1, C2, C3, dst. Perhatikan bahwa nama tiap kolom tidak boleh lebih dari 8 karakter. Mulailah memasukkan data sesuai peubah yang dikehendaki. Misalnya, pertama-tama masukkan data diameter pohon (lihat data di atas) pada kolom C1 (atau telah dinamai D). Data dimasukkan dari sel paling atas sampai sel terakhir sejumlah data pada peubah diameter tersebut (sebanyak 15 data). Untuk berpindah sel, gunakanlah tombol ENTER atau gerakan kursor ke bawah. Perhatikan bahwa, pergerakan kursor bisa Anda atur ke arah vertikal (atas ke bawah) atau horizontal (kiri ke kanan) dengan cara klik ganda pada tanda panah () di pojok kiri atas Worksheet window. Dengan cara yang sama seperti pada langkah ke-4 di atas, masukkan pula data pada peubah lainnya (yakni : T, dan V) hingga semua data lengkap. Perhatikanlah model regresi yang akan dibuat, apakah ada peubah yang nilainya perlu ditransformasi (misal : transformasi ke logaritma, bentuk kuadrat, dsb). Untuk model contoh di atas, kita perlu melakukan transformasi nilai D ke bentuk kuadratnya (D2) untuk model V = b0 + b1.D 2 , dan transformasi ke bentuk logaritma (log D dan log T) untuk model V = b0 .D
b1

2). 3).

4).

5). 6).

dan V = b0 D 1 T 2 .
b b

Untuk melakukan transformasi nilai,

Minitab menyediakan berbagai macam fungsi perhitungan yang tercakup dalam submenu Calculator (buka menu Calc, Calculator). 7). Cobalah bandingkan hasil pekerjaan Anda dengan Gambar 1. Apabila hasilnya sama, berarti Anda telah benar memasukkan data tersebut.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

Gambar 1. Input data pada lembar kerja (worksheet) Minitab 7). Simpanlah data tersebut dalam komputer Anda, dengan cara klik menu File, Save Current Worksheet As, pilih lokasi penyimpanannya dan berilah nama file-nya. Misalnya data Anda disimpan pada folder dan nama file berikut: C:\My Documents\Data-regresi.mtw. Perhatikan bahwa pada program Minitab disediakan dua submenu untuk penyimpanan data, yaitu 1) Save Project atau Save Project As dan 2) Save Current Worksheet atau Save Current Worksheet As... Perbedaan keduanya adalah bahwa pada Save Current Worksheet atau Save Current Worksheet As... , yang akan disimpan hanyalah data pada lembar kerja (worksheet) saja. Sedangkan pada Save Project atau Save Project As, yang akan disimpan adalah keseluruhan baik data pada worksheet maupun output pada Session window. Untuk membedakan file keduanya, lihatlah extension file-nya, jika extension-nya mtw (*.mtw) berarti file data saja (Minitab Worksheet) sedangkan jika extension-nya mpj (*.mpj) berarti file data dan output (Minitab Project)

3.1.2. Input Data Secara Tidak Langsung Selain cara pemasukan data seperti di atas, dapat pula dilakukan secara tidak langsung dengan mengetikan data terlebih dahulu pada program pengolah angka (spreadsheet) seperti : MS Excel dan Lotus. Berikut ini disajikan contohnya melalui program Excel. 1). 2). Bukalah program MS Excel dan ketikkan data secara lengkap pada suatu lembar keja (worksheet). Perhatikan bahwa judul kolom hendaknya dibuat sesingkat mungkin (misal cukup diberi nama : D untuk data diameter, T untuk tinggi, dan V untuk volume). Nama kolom yang lebih dari 8 karakter, tidak akan dapat terbaca semuanya oleh program Minitab. Perhatikan pula bahwa judul kolom cukup dibuat pada baris pertama dilanjutkan pengetikkan datanya pada baris-baris berikutnya, karena Minitab hanya dapat membaca satu baris nama peubah saja.

3).

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

4).

Simpanlah data tersebut dalam format MS Excel versi 5.0 atau versi sebelumnya, karena untuk Minitab versi 11.0 ke bawah belum bisa membaca format MS Excel versi terbaru (misal MS Excel 2000 atau 2002). Lihatlah contoh pada Gambar 2 di bawah ini.

5).

Gambar 2. Input data melalui program MS Excel 6). 7). Tutuplah file data tersebut dan bukalah program Minitab. Klik menu File, Open Worksheet, pilihlah pada File of type format data Excel (*.xls), dan carilah nama file data yang anda simpan tadi. Kemudian tekan tombol Open, dan sesaat kemudian data akan ditampilkan dalam jendela Worksheet Minitab seperti terlihat pada Gambar 1 di atas. Apabila Anda ingin cara yang lebih mudah dan praktis dari cara di atas, maka dapat dilakukan langkah-langkah berikut ini : 8.1). Pada lembar kerja MS Excel seperti pada Gambar 2., sorotlah (blok) data yang Anda telah anda ketik berikut nama-nama kolomnya 8.2). Klik icon Copy atau pilih dari menu Edit, Copy. 8.3). Beralihlah ke jendela Worksheet Minitab yang telah dibuka sebelumnya. 8.4). Arahkan kursor dan klik tepat pada sel dibawah kolom C1 (dan di atas baris ke1). 8.5). Klik pada icon Paste atau pilih dari menu Edit, Paste Cells 8.6). Tunggu sesaat, maka data akan ditampilkan seperti pada Gambar 1.

8).

3.2.

Proses Analisis Data

Setelah proses pemasukan data Anda kerjakan, sekarang Anda tinggal mengolah data tersebut dengan menggunakan alat-alat statisik yang cocok yang disediakan Minitab. Dalam hal ini, untuk keperluan penyusunan suatu model regresi cukup Anda pahami submenu Regression yang ada dalam menu Stat. Perlu Anda ketahui bahwa untuk alat-alat uji dalam analisis statistik pada program Minitab disediakan pada menu utama Stat, sedangkan menumenu lainnya berfungsi sebagai pendukung analisis statistik (lihat Gambar 3).
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

Gambar 3. Menu Regresi dalam Program Minitab

Untuk contoh kasus di atas, kita akan membuat lima model regresi linier dan model regresi transformasi ke bentuk linier. Untuk lebih jelasnya, penyusunan masing-masing model tersebut akan diuraikan sebagai berikut: Penyusunan model V = b0 + b1 D

3.2.1.

Model tersebut merupakan model regresi linier sederhana karena hanya melibatkan satu peubah bebas. Adapun prosedur penyusunan model regresi tersebut dengan program Minitab adalah sebagai berikut : 1). 2). Bukalah file data yang sebelumnya Anda simpan, yakni pada direktori : Documents\Data-regresi.mtw. C:\My

Setelah data tampil seperti terlihat pada Gambar 1., klik menu Stat, Regression, Regression , dan isilah kotak dialog sebagai berikut : 2.1). Isilah kotak Response dengan nama peubah atau nama kolom yang akan dijadikan sebagai peubah tak bebas (peubah respon). Untuk contoh kasus kita, isilah dengan peubah volume, yakni V dengan cara mengklik dan tekan tombol Select (atau cukup klik ganda pada peubah V tersebut pada daftar peubah yang tampil pada kotak disebelahnya) atau ketikkan langsung pada kotak Response. Selain mengetikkan V, Anda bisa juga menuliskan nomor kolomnya saja, yakni C3. 2.2). Tempatkan kursor pada kotak Predictors dan isilah dengan nama peubah tak bebasnya, yakni D atau ketikkan nomor kolomnya (C1). 2.3). Klik tombol OK untuk menginstruksikan kepada komputer agar memproses data regresi tersebut. Perhatikan bahwa masih ada empat sebmenu lagi, yakni : Graphs, Results, Options, dan Storage yang mendukung untuk analisis regresi lanjutan. Namun untuk sementara (bagi pemula), biarkan saja tidak perlu diklik karena prosedur di atas (langkah 2.1 dan 2.2) sudah memadai. Sebenarnya, keempat submenu tersebut berguna untuk analisis regresi lebih lanjut terutama yang menyangkut analisis sisaan. 2.4). Jika Anda melakukan tahapan 2.1. 2.3. di atas dengan benar, akan tampak seperti Gambar 4.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

Gambar 4. Pengisian kotak dialog untuk model V = b0 + b1 D 2.5). Setelah menekan tombol OK, sesaat kemudian akan ditampilkan output program dalam Session Window yang menyajikan hasil analisis regresi (persamaan regresi, uji-T bagi koefisien regresi, simpangan baku sisaan, koefisien determinasi, dan daftar analisis ragam) seperti terlihat pada Gambar 5. Interpretasi output program ini akan dijelaskan lebih lanjut pada bagian berikutnya.

Gambar 5. Output program Minitab untuk model V = b0 + b1 D 3). Simpanlah output program tersebut agar bisa dipanggil lagi lain waktu atau bisa Anda lampirkan output tersebut dalam lampiran laporan Anda. Untuk itu, klik menu File, dan pilihlah salah satu menu penyimpanan berikut ini : Save Project, jika Anda ingin menyimpan seluruh yang tampil di layar, baik pada Session window maupun Worksheet window. File yag disimpan akan diberi extension mpj (*.mpj) dan hanya bisa dibuka kembali dengan program Minitab. Save Project As, mirip dengan pilihan Save Project tetapi bila ingin disimpan dengan nama file yang berbeda. Save Session Window As, khusus jika Anda hanya ingin menyimpan output program pada Session window saja. Format file yang disimpan bisa Anda pilih,

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

apakah Text File (*.TXT), Rich Text Format (*.RTF), atau List File (*.LIS). Ketiga format file tersebut bisa Anda buka dengan program pengolah kata, seperti MS Word, namun untuk kemudahannya disarankan menggunakan format RTF (*.RTF) yang lebih kompatibel dengan program MS Word. Untuk data latihan kita, simpanlah dalam format RTF (*.RTF) misalnya disimpan pada folder : C:\My Documents\Hasil-analisis.RTF. Catatan : Apabila Anda ingin cara yang lebih praktis untuk menggabungkan hasil analisis yang tampil di Session window ke dalam lampiran yang Anda buat di program pengolah kata seperti MS Word untuk diedit lebih lanjut, maka lakukanlah cara-cara berikut : Blok hasil analisis yang ingin dicopy. Untuk memblok semua yang tampil di Session windows, klik menu Edit, Select All. Klik icon Copy atau pilih dari menu Edit, Copy. Bukalah dokumen baru pada program MS Word, dan klik icon Paste atau pilih dari menu Edit, Paste. Tunggu sesaat, maka akan ditampilkan copy dari Session windows Minitab tadi yang siap Anda edit lebih lanjut (kalau perlu).

3.2.2.

Penyusunan model V = b0 .D

b1

Model ini bukan merupakan model regresi linier sederhana melainkan model non-linier karena peubah bebasnya berpangkat lebih dari satu. Namun, apabila kita transformasi ke bentuk logaritma, maka akan diperoleh suatu model linier sebagai berikut : Model non-linier : V = b0 .D b1 Transformasi logaritma : log V = log b0 + b1 log D Apabila :

log V = Y , log b0 = a , b1 = b , dan log D = X , maka akan diperoleh : log V = log b0 + b1 log D
Y = a + bX

Dimana, bentuk terakhir ini, Y = a + bX , merupakan regresi linier sederhana yang dapat diselesaikan seperti pada Sub-bab 2.1. Adapun prosedur penyusunan model regresi tersebut dengan program Minitab mirip seperti uraian pada Sub-bab 2.1. namun data diameter (D) dan volume (V) perlu ditransformasi terlebih dahulu ke dalam bentuk logaritma. Secara singkat, tahapannya dapat diuraikan sebagai berikut : 1). 2). Bukalah file data yang sebelumnya Anda simpan, yakni : C:\My Documents\Dataregresi.mtw. Setelah data tampil seperti terlihat pada Gambar 1., lakukan transformasi peubah D dan V sebagai berikut : Berilah nama kolom pada C4 dengan log-D, dan kolom C5 dengan log-V. Klik menu Calc, Calculator, maka akan ditampilkan kotak dialog Calculator seperti terlihat pada Gambar 6. Isilah kotak Store result in variable: log-D , atau C4, dengan cara mengklik ganda pada daftar peubah kotak sampingnya atau langsung diketikan pada kotak tersebut.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

Isilah kotak Expression: LOGT(D), yakni untuk mentransformasikan data pada peubah D kedalam nilai logaritmanya. Untuk memilih fungsi transformasi, Anda bisa memilihnya dari kotak pilihan Functions pada pilihan log 10. Dalam hal ini, LOGT merupakan fungsi transformasi untuk logaritma basis 10. Klik OK dan lihat hasilnya. Ulangi lagi tahapan ke-2 sampai ke-4 tersebut untuk untuk transformasi peubah V ke bentuk logaritmanya (log-V). Bandingkan hasil pekerjaan Anda dengan Gambar 6, apabila sama berarti Anda dapat melakukannya dengan benar. Dari Gambar 6, terlihat bahwa peubah D dan V telah ditransformasi nilainya ke bentuk logaritmanya. Apabila Anda tidak ingin menggunakan prosedur transformasi seperti di atas, Anda dapat melakukannya dengan menggunakan MS Excel.

Gambar 6. Transformasi logaritma peubah D dan V untuk model

V = b0 .D b1
3). 4). Perhatikan kolom log-D dan log-V, karena data inilah yang akan dibuat model regresinya (bukan data D dan V lagi). Klik menu Stat, Regression, Regression , dan isilah kotak dialog sebagai berikut (lihat Gambar 7) : 4.1). Isilah kotak Response : log-V atau ketikkan C5. 4.2). Isilah kotak Predictors : log-D atau ketikkan C4. 4.3). Klik tombol OK.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

Analisis Regresi Linier dengan Program Minitab for Windows

Gambar 7. Pengisian kotak dialog untuk model V = b0 .D

b1

4.4). Setelah menekan tombol OK, sesaat kemudian akan ditampilkan output program dalam Session Window seperti terlihat pada Gambar 8.

Gambar 8. Output program Minitab untuk model V = b0 .D 5).

b1

Simpanlah output program tersebut agar bisa dipanggil lagi di lain waktu atau Anda dapat melampirkannya dalam laporan. Penyusunan model V = b0 + b1 D + b2T

3.2.3.

Model ketiga ini merupakan model regresi linier berganda yang terdiri atas dua peubah bebas (yakni D dan T) dan satu peubah tak bebas (V). Apabila Anda telah dapat memahami penyusunan model pertama dan kedua sebelumnya, maka Anda tidak akan kesulitan untuk menyusun model ketiga ini. Dengan prosedur analisis regresi yang hampir sama seperti model-model sebelumnya, Anda dapat menyusun model tersebut dengan prosedur sebagai berikut:
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

10

Analisis Regresi Linier dengan Program Minitab for Windows

1). 2).

Bukalah file data yang sebelumnya Anda simpan, yakni : C:\My Documents\Dataregresi.mtw. Setelah data tampil seperti terlihat pada Gambar 1., klik menu Stat, Regression, Regression , dan isilah kotak dialog sebagai berikut : 2.1). Isilah kotak Response dengan peubah volume, yakni V dengan cara mengklik dan tekan tombol Select (atau cukup klik dua kali pada peubah V tersebut), atau ketikkan secara langsung V atau C3 pada kotak tersebut. 2.2). Tempatkan kursor pada kotak Predictors dan isilah dengan nama peubah tak bebasnya, yakni D atau ketikkan nomor kolomnya (C1) dan kemudian T (atau ketikkan C2). Ingat, dalam hal ini kita memiliki dua peubah bebas, yakni D dan T. 2.3). Lihatlah Gambar 9. untuk memastikan bahwa Anda melakukan langkah 2.1.dan 2.2. di atas dengan benar.

Gambar 9. Pengisian kotak dialog untuk model V = b0 + b1 D + b2T 2.4). Klik tombol OK dan tunggu beberapa saat sampai komputer menampilkan outputnya seperti terlihat pada Gambar 10.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

11

Analisis Regresi Linier dengan Program Minitab for Windows

Gambar 10. Output program Minitab untuk model V = b0 + b1 D + b2T 3). Simpanlah output program tersebut agar bisa dipanggil lagi di lain waktu atau Anda dapat melampirkannya dalam laporan.

3.2.4.

Penyusunan model V = b0 .D b1 .T b2

Seperti halnya pada model kedua di atas, model ini pun merupakan model regresi nonlinier. Namun, dengan cara transformasi seperti pada model kedua, model tersebut dapat ditransformasikan kedalam model linier sebagai berikut : Model non-linier : V = b0 .D 1 .T
b b2

Model transformasi : log V = log b0 + b1 log D + b2 log T Apabila : log V = Y , log b0 = a , b1 = b , b2 = c , log D = X 1 , dan logT = X 2 , maka akan diperoleh :

log V = log b0 + b1 log D + b2 log T Y = a + bX 1 + cX 2

Bentuk terakhir ini, Y = a + bX 1 + cX 2 , merupakan regresi linier sederhana yang dapat diselesaikan seperti pada Sub-bab 2.3. dengan terlebih dahulu melakukan transformasi setiap peubahnya. Secara rinci, prosedur penyusunan model regresi tersebut dengan program Minitab dapat dijelaskan sebagai berikut: 1). 2). Bukalah file data yang sebelumnya Anda simpan, yakni : C:\My Documents\Dataregresi.mtw. Setelah data tampil seperti terlihat pada Gambar 1., lakukan transformasi peubah D, T dan V sebagai berikut : Berilah nama kolom pada C4 dengan log-D, kolom C5 dengan log-T, dan kolom C6 dengan log-V.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

12

Analisis Regresi Linier dengan Program Minitab for Windows

Klik menu Calc, Calculator, maka akan ditampilkan kotak dialog Calculator seperti terlihat pada Gambar 11. Isilah kotak Store result in variable: log-D, atau C4, dengan cara mengklik ganda pada daftar peubah kotak sampingnya atau langsung Anda ketikkan pada kotak tersebut. Isilah kotak Expression: LOGT(D), untuk melakukan transformasi peubah D kedalam nilai logaritmanya. Fungsi tersebut bisa Anda pilih dari kotak Functions pada pilihan Log 10. Dalam hal ini, LOGT merupakan fungsi transformasi untuk logaritma basis 10. Klik OK dan lihat hasilnya. Lakukan hal yang sama (seperti tahapan ke-2 sampai ke-4 tersebut) untuk transformasi peubah T ke bentuk log-T dan peubah V ke bentuk log-V. Apabila Anda melakukan tahapan di atas dengan benar, maka hasilnya akan terlihat seperti pada Gambar 11.

Gambar 11. Transformasi logaritma peubah D, T, dan V untuk model V = b0 .D b1 .T b2 3). Sekarang Anda telah memiliki data transformasi pada kolom log-D (C4), log-T (C5), dan log-V (C6). Data inilah yang untuk selanjutnya akan Anda gunakan untuk penyusunan modelnya, jadi bukanlah data pada kolom D, T dan V lagi. Klik menu Stat, Regression, Regression , seperti saat mengerjakan model-model sebelumnya, dan isilah kotak dialog sebagai berikut (lihat Gambar 12) : 4.1). Isilah kotak Response : log-V atau ketikkan C6. 4.2). Isilah kotak Predictors : log-D atau ketikkan C4, kemudian klik juga log-T atau C5, seperti terlihat pada Gambar 12. 4.3). Klik tombol OK.

4).

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

13

Analisis Regresi Linier dengan Program Minitab for Windows

Gambar 12. Pengisian kotak dialog untuk model V = b0 .D 1 .T


b

b2

4.4). Tunggulah beberapa saat, maka akan ditampilkan output program dalam Session Window seperti terlihat pada Gambar 13.

Gambar 13. Output program Minitab untuk model V = b0 .D b1 .T b2 3). Simpanlah output program tersebut agar bisa dipanggil lagi di lain waktu atau Anda dapat melampirkannya dalam laporan.

IV. INTERPRETASI HASIL ANALISIS DATA


Output software Minitab tidak akan berarti banyak tanpa adanya interpretasi lebih lanjut terhadap output tersebut. Disilah peranan kita sebagai brainware untuk menginterpretasikan hasil analisis data dari komputer sehingga memberikan solusi yang diinginkan dengan tepat. Tentunya, dasar-dasar teori tentang statistika sangat diperlukan. Oleh karena itu,
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

14

Analisis Regresi Linier dengan Program Minitab for Windows

alangkah baiknya apabila Anda ingat atau baca kembali teori-teori statistika, khususnya yang berkenaan dengan analisis regresi. Secara umum, output Minitab untuk analisis regresi menyajikan tampilan hasil analisis yang hampir sama walaupun model regresinya berbeda. Oleh karena itu, dalam tulisan ini tidak akan dibahas secara terperinci untuk setiap model dalam contoh kasus sebelumnya, melainkan hal-hal umum yang berlaku untuk semua hasil analisis regresi dari Minitab.

4.1. Interpretasi untuk Model Regresi Linier Sederhana Sebagai contoh pertama, marilah kita lihat output Minitab untuk model regresi linier sederhana : V = b0 + b1 D berikut ini (lihat pula Gambar 5):

Gambar 14. Contoh output program Minitab untuk regresi linier sederhana Seperti terlihat pada Gambar 14 di atas, secara umum output program Minitab terdiri atas empat bagian utama, yakni : 1) persamaan garis regresi, 2) statistik bagi koefisien regresi, 3) statistik bagi model regresi, dan 4) tabel analisis ragam (ANOVA) bagi model regresi. Secara rinci, keempat bagian output Minitab tersebut dapat dijelaskan sebagai berikut :

Persamaan garis regresi Persamaan garis regresi linier sederhana untuk data contoh kita (lihat Tabel 1) dinyatakan pada bagian :

Tampilan tersebut menyatakan bahwa persamaan regresi untuk data contoh di atas adalah : V = 1,13 + 0, 0518 D , yang dalam hal ini b0 = -1,13 dan b1 = 0,0518. Dengan demikian, berdasarkan model tersebut kita akan dapat menentukan nilai dugaan bagi
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

15

Analisis Regresi Linier dengan Program Minitab for Windows

volume pohon untuk diameter pohon tertentu. Misalkan, untuk D = 20 cm akan diperoleh nilai dugaan untuk V = 0,424. Secara manual, koefisien b0 dan b1 tersebut dapat kita hitung dengan rumus sebagai berikut :

1 = b1 =

JHK xy JK x

n n xi yi xi . yi n i =1 i =1 ; dan b = Y b . X = i =1 0 = 0 1 2 n n 2 xi xi n i =1 i =1 n

Perhatikan, dalam regresi tidak diperbolehkan adanya ekstrapolasi, yakni menduga nilai yang tidak berada dalam kisaran data yang digunakan untuk penyusunan model regresinya. Pada Tabel 1., data diameter yang digunakan untuk menduga volume pohon berkisar antara 25 sampai 56. Oleh karena itu, model regresi di atas pun harus digunakan untuk menduga volume pohon dengan kisaran diameter antara 25 sampai 56 (tidak boleh diluar kisaran nilai tersebut). Apabila digunakan untuk menduga volume pada diameter 20 cm (misalnya), maka kita telah melakukan ekstrapolasi yang apabila dipaksakan akan mengakibatkan kesalahan dugaan yang fatal. Sebagai bukti, misalkan jika D = 20 cm (padahal seharusnya minimal 25 cm dan maksimal 56 cm), maka nilai dugaan bagi V = -0,094 m3. Terlihat bahwa nilai dugaan V = -0,094 m3 tersebut merupakan nilai yang tidak logis bagi dugaan volume (isi) pohon. Oleh karena itu, apabila model regresi yang kita susun ingin digunakan secara leluasa untuk dapat menduga kisaran nilai yang lebar, maka data yang digunakan untuk penyusunan modelnya pun harus memiliki kisaran nilai yang lebar dengan memperhatikan keterwakilan data secara kontinyu (tidak mengumpul pada suatu titik tertentu).

Statistik bagi koefisien regresi Output Minitab menyajikan pula nilai-nilai statistik bagi koefisien regresi (b0, b1, dsb) seperti terlihat pada tampilan berikut ini :

Beberapa hal yang dapat dijelaskan tentang tampilan tersebut adalah sebagai berikut : Predictor, kolom ini mencantumkan koefisien regresi (penduga parameter) apa saja yang ada dalam model. Dalam hal ini hanya ada dua saja, yakni Constant dan D. Constant merupakan penduga parameter bagi 0 (yakni b0), sedangkan D merupakan penduga parameter bagi 1 (yakni b1). Tentunya apabila peubah bebasnya lebih dari satu (seperti pada regresi linier berganda), akan terdapat penduga parameter model lainnya. Coef (singkatan dari coefficient), kolom ini mencantumkan koefisien nilai dari b0 (constant) dan b1 (dalam hal ini D). Dari nilai ini dapat diketahui bahwa koefisien b0 = -1,1262 dan b1 = 0,051837. Apabila diperhatikan, nilai-nilai tersebut sama (walaupun ada sedikit perbedaan dalam pembulatannya) seperti yang tercantum dalam persamaan regresinya ( V = 1,13 + 0, 0518 D ).
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

16

Analisis Regresi Linier dengan Program Minitab for Windows

SE Coef (singkatan dari Standard Error of Coefficient), kolom ini mencantumkan simpangan baku bagi setiap koefisien model (dalam hal ini b0 dan b1). Secara manual, dalam regresi linier sederhana nilai-nilai simpangan baku tersebut dapat dihitung dengan rumus :
2 1 x s2 + = .KTS dan sb1 = n JK x JK X

sb0 =

()

KTS JK X

dimana : JK X =

n xi2 xi i=1 i=1


n

T, kolom ini menyajikan statistik t-hitung bagi masing-masing koefisien regresi, baik b0 maupun b1. Statistik t-hitung tersebut dapat digunakan untuk menguji keberartian masing-masing koefisien regresi secara parsial dengan hipotesis berikut : H0 : 0 = 0 vs H1 : 0 0 ; atau H0 : 1 = 0 vs H1 : 1 0 P, kolom ini mencamtukan nilai peluang bagi penerimaan H0 dalam pengujian b0 dan b1 (seperti tertera pada kolom T di atas). Seperti terlihat pada tampilan di atas, nilai P bagi Constant adalah 0.000, yang berarti bahwa peluang kita untuk menerima H0 : 0 = 0 adalah 0.000; atau dengan kata lain, pada taraf nyata 5%, terdapat cukup bukti untuk menolak H0. Interpretasi yang sama dapat digunakan untuk nilai P bagi peubah D. Dengan demikian, kita dapat menyatakan bahwa pada taraf nyata 5%, masing-masing koefisien regresi berbeda dengan nol. Sebenarnya, untuk pengujian hipotesis b0 dan b1 tersebut dapat pula digunakan nilai pembanding dari tabel t-student, dimana apabila nilai T (pada tampilan di atas) lebih besar dari nilai tabel, maka H0 ditolak. Namun dalam hal ini, Minitab telah memberikan kemudahan dengan mencantumkan nilai P tersebut. Berdasarkan nilai P tersebut, kita dapat memutuskan untuk menerima atau menolak H0 dengan ketentuan sebagai berikut : Jika P 0.01, yang berarti tolak H0, maka pada taraf nyata () 5% kita dapat mengatakan bahwa peranan b0 atau b1 sangat nyata. Jika 0.01 P 0.05, yang berarti tolak H0, maka pada taraf nyata () 5% kita dapat mengatakan bahwa peranan b0 atau b1 nyata. Jika P 0.05, yang berarti terima H0, maka pada taraf nyata () 5% kita dapat mengatakan bahwa peranan b0 atau b1 tidak nyata (artinya : nilai b0 atau b1 tersebut tidak nyata berbeda dengan nol).

Statistik bagi model regresi Selain nilai-nilai statistik bagi penduga parameter, Minitab pun menyajikan nilai-nilai statistik dari model regresi yang terbentuk seperti terlihat pada tampilan berikut ini :

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

17

Analisis Regresi Linier dengan Program Minitab for Windows

Dalam analisis regresi, nilai-nilai tersebut dapat digunakan sebagai kriteria dalam pemilihan model regresi terbaik. Secara rinci, ketiga nilai tersebut dapat dijelaskan lebih lanjut sebagai berikut : S (standard deviation), menunjukkan simpangan baku dari sisaan model yang merupakan akar kuadrat dari Mean Square Error (kuadrat tengah sisa). Model regresi yang baik adalah model regresi yang memiliki simpangan baku sisaan (S) yang kecil. R-Sq (R-square, R2), menunjukkan nilai koefisien determinasi yakni suatu nilai yang menerangkan besarnya keragaman dalam peubah tak bebas (Y) yang dapat dijelaskan oleh peubah bebasnya (X), yang umumnya dinyatakan dalam persen (%). Secara manual, R2 tersebut dapat pula dihitung dengan rumus :

R2 =

JHK XY JKR .100% = b1. .100% JKT JK Y

Dari tampilan di atas terlihat bahwa peubah D (diameter pohon) dapat menerangkan keragaman volume pohon (V) sebesar 92,8% sedangkan sisanya disebabkan oleh faktor lain yang tidak tercakup dalam model. Model yang baik adalah model yang memiliki nilai R2 yang tinggi mendekati 100%. R-Sq (adj) (R-square adjusted), yakni merupakan nilai R2 yang telah dikoreksi dengan derajat bebasnya. Nilai ini dapat pula dihitung dengan rumus:

( JKS) ( n - p ) R(2adj ) = 1 ( JKT ) ( n -1) x100% ,

dimana : p = banyaknya koefisien regresi (dalam RLS, p=2)

Tabel analisis ragam (ANOVA) Tampilan lain dari output Minitab adalah tabel analisis ragam (analysis of variance, ANOVA) seperti ditunjukkan pada bagian berikut ini :

Seperti umumnya tampilan dari suatu tabel ANOVA, pada output Minitab pun menyajikan nilai-nilai statistik yang umum dijumpai pada suatu tabel ANOVA yaitu : Source, yakni mencantumkan sumber keragaman dalam model regresi. Untuk regresi linier sederhana, sumber keragaman tersebut berasal dari regresi (regression), sisaan (residual error), dan total. DF, yakni mencantumkan derajat bebas (degree of freedom) untuk masingmasing sumber keragaman. SS, yakni mencantumkan nilai-nilai jumlah kuadrat (sum square) untuk masingmasing sumber keragaman, yaitu : SSR (sum square regression) untuk JKR, SSE (sum square error) untuk JKS, dan SST (sum square total) untuk JKT.

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

18

Analisis Regresi Linier dengan Program Minitab for Windows

MS, yakni mencantumkan nilai-nilai kuadrat tengah (mean square) dari regresi (biasa disebut sebagai MSR, mean square regression) dan kuadrat tengah dari sisaan (disebut sebagai MSE, mean square error). F, yakni mencantumkan nilai F-hitung dari Uji Fisher untuk menguji keberartian model regresi (overall fit test). Nilai F tersebut dapat dihitung dengan rumus :

Fhitung =

MSR KTR = MSE KTS

Nilai F tersebut, sangat berguna untuk pengujian keberartian model regresi secara menyeluruh (yakni sesungguhnya menguji apakah koefisien model, kecuali b0, sama dengan nol atau tidak) dengan hipotesis uji sebagai berikut : H0 : i = 0 vs H1 : ada i 0, untuk i = 1, 2, .k Atau dalam regresi linier berganda berlaku : H0 : 1 = 0 vs H1 : 1 0, karena peubah bebasnya hanya satu. P, yakni menunjukkan nilai peluang bagi penerimaan H0 dalam uji F di atas. Apabila nilai P tersebut lebih besar dari taraf nyata yang kita tetapkan dalam pengujian, misal = 5%, maka H0 diterima dan kita katakan bahwa model regresi tersebut tidak nyata, artinya semua koefisien regresi sama dengan nol. Seperti halnya dalam pengujian masing-masing koefisien regresi dengan uji T, dalam hal ini dapat digunakan ketentuan sebagai berikut : Jika P 0.01, yang berarti tolak H0, maka pada taraf nyata () 5% kita dapat mengatakan bahwa peubah bebas (dalam RLS hanya X1) bersifat sangat nyata. Jika 0.01 P 0.05, yang berarti tolak H0, maka pada taraf nyata () 5% kita dapat mengatakan bahwa peubah bebas (dalam RLS hanya X1) bersifat nyata Jika P 0.05, yang berarti terima H0, maka pada taraf nyata () 5% kita dapat mengatakan bahwa peubah bebas (dalam RLS hanya X1) bersifat tidak nyata (artinya : nilai b1 tersebut tidak nyata berbeda dengan nol). Cara lain yang dapat dilakukan dalam pengujian hipotesis di atas adalah dengan membandingkan nilai F tersebut dengan nilai F tabel, yakni apabila nilai F lebih besar dari nilai F tabel, maka H0 ditolak yang berarti bahwa satu atau lebih peubah bebas dalam model berpengaruh nyata pada taraf nyata () tertentu.

4.2. Interpretasi untuk Model Regresi Linier Berganda Pada dasarnya, interpretasi output Minitab untuk model regresi linier berganda hampir sama dengan regresi linier sederhana, kecuali bahwa pada regresi linier berganda terdapat lebih dari satu peubah bebas yang perlu kita perhatikan keberadaannya dalam model. Oleh karena itu, apabila Anda telah memahami output Minitab untuk regresi linier sederhana di atas, Anda pun akan lebih mudah untuk memahami regresi linier berganda.
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

19

Analisis Regresi Linier dengan Program Minitab for Windows

Sebagai contoh, perhatikanlah Gambar 15 berikut ini yang menyajikan output dari b b model : V = b0 .D 1 .T 2 yang apabila ditransformasikan ke dalam bentuk linier akan menjadi:

log V = log b0 + b1 log D + b2 log T


Y = a + bX 1 + cX 2

Gambar 15. Contoh output program Minitab untuk regresi linier berganda Secara umum, seperti terlihat pada Gambar 15, output program Minitab untuk regresi linier berganda tidak jauh berbeda dengan regresi linier sederhana, yakni terdiri atas: 1) persamaan garis regresi, 2) statistik bagi koefisien regresi, 3) statistik bagi model regresi, 4) tabel analisis ragam (ANOVA), dan 5) jumlah kuadrat sekuensial (sequential sum of squares). Oleh karena itu, pembahasan selanjutnya akan lebih ditekankan pada hal-hal yang belum dibahas pada pembahasan sebelumnya. Untuk lebih jelasnya, perhatikanlah uraian di bawah ini.

Persamaan garis regresi Seperti halnya pada regresi linier sederhana, pada bagian ini disajikan persamaan dari model regresi linier berganda untuk data contoh kita (lihat Tabel 1), yaitu :

log V = 3,92 + 1,92 log D + 0,568log T


Namun, karena kita melakukan transformasi ke bentuk logaritmanya, maka untuk mendapatkan model akhir perlu dilakukan lagi transformasi ke bentuk semula sebagai berikut:

log V = 3,92 + 1,92 log D + 0,568log T

logV = log b0 + b1 log D + b2 log T V = b0 .D b1 .T b2


Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

20

Analisis Regresi Linier dengan Program Minitab for Windows

Jadi : log b0 = 3,92 atau b0 = 0,00012, b1 = 1,92, dan b2 = 0,568. Sehingga diperoleh model akhir : V = 0, 00012.D1,92 .T 0,568 . Model inilah yang dapat Anda gunakan untuk menduga volume pohon pada diameter dan tinggi pohon tertentu.

Statistik bagi koefisien regresi Untuk regresi linier berganda, Minitab menyajikan nilai-nilai statistik bagi koefisien regresi baik nilai koefisiennya, simpangan baku untuk masing-masing koefisien, nilai t-hitung beserta nilai peluang (p) untuk pengujian keberartian koefisien regresi. Dengan cara interpretasi seperti pada regresi linier sederhana, kita dapat menganalisis output Minitab untuk regresi linier berganda, seperti terlihat pada Gambar 15, sebagai berikut : Constant, yakni dalam hal ini adalah log b0 = -3,9232 dengan simpangan baku 0,1472 dan nilai T= -26,65, pada taraf nyata 5% koefisien regresi ini tidak sama dengan nol sehingga berpengaruh nyata terhadap peubah responnya. Log-D, yakni merupakan b1 (dalam model umum regresi linier berganda) memiliki nilai koefisien sebesar 1,9196 dengan simpangan baku 0,1360. Dari nilai peluang bagi statistik T=14,11, terlihat bahwa pada taraf nyata 5% koefisien ini tidak sama dengan nol sehingga peranan peubah X1 (dalam hal ini D) diduga berpengaruh nyata terhadap peubah responnya. Log-T, yakni merupakan b2 (dalam model umum regresi linier berganda) memiliki nilai koefisien sebesar 0,5683 dengan simpangan baku 0,1386. Dari nilai peluang bagi statistik T=4,10, terlihat bahwa pada taraf nyata 5% koefisien ini pun tidak sama dengan nol sehingga peranan peubah X2 (dalam hal ini T) diduga berpengaruh nyata terhadap peubah responnya. Tentunya, apabila kita membuat model regresi linier berganda dengan peubah bebas lebih dari dua, maka Minitab akan menyajikan pula statistik bagi koefisien regresi lainnya.

Statistik bagi model regresi Seperti halnya pada regresi linier sederhana, Minitab menyajikan beberapa nilai statistik, yaitu : simpangan baku model (s), koefisien determinasi (R-Sq), dan koefisien determinasi terkoreksi (R-Sq (adj)), yang berguna sebagai kriteria dalam pemilihan model regresi terbaik. Dari output Minitab untuk model V = 0, 00012.D1,92 .T 0,568 di atas (seperti terlihat pada Gambar 15), dapat dikemukakan hal-hal berikut ini : Simpangan baku sisaan (s) dari model ini cukup kecil, yakni s = 0,03941. Apabila Anda menganalisis model lain, maka nilai simpangan baku (s) ini dapat Anda bandingkan satu sama lain sebagai salah satu kriteria dalam menentukan model regresi mana yang lebih baik, yakni model yang memiliki nilai simpangan baku sisaan yang paling kecil. Koefisien determinasi (R-Sq atau R2) untuk model ini cukup tinggi, yakni R2 = 98,3%. Hal ini berarti bahwa, peubah D (diameter) dan T (tinggi) pohon dapat menerangkan sebesar 98,3% keragaman dari volume pohonnya. Cobalah Anda bandingkan dengan nilai R2 dari regresi linier sederhana pada pembahasan sebelumnya (Gambar 14), yakni hanya sebesar 92,8%. Untuk sementara, mungkin
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

21

Analisis Regresi Linier dengan Program Minitab for Windows

Anda dapat menyimpulkan bahwa adanya penambahan peubah T (tinggi) dan transformasi model ke bentuk logaritma ternyata dapat meningkatkan koefisien determinasi model. Koefisien determinasi terkoreksi (R-Sq (adj)) untuk model ini pun cukup tinggi, yakni R2(adj)=98,0%. Seperti halnya pada koefisien determinasi belum terkoreksi (R2), nilai ini dapat dijadikan kriteria dalam pemilihan model terbaik. Tabel analisis ragam (ANOVA) Tampilan tabel analisis ragam (ANOVA) untuk regresi linier berganda hampir sama dengan regresi linier sederhana seperti pada pembahasan sebelumnya. Oleh karena itu, penjelasan lebih terperinci tentang bagian-bagian tabel analisis ragam ini dirasa cukup memadai. Hal terpenting yang ingin dibahas dibagian ini adalah interpretasi dari tabel analisis ragam untuk model regresi linier berganda di atas. Hal-hal yang dapat dikemukan tentang tabel analisis ragam seperti tersaji pada Gambar 15 di atas adalah sebagai berikut : Tabel ANOVA ini dapat digunakan untuk menguji hipotesis sebagai berikut : H0 : i = 0 , i = 1, 2, 3, ., k ; (artinya: semua peubah bebas tidak berpengaruh nyata terhadap respon) H1 : ada i 0 , i = 1, 2, 3, ., k ; (artinya: sekurang-kurangnya ada satu peubah bebas yang berpengaruh nyata terhadap respon) Nilai F (F-hitung) untuk model tersebut sebesar 349,14. Apabila Anda bandingkan nilai ini dengan nilai F tabel, atau cukup dengan melihat nilai P = 0,000, maka kita harus menolak H0 dan menyimpulkan bahwa pada taraf nyata 5% secara bersama-sama peranan peubah X1 (dalam hal ini D) dan peubah X2 (dalam hal ini T) dalam model regresi tersebut bersifat sangat nyata. Analisis selanjutnya dapat Anda lakukan untuk melihat peubah bebas yang mana yang berpengaruh lebih significant dibanding peubah bebas lainnya ataukah antar kedua peubah tersebut saling berkorelasi sehingga kita cukup mencantumkan salah satunya saja dalam model.

Jumlah Kuadrat Sekuensial (Sequential Sum of Squares) Khusus untuk regresi linier berganda, Minitab menyajikan output lain yaitu jumlah kuadrat sekuensial (sequential sum of squares, Seq SS) seperti terlihat pada tampilan berikut ini :

Jumlah kuadrat sekuensial (sequential sum of squares, Seq SS) tersebut menunjukkan tambahan jumlah kuadrat apabila suatu peubah dimasukkan ke dalam model setelah peubah lain ada dalam model tersebut, misal : peubah X2 setelah X1 ada dalam model. Dengan demikian, dari jumlah kuadrat sekuensial tersebut kita dapat pengaruh penambahan peubah baru dalam model regresi, apakah peubah baru tersebut berpengaruh nyata atau tidak. Namun demikian, jumlah kuadrat sekuensial ini tidaklah sama dengan uji T karena uji-T hanya menguji apakah masing-masing koefisien regresi sama dengan nol atau tidak.
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

22

Analisis Regresi Linier dengan Program Minitab for Windows

Dari tampilan jumlah kuadrat sekuensial di atas, kita dapat melakukan interpretasi sebagai berikut : Baris pertama : log-D, DF = 1, Seq SS = 1,05823, menyatakan tambahan jumlah kuadrat dari peubah X1 (dalam hal ini D) setelah b0 ada dalam model, adalah sebesar 1,05823 atau biasa dituliskan dalam notasi yang lebih ringkas sebagai : JK (b1|b0)=1,05823. Dengan kata lain, nilai ini menunjukkan pengurangan (reduksi) dalam jumlah kuadrat sisaan (JKS) akibat pengepasan (fitting) koefisien b1 (yakni akibat digunakannya X1 sebagai peubah bebas) dengan asumsi bahwa b0 telah ada dalam model. Dengan demikian, sesungguhnya nilai jumlah kuadrat sekuensial pada baris ini adalah sama dengan nilai jumlah kuadrat regresi linier sederhana (JKR) yang hanya melibatkan peubah X1 saja (Cobalah bandingkan nilai ini dengan JKR pada model V = b0 .D b1 , lihat Gambar 8, sama bukan ?). Baris kedua : log-T, DF = 1, Seq SS = 0,02612, menyatakan tambahan jumlah kuadrat dari peubah X2 (dalam hal ini T) setelah b0 dan b1 ada dalam model, adalah sebesar 0,02612 atau dapat dituliskan dalam bentuk notasi sebagai : JK (b2|b0, b1)=0,02612. Apabila model regresi linier berganda yang kita buat menggunakan lebih dari dua peubah bebas (katakan : X3, X4, ., Xk), maka pada bari-baris berikutnya akan ditampilkan pula nilai-nilai dari jumlah kuadrat sekuensial untuk masing-masing penambahan peubah baru secara berturut-turut, misalkan : JK (b3|b0, b1, b2), dsb. Perlu diingat bahwa, dalam hal ini Minitab menganalisis penambahan jumlah kuadrat dari peubah bebas baru tersebut sesuai urutan kehadiran peubah bebas dalam model yang kita spesifikasikan. Untuk kasus seperti di atas, model yang digunakan adalah Y = b0 + b1 X 1 + b2 X 2 . Sehingga, apabila Anda ingin menganalisis pengaruh penambahan peubah X1 setelah peubah X2 ada dalam model, maka Anda harus mengulangi lagi prosedur analisis regresi (lihat pembahasan sebelumnya) dengan memasukkan peubah X2 terlebih dahulu dan diikuti dengan peubah X1 sehingga spesifikasi modelnya menjadi : Y = b0 + b2 X 2 + b1 X 1 . Berdasarkan jumlah kuadrat sekuensial tersebut, kita dapat menganalisis bagaimana pengaruh penambahan peubah baru ke dalam model. Misalkan untuk contoh di atas, kita ingin tahu bagaimanakah pengaruh penambahan peubah X2 (log-T) setelah peubah X1 (log-D) ada dalam model ( log V = log b0 + b1 log D + b2 log T Y = b0 + b1 X 1 + b2 X 2 ). Untuk itu, lakukan uji F bagi penambahan peubah baru (X2 atau log-T) tersebut, dinotasikan sebagai Fhit ( b2 |b0 ,b1 ) , sebagai berikut:

Fhit ( b2|b0 ,b1 ) = = =

( JK ( JK

( b1 , b2|b0

JK(b1|b0

db( b2|b0 ,b1 )

KTS( b1 ,b2|b0 )
( b2|b0 , b1 )

db( b2|b0 ,b1 )

KTS( b1 ,b2|b0 )

Seq SS(log-T ) DF (untuk notasi dari output Minitab) MSE (0,02612)/(1) = 0,00155 = 16,85 ** ; karena nilai tabel : F0,05(1,12) = 4,75 , F0,01(1,12) = 9,33
Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

23

Analisis Regresi Linier dengan Program Minitab for Windows

Terlihat bahwa pengaruh penambahan peubah X2 (yakni log-T) tersebut, pada taraf nyata 5%, bersifat sangat nyata. Dengan prosedur seperti di atas, Anda dapat melakukannya untuk menganalisis setiap ada penambahan peubah bebas lain ke dalam model.

Catatan Penutup
Sesungguhnya masih banyak hal yang dapat dibahas tentang analisis regresi ini, baik menyangkut analisis sisaan maupun prosedur pemilihan regresi terbaik. Namun tulisan ini hanya dimaksudkan sebagai pengantar untuk pemahaman berikutnya, dan Insya Allah hal-hal yang menyangkut analisis lebih lanjut tentang analisis regresi tersebut dapat pemulis sajikan pada tulisan berikutnya. Akhir kata, dengan menyadari bahwa hanyalah ciptaan-Nya yang maha sempurna, penulis berharap semoga tulisan ini bermanfaat bagi yang memerlukannya. Tatang Tiryana (tangtir@ipb.ac.id)

Materi Tambahan untuk Modul Praktikum M.k. Ilmu Ukur Hutan, Fakultas Kehutanan IPB

24