Anda di halaman 1dari 21

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

INSTITUTO TECNOLOGICO DE CULIACAN


DEPARTAMENTO DE METAL-MECNICA

Prctica No. 1 Sistema automatizado con diagrama escalera.


+B +A +C A C B

Materia Automatizacin

Alumnos: Cabanillas Garca Pedro Oliver Quintero Castro Fernando Vargas Valdez Anayanzi Guadalupe

Nombre del Profesor M.C. Fabio Abel Aguirre Cerrillo

Fecha de realizacin de la prctica: ___________4 de Marzo del 2011_______________

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

CONTENIDO

1.- INTRODUCCIN .......................................................................................... 3

2.- MATERIAL UTILIZADO .............................................................................. 4

3.- DESARROLLO DE LA PRCTICA. ............................................................. 5

4.- CONCLUSION ............................................................................................... 7

5.- ANEXO ........................................................................................................... 8

A) DIAGRAMA ELECTRO-NEUMTICA EN FLUIDSIM. ................................................................... 8

B) INTRODUCCIN AL SOFTWARE FST 4.10 DE FESTO. .............................................................. 9

C) DIAGRAMA ESCALERA. ........................................................................................................ 15

D) DIAGRAMA ESCALERA ELABORADO EN EL SOFTWARE FST. ............................................. 15

E) INTERFACE ENTRE LA PC Y EL PLC FESTO COMPAC FC34. .................................................... 17

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

1.- Introduccin
La presente prctica fue elaborada en el Instituto Tecnolgico de Culiacn para la materia de Automatizacin, llevada a cabo por alumnos del 10 semestre de Ingeniera Mecatrnica.

La prctica se basa en un ecuacin de movimiento dada +B+A+C-A-C-B la cual nos da a entender que trata de una secuencia de entradas y salidas de tres pistones, los cuales manejaremos neumticamente con un PLC (Controlador Lgico Programable).

Utilizaremos como auxiliar el software de FST de FESTO para la elaboracin del diagrama escalera el cual introducimos al PLC por medio de un cable convertidor USB a RJ45 (entrada del PLC).

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

2.- Material utilizado


Para la puesta en marcha de la prctica se utilizaron los siguientes materiales.

Software FluidSim Neumtico de FESTO (Para simulacin y diagrama elctrico). Software FST de FESTO (Para diagrama escalera). Banco de pruebas de neumtica (laboratorio de Mecatrnica). Fuente de alimentacin para el PLC, marca FESTO de 24V /4,5 DC. PLC de la familia FEC compac FC34, con botonera integrada. 1 Vlvula 5/2 y 1 vlvula 3/2 monoestables marca SMC servo-pilotadas. 1 Vlvula 5/2 bi-estable servo-pilotada marca SMC. 2 Cilindros neumticos de doble efecto 1 cilindro de simple efecto retorno por muelle. 1 Sensor ptico a tres hilos 1 sensor inductivo a tres hilos 2 Sensores de fin de carrera a dos hilos 2 Sensores magnticos a dos hilos

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

3.- Desarrollo de la prctica.


Primeramente nos dimos a la tarea de de elaborar una simulacin de la ecuacin de movimiento proporcionada previamente, la simulacin se llevo a cabo en el Software FluidSim Neumtica de FESTO.

Imagen 1.- Desarrollo de la ecuacin de movimiento.

Imagen 2.- Simulacin de la ecuacin de movimiento +B+A+C-A-C-B.

Se elaboro un diagrama paso a paso con relevadores para efectuar el funcionamiento que indica la Ecuacin +B+A+C-A-C-B, en la cual nos obliga a colocar tres pistones a los cuales se les asignan las letras A, B y C respectivamente.

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

Ya elaborada la simulacin de la ecuacin de movimiento, se paso a construir el diagrama escalera el cual se realizo con ayuda del Software FST de FESTO.

Imagen 3.- Diagrama escalera, para el control del PLC.

EN la Imagen 3, podemos apreciar el diagrama escalera que se genero para programar el PLC, con esto se logra un manejo del Software FST de FESTO. Adems se cre un diagrama elctrico a peticin del asesor de la materia.
+24V 1 2 4 5 6 7

S1

S3 S2

S4

S5

S6

24V I0

I1

I2

I3

I4

I5

I6

I7

0V Q0 Q1 Q2 Q3 Q4 Q5 Q6 Q7

0V

Imagen 4.- Diagrama elctrico.

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

4.- CONCLUSION
Se concluyo que esta prctica es de vital importancia para reafirmar los conocimiento de neumtica, electro-neumtica y PLC. Se volvi una prctica multidisciplinaria ya que agrupa varios conocimientos.

Imagen 5.- Practica 1 +B+A+C-A-C-B

Imagen 6.- Sensores utilizados.

En la Imagen 6 se muestran los sensores utilizados en la prctica. A) Sensor todo-nada con rodillo de dos hilo, B) sensor inductivo de tres hilos, C) sensor todo-nada ptico de dos hilos y D) sensores magnticos de dos hilos.

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

5.- ANEXO
A) DIAGRAMA ELECTRO-NEUMTICA EN FLUIDSIM.

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

B) INTRODUCCIN AL SOFTWARE FST 4.10 DE FESTO.


Para la elaboracin del diagrama escalera utilizamos un software y para su uso se necesito aprender a manejarlo.

1.- Despus de instalado en la PC del software FST en este caso la versin 4.10 iniciamos el programa, ya sea con el icono de acceso directo localizado en el escritorio el cual se muestra en la Imagen 7 o desde Inicio> todos los programas > festo software > FST 4.10 > .

Imagen 7. Icono de acceso directo en el escritorio

2.- Para iniciar un proyecto nuevo nos vamos a la barra de herramientas en Project > New.. Nos aparecer una pantalla donde colocaremos el nombre con el que vamos a llamar a nuestro proyecto como se aprecia en la Imagen 8.

Imagen 8. Nombrar el nuevo proyecto

3.- Despus de asignar un nombre a nuestro nuevo proyecto y dar en ok nos abre dos ventanas nuevas las cuales se muestran en la Imagen 9. En la ventana b) que aparece seleccionamos la familia
9

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

del PLC que vamos a utilizar, y de ser necesario se agrega un comentario y se procede a dar clic en OK.

Imagen 9. Se abren dos ventanas nuevas.

De la Imagen 9, la ventana a), vamos a localizar Allocation List al dar doble clic en este apartado se desplegara otra ventana, en la cual vamos a agregar las entradas y salidas que asignaremos en el programa, tomando como entradas los sensores y botones de inicio, como salidas son las vlvulas neumticas que accionaran los cilindros ya que darn paso al aire para mover los actuadores.

4.- Luego de haber hecho doble clic en Allocation List se desplegara una cuadro similar al del cuadro del fondo de la Imagen 10, en la cual dentro damos un clic derecho y aparecer una opcin

10

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

llamada Insert Operand, al dar clic a esta opcin se abrir un recuadro similar al del cuadro pequeo de la Imagen 10, en donde pedir especificar si es entrada o salida, adems puede asignar un smbolo para mayor relacin y adems se puede agregar un comentario para tener una explicacin ms clara de ese comando.

Imagen 10. Agregar comandos que se utilizaran en el programa.

Para lograr este paso debe de preferencia tenerse una simulacin electro-neumtica en FluidSim, de tal manera se tendrn ms en mente las entradas y salidas que se utilizaran en el programa y as se logran disminuir la cantidad de errores ya que uno va viendo el movimiento que se desea obtener.

11

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

5.- Ya que terminamos de agregar nuestras entradas y salidas cerramos la ventana, y damos clic derecho en Controller Settings y en el desplegado damos clic izquierdo en Open como se muestra en la Imagen 11.

Imagen 11. Descarga de archivos para la comunicacin con el PLC.

Se abrir una ventana similar a la Imagen 12, ah se busca y abre la pestaa Download y adems se Palomean las opciones Delete project before download y la opcin Download source files y se deja seleccionada la opcin Download modified driver file y se finaliza dando clic en aceptar.

Imagen 12. Aceptar eliminar proyectos antiguos, se descargan los cdigos fuente y las modificaciones

12

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

6.- Ahora nos damos a la tarea de dar clic derecho en Programs a continuacin se desplegara una cortina y nos dirigiremos a dar clic en New Program..

Imagen 13. Acceso al editor del diagrama escalera.

En la ventana que se abra se debe seleccionar el lenguaje con el que se desea programar, este software maneja dos tipos como son Statement List y Ladder Diagram, al segundo diagrama escalera es el cual seleccionaremos y posterior a eso daremos clic en OK para aceptar la decisin.

Imagen 14. Seleccin del lenguaje de programacin.

Si es el primer programa se coloca como programa 0 y versin 1, si ya se genero un programa anterior mente es recomendable dejar el 0 en programa y variar la versin a un numero que contine la secuencia.

13

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

7.- Para lograr comenzar con nuestro programa es necesario tener visible la barra de herramientas necesaria llamada Shortcuts la cual nos permitir agregar los iconos necesarios para completar el diagrama escalera. Para la visibilidad de esta barra ingresamos a View > Shortcuts. La barra luce como se muestra en la Imagen 15.

Imagen 15. Barra de atajos Shortcuts.

Los smbolos mas destacados para esta prctica derivados de la barra de atajos Shortcurts se describen en la Tabla 1.

Tabla 1. Simbologa y funcin de la barra de atajos shortcurts.

SMBOLO

FUNCIN
Agrega una lnea delante de la seleccionada Agregar lnea antes de la seleccionada Agregar un contacto normalmente abierto Agregar contacto normalmente abierto en forma paralela Agregar una bobina normalmente abierta Negativa, para volver contactos y bobinas normalmente abiertas en normalmente cerradas.

14

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

C) DIAGRAMA ESCALERA.

Ilustracin 1.- Allocation List Con la cual logramos nuestro programa.

D) DIAGRAMA ESCALERA ELABORADO EN EL SOFTWARE FST.

15

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

16

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

E) INTERFACE ENTRE LA PC Y EL PLC FESTO COMPAC FC34.


Para lograr la interface fue necesario realizar los pasos siguientes.

1.- El M.C. Fabio Abel Aguirre Cerrillos nos proporciono los cables para lograr la conexin de la PC al PLC, y para ello se necesitaron los siguientes componentes.

Fuente de alimentacin didctica marca FESTO (24V/4.7A DC)

Cable USB macho a JR45 Macho

Imagen 16. Fuente de alimentacin didctica FESTO.

PLC Festo compac FC45 con botonera integrada, didctico.

Imagen 19. Cable USB a JR45.

Cable extensin serial hembra a serial hembra

Imagen 17. PLC FESTO compac FC34.

Cable USB macho a Serial macho

Imagen 20. Extensin serial a serial.

Imagen 18. Cable USB a Serial.

17

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

2.- Como siguiente paso se procedi a la conexin de los cables. Conexin 1

Imagen 21. Conexin cable JR45 al PLC.

Conexin 2

Imagen 22. Conexin Serial macho en extensin serial hembra

Conexin 3

Imagen 23. Conexin serial extensin hembra a serial macho.

Conexin 4

Imagen 24. Conexin USB macho a USB Hembra de PC.

18

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

3. Para lograr una comunicacin entre la PC y el PLC es necesaria la instalacin del controlador PL2303 que se puede encontrar fcilmente en internet.

Imagen 25. Instalacin del Driver.

4.- Automticamente la computadora detectara que el USB es controlable y asignara un nmero de puerto segn donde se encuentre conectado el cable USB, de no ser as es recomendable desconectar el cable USB, reinstalar el Driver y posterior a esto conectar de nuevo el cable USB a la PC.

Imagen 26. Asignacin del puerto.

Una vez conocido el puerto al cual se conecto el Cable USB, es necesario abrir nuestro diagrama escalera, ya estando dentro del programa damos clic en Extras > Preferences.

19

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

5.- Aparecer un cuadro en el cual seleccionaremos el puerto en el cual conectamos nuestro cable USB en el apartado de General en donde dice Local COM Post, una vez escrito nuestro puerto damos en Aceptar para guardar nuestra preferencia.

Imagen 27. Alinear el puerto asignado a la conexin.

6.- La barra de herramientas localizada en la parte superior de la ventana del programa encontramos unos iconos similares a los que se aprecian en la Imagen 28. De los cuales los tres primeros, de izquierda a derecha de la imagen, son con los cuales comprobaremos si tenemos error en nuestro programa, una vez analizado esto con xito lograremos una buena comunicacin con el PLC.

Imagen 28. Iconos para la deteccin de errores y comunicacin con el PLC.

20

Automatizacin

Prcticas de Laboratorio de Ingeniera Mecatrnica

8.- Para la comunicacin en lnea podemos acezar de dos maneras. 1- Dando clic derecho en el programa y de la plantilla que despliegue seleccionar online. 2- Entrando en la barra de herramientas a Online y posteriormente Online.

De esta manera logramos la comunicacin con el PLC, si es necesario editar de nuevo el programa por cualquier error que pudiera haber en la programacin es necesario salir del modo online, esto se logra ingresando en la barra de Herramientas a online y dar clic en el apartado editor.

21