Anda di halaman 1dari 65

LAPORAN PRAKTIKUM I Informatika

Disusun Oleh :

Bryan NIM . 211341032

TEKNIK OTOMASI MANUFAKTUR & MEKATRONIKA POLITEKNIK MANUFAKTUR NEGERI BANDUNG Maret, 2011

Page 1

Page 2

Pengenalan MS Access & Membuat DATABASE


1.1. Pengertian Microsoft Access Microsoft Access adalah suatu program aplikasi basis data komputer relasional yang digunakan untuk merancang , membuat dan mengolah berbagai jenis data dengan kapasitas yang besar . Database adalah kumpulan tabel tabel yang saling berelasi .Antar tabel yang satu dengan yang lain saling berelasi , sehingga sering disebut basis data relasional . Relasi antar tabel dihubungkan oleh suatu key , yaitu primary key dan foreign key . 1.2. Tampilan Microsoft Access 2007

1.3. Membuka Microsoft Access 2007

Page 3

Click Start

All Program

Microsoft Office

Microsoft Access 2007

Kemudian akan tampil jendela Microsoft Access Lalu click Blank Database untuk membuat database Membuat database Buku.accdb kemudian click tombol create

A .Ribbon Pengganti Menu dan Toolbar pada Microsoft Access 2007 dirancang untuk membantu kerja agar lebih produktif serta mudah dalam menggunakan seluruh fasilitas dan fungsi yang disediakan oleh access 2007 .

Page 4

B. Ribbon ini terdiri dari beberapa TABS yang mengorganisasikan berbagai skenario khusus dan objek sesuai dengan aktifitasnya . C. Masing Tabs terdiri dari beberapa Groups . D. Setiap Group terdiri atas beberapa Tombol Perintah atau Command Button .

Contextual Tabs

1. Objek yang sedang dipilih 2. Contextual Tools yang Otomatis tampil 3. Contextual Tabs untuk menyunting objek

Komponen utama 1. Table Table adalah objek utama dalam database yang digunakan untuku menyimpan sekumpulan data sejenis dalam sebuah objek .
Page 5

Table terdiri atas : a. Field Name : Atribut dari tabel yang menempati sebuah kolom . b. Record : Isi dari field atau atribut yang saling berhubungan yang menempati bagian baris 2. Query Query adalah bahasa untuk melakukan manipulasi terhadap database . Digunakan untuk menampilkan , mengubah , dan menganalisa sekumpulan data . Query dibedakan menjadi 2 yaitu : 1. DDL ( Data Definition Language ) digunakan untuk membuat atau mendefinisikan objek objek database seperti membuat tabel , relasi antar tabel dan sebagainya . 2. DML ( Data Manipulation Language ) digunakan untuk manipulasi database : seperti menambah , mengubah , atau menghapus data serta mengambil informasi yang diperlukan dari database . 3. Form Form digunakan untuk mengontrol process masukan data ( input ) , menampilkan data ( output ) , memeriksa dan memperbaharui data . 4. Report Report digunakan untuk menampilkan data yang sudah dirangkum dan mencetak data secara efektif . Tipe Data 1. Text Text digunakan untuk field alfanumeric ( misal : nama , alamat , kode pos , telepon ) , sekitar 255 karakter tiap fieldnya . 2. Memo Memo dapat menampung 64000 karakter tiap fieldnya , tapi tidak bisa diurutkan / diindeks . 3. Number Number digunakan untuk menyimpan data numeric yang akan digunakan untuk proses perhitungan matematis . 4. Date/Time Format digunakan untuk menentukan cara bilangan , tanggal , waktu , dan teks ditampilkan dan dicetak . Penggunaan salah satu format yang sudah terdefinisi atau membuat sendiri menggunakan simbol simbol format . 5. Currency Format tipe data Number yang menggunakan pemisah ribuan , menampilkan bilangan negatif dalam kurung . 6. Auto Number
Page 6

Properti yang digunakan untuk menentukan jumlah bilangan decimal yang merupakan nilai default . Bilangan tampil seperti yang dinyatakan dalam properti format . 7. Yes/No Properti yang digunakan untuk membuat field indeks tunggal . Indeks mempercepat query pada fields yang di index , demikian juga pada proses pengurutan dan pengelompokan data . 8. OLE Object OLE Object digunakan untuk eksternal object , seperti bitmap atau file suara . 9. Hyperlink 10. Lookup Wizard Jika menggunakan tipe data ini untuk sebuah field ,maka bisa memilih sebuah nilai dari tabel lain atau dari sebuah daftar nilai yang ditampilkan dalam combo Box .

Page 7

Membuat Hubungan Antar Tabel


2.1 Relationship Tabel Tabel Relationship adalah relasi atau hubungan antara beberapa tabel . Relasi antar tabel dihubungkan oleh primary key dan foreign key .

2.2 Step step Membuat Hubungan Antar Tabel


Buat database

Buat Tabel

Page 8

Layout Tampilan Design Tabel

Buat Hubungan Antar Tabel

Page 9

Apakah hubungan tabel Dalam database relasional, hubungan memungkinkan untuk mencegah data yang berlebihan. Sebagai contoh, jika merancang sebuah database yang akan melacak informasi tentang buku-buku, Mungkin memiliki meja disebut judul yang menyimpan informasi tentang masing-masing buku, seperti judul buku, tanggal publikasi, dan penerbit. Ada juga informasi yang Anda mungkin ingin menyimpan tentang penerbit, seperti penerbit nomor telepon, alamat dan kode pos. Jika Anda untuk menyimpan semua informasi ini dalam judul tabel, penerbit nomor telepon akan digandakan untuk setiap judul yang penerbit cetakan. Solusi yang lebih baik adalah untuk menyimpan informasi penerbit hanya sekali dalam sebuah meja tersendiri, penerbit. Anda akan kemudian menempatkan pointer di Judul tabel yang referensi entri dalam tabel penerbit. Pada Pastikan bahwa data Anda tidak sinkron, Anda dapat menerapkan referensial integritas antara tabel judul dan penerbit. Integritas referensial hubungan membantu memastikan bahwa informasi di satu meja sesuai informasi dalam lain. Sebagai contoh, setiap judul dalam judul tabel harus terkait dengan penerbit tertentu dalam tabel penerbit. Judul tidak ditambahkan ke database untuk penerbit yang tidak ada di database. Jenis hubungan tabel Hubungan bekerja dengan mencocokkan data dalam kolom kunci, biasanya kolom dengan nama yang sama dalam tabel kedua. Dalam kebanyakan kasus, hubungan cocok dengan kunci utama dari satu meja, yang menyediakan pengidentifikasi unik untuk setiap baris, dengan entri di kunci asing dalam tabel lainnya. Sebagai contoh, penjualan dapat dikaitkan dengan judul tertentu yang dijual oleh menciptakan hubungan antara title_id kolom dalam tabel judul (primary key) dan title_id kolom dalam tabel penjualan (kunci asing). Ada adalah tiga jenis hubungan antara tabel. Jenis hubungan yang dibuat tergantung pada bagaimana berkaitan kolom didefinisikan. Satu-ke-banyak hubungan Hubungan satu ke banyak adalah jenis yang paling umum hubungan. Jenis hubungan, baris dalam tabel a dapat memiliki banyak Pencocokan baris dalam tabel B, tapi baris dalam tabel b dapat memiliki hanya satu baris pencocokan dalam tabel A. Sebagai contoh, penerbit dan judul tabel memiliki satu-ke-banyak hubungan: setiap penerbit menghasilkan banyak judul, tetapi setiap judul berasal dari hanya satu penerbit. Hubungan satu-ke-banyak dibuat jika hanya satu kolom terkait primary key atau memiliki kendala unik.Dalam akses, sisi kunci utama dari hubungan satu-ke-banyak yang dilambangkan oleh kunci simbol. Sisi kunci asing hubungan yang dilambangkan oleh infinity simbol. Banyak-banyak hubungan Dalam banyak-banyak hubungan, baris dalam tabel a dapat memiliki banyak Pencocokan baris dalam tabel B, dan sebaliknya. Anda membuat hubungan dengan mendefinisikan meja ketiga, disebut meja persimpangan, kunci utama yang terdiri dari kunci asing dari kedua tabel a dan tabel B. Misalnya, tabel penulis dan judul tabel hubungan banyak-banyak yang didefinisikan oleh satu-ke-banyak Page 10

hubungan dari masing-masing tabel TitleAuthors tabel. Primary key TitleAuthors meja adalah kombinasi dari au_id kolom (tabel penulis primary key) dan kolom title_id (judul Tabel primary key). Satu-satu hubungan Dalam hubungan banding, baris dalam tabel a dapat memiliki tidak lebih daripada satu pencocokan baris dalam tabel B, dan sebaliknya. Hubungan banding dibuat jika kedua berkaitan kolom kunci primer atau memiliki unik kendala. Jenis hubungan ini tidak umum karena sebagian besar informasi yang terkait dengan cara ini akan menjadi semua dalam satu meja. Anda mungkin menggunakan satu-satu hubungan dengan:

Membagi meja dengan banyak kolom. Mengisolasi bagian dari tabel untuk alasan keamanan. Menyimpan data yang berumur pendek dan bisa dengan mudah dihapus dengan hanya menghapus meja. Menyimpan informasi yang hanya berlaku untuk bagian utama tabel.

Dalam akses, sisi kunci utama dari hubungan satu adalah dilambangkan oleh simbol kunci. Sisi kunci asing juga dilambangkan oleh simbol kunci. Bagaimana untuk menentukan hubungan antara tabel Bila Anda membuat hubungan antara tabel, bidang terkait tidak harus memiliki nama yang sama. Namun, bidang terkait harus sama data jenis kecuali bidang kunci utama bidang AutoNumber. Anda dapat menyesuaikan Bidang AutoNumber dengan nomor lapangan hanya jika FieldSize properti kedua bidang pencocokan adalah sama. Sebagai contoh, Anda dapat menyesuaikan bidang AutoNumber dan lapangan nomor jika FieldSize properti dari kedua bidang adalah bulat panjang. Bahkan ketika kedua pencocokan bidang kolom non-nomor, mereka harus sama FieldSize pengaturan properti. Bagaimana untuk menentukan satu-ke-banyak atau satu-satu hubungan Untuk membuat satu-ke-banyak atau satu-satu hubungan, ikuti langkah-langkah berikut: 1. Dekat setiap meja yang Anda buka. Anda tidak dapat membuat atau mengubah hubungan antara tabel terbuka. 2. Pada tahun 2002 akses atau akses 2003, ikuti langkah berikut: a. Tekan F11 untuk beralih ke jendela Database. b. Pada Alat menu, klik Hubungan. Di Access 2007, klik Hubungan dalam Tampilkan/Sembunyikan kelompok pada Database Tools tab. Jika Anda belum ditetapkan hubungan apapun dalam Anda database, Show tabel kotak dialog akan ditampilkan secara otomatis. Jika Anda ingin menambahkan tabel yang Anda ingin berhubungan, tetapi Show tabel kotak dialog tidak ditampilkan, klik Show tabel pada Hubungan menu. Klik dua kali nama tabel yang ingin Anda berhubungan, dan kemudian tutup Show tabel kotak dialog. Untuk membuat hubungan antara meja dan itu sendiri, menambahkan meja dua kali. Tarik bidang yang Anda ingin berhubungan dari satu meja untuk bidang terkait di atas meja. Untuk tarik beberapa bidang, tekan CTRL, Klik masing-masing bidang, dan kemudian menyeret Page 11

mereka. Dalam kebanyakan kasus, Anda menarik utama bidang kunci (yang ditampilkan dalam huruf tebal) dari satu meja ke serupa bidang (sering dengan nama yang sama) yang disebut kunci asing dalam tabel lainnya. The Mengedit hubungan kotak dialog akan ditampilkan. Memastikan bahwa nama kolom ditampilkan dalam dua kolom benar. Anda dapat mengubah mereka jika diperlukan. Set hubungan pilihan jika diperlukan. Jika Anda membutuhkan informasi tentang spesifik item pada Mengedit hubungan kotak dialog, klik tombol tanda tanya, dan kemudian klik item. Pilihan ini akan dijelaskan secara rinci nanti dalam ini artikel. Klik Buat untuk menciptakan hubungan. Ulangi langkah 5 hingga 8 untuk setiap pasangan dari tabel yang Anda ingin berhubungan. Ketika Anda menutup Mengedit hubungan kotak dialog, Microsoft Access bertanya jika Anda ingin menyimpan tata letak. Apakah Anda menyimpan tata letak atau tidak, hubungan yang Anda buat akan disimpan dalam database. CATATAN: Anda dapat membuat hubungan di query serta tabel. Namun, integritas referensial tidak diberlakukan dengan queries. Bagaimana untuk menentukan banyak-ke-banyak hubungan Untuk membuat banyak-banyak hubungan, ikuti langkah berikut: 1. Membuat tabel dua yang akan memiliki banyak-ke-banyak hubungan. 2. Membuat sebuah tabel yang ketiga, yang disebut persimpangan meja, dan kemudian tambahkan untuk bidang baru tabel persimpangan dengan definisi yang sama sebagai primary key bidang dari masing-masing dua tabel. Dalam tabel persimpangan, utama bidang kunci berfungsi sebagai kunci asing. Anda dapat menambahkan bidang lain ke persimpangan tabel, sama seperti Anda dapat untuk setiap meja. 3. Dalam tabel persimpangan, mengatur kunci utama untuk memasukkan bidang kunci utama dari dua tabel. Sebagai contoh, di TitleAuthors persimpangan meja, primary key akan terdiri dari nomorPesanan dan ProductID bidang. CATATAN: Untuk menciptakan kunci utama, ikuti langkah berikut: a. Buka tabel dalam Design view. b. Pilih bidang atau bidang yang Anda ingin mendefinisikan sebagai primary key. Untuk memilih salah satu bidang, klik baris pemilih untuk yang diinginkan lapangan. Untuk memilih beberapa bidang, tahan tombol CTRL dan kemudian Klik baris pemilih untuk setiap bidang. c. Pada tahun 2002 akses atau akses 2003, klik Primary Key di toolbar. Di Access 2007, klik Primary Key dalam Alat kelompok pada Desain tab. Catatan Jika Anda ingin untuk bidang dalam beberapa bidang utama kunci untuk menjadi berbeda dari urutan bidang tersebut dalam tabel, klik Indeks di toolbar untuk menampilkan Indeks dialog kotak, dan kemudian menyusun ulang nama kolom untuk indeks bernama PrimaryKey. Menentukan satu-ke-banyak hubungan antara masing-masing dari dua meja utama dan persimpangan meja.

Menggunakan Form untuk Menampilkan Data


Page 12

Form adalah salah satu obyek basis data dalam Microsoft Access yang digunakan sebagai antar muka bagi pengguna untuk memasukkan data atau menampilkan data. Pada Microsoft Access, dikenal ada tiga model form, yaitu: form data entry , form switchboard dan form custom dialog . Ada dua cara pembuatan form pada Micosoft Access, yaitu dengan menggunakan Wizard dan dengan menggunakan Design View. Wizard merupakan cara yang paling mudah, karena kita Microsoft Access akan melakukan pembuatan form secara otomatis. Sedangkan pada Design View kita melakukan rancangan form secara manual. Kita dapat memodifikasi hasil dari Wizard dengan Design View.

Membuat Form Pada bagian ini kita akan membuat form dengan mode Wizard. Form pertama yang akan kita buat adalah form untuk input data Pembeli. 1. Pada jendela Database, click pada object Form, kemudian double click pada Create form by using Wizard. Jendela Form Wizard akan terbuka .

Page 13

2.Pada jendela Form Wizard, click pada combo box Tabel/Queries dan pilih tabel pembeli (Gambar 1, kemudian click tombol >> sehingga semua field yang ada pada bagian Available Fields berpindah ke Selected Fields . Kemudian click Next untuk memunculkan jendela untuk memilih model tampilan form

Page 14

3.Pada Gambar tersedia beberapa opsi model tampilan form. Kita akan mencoba membuat dengan model Columnar. Namun pembaca dapat mencoba membuat dengan model tampilan lain yang tersaji pada pilihan. Click tombol Next maka akan muncul jendela untuk memilih style. Pada jendela ini kita dapat memilih sesuai keinginan kita dan setelah selesai kita click Next sehingga muncul jendela untuk member Title atau judul form yang telah kita buat. Isikan nama form pada Textbox yang telah disediakan .

Page 15

4.Click tombol Finish . Form pembeli telah selesai kita buat dan hasilnya tampak . Ada bagian yang sangat penting pada Form telah kita buat. Yaitu tombol navigasi dan tombol menambah record baru. Tombol navigasi berfungsi untuk melihat data yang telah kita buat secara urut berdasarkan id_pembeli. Sedangkan apabila tombol menambah form di-click, maka teks yang ada pada seluruh textbox akan dikosongkan dan kita dapat mulai mengisi data baru.

Dengan cara yang sama kita dapat membuat form-form yang lain. Sebagai contoh berikut ini tampilan akhir untuk Form Buku. Memodifikasi Form Membuat form dengan menggunakan mode wizard memiliki keuntungan yaitu, kemudahan dan kecepatan dalam pembuatan. Namun disisi lain juga memiliki kerugian karena semua format telah ditentukan secara otomatis. Sebagai contoh baik pada dan , kita melihat namanama fields pada form dibuat sama persis seperti pada nama fields pada tabelnya. Untungnya pada Microsoft Access menyediakan fasilitas untuk memodifikasi form. Berikut ini langkahlangkah untuk memodifikasi form. 1. Pada jendela Database, pilih Form. Kemudian click kanan pada nama form yang ingin kita modifikasi. Pilih Design View pada pop menu yang muncul, sehingga jendela form yang akan kita modifikasi .

Page 16

2.Pada Gambar 11.45, yang akan kita akan modifikasi adalah Form Pembeli. Sebelum kita modifikasi kita perlu tahu bagian-bagian dari suatu form. Gambar 11.46. menunjukkan bagian-bagian utama dari suatu form. Secara umum ada tiga bagian pada form, yaitu Form Header, Detail dan Form Footer. Form Header biasanya berisi judul form dan logo tertentu. Bagian Detail merupakan bagian utama karena disinilah tempat kita meletakkan field-field yang akan diisi datanya. Bagian Form Footer bersifat opsional (boleh dipakai boleh tidak). Biasanya Form Footer akan berisi keterangan-keterangan lain misalnya nama pembuat, nama pengisi data dan lain-lain.

Page 17

3.Microsoft Access menggunakan control-control yang sama seperti pada bahasa pemrograman berbasis GUI (lihat kembali Bab 13). Pada form kita akan menjumpai control Label, Text Box, Combo Box, Command Button dan lain-lain. 4. Modifikasi pertama yang kita lakukan adalah memperbaiki tampilan pada nama-nama fields. Caranya dengan click pada Label yang ingin kita perbaiki. Kemudian ganti atau ubah dengan cara mengetikkan nama yang baru. Setelah semua selesai tampilan Form Pembeli akan tampak seperti pada Gambar 11.47. Perhatikan perbedaan Label fields pada Gambar 11.45 dan Gambar 11.47.

Modifikasi berikutnya yang akan kita lakukan adalah menambahkan tombol-tombol untuk memudahkan pengguna dalam mengisi data. Untuk melakukan ini kita harus mengatur form menjadi seperti pada Gambar 11.48. Kemudian kita tambahkan tombol dengan cara click pada icon Command Button pada Toolbar, lalu letakan pada Form. Jendela Command Buttom Wizards akan muncul seperti pada Gambar 11.49. Pada Categories pilih Record Operations dan pada Actions pilih Add New Record. Click Next untuk melanjutkan. Pada jendela berikutnya (Gambar 11.50) pilih Text dan ketikkan Tambah lalu klik Next. Pada jendela berikutnya (Gambar 11.51) ketikkan nama untuk command button ini, kita berikan nama misalnya cmdTambah lalu klik Finish.

Page 18

Page 19

Kita tambahkan tombol yang berfungsi menghapus data. Cara pembuatannya persis seperti di atas hanya saja pada jendela Command Buttom Wizards, Categories dipilih Record Operations dan Actions yang dipilih adalah Delete Record (Gambar 11.52). Tentukan teks dan nama command button yang sesuai.

Page 20

7. Tampilan akhir dari form setelah dimodifikasi akan tampak seperti pada Gambar 11.53.

Membuat Query
Query adalah permintaan yang diberikan oleh user untuk mengambil informasi yang tersimpan dalamdatabase. Fungsi dari Query adalah untuk menyaring dan menampilkan data dari berbagai criteria dan urutan yang kita kehendaki. Contoh : Menampilkan mahasiswa yang tinggal di kota Semarang Menampilkan mahasiswa yang IPKnya > 3 Menampilkan mahasiswa yang memiliki nama tertentu Query pada Microsoft Access Langkah awal pembuatan query adalah dengan mengklik menu/object Query :

Page 21

Query pada Microsoft Access memiliki tiga bentuk yaitu : 1. Sql View Perintah sql yang deiberkan untuk sebuah query 2. Query Design Interface yang disediakan oleh Microsoft Access untuk melakukan query secara cepat dan mudah. 3. Query Wizard Hasil tampilan data dari perintah query sesuai definisi dari design view atau sql view Query dengan SQL View SELECT Perintah SQL untuk menampilkan data memiliki cara penulisan sebagai berikut : SELECT * | [ kolom1,kolom2,...] FROM <nama table> [ WHERE <kondisi>]; SELECT artinya memilih kolom atau field mana yang akan ditampilkan Dapat berupa list kolom, suatu persamaan (operasi aritmatika), fungsi, obyek tertentu Dapat diketikkan * yang artinya menampilkan semua field yang dimiliki oleh table tersebut FROM menunjukkan nama Tabel yang akan ditampilkan WHERE untuk meletakkan definisi kondisi penyaringan Berikut contoh query dan perintah SQL untuk penyelesaiannya : 1. Query : Tampilkan semua kolom yang ada pada table pegawai SELECT * FROM pegawai; 2. SELECT artinya memilih kolom atau field mana yang akan ditampilkan Dapat berupa list kolom, suatu persamaan (operasi aritmatika), fungsi, obyek tertentu Dapat diketikkan * yang artinya menampilkan semua field yang dimiliki oleh table tersebut FROM menunjukkan nama Tabel yang akan ditampilkan WHERE untuk meletakkan definisi kondisi penyaringan Berikut contoh query dan perintah SQL untuk penyelesaiannya : 1. Query : Tampilkan semua kolom yang ada pada table pegawai SELECT * FROM pegawai; 2. Query : Tampilkan kode buku dan judulnya SELECT kodebuku, judul FROM buku; 3. Query : Tanpilkan nim, nama, jenisKelamin dan tglLahir mahasiswa dengan nama field dari jenisKelamin diberi alis SEX dan tglLahir diberi alias Tanggal Lahir dari table mahasiswa; SELECT nim, nama, jenisKelamin as [SEX], tglLahir as [Tanggal Lahir]; Operator perbandingan yang dapat digunakan adalah : = (sama dengan), <> (tidak sama dengan) LIKE (khusus untuk data char/varchar yang mencari data berdasarkan pola. Karakter khusus yang dapat dimasukkan dalam operator LIKE antara lain % untuk sembarang lebih dari satu karakter, _ atau garis bawah untuk mewakili sembarang satu karakter), BETWEEN nilai_awal AND nilai_akhir (untuk menguji apakah suatu nilai berada di antara nilai_awal dan
Page 22

nilai_akhir), >, >=, <, <= (lebih besar, lebih besar atau sama dengan, lebih kecil, lebih kecil atau sama dengan), IS NULL atau IS NOT NULL (digunakan untuk menguji apakah nilai suatu kolom kosong atau tidak Selain itu, jika anda memiliki dua atau lebih ekspreis perbandingan, anda harus menggunakan salah satu dari operator logika berikut: AND, anda akan menghasilkan nilai true jika dan hanya jika kedua nilai yang dibangingkan bernilai true, OR, akan menghasilkan nilai true jika dan hanya jija salah satu dari dua nilai yang dibandingkan bernilai true Contoh : Tampilkan semua anggota yang berinisialisasi JONI. SELECT * FROM anggota WHERE nama LIKE JONI%; Kodekode lain untuk baris Criteria yang dapat dipakai sesuai kebutuhan : Tanda > untuk lebih besar dari Tanda < untuk lebih kecil dari Tanda >= untuk lebih besar dari atau sama dengan Tanda <= untuk lebih kecil dari atau sama dengan Tanda = untuk sama dengan Tanda ? menunjukkan satu karakter. Misal kita mengetikkan E? artinya kita akan mencari nama Er, En, Ek, Et, dan lainlain tetapi TIDAK akan mencari Erhans atau Eni atau yang lainnya yang lebih dari dua huruf. Tanda * Menunjuk pada banyak karakter. Misal kita ketik E* artinya kita akan mencari nama Erhans atau Eni atau nama lain yang berhuruf awal E. NOT untuk TIDAK menampilkan. Misalnya kita tidak ingin menampilkan mahasiswa yang berasal dari kota Yogyakarta maka pada tabel MAHASISWA dengan field KOTA di kolom isian Criteria kita ketik dengan not Yogyakarta

Page 23

Page 24

Latihan Praktikum I Atur Format dan propertinya berdasarkan masing masing tipe data yang dipakai A.Tabel Nasabah Field Nama_Nasabah Alamat Kota_Tinggal
Layout Design view Tabel Nasabah

Tipe Data Text Text Text

Ukuran 10 20 15

Tampilan Tabel Nasabah

Page 25

B . Tabel Cabang

Field Nama_Cabang Total_Aset Kota_Cabang


Layout Design view Tabel Cabang

Tipe Data Text Currency Text

Ukuran 10 15

Tampilan Tabel Cabang

Page 26

c.Tabel Tabungan

Field No_Rekening Nama_Nasabah Nama_Cabang


Saldo

Tipe Data Text Text Text


Currency

Ukuran 8 10 10

Layout Design Tabel Tabungan

Tampilan Tabel Tabungan

Page 27

d.Tabel Pinjaman

Field No_Kredit Nama_Nasabah Nama_Cabang


Jumlah_Kredit

Tipe Data Text Text Text


Currency

Ukuran 8 10 10

Layout Design View Tabel Pinjaman

Tampilan Tabel Pinjaman

Page 28

e. Petugas Field Tipe Data Ukuran

Nama_Nasabah Nama_Petugas
Layout Design view Petugas

Text Text

10 10

Tampilan Tabel Petugas

Page 29

2.3 Membuat Hubungan Tabel Tab relationship pada object tab dan kotak dialog

Membuat Hubungan satu ke satu

Membuat Hubungan satu ke banyak antara dua Tabel

Membuat hubungan satu kebanyak antara tiga tabel

Page 30

Mengubah Hubungan Tabel

Latihan Praktikum II Buat relationship studi kasus BANK dengan lengkap sesuai entity relationship diagram yang telah dirancang

M Melayani N N Deposito M N Pinjamanan


N

Petugas

NASABAH

M
N

Cabang

Page 31

Relationship

3.1.Membuat Form dalam Tampilan Desain Create form in design view

Page 32

Form yang dibuat dalam Tampilan Desain

Tampilan Form

Page 33

3.2.Menyimpan Form 1. Klik File dan klik perintah Save As untuk menampilkan kotak dialog save as. Pada kotak save form ketikan nama Form . dan pilih Form pada kotak AS .

3.3. Membuat Form Menggunakan Wizard Kotak dialog form wizard dengan pilihan fields

Page 34

Pemilihan Atribut

Kotak dialog Wizard dengan pilihan layout Form

Page 35

Kotak Dialog Wizard dengan pilihan Layout Form

Kotak dialog wizard dengan nama Form

Page 36

Tampilan Form dengan Wizard

3.4. Memasukan Tombol Perintah pada Form Tampilkan form yang akan diberi tombol perintah Pastikan Control Wizard aktif Klik tombol command button pada bar tombol toolbox Tunjuk pada form di tempat tombol perintah akan diletakan Klik kategori record navigation dan aksi Go to next record

Page 37

Kotak dialog button wizard dengan pilihan teks

Informasi nama tombol perintah

Page 38

Form setelah di edit

Form dengan tampilan Command button

Page 39

Latihan Praktikum III Tabel Nasabah

From Tabel Nasabah

Page 40

Tabel Cabang

Form Tabel Cabang

Page 41

Tabel Petugas

Form Tabel Petugas

Tabel Deposito

Page 42

Form Tabel Deposito

Tabel Pinjaman

Form Tabel Pinjaman

Page 43

Tabel Melayani/Pelayan

Form Tabel Melayani / Pelayan

Praktikum IV 4.1 Membuat Query dalam tampilan Desain

Page 44

Data Hasil Query

4.2 Membuat query menggunakan Wizard

Page 45

Kotak dialog simple query dengan judul query

Hasil tampilan data Query

Page 46

Praktikum IV 1. Tampilkan Nama_Nasabah , Alamat , Kota_Nasabah Tampilan design view

Tampilan SQL view

Tampilan Hasil Query

Page 47

2. Tampilkan Nama_Nasabah , No _ rekening , Saldo Tampilan Design view

Tampilan SQL view

Tampilan Hasil Query

Page 48

3. Cari Petugas yang melayani nasabah bernama Smith Tampilan design view

SQL View

Tampilan Query

Page 49

4. Tampilkan Nama_cabang , No_Pinjaman , nama_nasabah , jlh_pinjaman , dengan jumlah pinjaman lebih besar dari 500.000 Tampilan Design view

SQL view

Tampilan Query

Page 50

5. Cari nasabah yang mempunyai deposito dibawah 1 juta Tampilan design view

SQL View

Tampilan Query

Page 51

6.Cari Nasabah yang mempunyai pinjaman di Cabang Leimana Tampilan Design view

SQL view

Tampilan Query

Page 52

7.Tampilkan nasabah yang memiliki pinjaman dan tabungan di kota cabang yang sama

Tampilan SQL

Tampilan Query

Page 53

8.Buat Total saldo deposito tiap Cabang Tampilan design view

SQL view

Tampilan Query

Page 54

9.cari Total nasabah dari Morotai Tampilan Design view

SQL View

Tampilan Query

Page 55

10.Tampilan semua petugas bank yang melayani nasabah peminjaman Tampilan Design view

SQL view

Tampilan Query

Page 56

Design View

Hasil yang diperoleh

Nama Petugas yang melayani Nasabah peminjaman adalah Rudi, Rani, Hani, dan Haryono.

Page 57

Menggunakan Report untuk Membuat Laporan Report Cabang

Page 58

Report Nasabah

Page 59

Report Pelayanan

Page 60

Report Petugas

Page 61

Report Pinjaman

Page 62

Report Tabungan

Page 63

Switchboard

Switchboard Menu Form

Page 64

Switchboard Menu Laporan

Page 65