Anda di halaman 1dari 33

LAPORAN PRAKTIKUM JARINGAN KOMPUTER DYNAMIC ROUTING

Disusun Dalam Rangka Menyelesaikan Tugas Mata Kuliah Jaringan Komputer Pada Prodi Pendidikan Teknik Informatika Universitas Negeri Yogyakarta

Disusun Oleh :

Nika Resti Utami Wahyu Susilo Prabowo Yosafat Yudha Krisananda Hanifah Fasiyani

11520241061 11520244004 11520244005 11520244007

Pendidikan Teknik Elektronika Prodi Pendidikan Teknik Informatika /F2.2

FAKULTAS TEKNIK UNIVERSITAS NEGERI YOGYAKARTA 2012


Kelompok 3 http://www.jarkom-2012.blogspot.com

A. TUJUAN PRAKTIKUM 1. Mampu membangun jaringan dengan Dynamic Routing 2. Mampu memahami konsep Routing dan table Routing 3. Mampu membuat table Routing

B. SKENARIO PRAKTIKUM

C.

Gambar 1. Gambar Desain Jaringan UNY Group

Dalam perusahaan UNY Group terdapat tiga divisi, masing-masing di dalamnya terdapat komputer yang berbeda network dan dihubungkan menggunakan beberapa router. Seorang administrator dalam perusahaan tersebut harus membuat komputer-komputer dari ketiga divisi tersebut dapat saling berkomunikasi. Dari kebutuhan pada skenario di atas, network administrator membuat simulasi pada packet tracer dengan dynamic routing menggunakan protokol RIPv2, OSPF dan EIGRP.

D. DASAR TEORI Router adalah alat yang digunakan untuk mengirimkan paket data melalui sebuah jaringan atau internet menuju tujuannya, yang dikenal dengan istilah routing. Routing terjadi pada lapis tiga yaitu lapisan jaringan seperti Internet Protocol dari OSI layer. Router berfungi sebagai penghubung dua jaringan atau lebih untuk meneruskan data dari
Kelompok 3 http://www.jarkom-2012.blogspot.com

satu jaringan ke jaringan yang lain. Router digunakan dalam jaringan berbasis teknologi protokol TCP/IP yang disebut IP Router. Router juga berfungsi untuk mengkoneksikan dua buah jaringan yang menggunakan media atau arsitektur jaringan yang berbeda seperti dari Ethernet ke Token Ring. Fungsi router yang lain adalah: Untuk menghubungkan LAN ke koneksi telekomunikasi seperti telekomunikasi leased line atau Digital Subscriber Line (DSL) Untuk menghubungkan LAN ke sebuah koneksi leased line seperti T1 atau T3 (access server) Untuk menghubungkan jaringan lokal ke sebuah koneksi DSL yang disebut DSL router Prinsip kerja router: Menyamakan alamat host Menyamakan alamat jaringan Mencari default entri (default entri normal dalam routing label dengan network ID 0) Routing yang dilakukan oleh host cukup sederhana. Jika host tujuan berada di jaringan yang sama atau terhubung langsung maka IP datagram akan langsung dikirim ke tujuan. Jika tidak, IP datagram akan dikirim ke default router. Router ini akan mengatur pengiriman IP selanjutnya hingga sampai ke tujuannya yaitu: 1. Mencari di table routing, entry yang cocok dengan IP address tujuan. Jika ditemukan maka paket data akan dikirim ke next hop router (gateway) atau interface yang terhubung langsung dengannya. 2. Mencari di table routing, entry yang cocok dengan alamat network dari network tujuan. Jika ditemukan maka paket data akan dikirim ke next hop router tersebut. 3. Mencari di table routing, entry data yang bertanda default. Jika ditemukan maka paket data akan dikirim ke router tersebut. Mekanisme routing adalah ketika router mencari routing tabel dan memutuskan interface yang akan dikirim ke router tersebut. Dalam suatu table routing terdapat IP address tujuan, IP address next hop router (gateway), Flag (menyatakan jenis routing) dan interface tempat data dilewatkan. Ada 5 tipe flag dalam routing yaitu: o U untuk route up
Kelompok 3 http://www.jarkom-2012.blogspot.com

G untuk route gateway, jika flag ini tidak diset destinasi dapat langsung terhubung. Flag ini membedakan antara indirect dan direct route (flag G tidak diset untuk direct route).

H untuk route sebagai host, destination complete alamat host. Jika flag ini tidak diset route, jaringan dan destinasi adalah alamat network dengan destinasi adalah network address sebuah net ID atau kombinasi dari net ID dan subnet ID

o o

D route untuk dibuat dengan direct M route di modifikasi dengan direct

Berdasarkan bentuknya router dibagi menjadi 3, yaitu: a. Router Aplikasi merupakan sebuah aplikasi yang bisa diinstal pada sistem operasi komputer sehingga sistem operasi komputer tersebut dapat bekerja sebagai router. Contohnya aplikasi WinGate, WinProxy, Winroute, SpyGate dan lain sebagainya. b. Router Hardware adalah sebuah hardware yang memiliki kemampuan seperti router sehingga dapat membagi IP Address dan men-sharing IP Address. Router ini digunakan untuk membagi jaringan internet pada suatu tempat. Contohnya router buatan pabrik seperti Cisco dan Planet. c. Router PC adalah sebuah komputer yang dimodifikasi untuk digunakan sebagai router. Komputer tersebut harus diinstal dengan sistem operasi khusus untuk router seperti Windows NT, Windows NT 4.0, Windows 2000 Server, Windows 2003 Sever dan MikroTik (berbasis Linux). Secara umum ada dua jenis router yaitu: a. Static router (router statis) yaitu sebuah router yang mempunyai tabel routing statis dan disetting secara manual oleh administrator jaringannya. Static router memiliki kelemahan yaitu tidak mempunyai pilihan jika terjadi perubahan topologi rangkaian contohnya apabila router tiba-tiba gagal berfungsi. b. Dynamic router (router dinamis) yaitu sebuah router yang mempunyai tabel routing dinamis dengan mendengarkan lalu lintas jaringan dan saling berhubungan dengan router lain.

DYNAMIC ROUTING Dynamic routing digunakan untuk menangani kelemahan static routing yang tidak dapat mencari jalur alternatif ketika jalur pengiriman putus sehingga data tidak dapat terkirim. Secara umum dynamic routing dibagi menjadi 2 kategori yaitu:
Kelompok 3 http://www.jarkom-2012.blogspot.com

a. Distance Vector Distance vector adalah proses routing yang berdasarkan arah dan jarak, dalam penetapan jalur terbaik (the best path) hanya melibatkan jumlah hop (hop count) untuk me-route paket data dari satu alamat network ke alamat network tujuannya. Routing ini tidak dapat menganalisis bandwidth. Distance vector mendapatkan informasi dari router yang berhubungan langsung dengan jaringan router tersebut. Berdasarkan informasi tersebut, kemudian akan mengolah tabel routing. Yang tergolong Distance vector adalah RIPv1, RIPv2 dan IGRP (Interior Gateway Routing Protocol). Cara kerja Distance Vector adalah sebuah router awalnya hanya memiliki informasi tentang jaringan yang terhubung secara langsung dengannya. Kemudian router yang lain akan saling mengirimkan data jaringan yang ia punya. Setiap router akan melakukan pengecekan terhadap data-data yang didapat dan dibandingkan dengan tabel routing masing-masing router. Jika belum ada maka akan dimasukkan, jika sudah dibandingkan jumlah hop.

b. Link State Link state merupakan routing protocol yang lebih modern dari Distance Vector. Link state adalah proses routing yang membangun topologi databasenya sendiri. Link State akan melakukan penyelidikan terhadap semua koneksi yang ada dalam jaringan. Dalam Link State hop count, kapasitas bandwidth jaringan serta parameter-parameter lainnya ikut menentukan jalur terbaik (the best path) melalui router tetangganya. Untuk mencari router tetangga tersebut digunakan hello packet. Contoh Link State adalah Open Shortest Path First (OSPF). Fitur-fitur protokol routing Link State: a. Link State Advertisements, adalah paket kecil dari informasi routing yang dikirim antar router. b. Topologi database, adalah kumpulan informasi dari LSA-LSA yang telah terkumpul. c. Algorithma SPF (Shortest Path First), adalah hasil perhitungan pada database sebagai hasil dari SPF tree. d. SPF Tree

Kelompok 3 http://www.jarkom-2012.blogspot.com

SPF tree dibuat dari algorithma SPF dan database dengan router sebagai root. Algorithma SPF akan membentuk percabanagn yang akan membantu router dalam menentukan jalur terbaiknya. e. Menentukan routing table Routing table berupa daftar rute dan interface. Saat terjadi perubahan jaringan maka routing table juga akan berubah. Dari table inilah sebuah router mempelajari router tetangganya beserta router yang ada dalam jaringan. Cara kerja Link State adalah sebuah router akan mengirimkan hello packet secara periodik, dari proses ini akan tercipta LSA. Setiap router akan mempelajari sebuah router tetangganya dari database LSA. Setelah LSA terupdate, maka SPF algorithma akan mempelajari dan menghitung jumlah metric yang dibutuhkan untuk mencapai tujuannya. Informasi ini yang akan digunakan untuk mengupdate routing table. Routing table akan berubah jika ada router yang mati. Karena Link State menggunakan triggered update maka tidak perlu menunggu selama waktu tertentu untuk mengupdate table routing. Jadi ketika jaringan mengalami perubahan, Link State akan langsung mengupdate table routingnya. Setiap routing akan menghitung jarak terpendek ke router yang lain dengan Shortest Path First (SPF) dan membentuk tree. Untuk mencapai router yang sama, setiap router mempunyai tree yang berbeda. Keunggulan Link State adalah cepat sekali dalam penyatuan jaringan jika dibandingkan dengan Distance Vector. Selain itu Link State mendukung adanya VLSA dan CIDR sehingga sangat membantu untuk membuat jaringan yang lebih kompleks. Akan tetapi, Link State membutuhkan banyak memori dan processor.

Protocol Dynamic Routing 1. Routing Information Protocol (RIP) RIP merupakan routing protocol sederhana dan termasuk jenis Distance Vector. RIP menggunakan jumlah lompatan (hop count) untuk menentukan cara terbaik ke sebuah network remote, yaitu jumlah router yang harus dilalui oleh paket-paket untuk mencapai alamat tujuannya. Hop count RIP hanya dibatasi sampai 15 hop, selebihnya router akan memberikan pesan error destination is unreachable. Broadcast pada routing protocol ini diupdate setiap 30 detik untuk semua RIP counter guna menjaga integritas. RIP bekerja dengan baik pada

Kelompok 3 http://www.jarkom-2012.blogspot.com

jaringan kecil akan tetapi dalam jaringan besar dengna link WAN atau jaringan yang menggunakan banyak router, RIP tidak efisien. Routing Information Protocol (RIP) dibagi menjadi 2, yaitu: a. RIP versi 1 RIPv1 merupakan bagian dari Distance Vector yang mencari hop terpendek atau router terbaik dengan menggunakan classfull routing yang berarti semua alat di jaringan harus menggunakan subnet mask yang sama, karena RIPv1 tidak mengirimkan update informasi subnet mask di dalamnya. b. RIP versi 2 RIPv2 merupakan bagian dari Distance Vector yang mencari hop terpendek atau router terbaik dan merupakan classless routing. RIPv2 menyediakan sesuatu yang disebut prefix routing dan dapat mengirimkan informasi subnet mask bersama dengan update-update dari routing.

Keterbatasan yang dimiliki RIP antara lain: Metric: Hop count RIP menghitung routing terbaik berdasarkan hop count, padahal belum tentu hop count yang rendah menggunakan protokol LAN yang bagus dan bisa saja RIP memilih jalur jaringan yang lambat. RIP hanya dapat mengatur hop count 15, selebihnya paket akan dibuang. Hal ini digunakan untuk mencegah loop pada jaringan. Classful Routing Only RIP menggunakan classful routing (/8, /16, /24). RIP tidak dapat mengatur classless routing. Untuk menerapkan RIP ke suatu router digunakan perintah sebagai berikut: Router(config)#router rip Untuk menerapkan router RIP ke suatu network address digunakan perintah sebagai berikut: Router(config-router)#network <network_address> RIP mempunyai default update setiap 30 detik, selain itu RIP juga mempunyai beberapa jenis timer antara lain: Invalid timer adalah waktu dalam detik yang menyatakan suatu route tidak berfungsi (invalid).

Kelompok 3 http://www.jarkom-2012.blogspot.com

Holddown timer adalah interval tertentu dalam detik yang berlaku untuk semua interface router yang menyatakan bahwa suatu route tidak dapat dicapai.

Flash timer adalah waktu dalam detik dimana suatu route akan dihapus dari table routing.

Timer tersebut dapat dirubah nilainya dengan menggunakan perintah: Router(config)#timers basic <update invalid holddown flash> Untuk memeriksa konfigurasi routing protocol dapat digunakan perintah sebagai berikut: show ip protocol, digunakan untuk menampilkan protokol yang digunakan show ip route, digunakan untuk menampilkan daftar isi suatu tabel route show ip interface, digunakan untuk menampilkan status konfigurasi RIP di router dan konfigurasi parameter setiap interface debug ip rip, digunakan untuk melacak kesalahan

2. Enhanced Interior Gateway Routing Protocol (EIGRP) EIGRP merupakan routing protocol yang termasuk Cisco proprietarty yang berarti hanya bisa digunakan sesama router cisco saja. EIGRP( Enhanced Interior Gateway Routing Protocol) adalah pengembangan dari IGRP (Interior Gateway Routing Protocol). EIGRP sering disebut sebagai hybrid-distancevector routing protocol karena EIGRP menggunakan dua tipe routing protocol yaitu Distance Vector dan Link State. Tetapi pada dasarnya EIGRP adalah protocol Distance Vector karena router-router yang menjalankan EIGRP tidak mengetahui topologi network secara menyeluruh seperti Link State. Karakteristik EIGRP: Menggunakan protokol routing enhanced distance vector Menggunakan cost load balancing yang tidak sama Menggunakan algortima kombinasi antara Distance Vector dan Link State Untuk perhitungan dalam menentukan jalur yang tercepat/terpendek EIGRP menggunakan algoritma DUAL (Diffusing-Update Algorithm). EIGRP mempunyai 3 tabel dalam menyimpan informasi networknya, yaitu:

Kelompok 3 http://www.jarkom-2012.blogspot.com

a. Neighbor table, berisi data address router tetangga dan interface yang terhubung ke tetangga. b. Topology table, berisi semua entri route untuk setiap network destination yang didapatkan dari setiap neighbor. c. Routing table, berisi jalur/route terbaik untuk mencapai setiap destination. Kelebihan EIGRP: a. Protokol yang menggunakan fitur route backup. EIGRP menyimpan backup terbaik setiap route-nya sehinga jika terjadi kegagalan di jalur utama maka EIGRP akan menawarkan jalur alternatif tanpa menunggu waktu convergence. b. Mudah dikonfigurasi seperti RIP. c. Summarization dapat dilakukan dimana saja dan kapan saja. d. EIGRP merupakan satu-satunya protocol yang dapat melakukan unequal load balancing. e. Kombinasi terbaik dari protocol Distance Vector dan Link State. f. Mendukung multiple protocol network (IP, IPX dan lain-lain). Untuk menerapkan EIGRP ke suatu router digunakan perintah sebagai berikut: Router(config)#router eigrp <AS_number> AS_number diganti angka bebas dengan range 1-255. Untuk menerapkan router EIGRP ke suatu network address digunakan perintah sebagai berikut: Router(config-router)#network <network_address>

3. Open Shortest Path First (OSPF) OSPF merupakan sebuah protocol standar terbuka yang telah

diimplementasikan oleh sejumlah vendor jaringan. OSPF bekerja dengan algoritma Dijkstra. Pertama sebuah pohon jalur terpendek (shortest path tree) akan dibangun, kemudian routing table akan diisi dengan jalur-jalur terbaik yang dihasilkan dari pohon tersebut. OSPF hanya mendukung routing IP saja. OSPF merupakan routing protocol berjenis IGP (Interior Gateway Routing Protocol) yang hanya dapat bekerja dalam jaringan internal suatu organisasi atau perusahaan. OSPF digunakan dalam Internet Protocol (IP) jaringan. Ini adalah link state routing protocol dan juga sebagai kelompok interior
Kelompok 3 http://www.jarkom-2012.blogspot.com

gateway protocol yang beroperasi dalam satu sistem otonom (AS). Didefinisikan sebagai OSPF versi 2 dalam RFC 2328 (1998) untuk IPv4 sedangkan IPv6 ditetapkan sebagai OSPF versi 3 dalam RFC 5340 (2008). Karakteristik OSPF: a. Merupakan routing protocol standar terbuka b. Mendukung VLSM dan CIDR c. Dapat membentuk heirarki routing menggunakan konsep area d. Tidak mempunyai batasan hop e. Metric ditentukan berdasarkan bandwidht (defaulrnya= /bandwidth)

f. Terdapat tabel-tabel: neighbors table, topology table dan routing table g. Jika terjadi perubahan pada internetwork hanya akan dikirim partial update. Full update akan dikirim pada interval waktu 30 menit(defaultnya) h. Terdapat 3 macam tipe network pada interface OSPF yaitu broadcast multi access, non-broadcast multi access dan point-to-point. Kelebihan OSPF adalah waktu yang diperlukan untuk konvergen lebih cepat dan cocok digunakan dalam jaringan besar. Sedangkan kekurangannya adalah membutuhkan basis data yang besar dan lebih rumit. Untuk menerapkan OSPF ke suatu router digunakan perintah sebagai berikut: Router(config)#router ospf <process_ID> Untuk menerapkan router OSPF ke suatu network address digunakan perintah sebagai berikut: Router(config-router)#network <address> <wildcard_mask> area<area> Keterangan: Process-id digunakan untuk menentukan nomer dari OSPF yang digunakan, yaitu antara nomer 1-65535 yang ditentukan oleh system administrator. Dalam satu topologi jaringan digunakan process-id yang sama agar memudahkan dalam konfigurasi. Wildcard mask adalah kebalikan dari netmask. Contohnya netmask 255.255.0.0 maka wildcard-nya 0.0.255.255 Area-id merupakan nilai antara 0 - 4294967295 yang ditentukan oleh system administrator. Arena-id digunakan sebagai identitas untuk setiap router dengan area-id yang sama untuk berbagi tentang informasi linkstate.
Kelompok 3 http://www.jarkom-2012.blogspot.com

Jenis-jenis area dalam OSPF: a. Backbone Area, atau disebut dengan Area 0 karena sering ditandai dengan angka 0. Backbone area merupakan area dimana seluruh area-area lain dalam jaringan OSPF bertemu. b. Standar Area, adalah area selain area 0 tanpa disertai konfigurasi apapun. Semua router dalam area ini akan mengetahui informasi yang sama dan memiliki topology database yang sama akan tetapi routing table-nya bisa saja berbeda. c. Stub Area, adalah area yang terletak paling ujung dan tidak memiliki cabang apapun. Jadi, arena ini tidak mempunyai jalan lain lagi untuk dapat menuju ke jaringan dengan segmen lain. Dalam Stub Area, router hanya menerima informasi dari router-router lain yang ada di satu area, tidak ada informasi routing baru di router. Untuk menerima dan memasukkan semua informasi yang ingin keluar dari area ini digunakan default route. d. Totally Stub Area, merupakan area yang tidak akan pernah menerima informasi routing apapun dari jaringan di luar jaringannya. Area ini juga menggunakan default route untuk dapat menjangkau dunia luar. e. Not So Stubby Area (NSSA) merupakan stub yang memiliki kemampuan untuk mendapatkan informasi routing namun tidak semuanya. Informasi yang didapat hanya dari external route yang diterimanya bukan dari backbone route.

4. Redistributed Routing Protocol Redistribute digunakan untuk mendapatkan informasi routing yang telah ada dalam satu routing dan mendistribusikannya ke protokol routing yang berbeda, sehingga memungkinkan redistribusi protokol pertama ke jaringan protokol routing kedua. Redistribute dipengaruhi oleh karakteristik protokol routing, seperti metric, administrasi jarak, classful dan classless capability. Prinsip redistribute adalah router yang menjadi penghubung antara network dengan routing protocol yang berbeda akan menggunakan routing protocol yang sesuai dengan routing protocol yang digunakan oleh kedua network tersebut. Sebagai contoh, interface Fa0/0 pada router menggunakan RIP
Kelompok 3 http://www.jarkom-2012.blogspot.com

maka router tersebut harus menggunakan RIP dan pada Fa0/1 menggunakan OSPF maka router tersebut juga harus menggunakan OSPF sesuai dengan network interface yang terhubung. Agar routing table yang dibentuk RIP bisa diteruskan ke OSPF maka digunakan redistribute RIP dan untuk OSPF ke RIP digunakan redistribute OSPF.

E. ALAT DAN BAHAN 1. Software Packet Tracert 2. PC/Laptop

F. LANGKAH KERJA 1. Simulasi penggunaan protokol RIPv2

Tabel routing dari gambar desain diatas : Router A No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway * * 192.168.2.253 192.168.2.253 192.168.3.253 Interface Eth0 Eth1 Eth0 Eth0 Eth0 Keterangan Direct Connection Direct Connection Indirect Connection Indirect Connection Indirect Connection

Kelompok 3 http://www.jarkom-2012.blogspot.com

Router B No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway 192.168.2.254 * * * 192.168.3.253 Interface Eth1 Eth0 Eth1 Eth2 Eth0 Keterangan Indirect Connection Direct Connection Direct Connection Direct Connection Indirect Connection

Router C No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway 192.168.2.254 192.168.3.254 * 192.168.3.254 * Interface Eth1 Eth1 Eth0 Eth1 Eth1 Keterangan Indirect Connection Direct Connection Direct Connection Indirect Connection Direct Connection

LANGKAH KERJA (Simple configuration) : a. Konfigurasi Router A 1) Double klik Router A kemudian pilih CLI
Router> enable Router# configure terminal

2) Setting IP Address Router A eth0 (contoh pada fa0/0) ke switch


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip 255.255.255.0 Router(config-if)#exit Router(config)#router rip Kelompok 3 http://www.jarkom-2012.blogspot.com address 192.168.2.254

192.168.1.254

3) Setting IP Address Router A eth1 (contoh pada fa0/1) ke Router B

4) Tambahakan informasi pada table routing pada Router A

Router(config-router)#version 2 Router(config-router)#network 192.168.1.0 Router(config-router)#network 192.168.2.0 Router(config-router)#exit Router(config)#exit

5) Lihat hasil konfigurasi static routing pada Router A


Router#show ip route

b. Konfigurasi Router B 1) Double klik Router B kemudian pilih CLI


Router> enable Router# configure terminal

2) Setting IP Address Router B eth0 (contoh pada fa0/0) ke Router A


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit Router(config)#interface ethernet0/0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit

192.168.2.253

3) Setting IP Address Router B eth1 (contoh pada fa0/1) ke Router C

192.168.3.253

4) Setting IP Address Router B eth2(contoh pada et0/0/1) ke Switch

192.168.4.254

5) Tambahkan informasi pada table routing pada router B


Router(config)#router rip Router(config-router)#version 2 Router(config-router)#network 192.168.2.0 Router(config-router)#network 192.168.3.0 Router(config-router)#network 192.168.4.0 Router(config-router)#exit Router(config)#exit

6) Lihat hasil konfigurasi static routing pada Router B


Router#show ip route Kelompok 3 http://www.jarkom-2012.blogspot.com

c. Konfigurasi Router C 1) Double klik Router C kemudian pilih CLI


Router> enable Router# configure terminal

2) Setting IP Address Router C eth0 (contoh pada fa0/1) ke Router B


Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit 192.168.5.254

192.168.3.253

3) Setting IP Address Router C eth1(contoh pada fa0/0) ke Switch

4) Tambahkan informasi pada table routing pada router C


Router(config)#router rip Router(config-router)#version 2 Router(config-router)#network 192.168.3.0 Router(config-router)#network 192.168.5.0 Router(config-router)#exit Router(config)#exit

5) Lihat hasil konfigurasi static routing pada Router B


Router#show ip route

d. Cek hasil pada computer client Jika dari kesemua computer tersebut dapat saling berkomunikasi makan konfirgurasi dengan dynamic routing dengan RIPv2 sudah berhasil. Selain kita cek dengan menggunakan ping juga menggunakan perintah tracert ip address target

2. Simulasi Menggunakan Protokol OSPF

Kelompok 3 http://www.jarkom-2012.blogspot.com

Tabel Routing dari Gambar Desain Diatas : Router A No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway * * 192.168.2.253 192.168.2.253 192.168.3.253 Interface Eth0 Eth1 Eth0 Eth0 Eth0 Keterangan Direct Connection Direct Connection Indirect Connection Indirect Connection Indirect Connection

Router B No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway 192.168.2.254 * * * 192.168.3.253 Interface Eth1 Eth0 Eth1 Eth2 Eth0 Keterangan Indirect Connection Direct Connection Direct Connection Direct Connection Indirect Connection

Router C No. 1 Destination 192.168.1.0 Netmask /24 Gateway 192.168.2.254 Interface Eth1 Keterangan Indirect Connection

Kelompok 3 http://www.jarkom-2012.blogspot.com

2 3 4 5

192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0

/24 /24 /24 /24

192.168.3.254 * 192.168.3.254 *

Eth1 Eth0 Eth1 Eth1

Direct Connection Direct Connection Indirect Connection Direct Connection

LANGKAH KERJA : a. Konfigurasi Router A 1) Double klik Router A kemudian pilih CLI
Router> enable Router# configure terminal

2) Setting IP Address Router A eth0 (contoh pada fa0/0) ke switch


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit

192.168.1.254

3) Setting IP Address Router A eth1 (contoh pada fa0/1) ke Router B

192.168.2.254

4) Tambahakan informasi pada table routing pada Router A


Router(config)#router ospf 1 Router(config-router)#network area 0 Router(config-router)#network area 0 Router(config-router)#exit Router(config)#exit 192.168.1.0 192.168.2.0 0.0.0.255 0.0.0.255

5) Lihat hasil konfigurasi static routing pada Router A


Router#show ip route

b. Konfigurasi Router B 1) Double klik Router B kemudian pilih CLI


Router> enable Router# configure terminal

2) Setting IP Address Router B eth0 (contoh pada fa0/0) ke Router A


Kelompok 3 http://www.jarkom-2012.blogspot.com

Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit

192.168.2.253

3) Setting IP Address Router B eth1 (contoh pada fa0/1) ke Router C

192.168.3.253

4) Setting IP Address Router B eth2(contoh pada et0/0/1) ke Switch


Router(config)#interface ethernet0/0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit

192.168.4.254

5) Tambahkan informasi pada table routing pada router B


Router(config)#router ospf 1 Router(config-router)#network area 0 Router(config-router)#network area 0 Router(config-router)#network area 0 Router(config-router)#exit Router(config)#exit 192.168.2.0 192.168.3.0 192.168.4.0 0.0.0.255 0.0.0.255 0.0.0.255

6) Lihat hasil konfigurasi static routing pada Router B


Router#show ip route

c. Konfigurasi Router C 1) Double klik Router C kemudian pilih CLI


Router> enable Router# configure terminal

2) Setting IP Address Router C eth0 (contoh pada fa0/1) ke Router B


Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit

192.168.3.253

Kelompok 3 http://www.jarkom-2012.blogspot.com

3) Setting IP Address Router C eth1(contoh pada fa0/0) ke Switch


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 255.255.255.0 Router(config-if)#exit

192.168.5.254

4) Tambahkan informasi pada table routing pada router C


Router(config)#router ospf 1 Router(config-router)#network area 0 Router(config-router)#network area 0 Router(config-router)#exit Router(config)#exit Router#show ip route 192.168.3.0 192.168.5.0 0.0.0.255 0.0.0.255

5) Lihat hasil konfigurasi static routing pada Router c d. Cek hasil pada computer client Jika dari kesemua computer tersebut dapat saling berkomunikasi makan konfirgurasi dengan dynamic routing dengan OSPF sudah berhasil. Selain kita cek dengan menggunakan ping juga menggunakan perintah tracert ip address target. Keterangan command diatas : 1. Router ospf 1 Angka 1 adalah Process-id merupakan nomor antara 1-65535 yang ditentukan oleh sistem administrator. Proccess-id digunakan untuk

menentukan nomor dari OSPF yang digunakan. Biasanya dalam suatu topologi jaringan digunakan process-id yang sama agar memudahkan dalam konfigurasi. 2. Network 192.168.3.0 0.0.0.255 area 0 Angka 0.0.0.255 adalah wildcard-mask. Wildacard-mask merupakan kebalikan dari subner mask. Jika subnet mask adalah 255.255.255.0, maka wildcard-masknya adalah 0.0.0.255. Angka binary 0 pada subnet mask diubah menjadi angka binary 1 pada wildcard mask. Area 0 adalah area id. Area id pada OSPF merupakan nilai antara 04294967295 yang ditentukan oleh sistem administrator. Area id menjadi identitas untuk setiap router dengan area id untuk berbagi infirmasi link-state. Router dengan area id yang sama pasti memiliki informasi link-state yang
Kelompok 3 http://www.jarkom-2012.blogspot.com

sama di database link-statenya, Area id dapat di setting menjadi single area (area 0 saja) atau multi area yang menjadi core network. Area 0 digunakan sebagai backbone area atau area yang menjadi core network. Sedangkan area lain menjadi support area, biasanay area dengan jaringan kecil.

3. Simulasi Menggunakan Protokol EIGRP

Tabel Routing dari Gambar Desain Diatas : Router A No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway * * 192.168.2.253 192.168.2.253 192.168.3.253 Interface Eth0 Eth1 Eth0 Eth0 Eth0 Keterangan Direct Connection Direct Connection Indirect Connection Indirect Connection Indirect Connection

Router B No. 1 2 3 Destination 192.168.1.0 192.168.2.0 192.168.3.0 Netmask /24 /24 /24 Gateway 192.168.2.254 * * Interface Eth1 Eth0 Eth1 Keterangan Indirect Connection Direct Connection Direct Connection

Kelompok 3 http://www.jarkom-2012.blogspot.com

4 5

192.168.4.0 192.168.5.0

/24 /24

* 192.168.3.253

Eth2 Eth0

Direct Connection Indirect Connection

Router C No. 1 2 3 4 5 Destination 192.168.1.0 192.168.2.0 192.168.3.0 192.168.4.0 192.168.5.0 Netmask /24 /24 /24 /24 /24 Gateway 192.168.2.254 192.168.3.254 * 192.168.3.254 * Interface Eth1 Eth1 Eth0 Eth1 Eth1 Keterangan Indirect Connection Direct Connection Direct Connection Indirect Connection Direct Connection

LANGKAH KERJA : a. Konfigurasi Router A 1) Double klik Router A kemudian pilih CLI
Router> enable Router# configure terminal

2) Setting IP Address Router A eth0 (contoh pada fa0/0) ke switch


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.1.254 255.255.255.0 Router(config-if)#exit

3) Setting IP Address Router A eth1 (contoh pada fa0/1) ke Router B


Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.2.254 255.255.255.0 Router(config-if)#exit

4) Tambahakan informasi pada table routing pada Router A


Router(config)#router eigrp 1 Router(config-router)#network 192.168.1.0 Router(config-router)#network 192.168.2.0 Router(config-router)#exit Router(config)#exit

5) Lihat hasil konfigurasi static routing pada Router A


Router#show ip route

b. Konfigurasi Router B 1) Double klik Router B kemudian pilih CLI


Kelompok 3 http://www.jarkom-2012.blogspot.com

Router> enable Router# configure terminal

2) Setting IP Address Router B eth0 (contoh pada fa0/0) ke Router A


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.2.253 255.255.255.0 Router(config-if)#exit

3) Setting IP Address Router B eth1 (contoh pada fa0/1) ke Router C


Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.3.253 255.255.255.0 Router(config-if)#exit

4) Setting IP Address Router B eth2(contoh pada et0/0/1) ke Switch


Router(config)#interface ethernet0/0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.4.254 255.255.255.0 Router(config-if)#exit

5) Tambahkan informasi pada table routing pada router B


Router(config)#router eigrp 1 Router(config-router)#network 192.168.2.0 Router(config-router)#network 192.168.3.0 Router(config-router)#network 192.168.4.0 Router(config-router)#exit Router(config)#exit

6) Lihat hasil konfigurasi static routing pada Router B


Router#show ip route

c. Konfigurasi Router C 1) Double klik Router C kemudian pilih CLI


Router> enable Router# configure terminal

2) Setting IP Address Router C eth0 (contoh pada fa0/1) ke Router B


Router(config)#interface fa0/1 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.3.253 255.255.255.0 Router(config-if)#exit

3) Setting IP Address Router C eth1(contoh pada fa0/0) ke Switch


Router(config)#interface fa0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.5.254 255.255.255.0 Kelompok 3 http://www.jarkom-2012.blogspot.com

Router(config-if)#exit

4) Tambahkan informasi pada table routing pada router C


Router(config)#router eigrp 1 Router(config-router)#network 192.168.3.0 Router(config-router)#network 192.168.5.0 Router(config-router)#exit Router(config)#exit

5) Lihat hasil konfigurasi static routing pada Router c


Router#show ip route

d. Jika dari kesemua computer tersebut dapat saling berkomunikasi makan konfirgurasi dengan dynamic routing dengan EIGRP sudah berhasil. Selain kita cek dengan menggunakan ping juga menggunakan perintah tracert ip address target

G. PERMASALAHAN DAN TROUBLESHOOTING Permasalahan : Bagaimana caranya menghubungan beberapa network yang berbeda protokol routing melalui beberapa router?

Troubleshooting : Redistribute adalah cara untuk meredistribusikan kembali routing tabel yang dibentuk oleh suatu routing protocol untuk diteruskan ke routing protocol lain. Dengan redistribute kita bisa membentuk routing tabel yang lengkap dari suatu topologi walaupun menggunakan routing protocol yang berbeda. Pada prinsipnya router yang menjadi penghubung antara network dengan routing protocol yang berbeda akan menggunakan routing protocol sesuai dengan routing protocol yang dipergunakan oleh kedua network tersebut. Pada topologi yang menggunakan lebih dari satu protokol routing, router di titik redistribusi bertugas melakukan fungsi route redistribution, yaitu mengadvertise informasi route yang ada di routing table.

Kelompok 3 http://www.jarkom-2012.blogspot.com

R6 sebagai titik redistribusi memiliki informasi route dari OSPF dan EIGRP. Tugas R6 adalah melakukan redistribusi route OSPF ke domain EIGRP dan sebaliknya sehingga R7 memiliki informasi route 10.2.1.0/24 dan R8 memiliki informasi route

10.1.1.0/24, 10.1.2.0/24 dan 10.1.3.0/24, redistribusi ini disebut Mutual Redistribution. Pada mutual redistribution dapat terjadi masalah, yaitu jika informasi route suatu domain diadvertise kembali masuk ke domain tersebut tanpa difilter. Masalah ini disebut Route Feedback.

Jika R6 melakukan route summarization terhadap informasi route 10.1.1.0/24, 10.1.2.0/24 dan 10.1.3.0/24. R6 akan mengadvertise route summary ini ke R8, yang kemudian akan diadvertise kembali ke R7 sebagai External Route. Tanpa filtering, R7 akan menerima informasi routing dari domain EIGRP sebagai External Route (E1 atau E2), disinilah route feedback terjadi. R7 memiliki informasi route tambahan pada routing table menuju 10.1.1.0/24, 10.1.2.0/24 dan 10.1.3.0/24, yaitu route summary hasil advertise dari R8. Masalah akan terjadi jika ada link menuju 10.1.1.0/24 mati, R7 akan melihat pada routing table terdapat summary route menuju 10.1.1.0/24 , kemudian paket dikirim melalui domain EIGRP dan kembali ke OSPF sebelum dinyatakan unreachable.

H. BAHAN DISKUSI
Kelompok 3 http://www.jarkom-2012.blogspot.com

1. Apakah ke semua protocol dynamic routing RIPv2, OSPF, dan EIGRP dapat dihubungkan dengan static routing seperti pada gambar diatas? Jawab : Semua protocol dynamic routing RIPv2, OSPF, dan EIGRP dapat dihubungkan dengan static routing dengan menggunakan perintah REDISTRIBUTE. Apa itu redistribute? Redistribute adalah perintah untuk menyebarkan network antar routing protocol yang berbeda. Pada topologi seperti gambar diatas dapat dihubungkan dengan konfigurasi seperti berikut : Konfigurasi R1 : Router>en Router#conf t Router(config)#hostname R1 R1(config)#interface Ethernet0/0/0 R1(config-if)#ip address 192.168.3.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#exit

R1(config)#interface FastEthernet0/0 R1(config-if)#ip address 192.168.1.1 255.255.255.0 R1(config-if)#no shutdown


Kelompok 3 http://www.jarkom-2012.blogspot.com

R1(config-if)#exit

R1(config)#interface FastEthernet0/1 R1(config-if)#ip address 192.168.2.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#exit

R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.0 R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.0

R1(config)#router rip R1(config-router)#version 2 R1(config-router)#network 192.168.3.0 R1(config-router)#redistribute connected

Konfigurasi R2 : Router>enable Router#configure terminal Router(config)#hostname R2 R2(config)#interface Ethernet0/0/0 R2(config-if)#ip address 192.168.3.2 255.255.255.0 R2(config-if)#no shutdown Router(config-if)#exit

R2(config)#interface FastEthernet0/0 R2(config-if)#ip address 192.168.8.1 255.255.255.0 R2(config-if)#no shutdown R2(config-if)#exit

R2(config)#interface FastEthernet0/1 R2(config-if)#ip address 192.168.4.1 255.255.255.0

Kelompok 3 http://www.jarkom-2012.blogspot.com

R2(config-if)#no shutdown R2(config-if)#exit

R2(config)#interface FastEthernet1/0 R2(config-if)#ip address 192.168.5.1 255.255.255.0 R2(config-if)#no shutdow R2(config-if)#exit

R2(config)#interface FastEthernet1/1 R2(config-if)#ip address 192.168.11.1 255.255.255.0 R2(config-if)#no shutdown R2(config-if)#exit

R2(config)#router rip R2(config-router)#version 2 R2(config-router)#network 192.168.3.0 R2(config-router)#network 192.168.4.0 R2(config-router)#network 192.168.5.0 R2(config-router)#redistribute ospf 1 metric 1 R2(config-router)#redistribute eigrp 1 metric 1 R2(config-router)#exit

R2(config)#router ospf 1 R2(config-router)#network 192.168.8.0 0.0.0.255 area 0 R2(config-router)#redistribute rip % Only classful networks will be redistributed R2(config-router)#redistribute eigrp 1 % Only classful networks will be redistributed R2(config-router)#exit

R2(config)#router eigrp 1 R2(config-router)#network 192.168.11.0 0.0.0.255


Kelompok 3 http://www.jarkom-2012.blogspot.com

R2(config-router)#redistribute rip metric 10000 100 255 1 1500 (menggunakan Default metrik) R2(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500 (menggunakan Default metrik)

Konfigurasi R3: Router>en Router#conf t Router(config)#hostname R3 R3(config)#interface FastEthernet0/1 R3(config-if)#ip address 192.168.4.2 255.255.255.0 R3(config-if)#no shutdown R3(config-if)#exit

R3(config)#interface FastEthernet0/0 R3(config-if)#ip address 192.168.6.1 255.255.255.0 R3(config-if)#no shutdown R3(config-if)#exit

R3(config)#router rip R3(config-router)#version 2 R3(config-router)#network 192.168.4.0 R3(config-router)#network 192.168.6.0

Konfigurasi R4: Router>en Router#conf t Router(config)#hostname R4

R4(config)#interface FastEthernet0/1 R4(config-if)#ip address 192.168.5.2 255.255.255.0


Kelompok 3 http://www.jarkom-2012.blogspot.com

R4(config-if)#no shutdown R4(config-if)#exit

R4(config)#interface FastEthernet0/0 R4(config-if)#ip address 192.168.7.1 255.255.255.0 R4(config-if)#no shutdown R4(config-if)#exit

R4(config)#router rip R4(config-router)#version 2 R4(config-router)#network 192.168.5.0 R4(config-router)#network 192.168.7.0 R4(config-router)#

Konfigurasi R5: Router>en Router#conf t Router(config)#hostname R5

R5(config)#interface FastEthernet0/0 R5(config-if)#ip address 192.168.8.2 255.255.255.0 R5(config-if)#no shutdown R5(config-if)#exit

R5(config)#interface FastEthernet0/1 R5(config-if)#ip address 192.168.9.1 255.255.255.0 R5(config-if)#no shutdown R5(config-if)#exit

R5(config)#router osp R5(config)#router ospf 1

Kelompok 3 http://www.jarkom-2012.blogspot.com

R5(config-router)#network 192.168.8.0 0.0.0.255 area 0 R5(config-router)#network 192.168.9.0 0.0.0.255 area 0

Konfigurasi R6: Router>en Router#conf t Router(config)#hostname R6

R6(config)#interface FastEthernet0/1 R6(config-if)#ip address 192.168.9.2 255.255.255.0 R6(config-if)#no shutdown R6(config-if)#exit

R6(config)#interface FastEthernet0/0 R6(config-if)#ip address 192.168.10.1 255.255.255.0 R6(config-if)#no shutdown R6(config-if)#exit

R6(config)#router ospf 1 R6(config-router)#network 192.168.9.0 0.0.0.255 area 0 R6(config-router)#network 192.168.10.0 0.0.0.255 area 0 R6(config-router)#

Konfigurasi R7: Router>en Router#conf t Router(config)#hostname R7

R7(config)#interface FastEthernet0/1 R7(config-if)#ip address 192.168.11.2 255.255.255.0 R7(config-if)#no shutdown


Kelompok 3 http://www.jarkom-2012.blogspot.com

R7(config-if)#exit

R7(config)#interface FastEthernet0/0 R7(config-if)#ip address 192.168.12.1 255.255.255.0 R7(config-if)#no shutdown R7(config-if)#exit

R7(config)#router eigrp 1 R7(config-router)#network 192.168.11.0 0.0.0.255 R7(config-router)#network 192.168.12.0 0.0.0.255 R7(config-router)#redistribute ospf 1 R7(config-router)#redistribute rip

Konfigurasi R8: Router>en Router#conf t Router(config)#hostname R8

R8(config)#interface FastEthernet0/0 R8(config-if)#ip address 192.168.12.2 255.255.255.0 R8(config-if)#no shutdown R8(config-if)#exit

R8(config)#interface FastEthernet0/1 R8(config-if)#ip address 192.168.13.1 255.255.255.0 R8(config-if)#no shutdown R8(config-if)#exit

R8(config)#router eigrp 1 R8(config-router)#network 192.168.12.0 0.0.0.255 R8(config-router)#network 192.168.13.0 0.0.0.255

Kelompok 3 http://www.jarkom-2012.blogspot.com

I. KESIMPULAN Router adalah alat yang digunakan untuk mengirimkan paket data melalui sebuah jaringan atau internet menuju tujuannya, yang dikenal dengan istilah routing RIP merupakan routing protocol sederhana dan termasuk jenis Distance Vector. RIP menggunakan jumlah lompatan (hop count) untuk menentukan cara terbaik ke sebuah network remote, yaitu jumlah router yang harus dilalui oleh paket-paket untuk mencapai alamat tujuannya. EIGRP merupakan routing protocol yang termasuk Cisco proprietarty yang berarti hanya bisa digunakan sesama router cisco saja. EIGRP( Enhanced Interior Gateway Routing Protocol) adalah pengembangan dari IGRP (Interior Gateway Routing Protocol). OSPF merupakan sebuah protocol standar terbuka yang telah diimplementasikan oleh sejumlah vendor jaringan. OSPF bekerja dengan algoritma Dijkstra. Redistribute mempunyai untuk menyebarkan network antar routing protocol yang berbeda . Redistribute Rip : Merupakan proses ketika Routing sebuah router mengambil informasi yang telah ditemukan dalam suatu routing protocol dan mendistribusikan keprotocol routing yang berbeda dalam local dan wide area network dengan menggunakan routing vector. Redistribute Ospf 1 : suatu proses ketika routing sebuah router mengmbil informasi dan mendistribusikan ke protocol yang lain dimana jalur yang terbaik adalah jalur yang mempunyai cumulative cost yang paling rendah. Redistribute Eigrp 1 : proses ketika routing sebuah router mengambil informasi dan mendistribusikannya ke protokol yang berbeda dengn menggunakan dua tipe routing protocol yang berbeda yaitu distance vector dan link state.

J. DAFTAR PUSTAKA Ahira, Anne. Fungsi dan Jenis Router. http://www.anneahira.com/router-17908.htm (diakses tanggal 11 April 2012 jam 16.44 WIB) Anonim. Routing Protokol Link State dan Distance Vector http://raytkj.blogspot.com/2012/04/konsep-routing-protokol-link-state-dan.html (diakses tanggal 11 April 2012 jam 16.54 WIB)

Kelompok 3 http://www.jarkom-2012.blogspot.com

Deje. Modul Sistem Jaringan Komputer. http://deje.files.wordpress.com/2007/12/sisjarkom-modul-6.pdf (diakses tanggal 11 April 2012 jam 17.30 WIB) Rezye. Makalah Routing Dynamic. http://www.slideshare.net/Rezye/makalah-routingdynamic (diakses tanggal 11 April 2012 jam 17.12 WIB) Ramadhan, Fauzi. 2012. Route Redistribution : Route Feedback, (Online),

(http://ctrlaltnix.net/2012/01/route-redistribution-route-feedback/, diakses Rabu, 11 April 2012, pukul 22.10 WIB). Setiawan, Candra. 2010. Prinsip Redistribute Routing Protocol, (Online),

(http://candra.unsri.ac.id/?p=251, diakses Rabu, 11 April 2012, pukul 21.00 WIB).

Kelompok 3 http://www.jarkom-2012.blogspot.com