Anda di halaman 1dari 76

Tutorial membuat jaringan lan dan hotspot dengan mikrotik

Yang pertama akan kita lakukan adalah menyeting mikrotik. Diasumsikan mikrotik dalam keadaan clean, masih baru blm ada settingan apa apanya. 1. Buka Winbox anda, karena blm memiliki Ip address, connect to nya pake mac address. tekan tanda agar terscan mac nya

2. Pilih mac addressnya, kemudian loginlah. user name admin, password kosongin aja

3. Ubah semua nama interface yang dibutuhkan sesuai penggunaannya; wan, lan, hotspot, proxy

4. setting IP tiap2 interface yang ada. masuk ke > IP address. add tiap2 interface seperti gambar dibawah ini

/ip address add address=192.168.100.2/24 interface=wan #sesuaikan dengan IP wan anda add address=192.168.101.1/24 interface=lan #sesuaikan dengan IP lan anda add address=192.168.103.1/24 interface=hotspot #sesuaikan dengan IP hotspot anda add address=192.168.105.1/24 interface=proxy #sesuaikan dengan IP proxy anda 5. Setting DNS > IP DNS Set. kasih IP DNS nya 192.168.100.1 jangan lupa allow remote request nya dicentang

/ip dns set servers=192.168.100.1 allow-remote-requests=yes #sesuaikan dengan dns anda #klo mikrotik seri 3.30 perintahnya : #set primary-dns=192.168.100.1 allow-remote-requests=yes 6. buat nat nya. > IP firewall NAT. tambahkan rule baru, setting chain=srcnat outinterface=wan action=masquerade.

/ip firewall nat add chain=srcnat out-interface=wan action=masquerade comment=nat

7. bikin routenya > ip route. tambahkan rule baru, setting gatewaynya aja. 192.168.100.1

/ip route add gateway=192.168.100.1 #sesuaikan dengan gateway anda sampai disini harusnya mikrotik anda sudah konek ke internet. coba tes lewat terminal. ping yahoo. komputer yg terhubung ke mikrotik juga harus sudah konek internet. ingat setting IP PC anda secara manual, soalnya kita gak nyeting DHCP
Cara setting ip dynamic di Mikrotik untuk Remote Jarak Jauh

Kali ini saya akan memberikan info mengenai cara meremote ip dynamic modem dan mikrotik jarak jauh. Memang Pusing kalau Mikirin Ip Public Modem yang Dinamis secara IPnya ganti ganti terus jikalau kita menggunakan mikrotik sebagai router alhasil hilang jejak artinya tidak tau ip public nya berapa, khususnya kalau dari speedy, nah maka dari itu ada sedikit info nich buat pengguna IP Dinamis yang mungkin ingin meremote mikrotiknya di luar daerah, ini hasil test saya udah berhasil sebelumnya saya pake changeIP tapi saya pengen coba dari lain script.. yaitu dari Afraid Klik DAFTAR untuk membuat akun di afraid, karena kita memerlukan domain untuk ip modem. jika sudah !! Langsung aja ke langkah langkahnya : 1. Buka Notepad dan paste code dibawah ini, ke notepad tersebut # Update DNS on Freedns.afraid.org :global host :global "freedns.afraid.org" "urlddns"

url

/tool fetch url=$url host=$host 2. Edit dulu dibagian "urldns" menjadi : # Update DNS on Freedns.afraid.org :global host "freedns.afraid.org" :global url "http://freedns.afraid.org/dynamic/update.php?VEdmU24wTVRTTUlB QUs5NELAELADAEdae33" /tool fetch url=$url host=$host URL :global url "http://freedns.afraid.org/dynamic/update.php?VEdmU24wTVRTTUlBQUs5NELAELADAEd ae33" cara dapatkan url tersebut : Buka account afraid anda Klik Dynamic DNS, dan scroll kebawah lihat domain yang ingin anda revers ke ip mikrotik kita yang dynamis. Jika anda belum memiliki domain yang di masukkan di afraid, buatlah sebuah subdomain, dengan mengklik tulisan REGISTRY dan buat subdomain di salah satu domain yang anda sukai di list domain yang disediakan oleh afraid.org jika sudah kembali lagi ke Dynamic DNS, scroll kebawah dan lihat tulisan Direct URL, klik kanan Copy Link nya, dan timpa tulisan urlddns pada scripts diatas.

Klik System -> Scripts -> klik tanda add [+] yang berwarna merah Name dengan afraid Policy centang semua Paste code yang kita edit tadi di bagian source kotak scripts Apply -> Ok

Terakhir

Klik System -> Scheduler -> klik add [+] Isikan afraid pada name dan On Event. Centang semua policy Pada Start time pilih startup

Interval isikan 00:10:00 Klik tombol Ok.

Simple Queue Memisah Bandwidth Lokal dan Internasional

Latar Belakang Penyetingan simple Queue untuk Bandwith Minimum


Banyak sekali muncul pertanyaan bagaimana cara melakukan pemisahan Queue untuk trafik internet internasional dan trafik ke internet Indonesia (OpenIXP dan IIX). Di internet sebetulnya sudah ada beberapa website yang menampilkan cara pemisahan Simple Queue ini, tapi kami akan coba menampilkan kembali sesederhana mungkin supaya mudah diikuti. Pada artikel Simple Queue ini, kami mengasumsikan bahwa: 1. Router Mikrotik melakukan Masquerading / src-nat untuk client. Client menggunakan IP privat. 2. Gateway yang digunakan hanya satu, baik untuk trafik internasional maupun IIX. 3. Pada Penyetingan Simple Queue ini Anda bisa menggunakan web-proxy internal ataupun tanpa web-proxy. Jika Anda menggunakan web-proxy, maka ada beberapa tambahan rule Simple Queue yang perlu dilakukan. Perhatikan bagian NAT dan MANGLE pada contoh seting Simple Queue di bawah ini. Jika ada parameter Simple Queue yang berbeda dengan kondisi Anda di lapangan, maka konfigurasi yang ada di artikel ini harus Anda modifikasi sesuai dengan konfigurasi network Anda. Pengaturan Dasar dari Topografi Jaringan untuk seting Simple Queue yang bagus Berikut ini adalah diagram network dan asumsi IP Address yang akan digunakan dalam contoh Simple Queue ini.

Untuk mempermudah pemberian contoh, kami mengupdate nama masing-masing interface ether untuk Simple Queue sesuai dengan tugasnya masing-masing.
[admin@MikroTik] > /interface pr Flags: X - disabled, D - dynamic, R - running # NAME TYPE RX-RATE TX-RATE MTU 0 R ether-public ether 0 0 1500 1 R ether-local ether 0 0 1500

Untuk klien Simple Queue, akan menggunakan blok IP 192.168.0.0/24, dan IP Address 192.168.0.1 difungsikan sebagai gateway dan dipasang pada router, interface ether-local. Klien dapat menggunakan IP Address 192.168.0-2 hingga 192.168.0.254 dengan subnet mask 255.255.255.0.
[admin@MikroTik] > /ip ad pr Flags: X - disabled, I - invalid, D - dynamic # ADDRESS NETWORK BROADCAST INTERFACE 0 202.0.0.1/24 202.0.0.0 202.0.0.255 ether-public 1 192.168.0.1/24 192.168.0.0 192.168.0.255 ether-local

Jangan lupa melakukan konfigurasi DNS server pada router yang di seting Simple Queue, agar tidak menggangu pola Simple Queue nya dan mengaktifkan fitur allow remote request. Karena klien menggunakan IP private, maka kita harus melakukan fungsi src-nat pada IP address yang di implemetesikan ke Ip Simple Queue seperti contoh berikut.
[admin@MikroTik] > /ip fi nat pr Flags: X - disabled, I - invalid, D - dynamic 0 chain=srcnat out-interface=ether-public action=masquerade

Jika Anda menggunakan web-proxy transparan, Anda perlu menambahkan rule nat redirect, seperti terlihat pada contoh di bawah ini (rule tambahan yang tercetak tebal digunakan supaya web proxy dan seting Simple Queue dapat berjalan bersamaan).

[admin@MikroTik] > /ip fi nat pr Flags: X - disabled, I - invalid, D - dynamic 0 chain=srcnat out-interface=ether-public action=masquerade 1 chain=dstnat in-interface=ether-local protocol=tcp dst-port=80 action=redirect to-ports=8080

Jangan lupa mengaktifkan fitur web-proxy, dan men-set port layanan web-proxynya, dan disesuaikan dengan port redirect pada contoh di atas. CEK: Pastikan semua konfigurasi telah berfungsi baik. Lakukanlah ping (baik dari router maupun dari klien) ke luar network Anda secara bergantian. Pengaturan IP Address List untuk mempermudah Simple Queue bekerja Mulai Mikrotik RouterOS versi 2.9, dikenal dengan fitur yang disebut IP Address List. Fitur ini adalah pengelompokan IP Address tertentu dan setiap IP Address tersebut bisa kita namai. Kelompok ini bisa digunakan sebagai parameter dalam mangle, firewall filter, nat, ataupun queue. Mikrotik Indonesia telah menyediakan daftar IP Address yang diadvertise di OpenIXP dan IIX, yang bisa didownload dengan bebas di URL: http://www.mikrotik.co.id/getfile.php?nf=nice.rsc File nice.rsc ini dibuat secara otomatis di server Mikrotik Indonesia setiap jam, dan merupakan data yang telah dioptimalkan untuk menghilangkan duplikasi entri dan tumpang tindih subnet. Saat ini jumlah baris pada script tersebut berkisar 7000 baris. Contoh isi file nice.rsc :
# Script created by: Valens Riyadi @ www.mikrotik.co.id # Generated at 26 April 2007 05:30:02 WIB ... 431 lines /ip firewall address-list add list=nice address="1.2.3.4" rem [find list=nice] add list=nice address="125.162.0.0/16" add list=nice address="125.163.0.0/16" add list=nice address="152.118.0.0/16" add list=nice address="125.160.0.0/16" add list=nice address="125.161.0.0/16" add list=nice address="125.164.0.0/16" . . dst...

Proses pengambilan file nice.rsc bisa dilakukan langsung dari terminal di RouterOS dengan perintah:
/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc;

Kemudian, import-lah file tersebut.


[admin@MikroTik] > import nice.rsc

Opening script file nice.rsc Script file loaded and executed successfully

Pastikan bahwa proses import ip address situs situs untuk Simple Queue telah berlangsung dengan sukses, dengan mengecek Address-List pada Menu IP Firewall

Proses upload ini dapat juga dilakukan secara otomatis jika Anda memiliki pengetahuan scripting. Misalnya Anda membuat shell script pada Linux untuk melakukan download secara otomatis dan mengupload file secara otomatis setiap pk 06.00 pagi. Kemudian Anda tinggal membuat scheduler pada router untuk melakukan import file. Jika Anda menggunakan RouterOS versi 3.x, proses update juga dapat dilakukan secara otomatis. Perintah yang perlu dibuat adalah : /system sched add comment=update-nice disabled=no interval=1d name=update-nice-rsc on-event=:if ([:len [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc }; /tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc;/import nice.rsc startdate=jan/01/1970 start-time=00:06:00

Hati-hati! : Setelah copy paste, pastikan hasil copy paste sama persis. Proses copy paste kadang-kadang menghilangkan beberapa karakter tertentu. Pengaturan Mangle untuk ditautkan ke Simple Queue dibawahnya Langkah selanjutnya adalah membuat mangle. Kita perlu membuat 1 buah connection mark dan 2 buah packet mark, masing-masing untuk trafik internasional dan lokal.
[admin@MikroTik] > /ip firewall mangle pr Flags: X - disabled, I - invalid, D - dynamic 0 chain=prerouting in-interface=ether-local dst-address-list=nice action=mark-connection new-connection-mark=conn-iix passthrough=yes 1 chain=prerouting connection-mark=conn-iix action=mark-packet new-packet-mark=packet-iix passthrough=no 2 chain=prerouting action=mark-packet new-packet-mark=packet-intl passthrough=no

Untuk rule #0, pastikanlah bahwa Anda memilih interface yang mengarah ke client. Untuk chain, kita menggunakan prerouting, dan untuk kedua packet-mark, kita menggunakan passthrough=no. Jika Anda menggunakan web-proxy internal dan melakukan redirecting trafic, maka Anda membuat 2 buah rule tambahan seperti contoh di bawah ini (rule tambahan yang tercetak tebal).
[admin@MikroTik] > /ip firewall mangle pr Flags: X - disabled, I - invalid, D - dynamic 0 chain=prerouting in-interface=ether-local dst-address-list=nice action=mark-connection new-connection-mark=conn-iix passthrough=yes 1 chain=prerouting connection-mark=conn-iix action=mark-packet new-packet-mark=packet-iix passthrough=no 2 chain=output connection-mark=conn-iix action=mark-packet new-packetmark=packet-iix passthrough=no 3 chain=prerouting action=mark-packet new-packet-mark=packet-intl passthrough=no 4 chain=output action=mark-packet new-packet-mark=packet-intl passthrough=no

Pengaturan Simple Queue

Untuk setiap client, kita harus membuat 2 buah rule Simple Queue. Pada contoh berikut ini, kita akan melakukan limitasi untuk IP client 192.168.0.2/32, dan kita akan memberikan limitasi iix (up/down) sebesar 64k/256k, dan untuk internasional sebesar (up/down) 32k/128k. Setingan Default Simple Queue saya
[admin@MikroTik]> /queue simple pr Flags: X - disabled, I - invalid, D - dynamic 0 name="client02-iix" target-addresses=192.168.0.2/32 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=packet-iix direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=64000/256000 total-queue=default-small 1 name="client02-intl" target-addresses=192.168.0.2/32 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=packet-intl direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=32000/128000 total-queue=default-small

Pengecekan Akhir pada Optimasi Simple Queue ini Setelah selesai, lakukanlah pengecekan dengan melakukan akses ke situs lokal maupun ke situs internasional, dan perhatikanlah counter baik pada firewall mangle maupun pada Simple Queue. Anda juga dapat mengembangkan queue type menggunakan pcq sehingga trafik pada setiap client dapat tersebar secara merata. sumber: Seting Simple Queue ForumMikrotik.co.id

Memblokir Situs Pada Jam - jam Tertentu


Berikut ini adalah suatu trik untuk memblok situs yang di atur sesuai jam. Salah satu contoh adalah situs facebook yang beberapa kantor ingin di blok pada jam kerja.

Pertama, supaya waktu yang berjalan di router sesuai dengan waktu lokasi setempat, maka kita perlu mengatur agar clock di MikroTik mengacu pada NTP Server. Jika kita memiliki NTP Server sendiri, maka kita tinggal mengarahkan MikroTik ke NTP Server tersebut, namun jika kita tidak memiliki NTP Server, maka tidak perlu khawatir karena banyak NTP Server di luar yang bisa kita gunakan sebagai acuan. Beberapa diantaranya adalah NTP Server milik LIPI (Lembaga Ilmu Pengetahuan Indonesia) dengan URL: ntp.kim.lipi.go.id (203.160.128.6) dan NTP Pool Project dengan salah satu URLnya: 0.id.pool.ntp.org (202.169.224.16). Untuk mensettingnya di MikroTik, ketikkan perintah berikut :

/system ntp client set primary-ntp=203.160.128.6 secondaryntp=202.169.224.16 \ mode=unicast enabled=yes

Kedua, membuat rule di firewall filter. Dalam hal ini saya ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut :

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dst-port=80 content="facebook" action=drop comment="Blokir Akses Facebook";

Via Winbox :

Ketiga, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini saya membuat 3 script, yaitu script untuk mengaktifkan (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini scriptnya :

Script untuk mematikan (disable) firewall :

/system script add name="fb-allow" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes

Via Winbox :

Script untuk mengaktifkan (enable) firewall :

/system script add name="fb-deny" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}

Via Winbox :

Script untuk disable firewall di hari libur dan enable di hari kerja :

/system script add name="fb-holiday" policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find onevent="fb-deny"] disabled=yes]}

Keempat, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini saya membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00, jam 12:00, jam 13:00, jam 17:00, hari sabtu-minggu, dan hari senin. Berikut ini scriptnya :

Schedule untuk mengaktifkan (enable) firewall pada jam kerja (08:00) :

/system scheduler add name="fb-08:00" start-date=jan/01/2010 starttime=08:00:00 interval=1d on-event="fb-deny"

Via Winbox :

Schedule untuk mematikan (disable) firewall pada jam istirahat (12:00) :

/system scheduler add name="fb-12:00" start-date=jan/01/2010 starttime=11:30:00 interval=1d on-event="fb-allow"

Via Winbox :

Schedule untuk mengaktifkan kembali (enable) firewall pada jam kerja (13:00) :

/system scheduler add name="fb-13:00" start-date=jan/01/2010 starttime=13:00:00 interval=1d on-event="fb-deny"

Via Winbox :

Schedule untuk mematikan (disable) firewall di luar jam kerja ke atas ( > 17:00) :

/system scheduler add name="fb-16:00" start-date=jan/01/2010 starttime=16:00:00 interval=1d on-event="fb-allow"

Via Winbox :

Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :

/system scheduler add name="fb-sabtu-minggu" start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter "start-date" scheduler adalah Hari Sabtu. Dan parameter "interval" diberi nilai 7d.

Schedule untuk mengaktifkan kembali (enable) firewall di hari kerja (Senin) :

/system scheduler add name="fb-senin" start-date=aug/03/2009 starttime=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter "start-date" scheduler adalah Hari Senin. Dan parameter "interval" diberi nilai 7d.

Setting Filtering Websites Porno di Mikrotik


Berikut ini saya sharing tentang Step by Step membuat Web Proxy Mikrotik, simple, praktis dan dapat anda lakukan dengan mudah. Langkah Pertama : Aktifkan Fitur Web Proxy Mikrotik dari menu -> IP -> Web Proxy.

Langkah Kedua : Selanjutnya kita klik Web Proxy Setting.

Langkah Ketiga : Klik menu ENABLE lalu masukkan IP Interface LAN Mikrotik Router kita, disini IP yang saya gunakan adalah 192.168.88.250.

Langkah Keempat : Selanjutnya kita akan memblok websites www.playboy.com, pada menu ACCESS klik tanda plus untuk menambahkan satu Web Proxy Rule. Ketikkan www.playboy.com pada Destination Address, lalu pada menu ACTION kita pilih DENY . Kita juga bisa menambahkan peringatan ( dengan tampilan khusus yang kita buat sendiri ) dengan menambahkan opsi Redirect To : 192.168.88.100/warning . Contoh websites peringatam untuk Redirect ini saya berikan contoh seperti pada link dibawah ini dan anda bisa juga me-Redirect ke alamat web ini untuk Web Proxy anda : http://jamesbond.xcode.or.id/warning atau http://jamesbond.berjuang.info/warning

Langkah Kelima : Saat kita masukkan www.playboy.com maka Web Proxy Mikrotik akan mendeteksi alamat IP dari domain name websites tersebut dan secara otomatis akan dirubah menjadi alamat IP ( numerik )

Langkah Keenam : Contoh berikutnya adalah memblok ( tanpa redirect ) pada Websites www.pramuria.net.

Langkah Ketujuh : Oke sampai disini weting Web Proxy dari sisi Mikrotik sudah selesai, selanjutnya kita setting Web Proxy pada PC Client kita. Kita masuk ke menu Internet Option pada Control Panel, hal ini sama juga dengan masuk ke menu OPTION dari Internet Explorer. Untuk Google Chrome secara otomatis mengikuti setting ini ( setting IE ) sedangkan Mozilla Firefox harus di setting dari Menu Internal / di dalam Firefox itu tersendiri.

Langkah Kedelapan : Selanjutnya pada setting IP Address kita, IP Gateway dan IP DNS tidak perlu di masukkan seperti pada gambar dibawah ini.

Langkah Kesembilan : Selanjutnya pada menu tab Connection, masuk ke menu LAN Setting.

Lakukan setting seperti gambar berikut ini, masukkan IP Web Proxy Mikrotik kita : 192.168.88.250 dan Port yang kita gunakan port 80. ( lihat kembali langkah ketiga ).

Untuk mengatur konfigurasi Proxy pada Web Browser Mozilla Firefox, lakukan seperti gambar di bawah ini dengan masuk ke menu Tools lalu pilih Option.

Lalu masuk ke menu ADVANCED dan pilih submenu NETWORK dan selanjutnya klik menu SETTING.

Selanjutnya lakukan setting Manual Proxy Configuration seperti dibawah ini :

Langkah Kesepuluh : Kita uji / kita lihat hasilnya Lakukan Browsing ke www.pramuria.net dan ke www.playboy.com.

Seeeeppp dech seperti terlihat gambar diatas, websites www.pramuria.net sudah berhasil kita blokir dan selanjutnya akses ke www.playboy.com.

Tarrrraaaa Websites Redirect yang muncul, bukan websites www.playboy.com seperti yang diharapkan.

Oke lah kalo begitu, tutorial ini saya buat sebagai inspirasi yang dapat anda kembangkan lebih luas lagi sesuai kebutuhan anda masing-masing

Konfigurasi Mikrotik Firewall

Berikut ini adalah Step by Step Konfigurasi Mikrotik Firewall dalam bahasa yang simple dan mudah di pahami secara awam. Misalnya pada Mikrotik ini dengan Interface bernama LAN dan WAN. IP Address WAN adalah 192.168.42.75 dan IP Address LAN adalah 192.168.1.1. Lebih detailnya dapat kita lihat pada gambar dibawah ini :

Untuk memulai konfigurasi Firewall, kita pilih menu : IP > FIREWALL. Selanjutnya kita dapat menambahkan pengaturan Firewall secara Logika.

1. MEMBUAT FIREWALL UNTUK MEMBLOCK AKSES INTERNET DARI 1 IP ADDRESS CLIENT.


Buat New Firewall Rules, pada Option GENERAL, pilih Chain : FORWARD. Lalu kita pilih / isi Source Address dengan IP Address dari Client yang akan kita Block. Misalnya Client dengan IP : 192.168.1.10. Out Interface kita isi dengan interface : WAN. Selanjutnya pada Option ACTION, kita pilih : DROP. Jadi Firewall ini berarti : Jika ada Client dengan IP : 192.168.1.10 yang akan mengakses internet dengan OUTGOING melalui Interface WAN, maka koneksi ini akan di DROP oleh Mikrotik.

Dibawah ini tampilan Firewall Rule yang barusan kita buat.

2. MEMBUAT FIREWALL UNTUK MEMBLOCK AKSES INTERNET DARI 1 MAC ADDRESS CLIENT.

Buat New Firewall Rules, pada Option GENERAL, pilih Chain : FORWARD. Out Interface kita isi dengan interface : WAN. Selanjutnya pada menu ADVANCED, isikan pada menu Source Mac Address daripada Mac Address yang dimiliki oleh Client yang akan kita Blokir akses internetnya. Selanjutnya pada Option ACTION, kita pilih : DROP. Jadi Firewall ini berarti : Jika ada Client dengan Mac Address sesuai Mac target yang akan mengakses internet dengan OUTGOING melalui Interface WAN, maka koneksi ini akan di DROP oleh Mikrotik.

4. MEMBUAT FIREWALL UNTUK MEMBLOCK AKSES INTERNET DARI SEKELOMPOK IP ADDRESS CLIENT.

Pertama kita buat lebih dulu sejumlah IP Address pada menu Firewall > Address List. Misalnya kita berikan nama CLIENT NO INTERNET. Buatlah sejumlah daftar IP Address Client dari LAN kita yang akan di block akses internet-nya. Selanjutnya kita buat sebuah New Firewall Rules, pada Option GENERAL, pilih Chain : FORWARD. Out Interface kita isi dengan interface : WAN. Selanjutnya pada menu ADVANCED, isikan pada menu Source Address List daripada Daftar Address List yang telah kita buat untuk memblokir akses internetnya. Kita pilih nama : CLIENT NO INTERNET. Selanjutnya pada Option ACTION, kita pilih : DROP. Jadi Firewall ini berarti : Jika ada Client dengan IP Address yang terdaftar pada CLIENT NO INTERNET yang akan mengakses internet dengan OUTGOING melalui Interface WAN, maka koneksi ini akan di DROP oleh Mikrotik.

5. MEMBUAT FIREWALL UNTUK MEMBLOCK AKSES INTERNET DARI SEKELOMPOK IP ADDRESS ATTACKER.

Pertama kita buat lebih dulu sejumlah IP Address pada menu Firewall > Address List. Misalnya kita berikan nama ATTACKER.

Buatlah sejumlah daftar IP Address dari IP yang kita identifikasikan sebagai Black List IP Address dan kita akan di block akses internet-nya. IP Address ini biasanya terdeteksi sebagai LOG MERAH atau Ilegal Access pada Mikrotik kita. Selanjutnya kita buat sebuah New Firewall Rules, pada Option GENERAL, pilih Chain : FORWARD. In Interface kita isi dengan interface : WAN. Selanjutnya pada menu ADVANCED, isikan pada menu Source Address List daripada Daftar Address List yang telah kita buat untuk memblokir akses internetnya. Kita pilih nama : ATTACKER. Selanjutnya pada Option ACTION, kita pilih : DROP. Jadi Firewall ini berarti : Jika ada orang atau system dengan IP Address yang terdaftar pada ATTACKER yang akan mengakses IP Publick / IP WAN kita yang masuk melalui Interface WAN, maka koneksi ini akan di DROP oleh Mikrotik.

6. MEMBUAT FIREWALL UNTUK MEMBLOCK AKSES INTERNET DARI CLIENT KE SUATU WEBSITES TERLARANG.

Buat New Firewall Rules, pada Option GENERAL, pilih Chain : FORWARD. Lalu kita pilih / isi Destination Address dengan IP Address dari websites yang akan kita Block. Misalnya Websites www.porno.com dengan IP Public : 208.87.35.103. Out Interface kita isi dengan interface : WAN.

Selanjutnya pada Option ACTION, kita pilih : DROP. Jadi Firewall ini berarti : Jika ada Client dari jaringan LAN kita yang akan mengakses Websites www.porno.com dengan IP Public : 208.87.35.103 dengan OUTGOING melalui Interface WAN, maka koneksi ini akan di DROP oleh Mikrotik.

Mudah sekali bukan.??? Selamat mencoba dan nantikan Resep Firewall selanjutnya. Salam..

Step By Step Konfigurasi Mikrotik HotSpot @ Simple Mode


Maka kita dapat melakukan konfigurasi lebih lanjut, diantaranya konfigurasi Mikrotik HotSpot seperti yang kita bahas pada artikel ini. Tutorial ini di buat pada Mode Simple alias bahasa yang lebih manusiawi ( mudah di mengerti oleh pembaca yang masih awam sekalipun ), sehingga Mikrotik ini dapat kita setting dengan akses internet melalui proses pengunaan Username dan Password lebih dulu. Jadi sekalipun kita melakukan konfigurasi melalui menu IP -> Hotspot, bukan berarti fungsi ini hanya berlaku untuk HotSpot yang mengunakan Access Point saja. Namun akses melalui jaringan LAN dengan IP DHCP-pun dapat kita MANAGE mengunakan Username dan Password serta kita dapat lakukan pembatasan akses dengan kuota waktu alias LIMITED TIME ( Time Base ) ataupun dengan kuota kapasitas bandwith ( Quota Base ). Konfigurasi ini sangat cocok untuk pengunaan Layanan HotSpot Public seperti di Hotel, Cafe, Restoran, Bank maupun untuk tamu / Guest di perusahaan kita. Jadi seseorang tamu atau customer kita di berikan akses internet dengan quota tertentu, misalnya Time Base selama 2 jam dengan Username + Password yang diberikan secara perorangan di secarik kertas. Tentunya hal ini sangat bermanfaat bagi pemilik layanan Free Hotspot ini sebagai layanan PLUS yang memberikan kredit point baginya karena pelanggan akan merasa nyaman sekalipun sambil menunggu pesanan makanan atau menunggu antrian di bank, dsb. Namun Free Hotspot ini di tidak buka 100% untuk Non Pelanggan sehingga keamanan jaringan lebih terjaga dari pada akses Free HotSpot di buka secara Blak-Blakan

Berikut ini contoh Layout Desain Jaringan Hotspot :

Gambar di atas adalah salah satu contoh Layout desain jaringan LAN dengan HotSpot. Untuk gambar layout seperti pada tutorial ini adalah gambar dibawah ini :

Okelah kalau begitu, kita mulai konfigurasi ini dengan tampilan Mikrotik seperti dibawah ini.

1. Di contoh ini kita siapkan sebuah Interface yang kita beri nama HOTSPOT. Kita dapat gunakan Mikrotik RB-750 atau RB-450 ataupun PC Router di mana 1 Port Ethernet berfungsi sebagai akes ke ISP ( WAN ), lalu 1 Port Ethernet berfungsi sebagai akes LAN dan 1 Port Ethernet berfungsi sebagai akes ke HOTSPOT. Kita bisa fungsikan untuk jaringan LAN maupun langsung di sambungkan ke Access Point.

2. Pada tutorial ini kita berikan IP Address : 192.168.89.1/24 untuk interface ethernet bernama HOTSPOT. IP Address 192.168.89.1 ini juga berfungsi sebagai IP Gateway bagi jaringan HotSpot. Lalu kita siapkan juga sebuah IP POOL dengan nama DHCP_HOTSPOT dengan Range IP Address : 192.168.89.200 192.168.89.250.

3. Selanjutnya kita buka menu -> IP -> HOTSPOT lalu klik menu HOTSPOT SETUP.

4.Langkah selanjutnya adalah menentukan interface yang di gunakan untuk konfigurasi HotSpot ini. Kita pilih nama interface HOTSPOT yang telah kita siapkan atau kita rename nama interface-nya. Lalu kita klik Next.

5. Lalu kita tentukan IP Address dari Interface HotSpot yang kita kita setting dengan IP Address : 192.168.89.1/24 lalu kita klik Next.

6. Langkah berikutnya adalah menentukan IP Address Pool untuk Client HotSpot ini yang telah kita setting di menu IP Pool sebelumnya yaitu IP Address : 192.168.89.200 192.168.89.250. IP Address ini tergantung kita masing-masing, termasuk jumlah range IPnya atau jumlah Client yang kita sediakan. Lalu kita klik Next.

7. Selanjutnya menentukan Sertifikat akses SSL, kita lewati saja lalu kita klik Next.

8. Langkah selanjutnya menentukan IP Address SMTP Server, kita dapat lewatkan saja lalu kita klik Next.

9. Tahap berikutnya adalah menentukan IP DNS Server yang mana dapat kita isi dengan IP DNS Server yang telah kita tentukan dari menu IP -> DNS -> SETTING.

10. Langkah selanjutnya adalah menentukan Nama DNS, cukup di lewatkan saja lalu kita klik Next.

11. Berikutnya adalah menentukan User Local HotSpot. Berikan admin/admin, selanjutnya kita dapat atur lagi setelah Hotspot Wizard selesai. Lalu kita klik Next.

12. Berikutnya akan muncul tampilan seperti dibawah ini Setup has completed successfully yang menandakan setting HotSpot kita telah selesai.

13. Berikutnya kita lihat di menu -> HotSpot -> Server sudah ada konfigurasi yang kita buat barusan.

14. Selanjutnya kita Double klik dan ganti nama HotSpot Server sesuai keinginan kita, serta kita dapat melakukan berbagai perubahan seperlunya.

15. Selanjutnya di menu Tab Server Profile dapat kita lakukan editing juga seperlunya.

16. Selanjutnya di menu Tab User Profiles juga dapat kita edit dengan setting sesuai kebutuhan kita seperti contoh di bawah ini.

17. Kita telah melakukan setting Server HotSpot, Server Profile dan User Profile maka tahap berikutnya adalah membuat Account User.

18. Tentukan juga Limit Akses user sesuai kebutuhan kita. Bisa limited Time Base maupun Quota Base seperti contoh di bawah ini.

19. Okey sampai disini konfigurasi Mikrotik sudah selesai, selanjutnya kita tinggal konfigurasi / setting di PC Client dengan IP Otomatis / DHCP . ( kalo mengunakan Wifi maka di sarankan tetap mengunakan Security WPA / WPA2 / WPA + Radius ).

20. Kita testing dulu, setelah PC Client terkoneksi sekalipun masih tidak bisa melakukan PING ke IP Router Mikrotik kita. Apalagi ping ke Internet / Google.

21. Okey, testing selanjutnya kita buka Web Browser dengan mengakses ke Google.com

22. Kita lihat Browser langsung di belokkan ke IP HotSpot ( 192.168.89.1/login ), selanjutnya kita masukkan Username + Password yang telah kita buat di Mikrotik.

23. Setelah Username + Password yang di masukkan benar, maka Browser akan membuka Google atau Websites yang kita akses serta akan muncul Pop Up yang menampilkan informasi Counter Status Koneksi dari Account yang kita gunakan.

24. Counter ini akan terus berjalan selama PC masih Online dan di Mikrotik akan mencatat / me-record Waktu Koneksi maupun Quota / kapasitas pemakaian bandwith.

25. Jika kita lihat / kita pantau Status akses User di Mikrotik HotSpot akan tampil seperti di bawah ini. Catatan : Quota akses user dapat di reset.

Okey sampai disini konfigurasi Mikrotik HotSpot telah sukses dan telah kita uji fungsionalnya. Sangat mudah sekali dengan bahasa yang lebih manusiawi.. Mengenai Customize Login HotSpot akan di bahas di artikel tersendiri. Okey, Selamat mencoba..

Step by Step Installasi Router Mikrotik dgn ADSL Speedy


Mikrotik, sesuai dengan visinya yaitu ROUTING THE WORLD, saat ini benar-benar telah diakui sebagai Router yang sangat handal dan sangat lengkap fiturnya serta sangat mudah konfigurasinya. Namun tidak sedikit dari penguna Mikrotik ini menanggalkan Mikrotik dan kembali ke jaringan NATURAL, bukan karena Mikrotiknya yang tidak handal atau Mikrotiknya yang Bego. Melainkan SDM mereka sendiri yang masih kurang dalam memahami dan mendalami fungsi serta teknis konfigurasi Mikrotik itu sendiri. So belajarlah agar anda lebih expert menguasai Mikrotik ini. Termasuk rekan-rekan yang ingin profesional di bidang IT Networking System, kerja di ISP maupun di Telco. Siapkan Skill anda dengan keahlian Mikrotik Administrator yang handal, bukan sekedar bisa tapi harus benar-benar Expert Karena itulah, berbekal pengalaman dalam mengunakan Mikrotik sejak tahun 2005 hingga 2010 inilah saya membuat Buku Materi Training Mikrotik Bandwith Manajemen dan Mikrotik VPN Server Client, dalam kurun waktu 5 bulan ( November 2009 Februari 2011 ) telah membuat > 30 kelas Training dengan jumlah peserta > 500 orang ( baik kelas Reguler / umum maupun kelas Private / Inhouse Training ). Training ini bukan untuk Profit Oriented tapi bersifat sharing ilmu dan pengalaman bagi rekan-rekan sesama IT, Mahasiswa dan Komunitas.

Melakukan Installasi Mikrotik PC Router atau melakukan konfigurasi Mikrotik RouterBoard, bukanlah hal yang sulit ( jika benar2 paham basic konsep & teknisnya ) tapi juga bukanlah hal yang mudah ( bagi anda newbie Mikrotik dan bagi anda yang asal / sembarangan setting tanpa benar2 memahami cara kerja Mikrotik dengan seksama ). Mengunakan koneksi Speedy dengan Router Mikrotik ada 2 macam cara, yaitu : 1. Modem ADSL di setting sebagai PPPoE, lalu username & password Speedy di input pada Modem, sehingga setelah terkoneksi ke Speedy maka IP Public berada pada Modem ADSL ini. Pada option ini Mikrotik hanya berfungsi sebagai BANDWITH MANAJEMEN saja serta berbagai fitur lain, namun hanya untuk layanan LOKAL. 2. Modem ADSL di setting sebagai BRIDGE, lalu username & password Speedy di input pada Mikrotik( PPPoE Client ), sehingga setelah terkoneksi ke Speedy maka IP Public berada pada Mikrotik. Pada option ini Mikrotik bukan hanya berfungsi sebagai BANDWITH MANAJEMEN namun berbagai fitur lain dapat difungsikan untuk berbagai layanan PUBLIC. Seperti VPN Server / Client, FTP Server, Web Server, dll. Sebelum memulai konfigurasi, berikut ini Topologi Jaringan yang akan kita bangun. Modem ADSL kita setting sebagai Bridge ( Mode Bridge, bukan PPPoe ). IP Address yang digunakan juga bebas sesuai dengan jaringan di tempat anda. Sekali lagi bahwa jika kita memahami konsep Mikrotik dengan benar maka kita bikin Router untuk koneksi apa saja atau mengunakan IP Address berapa saja akan terasa mudah dan PASTI SUKSES 0 : Bahan-bahan yang harus disiapkan untuk membuat Mikrotik PC Router adalah sebuah PC Jangkrik setidaknya Pentium II/400 Mhz, harddisk minimal 1 GB, Ram 64 MB / 128 MB, 2 buah PCI LAN Card ( Merk Intel / Realtek / DLink / 3 Com / TPLink / dll ), CDRom, CD Installer Mikrotik, kabel UTP secukupnya serta sebuah Modem ADSL yang support BRIDGE MODE. 1 : IP Address ADSL Modem : 192.168.1.1 2 : IP Address interface Mikrotik ke ADSL Modem : 192.168.1.10 ( harus 1 segmen dengan IP Address Modem ). Walaupun sebenarnya kita bisa saja TIDAK memberi IP Address pada interface ini karena Dial Up PPPoE akan secara otomatis mencari Modem Bridge, tapi pemberian IP Address untuk Interface ini akan memberi kemudahan untuk pengecekan koneksi / ping ke Modem ADSL. 3 : IP Address interface Mikrotik ke Switch / Hub / Client : 192.168.88.251 ( kebetulan saja saya gunakan IP ini, yang penting harus 1 Segmen dengan IP Address PC Client kita yang lain ). Perhatikan dan pahami gambar dibawah ini :

Setelah pada tahap persiapan dengan memahai konsep dan topologi Jaringan Mikrotik yang akan kita bangun, maka cara memasaknya adalah sebagai berikut : Langkah Pertamax adalah melakukan setting Modem ADSL sebagai Bridge :

Kedua : Siapkan sebuah PC dengan 2 buah LAN Card dan di Install Mikrotik.

Ketiga : Setelah Installasi selesai, Reboot PC Router kita lalu akses ke Mikrotik dengan Winbox. Selanjutnya kedua Interface kita ganti nama menjadi LAN dan SPEEDY. Tujuannya adalah untuk memudahkan identifikasi kita sehingga tidak terjadi salah setting interface.

Keempat : Setting IP Address untuk LAN : 192.168.88.251/24 dan IP Addess interface Speedy : 192.168.10/24.

Kelima : Selanjutnya kita setting IP DNS dengan IP DNS Speedy : 202.134.1.10 dan 202.134.0.155. Caranya masuk ke menu IP lalu pilih DNS.

Keenam : Langkah selanjutnya adalah membuat Interface PPPoE Client. Caranya klik menu Interface, pada simbol plus kita klik dan pilih PPPoE Client. Disini kita juga memasukkan Username dan Password Speedy yang telah kita punya.

Pada Option General, cukup menentukan interface yang 1 jalur dengan Modem ADSL. Untuk nama dan type-nya pake default-nya saja sudah cukup.

Jangan lupa untuk menentukan Interface yang mengarah ke modem ADSL, yaitu interface yang telah kita beri nama SPEEDY. Lalu selanjutnya klik tab Dial Out dan masukkan Username + Password Account Speedy kita.

Selain melalui Winbox, kita juga bisa memasukkan Username dan Password Speedy ini lewat WebBox.

Ketujuh : Apabila kita telah selesai melakukan setting PPPoE Client maka begitu selesai setting Mikrotik langsung melakukan DialUp ke Modem ADSL kita. Jika setting Username

dan Password ini benar maka selanjutnya akan tampak status koneksi Mikrotik kita dan pada menu IP -> Address akan muncul sebuat IP Address baru berupa IP Public ( 125.164.75.150 ) yang diberikan Telkom Speedy kepada pelanggan berdasarkan Username & Password yang kita miliki.

Kedelapan : Selanjutnya kita atur NAT ( Network Address Translation ) agar Client dapat terkoneksi ke Internet atau dapat mengakses internet. Caranya masuk ke menu -> IP -> Firewall -> NAT ( seperti gambar dibawah ini ).

Kesembilan : Kita buat 1 buah NAT Rule, pada General -> Chain = srcnat, -> OutInterface = pppoe out1. Lalu pada option Action kita pilih -> Masquarade.

Selain setting dari Console atau dari Winbox, kita juga bisa melakukan setting NAT ini dari WebBox ( kalo menurut saya sich ini buat Newbie Mikrotik lebih mudah daripada setting dari Winbox ). Caranya : Pilih Public Interface = pppoe out1 lalu centang NAT trus klik Apply.

Kesepuluh : Selanjutnya kita tambahkan 1 buah IP Route. Perhatikan pada sebelah IP Address dari IP Public dibawah ini yaitu : Network = 125.164.72.1. Nah, IP Network ini adalah IP Gateway Telkom Speedy yang melayani koneksi kita. Tambahkan 1 buah New Route, Destination : 0.0.0.0/0 lalu Gateway = = 125.164.72.1.

Kesebelas : Sampai sini setting Mikrotik Router kita telah selesai. Tinggal test ping koneksi dari Mikrotik kita. Lakukan test ke IP DNS Speedy : 202.134.1.0 dilanjutkan test ping ke yahoo.com maupun ke websites yang lain. Jika ada reply maka Mikrotik kita telah berhasil / telah sukses kita konfigurasi.

Keduabelas : Langkah ini kita lakukan pada PC Client. IP Mikrotik interface ke LAN merupakan IP Gateway untuk PC Client kita. IP DNS pada Client dapat kita masukkan IP DNS Speedy secara langsung maupun IP DNS dari Mikrotik ( karena kita telah setting Mikrotik menjadi DNS Relay pada langkah kelima dari tutorial ini ).

~~~~~~~~~~~~~~~~~~ Okey, sampai sini Mikrotik kita telah berfungsi sebagai Router dan sharing akses internet untuk semua Client yang lain telah dapat difungsikan. Nah, tahap selanjutnya yang harus kita lakukan adalah Bandwith Manajemen atau mengatur bandwith yang tepat untuk semua Client sehingga jika ada Client yang melakukan download mengunakan software Downloader dapat di kendalikan atau di kontrol sehingga bandwith kita tidak dihabiskannya sendiri dan akses internet client yang lain tidak menjadi lemot. Tutorial ini merupakan tahap awal dalam menyiapkan Mikrotik untuk fungsi yang lain. Diantaranya sebagai VPN Server, FTP Server, dll Ikuti terus Cerita saya ini dalam episode berikutnya :
DHCP server mikrotik

DHCP Server Mikrotik


Discription...

DHCP (Dynamic Host Configuration Protocol) adalah protokol yang berbasis arsitektur client/server yang dipakai untuk memudahkan pengalokasian alamat IP dalam satu jaringan.Sebuah jaringan lokal yang tidak menggunakan DHCP harus memberikan alamat IP kepada semua komputer secara manual. Jika DHCP dipasang di jaringan lokal, maka semua komputer yang tersambung di jaringan akan mendapatkan alamat IP secara otomatis dari server DHCP. Selain alamat IP, banyak parameter jaringan yang dapat diberikan oleh DHCP, seperti default gateway dan DNS server. DHCP didefinisikan dalam RFC 2131 dan RFC 2132 yang dipublikasikan oleh Internet Engineering Task Force. DHCP merupakan ekstensi dari protokol Bootstrap Protocol (BOOTP). DHCP server merupakan sebuah mesin yang menjalankan layanan yang dapat "menyewakan" alamat IP dan informasi TCP/IP lainnya kepada semua klien yang memintanya. Beberapa sistem operasi jaringan seperti Windows NT Server, Windows 2000 Server, Windows Server 2003, mikrotik atau GNU/Linux memiliki layanan seperti ini. DHCP client merupakan mesin klien yang menjalankan perangkat lunak klien DHCP yang memungkinkan mereka untuk dapat berkomunikasi dengan DHCP Server. Sebagian besar sistem operasi klien jaringan (Windows NT Workstation, Windows 2000 Professional, Windows XP, Windows Vista, atau GNU/Linux) memiliki perangkat lunak seperti ini.

DHCP server umumnya memiliki sekumpulan alamat yang diizinkan untuk didistribusikan kepada klien, yang disebut sebagai DHCP Pool. Setiap klien kemudian akan menyewa alamat IP dari DHCP Pool ini untuk waktu yang ditentukan oleh DHCP, biasanya hingga beberapa hari. Manakala waktu penyewaan alamat IP tersebut habis masanya, klien akan meminta kepada server untuk memberikan alamat IP yang baru atau memperpanjangnya. DHCP Client akan mencoba untuk mendapatkan "penyewaan" alamat IP dari sebuah DHCP server dalam proses empat langkah berikut:

DHCPDISCOVER: DHCP client akan menyebarkan request secara broadcast untuk mencari DHCP Server yang aktif. DHCPOFFER: Setelah DHCP Server mendengar broadcast dari DHCP Client, DHCP server kemudian menawarkan sebuah alamat kepada DHCP client. DHCPREQUEST: Client meminta DCHP server untuk menyewakan alamat IP dari salah satu alamat yang tersedia dalam DHCP Pool pada DHCP Server yang bersangkutan. DHCPACK: DHCP server akan merespons permintaan dari klien dengan mengirimkan paket acknowledgment. Kemudian, DHCP Server akan menetapkan sebuah alamat (dan konfigurasi TCP/IP lainnya) kepada klien, dan memperbarui basis data database miliknya. Klien selanjutnya akan memulai proses binding dengan tumpukan protokol TCP/IP dan karena telah memiliki alamat IP, klien pun dapat memulai komunikasi jaringan. Empat tahap di atas hanya berlaku bagi klien yang belum memiliki alamat. Untuk klien yang sebelumnya pernah meminta alamat kepada DHCP server yang sama, hanya tahap 3 dan tahap 4 yang dilakukan, yakni tahap pembaruan alamat (address renewal), yang jelas lebih cepat prosesnya. Berbeda dengan sistem DNS yang terdistribusi, DHCP bersifat stand-alone, sehingga jika dalam sebuah jaringan terdapat beberapa DHCP server, basis data alamat IP dalam sebuah DHCP Server tidak akan direplikasi ke DHCP server lainnya. Hal ini dapat menjadi masalah jika konfigurasi antara dua DHCP server tersebut berbenturan, karena protokol IP tidak mengizinkan dua host memiliki alamat yang sama. Selain dapat menyediakan alamat dinamis kepada klien, DHCP Server juga dapat menetapkan sebuah alamat statik kepada klien, sehingga alamat klien akan tetap dari waktu ke waktu. DHCP Scope adalah alamat-alamat IP yang dapat disewakan kepada DHCP client. Ini juga dapat dikonfigurasikan oleh seorang administrator dengan menggunakan peralatan konfigurasi DHCP

server. Biasanya, sebuah alamat IP disewakan dalam jangka waktu tertentu, yang disebut sebagai DHCP Lease, yang umumnya bernilai tiga hari. Informasi mengenai DHCP Scope dan alamat IP yang telah disewakan kemudian disimpan di dalam basis data DHCP dalam DHCP server. Nilai alamatalamat IP yang dapat disewakan harus diambil dari DHCP Pool yang tersedia yang dialokasikan dalam jaringan. Kesalahan yang sering terjadi dalam konfigurasi DHCP Server adalah kesalahan dalam konfigurasi DHCP Scope.

DHCP Lease adalah batas waktu penyewaan alamat IP yang diberikan kepada DHCP client oleh DHCP Server. Umumnya, hal ini dapat dikonfigurasikan sedemikian rupa oleh seorang administrator dengan menggunakan beberapa peralatan konfigurasi (dalam Windows NT Server dapat menggunakan DHCP Manager atau dalam Windows 2000 ke atas dapat menggunakan Microsoft Management Console [MMC]). DHCP Lease juga sering disebut sebagai Reservation.

DHCP Options adalah tambahan pengaturan alamat IP yang diberikan oleh DHCP ke DHCP client. Ketika sebuah klien meminta alamat IP kepada server, server akan memberikan paling tidak sebuah alamat IP dan alamat subnet jaringan. DHCP server juga dapat dikonfigurasikan sedemikian rupa agar memberikan tambahan informasi kepada klien, yang tentunya dapat dilakukan oleh seorang administrator. DHCP Options ini dapat diaplikasikan kepada semua klien, DHCP Scope tertentu, atau kepada sebuah host tertentu dalam jaringan. Kita akan membuat sebuah DHCP-Server dengan menggunakan mikrotik step by step sebagai brikut :

Buat jarak(range) ip dhcp di ip pool [admin@mikrotik] ip pool [admin@mikrotik] ip pool> add ranges=192.168.1.10-192.168.1.50 name=dhcprange Set dhcp-servernya di ip dhcp-server [admin@mikrotik] ip pool>/ip dhcp-server [admin@mikrotik] dhcp-server> add range address-pool=dhcprange interface=local name=dhcp1 Seting gateway client di ip dhcp-server network [admin@mikrotik] dhcp-server> enable dhcp1 [admin@mikrotik] dhcp-server> network [admin@mikrotik] dhcp-server network> add address=192.168.1.0/24 netmask 255.255.255.0 gateway=192.168.1.254 dns-server=203.190.112.1 Silahkan coba computer client anda, pasti jalan...