Anda di halaman 1dari 57

Bentley AutoPLANT V8i (SELECTseries 1) Installation Procedure

IMPORTANT NOTES: In order to successfully install Autodesk and Bentley applications you must
be logged in as the local User, with local Administrator rights. Further, to install Bentley AutoPLANT V8i (SELECTseries 1) successfully, AutoCAD 2007 SP2 must first be installed and launched at least once to create the default AutoCAD 2007 profile.

Installing Bentley AutoPLANT V8i (SELECTseries 1)


You must use all defaults when installing Bentley AutoPLANT V8i (SELECTseries 1). This applies specifically for the type of install: It must be Standalone. The installs will create a C:\BentleyDownloads directory containing installation CAB files. This directory must be left on each client machine. DO NOT remove after installing the applications. The Bentley software must to be installed in the following order: If the machine is to be configured for Bentley ProjectWise you must install the client software before all other Bentley applications. 08.11.07.107_Bentley ProjectWise V8i - Client Setups - pwclt081107107en.exe If not then proceed as follows: 1. 2. 3. 4. 5. 6. 7. 08.11.06.30_1_Bentley AutoPLANT P&ID V8i (SELECTseries 1) - appid08110630en.exe 08.11.06.30_2_Bentley Process & Instrumentation V8i (SELECTseries 1) - prins08110630en.exe 08.11.06.30_3_AutoPLANT Plant Design V8i (SELECTseries 1) - appd08110630en.exe 08.11.02.23 ProStructures V8i AutoCAD (SELECTseries 2) - pstac08110223en.exe 08.11.07.03_Prerequisites for Bentley Desktop Applications - pbda08110703en.exe 08.11.07.171_ProjectWise Navigator V8i (SELECTseries 1) - nav081107171en.exe 08.11.07.171_ProjectWise i-model Composer V8i (SELECTseries 1) - imcom081107171en.exe

Once you have successfully installed the applications as above, install the Praxair customizations as detailed in the following pages.

Installing Praxair Customizations for AutoPLANT V8i (SELECTseries 1)


1. The first step is to remove any previously installed Praxair BASE configuration files. To do this, run the following batch file: 00_PX-PTC_CUST_Clean_BASE.bat NOTE: If this is the first time installing customizations on the users computer, you may skip this step. 2. The next step is to install the Praxair BASE Customizations by running the following executable: 01_PX-PTC_CUST_appd08110630en_v1.0h.exe At the welcome screen click Next >.

Click Next > again.

Click Start to begin the install.

Click Next > one last time.

Click Exit to close the installer.

3. After successfully installing the Praxair BASE Customizations, set the Drawing Flattener Settings by running the Registry Entries file: 02_PX-PTC_CUST_appd08110630en_v1.0h_Drawing_Flattener.reg 4. For regional installs, run the appropriate executable from the list below: For Belgium: For Brazil: For Canada: For China: For India: For Mexico: 03_PX-BEL_CUST_appd08110630en_v1.0h.exe 03_PX-BRA_CUST_appd08110630en_v1.0h.exe 03_PX-CAN_CUST_appd08110630en_v1.0h.exe 03_PX-CHN_CUST_appd08110630en_v1.0h.exe 03_PX-IND_CUST_appd08110630en_v1.0h.exe 03_PX-MEX_CUST_appd08110630en_v1.0h.exe

At the welcome screen that appears (as below), click Next >.

Click Next > again.

Click Start to begin the install.

Click Next > one last time.

Click Exit to close the installer.

5. Installation is now complete. For detailed information on project administrator procedures and standards, please see the following documents: 01 - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Project Administration - New Project Creation 02 - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Project Administration - Creating Project Specific VISION Startup Icons 03 - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - File Naming Convention and Reference Model Hierarchy 04a - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Drawing Production - New Document Creation Using Bentley Vision V8i (SELECTseries 1) 04b - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Drawing Production - New Document Creation Using ProjectWise Explorer V8i (SELECTseries 1) 05 - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Drawing Production - Work Area Setup 06 - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Drawing Production - Drawing Flattener 07 - Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Praxair AutoCAD Color Table

Bentley AutoPLANT V8i (SELECTseries 1) Praxair Customizations to the Supports/Topworks Browser


Using the Supports/Topworks Browser
From the Piping pull-down menu select Piping > Supports/Topworks Browser.

From the docked browser tree structure select Supports > Base Supports.

Two custom support sections are available. I. II. Praxair Supports - Cold Box Praxair Supports - Warmend

Double-click on PSD-01 U-Bolt Support - Loose (guide). You will be prompted to select the piping component on which you wish to place the support. Select T to toggle the port you wish to start from then Enter to make the selection. Enter the distance from the port at which you wish to place the support.

Chapter 1
Bentley AutoPLANT Plant Design V8i (SELECTseries 1) Project Administration - New Project Creation
Initial Project Creation
New projects can be created in two ways: Distributed Mode: This is a MS Access MDB project database, with individual model MDB files. Distributed mode is intended for small/medium sized projects (only recommended for local C:\ drive temporary project environments) where the user wants to continue to run MS Access for the primary database while retaining the benefits of a managed project. (See page 6 of this chapter) Central Mode: All data is stored in central project database. It requires a SQL Server database to be created. All Praxair projects are to be created in this mode. (See page 11 of this chapter)

Getting Started
The first step in setting up a project is to create the Local Projects Root folder. This folder is the top level directory under which individual projects related to the root will reside. You will have more than one Local Projects Root folder with multiple projects defined under each.

Praxair Standard Project File Share Hierarchy


File share locations will be set up as follows: \PLANT\Generic Product Lines\... \PLANT\Projects\... \PLANT\Proposals\... \PLANT\Specs\... Projects will further be broken down as follows: \PLANT\Projects\SITE_ID\PLANT_TYPE\ PROJ_NAME \... Where: SITE_ID consists of the EDMS sell location 3-digit country code and a 3-digit site identifier. Example:

Would be: \PLANT\Projects\CAN138-Varennes, QB\... More Examples: \PLANT\Projects\BRACOS-Cosipa, Brazil\... \PLANT\Projects\CHNCAO-Caojing, China\... \PLANT\Projects\DEUHEU-Huerth, Germany\... \PLANT\Projects\MEXTAM-Tampico, Mexico\... \PLANT\Projects\USA360-Hawkins, TX\... \PLANT\Projects\USA978-Riverport, TN\...

The next level will be: \PLANT\Projects\SITE_ID\PLANT_TYPE\ PROJ_NAME \... Where: PLANT_TYPE refers to the type of plant at the site. Example: \PLANT\Projects\CAN044-Montreal_East_QB\ TLA_480\... \PLANT\Projects\CAN138-Varennes_QB\300_MTON\... \PLANT\Projects\USA357-Texas_City_2\T-1800\... \PLANT\Projects\ USA978-Riverport, TN \ PL3XL \... This folder will act as the Local Projects Root folder. When initially set up as a root using Project Administrator it will contain the following root files: Access.mdb at_prods.dbf at_proj.dbf This file controls Bentley login access/permissions to the projects in the root. This file contains REGAPP mappings for Bentley Vision. This file logs the PROJ_ID contained in this root (0001, 0002, 0003)

Note: If the site has multiple identical plant types such as two PL4s then the root will have to be adjusted to be unique. PL4_1 and PL4_2, etc Further: If there are both 2D PID projects and 3D PIPING projects at the plant then the roots are to be adjusted as follows: PL4_2D and PL4_3D, etc The last level will be: \PLANT\Projects\SITE_ID\PLANT_TYPE\ PROJ_NAME \... Where: PROJ_NAME is actually the project number. Example: \PLANT\Projects\ CAN044-Montreal_East_QB \ TLA_480\10762C\... \PLANT\Projects\CAN138-Varennes_QB\300_MTON \10133C\... \PLANT\Projects\USA357-Texas_City_2\T-1800\12711B\...

Below this level is where the Bentley AutoPLANT project file share resides. The folder structure and contents is controlled with Bentley Vision. Unless it is a ProjectWise enabled project, users should only use Bentley Vision to access and modify the project content. The next section will cover project creation using Bentley Project Administrator V8i.

Bentley Project Administrator V8i (SELECTseries 1)


The installation of Bentley AutoPLANT V8i provides 3 sample projects in the \Bentley Plant V8i Projects\... Local Projects Root folder. These are provided as examples only and should not be considered for production.

Adding or Creating a Project Root


1. A new Local Project Root folder may be created or an existing Local Projects Root folder added by using one of the following methods: Select File > Add Root from the menu. Right-click on any folder in the navigation tree, then select Add Root from the context menu displayed. In either instance, the Browse For Folder dialog shown below is displayed. Notice when highlighting the SITE-ID folder level of an existing project the OK button is grayed out.

2. Browse to the PLANT_TYPE folder level which is the actual Local Project Root and notice the OK button is now enabled. Click OK to add this project to your local list of AutoPLANT projects.

3. Click the + sign to open the tree structure and see the projects under the Local Projects Root you just added. Highlighting the project will challenge you with the Login to Project dialog.

4. Enter the correct User Name and Password as required for the project roots Access.mdb file. You can check Save Password if you wish.

Creating Distributed Mode Projects


The Project Administrator provides a wizard driven interface to create new projects. The New Project Wizard will display a series of dialogs that walk you step-by-step through the process of creating a new project. For this example we will create a new Local Projects Root folder. 1. Select File > Add Root from the menu. The Browse For Folder dialog will let you browse to new local location to store all AutoPLANT local root folders: Example: C:\PLANT\Projects\

2. Select Make New Folder and type in a new project root folder. Example: C:\PLANT\Projects\USA926-Bridgeton, NJ\...

3. Click OK.

4. You should now have a new empty Local Project Root.

A new project may now be created under the new Local Project Root folder by using one of the following methods: Select File > New from the menu. Right-click on the root folder in the navigation tree, then select New from the context menu displayed. The New Project - Provider Type dialog will appear. Select Access for Distributed mode or SQL Server for Central mode projects.

5. Choose Access and click Next>.

6. At the New Project - Base Template and 3D Settings dialog leave the Base Schematic Template as the default Standard Base Project. Select the 3D Modelling Project Settings. For Praxair projects you must use the correct PX_ prefixed configuration. Select PX_WARMEND_MMetric Click Next >.

7. Accept the default New Project - Project Paths. Click Next >.

8. At the New Project - Details dialog the only required field is the Project Name. The rest are informational fields only. For Praxair projects the Project Name is the Project Number

Example:

Fill in the details and click Finish. You will see the Creating Project status bar.

9. When the process is completed you will see Ready in the bottom-left corner. You can also confirm the Mode, Version and Units Type.

Creating Central Mode Projects


The next section covers creating a new Central Mode project and is divided into tasks for Database Administrators and for Project Administrators (See page 14 of this chapter).

For Database Administrators


1. For Central Mode projects the following steps should be taken to configure the SQL Server for use with AutoPLANT. a. Create a SQL Server login for the AutoPLANT project. **Note: A new service account should be created for EACH AutoPLANT project! b. Use the naming convention as described below: i. Username: ap_<ProjectName or Number>_2D (for P&ID projects) ii. Username: ap_<ProjectName or Number>_3D (for PIPING projects) e.g. ap_12711B_2D or ap_13593B_3D iii. Be sure to store password information for future retrieval.

Do NOT check the Enforce password policy, Enforce password expiration and User must change password at next login. Default database can be left as Master. Default language can be left as <default> c. Create new project database: i. Database name should be in the format ap_<projectnumber>_<2D>/<3D> e.g. ap_12711B_2D or ap_13593B_3D .

ii. Owner Default

d. Configure the SQL Server Account created in step 1 to have db_owner rights to the project database.

For Project Administrators


Below is the procedure performed by the Project Administrator once there is confirmation from the Database Administrator that the database is ready. 1. Highlight the network file share you have setup to be the Local Project Root.

The new project may now be created under the network Local Project Root folder by using one of the following methods: Select File > New from the menu. Right-click on the root folder in the navigation tree, then select New from the context menu displayed. The New Project - Provider Type dialog will appear. 2. Choose SQL Server and click Next>.

DO NOT check Use Multi Project Mode. DO NOT change the Project Schema Location. Leave it as the default Access database.

3. At the New Project - Base Template and 3D Settings dialog leave the Base Schematic Template as the default Standard Base Project. Select the 3D Modelling Project Settings. For Praxair projects you must use the correct PX_ prefixed configuration. Select PX_WARMEND_MMetric BE SURE to check the Use Central Project Mode box. Click Next >.

4. Accept the default New Project - Project Paths. Click Next >.

5. At the New Project - Details dialog the only required field is the Project Name. The rest are informational fields only. For Praxair projects the Project Name is the Project Number

Example:

Fill in the details and click Finish. You will see the Creating Project status bar.

6. You will be shown the Data Link Properties dialog. Enter the correct SQL Server name. Enter the User name: and Password: as provided by the Database Administrator. IMPORTANT: BE SURE to check Allow saving password and BE SURE that you have selected the correct project database.

Click Test Connection. When you see that the Test connection succeeded click OK. Click OK one last time.

7. When the process is completed you will see Ready in the bottom-left corner.

The project is now created. BEFORE allowing users access to the project, please read and implement Chapter 2:

Bentley AutoPLANT Plant Design V8i (SELECTseries 1) Project Administration - Creating Project Specific Bentley Vision V8i STARTUP Icons

Chapter 2
Bentley AutoPLANT Plant Design V8i (SELECTseries 1) Project Administration - Creating Project Specific Bentley Vision V8i STARTUP Icons
Initial Project Creation
The Project Administrator, upon creation of a new AutoPLANT Plant Design V8i (SELECTseries 1) project from Chapter 1, needs to set up the project specific Bentley Vision V8i startup icon for the users.

Getting Started
Each project comes with the following folder: Config\Custom\STARTUP\...

The Custom Files


This folder contains the following files: at.ini at_V8i_XM_Legacy.ini (used by the XM legacy icon) at_prodsV8i.dbf at_prodsV8i_XM_Legacy.DBF (manually copy to project root of XM projects as needed) COPY Me to your desktop COPY Me to your desktop V8i_XM_Legacy EditFieldsDefaults.ini EditFieldsDefaults_EQP.ini (for equipment library projects) Vision.bat Vision_V8i_XM_Legacy.bat (used by the XM legacy icon)

The Icon Setup Procedure


The AT.ini
1. The first step is to open the at.ini file and search for the [GENERAL] section. Find the APPROJDB line and add the Local Project Root folder path (This path, detailed Chapter 1, is where the access.mdb, at_prodsV8i.dbf and at_proj.dbf files reside): APPROJDB= C:\PLANT\Projects\USA926-Bridgeton, NJ\ IMPORTANT: If this is not the only project in this root, you must also update the correct PROJ_ID number in the [GENERAL] section: CurProject=0002 Save and close the at.ini file.

The STARTUP Icon Shortcut


2. The next step is to right-mouse click > Properties on the COPY Me to your desktop icon. Paste the STARTUP folder path below into the Target: textbox. Click OK. Example: C:\PLANT\Projects\USA926-Bridgeton, NJ\14646B\Config\Custom\STARTUP\Vision.bat or C:\PLANT\Projects\USA926-Bridgeton, NJ\14646B\Config\Custom\STARTUP\ Vision_V8i_XM_Legacy.bat

3. Right-mouse click > Edit on the COPY Me to your desktop icon. This will open the Vision.bat file. (For XM Legacy projects edit the COPY Me to your desktop V8i_XM_Legacy icon). Replace the following two lines by pasting the STARTUP folder path into the file as shown below:

Replace: C:\Program Files\Bentley\Plant V8i\Config\PX_COLDBOX_MMetric\Custom\STARTUP With: C:\PLANT\Projects\USA926-Bridgeton, NJ\14646B\Config\Custom\STARTUP 4. Next, replace the PROJECT_ROOT path as follows:

Replace: G:\PLANT\Projects\PROJECT_ROOT With: C:\PLANT\Projects\USA926-Bridgeton, NJ 5. You must also replace the PROJECT_DIR path as follows:

Replace: G:\PLANT\Projects\PROJECT_ROOT\PROJECT_DIR With: C:\PLANT\Projects\USA926-Bridgeton, NJ\14646B

6. Finally, add the PROJECTNAME to the following two lines. Save and close.

Update: C:\Documents and Settings\All Users\Application Data\Bentley\Plant V8i\Config With: C:\Documents and Settings\All Users\Application Data\Bentley\Plant V8i\Config\ 14646B

Distributing the STARTUP Icon


7. Copy and rename the edited icon to your desktop. Distribute to the project team members. When used to start Bentley Vision V8i this will PURGE the local users project config folder and launch the user into the project, prompting for a login. IMPORTANT NOTE: This project specific icon will replace the local instance of the at.ini with each launch thus prompting the user for a login every time. If the user wishes to save the username and password after the initial launch using the project specific icon, use the regular Bentley Vision V8i icon instead. BEFORE allowing users to start creating project documents have them read Chapters 3 and 4:

Bentley AutoPLANT Plant Design V8i (SELECTseries 1) File Naming Convention and Reference Model Hierarchy Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Drawing Production New Document Creation

Chapter 3
Bentley AutoPLANT Plant Design V8i (SELECTseries 1) File Naming Convention and Reference Model Hierarchy
Due to the introduction of Bentley ProjectWise and the enhanced Bentley Vision feature set, the document management issues of the past pertaining to file share directory structures has been greatly simplified. The Praxair customizations for Bentley AutoPLANT Plant Design V8i (SELECTseries 1) has been stripped down to the following REGAPPS and LOCATION: AutoPLANT Piping = AT_PIPE AutoPLANT Equipment = AT_EQP AutoPLANT Structural = AT_STRUCT AutoPLANT Raceways = AT_ELECT AutoCAD = AT_ACAD > > > > > \documents\ PIPE\... \documents\ EQP\... \documents\ STRUCT\... \documents\ ELECT\... \documents\ ACAD\...

Design packages will be Document Grouped within Visions Display Options. (See the Praxair documentation on Bentley Vision V8i (SELECTseries 1) for instruction on the use of AREA folders in the DOC_REG)

Naming Conventions
To facilitate smoother administration of project documents, it is recommended that all models that get created for each application are clearly and consistently named using an easy to identify description or TAGNUMBER and suffixed with their corresponding REGAPP. Example: AutoPLANT Piping model CB_INT_PIPE.dwg AutoPLANT Equipment model AV-0200_EQP.dwg (vessel models associative primitives and nozzles) AutoPLANT Structural model AV-0200_STRUCT.dwg (vessel models structural components) IMPORTANT NOTE: These are examples of root-level models and when referencing each other, are to use the OVERLAY attachment method only.

Assembly and Sub-Assembly Models


Assemblies should be made using the AutoCAD (AT_ACAD) REGAPP. They are to be populated by root-level application specific REGAPP models and are to use the ATTACHMENT method NOT OVERLAY. Example: AutoCAD Assemblies AV-0200_ASSY.dwg (vessel sub-assembly model made up of root-level models) The table below illustrates the relationship between assembly models and their sub-assembly and/or root-models. Sub-Assembly AV-0200_ASSY.dwg AV-0300_ASSY.dwg AV-0330_ASSY.dwg References (Attached) AV-0200_EQP.dwg AV-0200_STRUCT.dwg AV-0300_EQP.dwg AV-0300_STRUCT.dwg AV-0330_EQP.dwg AV-0330_STRUCT.dwg

Main Assembly CB_INT_EQP_ASSY.dwg

CB_INT_PIPE_ASSY.dwg

References (Attached) AV-0200_ASSY.dwg AV-0300_ASSY.dwg AV-0330_ASSY.dwg CB_INT_EQP_SUPPORTS_STRUCT.dwg CB_INT_PIPE.dwg CB_INT_INST_PIPE.dwg CB_INT_PS_STRUCT.dwg

Overall Assembly CB_OVERALL_ASSY.dwg

References (Attached) CB_INT_EQP_ASSY.dwg CB_EXT_EQP_ASSY.dwg CB_INT_PIPE_ASSY.dwg CB_EXT_PIPE_ASSY.dwg CB_CASING_PLATE_STRUCT.dwg CB_FRAME_STRUCT.dwg

Drawing Production
When the time comes to generate layout drawings, we launch AutoPLANT Piping and go through the procedures outlined in the Praxair documentation listed below. At this point when we attach the reference models, it is only the overall model that gets attached. The rest of the models will be automatically brought along and attached. If the project utilizes Work Areas, it is as simple as inserting a pre-generated view into the layout and the references will automatically be attached. Example: Layout Drawing B-XXXXXXX.dwg References (Attached) CB_OVERALL_ASSY.dwg

BEFORE allowing users to start creating project documents have them read Chapter 4:

Bentley AutoPLANT Plant Design V8i (SELECTseries 1) - Drawing Production New Document Creation

Chapter 4
Bentley AutoPLANT Plant Design V8i (SELECTseries 1) Drawing Production - New Document Creation
Document Creation Methods
In Chapter 3 - File Naming Convention and Reference Model Hierarchy we covered project structure. Now we are ready to start creating project documents. The following section covers document creation and grouping using two methods: Non-ProjectWise Enabled: Bentley Vision V8i is used as a document interface to access and create documents. ProjectWise Enabled: If the project is ProjectWise enabled proceed to the appropriate section in this chapter.

Getting Started
What Is Bentley Vision V8i
Bentley Vision V8i provides an easy-to-use environment to manage critical plant data and documentation. The tree-like user interface allows you to quickly navigate to a specific component to view operating data and associated documentation. Vision and the P&ID Workgroup share a common relational database model for storage of all plant data including process equipment, lines, valves and instrumentation. Changes made to a P&ID are immediately available through the Vision interface. By sharing a common relational database, errors and data maintenance costs associated with duplicate data are virtually eliminated. Launch Bentley Vision V8i using the STARTUP icon created in Chapter 2. Once in the project you will see the interface below. The current project is identified along the top bar and in the bottom-left corner.

The Document Display Tab


The left side of the interface is document display tab section. The Praxair Custom Configuration sets the Display Options to enable the use of Document Grouping on the Area value in the DOC_REG.DBF table.

Creating a New Document Record


The New Document dialog enables you to create a new blank document record within the DOC_REG.DBF table of the current project database (to be used as a place-holder).

To Create a New Document Record


1. Select the Document Tab. 2. Select the appropriate application from the Document Tab navigation tree. Then select Documents > New from the pull down menu or right-click on the application to display context menu to select Documents > New and display the New Document dialog.

3. Enter a name for the document in the File Name field. Entering a description is optional but recommended (the Name and Location fields auto-populate). Then select the appropriate application from the pick-list and press Record Only. This procedure creates a new document record without actually launching the associated application.

4. Notice the new document record is displayed under an Area Not Defined folder in the navigation tree. This is how Bentley Vision V8i displays a blank Area value within the DOC_REG.DBF table for all newly created entries.

5. To associate the document record with the correct Document Grouping, left-click the Area Property in the Properties tab. For Praxair configurations this pull down [GridLists] menu is pre-populated with Praxair defaults. Make your selection from the pick-list. (NOTE: We will cover how to modify these as needed a little later on.)

6. To update the navigation tree Document Grouping, highlight the application and select Display > Refresh Tree or you can press function key F5.

7. Each of the applications in the navigation tree will function the same way when adding or creating new documents or document records. ISOGEN documents, when generated will also register in the DOC_REG and also show up under an Area Not Defined folder.

Creating a New Document from Vision


The New Document dialog also enables you to create a new blank document to add to the current project.

To Create a New Document from Vision


1. Select the Document Tab. 2. Select the appropriate application from the Document Tab navigation tree. Then select Documents > New from the pull down menu or right-click on the application to display context menu to select Documents > New and display the New Document dialog.

3. Like before, enter a name for the document in the File Name field. Then select the appropriate application from the pick-list, but this time press Create. This procedure creates a new document and launches the associated application.

4. After saving and closing AutoCAD notice the new document record is displayed under an Area Not Defined folder in the navigation tree.

5. Like before associate the document record with the correct Document Grouping, by leftclicking the Area Property in the Properties tab. Make your selection then update the navigation tree Document Grouping by highlighting the application and selecting Display > Refresh Tree or by pressing function key F5.

Chapter 5
Bentley AutoPLANT Plant Design V8i (SELECTseries 1) Drawing Production - Work Area Setup
Work Area Creation
The Project Administrator, upon creation of a new AutoPLANT Plant Design V8i (SELECTseries 1) project from Chapter 1, needs to set up the project specific Bentley Vision V8i startup icon for the users.

Getting Started
1. To setup a Work Area in AutoPLANT Plant Design V8i you must have a Piping session open. Using the pull down menu: Piping > Drawing Production > Work Area Setup You will see the Work Area Setup dialog box. Select Open

2. You will then see a list of Praxair pre-populated work areas contained in the current project. Select the one you wish to create and click OK.

3. Next, we want to build a list of Reference Drawings by clicking Add and then OK.

4. At the Project Documents Selection dialog box highlight the location you wish to attach and click the arrow button shown.

5. With the documents now selected click OK.

6. Verify the Membership Status. Normally, if the current drawing is an assembly model you would set the status to Guest. Select Done and if prompted to save changes select Yes.

Chapter 6
Bentley AutoPLANT Plant Design V8i (SELECTseries 1) Drawing Production - Drawing Flattener
Drawing Flattener
This is a Bentley AutoPLANT V8i utility that generates a flat AutoCAD file from a source files layout view. It must contain at least one MVIEW viewport of the 3D model. Much like how ISOGEN generates an isometric drawing, this output file is an unintelligent snapshot of the source file that shows visible and hidden edges on separate layers.

Getting Started
1. Drawing Flattener V8i is launched from the Start menu. Start > All Programs > Bentley > Plant V8i > Tools > Drawing Flattener Or from: C:\Documents and Settings\All Users\Start Menu\Programs\Bentley\Plant V8i\Tools

2. You will see the Bentley AutoPLANT Drawing Flattener V8i (SELECTseries 1) interface below:

3. You can add files to the list from either the File pull down menu or from the toolbar button menu.

4. Browse to the folder where the layout drawings that you wish to flatten reside. Make your selection and click Open.

5. AutoCAD will open and close a few times to build the selection set. When it is ready you will see an open empty AutoCAD session and your selection in the list. You can start flattening from the pull down menu File > Flatten or from the toolbar button menu. If you have a previously flattened file you will be prompted to overwrite it. Click Yes.

6. Depending on the complexity of the source file, the procedure can take anywhere from as short as 2-3 minutes or as long as 10-15 minutes. It all depends on how many viewports the source file contains and how many references models are being processed. It is recommended you not work on other tasks while the procedure runs. You may inadvertently interrupt the flattening process.

7. When the procedure has successfully completed you will see a green check next to the file. You can

Bentley AutoPLANT V8i (SELECTseries 1) Praxair AutoCAD Color Table


IMPORTANT NOTES: Below is a list of the 255 AutoCAD color palette and the commonly used
Praxair layers associated with each color. Note that we have provided unique pipe service colors to help differentiate and clarify model review. Within the AutoPLANT Piping application we now set the piping colors to BYLAYER instead of the old BYSIZE setting.
Colors 1 to 255 Color No. Color 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 Red Yellow Green Cyan Blue Magenta White/Black Grey Grey Red Pink Red Pink Red Pink Red Usage Lineweight mm Inches 0.25 0.010 0.50 0.020 0.35 0.014 0.50 0.020 0.13 0.005 0.18 0.007 0.25 0.010 0.13 0.005 0.18 0.007 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.25 0.010 0.25 0.010 0.25 0.010 0.25 0.010 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020 0.25 0.010 0.25 0.010 0.25 0.010 0.25 0.010 0.50 0.020 0.50 0.020 0.50 0.020 0.50 0.020

CASING QUADRANT_2

HYDROGEN1 HYDROGEN2 HYDROGEN3 HYDROGEN4 HYDROGEN5 HYDROGEN6

OXYGEN1 OXYGEN2 OXYGEN3 OXYGEN4 OXYGEN5 OXYGEN6

Orange Orange Orange

STEEL, CASING QUADRANT_3 KETTLE1 KETTLE2 KETTLE3 KETTLE4

35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82

Orange

Yellow Yellow Yellow Yellow

0.50 0.50 0.25 0.25 0.25 0.25 0.18 0.70 0.13 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.50 0.50 0.50 0.50 0.50 0.25 0.25 0.25 0.25 0.25 0.25 0.35 0.18 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.50 0.50 0.50 0.50 0.50 0.25 0.25 0.25 0.25 0.25 0.25

0.020 0.020 0.010 0.010 0.010 0.010 0.007 0.028 0.005 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.010 0.010 0.014 0.007 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.010 0.010

KETTLE5 KETTLE6

TEXT-THIN FOUNDATION

TEXT-MEDIUM, CASING QUADRANT_1 GAS1 GAS2 GAS3 GAS4 GAS5 GAS6

STEEL_PIPE_SUPPORT STEEL_GRATING

XENON1 XENON2 XENON3 XENON4 XENON5 XENON6

83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130

Green Green Green Green

Cyan

Cyan

0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.35 0.50 0.50 0.50 0.50 0.50 0.50 0.25 0.25 0.25 0.25 0.13 0.70 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.18 0.25 0.35 0.25 0.25 0.25 0.25 0.25 0.25 0.25

0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.014 0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.005 0.028 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.007 0.010 0.014 0.010 0.010 0.010 0.010 0.010 0.010 0.010

EQUIP NITROGEN1 NITROGEN2 NITROGEN3 NITROGEN4 NITROGEN5 NITROGEN6

BLDG REVISION

FOUND_SCUPPERS EL_TRAY ROADWAY EXISTING (FOUNDATION, STEEL) ROADWAY_EXISTING

CASING QUADRANT_4

131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178

Cyan Cyan Cyan

Blue Blue Blue Blue

0.50 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.35 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.50 0.50 0.50 0.50 0.50 0.25 0.25 0.25 0.25 0.50 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.13 0.13 0.25 0.25 0.25 0.25 0.25 0.25

0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.010 0.010 0.014 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.005 0.005 0.010 0.010 0.010 0.010 0.010 0.010

WATER1 WATER2 WATER3 WATER4 WATER5 WATER6

EL_DUCT_BANK EQUIP_BUNDLEPULL BORDER

AIR1 AIR2 AIR3 AIR4 AIR5 AIR6

CO2_1 CO2_2 CO2_3 CO2_4 CO2_5 CO2_6

CENTERLINES, DIMENSIONS CENTERLINES (EL_TRAY, FOUNDATION, STEEL)

179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226

Magenta Magenta Magenta Magenta

0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.50 0.50 0.50 0.50 0.50 0.25 0.25 0.25 0.25 0.25 1.00 0.13 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.50 0.50 0.50 0.50 0.50

0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.020 0.020 0.020 0.020 0.020 0.010 0.010 0.010 0.010 0.010 0.039 0.005 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.020 0.020 0.020 0.020 0.020

ARGON1 ARGON2 ARGON3 ARGON4 ARGON5 ARGON6

MATCHLINES GRIDLINES

TEXT_HEAVY

CHEMICAL1 CHEMICAL2 CHEMICAL3 CHEMICAL4 CHEMICAL5 CHEMICAL6

227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255

Grey Grey Grey Grey White

0.25 0.25 0.25 0.25 0.35 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.18 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.25 0.50 0.50 0.18 0.25

0.010 0.010 0.010 0.010 0.014 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.007 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.010 0.020 0.020 0.007 0.010

TEXT_BUBBLE

FOUND_ANCHOR_BOLTS STEEL_HANDRAIL, STEEL_LADDER

CONDENSATE STEAM EL_INSTRUMENT

Removing AutoPlant XM
After removing all AutoPlant XM applications (including ProjectWise) it is necessary to remove all the Bentley folders and registry entries from the users machine before installing AutoPlant V8i. Make sure the user has admin privileges on the machine. Also, make sure the user has checked the option Show Hidden Files and Folders in the View tab in Folder Options in Windows Explorer. Note: It is not necessary to remove AutoCAD before installing V8i.

Remove Bentley Program folders


Remove all of the following folders 1. 2. 3. 4. 5. C:\Documents and Settings\All Users\Application Data\Bentley C:\Documents and Settings\(User Name)\Application Data\Bentley C:\Documents and Settings\(User Name)\Local Settings\Application Data\Bentley C:\Program Files\Bentley C:\Program Files\Common Files\Bentley Shared

Remove Bentley Registry Entries


Remove the following registry entries 1. HKEY_CURRENT_USER\Software\Bentley\ 2. HKEY_LOCAL_MACHINE\Software\Bentley\