Anda di halaman 1dari 8

MCSModul Mikrokontroler MCS-51

2
Pendahuluan

TUTORIAL MIDE-51

Mikrokontroler MCS51 banyak digunakan dalam pembuatan alat-alat pengendali, salah satunya adalah AT89S51 produksi Atmel Corp. Untuk mempergunakan mikrokontroler tersebut sebagai system pengendali, maka diperlukan software yang digunakan untuk memprogram mikrokontroler tersebut. Dalam Modul ini, anda memerlukan software MIDE-51 dan ISP-pgm. Program ini dapat anda download di www.digilabteum.wordpress.com. Banyak sekali program yang dapat digunakan untuk pemrograman mikrokontroler MCS51 ini, salah satunya adalah MIDE-51. Software MIDE-51 ini telah dilengkapi dengan fasilitas antara lain: 1. Compiler, yaitu: untuk bahasa pemrograman assembler dan C. o Compiler yang digunakan untuk assembler adalah asem51 o sedangkan untuk bahasa C menggunakan SDCC buatan sandeep duta. 2. Selain itu juga terdapat simulator yang berfungsi untuk melihat hasil pembutan program yaitu TS Control Simulator 51 dan JSIM with 8051. 3. Pada MIDE-51 juga telah dilengkapi dengan fasilitas untuk link ke program-program downloader MCS51. Dengan fasilitas yang terdapat dalam MIDE-51 ini, sudah cukup untuk melakukan experimen dengan pemrograman mikrokontroler MCS51. Software MIDE-51 dapat di download diinternet melalui alamat www.opcube.com, kapasitas software ini hanya sekitar 5 Mb.

Persiapan
Untuk memulai bekerja dengan MIDE-51, langkah awal yang dilakukan adalah install software yang telah di download, double click software midepack02511.exe. Ikuti semua langkah yang ada pada saat instalasi software ini. Sehingga setelah terinstal, anda akan dapat melihat program yang terdapat pada MIDE-51 package sebagaimana Gambar 1.

Gambar 1. Fasiltas Pada MIDE-51 package

Siti Sendari, S.T., M.T. 2008

2. Page 1

MCSModul Mikrokontroler MCS-51 Setelah semua selesai buka software MIDE-51. Start>MIDE-51 package>MIDE-51, dan tampilan software tersebut seperti Gambar 2.

Gambar 2 Tampilan awal MIDE-51

Men-Set MIDE-51
Untuk memulai program MIDE-51, persiapkan/setting program sebagai berikut: Click preference (sebagaimana Gambar 3) untuk mengatur Assembler compiler, C-compiler, Configuration (setting jenis font serta size yang akan digunakan), Programmer serta Simulator yang akan digunakan.

Gambar 3. Tombol Preference MIDE-51

Siti Sendari, S.T., M.T. 2008

2. Page 2

MCSModul Mikrokontroler MCS-51 Pada pengaturan preference ini hanya Programmer saja yang perlu diatur karena untuk yang lain dengan default sudah dapat digunakan untuk bekerja. Programmer ini diatur untuk menentukan jenis programmer yang akan digunakan, misalnya dengan menggunakan Isppgm yang umum digunakan. Caranya adalah dengan mengarahkan Execute File (Full path and filename) pada file Isppgm.exe yang tersimpan di folder lain, misal di folder c:\MIDE sebagaimana Gambar 4.

Gambar 4 Kotak Pengaturan Preference

Bekerja dengan MIDE-51


A. Membuat Project Baru
Buka project baru dengan cara click File>New, maka akan muncul tampilan sebagaimana Gambar 5.

Lembar Kerja

Lokasi File

Message Report

Gambar 5 Lembar Kerja MIDE-51

Siti Sendari, S.T., M.T. 2008

2. Page 3

MCSModul Mikrokontroler MCS-51

B. Menyimpan Project
Untuk menyimpan program assembler maka click File>Save as dan buat file dengan extension asm (*.asm), misalnya coba.asm. Sedangkan untuk membuat program dengan bahasa C maka ketik nama file dengan extension c (*.c), misalnya coba.c. Software ini akan otomatis menjalankan compiler masing-masing bahasa pemrograman tanpa harus disetting. Pastikan bahwa Save as type pada posisi All MCS-51 known files. Lihat Gambar 6.

Gambar 6. Kotak Save As

C. Memilih Device
Untuk bekerja dengan mikrokontroler MCS-51, maka pilih tipe mikrokontroler yang anda gunakan, misal: AT89S52. Langkah yang dilakukan adalah Pilih device yang akan digunakan click Device>Select, misalnya ingin bekerja dengan mikrokontroler AT89S52 maka pilih 89S52, selanjutnya click OK. Lihat Gambar 7.

Gambar 7. Kotak Pemilihan Mikrokontroler Siti Sendari, S.T., M.T. 2008 2. Page 4

MCSModul Mikrokontroler MCS-51

D. Membuat Program Assembler


Buat program assembler pada lembar kerja yang telah ada, ketik contoh program di bawah ini. Lihat Gambar 8. Start : Mov A,#01h ulang: Mov P1,a Rl A Acall Delay Sjmp Ulang ;----------------------; sub routine delay ;----------------------Delay: DJNZ R3,delay ; R3=R3 -1 bila = 0 kembali label delay Djnz R1,Delay ; R1=R1 - 1 bila = 0 kembali label delay Ret ; Kembali ke instruksi setelah Acall ; End

Gambar 8 Program assembler

E. Meng-COMPILE Program
Untuk meng-compile program yang telah kita buat, click Build>Build / atau tekan F9. Lihatlah hasil yang terdapat pada massage report. Apabila tidak terjadi kesalahan maka akan muncul massage seperti Gambar 9.

Siti Sendari, S.T., M.T. 2008

2. Page 5

MCSModul Mikrokontroler MCS-51

Gambar 9 message Report Compiler ASM

Sedangkan apabila ingin meng-compile program sekaligus simulasi maka click Build>Build and Sim / atau tekan Shift+Ctrl+F9 dan hasilnya seperti gambar 10.

Gambar 10 Tampilan Simulator TS Control 8051 Emulator

Pada kotak Disassembled Code terdapat program yang telah kita buat sedangkan untuk menjalankan simulasi tekan F11 atau click . Perhatikan hasil program ini dengan melihat P1 pada kotak SFR Regiters, hasilnya adalah 01,02,04,08,10,20,40,80 dan akan kembali mengulang ke 01 dan seterusnya. Apabila ingin setelah dicompile hasilnya langsung didownload target ic AT89S52 maka tekan CTRL+F9 atau click Build>Build and Burn / . Setelah program dicompile otomatis akan membuka software Isppgm, sebagaimana Gambar 11.

Siti Sendari, S.T., M.T. 2008

2. Page 6

MCSModul Mikrokontroler MCS-51

Gambar 11 Software Isppgm

Sebelum melakukan download click Open File untuk membuka file hex hasil dari compiler program assembler, setelah file selesai di buka maka click write untuk melakukan download ke ic target dengan catatan donggle ISP dan minimum system telah terhubung dengan komputer.

F. Membuat Program SDCC


Sedangkan untuk membuat program dengan bahasa C caranya hampir sama tetapi yang digunakan untuk pemrograman mikrokontroler adalah c. Langkah awalnya adalah click File>New kemudian click File>Save as dan buat file dengan extension c (*.c). Pastikan bahwa Save as type pada posisi C source file (*.c).

Gambar 12 Proses menyimpan file SDCC Siti Sendari, S.T., M.T. 2008 2. Page 7

MCSModul Mikrokontroler MCS-51 Buat program c pada lembar kerja yang telah ada, ketik contoh program di bawah ini. Tampilan Program SDCC yang telah dibuat ditunjukkan dalam Gambar 13.

#include <reg51.h> unsigned char j,i; void delay(void) { int x;x=1000; while (x-- > 0); } void main(void) { i=0x01; for (j=0;j<=8;j++) { P1=i; i=i<<1;delay(); }; }

Gambar 13 Tampilan Program SDCC Proses selanjutnya meng-compile hasil program yang telah dimasukkan, cara dan langkahnya sama sepeti pada proses untuk pemrograman dengan bahasa assembly. --------------Selamat Mencoba---------------

Siti Sendari, S.T., M.T. 2008

2. Page 8