Anda di halaman 1dari 18

Pseudocdigo

Com base nos conceitos vistos podemos aprofundar nosso estudo sobre os mtodos de representao de algoritmos, iniciaremos pelo pseudocdigo. Pseudocdigo uma tcnica textual de representao de um algoritmo. Tambm conhecida como Portugus Estruturado ou Portugol. Nele os verbos (aes) disponveis para utilizao so limitados e empregados no imperativo, deve-se evitar as expresses excessivamente longas, estas restries visam eliminar a possibilidade de ambigidade. A tcnica baseada em uma PDL (Program Design Language), que uma linguagem genrica na qual possvel representar um algoritmo de forma 53semelhante das linguagens de programao.

Pseudocdigo Estrutura
A estrutura de um algoritmo em pseudocdigo pode variar um pouco de acordo com o autor ou com base na linguagem de programao que ser utilizada posteriormente, mas essas variaes ocorrem apenas na sintaxe, pois a semntica deve ser exatamente a mesma. A estrutura que empregaremos para a construo de nossos pseudocdigos ser a seguinte: algoritmo nome //Tem como objetivo identificar o //algoritmo, deve-se utilizar um nome o mais significativo //possvel, para facilitar a identificao var // Seo de Declaraes - Neste ponto so informadas //quais variveis, e seus respectivos tipos, sero // utilizadas no algoritmo inicio // Seo de Comandos - Aqui ser escrita a seqncia de // comandos que deve ser executada para solucionar // o problema em questo 54 fimalgoritmo //marca o final do algoritmo

Pseudocdigo

As palavras reservadas presentes na estrutura do pseudocdigo apresentado foram: algoritmo var inicio fimalgoritmo

55

Pseudocdigo Exemplo
Observaremos agora um pseudocdigo que recebe um valor inteiro, fornecido pelo usurio, e o retorna no monitor. algoritmo exemplo 1 var x: inteiro inicio leia (x) escreva (x) fimalgoritmo

56

Pseudocdigo Exemplo
Outro exemplo o pseudocdigo de um algoritmo que recebe um valor inteiro, acresce duas unidades a este, e exibe o resultado desta manipulao. algoritmo exemplo 2 var numero, resposta: inteiro inicio escreva (Digite um nmero inteiro: ) leia (numero) resposta <- numero+2 escreval (Resultado (nmero + 2): , resposta) fimalgoritmo
57

Pseudocdigo Exemplo
Outro exemplo o pseudocdigo de um algoritmo que recebe um valor inteiro, acresce duas unidades a este, e exibe o resultado desta manipulao. algoritmo exemplo 2 var n: inteiro inicio escreva (Digite um nmero inteiro: ) leia (n) n <- n+2 escreval (Resultado (nmero + 2): , n) fimalgoritmo
58

Pseudocdigo Exemplo
Outro exemplo o pseudocdigo de um algoritmo que recebe um valor inteiro, acresce duas unidades a este, e exibe o resultado desta manipulao. algoritmo exemplo 2 var n: inteiro inicio escreva (Digite um nmero inteiro: ) leia (n) escreval (Resultado (nmero + 2): , n+2) fimalgoritmo
59

Pseudocdigo Exerccio 1
Construa um pseudocdigo para representar um algoritmo que efetue a multiplicao de dois inteiros quaisquer. algoritmo exerccio 1 var n1, n2, res: inteiro inicio escreva (Digite o multiplicando inteiro: ) leia (n1) escreva (Digite o multiplicador inteiro: ) leia (n2) res <- n1 * n2 escreva (Resultado da multiplicao: , res) fimalgoritmo
60

Pseudocdigo Exerccio 1
Construa um pseudocdigo para representar um algoritmo que efetue a multiplicao de dois inteiros quaisquer. algoritmo exerccio 1b var n1, n2: inteiro inicio escreva (Digite o multiplicando inteiro: ) leia (n1) escreva (Digite o multiplicador inteiro: ) leia (n2) escreva (Resultado da multiplicao: , n1*n2) fimalgoritmo
61

Pseudocdigo Exerccio 1
Construa um pseudocdigo para representar um algoritmo que efetue a multiplicao de dois inteiros quaisquer. algoritmo exerccio 1c var n1, n2: inteiro inicio escreva ("Digite o multiplicando e em seguida ") escreva (" o multiplicador (ambos inteiros): ") leia (n1, n2) escreva ("Resultado da multiplicao: ", n1*n2) fimalgoritmo
62

Pseudocdigo Exerccio 1
Construa um pseudocdigo para representar um algoritmo que efetue a multiplicao de dois inteiros quaisquer. algoritmo "exerccio 1c" var n1, n2: inteiro inicio escreva ("Digite o multiplicando e em seguida ") escreva (" o multiplicador (ambos inteiros): ") leia (n1, n2) escreva (n1, "*", n1, "=",n1*n2) fimalgoritmo
63

Exerccios que sero trabalhados na prxima aula

Pseudocdigo Exerccio 2
Gere um pseudocdigo que aplique um desconto de 30% sobre o valor de um produto, recebido como entrada, e retorne o resultado da manipulao na sada padro.

65

Pseudocdigo Exerccio 3

Faa um pseudocdigo de um algoritmo que receba 4 notas, calcule e mostre a mdia aritmtica entre elas.

68

Pseudocdigo Exerccio 4

Elabore um algoritmo que calcule a rea de um crculo. rea = * r

72

Pseudocdigo Exerccio 5

Construa o pseudocdigo de um algoritmo capaz de ler dois valores inteiros armazenando-os em variveis distintas, aps o armazenamento o contedo das variveis deve ser trocado e, ao termino do processo, o algoritmo deve retornar o novo contedo de cada uma das variveis .

76

Pseudocdigo Exerccio 6

Elabore um algoritmo que receba como entrada o valor do saque realizado pelo cliente de um banco e retorne quantas notas de cada valor sero necessrias para atender ao saque com a menor quantidade de notas possvel. Sero utilizadas notas de 100, 50, 20, 10, 5, 2 e 1 reais.

78

Pseudocdigo Exerccio 7

Construa um algoritmo para ler um nmero inteiro, positivo de trs dgitos, e gerar outro nmero formado pelos dgitos invertidos do nmero lido. Ex: NumeroLido = 123 NumeroGerado = 321

Dica: Observe os resultados das funes Quociente e Resto de um nmero por 10.
82