Anda di halaman 1dari 3

EJERCICIO 12 DE EXCEL

EXCEL EJERCICIO 12

FUNCIONES SI ANIDADAS

Cuando el contenido de una celda depende tres o ms alternativas ya no basta combinar la funcin SI y las funciones Y u O. Es preciso incluir funciones SI dentro de otra funcin Si. Las funciones incluidas dentro de otras funciones se llaman funciones anidadas Por ejemplo, si tenemos 3 proveedores, codificados como 1, 2 y 3 y queremos que aparezca el nombre al introducir el cdigo, la funcin ser algo as =SI(A1=1; Proveedor A;SI(A1=2;Proveedor B;Proveedor C)). El tercer argumento o Valor si falso es, a su vez, una funcin SI. Otro ejemplo posible es una quiniela (el signo que aparezca depender de tres alternativas: victoria en casa, a domicilio o empate). Nota: la quiniela no es (ni mucho menos) de esta temporada.

ACTIVIDAD A REALIZAR
Crea un nuevo libro de Excel y gurdalo con el nombre 12ex SI anidada. En la Hoja1, que llamars Quiniela, confecciona la siguiente tabla.

1. 2. 3. 4. 5. 6. 7. 8. 9. 10. 11. 12. 13. 14. 15.

VALENCIA BETIS DEPORTIVO BARCELONA R. SOCIEDAD GETAFE MLAGA R. MADRID OSASUNA CASTELLN NUMANCIA XEREZ HRCULES VALLADOLID ZARAGOZA

Resultado MALLORCA ALAVS ESPANYOL CELTA CDIZ SEVILLA VILLARREAL RACING AT. MADRID RECREATIVO GIMNSTIC ALBACETE MURCIA LEVANTE
ATHLETIC CLUB

Signo

EJERCICIO 12 DE EXCEL Incluye en las celdas de la columna Signo una funcin que muestre el signo correspondiente (1, X , 2) en funcin del resultado. Luego, escribe resultados al azar para comprobar el funcionamiento correcto de la funcin. Recuerda eliminar las hojas sobrantes, etc.

ACTIVIDAD A REALIZAR
Un ejemplo algo rebuscado de funcin SI anidada es el siguiente: En el hospital Son Dureta, seis doctores/as comparten una consulta. Cada da, de lunes a sbado, atiende un doctor distinto, mientras que el domingo permanece cerrada: Lunes: Dra. Chaves Martes: Dr. Gomila Mircoles: Dra. Ansn Jueves: Dr. Antnez Viernes: Dr. Binimelis Sbado: Dra. Gonzlez Domingo: cerrada

Se trata de crear una hoja de clculo que pueda proporcionar, al que la consulte, slo con introducir el da de la semana, la informacin de qu doctor/a atiende el da en cuestin. Intntalo. Hazlo en la Hoja 2 del libro 12ex SI anidada.xls Por otro lado, tambin es posible hacerlo ms automtico y fcil para el usuario (y ms difcil para nosotros) ayudndonos de la funcin HOY combinada con la funcin DIASEM (da de la semana) y otra funcin SI del mismo estilo que la anterior para obtener el da de la semana en letras. Funcin HOY: =HOY() No tiene argumentos. Devuelve la fecha del da en que se abre el documento.

Funcin DIASEM: =DIASEM(celda con la fecha;2) El segundo argumento (2) es para indicar al programa que el sistema de semana que nos interesa es el latino (Lunes: da 1; Domingo: da 7). El formato de la hoja (puede ser la misma Hoja 2, modificada) ser algo parecido a esto (pg sig):

EJERCICIO 12 DE EXCEL

Hospital Son Dureta


Consulta: Oftalmologa Fecha de hoy
Esta fila se ocultar

Funcin HOY Funcin DIASEM Funcin SI anidada Funcin SI anidada

N de da de la semana Da de la semana Consulta