Anda di halaman 1dari 6

R2#sh run

Building configuration...
Current configuration : 1445 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.20.20.1 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside

ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.3.21 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 209.165.100.226 255.255.255.252
ip nat outside
ip virtual-reassembly
!
router ospf 1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 10.20.20.0 0.0.0.255 area 0
network 192.168.3.20 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
default-information originate
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
no ip http server
no ip http secure-server
!
!
ip nat inside source static 192.168.10.5 209.165.100.241
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
R2#
R2(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/1
R2(config)#interface serial 0/0/1
R2(config-if)#ip add
R2(config-if)#ip address 209.165.100.226 255.255.255.252
R2(config-if)#no shut
R2(config-if)#no shutdown
R2(config)#ip nat inside source static 192.168.10.5 209.165.100.241

R2(config)#interface
R2(config-if)#ip nat
R2(config-if)#ip nat
R2(config-if)#ip nat
R2(config-if)#
R2(config-if)#exit
R2(config)#interf
R2(config)#interface
R2(config)#interface
R2(config-if)#ip nat
R2(config-if)#ip nat
R2(config-if)#ip nat

fastEthernet 0/1
ins
inside

ser
serial 0/0/1
out
outside

R2#show ip nat translations


Pro Inside global
Inside local
icmp 209.165.100.241:512 192.168.10.5:512
icmp 209.165.100.241:512 192.168.10.5:512
icmp 209.165.100.241:512 192.168.10.5:512

Outside local
Outside global
172.20.20.1:512
172.20.20.1:512
172.20.20.5:512
172.20.20.5:512
209.165.200.225:512 209.165.200.225:5

R2(config)#access-list 1 permit 172.16.31.0 0.0.0.255


R2(config)#ip nat po
R2(config)#router ospf 1
R2(config-router)#default-information originate

R2(config)#ip nat pool RED_1 209.65.100.242 209.65.100.243 netmask 255.255.255.


240
R2(config)#ip nat inside source list 1 pool RED_1
R2(config)#interface
R2(config-if)#ip nat
R2(config-if)#ip nat
R2(config-if)#exit
R2(config)#interf
R2(config)#interface
R2(config)#interface
R2(config-if)#ip nat
R2(config-if)#ip nat
R2(config-if)#exit

serial 0/0/0
ins
inside
ser
serial 0/0/1
out
outside

R2#show ip nat translations


Pro Inside global
Inside local
icmp 209.65.100.242:512 172.16.31.10:512
icmp 209.65.100.242:512 172.16.31.10:512
--- 209.65.100.242
172.16.31.10
--- 209.165.100.241
192.168.10.5

Outside local
172.20.20.1:512
172.20.20.5:512
---

Outside global
172.20.20.1:512
172.20.20.5:512
---

no ip nat pool RED_1 209.65.100.242 209.65.100.243 netmask 255.255.255.240


no ip nat inside source list 1 pool RED_1
no ip nat inside source static 192.168.10.5 209.165.100.241

Building configuration...
Current configuration : 1725 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$SOJp$UySoVbahaHTH5n1Wfez5i.
!
no aaa new-model
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
hidekeys
!
!

!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.20.20.1 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.3.21 255.255.255.252
ip nat inside
ip virtual-reassembly
clock rate 64000
!
interface Serial0/0/1
ip address 209.165.100.226 255.255.255.252
ip nat outside
ip virtual-reassembly
!
router ospf 1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 10.20.20.0 0.0.0.255 area 0
network 192.168.3.20 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
default-information originate
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
no ip http server
no ip http secure-server
!
!
ip nat pool RED_1 209.165.100.242 209.165.100.243 netmask 255.255.255.240
ip nat inside source list 1 pool RED_1
ip nat inside source static 192.168.10.5 209.165.100.241
!
access-list 1 permit 172.16.31.0 0.0.0.255
!
!
!
!

!
!
control-plane
!
!
!
line con 0
password cisco
login
line aux 0
line vty 0 5
password cisco
login
!
scheduler allocate 20000 1000
end

R2#show ip nat translations


Pro Inside global
Inside local
Outside local
Outside global
icmp 209.165.100.242:512 172.16.31.10:512 172.20.20.5:512
172.20.20.5:512
icmp 209.165.100.242:512 172.16.31.10:512 209.165.100.225:512 209.165.100.225:51
2
--- 209.165.100.242
172.16.31.10
----tcp 209.165.100.241:1087 192.168.10.5:1087 91.228.167.26:80 91.228.167.26:80
tcp 209.165.100.241:1088 192.168.10.5:1088 93.184.71.27:80 93.184.71.27:80
tcp 209.165.100.241:1089 192.168.10.5:1089 91.228.166.15:80 91.228.166.15:80
tcp 209.165.100.241:1090 192.168.10.5:1090 91.228.166.13:80 91.228.166.13:80
--- 209.165.100.241
192.168.10.5
R2(config)#access-list 2 permit 10.10.10.0 0.0.0.255
R2(config)#access-list 2 permit 10.20.20.0 0.0.0.255
R2(config)#

Anda mungkin juga menyukai