Anda di halaman 1dari 12

KONFIGURASI CISCO ROUTER

Router bertugas untuk menyampaikan paket data dari satu jaringan ke jaringan
lainnya, jaringan pengirim hanya tahu bahwa tujuan jauh dari router. Dan routerlah yang
mengatur mekanisme pengiriman selain itu router juga memilih “jalan terbaik” untuk
mencapai tujuan. Ada dua jenis router berdasarkan cara ruting-nya, yaitu Router Statis
dan Router Dinamis.

1. Router Statis
Router Statis adalah Router yang me-rutekan jalur spesifik yang ditentukan oleh
user untuk meneruskan paket dari sumber ke tujuan. Rute ini ditentukan oleh
administrator untuk mengontrol perilaku routing dari IP "internetwork".
Rute Statis - Rute yang dipelajari oleh router ketika seorang administrator
membentuk rute secara manual. Administrator harus memperbarui atau meng"update"
rute statik ini secara manual ketika terjadi perubahan topologi antar jaringan
(internetwork). Mengkonfigurasi router statis adalah dengan memasukkan tabel routing
secara manual. Tidak terjadi perubahan dinamik dalam tabel ini selama jalur/rute aktif.

2. Router Dinamis
Router Dinamis adalah Router yang me-rutekan jalur yang dibentuk secara
otomatis oleh router itu sendiri sesuai dengan konfigurasi yang dibuat. Jika ada
perubahan topologi antar jaringan, router otomatis akan membuat ruting yang baru.

Tabel Routing
Supaya router bisa melayani permintaan untuk meneruskan pengiriman data,
maka router harus mempunyai tabel yang dipakai sebagai patokan data ini harus dikirim
ke jaringan yang mana? Tabel yang dipunyai oleh router disebut sebagai tabel routing
yang berisi NETID dan Default gatewaynya.
Router
192.168.1.13 192.168.2.43

192.168.1/24 192.168.2/24

192.168.1.5 192.168.2.36

Gambar 1. Contoh desain jaringan dengan dua subnet

Konfigurasi Cisco Router 1


Berdasarkan gambar 1, berikut ini adalah skenario pengiriman data dari komputer
192.168.1.5 ke komputer 192.168.2.36 :
1. Komputer 192.168.1.5 ingin mengirim data ke 192.168.2.36, menyadari bahwa
alamat tujuan tidak berada di jaringan lokal, maka komputer mencari daftar
“default gateway” pada property TCP/IP yaitu 192.168.1.13. Paket data kemudian
dikirim ke Gateway tersebut.
2. Pada komputer 192.168.1.13 paket data tersebut kembali diperiksa, dan
ditemukan pada tabel routing bahwa paket tersebut dapat dikirim ke jaringan
192.168.2 lewat IP 192.168.2.43
3. Via IP 192.168.2.43 akhirnya data dapat ditransmisi ke tujuan yaitu 192.168.2.36

Mengkonfigurasi static routing


Membangun static routing pada router-router tidak begitu sulit. Anda tinggal
masuk ke global configuration mode dan jalankan formula berikut pada masing-
masing router yang akan dikonfigurasikan :

Ip route <destination><mask><next_hop_address>

Berikut ini adalah detail untuk masing-masing opsi :


Ip route : perintah untuk membuat static routing itu sendiri
Destination : network tujuan yang hendak ditambahkan ke routing table
Mask : subnet mask yang digunakan dalam network
Next_hop_address : address dari hop router selanjutnya, yakni yang akan
menerima paket dan mem-forward-nya lagi ke network
remote. Tidak lain berupa interface router dari router dari
network yang terkoneksi secara langsung.

Contoh :
Router(config)#ip route 10.252.0.0 255.255.255.0 172.16.0.2

Artinya :
Ip network tujuan : 10.252.0.0
Mask : 255.255.255.0
IP Next hop : 172.16.0.2

1.1. Mengkonfigurasi static routing pada Packet Tracer

Simulasikan desain jaringan di bawah ini, gunakan Static Routing

Konfigurasi Cisco Router 2


Gambar 2. Contoh Konfigurasi Jaringan dengan Router Statis

1. Konfigurasi masing-masing PC :
PC 1 : 192.168.2.2
PC 2 : 192.168.2.3
PC 3 : 192.168.1.2
PC 4 : 192.168.1.4
PC 5 : 10.0.0.3
PC 6 : 10.0.0.5
PC 7 : 10.0.1.2
PC 8 : 10.0.1.6

Klik pada PC yang akan diset. Pilih menu Desktop. Pada IP Configuration, ketik
IP Address, subnet mask dan default gateway (nomor IP dari Router yang
terhubung langsung ke PC tersebut).

Gambar 3. Konfigurasi PC

Konfigurasi Cisco Router 3


2. Konfigurasi masing-masing Router
Klik router yang akan dikonfigurasi. Pilih menu Config. Pilih Interface Æ Serial
1/0. Isi IP Address dan Subnet Mask-nya. Jangan lupa ON kan Port Status. Lakukan
hal yang sama untuk interface yang lain (serial maupun fastethernet).
Khusus untuk koneksi serial, jika router yang dikonfigurasi merupakan sisi DCE,
isilah clock rate yang besarnya tergantung dari setting yang diinginkan.

Router 2
Serial 1/0 : 172.16.1.1 Æ DCE
Fe 0/0 : 192.168.2.1

Router 0
Serial 1/0 : 172.16.1.2 Æ DTE
Serial 2/0 : 172.16.0.1 Æ DCE
Fe 0/0 : 192.168.1.1

Router 1 :
Serial 1/0 : 172.16.0.2 Æ DTE
Fe 0/0 : 10.0.0.1
Fe 0/1 : 10.0.1.1

Gambar 4. Konfigurasi Router

3. Jika seluruh device sudah selesai dikonfigurasi, lakukan pengecekan koneksi antar
masing-masing device tersebut dengan perintah ping.

Konfigurasi Cisco Router 4


Gambar 5. Perintah ping dari PC 1 (192.168.2.2) ke PC 2 (192.168.2.3)

4. Konfigurasi pada gambar 2 belumlah lengkap, karena belum tersedianya Tabel


Routing pada masing-masing Router. Jika dilaksanakan perintah ping dari satu
device dalam sebuah segmen jaringan ke device lain pada segmen jaringan yang
lain, maka koneksi tidak akan terhubung. Tabel Routing dibuat di masing-masing
Router menuju ke jaringan-jaringan yang tidak terhubung langsung dengan router
tersbut. Pembahasan detail tentang Tabel Routing akan dijelaskan pada sub bab
yang lain.

1.2. Mengkonfigurasi static routing pada Router Fisik

Disain jaringan sama seperti gambar 2.


Siapkan peralatan sebagai berikut : 3 buah router (2811), 4 buah switch (2960) dan 8
buah PC. Langkah-langkahnya sebagai berikut :
1. Pasang interface serial pada slot yang kosong pada router. Cara instalasinya sama
seperti yang dijelaskan di Packet Tracer.

Konfigurasi Cisco Router 5


Gambar 6. Cara pemasangan interface pada slot Router

2. Siapkan kabel Rollover. Hubungkan sisi konektor RJ-45 ke Console di Router


dan sisi konektor DB 9 ke bagian port serial COM 1.

Gambar 7. Koneksi terminal Console

3. ON kan device tersebut. Pada PC, masuk ke Hyperterminal. Set parameter bit
per second, data bit, parity, stop bit dan flow control dengan nilai 9600,8,N,1,N
seperti gambar 8.

Gambar 8. Setting Terminal Console menggunakan Hyperterminal

Konfigurasi Cisco Router 6


4. Tunggu sampai ada response dari router yang bersangkutan. Isi user id dan
password yang diminta. Selanjutnya di display kan sebagai berikut :

Router > enable Æ ketik (untuk meng-enable router ybs).


Anggap Router ini sebagai Router 2. Kita akan mengeset Router tersebut sesuai
dengan konfigurasi Router 2 yang ada pada gambar 1

Router 2 :
Router > enable Æ meng-enable router yang bersangkutan
Router#conf t
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 172.16.1.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 9600
Router(config-if)#exit
Router(config)#interface fasethernet 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router 0 :
Router > enable
Router#conf t
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 172.16.1.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/1/1
Router(config-if)#ip address 172.16.0.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 9600
Router(config-if)#exit
Router(config)#interface fasethernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router 1 :
Router > enable
Router#conf t
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 172.16.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fasethernet 0/0
Router(config-if)#ip address 10.0.0.1 255.255.255.0

Konfigurasi Cisco Router 7


Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fasethernet 0/1
Router(config-if)#ip address 10.0.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Untuk mengecek seluruh konfigurasi pada masing-masing router, ketik perintah :


Router#show running-startup

5. Hubungkan masing-masing router dengan switch pasangannya menggunakan


straight through cable dan masing-masing switch ke PC-PC yang terhubung
dengannya juga dengan straight through cable. Set IP address PC sesuai dengan
konfigurasi pada gambar 2. Klik Control Panel, pilih Network Connection, Klik 2
kali pada gambar LAN. Pada LAN Status klik tombol Properties. Ketik nomor IP,
subnetmask dan default gateway seperti yang didisain pada gambar 2.

Isi di sini

Gambar 9. Konfigurasi IP Address pada PC

Menciptakan Tabel Routing Static


Setelah seluruh device dikonfigurasi, perlu ditambahkan Tabel Routing di
masing-masing Router. Tabel Routing ini menunjuk ke jaringan (network) yang tidak
terhubung langsung dengan router tersebut.. Seperti yang telah disebutkan sebelumnya,
Tabel Routing Static dibuat oleh Administrator secara manual. Tabel ini perlu di-update
jika ada perubahan konfigurasi jaringan. Bentuk Tabel Routing Static ditunjukkan pada
gambar 10.

Konfigurasi Cisco Router 8


RO UTER 1
Network Subnet M ask Next Hop
192.168.1.0 255.255.255.0 172.16.0.1
172.16.1.0 255.255.255.252 172.16.0.1
192.168.2.0 255.255.255.0 172.16.0.1
192.168.3.0 255.255.255.0 172.16.0.1

RO UTER 0
Network Subnet M ask Next Hop
10.0.0.0 255.255.255.0 172.16.0.2
192.168.2.0 255.255.255.0 172.16.1.1
192.168.3.0 255.255.255.0 172.16.1.1

RO UTER 2
Network Subnet M ask Next Hop
10.0.0.0 255.255.255.0 172.16.1.2
192.168.1.0 255.255.255.0 172.16.1.2
172.16.0.0 255.255.255.252 172.16.1.2

Gambar 10. Tabel Routing untuk konfigurai jaringan Gambar 1

- Pada masing-masing router tambahkan perintah :


ip route <network IP> <netmask> <next hop>

Router 0 :
Router(config)#ip route 10.0.0.0 255.255.255.0 172.16.0.2
Router(config)#ip route 192.168.2.0 255.255.255.0 172.16.1.1
Router(config)#ip route 192.168.3.0 255.255.255.0 172.16.1.1

Router 1 :
Router(config)#ip route 192.168.1.0 255.255.255.0 172.16.0.1
Router(config)#ip route 172.16.1.0 255.255.255.252 172.16.0.1
Router(config)#ip route 192.168.2.0 255.255.255.0 172.16.0.1
Router(config)#ip route 192.168.3.0 255.255.255.0 172.16.0.1

Router 2 :
Router(config)#ip route 10.0.0.0 255.255.255.0 172.16.1.2
Router(config)#ip route 192.168.1.0 255.255.255.0 172.16.1.2
Router(config)#ip route 172.16.0.0 255.255.255.0 172.16.1.2

Untuk melihat seluruh konfigurasi ip route di masing-masing router, ketik perintah


show ip route Æ pada priviledged mode

Konfigurasi Cisco Router 9


Menciptakan Tabel Routing Dinamis
a) Routing RIP (Routing Information Protocol)
Langkah-langkah :
1. Menciptakan rute dengan model RIP
router rip Æ pada priviledged mode
network <IP network> Æ pada Global Configuration mode
write mem Æ -“-
2. melihat semua rute ke masing-masing router yang lain
show ip route Æ pada priviledged mode
3. hanya melihat rute RIP saja
show ip route rip Æ pada priviledged mode

Contoh : dari konfigurasi gambar 1


- Menciptakan rute dengan model rip di masing-masing router

Router 0 :
Router#router rip
Router(config-router)#network 172.16.1.0 Network yang langsung
Router(config-router)#network 172.16.0.0 terhubung dengan router 0
Router(config-router)#network 192.168.1.0

Router 1 :
Router#router rip
Router(config-router)#network 172.16.0.0 Network yang langsung
Router(config-router)#network 10.0.0.0 terhubung dengan router 1
Router(config-router)#network 10.0.1.0

Router 2 :
Router#router rip Network yang langsung
Router(config-router)#network 172.16.1.0 terhubung dengan router 2
Router(config-router)#network 192.168.2.0

- Melihat seluruh konfigurasi rute pada router (menuju jaringan yang tidak
terhubung langsung dengan router)

Router#show ip route

Akan ditampilkan :
(Untuk Router 0)
R 192.168.2.0/24 via 172.16.1.1 serial 0/0
R 10.0.0.0/24 via 172.16.0.2 serial 0/1
R 10.0.1.0/24 via 172.16.0.2 serial 0/1
C 172.16.1.0 directly connected serial 0/0
C 172.16.0.0 directly connected serial 0/1
C 192.168.1.0 directly connected fastethernet 0/0

Konfigurasi Cisco Router 10


R Î Routing RIP
C Î Directly Connected

(Untuk Router 1)
R 172.16.1.0/30 via 172.16.0.1 serial 0/0
R 192.168.1.0/24 via 172.16.0.1 serial 0/0
R 192.168.2.0/24 via 172.16.0.1 serial 0/0
C 172.16.0.0 directly connected serial 0/0
C 10.0.0/24 directly connected fastethernet 0/0
C 10.0.1.0/24 directly connected fastethernet 0/1

(Untuk Router 2 silakan dicari sendiri)

b) Routing EIGRP (Enhanced Interior Gateway Routing Protocol)


Langkah-langkah :
1. Menciptakan rute dengan model EIGRP
router eigrp <autonomous system number> Æ pada priviledged mode
network <IP network> <wildcard-mask> Æ pada Global Configuration mode
write mem Æ -“-
2. Melihat semua rute ke masing-masing router yang lain
show ip route Æ pada priviledged mode
Contoh : dari konfigurasi gambar 1
- Menciptakan rute dengan model rip di masing-masing router

Router 0 :
Router#router eigrp 100
Router(config-router)#network 172.16.1.0 0 0.0.3 Network yang langsung
Router(config-router)#network 172.16.0.0 0.0.0.3 terhubung dengan router 0
Router(config-router)#network 192.168.1.0 0.0.0.255

Router 1 :
Router#router eigrp 100
Router(config-router)#network 172.16.0.0 0 0.0.3 Network yang langsung
Router(config-router)#network 10.0.0.0 0.0.0.255 terhubung dengan router 1
Router(config-router)#network 10.0.1.0 0.0.0.255

Router 2 :
Router#router eigrp 100 Network yang langsung
Router(config-router)#network 172.16.1.0 0.0.0.3 terhubung dengan router 2
Router(config-router)#network 192.168.2.0 0.0.0.255

- Melihat seluruh konfigurasi rute pada router (menuju jaringan yang tidak
terhubung langsung dengan router)

Router#show ip route

Konfigurasi Cisco Router 11


Akan ditampilkan :
(Untuk Router 0)
D 192.168.2.0/24 via 172.16.1.1 serial 0/0
D 10.0.0.0/24 via 172.16.0.2 serial 0/1
D 10.0.1.0/24 via 172.16.0.2 serial 0/1
C 172.16.1.0 directly connected serial 0/0
C 172.16.0.0 directly connected serial 0/1
C 192.168.1.0 directly connected fastethernet 0/0

D Î Routing EIGRP

c) Routing OSPF (Open Shortest Path First)


Menciptakan Routing dengan model OSPF
router ospf <process id>
network <ip network>

- Perintah untuk melihat Route dari terminal pengirim ke terminal tujuan :


Router#traceroute <ip tujuan>

(akan ditunjukkan rute melalui jaringan mana saja sampai ke tempat tujuan)

diambil dari :
1. Catatan ppt-nya Pak Amang
2. Petunjuk praktikum Jarkom D4-LJ
3. catatan pelatihan Cisco Router Agustus kemarin

Konfigurasi Cisco Router 12