Anda di halaman 1dari 11

BELAJAR MENGKONFIGURASI

ROUTER DENGAN IS-IS ROUTING PROTOCOL


By:Daywalker@cnc-108
http://www.ittelkom.ac.id/pinguin
http://iwing.wordpress.com

Ketika saya belajar jaringan computer, saya menemukan suatu bagan seperti gambar
(1 ) dibawah ini.

Gambar 1

Pikiran saya langsung tertuju pada suatu link-state protocols yaitu IS-IS, aneh
kedengarannya dan tidak familiar dengan apa yang telah saya pelajari, RIP,IGRP,EIGRP,
OSPF, BGP pernah saya dengar, tapi IS-IS masih menjadi suatu misteri dan suatu tanda
tanya besar bagi saya hi3. Akhirnya saya memutuskan mencari tau dan bertanya pada mbah
google. Nah sedikit apa yang telah saya pelajari dari mbah google dan dari resource lainnya
saya review dibawah sebagai catatan pribadi pada khususnya, maaf kalau bahasa yang
dipergunakan amburadul dan campur aduk dengan bahasa londo2 hi3.
1. IS-IS
IS-IS merupakan salah satu routing protocol yang diciptakan untuk OSI model
,menggunakan metode link state sebagai metode pengumpulan rutenya, selain IS-IS, juga
ada routing protocol yang mempergunakan metode link state yaitu OSPF, kedua routing
protocol ini selain sama-sama menggunakan metode link state, juga menggunakan algoritma
Shortest Path First (algoritma Djikstra) dalam melakukan perhitungannya, keduanya
menggunakan konsep hierarki, system area dan banyak lagi.

Tabel 1

Tabel 1 diatas menunjukkan perbedaan istilah antara IS-IS dengan OSPF.


Gambar 2

Nah sekarang di review sedikit perbedaan antara OSPF dengan IS-IS


a) OSPF
Interfaces belong to areas
All areas tie to backbone area (area 0)
Support more area types
Support a metric scaled by default
Supported by more vendors
Is well understood by the majority of the industry
b) IS-IS
Router belong to area
Handles updates more efficiently
Much faster (by default) to detect failures and converge
Rarely runs the SPF algorithm, prefers using partial route calculation
2. SISTEM PENGALAMATAN
Seperti yang telah disinggung sebelumnya IS-IS merupakan routing protocol yang
diciptakan oleh OSI, OSI menggunakan connectionless network protocol (CLNP) address,
dan ketika CLNP address digunakan di router maka disebut dengan Network Service
Access Point (NSAP) dan NSAP ini yang digunakan dalam system pengalamatan di IS-IS.
NSAP ini memiliki panjang yang bervariasi mulai dari 0 oktet sampai dengan 20 oktet.

Nah karena saya nanti saya mau simulasi menggunakan produk cisco, maka dalam
pengalamatan IS-IS nya hanya menggunakan 3 field saja yaitu :
The area Address
The system ID
The NSAP selector (NSEL)

Aturannya adalah sebagai berikut, NSAP address nilainya bervariasi sampai dengan 20
bytes, byte address terakhir dari NSAP yaitu NSEL nilainya adalah 00, 00 ini menandakan
sebuah IS (Intermediate system=Router) dan system ID nilainya adalah tetap yaitu 6
bytes.

Contoh pengalamatan 49.0001.xxxx.yyyy.zzzz.00 (untuk memudahkan pembacaannya,


pembacaan dari kiri ke kanan), 00 menandakan IS, xxxx.yyyy.zzzz menandakan system ID,
0001 menandakan area dan nilai 49 menandakan Private, 49 merupakan nilai field dari AFI
(Authority and Format Identification)
3. STRUKTUR HIRARKI PENGALAMATAN
Untuk membedakan router mana yang merupakan router backbone area dan yang mana
router non backbone area (lihat table 1 dan gambar 2 sebagai referansi), IS-IS
menggunakan konsep tipe router. Tipe-tipe router dalam IS-IS dibagi menjadi :
Router Level-1
Router tipe ini hanya bisa berkomunikasi dengan router dalam area yang sama.
Router Level-2
Router ini dapat berkomunikasi dengan router dalam area yang berbeda, router
ini termasuk dalam backbone area router
Router Level 1-2, Router dengan tipe level ini seolah-olah memiliki dua router
dalam satu perangkat, memiliki kemampuan level-1 dan kemampuan level-2.

4. Contoh Simulasi Konfigurasi


5. Konfigurasi lengkapnya
Konfigurasi di Router CNC-1

cnc1>ena
cnc1#sh run
Building configuration...
!
hostname cnc1
ip cef
!
interface Loopback0
ip address 192.168.10.1 255.255.255.0
ip router isis
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/0.102 point-to-point
ip address 192.168.128.1 255.255.255.0
ip router isis
frame-relay interface-dlci 102
!
interface Serial0/0.103 point-to-point
ip address 192.168.192.1 255.255.255.0
ip router isis
frame-relay interface-dlci 103
!
router isis
net 49.0001.1111.1111.1111.00
!
end

cnc1#
Konfigurasi di Router CNC-2

cnc2#sh run
Building configuration...
!
hostname cnc2
!
interface Loopback0
ip address 192.168.20.1 255.255.255.0
ip router isis
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/0.201 point-to-point
ip address 192.168.128.2 255.255.255.0
ip router isis
frame-relay interface-dlci 201

!
router isis
net 49.0001.2222.2222.2222.00
!
end

cnc2#

Konfigurasi di Router CNC-3

cnc3#sh run
Building configuration...
!
hostname cnc3
!
interface Loopback0
ip address 192.168.30.1 255.255.255.0
ip router isis
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/0.301 point-to-point
ip address 192.168.192.2 255.255.255.0
ip router isis
frame-relay interface-dlci 301
!
router isis
net 49.0001.3333.3333.3333.00
!
end

cnc3#

Konfigurasi Frame Relay Switches (FRS)

FCS#sh run
Building configuration...
!
hostname FCS
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 128000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 128000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 128000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
!
end

FCS#

Pengecekan dengan ping utility


Sh ip topology

Perlu diingat bahwa nilai metric dari IS-IS bukan berdasarkan bandwidth akan tetapi nilai
dari 0 sampai 63 dan 10 adalah default nya, jadi metric dari cnc2 ke cnc3 adalah 20, perlu
diingat jika nilai ini hanya dipasang default, sepertinya kinerja dari IS-IS akan tidak
optimal, tak ubahnya seperti protocol distance vector.

Sh clns neighbors detail

Dengan perintah ini kita bisa melihat area address, SNPA (Show Network Point
Attachment), type dari jenis level router, protocol yang dipergunakan.
Show ip route

Referensi:

http://www.cisco.com
http://www.gns3.net
Majalah PC media (02/05) tulisan Hayri hal 70-74